fedora-meeting
LOGS
15:00:19 <adamw> #startmeeting BugZappers meeting 2010-03-30
15:00:19 <zodbot> Meeting started Tue Mar 30 15:00:19 2010 UTC.  The chair is adamw. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:20 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:00:28 <adamw> #topic roll call
15:00:31 * Tech33 is here
15:00:33 <adamw> morning everyone...who's here?
15:02:13 <adamw> ...bueller?
15:02:27 <Tech33> oh come on, there are more people here than adam and me :)
15:02:46 * etank is here
15:03:00 <adamw> mcepl: oy
15:03:36 <Tech33> hmm, ok, I move to adjourn the meeting until people give a darn :p
15:03:54 <mcepl> hoy
15:04:13 <adamw> so, four people who give a damn
15:04:14 * SMParrish here'
15:04:17 <adamw> that's enough for a short meeting
15:04:21 <adamw> ooh, 5! we're steaming
15:04:37 * mbuf is here
15:04:56 <Tech33> waltJ_: would be here except he said he has a conflct
15:05:02 <adamw> alright, we have a short agenda today. my normal reminder: if you want to discuss something at the meeting, you can add it to the list at https://fedoraproject.org/wiki/BugZappers:meeting-agenda-list
15:05:09 <adamw> any time during the week
15:05:14 <adamw> it'll get picked up for the meeting agenda.
15:05:16 <adamw> okay
15:05:19 <adamw> #topic follow-up
15:05:42 <adamw> there's only one thing for follow-up from last week's meeting: adamw to test btrfs-progs installation when creating a btrfs partition in installer
15:06:01 <adamw> follow-up is simple - i didn't need to test, in the end, as anaconda team reproduced and realized where the bug was and fixed it.
15:06:05 <adamw> so, ponies
15:06:24 <adamw> anyone have any other concerns arising out of last week's meeting?
15:07:49 <adamw> alrighty then, moving on
15:07:51 <mcepl> -1
15:07:51 <adamw> #topic open floor
15:08:04 * mcepl observes this to be really short meeting ;)
15:08:06 <adamw> ...and that's as far as we have to move :) no other business, so let's open it up
15:08:21 <adamw> who'd like to discuss something related to bugzappers? or, y'know, their aching back? we've got the time
15:08:25 <mbuf> ?
15:08:37 <adamw> mbuf: told you it was a short agenda :)
15:08:37 <etank> is it possible that we could have a class for new zappers?
15:08:54 <mbuf> adamw, I have couple of questions
15:09:08 <adamw> etank: possible, yup. good idea, probably. someone would have to want to organize and run it, though
15:09:11 <Tech33> I was going to press for a series of short (5-10 min) 'classes' on various topics for bz'ers, but if attendance is low it might not be worth the time/effort
15:09:17 <adamw> mbuf: after etank's idea
15:09:20 <etank> a simple walk through with some real life examples
15:09:23 <adamw> #topic classes for bugzappers
15:09:51 <adamw> etank: we sometimes do something much like that, but informal, for new zappers who come to the chan and ask for help
15:09:52 <mcepl> adamw: if somebody else organize it, I am willing to answer any questions anybody asks
15:09:57 <adamw> so yeah, it's certainly possible
15:09:58 <Tech33> ouch sorry, etank hit it first
15:10:06 <adamw> Tech33: great minds think alike :)
15:10:23 <Tech33> I have a couple ideas for mayyyybe three classes
15:10:50 <etank> i have looked through the "components and triagers" page and nothing really jumped out at me. what is a good area for new people to jump in on?
15:10:52 <Tech33> and I'm (god I hate volunteering) am willing to make a script for them
15:10:54 <adamw> we could perhaps make it flexible - each time we hit, say, 5 new bugzappers since the last class, ask those 5 if they'd like to attend a class? just thinking out loud.
15:11:11 <adamw> etank: we're talking about your first idea still :) we can answer that in a bit
15:11:25 <mbuf> adamw, etank question was my first question; but, just instead of an IRC discussion with logs, would it be possible to make a screencast that we can refer newbies to, in getting them introduced to bug zapping, or atleast using bugzilla?
15:11:29 <etank> adamw: that was kind of related to the first question actually
15:11:45 <adamw> mbuf: again, certainly possible
15:11:54 <adamw> it's worth noting there's an Official Fedora Thing for running classes
15:12:04 <Tech33> where
15:12:07 <adamw> #url http://fedoraproject.org/wiki/Communicate/IRC/Classroom
15:12:15 <adamw> there may be resources for recording associated with that
15:12:27 <mbuf> adamw, I see this here, https://fedoraproject.org/wiki/BugZappers; for each of the tools and procedures if a screencast could be made, it would be extremely helpful;
15:13:01 <mcepl> +1 ... and again if somebody organizes I am willing to give a tutorial about my scripts
15:13:07 <mbuf> adamw, or if experienced bug zappers atleast do a recording of one of the bugs that they have handled or solved, it will be awesome
15:13:11 <adamw> mbuf: like an example to go with the walk-through instructions? that's another good idea - doesn't necessarily need to go along with the class idea
15:13:21 <mbuf> adamw, exactly
15:13:36 <adamw> okay, let me note that down so we don't lose it
15:13:54 <adamw> #idea mbuf suggests recording screencasts to go along with the wiki instructions
15:14:09 <mbuf> adamw, I try to work with students, and I feel bug zapping is a good way for them to get started with the Fedora project
15:14:09 * etank needs a way to find the "low hanging fruit" to get his feet wet
15:14:25 <adamw> so i think both of those are certainly good ideas if anyone's willing to give them a push...i'm not sure i can commit to it right now, my todo list is growing :/
15:14:36 <adamw> mbuf: it certainly can be, yes
15:14:52 <adamw> anyone here willing to take point on either of those ideas? if not, we can forward them to the list and see...
15:16:11 <Tech33> I don't know about screencasts, but I'd like to do an IRC class, so I'll read up the page and maybe offer up a class
15:16:37 <Tech33> an hour is a long time, but maybe not once I get going
15:17:09 <adamw> you can always adjust the length to suit, but i suspect it would actually take that long
15:17:15 <mcepl> but if I would do anything, I need somebody asking questions
15:17:27 <Southern_Gentlem> irc classes are always welcome
15:17:58 <mbuf> Southern_Gentlem, indeed; these sessions can always be used to clarify answers from newbies
15:18:10 <etank> mcepl: i bet that once the class is started with a few examples that the questions will start flowing
15:19:23 <adamw> #action tech33 to look into running a test class
15:19:51 <adamw> i'll throw the screencast idea to the list to see if anyone would be interested in doing it
15:20:00 <adamw> #action adamw to pass on the screencast idea to the mailing list
15:20:20 <adamw> anything else on that topic?
15:21:37 <adamw> alright then
15:21:42 <adamw> mbuf: what was your second question?
15:22:10 <mbuf> if one has to test bugs or reproduce them on different distro releases, what is the recommended virtual machine to be used in Fedora?
15:22:28 <mbuf> *distro releases (F-11, F-12, F-13, rawhide etc.)
15:23:07 <mbuf> in other words, is there a minimal raw image that can be used as a virtual machine, and only relevant software required to reproduce the bug be installed?
15:23:14 <adamw> #topic what VM is recommended for Fedora
15:23:16 <mbuf> *on a virtual machine
15:23:18 <adamw> mbuf: the fedora virt stack is what i'd usually suggest
15:23:30 <adamw> that's qemu/kvm/libvirt/virt-manager/ponies
15:23:37 <mbuf> adamw, I see
15:23:46 <adamw> basically run virt-manager and use that. it's pretty easy-to-use these days
15:24:05 <mbuf> adamw, thanks!
15:24:09 <adamw> it's available from the repositories (unlike vmware/virtualbox) and it gets quicker support from the devs than they do.
15:24:32 <adamw> there isn't an official minimal image; i'd just work from the desktop live image for most testing
15:24:58 <adamw> you can install from the network install image and do a minimal install if you like, but minimal install is *really* minimal. you get a console and yum and not much else
15:25:05 <etank> iirc you have to be careful though because the default is to place the virtual machine disk images in /var
15:25:22 <Tech33> personally, I go a different route, but that's just me
15:25:23 <etank> this could fill up / pretty easily if /var is not on its own partition
15:25:59 <mbuf> ok, will remember that
15:27:02 <adamw> #agreed the standard virt stack for fedora is kvm/qemu/libvirt/virt-manager , but virtualbox is available from rpmfusion or upstream, and vmware from upstream, and they usually work on fedora, more or less.
15:27:28 <mcepl> I use kvm, but I guess it doesn't matter ... there is a minimal installation option for Anaconda
15:27:42 <Tech33> as a comment, I use virtualbox and put my images on a terabyte external drive, and use its snapshots feature extensively
15:28:25 <mcepl> of course, kvm/libvirt can use images anywhere
15:28:58 <mcepl> (if appropriate SELinux are applied; virtualbox doesn't even know about SElinux, so it is hardly kvm's fault ;))
15:30:00 <mbuf> ok
15:30:07 <mbuf> EOF
15:30:19 <adamw> alrighty...i think etank also wanted some advice for what package to start zapping
15:30:31 <etank> yup
15:30:40 <mcepl> Tech33: how is your situation with Gecko-related packages and ABRT?
15:31:40 <Tech33> I could still use some assistance there, I just don't have enough time to keep up with it, as it is high bandwidth ( alot of bugs)
15:32:06 <adamw> etank: if you're willing to dig into firefox bugs, tech33 needs help and could give you some instructions to get started (right tech33?)
15:32:35 <Tech33> I'd like to spend time with noveau again, but am overwhelmed just keeping up with firefox and company
15:32:50 <Tech33> yes
15:32:58 <etank> i was looking at the firefox bugs earlier. seems to be a lot of dupes there
15:33:18 <mcepl> yes, that's exactly where our help is needed
15:33:23 <adamw> Tech33: i keep meaning to go through the nouveau list, never got to it yet :)
15:33:26 <Tech33> if etank is willing, I can get with him at his convenience, as long as we're not completly opposite time zones
15:33:51 <mcepl> and of course, if you have any questions about gecko-bugs, feel free to contact me ... gecko & spol. are (among other things) my job at Red Hat.
15:33:55 <etank> Tech33: i am good with that. i am in EDT tz
15:33:57 <adamw> etank: right, abrt files a lot of firefox bugs (because lots of people use it all the time...) and its dupe detection isn't perfect, so we definitely need help weeding out those bugs
15:34:04 <etank> 11:33am here
15:34:16 <adamw> #action mcepl and tech33 to help etank get started working on the firefox bug mountain
15:34:35 <Tech33> as am i, so I'll try and schedule some time with you
15:34:41 <etank> ok
15:35:01 <adamw> thanks a lot tech33
15:35:21 * Tech33 nods
15:37:18 <adamw> so, any other topics?
15:37:25 <mcepl> Tech33: thanks
15:39:47 <adamw> if not, will close the meeting soon...
15:41:26 <Tech33> I'm good
15:41:34 <Tech33> close away :)
15:41:39 <adamw> we'll be the judges o' that! ;)
15:41:49 <Tech33> heh
15:42:17 <adamw> alright, thanks for coming everyone
15:42:30 <adamw> remember, agenda list is at https://fedoraproject.org/wiki/BugZappers:meeting-agenda-list
15:42:36 <adamw> for next week :)
15:42:38 <adamw> #endmeeting