fedora-releng
LOGS
17:59:37 <Oxf13> #startmeeting Fedora Release Engineering
17:59:38 <zodbot> Meeting started Fri Mar  5 17:59:37 2010 UTC.  The chair is Oxf13. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:59:40 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
17:59:50 <Oxf13> #meetingname fedora-releng
17:59:51 <zodbot> The meeting name has been set to 'fedora-releng'
17:59:58 <Oxf13> #topic roll call
18:00:37 <Oxf13> ping: notting jwb lmacken poelcat rdieter_work dgilmore spot wwoods
18:00:56 * jwb 
18:01:06 * notting is here
18:01:30 * dgilmore 
18:02:57 <Oxf13> light crew today
18:03:14 <Oxf13> #info present are Oxf13 jwb notting dgilmore
18:04:43 * poelcat 
18:05:58 * nirik lurks
18:06:50 <Oxf13> #info poelcat and nirik also present
18:07:12 <Oxf13> #topic Old Business (SOPs)
18:08:03 <jwb> the f-d-l thread of doom consumed my time to do the updates SOP last week
18:08:13 <jwb> and now i have something i need to get done for the board this afternoon
18:08:23 <Oxf13> ok
18:08:30 <Oxf13> I submitted a very short SOP to poelcat just before the meeting
18:08:37 <Oxf13> for updating bugzilla verisons
18:08:51 <Oxf13> I have a few more scattered in gnotes that require some level of detail
18:08:59 * poelcat hasn't seen it yet
18:09:03 <poelcat> will look
18:09:36 <Oxf13> #info one (small) SOP delivered late late late this week by Oxf13
18:10:02 <poelcat> i have something on that here too https://fedoraproject.org/wiki/BugZappers/HouseKeeping/DayBeforeRelease
18:10:25 <poelcat> naturally the timing needs to be changed
18:13:01 <Oxf13> Sorry, I'm a bit distracted today.
18:13:25 <Oxf13> anything else on SOPs?
18:13:34 <poelcat> which one are we doing next week?
18:14:09 <Oxf13> I could submit Updating Comps
18:14:17 <Oxf13> after I give it some more details.  It's rather... terse right now
18:14:26 * wwoods lurks
18:14:35 <Oxf13> #info wwoods also in attendance
18:15:09 <dgilmore> Oxf13: updating comps in what sense?
18:15:19 <notting> Oxf13: i was trying to move 'updating comps' out of the releng responsibilities
18:15:24 <notting> (see mether's ticket this week)
18:15:58 * dgilmore has always thought that it was the maintainers responsobility to add their own package to comps
18:16:28 <Oxf13> updating comps as in creating the new comps file for the new release
18:16:37 <dgilmore> ahh ok
18:16:42 <Oxf13> not as in making additions/removals to the comps content
18:16:43 <notting> oh. so it's expectedly terse :)
18:17:03 <Oxf13> right
18:17:26 <Oxf13> so far my SOP is 4 lines, with things like "check out comps; edit Makefile; commit"
18:19:10 <notting> Oxf13: let's postpone that one, i think we can handle that with a topic i'd like to mention later
18:19:27 <Oxf13> ok
18:19:43 <Oxf13> if I skip that one, then I have one for updating the Package Announce topic list
18:22:19 <Oxf13> anything else?
18:23:17 <Oxf13> #action Oxf13 to submit SOP on updating Package Announce topics next week
18:23:36 <Oxf13> #topic Old Business (/mnt/koji storage)
18:23:42 <Oxf13> dgilmore: got an update for us?
18:24:59 <dgilmore> Oxf13: we have still been testing
18:25:13 <dgilmore> not really alot
18:25:37 <dgilmore> We will need to schedule a weekend of downtime to do some final validation and switchover
18:27:32 <dgilmore> mmcgrath has been doing some mash profiling
18:29:38 <Oxf13> #info still testing, doing some mash profiling
18:30:46 <Oxf13> ok, lets move on
18:31:02 <Oxf13> #topic Old Business (dist-git update)
18:31:09 <Oxf13> I got nothing here
18:31:19 <Oxf13> dgilmore: you were working on a push of fedora-packager ?
18:32:59 <tomspur> Oxf13, isn't GitPython missing for that?
18:33:14 <Oxf13> tomspur: I've done GitPython builds for EL-5, F-12, F-13, and rawhide
18:33:35 <tomspur> ah ok, only searched for updates...
18:34:03 <dgilmore> Oxf13: yep
18:34:10 <dgilmore> i pushed out 0.4.0 to testing
18:34:16 <dgilmore> i have some bugs to fix
18:34:35 <dgilmore> and ill push out another update today
18:34:56 <Oxf13> #info fedora-packager (test) updates going out, which include fedpkg
18:37:45 <Oxf13> moving on
18:38:10 <Oxf13> #topic Old Business (ticket 3420)
18:38:14 <Oxf13> .rel 3420
18:38:16 <zodbot> Oxf13: #3420 (Request new compose image for translators' review) - Fedora Release Engineering - Trac - https://fedorahosted.org/rel-eng/ticket/3420
18:38:41 <Oxf13> I spoke some more with the ticket filer, and they can just use the nightly image and do a pk update to things in updates-testing as well as use pk to install anything missing
18:38:50 <Oxf13> so I'll just hardlink today's nightly image (if it works)
18:39:01 <Oxf13> nirik: did we get a desktop nightly image last night?
18:39:09 <nirik> Oxf13: yep.
18:39:22 <nirik> http://alt.fedoraproject.org/pub/alt/nightly-composes/desktop/
18:39:23 <Oxf13> any feedback on it yet?
18:39:28 <nirik> not that I know of.
18:40:55 <Oxf13> well, I'll make a link to it anyway and see how it goes
18:41:14 <Oxf13> #action Oxf13 will make a hardlink to the nightly desktop image and update ticket 3420 with the location
18:41:59 <Oxf13> #topic Old Business (13 Alpha)
18:42:10 <Oxf13> 13-alpha is a go, and I've got bits staged for mirrors
18:42:16 <Oxf13> #info bits are staged for mirrors
18:42:24 <notting> hip hip hooray!
18:42:26 <Oxf13> I just have to fix a permission issue or two and I'll release it to mirrors today
18:42:34 <Oxf13> #action Oxf13 to release bits for mirrors today
18:42:44 <Oxf13> on to the next grind
18:42:50 <Oxf13> anything else on Alpha?
18:44:47 <nirik> Oxf13: do you want torrent seeders?
18:45:06 <Oxf13> ah, yes torrent
18:45:19 <Oxf13> so... the content on alt. (and serverbeach1) isn't exactly in torrent format
18:45:24 * dgilmore doesnt have much torrenting capacity with new host
18:45:28 <Oxf13> which makes it somewhat harder to get seeding
18:46:17 * nirik is happy to seed if he can get content and torrent files.
18:47:12 <Oxf13> nirik: I'll see what I can do, probably Monday
18:47:17 <Oxf13> I'm hoping to take this afternoon off
18:47:29 <nirik> ok, no worries, just let me know if I can help.
18:47:35 <Oxf13> and one shouldn't play with files when on a bender.
18:48:26 <Oxf13> alright that ends the old business
18:48:36 <Oxf13> .... I have no new business because my brain is fried
18:48:41 <Oxf13> #topic Open Floor
18:48:50 <notting> ok
18:49:00 <notting> i sent mail to devel@ a while back about moving comps to git
18:49:10 <notting> now that alpha's done, i'd like to pick a time and do this
18:49:18 <Oxf13> #topic comps into git
18:49:31 <notting> as part of that, i can do the updating of the previously referenced SOP
18:49:42 <Oxf13> notting: since you volunteered to fix all the automated things that use comps, I'm fine with that.
18:49:56 <notting> any time work better or worse for people here?
18:51:14 * dgilmore doesnt mind
18:51:32 <dgilmore> though ill need to fix up some secondary arch scripts
18:51:38 <dgilmore> which reminds me
18:51:58 <Oxf13> notting: no time issues here
18:52:00 <dgilmore> would anyone object to me making a branch in releng git for secondary arches?
18:52:15 <notting> ok, i'll shoot for next thursday
18:52:30 <notting> #info notting will move comps to git on Thursday, March 11
18:52:45 <notting> #info notting will adjust things where necessary, and inform FESCo
18:53:01 <Oxf13> woo
18:53:37 <notting> #info notting will at least leave the CVS copy around in r/o mode for a while
18:55:36 <notting> dgilmore: no objections here
18:55:47 <Oxf13> dgilmore: I don't mind
18:56:07 <dgilmore> cool
18:56:20 <dgilmore> it will help make it more trasnparent i hope
18:58:46 <Oxf13> anything else today?
18:59:27 <Oxf13> looks like a no
18:59:31 <Oxf13> thanks all!
18:59:34 <Oxf13> #endmeeting