fedora-meeting
LOGS
15:04:22 <tk009> #startmeeting bugzappers
15:04:22 <zodbot> Meeting started Tue Feb 23 15:04:22 2010 UTC.  The chair is tk009. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:04:23 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:04:31 <tk009> #chair adamw
15:04:31 <zodbot> Current chairs: adamw tk009
15:04:40 * adamw kicks it
15:04:44 <tk009> hehe
15:05:09 <tk009> kk sound off if you are here for the bugzappers meeting (please)
15:05:32 <tk009> it better not be just us
15:05:44 * iarlyy here, hi all
15:05:54 <tk009> hi iarlyy
15:06:19 * waltJ is here.
15:06:42 <tk009> hello waltj
15:07:35 <tk009> I'll give two minutes then start
15:08:16 <tk009> I was hoping we'd get more for these topics
15:09:14 <tk009> kk first up
15:09:34 <tk009> #topic discuss jon stanley's suggestions
15:09:38 <adamw> people might appear out of the woodwork
15:09:43 <adamw> jds2001: pingle
15:09:47 <tk009> #link http://lists.fedoraproject.org/pipermail/test/2010-February/088644.html
15:09:54 <Oxf13> I'm watching from the peanut gallery
15:09:58 <tk009> =)
15:10:27 * adamw has never understood why some people find looking at peanuts so interesting
15:10:38 <tk009> I there we are getting what we need from fedora as far as resources go.
15:10:45 <tk009> its the arouma
15:10:49 <Oxf13> soo many different shapes and sizes
15:10:58 <adamw> yeah, i couldn't immediately think of anything we need
15:11:17 <tk009> we need what everyone else needs
15:11:21 <tk009> mentors
15:11:24 <tk009> more time
15:11:31 <adamw> although in terms of 'resources' we could talk about stuff like if bugzilla is set up in the best way, and maybe help from infrastructure for the statistics stuff?
15:11:33 <tk009> I think we have the people now
15:11:46 <tk009> yes
15:12:02 <tk009> I thought soething was in the works on the metrics
15:12:18 <tk009> I know comphappy bolgged about working on it again
15:12:36 <tk009> but I've not seen hide nor hair since
15:12:47 * mcepl is here
15:12:55 <tk009> welcome brother
15:13:11 <adamw> as i said last i heard from comphappy was at fudcon
15:13:21 <adamw> where he was talking with the fedora community group about doing stats in that
15:13:26 <adamw> but i don't know anything since then
15:13:32 <tk009> he blogged about starting on the metrics again about two weeks ago
15:13:37 <adamw> ah, missed that
15:13:43 <mcepl> well, that's I think much more interesting question ... plenty of our infrastructure seems to depend on him
15:13:44 <adamw> unfortunately we never found anyone else to work on it i think...
15:13:48 <adamw> mcepl: ^^^
15:13:58 <adamw> there just hasn't been anyone else who's volunteered to work on the stats stuff
15:14:09 <adamw> it's easy to criticise comphappy but we'd be no FURTHER along without him, heh
15:14:27 <mcepl> well, I was more interested in administration of fedorahosted.org triage part, for example
15:14:59 * mcepl has to admit to the terrible heresy ... he doesn't care much about statistics
15:15:00 <tk009> do you not have admin on that mcepl?
15:15:09 <mcepl> unfortunately, no
15:15:24 <tk009> that should be changed then yes?
15:15:55 <mcepl> OK, gimme action item
15:16:04 <tk009> #chair mcepl
15:16:05 <zodbot> Current chairs: adamw mcepl tk009
15:16:07 <tk009> =)
15:16:15 <mcepl> no I meant
15:16:31 <mcepl> #action mcepl to take over fedorahosted/triage
15:16:49 * mcepl goes to talk with zodbot privately
15:17:50 <tk009> the thing I found hard is the interaction with bugzilla grabbing the info from the outside is not a good way to do it
15:18:12 <tk009> you'd think someone already thought of this and had something set up
15:18:28 <adamw> we couldn't really find anything when we looked
15:18:45 <adamw> you've seen bugzilla's internal stats stuff right? i posted it up in a meeting a few weeks back
15:19:24 <tk009> I remember the mention but I dont recall looking at it, do you still have the link
15:20:15 <tk009> #action tk009 email comphappy on metrics status
15:20:22 <adamw> just lemme find it
15:20:48 <tk009> did anyone else want to add to this topic
15:21:18 <adamw> can't think of much
15:21:45 <tk009> I have some but its best as reply to the email.
15:21:55 <tk009> kk we'll move on then
15:21:59 <tk009> one sec
15:22:38 <adamw> #link https://bugzilla.redhat.com/browse.cgi
15:24:03 <tk009> back sorry about that
15:24:24 <tk009> #topic discuss what to do with rawhide bugs now f13 has branched
15:24:55 <adamw> so yeah, this is a bit sticky
15:25:02 <tk009> did everyone see 0xf13's email on this?
15:25:10 <adamw> let's go over it quickly just in case
15:25:16 <iarlyy> interesting this topic... yesterday we had some questions about how to close a bug against fedora 13
15:25:18 <adamw> we've changed the development process from f13 on
15:26:07 <adamw> previously, the next release would be developed in rawhide and only branch from it just before release. around then we'd rebase all 'rawhide' bugs to be 'nextrelease' bugs instead. nice and simple
15:26:26 <adamw> now we've branched 'nextrelease' (f13) very early, and rawhide continues with a distinct identity - it's working towards f14
15:26:55 <adamw> now the question is, what do we do with bugs filed against rawhide between the release of f12 and now?
15:27:00 <iarlyy> adamw, I knew by this way
15:27:00 <tk009> should we think about re-defining nextrelease?
15:27:03 <adamw> do we rebase them to be f13 bugs, or leave them as rawhide?
15:27:27 <adamw> i'd come down on the side of making them f13 bugs
15:27:31 <adamw> but it's a tricky call
15:27:40 <tk009> what does bodhi close them as?
15:27:51 <tk009> off the top of my head I dont know
15:28:44 <iarlyy> all rawhide bugs still as rawhide, ins't? when rebase will happen?
15:29:05 <adamw> bodhi isn't much of a canonical reference, what it's doing know will be basically random
15:29:21 <adamw> iarlyy: we haven't changed anything yet, because we hadn't decided what to do yet
15:29:24 <adamw> s/know/now/
15:29:47 <adamw> i'd rather worry about what we do with open bugs than how we close them, though
15:29:58 <adamw> resolutions aren't frankly that important, especially as long as we don't have statistics
15:30:14 <tk009> what are your thoughts on open bugs
15:30:20 <iarlyy> adamw, I'm worried about too
15:30:50 <adamw> tk009: as I said, i'd say to move current open rawhide bugs to f13
15:31:46 <iarlyy> tk009, same happened after releases, yep?
15:32:04 <iarlyy> s/after/before/
15:32:33 <tk009> is that soething we'd was to autoagically do?
15:32:42 <tk009> s/was/want
15:32:42 <adamw> it's covered in the bugzappers housekeeping
15:32:47 <adamw> but that's different
15:33:18 <adamw> under the previous system it was clearer what was 'correct', because rawhide and 'nextrelease' never differed
15:33:40 <adamw> we never had a situation where f12 and f13 were simultaneously under development, really
15:34:27 <adamw> now it's not clear whether we should assume all bugs filed on rawhide before the branch should be considered f13 bugs, or remain as rawhide bugs
15:34:28 <Oxf13> you mean f13 and f14
15:34:31 <iarlyy> actually f13 in development and f14 same time
15:34:33 <adamw> no, i mean f12 and f13
15:34:43 <adamw> Oxf13: right now we have f13 and f14 in development simultaneously
15:34:45 <adamw> which is the new bit
15:34:48 <Oxf13> right
15:34:56 <Oxf13> we've never had two releases in develoipment simultaneously
15:35:01 <adamw> before, we *didn't* have f12 and f13 in development simultaneously.
15:35:16 <tk009> how long would you say we have to figure this out? I need to get my head around this and I am distracted atm and not uch help
15:35:45 <adamw> erf, it'd be nice to do it soon
15:35:54 <adamw> it's just a 'which way to jump' call, really, not a complex operation
15:36:03 <tk009> I can work on this today and colaberate with you
15:36:13 <tk009> I have inspectors at the house right now
15:36:17 <adamw> well we can't 'work on' it until we decide what to do
15:36:25 <adamw> if we leave them as rawhide bugs, there's nothing to do
15:36:36 <adamw> if we make them f13 bugs, it's a pretty simple operation in the database i believe
15:36:42 <adamw> it's just a question of making a call about which to do
15:37:09 <adamw> again, i'd vote to make them f13 bugs; does anyone want to argue for leaving them as rawhide bugs?
15:37:12 <tk009> but as you said how do we know some of those are not f14 bugs
15:37:21 <iarlyy> I don't understand, if I enable rawhide now, what updates will I get?
15:37:26 <iarlyy> f13 ou f14 updates?
15:37:33 <adamw> iarlyy: stuff tracked for f14.
15:37:44 <tk009> rawhide is f14 atm iarlyy
15:37:51 <adamw> iarlyy: if you want to follow f13 you need to have a fedora-release package versioned 13, and enable the 'fedora' and 'updates' and 'updates-testing' repos, and disable rawhide.
15:38:19 <adamw> tk009: some of them probably will be stuff the developers would prefer to target for f14, yup.
15:38:25 <iarlyy> as our bugs is based on our rpm packages versions, so rawhide now is f14 and f13 should be created on bz and all bugs rebased, isn't?
15:38:27 <adamw> tk009: but then, some of them will be targeted for f13.
15:38:35 <adamw> tk009: my feel is *more* are likely to be f13 stuff than f14 stuf.f
15:38:42 <tk009> it will hurt less if we do it now
15:38:47 <adamw> since we can't make an individual judgment on every bug, i'd argue just to go with the majority.
15:39:06 <adamw> iarlyy: 13 is already in bugzilla, but we're making the decision about whether to rebase or not now. :)
15:39:18 <adamw> the problem is that some of the bugs will be f13 stuff, and some will be f14 stuff, most likely.
15:39:19 <tk009> kk +1 rebase to f13
15:39:36 <tk009> we will just have to take the heat on that and deal wit hit
15:39:49 <adamw> we can explain the situation in the comment
15:40:03 <adamw> and make sure it says that it's fine to change it back to rawhide if that's more appropriate
15:41:17 <tk009> so do we need poelcat to request this? he is the only one that can I believe
15:41:43 <adamw> i'm not sure how the rebase is usually done, i guess we go through dkl to do it directly in the bz database to avoid a big email spam
15:41:52 <adamw> i can take an action item to check with poelcat and dkl about it
15:42:10 <tk009> #action check with poelcat and dkl  about
15:42:14 <tk009> grrr
15:42:28 <tk009> #action check with poelcat and dkl  about rebase to f13
15:42:42 <tk009> bah I will get it right eventualy
15:43:00 <tk009> #action adamw to check with poelcat and dkl  about rebase to f13
15:43:13 <tk009> okay any more on this one?
15:43:30 <iarlyy> tk009, the actions was added?
15:43:34 <adamw> well, there's the resolution question, but as i said i'm not losing much sleep over that
15:43:49 <iarlyy> normally zodbod confirms action
15:43:50 <adamw> i'd say just go with ERRATA as it follows practice for finished releases
15:43:59 <adamw> iarlyy: i don't think so?
15:44:11 <tk009> I will fix it if it doesn't iarlyy
15:44:16 <Oxf13> adamw: I'm OK with that, since that's what bodhi is doing automatically
15:45:11 <tk009> do we need to changes the wiki for that?
15:45:23 <adamw> yeah, we can explain it explicitly there
15:45:23 <adamw> i
15:45:27 <adamw> i'll update the page later
15:45:32 <tk009> kk
15:45:56 <adamw> #action adamw to update lifecycle page
15:46:10 <tk009> meetbot is sleeping maybe
15:46:27 <adamw> i don't remember meetbot confirming action items?
15:47:11 <tk009> no biggie if it didnt
15:47:25 <tk009> well that is it for the topics
15:47:34 <tk009> #topic Open Floor
15:48:00 <mcepl> adamw: do you know what other resources (aside from fedorahosted hosting) we should be managing and we don't?
15:48:19 <adamw> not a frickin' clue
15:48:40 <tk009> mcepl: aybe ask jds2001
15:48:49 <mcepl> jds2001: ^^^^
15:49:27 <tk009> hosted is all I know about
15:49:29 <mcepl> anyway, that's it from me (I don't want to held meeting waiting on jds2001)
15:49:49 <tk009> kk does anyone have something else
15:49:57 <adamw> yeah i don't have anything
15:50:08 <tk009> waltj iarlyy
15:50:17 <waltJ> nothing.
15:50:35 <tk009> closing in 2
15:50:47 <iarlyy> nothing
15:51:11 <tk009> kk thank all and thanks adamw for doing the agenda
15:51:17 <tk009> I will do the recap
15:51:24 <tk009> #endmeeting