fesco
LOGS
20:00:03 <nirik> #startmeeting FESCO (2010-02-16)
20:00:03 <zodbot> Meeting started Tue Feb 16 20:00:03 2010 UTC.  The chair is nirik. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:00:03 <nirik> #meetingname fesco
20:00:03 <nirik> #chair dgilmore notting nirik skvidal Kevin_Kofler ajax pjones cwickert mjg59
20:00:03 <nirik> #topic init process
20:00:04 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
20:00:07 <zodbot> The meeting name has been set to 'fesco'
20:00:09 <zodbot> Current chairs: Kevin_Kofler ajax cwickert dgilmore mjg59 nirik notting pjones skvidal
20:00:19 <nirik> Who all is around for the FESCo meeting?
20:00:22 * skvidal is
20:00:34 <pjones> I'm here, but I expect to get pulled away several times during this meeting.
20:00:42 <Kevin_Kofler> Present.
20:00:44 <pjones> (my grandmother just died)
20:00:51 <dgilmore> pjones: sorry to hear
20:00:56 <nirik> pjones: :( my condolances.
20:00:57 <pjones> yeah, me too.
20:00:59 * dgilmore is hear for ~ 30mins
20:01:07 <mjg59> Hi
20:01:12 <ajax> hello there
20:01:15 <dgilmore> here even
20:01:19 <Kevin_Kofler> pjones: Sad to hear indeed, my condolances as well.
20:01:46 <nirik> ok, hopefully a reasonably short meeting this time.
20:02:14 <Kevin_Kofler> (Grrr, the ld DSO changes you allowed into F13 by outvoting me broke 400 (!) packages at its introduction, of which 250 are still broken!)
20:02:19 * cwickert is sorry for being late
20:02:23 <nirik> #topic #314 Wordpress bundles libraries
20:02:27 <Kevin_Kofler> (What a great feature to allow in that late in the release cycle.)
20:02:45 <nirik> so FPC hasn't had a chance to meet yet on the remaining questions... so I guess we defer this again?
20:02:57 <ajax> i believe so, yeah
20:03:03 <dgilmore> nirik: yup
20:03:08 <Kevin_Kofler> Yeah, defer #314 +1.
20:03:26 <nirik> #agreed Defer another week and hear from FPC
20:03:56 <nirik> #topic #297 Please consider the idea of a security (privilege escalation) policy
20:04:00 <nirik> adamw: you around?
20:04:06 <adamw> yup
20:04:35 <mjg59> I poked various desktop people today - they've all had an opportunity to review the draft
20:04:55 <mjg59> So I'm reasonably happy that there's been adequate feedback from that perspective
20:05:01 <nirik> there was a bit of feedback on the list...
20:05:25 <mjg59> The only point of controversy I saw was one disagreement that package upgrades should be on the list
20:05:27 * nirik is still +1 as he was last week. We can adjust/expand this over time, but it would be good to have in place now.
20:05:31 <Kevin_Kofler> For me, this policy was already OK last week and still is.
20:05:40 * cwickert nods
20:05:41 <Kevin_Kofler> So +1 to approving it.
20:05:45 <cwickert> +1
20:05:53 <ajax> i think this one is close enough to be worth modifying in place rather than deferring whole anymore
20:06:13 <adamw> nirik: I've adjusted for all the feedback received on the list
20:06:14 <mjg59> Yeah
20:06:18 <mjg59> So +1 from me
20:06:27 <nirik> adamw: yeah. :) Thanks again for working on this.
20:06:28 <cwickert> mjg59, what did the desktop folks say?
20:06:40 * nirik notes we are at +4 now.
20:06:43 <cwickert> did they see any problems, e.g. the time setting
20:06:50 <mjg59> cwickert: I think walters had given some feedback in the past, nobody else seemed concerned about the current contents
20:07:07 <cwickert> ok, if they have problems they should speak up
20:07:29 <ajax> +1
20:07:36 * notting is here. sorry.
20:07:46 * cwickert still thinks setting time should require authentication, so +1 for the policy as is
20:08:14 <adamw> cwickert: just to put it on the record again, we checked in last week's meeting, and in fact system-config, KDE and GNOME all already require authentication to change the system time.
20:08:24 <cwickert> right
20:08:36 <nirik> ok, thats +5 then I think... so it passes.
20:08:44 <nirik> anyone else care to weigh in for the record?
20:08:48 <dgilmore> +1 from me also
20:09:19 <cwickert> adamw, great job
20:09:20 <notting> seems like a good start. +1
20:09:22 <adamw> thanks
20:09:31 * skvidal returns from other irc tabs
20:09:40 <nirik> #agreed the policy is Approved.
20:09:40 <skvidal> um - yes +1 ftr
20:10:16 <nirik> adamw: I guess this would move to the fesco policy page?
20:10:18 <nirik> or ?
20:10:38 <adamw> i'm not actually sure :)
20:10:49 <adamw> what's the usual process with new policies?
20:11:27 <Kevin_Kofler> Looks like we're missing a policy for policies. ;-)
20:11:36 <Kevin_Kofler> And what about a policy for policies for policies? ;-)
20:12:17 <nirik> well, we have https://fedoraproject.org/wiki/Package_maintainer_policy
20:12:35 <nirik> I guess it could have a pointer there and be it's own page, and added to the category.
20:12:43 <nirik> also, we should announce it to devel-announce.
20:12:50 * nirik can work with adamw on this after the meeting.
20:12:54 <adamw> right, that's more or less what i figured
20:13:07 <nirik> anything more on this topic? or shall we move on.
20:13:10 * adamw nominates kevin_kofler to write the policies policy
20:13:26 <cwickert> move please
20:13:26 <nirik> #topic #275 Propose a soft-path via co-maintainer status to becoming sponsored
20:13:40 <nirik> ok, so abadger1999 did some work on drafting some new pages for this.
20:13:46 <nirik> .fesco 275
20:13:47 <zodbot> nirik: #275 (Propose a soft-path via co-maintainer status to becoming sponsored) - FESCo - Trac - https://fedorahosted.org/fesco/ticket/275
20:14:02 <nirik> https://fedoraproject.org/wiki/Package_sponsor_responsibilities%28draft%29 https://fedoraproject.org/wiki/Package_maintainer_responsibilities%28draft%29
20:14:21 <nirik> basically this moves some responsibility to package maintainers from sponsors.
20:15:16 <mjg59> I have some vague concerns with the "miscellaneous items" section of https://fedoraproject.org/wiki/Package_maintainer_responsibilities%28draft%29
20:15:22 <nirik> (this is all about adding a 'anyone in packager can commit to my package' checkbox.
20:15:57 <nirik> mjg59: what concerns you there?
20:16:01 <mjg59> The "Packages should be pushed to the Rawhide branch first. If it builds and works fine for a few days, then it can be pushed to F(current)" language
20:16:24 <dgilmore> mjg59: I think we should discourgage that behaviour
20:16:29 <mjg59> But I realise that that's also present in the current guidelines
20:17:04 * dgilmore thinks we need to encourage package maintainers to push rawhide forward quickly.  but minimise change in stable releases
20:17:06 <Kevin_Kofler> I object to the "If there is a good reason to push it to F(current-1), it should be done after a few days of being in F(current)." part.
20:17:07 <mjg59> So I guess my concern is less about the actual context, but whether we want to change anything else while we're at it
20:17:12 <nirik> yeah, it's an inexact thing... and more ties in with the guidelines for updates.
20:17:17 <Kevin_Kofler> Nobody actually does that and I don't see why we should.
20:17:29 <Kevin_Kofler> Instead we all just queue the Fn and Fn-1 updates at the same time.
20:17:38 <Kevin_Kofler> Makes much more sense and makes it easier to keep track of it.
20:17:42 <dgilmore> Kevin_Kofler: and that needs to stop
20:17:44 <mjg59> Kevin_Kofler: Again, that's part of the existing guidelines
20:18:06 <Kevin_Kofler> dgilmore: I disagree very strongly.
20:18:16 <Kevin_Kofler> I think we should encourage updates more strongly, not discourage them.
20:18:16 <mjg59> Hence my question about whether we want to discuss anything else while we're at it, or purely look at these drafts in the context of the issue at hand
20:18:26 <dgilmore> Kevin_Kofler: its something we wont ever agree on.  i happen to think your wrong on this
20:18:33 <nirik> right, so if we want to revise other parts of this, perhaps we should defer another week and interested parties can work on the draft?
20:18:44 <Kevin_Kofler> The problem is the lazy/paranoid maintainers, not the ones who're doing their job properly. ;-)
20:18:45 * nirik nods at mjg59
20:18:46 * notting suggests we either change the topic, or get back to the topic
20:18:53 <mjg59> nirik: I think if we're going to bring update policy into this, it's going to take more than a week
20:18:55 <dgilmore> nirik: we shuld look at this as it is.  and come up with other changesets
20:19:15 <mjg59> So, while I do have reservations, I don't think they conflict with what we're supposed to be talking about
20:19:49 <nirik> so, looking at this as a diff of the existing pages (ie, just the changes related to this task), does anyone have any comments?
20:19:53 <ajax> yeah, i don't have a problem with the drafts that i can see
20:19:53 <abadger1999> nirik: If there's interest in changing that aswell, I can do that really quick.
20:20:17 <abadger1999> Up to you guys.
20:20:21 <ajax> abadger1999: i think there's interest but not consensus.
20:20:25 <abadger1999> k
20:20:52 <nirik> I would be ok with striking that last section in favor of linking to https://fedoraproject.org/wiki/Package_update_guidelines
20:20:56 <mjg59> I'd also expect it to be controversial to attempt to proscribe a new update policy without external conversation
20:20:58 <nirik> but thats kinda another topic.
20:21:07 <dgilmore> i think "The current ACL system does not make it easy for non-provenpackagers to apply changes to someone else's packages. Hopefully this can be addressed in the future."  should be removed from the sponsors guidelines
20:21:24 <dgilmore> all sponsors are provenpackagers
20:21:24 <mjg59> Well, this is the main issue I see
20:21:40 <mjg59> Do these guidelines match our implementation?
20:22:27 <nirik> mostly these are "Here are things we think maintainers/sponsors should do"
20:22:34 <mjg59> Yeah
20:22:39 <nirik> I don't think we have any enforcement on many of the items.
20:23:07 <Kevin_Kofler> Some of that stuff can't be enforced.
20:23:18 <mjg59> With dgilmore's proviso, I think these seem sound
20:23:21 <Kevin_Kofler> Other stuff probably could, but currently isn't, like enforcing working upgrade paths.
20:23:23 * dgilmore thinks that we need to change our attitude on enforcement.  i think we need to start asking people to do things,  and if they dont revoke access
20:23:24 <nirik> or is subject to judgement calls.
20:23:42 <Kevin_Kofler> dgilmore: What sort of things?
20:23:47 <dgilmore> im ok with the proposals,  with the caveat that we should remove that one line
20:23:53 * notting agrees with mjg59. sponsor page seems ok
20:24:15 <Kevin_Kofler> If you want to ban version upgrades, kick me out right now, I won't be able to do fulfill my role of a maintainer under those circumstances anyway. :-/
20:24:16 * nirik also thinks that the drafts are ok.
20:24:18 <dgilmore> Kevin_Kofler: updating packages,  working on bugs, etc
20:24:44 <Kevin_Kofler> Enforcing version upgrades where it makes sense, on the other hand, makes much more sense. :-)
20:24:44 <nirik> Kevin_Kofler / dgilmore: can we skip the argument about that today? unless it is related to these changes?
20:25:14 <dgilmore> nirik: :)  yep,  but thats not what i was talking about
20:25:29 <mjg59> Kevin_Kofler: Please. The "my way or the highway" approach is not a useful way to run a conversation, *and* this isn't the time to have it anyway
20:25:42 <dgilmore> nirik: I think FESCo is scared to ask people to do things.  and we need to change that
20:25:54 <nirik> so, really here we need to: a) decide if the draft changes are ok in the context of this, and then if so, b) should we approve adding a 'any packager can commit to my package' right?
20:26:05 <notting> what actually changed on the package maintainer responsibility page?
20:26:17 <mjg59> I'll admit to mild confusion here
20:26:22 <mjg59> What in these drafts requires that flag?
20:26:46 <nirik> dgilmore: feel free to draft something for us to consider relating to that? ie, what we should ask for and what we should do?
20:26:56 <nirik> mjg59: it's a shift in responsibility.
20:27:15 <nirik> mjg59: before we said sponsors should watch the people they sponsor and be responsible for their actions.
20:27:36 <nirik> now, we are saying the package maintainer who clicks 'any packager can commit here' should be the one responsible for the commits on their package...
20:28:01 <nirik> ie, if they set that they realize they are opening up anyone who has been sponsored for any reason into packager.
20:28:21 <notting> the only change is the 'mentor and watch over ...' section?
20:28:22 <ajax> that seems a bit self-evident.  but sure.
20:28:32 <abadger1999> notting: Mostly removals.  /me pulls up the diff
20:28:48 <notting> abadger1999: alas, can't diff page A to page B easily
20:28:51 <abadger1999> Oh wait.. package maintainer page... /me checks that
20:29:07 <mjg59> Ok. So these are the guidelines for influencing the behaviour that results from that change, rather than the change following from the new drafts? That's much clearer, thank you
20:30:04 <Kevin_Kofler> I'm +1 to the changes, with dgilmore's amendment of removing the note about non-provenpackagers which doesn't make sense for sponsors as sponsor implies provenpackager.
20:30:31 <cwickert> sorry if this is a dumb question: we are talking about packagers/sponsors responsibility. what is the actual path for co-maintainers to get sponsored without a package/review?
20:30:33 <Kevin_Kofler> And I'm also +1 to adding an "allow everyone to commit" button, some people want that, they should get it, at which point it becomes their problem if something breaks.
20:30:51 <nirik> cwickert: convincing a sponsor to sponsor them.
20:31:09 <cwickert> nirik, ok, but based on what criteria?
20:31:31 <Kevin_Kofler> No official ones, sadly.
20:31:36 <notting> AIUI , the responsibilities change is a prerequisite to having another path, right?
20:31:38 <Kevin_Kofler> It's something I have complained about already.
20:31:46 <cwickert> how do they prove their knowledge of the guidelines?
20:32:05 <nirik> cwickert: based on sponsors judgement I guess.
20:32:22 <cwickert> ok, then it's about trust bot not about a policy I guess
20:32:27 <cwickert> s/bot/but
20:32:28 <abadger1999> notting: The new mentor section is the main thing; a few cleanups (ml change) and a little bit of wording changes.  I'll post the diff.
20:32:54 <dgilmore> cwickert: i see it as being a package mantainer saying i want foo to help me co-maintain bar,  please sponsor them
20:33:24 <cwickert> dgilmore, but this means that the sponsor has to trust you and foo
20:33:32 <Kevin_Kofler> Yes.
20:33:53 <cwickert> ok, for me, but I'm not sure if this works out
20:34:05 <nirik> I don't think we could write up any guidelines for sponsors above "in your judgement, foo knows enough to commit to packages"
20:34:20 <abadger1999> Diff: http://fpaste.org/5RpT/
20:34:41 <cwickert> nirik, yes, something like this should be in there explicitly
20:34:44 * notting is +1 to both wiki changes
20:34:59 <nirik> cwickert: I would be fine to add something like that to the sponsors page...
20:36:00 <cwickert> nirik, but on the maintainers page too: "If you want foo to co-maintain your package, make sure ...."
20:37:01 <nirik> cwickert: ok, so would you like to work with abadger1999 to add that and we revisit? or ?
20:37:31 <mjg59> Kevin_Kofler: Feel like writing some guidelines for sponsoring criteria?
20:37:48 * skvidal is also +1 to the wiki changes
20:37:55 <Kevin_Kofler> Hmmm, what kind of criteria should they be?
20:38:01 <cwickert> nirik, I'm already +1 for the pages. can we vote now and add the missing bits later?
20:38:07 <mjg59> Kevin_Kofler: Unsure, but you're complaining about the status quo :)
20:38:14 <ajax> yeah, +1 to this proposal
20:38:20 <nirik> sure.
20:38:33 <Kevin_Kofler> I'm complaining because I have no idea what criteria to use, so I don't know what I'd be supposed to write up. ;-(
20:38:40 <cwickert> +1 ftr, if I wasn't clear enough
20:38:52 <dgilmore> +1 again
20:38:56 <mjg59> Kevin_Kofler: Well, we're the people who are supposed to make these criteria
20:38:57 <nirik> I guess I am a weak +1 here as well. I wonder how many packages will use this.
20:39:02 <mjg59> Also, +1
20:39:11 <cwickert> Kevin_Kofler, I think the criteria are the same than for being sponsored, the question is how to prove them
20:39:17 <Oxf13> "Are you willing to help be a mentor to, and help FESCo with enforcement issues of this person"
20:39:19 <nirik> I think it's hard to write any more detailed criteria than "use your judgement sponsors"
20:39:21 <mjg59> Kevin_Kofler: If it's something you care about, it's a great time to do something about it :)
20:39:27 <cwickert> nirik, +1
20:39:47 * gholms recommends asking for informal package reviews
20:40:40 <nirik> so, thats enough to pass this change.
20:41:22 <nirik> abadger1999: was the thought that this would be implemented now? or wait until the git transition?
20:42:12 <nirik> #agreed Wiki Drafts are accepted, any packager can commit to this package pkgdb checkbox approved.
20:42:16 <abadger1999> nirik: I'll start looking at it soonish (F-14 timeframe, probably).  It will probably work into whatever the git transition is but it depends on how each progress.
20:42:21 <pjones> nirik: also unnecessary.
20:42:24 <pjones> (not just hard)
20:42:30 <abadger1999> F-14 timeframe for deploy.
20:42:42 <nirik> pjones: ?
20:42:59 <pjones> nirik: writing more detailed criteria than that.
20:43:02 <nirik> #info looking at F14 timeframe to implement
20:43:07 <abadger1999> It shouldn't be hard to add the packager checkbox, jds2001 already did most of the work.
20:43:11 <nirik> pjones: ah, ok.
20:43:19 <nirik> anything further on this topic?
20:43:34 <Oxf13> (thank you!)
20:43:55 <nirik> #topic Fedora Engineering Services
20:44:00 <nirik> mmcgrath: you around?
20:44:46 <nirik> Basically mmcgrath has been putting together some pages/infrastructure around a group
20:44:52 <nirik> https://fedoraproject.org/wiki/FES
20:45:14 <nirik> we would have folks sign up and then fesco at first and possibly other groups later would create tasks for them to work on.
20:45:19 <mmcgrath> nirik: yup yup
20:45:30 <nirik> These would be short, discrete tasks that we need done
20:45:50 <nirik> Something we can say has a end/completion, etc.
20:46:16 <nirik> I listed a few things off the top of my head such a pool of people could work on: http://lists.fedoraproject.org/pipermail/advisory-board/2010-February/007924.html
20:46:45 <nirik> I'd like to see if we can come up with 2-3 tasks like this we can use to test this and setup procedure/proof of concept.
20:47:04 <mmcgrath> I'll donate 4 hours / week for starters.
20:47:24 <mmcgrath> Once we're comfortable with the process I'll send an announcement out and see if we can get more people.
20:48:24 <Oxf13> i hope nobody minds if I refrain from donating time :/
20:48:39 <Oxf13> not that I don't believe in this effort, because I do, a lot.  Just have no more time to give
20:49:13 * mmcgrath doesn't have any expectations of anyonw :)
20:49:13 <ajax> i can think of a few package qa checks that would be appropriate for this
20:49:19 <jwb> Oxf13, i think the intention is to drum up _new_ contributors
20:49:39 <Oxf13> or to find better use for the existing ones
20:49:52 <jwb> true
20:49:59 * mmcgrath fits more into that last category
20:50:06 <nirik> so, for starting tasks, how about: 1) look at broken deps in stable (we already have a report/list of them). contact maintainers and see why they are still broken, report back on status next week. 2) find/locate VPS services and see what versions of fedora they all offer, report back to fesco with a list so we can contact them/see about updateing them.
20:50:13 <mmcgrath> as the release gets closer, infrastructure freezes more often so I find myself with more time then normal.
20:50:36 <Oxf13> mmcgrath: interesting point
20:50:56 <nirik> I would like to use a smart part of our meeting each week for status on these and/or adding new ones or closing finished ones. So we don't loose something that we wanted done.
20:51:12 <nirik> (that should be 'small' , but also 'smart' I hope)
20:52:20 <Oxf13> also "lose" instead of "loose" I'd wager
20:52:21 <nirik> so, any other ideas for inital tasks? thoughts on the entire idea?
20:52:31 <Oxf13> There are tonnes of QA tasks that could be done
20:52:32 * nirik can't type today. Should just give up. ;)
20:52:44 <Oxf13> as well as making existing packages conform to new packaging guidelines
20:52:58 <Oxf13> the broken deps in the rawhide report
20:53:05 <Kevin_Kofler> One I'm thinking of: check for (Build)Requires with >= and possibly missing Epoch.
20:53:07 <Oxf13> the broken deps in the updates(-testing) lists
20:53:12 <ajax> i can think of a bunch of oneshot things like "any use of chcon in a specfile probably needs inspection"
20:53:15 <nirik> also info gathering for further action by fesco. Ie, if we know something we could act on it or change policies.
20:53:19 <Kevin_Kofler> The >= on things like Requires: kdelibs >= 4.4.0 has no effect.
20:53:31 <Kevin_Kofler> (should be kdelibs >= 6:4.4.0 or kdelibs4 >= 4.4.0)
20:54:03 <nirik> ie, how many of our sponsors have never sponsored anyone? how many haven't sponsored anyone in 6months? a year? 2 years?
20:54:11 <Kevin_Kofler> I'm fixing these every so often, it could be caught by an automated check (though it'd get false positives too).
20:54:42 <ajax> actually it's a lot of things that should go into automated tests for post-build
20:54:53 <nirik> for checking those kinds of things, perhaps the task could be: setup a machine that has an exploded cvs checkout in it so we can run various tests. Each test is another task using that infrastructure.
20:54:56 <ajax> but writing those tests is definitely something with a known finish
20:55:18 * mmcgrath sees the idea machine churning
20:55:20 <nirik> right, autoqa takes care of a lot of that if there are tests.
20:56:32 <nirik> so, how about once the trac for it is setup, we hit the fesco list... fesco members can then submit a idea or two and we see how it looks next week?
20:56:57 <ajax> sounds like a plan
20:57:06 <mmcgrath> nirik: trac is mostly up, I'd say go ahead and throw a couple of tasks in
20:57:11 <nirik> or a fesco trac ticket perhaps. No need to put it on the list/private.
20:57:41 <nirik> mmcgrath: cool. Whats the link?
20:57:56 <mmcgrath> https://fedorahosted.org/fedora-engineering-services/newticket
20:58:29 <nirik> great. Thanks for working on this. I am hopefull it will be of great help...
20:58:38 <ajax> heh, no tickets yet.
20:59:08 <nirik> anyone have any further input on this?
20:59:39 <ajax> not i
21:00:12 <nirik> #topic Open Floor
21:00:18 <nirik> anyone have anything for open floor?
21:00:25 <Kevin_Kofler> Yes, me.
21:00:36 <Kevin_Kofler> I'd like to report on the breakage caused by the Implicit DSO Linking "feature".
21:00:40 <Kevin_Kofler> https://bugzilla.redhat.com/showdependencytree.cgi?id=564245&hide_resolved=0
21:01:01 <Kevin_Kofler> 400 packages broken, excluding those fixed within a day or 2 of the change going in which didn't even show up there.
21:01:05 <Kevin_Kofler> https://bugzilla.redhat.com/showdependencytree.cgi?id=564245&hide_resolved=1
21:01:08 <Kevin_Kofler> 250 still broken.
21:01:17 <Kevin_Kofler> 0 fixed in the hour of the meeting.
21:01:26 <mjg59> Kevin_Kofler: Your consistent denigration of work done by others in an attempt to improve the quality of Fedora is tiresome
21:01:39 <mjg59> If you have issues, please phrase them differently
21:01:45 <Kevin_Kofler> Time to enact the contingency plan? Should I bring up an official proposal to enact the contingency plan for next week?
21:01:46 <cwickert> Kevin_Kofler, from 400 down to 250 is great progress
21:01:50 <Kevin_Kofler> (i.e. revert the feature for F13)
21:01:56 <Kevin_Kofler> cwickert: But that has stopped.
21:02:06 <cwickert> for an hour?
21:02:13 <Kevin_Kofler> My experience is that rate of fixes slows down considerably after the first wave.
21:02:16 <ajax> and i'm sure it'll stay stopped until f13 goes live?
21:02:21 <ajax> wait.  not that at all.
21:02:22 <notting> stopped 'by your experience'? give me a break.
21:02:23 <Kevin_Kofler> Some maintainers fix things right away, the others take much longer.
21:02:34 * nirik has some more to fix, but been busy today. I am sure I will get to them in the next week or so.
21:02:34 <cwickert> Kevin_Kofler, I will fix mine tonight, that's another 30 or so
21:02:37 <Kevin_Kofler> notting: My stats: 0 fixes in 1 hour.
21:02:45 <notting> which is a useless metric
21:02:50 <Kevin_Kofler> I checked when the meeting started, rechecked now, still 250 broken.
21:02:54 <nirik> so?
21:02:58 <notting> do you intend to bring this up every meeting like a petulant toddler?
21:03:23 <mjg59> I propose that we drop this topic now, as it's clear that no useful conclusion will be drawn from it
21:03:33 <nirik> I think great progress is being made and hopefully we will get them all fixed. I think ones not fixed before too long is a great chance for provenpackagers to help out.
21:03:39 <nirik> mjg59: +1
21:03:39 <cwickert> Kevin_Kofler, you said we will not make it in time for F13 but now we have already more than one third. I'm optimostic we will make it
21:03:47 <Kevin_Kofler> What do we have contingency plans for if we don't even consider enacting them?
21:03:49 <nirik> so, any other topics?
21:04:03 <cwickert> !
21:04:11 <nirik> cwickert: ?
21:04:13 <cwickert> the opening of the mailing list archives again
21:04:23 <Kevin_Kofler> (which is what the "drop this discussion" proposals amount to)
21:04:27 <notting> Kevin_Kofler: last week you attempted to make up guidelines to get this removed. today you're attempting to make up an arbitrary contingency deadline that didn't exist before to get it reverted
21:04:28 <cwickert> someone reminded me again
21:04:32 <notting> what will you make up next week?
21:04:49 <Kevin_Kofler> notting: I'm bringing up the regressions caused by the feature.
21:05:00 <ajax> they're just ftbfs
21:05:00 <Oxf13> the contingency plan is there in case the feature itself is not ready.  In this case, the feature is ready, some packages aren't ready for the feature.
21:05:01 <Kevin_Kofler> And thus I want us to consider it a failure.
21:05:05 <nirik> cwickert: I thought we agreed we will leave them closed, but assure people we don't use them for much, and that everything is done in trac.
21:05:13 <cwickert> IIRC one of the reasons for not opening the list archives was that we need to do an audit on the old content
21:05:20 <ajax> we have 800 of those.  less than half are due to the linker change.
21:05:25 <Oxf13> since we're not expecting to do a mass rebuild for this feature, that does not mean we need to enact the contingency plan
21:05:33 <notting> Kevin_Kofler: REGRESSIONS? for fucks sake
21:05:40 <cwickert> nirik, but the list migration might be a good point to open them because we don't have much / anything to audit
21:05:41 <Kevin_Kofler> Oxf13: So let's make the "remove GNOME from Fedora" feature, it's already ready now, only "some packages aren't ready for the feature". ^^
21:05:41 <notting> are you just going to make up reasons?
21:05:49 <cwickert> just an idea, I'm not insisting on this
21:05:57 <Oxf13> Kevin_Kofler: propose the feature and get FESCo to approve it.
21:06:00 <nirik> cwickert: it's already been moved with archives... so the new list has all the old archives.
21:06:11 <cwickert> nirik, ah, i see
21:06:17 <cwickert> no further questions then
21:06:23 <mjg59> cwickert: The other concern that was raised was that it's likely to be effectively impossible to communicate the change in expectations to everyone
21:06:23 <Kevin_Kofler> notting: Things that built before and no longer build.
21:06:39 <mjg59> The things that no longer build have always been buggy
21:06:51 <cwickert> mjg59, agreed, I just wanted to proxy what someone else asked me
21:06:55 <notting> Kevin_Kofler: right. we knew that, and we accepted that. things will be fixed. things have already been fixed (nearly 40% in one week.)
21:07:04 <nirik> Kevin_Kofler: I'm sorry you find the number of FTBFS bugs from this worrysome. I think we will get things fixed, I see no need to revert this at this time.
21:07:05 <ajax> and of the other ~400 things that no longer build, you have nothing to say.  hm.
21:07:14 <notting> so, you're trying to set an arbitrary deadline that wasn't in the feature, the schedule, or anywhere else, to call for its reversion today.
21:07:27 <notting> which is patently silly.
21:07:37 <mjg59> 21:03 < mjg59> I propose that we drop this topic now, as it's clear that no useful conclusion will be drawn from it
21:07:40 <cwickert> sorry, can we just stop this discussion?
21:07:45 <ajax> +1 drop
21:07:46 <notting> mjg59: agreed, i'm sorry.
21:07:48 <cwickert> +10
21:07:59 <nirik> any other topics?
21:08:07 * nirik will close the meeting out soon if not.
21:09:08 <nirik> #endmeeting