fedora-meeting
LOGS
00:02:41 <sparks> #startmeeting Docs Project Meeting - Agenda: http://fedoraproject.org/wiki/Docs_Project_meetings
00:02:42 <zodbot> Meeting started Thu Feb 11 00:02:41 2010 UTC.  The chair is sparks. Information about MeetBot at http://wiki.debian.org/MeetBot.
00:02:44 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
00:02:51 <sparks> #topic Roll Call
00:02:52 * sparks 
00:02:53 * ianweller is sorta kinda not really here
00:03:26 * laubersm is here (for a change)
00:03:27 * stickster 
00:03:53 * jjmcd just
00:03:57 * mprice is here
00:04:12 * bcotton is here and cooking
00:04:36 <radsy> .
00:04:45 <sparks> #chair jjmcd
00:04:46 <zodbot> Current chairs: jjmcd sparks
00:05:43 * quaid is here
00:05:52 <sparks> WOOT!
00:06:41 <sparks> Okay...  Let's get started.
00:06:50 <sparks> #topic Desktop Help Summit
00:07:07 <sparks> #link http://live.gnome.org/DesktopHelpSummit2010
00:07:16 <sparks> jjmcd: Are you still planning on going?
00:07:26 <jjmcd> yes of course
00:07:30 <sparks> Great!
00:07:45 <laubersm> I know I will NOT be in Chicago the week before or after...  they couldn't get me scheduled there.
00:07:53 <laubersm> I do not know where I will be those weeks though
00:07:54 <jjmcd> bummer
00:08:01 <sparks> laubersm: Handy.  Isn't that always how it works?
00:08:13 <jjmcd> But at least now I can be pretty confident there won't be a Monday
00:08:14 <quaid> can we use the power of remote access?
00:08:21 <sparks> Did we ever figure out a remote solution for shaunm?
00:08:25 <laubersm> If it is not too hard to work out the travel, there is still an option - it is penciled in on my calendar
00:08:35 <jjmcd> We've been talking about that
00:08:53 <stickster> sparks: I mentioned several last week. shaunm didn't follow up with me about anything.
00:08:57 <sparks> okay
00:09:05 <laubersm> remote options would be good.
00:09:08 <stickster> shaunm: I suggested several options last meeting, including IRC and Fedora Talk.
00:09:16 <stickster> shaunm: What would help you move forward with this?
00:09:18 <sparks> Can someone follow up with shaunm on remoting the Summit?
00:09:30 <stickster> Do you want me to raise a topic on our docs list, or elsewhere? Or something else?
00:09:51 * sparks didn't see shaunm on the roll call...
00:09:58 <sparks> stickster: Maybe email directly?
00:10:04 <quaid> stickster: cool, on list would mean we could contact people who may have the new Events A/V Kit (right?)
00:10:06 * stickster thinks we need to have a specific commitment from shaunm that he can do one or more of some remote access thingy.
00:10:19 <quaid> +1
00:10:19 <stickster> quaid: Sure
00:10:24 <jjmcd> I think we concluded all we needed was a conference phone
00:10:38 <quaid> yep
00:10:42 <jjmcd> Since there is a Chicago dial in number
00:10:48 <quaid> "all we need" is sometimes a long way, though
00:10:49 <stickster> So let's be clear about what you want me to do
00:10:52 <sparks> #action stickster to work with shaunm on remoting the Desktop Help Summit and make sure everything is squared away.
00:10:57 <sparks> :)
00:11:00 <stickster> let's be clearer than that please.
00:11:15 <stickster> 1. See if shaunm is willing to run an IRC session in real time alongside hacking
00:11:20 <jjmcd> Yes, make sure we have a conference phone and a phone line where we will be meeting
00:11:27 <stickster> 2. See if shaunm will have access to a conference-able phone.
00:11:41 <quaid> 3. Gobby
00:11:43 <quaid> 4. Wiki
00:11:55 <stickster> Wiki is not that good for realtime participation, frankly.
00:12:05 <stickster> Although if it's needed, certainly GNOME has one.
00:12:22 <stickster> Wiki is great for capturing things to a more semi-permanent state, just not good for r-t collaboration.
00:12:29 <quaid> wiki is crucial for ongoing status updates to allow for async
00:12:39 <stickster> or meetbot
00:12:42 <quaid> every ~1 hour dump gobby docs
00:12:47 <quaid> well, sort of
00:13:08 <sparks> We have a lot of options...  I'm not sure shaunm has had them all laid out in front of him, though.
00:13:16 <quaid> this all comes down to, are folks who are present willing to assign documenters, etc.
00:13:23 <sparks> He liked the idea of using Talk, IIRC.
00:13:31 * stickster wonders if he can #action properly hee
00:13:33 <stickster> *here
00:13:39 <sparks> you should be able to
00:13:48 <sparks> #chair stickster
00:13:48 <zodbot> Current chairs: jjmcd sparks stickster
00:13:51 <sparks> just to be sure
00:14:00 <stickster> #action stickster Find out if shaunm or proxy is willing to run IRC in real time during hackfest
00:14:07 <stickster> #undo
00:14:08 <zodbot> Removing item from minutes: <MeetBot.items.Action object at 0xff73550>
00:14:10 <stickster> #undo
00:14:11 <zodbot> Removing item from minutes: <MeetBot.items.Action object at 0x2b599d4ed6d0>
00:14:13 <stickster> #action stickster Find out if shaunm or proxy is willing to run IRC in real time during hackfest
00:14:22 <stickster> #action stickster Find out if shaunm will have access to conference phone
00:14:47 * sparks forgets about #undo
00:14:55 <stickster> #action stickster Find out if shaunm wants to use gobby.fp.o or wiki for other collaboration options
00:15:01 <stickster> OK, anything else?
00:15:01 * laubersm thinks undo is cool
00:15:30 * sparks thinks that is all...
00:15:46 <sparks> stickster: did we ever get that recording of conference rooms working?
00:15:51 <stickster> sparks: Yes
00:16:08 <sparks> might want to mention that as well
00:16:22 <stickster> What's not ready is a web app to make it a smoother fit for people who don't know much about it.
00:16:42 <stickster> #action stickster Provide pointers to shaunm for Fedora Talk recording options
00:17:09 <shaunm> oh, shaun shaunm shaunm
00:17:42 <sparks> heh...  speak his name enough and he appears!
00:17:46 <shaunm> IRC absolutely yes.  don't see any problems with that.  I need to check if we can get a conference phone
00:17:54 * shaunm puts it on his todo list for tomorrow morning
00:18:03 <stickster> hehehe
00:18:29 <stickster> shaunm: We're big Gobby fans around here too
00:18:39 <shaunm> do we want to transcribe to irc real-time?
00:18:54 <quaid> as close as you can
00:19:04 <laubersm> I will likely only be able to participate remotely
00:19:07 <laubersm> so yes
00:19:08 <quaid> if >1 person is in IRC and transcribing/note taking
00:19:11 <stickster> shaunm: At our live sessions, we rotate duty for that around the room per hour or so
00:19:18 <laubersm> it also make good logs
00:19:20 <stickster> So no one's stuck doing it all day.
00:19:26 <quaid> what about projecting IRC on the wall so people can more closely participate?
00:19:49 <stickster> shaunm: Will you have a projector available at the site?
00:20:25 <shaunm> yes
00:20:32 <jjmcd> 3 - slides, gobby, irc
00:20:34 <stickster> shaunm: Awesome!
00:20:47 <stickster> #info shaunm will have a projector at the site, and is checking into the availability of a conference phone.
00:20:56 <shaunm> (so I was told.  I should double-check that though)
00:20:59 <sparks> shaunm: We also have meetbot, too
00:21:32 <shaunm> yes, I'm jealous of your bot's powers.  I want him for my gnome meetings
00:21:42 <sparks> we rent him out on the weekends
00:21:51 <shaunm> heh
00:22:07 <jjmcd> shaunm, I think we stole him from some other distro
00:22:24 <jjmcd> They're still trying to find him
00:22:44 <sparks> shhh  they may be listening!
00:23:18 <stickster> shaunm: Why don't we make a meeting room for your event, and I have the ability to invite zodbot there.
00:23:26 <jjmcd> Watch out for guys with them funny spirals on their shirt
00:23:54 <stickster> shaunm: Let's work on this in #fedora-docs so the meeting can proceed
00:24:15 <shaunm> sounds good
00:24:58 <sparks> Anything for the summit?
00:25:43 <sparks> Okay, moving on...
00:25:48 <sparks> #topic Release Notes
00:25:59 <sparks> jjmcd: What's going on with the RN?
00:26:04 <sparks> Are you still on schedule?
00:26:22 <jjmcd> YEah, but I blew it yesterday so gonna need to post to mktg-list
00:26:31 <jjmcd> showed up at the wrong place :-(
00:26:50 <sparks> heh
00:27:15 <sparks> Are you getting good input?  Should a message be sent out "encouraging" submissions?
00:27:15 <jjmcd> I thought it was kinda techhie for mktg, turned out to be fesco
00:27:44 <jjmcd> I was surprised to see some input, but real wiki input needs to be solicited a little later
00:27:54 <sparks> ok
00:27:56 <laubersm> I think they are either in their channel or in meeting-1
00:28:21 <jjmcd> Yeah, too late when I figured out they were elsewhere
00:28:31 <quaid> is this back around to recruiting beat writers and relevant content not in Feature pages?
00:29:14 <jjmcd> Yes, we are still over a week from the one pager, so pretty early to start soliciting beat writers
00:31:16 <sparks> jjmcd: Need anything from me/us?
00:31:25 <jjmcd> Not yet
00:32:33 <sparks> Okay...  anyone have anything else on the RNs?
00:32:35 <quaid> no worries about the content on the one pager?
00:32:46 <quaid> quantity and importance, mainly
00:33:16 <jjmcd> And on F12 marketing mostly took the lead there
00:33:31 <jjmcd> Our role was mainly to keep them on point
00:33:38 <jjmcd> Alpha RN's are a one pager
00:34:17 <jjmcd> Which is why it is so different from beta/GA
00:34:41 * stickster notes that talking points discussion is underway
00:34:53 <stickster> sparks: When is the publication date for one-page relnotes for Alpha?
00:35:30 <sparks> stickster: I'd have to look... I forget
00:35:44 <stickster> Ah
00:35:47 <stickster> #link http://poelstra.fedorapeople.org/schedules/f-13/f-13-docs-tasks.html
00:35:48 <sparks> jjmcd: Did the schedule ever get published as an .ical?
00:35:49 <stickster> March 1
00:35:57 <sparks> TU
00:36:08 <jjmcd> poelcat has it on his people site
00:36:11 <stickster> sparks: They're always published alongside an .ics file
00:36:14 <sparks> So just over two weeks
00:36:16 <stickster> #link http://poelstra.fedorapeople.org/schedules/f-13/
00:37:11 * sparks adds that to his calendar.
00:37:18 <sparks> I knew I had been lost...
00:38:09 <sparks> So Beats and Feature review doesn't start until 23 Feb
00:38:19 <jjmcd> right
00:38:44 <sparks> Okay, I'm good, now
00:39:44 <stickster> Next?
00:39:47 <sparks> Okay, anything else?
00:40:02 <sparks> Moving right along...
00:40:06 <sparks> #topic New Guides
00:40:18 <sparks> Anyone have a new guide they'd like to present/talk about?
00:40:54 <sparks> No>?
00:41:12 <sparks> #topic Guide Status
00:41:35 <sparks> Okay, so last week the big discussion was on the Transifex update
00:41:57 <sparks> Last I heard there were significant strides to get authentication working.
00:42:14 <sparks> Now I think they are waiting on data migration, maybe.
00:42:37 <sparks> The date of doom was added to the ticket, as well.
00:43:46 <sparks> As soon as it gets up and we get the thumbs up, I'd like for all guide leads to get your latest POTs uploaded so they can start being worked.
00:43:48 <stickster> sparks: Good idea to post a link to the ticket in the notes here
00:43:54 <sparks> yes
00:44:06 <stickster> #link https://fedorahosted.org/fedora-infrastructure/ticket/1455
00:44:36 <sparks> stickster: Thanks, you beat me to it.
00:45:11 <sparks> Anyone have any needs for their guide?
00:45:58 <sparks> Starting next week I'll start asking for status reports on each guide so we can make sure of what we'll have for F13.
00:46:29 <stickster> sparks: Is there a list somewhere of who's responsible for each guide?
00:46:35 * stickster is woefully out of touch there, sorry
00:46:41 <sparks> Yes...
00:46:52 <sparks> On the agenda page...  scroll down to Guides
00:46:52 <laubersm> #link http://fedoraproject.org/wiki/Docs_Project_meetings
00:47:03 <laubersm> at the bottom
00:47:15 <sparks> #undo
00:47:15 <zodbot> Removing item from minutes: <MeetBot.items.Link object at 0x2b599dab73d0>
00:47:23 <sparks> #link https://fedoraproject.org/wiki/Docs_Project_meetings#Guides
00:47:27 <stickster> heh
00:47:29 <stickster> Okey doke
00:47:38 <sparks> It's woefully out of date.
00:47:39 <laubersm> see if I help again.
00:47:41 <laubersm> :)
00:47:56 <sparks> laubersm: Just taking your great link and putting a shine on it.
00:48:29 * laubersm was just using what was already in buffer from searching for the list before stickster even asked...
00:48:35 <sparks> ya
00:48:43 <sparks> So that Guide table needs to be updated...
00:48:58 <sparks> #action sparks to request guide leads update the table before next week
00:49:46 <sparks> radsy: Is rudi in the office?
00:50:51 <radsy> sparks, yup
00:51:24 <sparks> radsy: Can you ask him what the status is of the non-guide translations items in that table, please?
00:51:34 <sparks> radsy: Or just bonk him on the head and ask him to join us?
00:52:52 <sparks> Okay, anyone have anything else on this topic?
00:53:18 <radsy> asking, he couldn't talk even when identifying a new nick
00:53:24 <sparks> Hmmm
00:53:29 <radsy> irc client gremlins maybe
00:53:35 <sparks> maybe
00:53:48 <sparks> we should try to work on that in #fedora-docs post meeting
00:55:07 <sparks> Okay, moving on to stickster's topic.
00:55:21 <sparks> #topic Making docs.fp.o accessible for non-JavaScript equipped browsers
00:55:40 <sparks> #info To see the problem, install w3m or links, and use it to visit http://docs.fedoraproject.org -- try to select an existing guide
00:55:51 <radsy> sparks, "Awesome response from L10N for the DocBook stuff; I'm committing upstream but don't know how long it will take to trickle back down; probably not in time for F13"
00:56:02 <sparks> radsy: Thanks
00:56:16 <sparks> stickster: Would you like to introduce this?
00:56:36 <stickster> #info rudi reports Good response from L10n for DocBook stuff... committing upstream but might not make it down in time for F13
00:56:39 <stickster> sparks: Sure.
00:56:50 <radsy> "I need to approach some translators to fix some slight changes we made to the Common Content in Publican 1; but all RH-sponsored lanaguages (plus a few others) are in good shape"
00:56:52 * stickster points to zodbot, make him work for us! :-)
00:56:53 <radsy> sorry
00:57:30 * stickster waits to see if sparks is #info'ing that last bit too
00:57:55 <sparks> Ok
00:58:07 <sparks> #info I need to approach some translators to fix some slight changes we made to the Common Content in Publican 1;
00:58:10 <sparks> but all RH-sponsored lanaguages (plus a few others) are in good shape
00:58:12 <laubersm> sparks, looks like most guide leads need to branch for F13 too...  sometime soon so work can start
00:58:16 <sparks> #undo
00:58:16 <zodbot> Removing item from minutes: <MeetBot.items.Info object at 0x2b599cfa9450>
00:58:31 <sparks> #info I need to approach some translators to fix some slight changes we made to the Common Content in Publican 1; but all RH-sponsored languages (plus a few others) are in good shape
00:58:49 <sparks> laubersm: Yeah...  that didn't work like I wanted it too.
00:59:05 <sparks> laubersm: The day after F12 was released there should have been a F13 branch.  :(
00:59:39 <stickster> sparks: mm... that depends, branching methods differ.
00:59:52 <laubersm> history looks like there is F11 and F10 and master...  so master should go to F12 and master becomes the next (rawhide like)
01:00:03 <laubersm> at least in the few that I work on.
01:00:07 <stickster> Many would say you hold on to a "development" or moving branch until you *know* that you need to work on both a specific "next" version and stuff that won't make it to the next version.
01:00:22 <stickster> laubersm: Right
01:00:22 <sparks> well...   branching == working on F13 guide and leaving F12 alone, short of bugs, etc.
01:00:35 <sparks> yeah
01:00:42 <stickster> yup, but then "master" or "devel" or whatever would be F13 until such time as we needed to work on F14
01:00:46 <sparks> yes
01:00:48 <stickster> Which might happen before F13, or it might not
01:01:14 <stickster> It's kind of up to a community to figure that out, document it, and then do it regularly.
01:01:31 * stickster realizes we're way into a new topic here though.
01:01:40 <stickster> Would be good to do this on the list instead of using meeting time :-)
01:01:47 * stickster has a hard stop in 5 min.
01:02:02 <stickster> sparks: Should I give a quick intro to this topic?
01:02:03 <sparks> yes
01:02:23 <stickster> laubersm: Can you bring up the branching topic so we can make a decision and record it
01:02:24 * jjmcd wonders how much effort to put in before we understand what zikula will do to us
01:02:24 <stickster> ?
01:02:38 <laubersm> yes
01:02:45 <sparks> jjmcd: I agree.
01:03:01 <stickster> #action laubersm Bring branching topic to docs list to decide how we want to do this going forward, and record it for posterity.
01:03:07 <stickster> Thanks laubersm!
01:03:13 <stickster> jjmcd: That depends, the only plan we had talked about to a great extent was publishing RPMs and HTML on Zikula.
01:03:13 <stickster> jjmcd: Unless you guys are planning abandoning source code repos, branching matters.
01:03:13 <stickster> (which you might be doing, I'm not assuming anything)
01:03:13 <jjmcd> Oh, I was back to the javascript topic, sorry
01:03:13 <stickster> Ah
01:03:13 <stickster> Well, still worthwhile since there's no Zikula ETA
01:03:13 <jjmcd> RNs is a different branching prob than guides anyway
01:03:13 * stickster gets back on topic
01:03:13 <stickster> sparks: jjmcd: Who created the current HTML indeces?
01:03:13 <jjmcd> rudi
01:03:20 <jjmcd> If I recall, I had a cockamamy scheme but rudi beat me to the punch with a prettier scheme
01:03:23 <stickster> OK, so really we just need to see if rudi can put a graceful fallback in that allows people to use a HTML form submit if no JS is available.
01:03:53 <stickster> I think most people have browsers that handle JS. But unfortunately, most of them aren't a11y (accessibility) challenged
01:04:03 <stickster> s/them/those people/
01:05:01 <stickster> So I suggest that I just bring this to the list to see if this is a fix that is relatively minor, and if so, if rudi can do it, and if not, we can file a websites ticket to get help from someone who knows what they're doing.
01:05:20 <stickster> +/-1?
01:05:32 <sparks> +1
01:05:57 <jjmcd> I'm pretty sure it will be a useability delta, but I think codewise easy
01:06:22 <stickster> jjmcd: If it's a proper fallback, it shouldn't make any difference to people who have JS browsers.
01:06:35 <stickster> You make your dropdown selection, and things will just happen as they do now.
01:06:53 <stickster> If you happen to be sans JS, you hit the button afterward, and then everything works
01:07:13 <jjmcd> Yeah, I think I can see how that would work
01:07:15 * stickster is specifically referring to adding a "GO" button or some such.
01:07:22 <jjmcd> Yep
01:07:39 <jjmcd> So each dropdown needs a noscript block
01:07:41 <stickster> So I think it's essentially no delta for people other than those for whom the delta is positive :-)
01:08:03 * stickster takes the action item
01:08:05 <stickster> #action stickster Ask rudi through list to provide non-JS fallback (HTML form submit or something else). If he can't do it, file ticket with websites to ask for help.
01:09:01 * sparks is getting close to a hard stop
01:09:48 * stickster is there
01:09:52 <sparks> Okay, anything else on this topic?
01:10:18 <stickster> Nothing here
01:10:53 <sparks> Okay
01:11:00 <sparks> #topic All other business
01:11:15 <sparks> #action sparks to setup a bug busting weekend
01:12:04 <sparks> Anyone have anything?
01:12:43 <stickster> sparks: Are you going to send some email about that this week?
01:13:04 <sparks> I hope to
01:13:11 * sparks needs to get his head on straight
01:14:24 * stickster jets, g'night all
01:14:35 <sparks> Well... thanks everyone for coming tonight.
01:14:45 <sparks> Let's do this again next week!
01:14:50 <sparks> #endmeeting