fedora-meeting
LOGS
00:03:01 <sparks> #startmeeting Docs Project Meeting - Agenda: http://fedoraproject.org/wiki/Docs_Project_meetings
00:03:02 <zodbot> Meeting started Thu Feb  4 00:03:01 2010 UTC.  The chair is sparks. Information about MeetBot at http://wiki.debian.org/MeetBot.
00:03:03 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
00:03:10 <sparks> #topic Roll Call
00:03:13 * sparks 
00:03:16 * stickster 
00:03:39 * jjmcd .
00:03:55 * shaunm 
00:05:27 <stickster> sparks: I think that's it, shall we proceed?
00:06:01 * sparks was hoping others might show up
00:06:20 <stickster> Where's that quaid guy? :-D
00:06:23 <sparks> #chair jjmcd
00:06:23 <zodbot> Current chairs: jjmcd sparks
00:06:31 <sparks> #topic Desktop Help Summit
00:06:39 <sparks> #link http://live.gnome.org/DesktopHelpSummit2010
00:07:06 <sparks> jjmcd: Did you get funding squared away for you to attend the Summit?
00:07:07 * stickster is happy jjmcd will be there to represent
00:07:32 <jjmcd> Sparks - still haven't totally nailed all the details but I will be there
00:07:45 <shaunm> I've got nothing to add.
00:07:51 <sparks> shaunm: Thank you
00:07:52 <stickster> jjmcd: shaunm: Will there be a "live/remote" component so others can participate from afar?
00:07:52 <jjmcd> I assume you are still no?
00:08:11 <shaunm> there are two locals who have offered up accommodations at their place, by the way
00:08:12 <sparks> jjmcd: At this time.  Still working with the boss on if I can rule out a few projects.
00:08:27 <jjmcd> stickster, I have no sudh capability
00:08:41 <jjmcd> work is the curse of the drinking class
00:08:41 <shaunm> stickster: an Ubuntu person asked that as well.  I think it would be neat, but I'm not sure I know how to go about setting it up
00:08:57 <stickster> shaunm: One way to do it is the way we do FUDCon Live.
00:09:14 <stickster> shaunm: You could have one person in each hour/timeslice of the conference transcribe to an IRC channel.
00:09:32 <sparks> Fedora Talk?
00:09:42 <stickster> shaunm: Alternatively, or in addition, you can use a VoIP dialin so people can listen in on proceedings
00:09:42 * quaid has shown up
00:09:49 <jjmcd> If we have wifi I can certainly help with the IRC stuff, but I have no IP phone or stuff like that
00:10:00 <sparks> jjmcd: I can send you one
00:10:06 <stickster> jjmcd: You don't need a special IP phone... you can dial in from a normal phone too
00:10:21 <stickster> shaunm: There is a local dial in for Chicago:  http://talk.fedoraproject.org/
00:10:38 <jjmcd> hmmm, so if shaunm could score us one of those conference phones we could just dial 2008
00:10:43 <stickster> jjmcd: Exactly.
00:11:05 <stickster> shaunm: Does that strike you as easy enough to pull off?
00:11:40 <shaunm> I'll check with Kevin to see if there's anything there we can use.
00:11:48 <jjmcd> that would be great
00:11:54 <shaunm> it would be
00:12:00 <stickster> shaunm: Even a cell phone would suffice, I'm sure you'll have some of those around :-)
00:12:02 <shaunm> are there limits on who could dial in?
00:12:08 <stickster> shaunm: Not really
00:12:25 <stickster> The codec is pretty tight, unless more than a couple dozen people dialed in it should work OK
00:12:30 <sparks> Fedorians would have access via VoIP...  others could just dial in, correct?
00:12:42 <jjmcd> shaunm and there are more numbers than just chicago
00:12:42 <quaid> yes, which would limit the voip draw
00:12:46 <stickster> sparks: Right
00:12:55 <stickster> sparks: shaunm: And there's a streaming connection too I believe.
00:13:03 <sparks> Ooo
00:13:04 <shaunm> ok, I'm just wondering if it's ok for non-fedora people to use this as well
00:13:10 <quaid> #link http://talk.fedoraproject.org/
00:13:29 <stickster> Sure
00:13:31 <sparks> shaunm: Should be fine
00:13:45 <jjmcd> shaunm Fedorans get a voip connection, but others can just dial one of 4 or 5 numbers
00:14:18 * sparks needs to get his VoIP problems figured out.
00:14:23 <stickster> It's a GNOME event, we <3 GNOME... no problem. QED. :-)
00:14:32 <jjmcd> :-)
00:14:46 <shaunm> I wonder if I could figure out a simple way to stream video as well
00:14:57 <quaid> ustream.tv or something similar?
00:15:06 <quaid> or icecast.fedoraproject.org
00:15:24 <jjmcd> Wouldn't surprise me if the uni had a server
00:15:24 <stickster> shaunm: We worked on a fully free software solution last weekend. It's not done, but we're a couple steps closer.
00:15:44 <shaunm> nice
00:15:54 <stickster> It's just a matter of a little more developer time
00:16:01 <shaunm> I'd have to think about hardware.  I suppose I could just use a webcam
00:16:10 <stickster> shaunm: https://fedorahosted.org/freeseer/
00:16:17 <shaunm> I wonder if my camcorder can be made to work for streaming
00:16:31 <stickster> shaunm: That software I just URL'd is meant to do that
00:16:38 <shaunm> awesome
00:16:42 <stickster> via firewire, v4l, v4l2
00:17:02 * stickster doesn't want to gum up docs meeting with technical weeds, ask me about it later if interested
00:17:03 <shaunm> I have fun stuff to distract me from contracts tomorrow.
00:17:17 <shaunm> sure
00:17:30 <stickster> shaunm: That code needs love, btw... but opening it up was the first step ;-)
00:17:42 * stickster yields floor for any other Desktop Help Summit stuff
00:17:59 <sparks> Okay, anything else?
00:18:33 <sparks> Okay... moving on
00:18:42 <sparks> #topic Release Notes
00:18:55 <sparks> jjmcd: Anything new?
00:19:02 * jjmcd was totally consumed with NTS stuff this week so nothing to report
00:19:17 <sparks> Okay.
00:19:40 <sparks> #topic New Guides
00:19:52 <sparks> Anyone have any new guides they want to talk about?
00:20:34 <sparks> #topic Guide Status
00:20:54 <sparks> Anyone know what the status of the new Transifex?
00:21:10 <stickster> sparks: There is an infrastructure ticket
00:21:15 <stickster> Hang on and I'll dig up the link
00:21:21 <stickster> Also, I want to back up to release notes for a second.
00:21:22 <sparks> thanks
00:21:27 <sparks> Ok
00:21:39 <stickster> You guys are kind of breezing through the agenda, but I don't see any note on where we are in the schedule
00:21:45 <stickster> http://poelstra.fedorapeople.org/schedules/f-13/f-13-docs-tasks.html
00:21:47 <jjmcd> That reminds me
00:22:00 <stickster> THat shows 3 weeks until Release Notes start getting prepared for Alpha, the first of two test releases before final.
00:22:03 <jjmcd> I need to remind guide owners once again about the schedule sign up
00:22:30 <stickster> sparks: Can you topic back to Release Notes to capture this piece?
00:22:45 <sparks> #topic Release Notes
00:22:50 <stickster> Cool, thanks
00:23:03 <stickster> #info Release Notes for F13 Alpha start production in 3 weeks (2010-02-23)
00:23:24 <stickster> What are we planning to produce for the Alpha?
00:23:35 <jjmcd> One pager
00:23:50 <jjmcd> wIf I recall, working with marketing like last time
00:24:14 <stickster> OK, and content for that will come from devs and contributors directly, with Docs editing?
00:24:32 <jjmcd> Mostly stolen from feature pages I imagine
00:24:52 <stickster> jjmcd: OK, then I think it would be a good idea to clarify that schedule with the right tasks and dates
00:25:11 <jjmcd> https://fedoraproject.org/wiki/Docs_F13_schedule
00:25:11 <stickster> This is what John Poelstra was asking for earlier and maybe it was unclear what he was looking for
00:25:29 <stickster> poelcat just wants to make sure that schedule reflects what the Docs team is really doing
00:25:33 <jjmcd> We can/should flesh that out a little
00:25:40 <stickster> jjmcd: Let's do it now, then.
00:25:55 <stickster> What tasks make up the Alpha release notes production?
00:26:07 <jjmcd> stickster, we have asked all parties to sign up for/comment on, F13 tasks on the url I just pasted
00:26:17 <jjmcd> relnotes is at the bottom
00:26:18 <stickster> Did I miss one?
00:26:24 <jjmcd> https://fedoraproject.org/wiki/Docs_F13_schedule
00:26:29 <stickster> Nuts, didn't see my buffer, thanks jjmcd
00:27:07 <stickster> Wow, jjmcd, so that's complete for Release notes then?
00:27:12 <stickster> cool
00:27:36 <jjmcd> Well, I gave poor John a tough time over that
00:28:03 <stickster> Was that a yes, or a no?
00:28:06 <jjmcd> But I think we are close to right this time
00:28:08 <jjmcd> Yeah
00:28:17 <stickster> Cool
00:28:31 <jjmcd> I need to buy into it because its basically my schedule after a zillion rounds with poelcat
00:28:52 <stickster> jjmcd: Is there a pre-Feb 23 task for letting people know what we are expecting from them (marketing, general community, etc.)?
00:29:16 <jjmcd> There are several like that, dunno about pre-23rd tho
00:29:54 <jjmcd> We were pretty lightweight on alpha because last time marketing mosly led
00:30:06 <jjmcd> sheesh the typing tonight
00:30:24 <stickster> jjmcd: OK, maybe a task to send marketing a heads up then?
00:30:42 <jjmcd> Yeah, and also to devs for being sure feature pages are updated
00:30:53 <jjmcd> I'll add a ping on my to-do for the 11th
00:30:58 <jjmcd> that will give 2 weeks
00:31:10 <stickster> jjmcd: OK, write that in and I'll ping poelcat to update his schedule appropriately
00:31:35 <stickster> The task is either email someone, or show up at a meeting
00:31:59 <stickster> Marketing meets on Tuesdays 3:00pm EST (2000 UTC) if that helps
00:34:00 <sparks> Anything else?
00:34:18 <stickster> not here, thanks sparks
00:34:23 <stickster> thanks jjmcd
00:34:32 <sparks> How will the Transifex delay affect the Release Notes?
00:35:25 <jjmcd> That is a problem
00:35:49 <sparks> yes
00:36:31 <quaid> is that delayed ue to lack of hands to do the upgrade work?
00:36:36 <stickster> sparks: Might want to #topic back, now that I finished my digression :-D
00:36:39 * stickster looks for link
00:36:53 <jjmcd> WHat is the status there?  I have been assuming glezos would be ready
00:37:05 <stickster> https://fedorahosted.org/fedora-infrastructure/ticket/1455
00:37:11 <sparks> quaid: I don't know/think so
00:37:55 <stickster> jjmcd: sparks: You guys need the new Tx 0.7+ to work with Publican production smoothly, right?
00:38:02 <jjmcd> Correct
00:38:11 <jjmcd> And we made schedule assumptions
00:38:12 <stickster> I see sparks in cc: on that ticket
00:38:28 <ricky> It's about 80% of the way there :-/  It's up to the testing stage, but there's one glitch with the staging setup preventing testing at the moment.  I haven't had any luck chasing that down though :-(
00:38:28 <jjmcd> Reworked a lot of what we were doing based on 0.7
00:38:47 <stickster> ricky: Hi there!
00:39:03 <stickster> ricky: Is that the piece in comment 43?
00:39:10 <stickster> https://fedorahosted.org/fedora-infrastructure/ticket/1455#comment:43
00:39:34 <stickster> sparks: You might want to comment in that ticket that this is critical for F13 guides/release notes
00:39:38 <sparks> ok
00:39:57 <quaid> +1
00:40:08 <ricky> Well, I actually know the cause for the issue in comment 43.  It's the problem in comment 38 that we're having issues with
00:40:35 <ricky> I'll be able to debug this further after tonight, so hopefully it'll be ready for testing soon this week
00:40:47 <stickster> ricky: Thanks for looking into that for us
00:40:52 <sparks> #action sparks to add comment explaining the need for the Transifex 0.7
00:41:02 <sparks> ricky: Thanks!
00:41:56 <sparks> Okay, anything else?
00:42:37 <stickster> nope, other than that sparks, you might want to explicitly ask if it should raised to 'critical' in the Trac
00:42:55 <sparks> ok
00:43:01 * stickster doesn't know the criteria that infrastructure uses for that, probably just "a lot of people really need it yesterday" :-)
00:43:11 <ricky> Setting it to critical as is is fine
00:43:20 <stickster> ricky: OK, thanks!
00:43:22 <ricky> Or blocker if it's blocking something :-)
00:44:08 <sparks> Okay...  moving back to Guides...
00:44:19 <sparks> #topic Guide status
00:44:20 <jjmcd> on Mar 11 it is a blocker
00:44:35 <sparks> So everyone is waiting on the Transifex upgrade.
00:45:11 <jjmcd> Guides are supposed to be sending POTs to tfx already
00:45:13 <sparks> Does anyone have any concerns about their guide?
00:45:18 <sparks> Yes.
00:46:17 <sparks> But that was also a proactive submission.  So it's not at a critial status, yet.
00:47:18 <sparks> rudi: What's going on on your guides?
00:47:29 <sparks> rudi: Have you heard anything from radsy?
00:48:46 <stickster> ricky: It sounds like it might end up blocking release notes production if we're unlucky...
00:48:46 <stickster> I suppose we could work around the l10n issues but it would be painful, yet again
00:48:46 * stickster doesn't want jjmcd to have to go through that
00:48:48 <stickster> <eof/>
00:48:52 * stickster hums Jeopardy theme :-)
00:49:22 <sparks> Well...  I don't have anything.
00:49:23 <jjmcd> stickster, we also have a boatload of guides to deal with this time
00:49:35 <stickster> jjmcd: There's quite a lot of them
00:49:44 <sparks> As soon as we get Transifex up we'll want all guides to start pushing POTs.
00:49:54 <jjmcd> But you know, rudi sprinkles his magic pixie dust and the problems go away
00:50:04 <stickster> jjmcd: So really, the owners of those docs *need* Tx 0.7, because we can't expect every owner to work around the l10n tooling
00:50:11 <jjmcd> Exactly
00:50:31 <sparks> yes
00:51:05 <sparks> Okay...
00:51:15 <stickster> Do all of those docs have specific owners? Just curiosu
00:51:17 <stickster> *curious
00:51:22 <sparks> kinda
00:51:28 <stickster> kinda specific? ;-)
00:51:32 <sparks> I think we can point to someone for each guide, yes.
00:51:35 <stickster> "somewhat pregnant"
00:51:37 <stickster> :-D
00:51:57 <stickster> OK, fair enough -- just wondering how many people were going to be rolled up in that Tx blocker.
00:52:03 <jjmcd> But most fall to just a few people :-(
00:52:08 <sparks> yes
00:52:31 <sparks> We wanted to get the POT files uploaded early so l10n would have more time to do the work.
00:52:40 <stickster> Yup
00:53:18 <sparks> Okay... lets talk tickets
00:53:22 <sparks> err...  bugs
00:53:28 <sparks> #topic Outstanding BZ Tickets
00:53:28 <stickster> So do you guys want to set up some sort of "point of no return" date for Fedora's Tx 0.7? in collaboration with the L10n folks
00:53:35 <stickster> oops, wasn't finished
00:53:50 <sparks> stickster: What else you got?
00:54:02 <stickster> sparks: I think it's important that we know exactly when is too late for Tx 0.7 from y'all's perspective
00:54:07 <stickster> And that Infrastructure know too
00:54:17 <stickster> If we pass that date, is there any other alternative?
00:54:32 <stickster> Do we have the ability to use transifex.org in the meantime, or something else?
00:54:49 <sparks> Ummm....  I think we had a solution for F12 but it was painful.
00:55:09 <stickster> sparks: It was.
00:55:34 <stickster> sparks: Was my question hazy?
00:55:47 <stickster> Not sure if I wrote it badly.
00:56:16 <stickster> You guys know that translate.fedoraproject.org is our hosted instance of Tx, right?
00:56:17 <sparks> I was waiting for jjmcd to chime in...  He was the "designer" of the solution.
00:56:24 <sparks> yes
00:56:37 <stickster> Well, I think in all cases, jjmcd used translate.fedoraproject.org -- correct?
00:56:37 <jjmcd> We need to re-do the sked with L10N if we don't have it
00:56:44 <stickster> jjmcd: don't have it by when?
00:56:51 <jjmcd> mar 11
00:56:54 <stickster> OK
00:57:08 <stickster> jjmcd: And you used translate.fp.o for everything last time, along with ugly hacky workarounds, right?
00:57:18 <jjmcd> We made some sweeping assumptions in that schedule.  Yes
00:57:38 <stickster> jjmcd: OK, thanks
00:57:40 <jjmcd> Once it was scripted the main issue was the elapsed time
00:57:59 <jjmcd> Takes a few minutes to build RNs, a few hours to merge the po's
00:58:32 <stickster> So, what I'm asking is, in the case that ricky and the other Infrastructure genii (I mean that most sincerely) can't get Tx 0.7+ working in our infrastructure by that date, do we have any alternatives other than ugly hacky workarounds?
00:58:38 <stickster> Are there any worth considering?
00:58:55 <sparks> I don't think we have a different workaround
00:59:20 <stickster> What about using transifex.net for one release?
00:59:27 <stickster> Is that a possibility? I see they're running Tx 0.8.0devel.
00:59:43 <jjmcd> There may be some things we can do to ease the pain, but as I said, we made sweeping assumptions in the schedule which need to be revisited
01:00:04 <jjmcd> I guess that is more of a question for glezos
01:00:18 <stickster> jjmcd: OK, have one of you guys asked glezos about it?
01:00:32 <jjmcd> No, I haven't spoken with him in a while
01:00:38 <sparks> I don't know the capabilities of Transifex so I can't answer the question about usng transifex.net.
01:00:45 <jjmcd> Mostly third hand
01:01:02 <stickster> sparks: Transifex just gives people a way to check out POT files and send up PO files, without you having to give everyone individual access to your guides and notes.
01:01:14 <stickster> It does the same things on transifex.net as it does at translate.fp.o
01:01:15 <sparks> yes
01:01:29 <sparks> I don't know about the versions, though
01:01:39 <sparks> did 0.8 break something else?
01:01:42 <sparks> don't know
01:01:44 <stickster> The question would be, if we did something on the tx.net 0.8.0, would it be portable back to translate.fp.o 0.7
01:02:14 <sparks> that too
01:02:41 <stickster> OK, if no one wants to take on the task of asking glezos about it, I will
01:02:48 <stickster> sparks: #action me baby
01:03:15 <sparks> #action stickster to talk to glezos about transifex and to report back ASAP!  :)
01:04:36 <sparks> jjmcd: Anything else?
01:04:46 <jjmcd> nope
01:05:02 <sparks> stickster: ?
01:05:50 <stickster> nada
01:06:00 <sparks> Okay
01:06:05 <sparks> BZ Tickets...
01:06:18 <sparks> #link https://bugzilla.redhat.com/buglist.cgi?query_format=advanced&classification=Fedora&product=Fedora%20Documentation&bug_status=NEW&bug_status=ASSIGNED
01:06:56 <sparks> Last week I went through and tried to assign tickets where I thought I could
01:07:51 <sparks> So please login and see what we can take
01:07:54 <sparks> you can take
01:08:05 <sparks> there are 109 outstanding tickets
01:08:42 <stickster> sparks: Hey, I think I actually closed or reassigned some of mine properly in a recent bug binge
01:08:43 <sparks> #topic All other topics
01:08:54 <sparks> stickster: Excellent!
01:09:27 <stickster> sparks: Is there any thought given to a bug sprint day?
01:09:28 <sparks> Does anyone have anything else they'd like to discuss?
01:09:39 <sparks> stickster: I haven't.
01:09:45 <stickster> sparks: You should! :-)
01:10:04 <stickster> It's worked well for some other collateral groups... marketing does this, mchua rocketh the issue list.
01:10:09 <sparks> Not sure we have enough people to jump in.  We haven't been able to get everyone together at the same time in a while.
01:10:32 <jjmcd> And there are a surprising number of names on those bugs
01:10:36 <stickster> sparks: I can commit to helping
01:10:42 <stickster> quaid: How about you, any chance?
01:11:08 <stickster> sparks: If you can pick a weekend day, that might work best, esp. since everyone's got $DAYJOB concerns
01:11:20 <sparks> ya
01:11:24 <stickster> sparks: Why don't you bring it up on the list and see who nibbles
01:11:27 <quaid> I would jump in
01:11:31 <quaid> if I can meet the time :)
01:11:35 <quaid> sprints are the bomb
01:11:36 <sparks> #action sparks to setup a bug tackle day for Docs
01:12:04 * stickster is going to have a hard stop in about 4 min, just for info in case he disappears
01:12:19 <sparks> Does anyone have anything else they'd like to discuss?
01:12:49 * stickster is mum
01:14:19 <sparks> Okay, thanks everyone for coming out!
01:14:24 <sparks> #endmeeting