fedora-meeting
LOGS
15:04:52 <adamw> #startmeeting bugzappers 2010-01-26
15:04:52 <zodbot> Meeting started Tue Jan 26 15:04:52 2010 UTC.  The chair is adamw. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:04:52 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:05:06 <adamw> #topic gathering
15:05:17 <adamw> roll up, roll up - who's around for a bugzappy feast?
15:05:20 * tk009 is here but fighting wit hte ac installer atm
15:05:28 <Tech33> here
15:05:41 <tk009> airc condition guy is replacing my ac
15:06:52 <tk009> hmm just three of us?
15:06:59 <adamw> no-one else? aw, c'mon, i'm waking up at 7am for this
15:07:26 <tk009> we should think about changing the meeting time again
15:07:41 <tk009> we have two hours free after this one
15:07:42 <adamw> if you make it earlier i'm gonna kill someone
15:07:42 * thomasj_ is partly here
15:07:50 <tk009> later
15:07:52 <tk009> hehe
15:07:53 <adamw> =)
15:07:54 <Southern_Gentlem> adamw,  not our fault you live on the rong coast and sleep the day away
15:08:02 <tk009> lool
15:08:34 <adamw> Southern_Gentlem: oh THAT brought you out of the woodwork huh
15:09:03 <Southern_Gentlem> adamw,  the woodwork is where stuff gets done lol
15:09:21 <adamw> alright, well, there's interesting stuff on the agenda so let's walk it anyway
15:09:22 <tk009> I am starting to think by-weekly meetings wit hte turn out of late
15:09:27 <adamw> Southern_Gentlem: oh well i wouldn't know anything about that!
15:09:33 <rjune_> I'm here.
15:09:36 <adamw> hey rjune
15:09:46 <adamw> #topic housekeeping SOP
15:10:07 <tk009> I noticed this one as well
15:10:13 <adamw> as the agenda says - the housekeeping page currently gives a quick outline of what should be done but there isn't a detailed procedure for how exactly it should be implemented
15:10:28 <adamw> jlaska: this is you, in a guest starring role
15:10:45 <adamw> a housekeeping SOP sounds like a good idea. who's going to write it? :)
15:10:56 <tk009> when i first saw this problem I went and closed one of those bugs
15:11:06 <tk009> that was two months ago or so
15:11:12 <rjune_> link to the page in question?
15:11:15 <tk009> and holy hell the mail that was generated
15:11:19 <adamw> oh yeah i was gonna do that before i nodded off
15:11:30 <adamw> #link https://fedoraproject.org/wiki/BugZappers/HouseKeeping
15:11:37 <jlaska> tk009: yeah :)  I gather it kicks off quite a bit of mail
15:11:50 <tk009> link - https://fedoraproject.org/wiki/BugZappers/HouseKeeping/Trackers
15:11:55 <tk009> link -  https://fedoraproject.org/wiki/BugZappersHouseKeeping#Tracker_.28Blocker.29_Bugs
15:12:07 <adamw> #chair tk009 rjune_
15:12:07 <zodbot> Current chairs: adamw rjune_ tk009
15:12:14 <tk009> then people were mad I closed their bugs
15:12:23 <tk009> not many but I did get hate ail
15:12:42 <Tech33> are we talking about eol closures?
15:13:12 <tk009> clean-up on tracker and blocker bugs
15:13:18 <jlaska> what started this for me was notting asking if we had a formal procedure for closing out tracker bugs after a release
15:13:31 <tk009> we don't that I am aware of
15:13:38 <adamw> cleaning up trackers doesn't mean you have to *close* the reports if the bugs are still valid, can always just take them off the tracker
15:13:40 <tk009> and its clear we need one
15:13:49 <tk009> yes I know
15:13:50 <adamw> yup i think that's kinda obvious
15:14:02 <tk009> they were closed correctly
15:14:27 <adamw> i can do it if no-one else wants to, I guess. but since I've not actually done any housekeeping it seems odd :)
15:14:40 <tk009> I spent about two weeks on just one of those blockers
15:14:46 <adamw> so maybe poelcat or tk009? (yes, this is the reward for success)
15:15:07 <tk009> yes I can work with poelcat
15:15:15 <tk009> seems the best solution
15:15:17 <rjune_> Neither have I.
15:15:17 <jlaska> tk009: were you checking in on the status of each of the linked bugs on the tracker also?
15:15:24 <tk009> yes
15:15:34 <jlaska> tk009: oh boy, yes ... that would be rough
15:15:40 <tk009> I tried to cover it all
15:16:00 <adamw> alright - if you guys need help i'm happy to pitch in
15:16:20 <tk009> afk to yell at this guy a sec
15:16:42 <adamw> try and vaguely follow the existing SOP pages for layout and page naming (if the existing ones are consistent, I forget...) and add to the appropriate category
15:16:53 <adamw> #action tk009 and poelcat to work on a housekeeping SOP page
15:17:19 <adamw> #topic bug reports on orphaned packages
15:17:29 <adamw> this is another guest star if he's around - nirik?
15:17:44 <tk009> this isn't a big one
15:17:51 <tk009> there were not many listed
15:18:16 <tk009> its like bugs against eol versions, just every now and then we need to look for them
15:18:29 <tk009> something good for new folks
15:18:34 <tk009> was my thinking
15:19:19 <Tech33> suggestion (and no, I'm not volunteering)... add a stock response for that to the stock response page
15:19:24 <adamw> yeah, it could be a regular sweep i guess
15:19:26 <tk009> a zpper whos nick I cant recall atm said he would work on the current list
15:19:42 <tk009> kysoething
15:19:50 <adamw> Tech33: a single stock response wouldn't always be appropriate, but yeah, we could add one for the most common cases
15:19:55 <Tech33> kyril
15:20:03 <tk009> yes thanks tech33
15:20:20 <adamw> remember when adding stock responses we always need mcepl to add 'em to the jetpack too
15:20:37 <adamw> does anyone feel like taking point on this one (other than tk009 who we shouldn't make double-dip?)
15:20:45 <Tech33> not true
15:20:57 <adamw> Tech33: which bit?
15:21:09 <Tech33> not all stock's are buttons in the script
15:21:46 <adamw> well, ok, but mostly they ought to be, and new ones should be at least considered
15:23:12 <tk009> the wiki and jetpack should have everything we use as a stock response. If they don't match we need to correct that
15:23:54 <adamw> soo, i guess i'm getting this one?
15:24:17 <tk009> tech33 can you do this task?
15:24:28 <Tech33> rather not, sorry
15:24:45 <tk009> that is fine but I am going to ask why
15:24:47 <adamw> it's ok, i'll take it
15:24:49 <Tech33> meaning the orphaned bit
15:25:53 <adamw> #action adamw to work on a plan and stock response for dealing with reports against orphaned packages
15:27:06 <adamw> next up
15:27:11 <adamw> #topic duplicate marking procedure
15:27:28 <tk009> I never fixed the wording on that one
15:27:31 <adamw> iarlyy brings up a mail from the user list about inappropriate duplicate marking
15:27:31 * Tech33 sits up
15:27:41 <adamw> #link http://lists.fedoraproject.org/pipermail/users/2010-January/364426.html
15:27:53 <adamw> now as I noted on the thread - we're not actually guilty in the case cited
15:27:57 <adamw> that triage was being done by a developer
15:28:00 <tk009> I thought it was still good to bring up so we "zappers" are aware and careful we are not cloing stuff willy lilly
15:28:15 <adamw> but it is a point worth running over briefly - good practice when marking bugs as dupes
15:28:24 <adamw> and making sure our procedure docs explain it well
15:28:34 <adamw> so let's see what we have on it atm...
15:29:01 <adamw> "If so, set the least helpful report to CLOSED/DUPLICATE with the bug number of the most helpful report and this stock response."
15:29:09 <adamw> that seems pretty good to me, and doesn't rely on date
15:29:13 <Tech33> I understand iarlyy's point, but...
15:30:01 <tk009> but?
15:30:17 <Tech33> I mark anywhere from 5 to 15 bugs as dupes per DAY
15:30:52 <adamw> and yet you have no personal hate threads on users@ yet, so congrats :)\
15:30:55 <tk009> and you are more likely right than wrong in all of those cases
15:31:20 <adamw> i don't think we really have much of an action item here, since our guidelines are sane - just really a heads-up
15:32:07 <tk009> in the past the devs complain to jesse and not to us. other than that thread I've seen nothing else on this issue
15:32:24 <adamw> jesse would come and yell at jlaska or me if anyone was yelling at him, i think
15:32:28 <adamw> haven't heard anything
15:32:53 <tk009> so tech33 carry on =)
15:32:59 <Tech33> ok, I am sorry about having the potential there to overreact
15:33:46 <Tech33> I was worried that a single case was going to cause a serious change when I'm dealing with many many more
15:33:47 <adamw> npnp
15:34:00 <adamw> nope, i don't see any change we need to make here...does anyone?
15:34:07 <tk009> no
15:34:10 <tk009> just the heads up
15:34:17 <Tech33> just so you know, real quick, if I may
15:34:50 <adamw> go for it
15:34:54 <tk009> afk again for a min crane is here
15:35:17 <adamw> holy crap is this a *sentient* A/C?
15:35:20 <Tech33> when I get a non-dupe, and ask the originator for info, if I get a dupe to that, if the original bug has not yet respnded to, I set the dupe as a needinfo as well
15:35:50 <adamw> ...and then mark it as a dupe, or wait for one to respond?
15:36:12 <Tech33> it's my personal policy to get some response, then use that as the tracker
15:37:20 <adamw> that sounds pretty reasonable
15:37:32 <Tech33> that's it
15:38:13 <adamw> alrighty
15:38:29 <adamw> we have one more topic but it's for tcpip4000, who isn't around
15:38:51 <adamw> #agreed no action needed on duplicate marking topic, just a heads-up to be smart and don't go only on age of reports
15:39:26 <adamw> so let's go straight to...
15:39:28 <adamw> #topic open discussion
15:39:56 <Tech33> I have nothing
15:40:11 <adamw> zippedy doodle here
15:40:13 <adamw> anyone else?
15:40:24 <rjune_> nope
15:40:31 <tk009> yes
15:40:42 <tk009> meeting time
15:40:53 <tk009> two free slots later in the day
15:41:14 <Tech33> what time is it in cz?
15:41:22 <Tech33> right now
15:41:29 <tk009> the two hours after this one
15:42:01 <Tech33> ok, then we could move it later a few hours and not terribly inconvenience people, I would think
15:42:03 <tk009> soething to thing about
15:42:04 <adamw> we've been through the rodeo a couple of times but i don't mind doing it again
15:42:12 <adamw> we did have a matrix last time we moved it though
15:42:27 <adamw> does someone want to look that up and see how many people on it are still active? maybe run another thread to make a new one?
15:42:30 <rjune_> what was the matrix for?
15:42:31 <tk009> we need to do it faily often I think jsut to make sure the time works for everyone
15:42:43 <tk009> http://fedoraproject.org/wiki/Fedora_meeting_channel
15:43:18 <rjune_> in the fesco elections, there was a website used to track who was available when.
15:43:21 <tk009> this time has been fine for me but others my find an hour or tow later better
15:43:25 <rjune_> Might look into that.
15:43:37 <Tech33> well, striaght off, if we moved it ahead andhour, then kde wouldn't need to cut off on-going discussions
15:44:21 <Tech33> not that that is a biggie
15:44:31 <adamw> rjune_: that's what the matrix was
15:44:36 <adamw> it's whenisgood.net or something like that
15:45:10 <adamw> #topic open discussion - meeting time again
15:45:30 <adamw> tk009: well do you want to take an action item to start up the discussion again then?
15:45:41 <tk009> yes I can
15:45:56 <tk009> I think you'd benefit most from the change
15:46:14 <tk009> I would as well as the is y lunch time
15:46:31 <adamw> well i don't really want a change that only benefits me, but it can't hurt to look at the time again for sure
15:46:33 <tk009> okay I will get that rolling
15:46:41 <adamw> #action tk009 to raise the meeting time topic again
15:46:46 <tk009> that was all I had
15:46:50 <adamw> alrighty then
15:46:57 <adamw> anything else, speak now or forever hold your peace
15:47:07 <tk009> one last thing
15:47:16 <tk009> who is doing the recap and wkik?
15:47:23 <tk009> wiki*
15:47:47 <adamw> magic pixies?
15:48:13 <adamw> failing that, rjune, do you feel like it? :)
15:48:28 <rjune_> I can
15:48:32 <adamw> thanks a lot
15:48:35 <rjune_> yup.
15:49:06 <adamw> ok then
15:49:09 <adamw> thanks for coming everyone
15:49:13 <adamw> i'm going back to sleep :)
15:49:22 <tk009> hehe
15:49:30 <adamw> #endmeeting