kde-sig
LOGS
14:01:40 <rdieter> #startmeeting KDE SIG -- http://fedoraproject.org/wiki/SIGs/KDE/Meetings/2010-01-19
14:01:40 <zodbot> Meeting started Tue Jan 19 14:01:40 2010 UTC.  The chair is rdieter. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:40 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
14:01:54 <rdieter> #chair Kevin_Kofler svahl than
14:01:54 <zodbot> Current chairs: Kevin_Kofler rdieter svahl than
14:02:03 <rdieter> #topic Init
14:02:10 <rdieter> who's present today ?
14:02:20 <svahl> present
14:02:29 <Kevin_Kofler> #meetingname kde-sig
14:02:29 <zodbot> The meeting name has been set to 'kde-sig'
14:02:32 <Kevin_Kofler> Present.
14:02:39 * than is present
14:03:11 * thomasj 's here
14:03:49 <rdieter> #topic Proposal: split of kdegames
14:03:59 <rdieter> see, http://fedoraproject.org/wiki/SIGs/KDE/Meetings/2010-01-19/kdegames-split
14:04:00 * SMParrish here
14:04:22 <rdieter> svahl: this is your proposal ?
14:04:40 <svahl> yes. I'd like to split kdegames to get some more free space on the live images
14:05:31 <Kevin_Kofler> I see you're putting KSudoku in the main package, upstream lists it as "extended".
14:05:33 <svahl> the proposed split itself is taken from upstream: http://websvn.kde.org/trunk/KDE/kdegames/README.PACKAGERS?revision=885625&view=markup
14:05:55 <Kevin_Kofler> The thing is, the upstream lists are not complete.
14:06:00 <Kevin_Kofler> They all have "etc.".
14:06:16 <Kevin_Kofler> Upstream hasn't decided on a complete list of minimal games at this point, it seems.
14:06:44 <rdieter> unfortunate, but that's ok, we can start from their initial suggestions, and go from there.
14:07:06 <jreznik> ok, 5 games to minimal set etc...
14:07:09 <svahl> Kevin_Kofler: yes, they aren't complete. but the last change is quite old (2008)
14:07:19 <SMParrish> looks like upstream is just giving examples,
14:07:21 <Kevin_Kofler> But that means upstream dropped the idea.
14:07:33 <Kevin_Kofler> They said they want to categorize the games, but apparently that was never completed.
14:08:08 <jreznik> if we really want it - let's do it
14:08:27 <rdieter> prolly true (Kevin_Kofler), svahl , you mind poking upstream for clarification, advice ?
14:08:31 <rdieter> otherwise, I agree, do it
14:08:45 <jreznik> actually I think it's better not to have games at all and use that space for something more important (speaking while playing angry birds :D)
14:08:47 <rdieter> one small nitpik about naming, I'd either follow their suggestion of -extended , or use -extras , not -extra
14:09:13 <svahl> rdieter: nod
14:09:29 <rdieter> nvm, they use -extra I guess
14:09:32 <Kevin_Kofler> It's a bit sad that we're getting less and less stuff on our live images. It sucks that the work on LZMA support for the live images is still not done. :-(
14:09:55 <rdieter> they have minimal, extra, extended, friends(?)
14:10:06 <Kevin_Kofler> Their idea of extra is extragear.
14:10:08 <svahl> the last I know about lzma is that it propably won't be implemented til f13
14:10:17 <rdieter> Kevin_Kofler: we can still do bigger images (ie, 1Gb ... or more). :)
14:10:19 <Kevin_Kofler> We don't package extragear stuff at all at this time.
14:10:31 <Kevin_Kofler> (extragear games, I mean)
14:10:48 <rdieter> that's odd to mention it in kdegames README then, but meh
14:10:49 <Kevin_Kofler> I'm not aware of any releasable ones.
14:11:15 <Kevin_Kofler> And "friends" is stuff which is arguably a game, but not in kdegames, like some kdeedu stuff.
14:11:34 <Kevin_Kofler> They're both irrelevant for a kdegames split.
14:11:40 <rdieter> also strange, if it's not in kdegames module, it shouldn't be using the kdegames name (imo) (another meh)
14:11:42 <svahl> On the other hand we could follow jreznik's proposal and leave out kdegames on the live images (would save ~60 megs, splitted ~40 megs)
14:12:19 <rdieter> regardless, following their split advice is still good (better late than never)
14:12:29 <jreznik> svahl: or let only that minimal set for office rats...
14:12:33 <Kevin_Kofler> What if we go completely minimal and only ship kpat and kmines in the default install?
14:12:55 <Kevin_Kofler> People only want to play Solitaire (Klondike) and Minesweeper anyway. ;-)
14:12:57 <than> svahl: imo it doesn't make sense to add kdegames on live images
14:12:57 <jreznik> Kevin_Kofler: +1, that's what I like
14:13:10 <jreznik> Kevin_Kofler: absolutely - solitaire and mines...
14:13:10 <Kevin_Kofler> And with kpat, they also get FreeCell, Spider and more.
14:13:44 <SMParrish> Kevin_Kofler: good idea +1
14:13:49 <rdieter> than: yes and no, the games are a good kde4 showpiece (artwork mostly)
14:14:15 <rdieter> I also tend to like the (very) minimal, -minimal , then space is even less an issue
14:14:16 <Kevin_Kofler> Well, kmines isn't that wonderful a showpiece.
14:14:21 <svahl> :)
14:14:48 <Kevin_Kofler> It's more that I don't want the "Fedora sucks, there's no Solitaire and Minesweeper" complaints. ;-)
14:15:57 <rdieter> looking closer, I'd suggest something slightly different (which would help with upgrade paths too).
14:16:33 <Kevin_Kofler> kdegames-kpat and kdegames-kmines subpackages required by kdegames?
14:16:37 <rdieter> keep kdegames main pkg as mostly empty, it Requires: -minimal, -extra , and put everything else into those subpkgs
14:16:42 <than> kmahjongg is a must for a good showpiece
14:16:46 <Kevin_Kofler> Or a kdegames-minimal subpackage?
14:17:04 <Kevin_Kofler> Do we need a -extra subpackage at all?
14:17:19 <Kevin_Kofler> Wouldn't it be enough to just have kdegames-minimal and a kdegames which Requires: kdegames-minimal and has the rest?
14:18:38 <than> i prefer kdegames, kdegames-extra
14:18:51 <Kevin_Kofler> It sucks for upgrade paths though. :-(
14:20:24 <than> we won't have spaces issue if we put live image on dvd!
14:20:31 <thomasj> +1
14:21:05 <than> nowadays every pc has dvd
14:21:16 <thomasj> And for people without DVD, netinstall.iso
14:21:17 <svahl> I don't know if mirror admins would like that
14:21:50 <than> svahl: why?
14:22:04 <Kevin_Kofler> Not everyone has a DVD burner. There are still CD burner + DVD reader combos being sold.
14:22:15 <Kevin_Kofler> And probably even the odd CD-only drive.
14:23:07 <svahl> than: the kde live images are mirrored everywhere. the dvd spins are only available via torrent
14:24:02 <Kevin_Kofler> Well, there's also the installer DVD and the GNOME folks are probably going to >CD-size spins too.
14:24:06 <than> svahl: ok, bandwidth issue
14:24:10 <Kevin_Kofler> So I don't think we'll be the only ones.
14:24:35 <jreznik> and most people are just using usb stick
14:24:36 <Kevin_Kofler> But a full DVD might be overkill.
14:24:41 <rdieter> (sorry, someone stopped by my office)...
14:24:45 <jreznik> full DVD is overkill
14:25:01 <rdieter> no -minimal means we're also not completely following the recommended splitting either
14:25:17 <rdieter> mind you.  and given the upgrade path problem, I'd suggest using it too
14:26:12 <rdieter> we can discuss making a larger image later, and separately. :)
14:26:24 <jreznik> I'm for -minimal
14:26:38 <rdieter> so, I don't see any objection for splitting, just exactly how to do it, and what to include.
14:27:17 <rdieter> I'd propose, -minimal, -extra, with a skeleton kdegames Requires: those 2.  (we can bikeshed on what goes where more later I guess)
14:27:28 <Kevin_Kofler> I propose just kdegames and kdegames-minimal.
14:27:37 <Kevin_Kofler> I don't see why we need a metapackage approach.
14:28:02 <rdieter> Kevin_Kofler: because http://websvn.kde.org/trunk/KDE/kdegames/README.PACKAGERS asks for a -minimal pkg ?
14:28:03 <Kevin_Kofler> Installing only the extra games without the minimal ones doesn't make that much sense.
14:28:43 <Kevin_Kofler> Allowing that kinda defeats the point of minimal being, well, minimal (because you can install a kdegames without the minimal one). ;-)
14:29:07 <Kevin_Kofler> So I think -extra shouldn't be separate.
14:29:30 <rdieter> true, but again, that goes against the spirit of the upstream recommendation is all...
14:29:49 <Kevin_Kofler> The upstream recommendation doesn't say anything about how to implement the packaging.
14:29:50 <rdieter> and we're inventing something different
14:30:02 <Kevin_Kofler> It just talks about defining sets of games.
14:30:15 <rdieter> sets, and what to call them.
14:30:16 <Kevin_Kofler> And then tells us that we should do something useful with those sets when packaging.
14:30:45 <Kevin_Kofler> Well, they say to call the extra games "extended", not "extra". :-)
14:30:56 <Kevin_Kofler> So you're not following that part either with your proposal.
14:31:06 <rdieter> fine, call it -extended (I made a mistake there)
14:31:06 <jreznik> I think upstream approach is a little overhead - 4 cats...
14:31:39 <Kevin_Kofler> Well fine, have kdegames Provides: kdegames-extended if you think people really care about installing something by that name.
14:31:44 <jreznik> let's say - kdegames is our extended package and -minimal is minimal
14:31:52 <Kevin_Kofler> jreznik: +1
14:31:55 <rdieter> ok
14:32:00 <than> +1
14:32:17 <rdieter> +1
14:32:21 <SMParrish> +1
14:32:24 <svahl> +1
14:32:47 <Kevin_Kofler> Now all that's left is to define what should be in -minimal. :-)
14:33:21 <Kevin_Kofler> Sadly, upstream didn't end up providing such a list.
14:33:21 <jreznik> Kevin_Kofler: at least solitaire and mines and choose one nice looking game to acompany them
14:33:39 <rdieter> svahl: you mind adjusting your patch to match jreznik's proposal, and commit, and we'll go from there.
14:34:05 <svahl> for comparison: gnome-games contains only kmines, kreversi, ksame, ksudoku, kpat
14:34:08 <jreznik> Kevin_Kofler: they suggest KMines, KPat, KMahjongg + two more games...
14:34:12 <than> kmahjongg, kmines,
14:34:24 <Kevin_Kofler> As a "nice looking game", kmahjongg? It's suggested by upstream, than also says it's good to showcase stuff.
14:34:24 <svahl> rdieter: I could do that
14:35:11 <rdieter> and go with KMines, KPat, KMahjongg for now, and can think about what else (if anything) to add later.
14:35:26 <rdieter> keeping in mind not to add anything that's very large (probably)
14:35:31 <svahl> rdieter: +1
14:36:32 <rdieter> #agreed create kdegames-minimal subpkg for live image (svahl)
14:37:01 <rdieter> let's move on, we can bikeshed on details later. :)
14:37:14 <rdieter> #topic bug #549687 - kdm: no autologin on first start
14:37:15 <buggbot> Bug https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=549687 medium, low, ---, jmccann, NEW, kdm: no autologin on first start
14:37:16 <Kevin_Kofler> Not that I'm that happy with fewer games on the live image, but size constraints are what they are, so I guess it's better to have a few games than none.
14:38:02 <svahl> just want to ask the status here. If this bug isn't resolved by alpha release it should be mentioned in the release notes
14:39:13 <rdieter> svahl: we need some action/response from ConsoleKit maintainers
14:39:41 <rdieter> I'll mark it as a F13 Alpha blocker, and do some poking
14:40:05 <Kevin_Kofler> I just set it to needinfo(assignee).
14:40:20 <svahl> rdieter, Kevin_Kofler: thx
14:41:35 <Kevin_Kofler> If they don't handle it soon, I'll see if I can fix it myself.
14:42:48 <rdieter> ok.
14:42:56 <rdieter> #topic open discussion
14:43:03 <rdieter> that's it for the agenda today, anything else to discuss ?
14:43:25 <mefoster> One update: the sesame stuff is now blocked on a licensing question :(
14:43:38 <mefoster> http://sourceforge.net/mailarchive/message.php?msg_name=f58861e01001140635p2cf1597dv49337a12a445be42%40mail.gmail.com
14:43:39 <rdieter> rats
14:43:41 <mefoster> (sorry for the bad URL)
14:43:54 <mefoster> I've poked upstream again but they so far aren't replying ...
14:44:09 <mefoster> Not an "is-it-legal" question, a "what-is-the-license" question
14:44:47 <rdieter> sure, thanks for the update.
14:45:04 <mefoster> Bleah. The packages are all ready to go, too ... urgh
14:47:18 <rdieter> since we've time, noticed too... looks like qt-4.6.1 is available today, we'll be jumping on that.
14:48:30 <svahl> according to upstream this should solve #550049
14:48:46 <rdieter> bug #550049
14:48:47 <buggbot> Bug https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=550049 medium, low, ---, than, NEW, plasma-netbook crashs when moving mouse to hidden plasma bar
14:48:51 <svahl> rdieter: thx
14:53:35 <rdieter> alright, thanks everybody.
14:53:38 <rdieter> #endmeeting