irc-support-sig
LOGS
16:30:20 <nirik> #startmeeting IRC Support SIG
16:30:20 <zodbot> Meeting started Thu Jan 14 16:30:20 2010 UTC.  The chair is nirik. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:30:20 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:30:28 <nirik> #meetingname irc-support-sig
16:30:28 <zodbot> The meeting name has been set to 'irc-support-sig'
16:30:32 <nirik> #topic Init process
16:30:56 <DiscordianUK> Good afternoon
16:31:08 <fenris02> 
16:31:12 <nirik> morning DiscordianUK
16:31:19 * zcat 
16:31:35 <che> heyyas
16:31:46 <zcat> holas
16:32:15 * nirik will wait just a bit more for any others wandering in.
16:33:26 <EvilBob> Bacon!
16:33:35 <mock> EvilBob: +1
16:33:56 <fenris02> Tofukey, Terducken, and other made up foods
16:34:11 <EvilBob> Meeting adjourned
16:34:25 <EvilBob> there's really nothing else to say is there?
16:34:34 <nirik> ha.
16:34:38 <nirik> lets go ahead and start in.
16:34:44 <nirik> #topic Weekly stats
16:34:45 * thomasj here.. sorry, late
16:34:46 * EvilBob goes looking for his corner
16:34:47 <nirik> http://fedora.theglaserfamily.org/ircstats/fedora-weekly.html
16:35:03 <nirik> http://fedora.theglaserfamily.org/ircstats/fedora-social-weekly.html
16:35:11 <nirik> @channelstats #fedora
16:35:11 <fedbot> nirik: On #fedora there have been 51654 messages, containing 2065615 characters, 363295 words, 1247 smileys, and 1714 frowns; 594 of those messages were ACTIONs.  There have been 12803 joins, 1099 parts, 11588 quits, 34 kicks, 111 mode changes, and 0 topic changes.  There are currently 580 users and the channel has peaked at 607 users.
16:36:01 <nirik> A busy, but otherwise not too atypical week...
16:36:21 <nirik> Anyone have anything they would like to point out from the stats? or general items from the last week?
16:36:50 <mock> bacon is no longer on the top of social.  i feel sad about that.
16:37:13 * nirik is also sad that he's so low in the new "similey" chart. ;(
16:37:25 <mock> oh, that's new
16:37:27 <Sonar_Guy> Sorry I am late
16:37:36 <underscores> hehe, 5th place
16:37:58 <nirik> links look pretty typical. nvidia seems to be going down a bit...
16:38:20 <fenris02> relatively due to lack of new releases
16:38:34 <EvilBob> Do we need to talk about the whiner?
16:38:59 <nirik> EvilBob: ?
16:38:59 <fenris02> EvilBob, he here to speak his piece ?
16:39:02 <EvilBob> "Oh the bot kicked me accidentally and hurt my feeeeelllings"
16:39:15 <nirik> ah, yes, next topic...
16:39:20 <nirik> #topic Bot news
16:39:20 <EvilBob> How can we deal with such accidents better?
16:39:57 <nirik> So, the bot has had some issues over the last week... first my virtual where it runs had some high load/lockups, then I tried to test it against freenode-test and ran into some issues.
16:40:16 <underscores> Did the bot realy did that accidentally? I thought it is a programm, a programm cant evaluate its deeds can it?
16:40:17 <nirik> I'm sorry for anyone who was caught by it at these times.
16:40:52 <nirik> I have made some adjustments to it, and also the virtual it runs on seems stable for now.
16:41:03 <nirik> so, hopefully it will be better moving forward.
16:41:10 <fenris02> underscores, its lagmeter broke, so it thought folks were flooding
16:41:26 <nirik> If any ops notice the bot kicking someone for no reason or the like a quick fix is to deop it.
16:41:30 <EvilBob> underscores: the kick criteria was met because of a lag
16:41:31 <thomasj> Wasn't the first time. No real harm as well.
16:41:45 <nirik> you can also find out how lagged it is:
16:41:47 <mock> except for feelings
16:41:49 <nirik> @latency
16:41:51 <fedbot> nirik: 1.04 seconds.
16:42:00 <thomasj> mock, yeah, maybe that ;)
16:42:01 * Southern_Gentlem 
16:42:01 <nirik> around 1 second is normal.
16:42:06 <underscores> ok
16:42:12 <MrHacks> Sweet...a meeting
16:42:28 <nirik> Also, next bot news:
16:42:56 <nirik> I have enabled command flood protection. It will only listen to 3 commands from one user in 1 minute. More than that will cause it to ignore that hostmask for 5minutes.
16:43:10 <nirik> This will cut down on people playing around with commands and flooding the channel.
16:43:20 <zcat> does the bot actually have the smarts to recognize when it's getting a burst of lagged messages from everyone, vs a flood from one user?
16:43:57 <nirik> zcat: the flood code is per user I think...
16:44:22 <nirik> so, if 5 people are talking and it sees all of them at once it would check each user against the flood/paste limit.
16:44:22 <thomasj> I doubt that, he kicked as well two users the same time for flooding as he lagged.
16:44:23 <Southern_Gentlem> zcat seems to be last person
16:44:27 <EvilBob> so no way for the bot to tell the difference
16:44:41 <zcat> ok - no smarts
16:44:41 <Khaytsus> Can the bot detect server lag?
16:44:50 <nirik> I can check the logs... or we can test.
16:45:01 <nirik> anyhow, any ideas on improving things welcome... along with patches. ;)
16:45:02 <Khaytsus> Perhaps if he's lagged, disable all lag-based stuff for (figure out algortihm here)
16:45:12 <Khaytsus> nirik: You FOSS guy you...  patches....
16:45:23 <nirik> Khaytsus: yeah, it has a latency thing... but not sure how to hook it to the floodprotect plugin off hand.
16:45:29 <zcat> lets fix the irc protocol to allow for timestamps on all messages? :)
16:45:30 <nirik> yep. ;)
16:45:53 <Khaytsus> That seems like it'd be one way to fix it, say if he's getting lag to the server disable such things until the lag has cleared up for as long as it was happening?
16:46:06 <nirik> Khaytsus: yeah, could be.
16:46:07 <fenris02> zcat, and call it 'jabber' ? great idea.
16:46:10 * fenris02 hides
16:46:10 <Khaytsus> Like if he dtects hes lagged for 30s, it must be unlagged for 30s before re-enabling
16:46:53 * nirik nods. Just not sure how easy that will be to implement.
16:46:57 <EvilBob> How can we deal with such "accidents" better?
16:47:21 <nirik> EvilBob: good question.
16:47:23 <Khaytsus> EvilBob: How many times has it happened in the last week.
16:47:35 <EvilBob> I know how "I" would have dealt with it
16:47:38 <thomasj> EvilBob, the one kicked should learn to relax?
16:47:44 <Khaytsus> EvilBob: Offered cheese?
16:47:47 * nirik knows of two incidents.
16:48:17 <EvilBob> Khaytsus: add a ban to the kick with the whine
16:48:39 <zcat> add an alias to unban and apologize? :)
16:48:44 <nirik> I think deoping the bot until latency goes down, unbanning user, appologizing and re-inviting them to the channel is the best we can do.
16:48:53 <EvilBob> at some point the user is just seeking attention b going on and on about it
16:49:02 <nirik> EvilBob: true.
16:49:13 <Southern_Gentlem> +1 EvilBob
16:49:13 <fenris02> "at some point" threshold is really quite low
16:49:20 <EvilBob> at tht point they are being disruptive and should be eliminated
16:49:23 <fenris02> i was one of those people booted one time :)
16:49:33 <nirik> anyhow, any other bot questions/comments/info?
16:49:39 <EvilBob> fenris02: are you still crying about it?
16:49:40 <Khaytsus> EvilBob:  Especially those that start with amm and end with ini?
16:49:53 <EvilBob> fenris02: we can have you removed also
16:49:56 <EvilBob> ;^)
16:49:57 <fenris02> EvilBob, i consoled myself with chocolate
16:50:02 <zcat> i added a new bot alias, which won't get much use (since most people use !paste):
16:50:05 <zcat> @paste
16:50:06 <fedbot> #fedora recommends using the fpaste.org or dpaste.com pastebins, instead of some other, slower, ad-ridden pastebins.
16:50:10 <Khaytsus> fedbot: chocolate covered bacon?
16:50:25 <Khaytsus> zcat: So, about the slower part
16:50:28 <nirik> zcat: might change that to have the http:// in there so people can click on the shiny links?
16:50:31 <fenris02> Khaytsus, whole foods has it
16:50:33 <zcat> Khaytsus, damaestro's on the case :)
16:50:36 <Khaytsus> :D
16:50:38 <DiscordianUK> That's useful and being new I didn't know
16:50:48 <fenris02> zcat, how long ago was that added?
16:50:57 <zcat> fenris02, few days ago
16:51:30 * fenris02 notes the illumination is suboptimal under his rock
16:52:03 <nirik> ok, shall we move along then?
16:52:04 <EvilBob> On the bot topic, in the last week I asked to have another user in -social added to the "op by proxy" list in that channel
16:52:24 <nirik> EvilBob: was going to get to that next. ;)
16:52:32 <fenris02> sweet!
16:52:35 <nirik> #topic voting for things
16:52:35 <EvilBob> Glad I am ahead of the game
16:52:57 <nirik> We never decided how we vote on new ops/issues/etc... it's murky to me.
16:53:18 <nirik> EvilBob proposed adding a new op (via the bot) on social last week...
16:53:36 <nirik> everyone polled in the ops channel thought it would be fine.
16:53:37 <thomasj> Maybe we vote that on the "list"?
16:54:10 <thomasj> Not the specific yet, but in general.
16:54:11 <fenris02> email is likely the best route for official votes imho.  that way folks have several days to respond instead of a few minutes until it scrolls off the top
16:54:15 <Khaytsus> My idea for botops is that we should try to have solid trusted chanops available, but folks who do not need or what to be chanop but want to help police as necessary can be botops.
16:54:46 <nirik> ok, in the past there was talk of doing some kind of secret ballots or using a web app...
16:54:51 <nirik> or just voting in meetings.
16:54:56 <EvilBob> Voting on and discussing things of this nature can be embarrassing
16:55:03 <Khaytsus> Granted one could botop ban *@* but it's generally less destructive than a chanop could be.
16:55:11 <EvilBob> when done in public
16:55:19 <nirik> EvilBob: indeed.
16:55:32 <fenris02> EvilBob, you have a ballot system in mind?
16:55:47 <nirik> so, I am fine with alias, although we could just make a real list I suppose.
16:56:29 <EvilBob> nirik: the problem with voting on a real list if that the archive is also "out there" for the world to see
16:56:45 <nirik> EvilBob: sure, it would need to be private archives.
16:57:04 * nirik hates personally doing things in private, but also doesn't want someone to be offended if they were discussed.
16:57:28 <fenris02> regardless, we have no ballot means at this time.
16:57:34 <EvilBob> nirik: say we were voting on DiscordianUK, there could be hurt feelings if someone said "I don't think so"
16:57:50 <EvilBob> see what I mean
16:57:57 <EvilBob> now he's pissed
16:58:01 <EvilBob> ;^)
16:58:02 <thomasj> The alias should be fine.
16:58:04 <thomasj> EvilBob, lol
16:58:14 <mock> lol
16:58:41 <nirik> well, just as an example, for fedora packager sponsors or provenpackagers, fesco asks for private feedback from the existing members, but then votes in an open irc session.
16:58:59 <EvilBob> that could not have been timed better if it had been choreographed
16:59:06 <Sonar_Gal> lol
16:59:09 <fenris02> nirik, how does the private feedback work?  email?
16:59:23 <nirik> fenris02: yep.
16:59:29 <EvilBob> nirik: I am cool with that idea
16:59:48 <Southern_Gentlem> i rather have voting in meeting and not on the lists to be honest
17:00:00 <nirik> we have had people who were not accepted, and in those cases, someone was tasked with providing them feedback so they could improve and try again.
17:00:03 <EvilBob> Southern_Gentlem: that is what ws just said
17:00:22 <fenris02> nirik, is there a minimum number of votes required to pass ?  as in, if enough people abstain - it gets delayed?
17:00:30 <nirik> of course, since we have no way of voting currently we can't vote on doing this. ;)
17:00:40 <mock> couldn't op-type ballots be voted on in fedora-ops?
17:00:45 <nirik> fenris02: yes... majority vote needed.
17:00:46 <EvilBob> Southern_Gentlem: discuss and debate privately, vote publicly
17:01:06 <mock> isn't that remvoed from the general arena enough yet not on the lists?
17:01:07 <DiscordianUK> Sorry
17:01:17 <nirik> is everyone ok with that method? it would align us more with other groups in fedoras methods?
17:01:26 <Southern_Gentlem> +1
17:01:30 <thomasj> +1
17:01:33 <fenris02> +1
17:01:33 <EvilBob> +1
17:01:54 <EvilBob> I need to get added to the alias I think
17:01:54 <thomasj> zcat, ^^^^
17:02:03 <zcat> +1
17:02:26 <fenris02> DiscordianUK, to backfill,  <nirik> well, just as an example, for fedora packager sponsors or provenpackagers, fesco asks for private feedback from the existing members, but then votes in an open irc session.
17:02:41 <DiscordianUK> ahhh okay
17:02:50 <DiscordianUK> +1
17:03:12 <EvilBob> nirik: I would suggest we handle things the same way if someone needs to be removed
17:03:16 <nirik> EvilBob: Well, the alias is the fedora irc operators group... orig for just #fedora ops. I guess I don't see the big problem in adding you there since you are poking at social and so we can expand scope.
17:03:43 <fenris02> what about op-by-proxy user?
17:03:48 <fenris02> voting member, or non-voting?
17:03:58 <thomasj> good point
17:04:03 <EvilBob> fenris02: I vote if you want me to or not
17:04:11 <nirik> #agreed adding/removing ops will use the irc-support-operators alias for discussion + irc and then be voted on in the next public irc meeting.
17:04:25 <thomasj> fenris02, Maybe try out the new way for that?
17:04:41 <fenris02> EvilBob, oh, did you say something?  I was not listening.  ;^)
17:05:33 * nirik could go either way... I guess I would say non voting at least at first, but then promoted to regular ops and voting?
17:06:04 <EvilBob> An op is an op is an op
17:06:16 <fenris02> if they have an opjection, it should be heard regardless of their +o status imho
17:06:38 <nirik> sure, so I'd be fine that way too.
17:06:40 <EvilBob> nirik: if you go that way I would never have a vote
17:06:41 * nirik shrugs.
17:06:48 <fenris02> objection even.  sheesh.  typing is bad.
17:06:54 <nirik> EvilBob: true, you found out my evil plan. ;)
17:07:01 <EvilBob> ;^)
17:07:07 <nirik> I'd be fine with them having votes too...
17:07:21 <Southern_Gentlem> not against it at all
17:07:37 <nirik> so, anything more on procedure? or have we hopefully cleared up things?
17:08:22 <DiscordianUK> A suggestion perhaps people shouldn't be able to vote on issues about themselves
17:08:24 <EvilBob> can we vote on the proposed op-by-proxy today?
17:08:31 <thomasj> Procedure is fine. The rest can be discussed using that procedure i think.
17:08:57 <nirik> DiscordianUK: yeah, that would be the polite thing to do.
17:09:05 <nirik> EvilBob: I think so... shall we move on to that now?
17:09:27 <EvilBob> I think we can
17:09:59 <nirik> #topic hiemanshu to be added to fedora-social ops (via bot)
17:10:05 <nirik> +1 here.
17:10:11 <DiscordianUK> +1
17:10:12 <EvilBob> I proposed that we add hiemanshu to be a bot op in -social
17:10:30 <EvilBob> I will abstain from voting on it as I proposed it
17:10:31 <fenris02> no objection
17:11:39 <EvilBob> Who else do we have here today? Southern_Gentlem Sonar_Guy
17:11:52 <zcat> +1
17:11:52 <EvilBob> zcat
17:11:56 <zcat> jinx
17:12:10 <Southern_Gentlem> +1
17:12:17 <Khaytsus> +1
17:12:19 <underscores> +1
17:12:36 * Southern_Gentlem kicks underscores
17:12:37 <EvilBob> Think we have a majority of ops
17:12:39 <mock> lol
17:12:55 <underscores> I'm quiet ^_^'
17:13:08 <EvilBob> I count 5 - 1 from underscores, so 4...
17:13:14 <EvilBob> ;^)
17:13:21 <nirik> ok, sounds approved to me, lets just do it. ;)
17:13:34 <mock> EvilBob: was underscores your proxy?
17:13:40 <nirik> #agreed hiemanshu added to the ops list for #fedora-social
17:13:48 <nirik> #topic Freenode news
17:14:15 <nirik> Not sure if you all saw it or not, but freenode is changing to the new ircd at the end of the month.
17:14:17 <nirik> http://announce.freenode.net/
17:14:29 <nirik> This ircd will support ssl connections.
17:14:33 <Southern_Gentlem> again??
17:14:38 <DiscordianUK> ahhh useful
17:15:11 <EvilBob> that will make daMaestro happy
17:15:29 <nirik> well, one thing we can note is uses who are connected via ssl and identified will get +Z, for whatever it's worth.
17:15:53 <nirik> I tested the bot against it the other day.
17:15:55 <Southern_Gentlem> which means??
17:16:02 <nirik> it can connect fine, but not via ssl.
17:16:25 <Southern_Gentlem> what does the +Z switch do
17:16:40 * nirik looks at the bot. ;(
17:17:00 <nirik> Southern_Gentlem: just a user mode... says they are connected via ssl. Not entirely sure that info is worthwhile, but it's a data point.
17:17:08 <fenris02> http://freenode.net/using_the_network.shtml
17:17:12 <EvilBob> what is the point of an SSL connection to IRC?
17:17:18 <fenris02> i dont see Z
17:17:26 <nirik> fenris02: it's the new ircd only.
17:17:30 <fenris02> oic
17:17:53 <zcat> EvilBob, prevents the unlikely case of someone sniffing your nick/bot passwds and anything you may blurt
17:17:58 <fenris02> EvilBob, crypto from your workstation to ircd while you surf from harbucks
17:18:08 <zcat> btw - gmail switched to https-only the other day.
17:18:31 <fenris02> zcat, true, but it was available for the last ~2yrs
17:18:42 <zcat> fenris02, as an option. it's default now.
17:18:46 <nirik> Anyhow, the changeover is jan 30th...
17:18:52 <nirik> so we need to be ready for the fun then.
17:18:52 * fenris02 nods
17:19:25 * mock gets some party hats and noise makers
17:19:36 <nirik> #topic Open Floor
17:19:40 * Sonar_Gal cooks up some bacon
17:19:41 <nirik> ok, anything for open floor?
17:20:00 <fenris02> needs moping.  i vote EvilBob for the task
17:20:21 * mock gives fenris02 an extra 'p'
17:20:26 <EvilBob> Moping I can handle, I don't do Windows
17:20:35 <EvilBob> mopping
17:20:52 <fenris02> yaya, we've already established that i cannot type nor spel
17:22:15 * nirik will close the meeting in a few here.
17:22:47 * EvilBob thinks that would be a good idea
17:22:51 <mock> +1
17:22:54 <mock> hahaha
17:23:08 <EvilBob> See mock is acting up already
17:24:21 <nirik> Thanks for coming everyone
17:24:25 <nirik> #endmeeting