fedora-meeting
LOGS
00:00:23 <sparks> #startmeeting Docs Project Meeting - Agenda: http://fedoraproject.org/wiki/Docs_Project_meetings
00:00:23 <zodbot> Meeting started Thu Jan 14 00:00:23 2010 UTC.  The chair is sparks. Information about MeetBot at http://wiki.debian.org/MeetBot.
00:00:23 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
00:00:28 <sparks> #topic Roll Call
00:00:29 * sparks 
00:00:43 * jjmcd .
00:00:49 <sparks> #chair jjmcd
00:00:49 <zodbot> Current chairs: jjmcd sparks
00:01:32 <jjmcd> ummm, where are all the other troublemakers and ne'er-do-wells ?
00:01:45 <sparks> I donno...
00:01:54 <sparks> I figured they'd be along..
00:02:12 <jjmcd> I put stickster_afk's topic on the agenda
00:02:32 * bcotton is here and is both a troublemaker AND a ne'er-do-well
00:02:36 * laubersm slinks into the back
00:05:35 <sparks> Okay, let's get started.
00:05:55 <sparks> #topic F13 Release Schedule
00:06:04 <sparks> #link http://poelstra.fedorapeople.org/schedules/f-13/f-13-docs-and-trans-tasks.html
00:06:29 <jjmcd> I never did get with poelcat on my concerns, but they were mostly nit-picks
00:08:14 <sparks> poelcat: You around?
00:08:20 <poelcat> present
00:08:51 * jjmcd hasn't been able to find his note just now
00:09:10 <sparks> heh
00:09:20 <jjmcd> John, I had a few concerns about the sked, nothing that really affects anyone else.  A few things could start earlier, a few things had confusing wording
00:09:29 <sparks> poelcat: Well, apparently jjmcd wants to nit pick the schedule but now doesn't have the notes he made.
00:09:29 <jjmcd> But I need to dig to find my notes
00:09:53 <jjmcd> No biggies tho
00:10:12 <jjmcd> I have a feeling I may have made them on a piece of dead tree
00:11:26 <sparks> #action jjmcd to get with poelcat to work out the minor issues to the F13 schedule.
00:11:57 <sparks> poelcat: Sorry about that.  I thought we might have a break through
00:11:58 <jjmcd> yeah, grepping paper is a pain
00:12:13 <poelcat> okay, let me know when you want to schedule an "intervention" ;-)
00:12:47 <sparks> Okay...  anything else on the F13 schedule?
00:13:00 <sparks> I know I looked over it and didn't see anything major that was broken.
00:13:06 <jjmcd> poelcat, I'll email you my nit-picks
00:13:25 <poelcat> jjmcd: okay, please include line refs
00:13:30 <jjmcd> Yeah
00:13:36 <jjmcd> I did that on my notes
00:13:48 * ianweller is here
00:14:05 <sparks> Okay, moving on.
00:14:20 <sparks> poelcat: thanks
00:14:32 <sparks> #topic Desktop Help Summit
00:14:40 <sparks> #link http://live.gnome.org/DesktopHelpSummit2010
00:14:59 <sparks> I guess shaunm isn't here tonight...
00:15:24 <jjmcd> Does everyone know about it?
00:15:26 <sparks> So the Docs Project has been invited to the GNOME Desktop Help Summit...
00:16:00 <sparks> which will include people from different flavors (Ubuntu, etc) and different desktops (KDE, GNOME, etc)..
00:16:14 <sparks> to help come up with a standard way of pushing documentation to the user.
00:16:35 <jjmcd> I see no XFCE rep - just noticed that
00:17:08 <sparks> As you know we use Yelp in GNOME, which works well with XML, but KDE like HTML and XFCE and Sugar and...  might like HTML or XML or whatever.
00:17:16 <bcotton> jjmcd: jim campbell is listed as being a part of xfce
00:17:38 <sparks> But the problem is that we can't push a single format and have all our desktop users access it similarly.
00:17:50 <sparks> And don't get me started with the translations.
00:18:14 <sparks> So if you are interested in going I need to know by next week.
00:18:39 <sparks> Please include your transportation costs.
00:19:03 <jjmcd> Are we going to try to hang a Fedora event on it?
00:19:12 <sparks> Shaun is attempting to find some funding but I have asked spevack for some assistance as well.
00:19:18 <sparks> We could.
00:19:20 <jjmcd> THere was some discussion of maybe something Monday
00:19:27 <sparks> I sent a note to the list and got zero responses.
00:20:07 <laubersm> too far out for me to plan....
00:20:38 * jjmcd not decided on drive/fly
00:20:46 <laubersm> and I haven't been involved enough in the packaging (format decisions) to make a contribution
00:21:12 <jjmcd> laubersm, so a good opportunity then
00:21:17 <sparks> well, as long as jjmcd gets there.
00:21:27 <laubersm> ha!
00:21:29 <sparks> laubersm: True...  it would be a great opportunity.
00:22:03 * bcotton could be interested potentially, but it would interfere with my basketball obsession
00:22:10 <laubersm> Schedule looks doubtful for me though - the previous weekend already has 2 items and I don't know my work/travel sched until about 2 weeks in advance...
00:22:28 <laubersm> make it hard to book a non-reundable from home when I may need to originate from elsewhere
00:22:36 <jjmcd> Ahh, so you could arrange to be in chicago the week before
00:23:02 <laubersm> non-refundable is about 400 and flexible is about 2k
00:23:16 <laubersm> Ask RH training....
00:23:20 <jjmcd> yeah, dontcha love it
00:23:28 <laubersm> if they put in Chicago before or after I'll be there
00:24:40 <jjmcd> Hey look
00:24:43 <sparks> speak of the devil
00:24:59 <jjmcd> Ears must have been burning
00:25:00 <shaunm> I told you, electric shocks
00:25:04 <sparks> heh
00:25:13 <shaunm> what's up?
00:25:25 <jjmcd> We were just on the second topic
00:25:26 <sparks> we're just talking about the summit
00:25:54 <shaunm> ah, ok
00:26:55 <nirik> jjmcd: The Xfce sig has a mailing list now... you could send your questions to there? ;)
00:27:26 <jjmcd> nirik, Nathan did some testing for us
00:27:33 <jjmcd> Looks encouraging
00:28:02 <nirik> cool. Let us know if we can do anything more to assist on it.
00:28:12 <jjmcd> thanks
00:28:31 <jjmcd> And it looks like shaunm has xfce covered for the summit
00:29:10 <shaunm> Jim's coming, yes.  There aren't a whole lot of people doing xfce documentation
00:30:07 <nirik> yeah. ;(
00:32:23 <sparks> Okay, anything else on this topic?
00:33:23 <sparks> Okay, moving on.
00:33:32 <sparks> #topic Release Notes
00:33:44 <sparks> jjmcd: Anything to discuss about the Release Notes?
00:34:03 <jjmcd> Nothing much to report on that front other than the packaging program which prolly fits better w/guides
00:34:13 <sparks> Okay
00:34:27 <sparks> #topic Status on CMS (Zikula)
00:34:35 <sparks> #link https://fedoraproject.org/wiki/Zikula#Module_status
00:34:43 <sparks> ke4qqq: You around?
00:34:47 <sparks> mchua: ping
00:35:20 <mchua> sparks: pong
00:35:30 * mchua reads up
00:35:32 <sparks> mchua: Anything else going on with Zikula that you know of?
00:35:55 <mchua> I am going through https://fedoraproject.org/wiki/How_to_set_up_a_Zikula_sandbox as we speak, so we'll find out shortly
00:35:58 <mchua> but nothing has hit yet
00:36:04 <sparks> okay
00:36:08 <sparks> no problem.
00:36:22 <sparks> Anyone have anything on this they'd like to discuss before moving on?
00:37:01 <sparks> mchua: Thank you.
00:37:15 <sparks> #topic Guide Status
00:37:26 <sparks> jjmcd: What you got.
00:37:43 <jjmcd> Last week I was supposed to make a test rpm from packaging prog
00:37:56 <jjmcd> I picked IG since it is more complex than RNs
00:38:14 <jjmcd> Ended up improving prog, works in Gnome, KDE and XFCE
00:38:21 <jjmcd> However, Paul found a prob
00:38:41 <jjmcd> Sent out a fixed doc to test, no reponse yet
00:38:52 <jjmcd> Fixed prog not on git yet, will do that tomorrow
00:39:23 <jjmcd> But you can take your guide, build N languages, prog will make a package with the correct functionality
00:39:43 <sparks> cool
00:40:00 <jjmcd> Just fill in a short config file with stuff like version, author, run prog and out pops RPM and SRPM
00:40:20 <jjmcd> Reminded me of the old adage
00:40:29 <jjmcd> To iterate is human, to recurse divine
00:40:37 <jjmcd> Had to do that to deal with IG
00:40:59 <sparks> cool
00:41:02 <sparks> so that works
00:41:12 <jjmcd> Yeah, would like more testing tho
00:41:24 <jjmcd> posted the test doc's url to the list
00:42:14 <sparks> If I could ever get a second...  :)
00:42:24 <jjmcd> I know that feeling
00:43:02 <sparks> Does anyone have anything else?
00:43:18 * nirik has a small item for open floor when/if that happens.
00:43:30 <sparks> nirik: that will be in just a minute
00:43:40 * bcotton can fulfill his promise re: rpm guide
00:43:48 <sparks> excellent
00:43:54 <jjmcd> way cool
00:44:33 <bcotton> here's where we stand.  jsmith has labored to get it all publicanized.  i've fixed a few typos, and we're ready to start making real edits
00:44:36 <jjmcd> bcotton, since you are now an rpm guru, would you like to review the rpm-making prog?
00:44:45 <bcotton> jjmcd, sure
00:45:05 <bcotton> so what i need for the guide now is some guidance from the old hands about how much we want to change
00:45:06 <jjmcd> I'll send you the repo addy after I push the latest changes
00:45:50 <bcotton> do we just want to update the technical facts, do we want to completely re-write it, do we want to do something in between
00:46:16 <jjmcd> Have you spoken with Florian?
00:46:35 <bcotton> i have not
00:47:03 <jjmcd> He is kind of the customer
00:47:21 <jjmcd> Ffesti - I don't see an email on his user page
00:47:35 <bcotton> i'm sure i can find one on the Googles or something
00:47:53 <jjmcd> I suspect it is something arcane like ffesti@rh.c
00:48:09 <jjmcd> .fasinfo ffesti
00:48:10 <zodbot> jjmcd: User: ffesti, Name: Florian Festi, email: ffesti@redhat.com, Creation: 2006-07-04, IRC Nick: ffesti, Timezone: UTC, Locale: en, Extension: 5100764, GPG key ID: , Status: active
00:48:13 <bcotton> i assume we're covered from a copyright standpoint, right?
00:48:14 <zodbot> jjmcd: Approved Groups: cla_done fedorabugs packager hgLHCP gitpyrpm cla_fedora svnsystem-config-printer hgsystem-config-services gitsystem-config-printer
00:48:18 <zodbot> jjmcd: Unapproved Groups: None
00:48:56 <bcotton> in that we won't get in trouble with the original author for re-writing his work
00:49:27 <jjmcd> I remember having a discussion about that like a hundred years ago
00:49:54 <jjmcd> Can't say I recall what our concerns were, tho.  If there are any issues, Florian would be on top of them
00:49:56 <bcotton> i  know someone was looking into it, but i dont know if we ever got that covered. iirc, he didn't have a CLA
00:50:52 <bcotton> okay, cool.  well i'll get in touch with florian and start getting the guide updated. i guess that covers me for now, unless anyone else wants to talk rpm guide
00:52:36 <sparks> Okay, anything else?
00:53:04 <sparks> #topic New Guides
00:53:11 <sparks> Okay, any new guides anyone wants to talk about?
00:53:51 <sparks> #topic Open discussion
00:53:55 <sparks> nirik: You had something?
00:54:12 <nirik> It looks like we are going to be splitting out the fedora-rawhide.repo file from the main fedora-release file. I said I would look for where we need to update docs about this. I know the rawhide wiki page needs updating. Is there any way I can find out where else needs changing? should I file a bug/ticket and/or work with folks in #fedora-docs? or other suggestions?
00:55:12 <jjmcd> I guess I don't totally understand the impact, so I presume maybe somebody else also doesn't
00:55:47 <jjmcd> nirik, filing bugs is a good thing, they don't get lost, but we will need an SME to help
00:56:06 <nirik> yeah, basically the files that tell yum and packagekit about the rawhide repo will be in a subpackage thats not installed by default.
00:56:26 <nirik> so, if you want to go from a stable release-> rawhide you have to install that package and then enable it, instead of just enabling it.
00:56:34 <laubersm> I doubt there is much documentation on it other than in the wiki on how to use rawhide
00:56:42 <jjmcd> Oh, that actually sounds like an improvement
00:56:43 <nirik> yeah, I don't know where it would be.
00:56:57 <laubersm> if anyone sees it - a bug on that doc would be the best way.
00:56:59 <nirik> what docs would refer to rawhide in particular.
00:57:23 <sparks> nirik: Is this going to be post F13?
00:57:34 <laubersm> A note to the docs list would alert any guide owners to think if there is a reference .... maybe install but I even boubt that since it so GA focused
00:57:54 <nirik> sparks: the change should be made in this rawhide cycle... so f13 would be the first release with it.
00:57:59 <jjmcd> Should have a release note for the change, tho
00:58:22 <nirik> yeah, most docs I can think of are talking about stable release... not rawhide, but thought I would ask
00:58:32 <sparks> jjmcd: That was my thought
00:58:35 <nirik> yes, release note is a very good idea.
00:59:32 <sparks> nirik: something on the news feed would be good too
00:59:43 <nirik> FWN?
00:59:53 <sparks> yeah
01:00:08 <nirik> ok.
01:00:45 <nirik> thanks for the suggestions. ;)
01:01:09 <sparks> no problem.  good luck!
01:01:44 <sparks> Anything else?
01:04:12 <sparks> Okay, thanks everyone for coming out tonight.
01:04:20 <sparks> #endmeeting