qa
LOGS
16:00:11 <kparal> #startmeeting Fedora QA Meeting
16:00:11 <zodbot> Meeting started Mon Jan 11 16:00:11 2010 UTC.  The chair is kparal. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:11 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:00:17 <kparal> #meetingname qa
16:00:17 <zodbot> The meeting name has been set to 'qa'
16:00:23 <kparal> #topic gathering
16:00:36 <kparal> ok, welcome all, let's start
16:00:37 * maxamillion is here ... but about to walk over to a meeting, taking laptop
16:00:39 <kparal> who's here?
16:01:08 * jlaska lurking ... but likely unresponsive :(
16:01:24 * tk009_ here
16:01:39 * kparal poking wwoods
16:03:17 <tk009_> no one really seems to be about today
16:03:50 <kparal> ok, seems that's all for today
16:03:52 <maxamillion> ok, back
16:04:15 <kparal> I have an unfortunate message for you - jlaska is out, so I will lead the meeting
16:04:18 * Viking-Ice jumps in..
16:04:29 <kparal> that means it will be short and poorly moderated :)
16:04:44 <wwoods> ack! pokes!
16:04:47 <kparal> I hoped to have wwoods help, but he's somewhere out too
16:04:49 <kparal> ah
16:04:55 <kparal> came to save me, good!
16:04:57 <wwoods> heh!
16:05:28 <kparal> alright, jlaska and adamw are not here. the same is probably for lili and rhe
16:05:33 <kparal> let's go on
16:05:34 <wwoods> sorry, was distracted fixing up my mail filters
16:05:51 <kparal> #topic Previous meeting follow-up
16:05:54 <kparal> #topic Previous meeting follow-up
16:06:06 <kparal> * Viking-Ice investigating adding an LXDE test day to the F-13 test day schedule
16:06:23 <kparal> any updates on that Viking-Ice?
16:06:42 * kparal still learning the meetbot tags
16:06:47 <kparal> #info Viking-Ice investigating adding an LXDE test day to the F-13 test day schedule
16:07:27 * jlaska encourages excessive use of # info :)
16:07:43 <kparal> ok, let's give some time to Viking-Ice
16:07:48 <kparal> #info  maxamillion investigating scheduling a XFCE test day to F-13 test day schedule
16:08:07 <maxamillion> should I talk or wait for Viking-Ice to finish?
16:08:13 <kparal> go ahead
16:08:26 <kparal> he didn't start yet :)
16:09:13 <maxamillion> ok, so I spawned a conversation with cwickert and nirik and we've hashed out some good stuff as far as test planning and how to improve the test-day, we've also started as xfce@lists.fedoraproject.org because we want to start getting more of a community built around the Xfce SIG/Spin
16:09:40 <kparal> nice
16:09:55 <maxamillion> we discussed the possibility of pushing forward with Xfce 4.8 and the testing/QA implications that would bring up and considered submitting it as a feature
16:10:16 <Viking-Ice> sorry I to finish some stuff here @ work
16:10:23 <maxamillion> but after some review and some discussion with upstream there is potential for the release to slip and we don't feel there would be enough time to test thoroughly
16:10:23 <kparal> Viking-Ice: no problem
16:10:51 <cwickert> maxamillion: I talked to Jannis, the release manager today and he said he thinks they will be on time
16:11:05 <maxamillion> but we do plan to be working closely with upstream in pushing 4.8 to rawhide as soon as possible after the Fedora 13 branch
16:11:09 <wwoods> maxamillion: sounds like a prudent decision
16:11:13 <maxamillion> cwickert: oh?
16:11:30 <maxamillion> cwickert: should we bring that back up on xfce@lists.fp.o for a topic of conversation?
16:11:38 <cwickert> ok
16:11:47 <Viking-Ice> spoke to cwickert and he agreed on having an lxde test day would be a great idea next task write lxde test and find a date for the day
16:11:51 <cwickert> for the interested, here is the detailles schedule: https://fedoraproject.org/wiki/Features/Xfce48#Detailed_Description
16:12:04 <kparal> Viking-Ice: just a second to let maxamillion finish, thanks
16:12:10 <maxamillion> cwickert: oh! awesome, thanks for the info and the link
16:12:22 <maxamillion> kparal: can you #link that wiki page please?
16:12:27 <kparal> sure
16:12:30 <cwickert> #link https://fedoraproject.org/wiki/Features/Xfce48#Detailed_Description
16:12:34 <kparal> #link https://fedoraproject.org/wiki/Features/Xfce48#Detailed_Description
16:12:43 <maxamillion> kparal: thank you :)
16:12:46 <kparal> feel free to correct my moderation :)
16:12:57 <kparal> maxamillion: should I give you another action point for the next week?
16:12:58 <maxamillion> lol
16:13:25 * nirik notes no need for link, it should just pick up anything that looks like a URI.
16:13:27 <maxamillion> kparal: uhmmm... yeah, I think that would be a good idea. Label it something along the lines of "Xfce 4.8 update"
16:13:38 <maxamillion> nirik: good to know
16:14:11 <kparal> #action maxamillion bring back conversation about Xfce 4.8 updato on xfce@lists.fp.o and inform about conclusion
16:14:28 <kparal> alright, anything to add or let Viking-Ice talk?
16:14:42 <maxamillion> that's more or less all I've got for now, I still need to update a wiki page on the Xfce test day stuff, but that's about all I have to report
16:14:57 <kparal> ok, thanks
16:15:05 <maxamillion> anytime :)
16:15:07 <kparal> Viking-Ice: are you ready now?
16:15:13 <Viking-Ice> Ah yeas spoke to cwickert and he agreed on having an lxde test day would be a great idea next #action write lxde tests and find a date for the day
16:15:16 <kparal> #info Viking-Ice investigating adding an LXDE test day to the F-13 test day schedule
16:15:46 <kparal> Viking-Ice: assign that action item to you I suppose?
16:15:46 <Viking-Ice> It would be good to have an lxde mailing list ( since it's twice as popular as XFCE )
16:15:50 <Viking-Ice> kparal yes
16:15:55 <cwickert> especially the new login manager LXDE will need to be tested
16:15:56 <kparal> #action Viking-Ice write lxde tests and find a date for the day
16:16:10 * wwoods senses a growing rivalry
16:16:35 <cwickert> wwoods: between Xfce and LXDE? nope, it's getting better in fact
16:16:37 <maxamillion> wwoods: not yet, but we might need to spawn one ;)
16:16:59 <kparal> so who can we talk about new mailing list for lxde?
16:17:07 <cwickert> there were some problems in the past, but we figured them out and work together now
16:17:09 <kparal> *talk to
16:17:10 <maxamillion> but yeah ... we actually have a pretty good working relationship, similar ideals but very different approach and solution
16:17:27 <cwickert> nirik: can you set up lxde@lists.fedoraproject.org?
16:17:28 <nirik> kparal: file a infrastructure ticket.
16:17:28 <tk009_> jds2001 for mailing list
16:17:35 <cwickert> and add me as admin?
16:17:56 <nirik> yeah, I can at some point here... or if you file a ticket someone else could get to it first. ;)
16:18:01 <Viking-Ice> I suppose so if you are up for it..
16:18:13 <kparal> nirik: anyone can file a ticket?
16:18:19 <nirik> yes.
16:18:23 <maxamillion> anyone with a FAS account
16:18:25 <cwickert> #action cwickert to file an infrastruture ticket for the lxde mailing list
16:18:35 <wwoods> (oh it seems like a *friendly* rivarly. the best kind!)
16:18:45 <maxamillion> https://fedorahosted.org/fedora-infrastructure/
16:18:50 <kparal> alright. meetbot registers the action items even for non-moderators, right?
16:19:03 <cwickert> not sure
16:19:05 <tk009_> no
16:19:09 <kparal> #action cwickert to file an infrastruture ticket for the lxde mailing list
16:19:19 <kparal> ok
16:19:21 <maxamillion> wwoods: lol, yeah .... I was honestly a bit surprised to see the popularity of lxde .... I wasn't aware, but good for them! Its a great project :)
16:19:50 <tk009_> people want a smaller footprint it makes sense
16:20:00 <Viking-Ice> goes in circle I suppose..
16:20:09 <maxamillion> yup, and with netbooks being so popular its even more prevelent
16:20:31 <kparal> perfect, anything else on mind on this topic?
16:20:58 <Viking-Ice> nothing from me..
16:21:10 <kparal> ok, thanks Viking-Ice
16:21:29 <kparal> now we have here a few action items for which the people are not available right now
16:21:41 <kparal> *  adamw and rhe to discuss ways to add install testing as a QA activity
16:21:55 * maxamillion throws #info at kparal
16:21:57 <maxamillion> :)
16:21:58 <kparal> so I guess I will just reschedule them for next meeting
16:22:11 <kparal> #info adamw and rhe to discuss ways to add install testing as a QA activity
16:22:15 <kparal> #action adamw and rhe to discuss ways to add install testing as a QA activity
16:22:28 * kparal catches, thanks maxamillion
16:22:36 <kparal> #info  jlaska will reach out to mclasen for thoughts on F-13 fit'n'finish test days
16:22:41 <wwoods> kparal: also we can ask adamw/rhe (whenever they are around) to put a post on the planet if they have anything new and shiny to talk about
16:22:57 <kparal> wwoods: good idea
16:22:59 <maxamillion> kparal: anytime ;)
16:23:13 <cwickert> here is the link to the LXDE mailing list ticket: https://fedorahosted.org/fedora-infrastructure/ticket/1921
16:23:22 <kparal> #link https://fedorahosted.org/fedora-infrastructure/ticket/1921
16:23:28 <cwickert> thanks
16:23:40 <kparal> jlaska or mclasen here?
16:23:54 <kparal> seems not, let's reschedule
16:24:01 <kparal> #action  jlaska will reach out to mclasen for thoughts on F-13 fit'n'finish test days
16:24:12 <jlaska> kparal: I updated my status on the wiki .
16:24:17 <jlaska> just a bit late for updates sorry :(
16:24:32 <kparal> jlaska: oh sorry, didn't refresh
16:24:48 <kparal> so update from jlaska:  Ideas posted to Talk:QA/Fedora_13_test_days.  A main fit'n'finish track is likely not in plan for F-13.
16:24:54 <jlaska> kparal: no worries ... I was late to post :(
16:25:03 <kparal> #link https://fedoraproject.org/wiki/Talk:QA/Fedora_13_test_days
16:25:32 <kparal> so it seems there will be no main fit'n'finish track for F13
16:25:58 <kparal> another item
16:26:03 <kparal> #info jlaska to reach out ot fedora-{test,devel}-list for trading reviews
16:26:14 <kparal> update from jlaska:  Request sent, see https://www.redhat.com/archives/fedora-devel-list/2010-January/msg00127.html
16:26:22 <kparal> #link https://www.redhat.com/archives/fedora-devel-list/2010-January/msg00127.html
16:26:42 <jlaska> kparal: I'm still looking for some help there ... so if anyone is interested in the first of many package reviews related to autoqa ... this is a nice way to help the project
16:27:07 <kparal> jlaska: I think pmuller offered some package review, am I right?
16:27:26 <wwoods> oh yeah, so all the lists have moved to lists.fedoraproject.org
16:27:34 <wwoods> so: http://lists.fedoraproject.org/pipermail/devel/2010-January/043856.html
16:27:40 <kparal> ah
16:27:41 <wwoods> same message, just in the new location
16:27:47 <kparal> #link http://lists.fedoraproject.org/pipermail/devel/2010-January/043856.html
16:27:54 <kparal> thanks wwoods
16:28:12 <jlaska> kparal: oh I musted have missed any comments from pmuller
16:28:19 <jlaska> kparal: is this for beakerlib review or for autotest-client?
16:28:37 <kparal> jlaska: I heard something on the conference call we had about beakerlib
16:28:44 <kparal> jlaska: but I may be wrong
16:28:50 <jlaska> kparal: oh right ... you're right ... that should be posted soon
16:29:36 <kparal> ok, if anyone interested in package reviewing, you know where to go
16:29:42 <kparal> last action item
16:29:46 <kparal> #info jlaska to reach out to beland for guidance/ideas on how to document the process (or point to existing documentation) for how bugs are noted (common_bugs, release notes, install guide etc...) How to determine which bugs land in which place
16:30:01 <kparal> no action taken on that yet, so just reschedule
16:30:06 <kparal> #action jlaska to reach out to beland for guidance/ideas on how to document the process (or point to existing documentation) for how bugs are noted (common_bugs, release notes, install guide etc...) How to determine which bugs land in which place
16:30:23 <kparal> and now for something completely different
16:30:28 <kparal> #topic AutoQA project update
16:30:50 <kparal> wwoods: any news on your front?
16:31:02 <kparal> (save me from typing for some time :))
16:31:11 <wwoods> heh! let's see
16:31:35 <wwoods> mostly I've been: 1) filing/updating tickets for future work with respect to installation testing
16:32:00 <wwoods> we have a new(ish) milestone: https://fedorahosted.org/autoqa/milestone/Automate%20installation%20test%20plan
16:32:18 <kparal> #topic AutoQA project update - install automation
16:32:25 <kparal> #link https://fedorahosted.org/autoqa/milestone/Automate%20installation%20test%20plan
16:32:28 <wwoods> the tickets (mostly) outline the work that will need to be done to lay groundwork for automating the installation test plan
16:32:45 <wwoods> there's some improvements needed in our little autoqa virtguest library
16:32:53 <kparal> #info wwoods updated tickets regarding install automation
16:32:54 <wwoods> and some other setup code and things
16:33:25 <wwoods> mostly that was from some discussions at FUDCon and the documentation sprint just before the new year
16:33:41 <wwoods> I don't expect that we'll begin work on that stuff *immediately*
16:34:08 <wwoods> the autoqa depcheck test(s) are coming first
16:34:14 <wwoods> that's:
16:34:15 <wwoods> https://fedorahosted.org/autoqa/milestone/autoqa%20depcheck
16:34:24 <kparal> #topic AutoQA project update - Deps/conflicts prevention
16:34:33 <kparal> # link https://fedorahosted.org/autoqa/milestone/autoqa%20depcheck
16:34:37 <kparal> #link https://fedorahosted.org/autoqa/milestone/autoqa%20depcheck
16:34:45 <wwoods> this requires a new hook - post-bodhi-update - which should trigger when someone files a new update request in bodhi
16:34:58 <wwoods> I've been working with lmacken to figure out how to query for that info
16:35:06 <wwoods> (and fix some bugs in the bodhi API)
16:35:23 <kparal> #info wwoods working with lmacken to figure out how to query bodhi
16:35:24 <lmacken> I'll be hacking on the API today, and hopefully have a new release into staging today/tomorrow
16:35:33 <wwoods> lmacken: awesome, thank you
16:35:38 <kparal> very nice
16:35:47 <maxamillion> ninja status
16:35:50 <maxamillion> :P
16:36:14 <wwoods> so that milestone is missing the important ticket - actually write the depcheck test
16:36:19 <wwoods> I'll file that in a bit
16:36:26 <kparal> :)
16:36:45 <kparal> ok, thank you for the info wwoods
16:36:49 <lmacken> wwoods: so we'll probably want bodhi to prevent an updates push if there is an autoqa depcheck job in progress, or if some updates failed it, I assume?
16:36:56 <wwoods> so that's what I'm working on at the moment - that and working with kparal on rpmguard, which was just merged into the master branch of autoqa
16:37:15 <wwoods> lmacken: each update will be checked individually - we'll want some way to flag updates which fail the test
16:37:22 <wwoods> and/or prevent them from being pushed
16:37:41 <lmacken> wwoods: gotcha.  will autoQA have a JSON API, or somethign?
16:37:45 <wwoods> I assume the simple implementation would just be to add negative karma from autoqa
16:37:48 <lmacken> or will bodhi have to listen to the AMQP bus?
16:38:03 <lmacken> ah, having autoqa add a comment to bodhi would be great
16:38:03 <kparal> wwoods: is satisfactory just not to push it automatically, or you want the owner to prevent push until some QA approves or issue is fixed?
16:38:07 <lmacken> that would make things much easier
16:38:10 <Oxf13> well autoqa right now is all about testing, not so much with the reporting right?
16:38:27 <Oxf13> we still need to have a test results tracking software?
16:38:35 <wwoods> right - currently autoqa doesn't really have anything to query
16:38:50 <wwoods> in the future it'll be emitting AMQP messages on test completion, I'm sure
16:39:17 <wwoods> but that's the Glorious Future and we're stuck in the grim present
16:39:21 <Oxf13> and our test results software would be listening on the bus to get it's updates
16:39:45 <wwoods> so: initial simple implementation would just be to have the test give karma and a useful message
16:40:00 <kparal> #info Glorious Future will be better than grim present
16:40:16 <wwoods> near-future we may want a special way for autoqa to mark an update as bad, or to give autoqa power to retract a request
16:40:22 <wwoods> kparal: ha
16:40:28 <kparal> :)
16:41:02 <wwoods> lmacken: so give some thought to a good way to implement that and we'll talk more about it once there's actually a working hook/test
16:41:23 <lmacken> wwoods: sounds good
16:41:35 <wwoods> on the koji side we have a vague idea how to implement it - have new builds land in, say, dist-blah-candidate-untested
16:41:54 <wwoods> and autoqa will have the power to move packages that pass their tests to dist-blah-candidate
16:42:24 <Oxf13> (or something that listens to autoqa output)
16:42:26 <wwoods> right
16:42:28 <lmacken> hmm... we could also move tested builds to dist-f13-updates-tested, or something, and only mash autoqa-tested tags
16:42:33 <lmacken> from a bodhi perspective
16:42:47 <wwoods> lmacken: interesting - we'll talk more about this later, I'm sure
16:42:54 <lmacken> yeah, I'll churn on it
16:43:09 <kparal> ok, thank you guys
16:43:20 <kparal> well, now I will say a few words about my stuff
16:43:30 <kparal> #topic AutoQA project update - rpmguard package comparison
16:43:44 <kparal> so, there are some updates on rpmguard
16:43:58 <kparal> first of all it's finally merged in master, thanks to wwoods
16:44:24 <kparal> so it's closer to be really working then ever
16:44:25 <wwoods> \o/
16:44:38 <kparal> #info rpmguard merged in master
16:44:49 <kparal> also, I have created a small blogpost about recent updates
16:44:51 <kparal> #link http://kparal.wordpress.com/2010/01/11/rpmguard-a-wiki-page-and-a-new-output-format/
16:45:31 <kparal> I have created a separate wiki page for rpmguard, so it should be easier now to collect all basic data - what, where, why, when
16:45:33 <kparal> :)
16:45:36 <kparal> #link https://fedorahosted.org/autoqa/wiki/rpmguard
16:45:54 <kparal> there's even some origin of a documentation
16:46:07 <kparal> I have also changed the output format to be more rpmlint-like
16:46:49 <kparal> the small task ahead is to start sending output to autoqa-results
16:46:51 * jlaska a fan of the updated output format :)
16:47:16 <kparal> and the big task ahead is to publish results in some other format then 50 emails/day
16:47:21 <wwoods> heh
16:47:36 <kparal> which I have started to discuss in autoqa-devel today
16:48:01 <kparal> ok, that would be about rpmguard
16:48:11 <kparal> #topic AutoQA project update - packaging/deployment
16:48:20 <kparal> there is some update from jlaska about packaging autoqa
16:48:27 <kparal> let's copy n paste it here
16:48:41 <kparal> autotest-client - awaiting review - RHBZ #548522
16:48:54 <kparal> autoqa - packaged (see autoqa-0.3-2.fc12.src.rpm), will submit once autotest-client is accepted
16:49:00 <kparal> gwt-* - investigating scope of packaging needed
16:49:05 <kparal> autotest - packaged (see autotest-0.11.0-4.el5.src.rpm, will submit for review after gwt* accepted
16:49:31 <kparal> so, the things are moving forward, good job, jlaska :)
16:49:45 <jlaska> packaging gwt's deps is going to be a nightmare
16:49:51 <Oxf13> yes
16:49:58 <Oxf13> because each dep will spawn another 2 or 3 deps
16:50:03 <wwoods> blarg
16:50:03 <jlaska> I'll be soliciting help on that task
16:50:04 <Oxf13> if not more
16:50:07 <kparal> let's employ ghostbusters
16:50:11 <wwoods> is it worth trying to do a sprint or something?
16:50:19 <jlaska> wwoods: yeah ... that was one suggestion
16:50:34 * wwoods thinks of it as more of a siege
16:50:36 <jlaska> wwoods: once I close our scoping all the packaging changes ... that would be one good idea to tackle it
16:50:55 <kparal> #info jlaska considering a sprint about packaging gwt
16:51:37 <kparal> sorry, I have been disconnected
16:51:51 <maxamillion> jlaska: did anyone review your autotest-client package yet?
16:52:07 <jlaska> maxamillion: there was an updated comment this morning ... I'll be checking that shortly
16:53:01 * jlaska notes ... meeting conflict ended
16:53:02 <maxamillion> jlaska: ok, let me know because if not then I should be able to get a formal review in this evening (*should*)
16:53:20 <jlaska> maxamillion: that's much appreciated, I'll let you know
16:53:34 <maxamillion> jlaska: no problem, sounds good
16:53:56 <kparal> ok, seems like we go to open discussion
16:54:00 <kparal> #topic Open discussion
16:54:16 <kparal> anyone have a topic he/she wants to discuss?
16:56:16 <kparal> ok, thank you everyone, see you on next meeting
16:56:22 <kparal> it seems I didn't even made such a mess as a chairman as I supposed :)
16:56:26 <kparal> #endmeeting