fedora-meeting
LOGS
14:03:46 <rdieter> #startmeeting KDE SIG Meeting -- http://fedoraproject.org/wiki/SIGs/KDE/Meetings/2009-12-22
14:03:46 <zodbot> Meeting started Tue Dec 22 14:03:46 2009 UTC.  The chair is rdieter. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:03:46 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
14:03:58 <rdieter> #chair Kevin_Kofler jreznik than
14:03:58 <zodbot> Current chairs: Kevin_Kofler jreznik rdieter than
14:04:07 <rdieter> #topic Init
14:04:13 <rdieter> who's present today?
14:04:15 <Kevin_Kofler> Present.
14:04:18 <SMParrish> Here
14:04:21 <jreznik> here
14:04:53 <rdieter> than: ping
14:04:59 <svahl> present
14:05:11 <rdieter> is ltinkl ping'able anywhere ?
14:05:56 * jreznik is checking jabber
14:06:14 <jreznik> rdieter: offline on jabber too
14:06:20 <rdieter> ok
14:06:25 <rdieter> #topic Agenda
14:06:32 <rdieter> I added a few items to the agenda, anything else ?
14:06:41 <rdieter> https://fedoraproject.org/wiki/SIGs/KDE/Meetings/2009-12-22#Agenda
14:08:03 <Kevin_Kofler> Have you given up on that wacky "fewer updates" idea already? :-)
14:08:17 <rdieter> no
14:08:21 <Kevin_Kofler> I guess we should wait for the outcome of Fedora-wide discussions about updates before making any decision there.
14:08:23 <svahl> was on the agenda last week but time was up: http://fedoraproject.org/wiki/SIGs/KDE/Stability_Proposal ?
14:08:24 <jreznik> I have one idea for default comps too
14:08:45 <rdieter> Kevin_Kofler: you're probably right, I think that's a good idea
14:08:50 <SMParrish> I haven't given up either
14:09:09 <jreznik> yep - it's better to force reasonable updates over Fedora
14:09:27 <jreznik> we are very open to updates, other teams are really very closed...
14:09:35 <rdieter> jreznik: what for comps ?
14:11:18 <jreznik> rdieter: cyrus-sasl-gssapi or maybe as direct requirement for knetwork? lot of Red Hat people are using kerberos in kmail and this package is missing - it should be in default installation
14:11:46 <jreznik> just an idea - today another colleague asked me
14:11:50 <rdieter> k
14:12:05 <Kevin_Kofler> Should be a dep of kdepim, not kdenetwork, if it's kmail which uses it, shouldn't it?
14:12:41 <jreznik> Kevin_Kofler: ah sorry, kdepim (kmail)
14:13:10 <rdieter> ok, let's get started...
14:13:21 <rdieter> #topic kcm_touchpad in defaults for comps
14:13:36 <rdieter> this is a no-brainer to me, any objections ?
14:13:42 <jreznik> +1
14:14:10 <SMParrish> +1
14:14:12 <Kevin_Kofler> Same, here, clear +1, should be there by default.
14:14:17 <svahl> +1
14:14:24 <rdieter> +1
14:14:29 <rdieter> ok, I'll add it after meeting
14:14:45 <rdieter> #topic kde-4.3.85 and kdevplatform/kdevelop4 for kde-redhat
14:15:05 <rdieter> I munged these together, just an fyi, kde-4.3.85 is all built for f12 in kde-unstable repo
14:15:13 <Kevin_Kofler> kdevplatform should just be handled as a stable thing.
14:15:21 <Kevin_Kofler> It's in beta, but it doesn't replace or conflict with anything.
14:15:26 <Kevin_Kofler> And krazy2 can use it.
14:15:27 <rdieter> tried kdevplatform/kdevelop , but it conflicts with kdelibs-4.3.85 somewhere
14:15:37 <rdieter> ok
14:15:45 <Kevin_Kofler> I think in fact it already does.
14:16:01 <Kevin_Kofler> There is some old beta of kdevplatform which mathstuf pushed out already.
14:16:06 <rdieter> I filed a bug about the conflict
14:16:16 <rdieter> bug #549713
14:16:17 <buggbot> Bug https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=549713 medium, low, ---, mathstuf, NEW, kdevplatform/kdevelop : update needed for kde-4.3.85+
14:16:24 <Kevin_Kofler> Isn't there a bug filed for that already?
14:16:39 <rdieter> maybe, sorry, I didn't look for dups yet
14:17:09 <rdieter> when mathstuf is around, we can ask him to do kdevplatform as an update at least, right ?
14:17:19 <Kevin_Kofler> kdevplatform-0.9.95-0.3.beta5.fc12 is in dist-f12 already (and the .fc11 in dist-f11-updates).
14:17:30 <rdieter> ah, ok.
14:18:02 <rdieter> so, the proposal was for me to build kdevelop against that on/for kde-4.3.4 ?
14:18:24 <Kevin_Kofler> https://bugzilla.redhat.com/show_bug.cgi?id=541690
14:18:25 <buggbot> Bug 541690: medium, low, ---, mathstuf, NEW, kdevplatform: file conflict with kdelibs (FindKDevPlatform.cmake)
14:18:26 <rdieter> or should we wait for the 4.3.85 conflict to get resolved ?
14:18:31 <Kevin_Kofler> I closed your bug as a dupe of that.
14:18:35 <rdieter> k
14:18:48 <jreznik> is it really worth to try to solve it now?
14:19:16 <jreznik> if you have time, feel free to do it :)
14:19:16 <Kevin_Kofler> And the next question is, will we ship F13 with KDevelop 4?
14:19:32 <rdieter> Kevin_Kofler: yes, it's in rawhide, that's the plan as I understand it
14:21:18 <rdieter> I guess we can move on then...
14:21:30 <rdieter> #topic comps: cyrus-sasl-gssapi or maybe as direct requirement for kdepim(kmail)
14:21:48 <rdieter> jreznik mentioned many krb-using colleagues need this
14:22:23 <rdieter> not sure if it warrants a hard dep though, I'd venture a vast majority of users don't need krb support
14:22:51 <rdieter> so I'd prefer some comps-based solution here myself
14:23:03 <jreznik> rdieter: I'm one of that users :)
14:23:31 <jreznik> problem is that kmail just returns server error and doesn't help how to solve this problem
14:23:54 <rdieter> heh, one problem is that cyrus-sasl-gssapi isn't in comps *at all* right now.
14:24:56 <rdieter> looks like other krb5-based stuff is in comps base group, perhaps this should be there too.
14:25:16 <rdieter> I'll ping other comps-ninja's after meeting to ask for advice, and help take care of this one too
14:25:21 <jreznik> thanks
14:25:24 <rdieter> any other comments ?
14:26:06 <jreznik> it's nice that more and more rh people are moving to kde ;-)
14:26:22 <svahl> I would also prefer comps. Only add packages as hard deps when there is no other choice
14:26:42 <rdieter> #topic kde-plasma-* : yawp, stasks needed rebuilds for 4.3.85, need to test all kde-plasma-* bits
14:27:08 <rdieter> ok, next, looks like a bunch of kde-plasma-* bits need testing with kde-4.4(beta).  at least stasks,yawp required rebuilding to be functional
14:27:12 <svahl> rdieter: live images at last agenda item?
14:27:33 <svahl> s/at/as/
14:27:39 <jreznik> uf, 4.4 changes plasma api again? it should be stable... ok, I have to try 4.4b2
14:27:41 <rdieter> oops, sorry, we'll get that next. (I'll purposely save the statibility proposal for last)
14:27:52 <svahl> ok :)
14:28:02 <rdieter> jreznik: unsure, probably best to ping some plasma folks for advice/council here too
14:28:33 <Kevin_Kofler> Might be Qt's fault too.
14:28:35 <rdieter> anyone on rawhide or f12 + kde-unstable can test this... any takers ?
14:28:44 <Kevin_Kofler> I think there's some silent ABI breakage in QGraphicsView.
14:28:49 <Kevin_Kofler> This'll obviously hit plasmoids.
14:28:53 <Kevin_Kofler> It also hits Konquest.
14:28:54 <rdieter> Kevin_Kofler: <nod>
14:29:12 <Kevin_Kofler> thomasj reported a crash in Konquest 4.3.4 with Qt 4.6.
14:29:33 <Kevin_Kofler> (i.e. built with 4.5, run with 4.6)
14:30:07 <rdieter> we can leave that task open for now...
14:30:51 <rdieter> #help need help testing all kde-plasma-* applets against kde-4.4, file bugs, help investigate qt46/kde44 incompatibilities (QGraphicsView?)
14:31:11 <rdieter> #topic kde-plasma-* : yawp, stasks needed rebuilds for 4.3.85, need to test all kde-plasma-* bits
14:31:13 <rdieter> arg
14:31:29 <rdieter> #topic https://fedoraproject.org/wiki/SIGs/KDE/Meetings/2009-12-22/current_live_image_issues
14:31:34 <rdieter> svahl ... ?
14:31:54 <svahl> I've written some notes on a several page: http://fedoraproject.org/wiki/SIGs/KDE/Meetings/2009-12-22/current_live_image_issues
14:32:09 <Kevin_Kofler> The list of stuff requiring gtk2 is very incomplete.
14:32:14 <svahl> first one is that kdm doesn't autologin anymore
14:32:17 <Kevin_Kofler> It lists only explicit deps, not soname deps.
14:32:24 <svahl> Kevin_Kofler: right. it was just the output of rpm
14:32:29 <rdieter> Kevin_Kofler: yeah, that's anything depending on gtk2 directly
14:32:29 <Kevin_Kofler> There's tons of stuff requiring gtk2, we can't get rid of gtk2.
14:32:46 <svahl> sure. Just wanted to list these
14:32:46 <rdieter> but nice try. :)
14:32:47 <Kevin_Kofler> liveinst requires it, among other things.
14:33:10 <svahl> from time to time there appears some unneeded dep in this list
14:33:17 <rdieter> autologin needs some love... yeah.  that's a weird one... may be related to the hal/kdm issue we saw in f12 too
14:33:27 <svahl> https://bugzilla.redhat.com/show_bug.cgi?id=549687
14:33:29 <buggbot> Bug 549687: medium, low, ---, than, NEW, kdm: no autologin on first start
14:33:52 <svahl> second thing is that there are many notifications on first start: http://www.deadbabylon.de/files/F13-KDE-011-1.png
14:34:12 <rdieter> svahl: for kdm, to clarify, you can't login at all until you kill(and restart) kdm ?
14:34:35 <svahl> rdieter: no. Just hit "enter" and it will login
14:34:47 <rdieter> ok, so what's with the comment in the bug about killing kdm ?
14:34:47 <svahl> if I kill kdm it will autologin
14:35:03 <rdieter> that's wierd, ok.
14:35:07 <Kevin_Kofler> The HAL update is also reported to break GDM.
14:35:13 <Kevin_Kofler> So maybe it's screwing up PAM in some way.
14:35:25 <Kevin_Kofler> Userlist displaying in GDM fails with the new HAL for whatever stupid reason.
14:35:30 <Kevin_Kofler> Maybe other stuff too.
14:35:35 <rdieter> our hal issue at least reported to /var/log/messages that libckconnector failed
14:35:38 <Kevin_Kofler> I don't know how HAL can screw up display managers.
14:35:53 <rdieter> but svahl said he saw nothing in /var/log/messages
14:36:22 <svahl> but maybe I missed sth. I'll recheck after the meeting (and/or attacht messages to the bug)
14:36:30 <rdieter> ok, thanks.
14:36:40 <Kevin_Kofler> Re the notifications, looks like we need to silence those global shortcut notifications.
14:36:59 <rdieter> Kevin_Kofler: nod, those are a bit rediculous
14:37:00 <jreznik> I'm on KDM crashing laptop now - but I'm not going to test it right now :)
14:37:36 <rdieter> svahl: any bug on the notifications (yet)?
14:37:47 <svahl> rdieter: no, not yet
14:37:56 <svahl> I can file one if needed
14:38:04 <rdieter> if not, let's open one to track the issue, and task someone to talk to upstream about how best to resolve that bit of insanity
14:38:19 <Kevin_Kofler> Re the "Packages are more and more" issues, there's hope that we'll see LZMA squashfs for F13.
14:38:26 <Kevin_Kofler> If that works out, we'll have plenty of room.
14:38:37 <Kevin_Kofler> In addition, the removal of kdelibs3 is freeing us up some room.
14:38:39 <rdieter> Kevin_Kofler: last rumor I heard was that it was looking unlikely... fwiw.
14:38:57 <svahl> hopefully, yes. atm virtuoso-opensource kills most of the addon/extragear packages
14:39:04 <rdieter> we can still consider making a bigger image ( > cd sized) :)
14:39:34 <Kevin_Kofler> Last FESCo was told is that it was being worked on.
14:39:49 <Kevin_Kofler> But there was some uncertainty due to upstream acceptance etc.
14:39:49 <rdieter> ok, cool.
14:39:50 <jreznik> who uses CD for live CD image? shouldn't be better to call it liveUSB image? :)
14:40:03 <Kevin_Kofler> Your news might be newer.
14:40:07 <rdieter> well, they're called live images
14:40:17 <Kevin_Kofler> I should try to nag the folks working on it and put some pressure on them.
14:40:18 <rdieter> ours just happens to fit on a cd. :)
14:40:29 <Kevin_Kofler> We really need LZMA squashfs ASAP.
14:40:41 <Kevin_Kofler> I don't give a darn if it's upstream or not.
14:41:33 <rdieter> it matters of what we use ends up not being compat with what upstream eventually accepts
14:41:40 <rdieter> s/of what/if what/
14:41:54 <Kevin_Kofler> Why would it? Live images cannot be used for upgrades anyway.
14:41:56 <rdieter> anywho, that's our of our hands.
14:42:07 <Kevin_Kofler> So they need to be readable only by the release which is on them.
14:42:13 <rdieter> true
14:42:21 <rdieter> svahl: anything else or is that it ?
14:42:36 <Kevin_Kofler> The wiki page also lists plasma-netbook issues.
14:42:40 <svahl> maybe the plasma-netbook issues.
14:42:52 <rdieter> svahl: to be clear, our current image as already free of qt3/kdelibs3, and we're still too tight for space ?
14:42:52 <svahl> all plasmoids are broken: http://www.deadbabylon.de/files/F13-KDE-011-2.png
14:43:11 <svahl> rdieter: yes. there is no qt3/kde3 on it
14:43:15 <rdieter> ok
14:43:26 <Kevin_Kofler> rdieter: Yes. :-( akonadi and virtuoso-opensource eat a lot of room.
14:44:02 <rdieter> true, I mentioned it before, those will really be a pain for the live image
14:44:24 <rdieter> 1.  akonadi db should be pre-initialized (ie, prior to first autologin)
14:44:44 <Kevin_Kofler> The missing plasmoids for plasma-netbooks are probably in kdeplasma-addons.
14:44:46 <Kevin_Kofler> I know weather is.
14:44:47 <rdieter> 2.  ideally same for virtuoso, but perhaps we can get away with simply disabling nepomuk in the live session
14:45:00 <Kevin_Kofler> So there's yet another package we'll need to ship if we want to support plasma-netbook. :-/
14:45:08 <Kevin_Kofler> And we're already strapped for space.
14:45:20 <svahl> Kevin_Kofler: oh, right. just forgotten about kdeplasma-addons
14:45:47 <rdieter> Ideally, plasma-netbook related stuff would be split out separately (and perhaps not included on default live image)
14:45:49 <Kevin_Kofler> Stability will hopefully improve from now to the F13 release.
14:45:50 <svahl> rdieter: nepomuk is already disabled on the live images
14:46:20 <rdieter> svahl: but I want to re-enable it... :)  https://bugzilla.redhat.com/show_bug.cgi?id=549436
14:46:21 <buggbot> Bug 549436: medium, low, ---, rdieter, NEW, kde-settings: enable nepomuk by default (?_)
14:46:35 <SMParrish> I envisioned plasma-netbook to be a seperate spin not part of the kde live image
14:46:43 <rdieter> SMParrish: me too
14:46:47 <svahl> rdieter: also on the _running_ live images?
14:47:06 <rdieter> svahl: no, "but perhaps we can get away with simply disabling nepomuk in the live session"
14:47:37 <rdieter> for the live image,nepomuk makes little sense
14:47:39 <svahl> SMParrish: I would also prefer a different spin for netbooks (if its stable enough). And there usb sticks would be more used than cd images, so it could be bigger
14:48:23 <rdieter> Can someone open a new tracker bug for plasma-netbook related issues ?
14:48:27 <Kevin_Kofler> I'd expect a netbook spin to be smaller rather than larger.
14:48:38 <SMParrish> rdieter: I'll open one
14:48:55 <jreznik> svahl: why bigger - I think it can be smaller - just what users need on netbook (netbook is not big PC/laptop)
14:49:02 <rdieter> #action SMParrish to open tracker bug for plasma-netbook related issues
14:49:38 <jreznik> for netbook usage you need browser (90%) of uses cases of netbook
14:49:39 <rdieter> jreznik: point is... we don't have to obsess about being cd-sized anymore
14:50:30 <rdieter> I think we've beaten that topic pretty well, let's move on before we run out of time again. :)
14:50:39 <Kevin_Kofler> We could possibly target 800 MB?
14:50:59 <rdieter> #topic  nepomuk tracker, https://bugzilla.redhat.com/show_bug.cgi?id=nepomuk_disabled : for kde-4.3.x dup or block ?
14:51:00 <buggbot> Bug 549725: medium, low, ---, than, NEW, kdebase-runtime-4.3.x : nepomuk is not supported
14:51:01 <Kevin_Kofler> That fits nicely on a 1 GB USB stick with room for an overlay, and those who really need a CD can use a CD-R90.
14:51:45 <rdieter> Kevin_Kofler: maybe, mind putting that proposal in the wiki somewhere, and take it to fedora-kde list ?
14:51:54 <rdieter> with pros/cons, etc... of course.
14:52:18 <Kevin_Kofler> Obvious con: doesn't fit on a standard CD (only nonstandard CD-R90).
14:52:30 <rdieter> anyway, we're starting to get a bunch of nepomuk related crashers reported.
14:52:34 <Kevin_Kofler> Also less room for overlays on USB sticks.
14:53:10 <rdieter> so, 2 options came to mind...
14:54:05 <rdieter> 1 (preferred by me... I think), dup all bugs to the aforementioned one, highlighting that nepomuk is disabled by default and not supportable
14:54:27 <rdieter> or 2.  a little nicer, keep the bugs open, but block on nepomuk_disabled.
14:54:38 <rdieter> anyone object to the slightly harsher plan 1 ?
14:55:04 <rdieter> or have a more brilliant plan 3 ?
14:55:55 <SMParrish> I prefer option 1
14:56:14 <Kevin_Kofler> I think 1 is OK.
14:56:33 <Kevin_Kofler> It's not pedantically correct as some of those crashes are different.
14:57:05 <rdieter> at least until sesame2 or kde44/virtuoso lands and/or we enable nepomuk by default...
14:57:07 <Kevin_Kofler> But I guess "Nepomuk is just broken with 4.3, reopen if this can be reproduced with 4.4" is OK.
14:57:20 <jreznik> yep
14:57:29 <rdieter> Kevin_Kofler: yeah, that was my thinking
14:57:30 <svahl> Kevin_Kofler: +1
14:57:46 <rdieter> alrighty.
14:58:00 <rdieter> #topic F13Blocker-kde , https://bugzilla.redhat.com/showdependencytree.cgi?id=F13Blocker-kde
14:58:10 <rdieter> just wanted to highlight this handy tracker bug, F13Blocker-kde , https://bugzilla.redhat.com/showdependencytree.cgi?id=F13Blocker-kde
14:58:35 <rdieter> deps in there include the qt46 and kde-4.4 trackers as well
14:58:53 <rdieter> when testing out stuff, make sure to include in that tree, where appropriate.
14:59:19 <rdieter> looks like we're almost out of time, any final comments before we close?
14:59:46 <svahl> do we meet next week?
14:59:47 <rdieter> (yes, we missed the stability proposal... again... maybe next meeting we can slot out at least 10-15 minutes near the beginning...)
14:59:56 <rdieter> svahl: good question.
15:00:21 <Kevin_Kofler> My proposal: defer the stability proposal until the Fedora-wide discussions on updates are complete.
15:00:27 <svahl> I would be there.
15:00:33 <rdieter> I'd say, if we have bodies for a meeting, then ok, else cancel.  who could be here?
15:00:43 <SMParrish> I'll be online
15:00:48 <rdieter> I think I can make it
15:00:58 <Kevin_Kofler> If changes as drastic as only 1 push per month are made, we may need bigger procedure changes than the proposed ones. :-(
15:01:07 <jreznik> Kevin_Kofler: or prepare our own proposal for Fedora wide updates? so we will have something in our hands?
15:01:09 <rdieter> Kevin_Kofler: I would tend to agree, make no decisions before then, yeah.
15:01:21 <Kevin_Kofler> I'll probably be traveling on Dec 29.
15:01:32 <Kevin_Kofler> So I don't think I can attend.
15:01:42 <rdieter> jreznik: dec 29 for you?  aye/nay?
15:02:26 <rdieter> meh, let's just cancel.  if y'all want to meet/discuss anything, we can do it informally whenever in #fedora-kde in the meantime.
15:02:38 <rdieter> let's officially enjoy the holidays
15:02:48 <svahl> ok :)
15:03:12 <rdieter> cool
15:03:25 <rdieter> #info  next week, dec 29 meeting cancelled.  happy holidays!
15:03:39 <rdieter> thanks everybody, wrap up.
15:03:47 <jreznik> not sure but I'll be online whole holidays :)
15:03:50 <rdieter> #endmeeting