fedora-meeting
LOGS
00:00:00 <Sparks> #startmeeting Docs Project Meeting - Agenda: http://fedoraproject.org/wiki/Docs_Project_meetings
00:00:00 <zodbot> Meeting started Thu Dec 10 00:00:00 2009 UTC.  The chair is Sparks. Information about MeetBot at http://wiki.debian.org/MeetBot.
00:00:00 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
00:00:07 <Sparks> #topic Roll Call
00:00:08 * Sparks 
00:00:14 * Sparks 
00:00:27 * jjmcd .
00:00:55 * radsy .
00:02:56 * Sparks gives everyone a few more minutes to arrive.
00:03:37 <radsy> rudi not in the office yet
00:04:06 <Sparks> slacker
00:04:55 <Sparks> Okay, let's get started.
00:05:00 <Sparks> #topic Release Notes
00:05:09 <Sparks> Discussion of Yelp vs. HTML
00:05:30 <Sparks> jjmcd: Anything else on this?
00:05:42 <jjmcd> bah
00:05:46 <jjmcd> wrong window
00:05:53 <jjmcd> we've always done it that way
00:06:11 <jjmcd> To tell the truth, that is probably the largest reason we are still using yelp
00:06:26 <jjmcd> Now, it does put our release notes a little more up front
00:06:52 <jjmcd> And now that we have a way to select language for html, yelp loses a big advantage it had
00:06:56 <Sparks> I wonder if people read stuff that is on their system or if they read it online.
00:07:07 <jjmcd> I dunno
00:07:16 * Sparks would really like to get limesurvey reviewed so he could answer some of these questions.
00:07:38 <jjmcd> We used to put a ton of stuff in /usr/share/doc with no links or anything, so it seems pretty unlikely that someone would find it
00:07:44 <Sparks> Yes
00:07:47 <Sparks> which is not good.
00:08:15 <jjmcd> Although, I guess in the distant past I would rummage around to see what is there ... don't know how many others do that tho
00:08:52 <jjmcd> radsy, FYI, I sent Sparks a prog to package a multilang publican html
00:08:55 <Sparks> I'm against blindly putting documentation on someone's computer and not linking to it from the GUI somehow
00:09:12 <jjmcd> Well, not everyone is such a huge fan of the gui
00:09:25 <jjmcd> ANd EVERY application has unlinked dox in /usr/share/doc
00:09:35 <jjmcd> SO you do know where to look
00:09:37 <jjmcd> or should
00:09:50 <Sparks> Well, if you aren't using a gui then you already know your way around /usr
00:10:01 <jjmcd> I would hate to have a menu item for every sub of /usr/share/doc and /usr/share/doc/HTML
00:10:16 <jjmcd> There are literally thousands of them
00:10:21 <Sparks> I'm talking about OUR documentation
00:10:37 <jjmcd> So knowing where they are is almost as good as having a menu choice, and less clutter
00:10:40 <jjmcd> Well, yeah
00:10:48 <jjmcd> I like having RN on the menu
00:11:01 <Sparks> It would be a horrible experience for someone to install the admin guide and then have it not show up on the desktop somewhere
00:11:30 <jjmcd> I dunno, I install things I don't expect to see on the desktop
00:11:36 <Sparks> Well, I have mixed feelings about Yelp versus HTML
00:11:54 <jjmcd> Yeah, there's a little to be said fo each
00:11:58 <Sparks> Yelp is good at what it does... but only does it for one of our desktops
00:12:25 <jjmcd> No reason not to run yelp from kde tho.  We just don't put the link there
00:12:59 <jjmcd> Altho maybe it pulls in a lot of crap like every KDE app does on a gnome system
00:13:18 <Sparks> yeah
00:13:34 <Sparks> Well, I hope to see some promise in the March meeting... if that happens
00:13:40 <jjmcd> It would be good if rudi was here
00:14:22 <jjmcd> That would really be good.  But even assuming it is all rebecca at sunnybrook farms, there are still advantages to html
00:14:45 <jjmcd> One prob w/yelp is it reads all the xml files when you open the doc
00:15:08 <jjmcd> It displays the first file before it is done, but on a big doc, it keeps the cpu pinned for a long time
00:15:47 <Sparks> I think that was something that was going to be remedied
00:16:17 <jjmcd> Well, it might help, but it also doesn't do the index, which is now pretty important on release notes
00:16:49 <jjmcd> Because the yum groups make no sense, that is the only way you can find things
00:17:09 <Sparks> Have we filed bugs upstream for all these problems?
00:17:45 <jjmcd> I've filed bugs on Fedora for those apps, but not upstream.  I assume that is the maintainer's role
00:18:34 <Sparks> Okay.  As long as we'
00:18:48 <Sparks> they haven't been filed...  :)
00:19:47 <Sparks> Okay, anything else on this topic?
00:20:01 <jjmcd> I did update the doc on that packaging app a couple times on fedorapeople dunno if you saw that
00:20:15 <jjmcd> added some pictures to hopefully make a little more sense
00:20:44 <Sparks> cool.  I haven't had a chance to surf over there lately.
00:21:08 <jjmcd> I need to find some guides to play with
00:21:20 <jjmcd> but most either don't build or have no translations
00:22:34 <Sparks> Yeah
00:22:49 <Sparks> Okay, moving on...
00:22:54 <Sparks> #topic Status on CMS (Zikula)
00:23:00 <Sparks> #link https://fedoraproject.org/wiki/Zikula#Module_status
00:23:20 <Sparks> Apparently a lot of work was completed at FUDCon.
00:23:31 * Sparks wishes ke4qqq could be here tonight.
00:23:52 <Sparks> I finally got menutree squared away and pushed.
00:24:10 <Sparks> But it was a little premature as ke4qqq hasn't gotten zikula 1.2 out the door, yet.  Opps.
00:24:19 <radsy> is there a live demo of this somewhere still?
00:24:46 <Sparks> I'm working MediaAttach, though, and am planning on yanking out the bad bits and packaging the rest.  We can see, then, if it breaks.
00:24:56 <Sparks> radsy: mchua I think has one up for Insight.
00:26:52 <Sparks> Anyone have any questions?
00:27:47 <Sparks> Okay, moving on...
00:27:53 <Sparks> #topic Guide Status
00:28:00 <jjmcd> what happened to 543540
00:28:05 <Sparks> Anyone have any guides they want to discuss?
00:28:11 <Sparks> .bug 543540
00:28:12 <buggbot> Bug https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=543540 medium, low, ---, rlandman, ASSIGNED, Usability of http://docs.fedoraproject.org/  is poor
00:28:12 <zodbot> Sparks: Bug 543540 Usability of http://docs.fedoraproject.org/ is poor - https://bugzilla.redhat.com/show_bug.cgi?id=543540
00:28:14 <buggbot> Bug 543540: medium, low, ---, rlandman, ASSIGNED, Usability of http://docs.fedoraproject.org/  is poor
00:28:34 <jjmcd> was on the schedule b4 zik only reason i asked
00:28:43 <Sparks> jjmcd: I thought that was from last week so I just removed it.
00:28:52 <jjmcd> ah,ok
00:29:06 <radsy> it's likely to change again before zikula?
00:29:12 <Sparks> jjmcd: Unless you have something further on it.  I don't really see a resolution to it until Zikula is fielded.
00:29:29 <jjmcd> I see Paul wanted us to discuss the sked but that will take some time before we can have a meaningful discussion
00:29:38 <radsy> i find it pretty usable as it is
00:29:46 <jjmcd> I expect zikula won't help
00:29:49 <Sparks> I find it MUCH more useable .
00:30:20 <jjmcd> Altho, I like the original idea of the initial single dropdown for a language
00:31:16 <radsy> imo the focus should be on getting zikula up instead of another re-design
00:31:38 <radsy> re-arranging deck chairs...
00:31:42 <jjmcd> I tend to agree, but if anything, zikula will make that harder
00:32:18 <jjmcd> The problem is what it should look like.  At best Zikula will be equivalent to raw php.  More likely it will be a constraint
00:32:54 <jjmcd> So I'm not so sure the redesign is wasted.  Although, having Zikula in  hand may avoid some dead ends
00:33:08 <Sparks> I think we should get some of the design folks in on this dicussion once we get Zikula up and running
00:33:23 <jjmcd> Yes, I think that is the best plan
00:33:24 <Sparks> Right now we don't have the base setup to build on
00:33:43 <Sparks> Okay, any guide issues?
00:33:45 <jjmcd> Assuming we will EVER see Zikula up and running
00:34:06 <Sparks> #topic New Guides
00:34:12 <Sparks> Any new guides coming out>?
00:34:32 <jjmcd> I made a little more headway on ARG
00:34:37 <Sparks> ARG?
00:34:38 <jjmcd> OH, yes
00:34:39 <Sparks> Oh
00:34:44 <Sparks> Amateur Radio Guide
00:34:50 <jjmcd> convert -alpha on
00:34:58 <jjmcd> Makes the colors right in pdf
00:35:04 <Sparks> cool
00:35:12 <radsy> i'm kicking around the idea of a solaris -> fedora/rhel sysadmin/migration guide
00:35:31 <radsy> just to highlight differences
00:35:59 <Sparks> radsy: You getting this from the new Sun Admin -> RHCE class I saw today?
00:36:06 <radsy> but RHEL duties for already existing stuff are taking a lot of my time right now
00:36:12 <radsy> no Sparks?
00:36:18 <Sparks> ha
00:36:34 <Sparks> Yeah, there's a new Sun admin -> RHCE class out there...
00:36:49 <radsy> damn it, beaten ;)
00:37:01 * Sparks hasn't touched a lot of Solaris boxes lately.
00:37:23 <Sparks> Okay... moving onward...
00:37:23 <jjmcd> Didn't that run on PDP-4's or something?
00:37:26 <radsy> i used to admin it, still use it at home
00:37:48 <Sparks> #topic F13 Schedule
00:38:08 <Sparks> Okay... I think we need to come up with a slightly different plan that the F12 release
00:38:46 <Sparks> I didn't like the devel -> translation freeze -> devel -> wash, rinse, repeat
00:39:02 <Sparks> We should be constantly pushing pot files
00:39:04 <Sparks> IMO
00:39:24 <radsy> has there been any movement on a way to get breaking info from devs more easily, ie. lessons learned from the F12/PackageKit fiasco?
00:39:34 <jjmcd> How does L10N feel about that
00:39:34 <Sparks> If we have thousands of lines of text that need to be translated we shouldn't be dumping it on the translators for a week
00:40:01 <Sparks> jjmcd: Not sure... but if we get a paragraph done now why not?
00:40:25 <Sparks> radsy: Not sure.
00:40:32 <jjmcd> Well, they like to see those percentages.  Might be a disincentive to have a moving target
00:41:02 <Sparks> I said it last release and didn't really follow through but we really need to have a drop dead date to get all the text in.
00:41:32 <jjmcd> radsy, one problem is that people have conversations in groups and assume everyone else is read in
00:41:36 <Sparks> You knew these changes were happening months ago, you shouldn't come running up to use three hours before the release with it
00:42:07 <jjmcd> And really, probably everything gets discusses on dev-list, but who can wade through all the crap
00:42:18 <Sparks> jjmcd: I think transifex 0.7 will help alot.  Translations will be broken down by chapter...
00:42:47 <jjmcd> And that will come along how long after zikula?
00:42:50 <Sparks> If you know something is changing you should write up a quick paragraph and submit a ticket on it.  simple as that.
00:43:06 * jjmcd has a problem depending on vaporware
00:43:07 <Sparks> WTHK
00:43:09 <radsy> it might only take someone to maintain some sort of changelog of significant changes from last release
00:43:33 <jjmcd> The feature list is supposed to be that
00:44:10 <jjmcd> And different people have different perceptions of "significant"
00:44:25 <Sparks> maybe we should define significant
00:44:39 <jjmcd> The PackageKit thing was just a minor change to a policy, no code changed at all
00:44:59 <Sparks> a minor change with big implications
00:45:17 <jjmcd> Depends on your perspective
00:45:50 <Sparks> I'm pretty sure everyone was in agreement that it had big implications
00:46:11 <jjmcd> A change to fldigi might be a real big deal to me, but to most people?
00:46:38 <jjmcd> We look at changes to MySQL as a big deal, but in reality, how many people actually use it?
00:46:54 <Sparks> Who's to say that the fldigi change shouldn't end up in the RN?
00:47:05 <jjmcd> Well, yeah.
00:47:33 <jjmcd> It's always a judgement call as to what is significant, tho, and depending on where you are sitting, things change a lot
00:47:45 <Darkedge> Any chance of someone doing an RPM Packages lesson?
00:48:27 <jjmcd> Whatever happened to the classroom?  I havent heard anything lately
00:48:30 <Sparks> jjmcd: So we should include as much stuff as we can.
00:48:47 <radsy> Darkedge, http://docs.fedoraproject.org/drafts/rpm-guide-en/ ?
00:48:48 <jjmcd> Except that make it hard to find anything and pisses off the translators
00:48:51 <Sparks> jjmcd: We have a space for the Amateur Radio beat writer.
00:49:05 <jjmcd> yep
00:49:28 <jjmcd> And we have a growing ham community in fedora, too
00:49:37 <Sparks> Well...  this has gone way off topic.
00:49:41 <Darkedge> radsy: I just don't find that as good as hanging in #fedora-classroom because if I don't understAND something, What am I to do?
00:50:06 <Sparks> Darkedge: #fedora-devel is a good place to ask questions
00:50:29 <jjmcd> There have been some RPM classes in the past, but really, the thing to do is to make a couple of packages
00:50:30 <Sparks> So my thought is that we push pot files early and often
00:50:49 <Sparks> We push our documentation early and often
00:50:50 <jjmcd> We probably should chat with Bimitris about that
00:50:58 <jjmcd> Dimitris - damn typing
00:51:05 <Sparks> we shouldn't be waiting for the very last second to get all this done
00:51:14 <Sparks> which leads to going over a deadline
00:51:25 <jjmcd> Well, that wasn't our problem this time
00:51:34 * ianweller is kinda halfway here
00:51:45 <jjmcd> Somehow our schedule had us making pots and rpms on the same day
00:51:50 <radsy> sorry Darkedge - I had no idea that channel existed.
00:52:05 <jjmcd> ANd that day was two weeks too late
00:52:34 <jjmcd> SO yeah, I need to have a long hard look at John's schedule, and keep looking at it
00:52:37 <Sparks> yes
00:53:02 <Sparks> I'd really like to pull in the L10N folks and really talk about options.
00:53:22 <Sparks> If they think we can't change and it is what it is... then they won't know any different
00:53:46 <Sparks> But I don't like it when groups start pulling the translations out of transifex so no one can use them.
00:53:52 <jjmcd> Yes, that would be good.  Should have thought of this a couple weeks ago so someone could have sat down at FUDcon, I think glezos was tere
00:54:14 <jjmcd> Yeah, that was kinda pissy
00:54:18 * Sparks ponders the ability to have a gathering in about three months
00:54:26 <jjmcd> But you know ... French
00:54:35 <Sparks> *snicker*
00:55:29 <Sparks> Anyway, lets have a break-off meeting early next week to discuss the schedule.
00:55:30 <jjmcd> I think we SHOULD let L10N know they are getting Publican pots ofr F13.  If Tfx can't deal with them then they can deal with the conversions
00:55:33 <Sparks> poelcat: ^^^
00:55:45 <jjmcd> Might light a fire under the 0.7 effort
00:55:46 <Sparks> I agree
00:56:45 <Sparks> #action Sparks to send a message to L10N and Logistics about a docs planning meeting for early next week
00:57:26 <Sparks> #action jjmcd to review poelcat's schedule and come up with a recommendation before the meeting
00:57:34 <Sparks> Okay, anything else on the F13 schedule?
00:57:36 <jjmcd> roger that
00:57:49 <Sparks> jjmcd: Sanity check... :)
00:58:16 <Sparks> Okay, moving on...
00:58:22 <Sparks> #topic Other business
00:58:25 <Sparks> Anyone have anything else?
00:59:10 <Sparks> Anything at all?
00:59:55 <Sparks> Okay...  thanks for coming out everyone!
00:59:58 <Sparks> #endmeeting