fesco
LOGS
17:00:23 <notting> #startmeeting FESCo meeting 20091204
17:00:24 <zodbot> Meeting started Fri Dec  4 17:00:23 2009 UTC.  The chair is notting. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:24 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
17:00:32 <Kevin_Kofler> Present.
17:00:36 <josef> yo
17:00:37 <notting> #chair dgilmore dwmw2 notting nirik sharkcz jds2001 j-rod sk
17:00:37 <notting> vidal Kevin_Kofler
17:00:37 <zodbot> Current chairs: dgilmore dwmw2 j-rod jds2001 nirik notting sharkcz sk
17:00:38 * sharkcz is here
17:00:43 * nirik is here.
17:00:44 <notting> #meetingname fesco
17:00:44 <zodbot> The meeting name has been set to 'fesco'
17:01:04 <Kevin_Kofler> Your chair line got cut off...
17:01:09 <notting> #chair dgilmore dwmw2 notting nirik sharkcz jds2001 j-rod skvidal Kevin_Kofler
17:01:09 <zodbot> Current chairs: Kevin_Kofler dgilmore dwmw2 j-rod jds2001 nirik notting sharkcz sk skvidal
17:01:24 <notting> that's 4. anyone else?
17:01:31 <notting> dwmw2: have internets?
17:02:17 <nirik> do we have any tickets with votes from nonpresent folks?
17:02:50 * dwmw2 here
17:02:51 <notting> no
17:03:04 <dwmw2> someone stole my phone line, but BT put another one in
17:03:34 <notting> ok, that's quorum
17:04:11 <notting> first topic *was* linville provenpackager, but that was handled last meeting. i'll close out the ticket
17:04:23 <notting> #action notting will close out ticket 274
17:04:38 <notting> #topic F13 schedule
17:04:46 <notting> .fesco 281
17:04:47 <zodbot> notting: #281 (Approve Fedora 13 Schedule) - FESCo - Trac - https://fedorahosted.org/fesco/ticket/281
17:05:11 * nirik kills his browser... trying to change component on a bug sent it to lalaland.
17:05:39 <notting> John Poelstra set this up after some long discussions with rel-eng. It's what's currently reflected in Releases/13/Schedule on the wiki as well
17:05:52 <Kevin_Kofler> That'd put the F13 release at May 11.
17:06:18 <nirik> right. I'm ok with the plan I guess. It's anoying that we have to move around for otheros releases... but such is life.
17:06:18 <notting> yes. there was a conflict with the release of ubuntu $next, that would make staging it at our original planned date impossible
17:06:54 <nirik> another short schedule is a thought, but if we slip for any reason we would have to slip like 4 weeks. ;(
17:07:23 <Kevin_Kofler> It's the big problem: if we release differently from Ubuntu, everyone complains that we're not in sync with upstream projects, if we release together with them, the mirrors complain that we're swamping them.
17:07:41 <Kevin_Kofler> Can't make everyone happy.
17:08:01 * notting is +1 to the schedule as posted
17:08:04 <nirik> yeah. One thing that might help: we could decide tenative schedules further out.
17:08:26 <sharkcz> +1 also from me
17:09:31 <notting> Kevin_Kofler: dwmw2: ?
17:09:48 <dwmw2> +1
17:10:06 <Kevin_Kofler> Well, I think releasing before Ubuntu might be better for marketing than after them, but it'd leave us no room to slip without going back to causing the mirrors trouble.
17:10:10 <Kevin_Kofler> So that's not a good plan.
17:10:18 <Kevin_Kofler> Thus +1 to the plan with the May 11 release.
17:10:32 <notting> ok
17:10:39 <notting> #agreed F13 schedule as proposed is accepted.
17:11:37 <notting> rest of the agenda is features.
17:11:51 <notting> #topic Feature Intellij IDEA
17:11:56 <notting> .fesco 272
17:11:57 <zodbot> notting: #272 (Intellij IDEA - https://fedoraproject.org/wiki/Features/IntelliJ_IDEA) - FESCo - Trac - https://fedorahosted.org/fesco/ticket/272
17:12:11 <notting> (sorry, delivery. back in ~2 minutes)
17:12:33 <nirik> where were we on this? we discussed it last time.
17:13:13 * nirik was a weak +1 on it before. It's nice that we show fedora gets things first and helps a company open source.
17:13:43 <dwmw2> I think we wanted an assurance that it wasn't crippleware
17:13:44 <Kevin_Kofler> The picture with the monkeys as "users" is surely meant as a joke, but it comes out outright insulting.
17:13:50 <dwmw2> I was also a weak +1
17:14:06 <Kevin_Kofler> (on the feature page)
17:14:07 <dwmw2> Kevin_Kofler: I thought the monkeys were java developers?
17:14:15 <nirik> yeah, I thought we got such an assurance...
17:14:28 * nirik looks around, doesn't see lkundrak.
17:14:58 <Kevin_Kofler> Well, the feature list from upstream, which compares it to the proprietary "Enterprise Edition", looked a lot like crippleware.
17:14:58 <sharkcz> => "lkundrak is now known as miniperl"
17:15:30 <sharkcz> miniperl: ping
17:15:35 <cjb> Kevin_Kofler: but you could probably say the same thing about MySQL, right?
17:15:39 <nirik> Kevin_Kofler: I agree the monkey picture is not a good idea.
17:15:54 <Kevin_Kofler> http://www.jetbrains.com/idea/nextversion/editions_comparison_matrix.html
17:15:56 <nirik> (unless it's some sort of upstream mascot thing)
17:16:27 <nirik> (in which case its still a bad idea, just not ours. ;)
17:16:35 <notting> nirik: thankfully, that appears to be a feature owner put that there, not the upstream
17:16:44 <dwmw2> what's wrong with monkeys anyway?
17:16:50 * dwmw2 likes monkeys
17:16:53 <notting> there's some responses to our questions on the discussion page
17:17:05 <dwmw2> it's better than the reasoning behind bonobo :)
17:18:10 <nirik> well, the commercial version has more features, but does that make the free one crippleware?
17:19:12 <nirik> I guess intent matters.
17:19:31 <Kevin_Kofler> The big issue is that these things 1. demotivate people from implementing the missing features (as they're being intentionally withheld) and 2. they're likely to be rejected if someone contributes them (again, as withholding them is intentional).
17:19:32 <notting> oh crud
17:19:37 <sharkcz> right, and I am +1 for the feature
17:19:38 <notting> Nov 20 12:37:51 <jds2001>       #agreed IntelliJ IDEA feature is accepted for F13
17:19:43 <Kevin_Kofler> So those features will most likely never be added.
17:19:48 <notting> trac wasn't updated. :)
17:20:03 <notting> #action this was already accepted at the 2009-11-20 meeting
17:20:05 <Kevin_Kofler> notting: I think this was reconsidered after that #agreed line.
17:20:06 * nirik goes to get more coffee
17:20:17 <nirik> notting: I thought it was unaccepted after that?
17:20:37 <notting> not according to the agenda
17:21:08 <Kevin_Kofler> Such a crippleware project is not a healthy Free Software project.
17:21:53 <Kevin_Kofler> And I'm worried that advertising this will drive people to the proprietary edition instead of to what we package.
17:21:54 <miniperl> sharkcz: boo
17:21:56 <notting> it's not great, but we ship plenty of unhealthy things. in any case, since it wasn't un-accepted, i'd like to move onto the rest of the agenda for now
17:22:13 <cjb> Kevin_Kofler: would be interested in how you think this compares to mysql, if you are against this and not mysql.
17:22:40 <Kevin_Kofler> I'm not sure about how MySQL behaves there.
17:22:47 <notting> #topic Feature - Better Hostname
17:22:52 <sharkcz> miniperl: hi, IDEA is again on the agenda, but it looks like trac wasn;t updated
17:22:56 <notting> .fesco 278
17:22:57 <zodbot> notting: #278 (Better Hostname - https://fedoraproject.org/wiki/Features/BetterHostname) - FESCo - Trac - https://fedorahosted.org/fesco/ticket/278
17:23:21 <notting> this was considered, *not* accepted, and questions added to the discussion page
17:23:23 <cjb> Kevin_Kofler: I think similarly; free software Community Edition, proprietary Enterprise Server.
17:23:47 <notting> but there haven't been any updates to the questions. i vote to defer this?
17:23:48 <Kevin_Kofler> But I haven't seen how these differ feature-wise, so I can't really form an opinion.
17:24:00 <Kevin_Kofler> But the discussion has moved on.
17:24:56 <nirik> notting: +1
17:25:49 <Kevin_Kofler> The only question that got answered was mine (and they basically said "KDE is free to talk to this over D-Bus", but nothing about acceptance from KDE upstream).
17:26:37 <Kevin_Kofler> The other 3 questions got no answer.
17:28:39 <notting> the feature in-page got updated to be called 'Better Computer Names'; the page wasn't renamed
17:29:34 <notting> i suppose if anyone here is still -1 on the feature, it's also deferred
17:30:25 <notting> ... opinions?
17:30:28 * sharkcz is still +1
17:30:31 * nirik wasn't opposed to it, just wanted to know questions were answered and integration was considered.
17:30:35 <mjg59> Just to be clear on this, FESCo failing to adopt a feature doesn't prevent anyone from implementing the feature, right?
17:30:42 <Kevin_Kofler> I'm for deferring it.
17:31:18 <nirik> mjg59: right. Just doesn't get touted in press, etc.
17:31:21 <Kevin_Kofler> mjg59: Well, it depends, if something is really a bad idea, we can outright forbid it. But by default, if we vote "not a feature", it's just not an advertised feature.
17:32:10 <Kevin_Kofler> In general, we try not to tell maintainers what they can or cannot implement.
17:32:16 <Kevin_Kofler> They should know best.
17:32:23 <notting> mjg59: in general, yes. there's been one or two where we've said "don't do that period", or "you need to go work with these other people". those were usually people outside of SIG <foo> asking to make changes to SIG <foo>'s spin.
17:32:53 <nirik> my main concern was the sharing name... ie change your computer name to 'Secure Files'. I'm not sure how that ended up answered.
17:33:21 <notting> #action discussion on Better Hostname/Computer Name is deferred pending answers to questions on the discussion page
17:33:35 <notting> #topic Feature - User Account Dialog
17:33:38 <notting> .fesco 279
17:33:39 <zodbot> notting: #279 (User Account Dialog - https://fedoraproject.org/wiki/Features/UserAccountDialog) - FESCo - Trac - https://fedorahosted.org/fesco/ticket/279
17:34:00 <notting> at last meeting, this was deferred with 4 +1, a couple of 0, and a -1
17:34:20 <notting> dgilmore added a question to the discussion page, which Matthias answered
17:34:22 * nirik is still +1, although sad that the gdm part will be minimal
17:35:09 <notting> dgilmore and skvidal aren't here. Kevin_Kofler was -1, dwmw2 had no vote earlier.
17:35:13 <notting> Kevin_Kofler: dwmw2: opinions?
17:35:30 <notting> (+1 votes from prior meeting: myself, nirik, jds2001, sharkcz)
17:36:28 <dwmw2> sorry, SIGWENCH
17:36:30 <Kevin_Kofler> So this has been clarified to primarily target the GNOME spin.
17:37:10 <dwmw2> and local authentication? Or does it attempt to cope with ldap/AD/etc.?
17:37:11 <Kevin_Kofler> I'm still a bit worried about the implications of Anaconda or firstboot trying to use this (it might end up sucked onto other spins as unwanted dependencies).
17:37:51 <Kevin_Kofler> But I'm +1 if we can be sure that they're not going to break the KDE spin.
17:38:06 <dwmw2> yeah, if done sanely, it seems reasonable
17:38:09 <dwmw2> +1
17:38:28 <notting> ok.
17:38:37 <notting> #action User Account Dialog feature has been accepted for F13
17:38:56 <notting> #topic Feature - Copy/Paste Just Works
17:38:59 <notting> .fesco 286
17:39:00 <zodbot> notting: #286 (Copy/Paste Just Works - https://fedoraproject.org/wiki/Features/CopyPasteJustWorks) - FESCo - Trac - https://fedorahosted.org/fesco/ticket/286
17:39:39 <Kevin_Kofler> This one is about GNOME getting a feature KDE has had for years.
17:39:49 <nirik> Kevin_Kofler: turns out gnome has it too. ;)
17:40:04 * notting is -1 to this, based on the opinions of people who know way more about X11/clipboards/etc than me
17:40:17 <dwmw2> what's this about a familiar Ctrl-V sequence?
17:40:20 <sadmac> yeah, I don't know if I just stopped closing applications years ago but I haven't noticed a problem here in awhile
17:40:22 <dwmw2> it's the middle button, dammit
17:40:37 <dwmw2> it does still happen
17:40:42 <Kevin_Kofler> Has this feature been run through the GNOME maintainers / "Desktop Team" yet?
17:40:48 <nirik> I think gnome is supposed to do this already, and if it doesn't its a bug...
17:40:58 <dwmw2> I select something in gitk, hit CtrlC and then try to paste it into the terminal I was running gitk from, and it's gone
17:41:05 <Kevin_Kofler> I don't think we're in a business of approving features against the will of the responsible team/SIG.
17:41:05 <notting> Kevin_Kofler: that's who I asked. owen says if this doesn't work now, it's a bug, and it is very likely to break apps
17:41:20 <notting> Kevin_Kofler: and someone on the discussion page mentioned it broke inkscape
17:41:23 <sadmac> There was also an issue where firefox in particular didn't work with this. I think I was told it was a security thing (?!)
17:41:30 <nirik> right, so -1 based on that. Ask the feature submitter to work with others to make sure it works?
17:42:39 <notting> dwmw2: sharkcz: opinions?
17:42:40 <Kevin_Kofler> -1 to this feature and we should also make it clear that this cannot be implemented without approval from the spin maintainers.
17:42:50 <sharkcz> -1
17:42:59 <dwmw2> I'm kind of dubious about it
17:43:01 <notting> well, it certainly can be packaged, of course.
17:43:11 <notting> but not as default on the spin without the spin maintainer's approval.
17:43:15 <dwmw2> yeah
17:43:20 <Kevin_Kofler> Yeah.
17:43:57 <dwmw2> -1 then, I suppose
17:44:30 <notting> #action CopyPasteJustWorks is not approved as a feature for Fedora 12. FESCo suggests the submitter work with the Desktop spin maintainers on this issue.
17:45:03 <Kevin_Kofler> That would be 13, not 12. :-)
17:45:18 <notting> #action correction: Fedora 13
17:45:31 * nirik notes you can do #undo for just the previous thing
17:45:37 <notting> mjg59: so, that above would be one of those exceptions to the rule mentioned above
17:45:49 <notting> #topic Feature - Upstart 0.6.x
17:45:56 <notting> .fesco 287
17:45:57 <zodbot> notting: #287 (Upstart 0.6.x - https://fedoraproject.org/wiki/Features/Upstart0.6.0) - FESCo - Trac - https://fedorahosted.org/fesco/ticket/287
17:46:25 * notting is +1 to this, as his name's on it
17:46:47 <Kevin_Kofler> +1, tracking upstream is a good thing and I don't see any obvious drawbacks.
17:46:57 <nirik> +1 here as well.
17:47:24 <sharkcz> +1
17:47:24 <nirik> how far out is 1.0?
17:47:31 <notting> sadmac: ?
17:47:33 <dwmw2> Since when is updating to the current upstream a "fedora feature"?
17:47:40 <dwmw2> when it's not even a major version bump
17:47:43 <notting> dwmw2: when it changes the job location and format slightly
17:48:01 <dwmw2> notting: how's that different to an soname bump?
17:48:04 <sadmac> notting: hard to say. F-15 ish my guess
17:48:05 <nirik> dwmw2: so we can tout we use the latest wizz bang upstart?
17:48:27 <Kevin_Kofler> When it's the first thing which runs on the system, plays an important part in system startup, can help reduce startup times etc.
17:48:30 <notting> dwmw2: we've done features for latest upstream in the past (there's one for netbeans coming up later in the meeting)
17:48:39 <nirik> so other maintainers can see if they should use the new dbus/service features?
17:48:56 <dwmw2> ok, +1 then I suppose
17:49:07 <Kevin_Kofler> We also systematically have GNOME 2.n and KDE 4.n as features.
17:49:20 <dwmw2> well, that's a major user-visible component.
17:49:25 <notting> nirik: moving system scripts to native upstart is *not* encouraged yet
17:49:27 <Kevin_Kofler> Well, should really be 2.2*n for GNOME, to be pedantic. ;-)
17:49:50 <notting> Kevin_Kofler: well, 3 will be on etoo :)
17:49:54 <nirik> notting: yeah, might note that in an admon or something on the page?
17:49:54 <notting> ok
17:50:00 <notting> nirik: good idea
17:50:08 <notting> #action Upstart 0.6.x has been accepted as a Fedora 13 feature
17:50:24 <notting> #topic Feature - NetBeans 6.8
17:50:28 <notting> .fesco 288
17:50:28 <zodbot> notting: #288 (NetBeans 6.8 - https://fedoraproject.org/wiki/Features/NetBeans_6.8) - FESCo - Trac - https://fedorahosted.org/fesco/ticket/288
17:51:02 <notting> we did a netbeans 6.7.1 feature for f12. this appears to be the followup
17:51:18 <nirik> yeah, so is this really a feature?
17:51:36 <Kevin_Kofler> Once again the "Just an update?" debate...
17:51:38 <nirik> I guess it depends on how popular netbeans is... I do see users asking for it/using it in #fedora somewhat regularly.
17:51:51 <notting> nirik: we appear to have painted ourselves into a corner by approving the last one
17:52:09 <nirik> yeah.
17:52:29 <nirik> so +1, lets add it as a nice bullet point for people looking for it, and move on. ;)
17:52:44 <Kevin_Kofler> +1 here too, can't hurt to advertise this.
17:52:49 <sharkcz> +1
17:52:51 * notting is +1
17:53:48 <Kevin_Kofler> dwmw2?
17:54:13 <dwmw2> +1
17:54:30 <notting> #action NetBeans 6.8 feature has been approved for Fedora 13
17:54:45 <notting> #topic Feature - RPM 4.8
17:54:48 <notting> .fesco 289
17:54:49 <zodbot> notting: #289 (RPM 4.8 - https://fedoraproject.org/wiki/Features/RPM4.8) - FESCo - Trac - https://fedorahosted.org/fesco/ticket/289
17:55:19 * notting is +1. newer/better/faster rpm is always good.
17:55:32 <nirik> yeah, +1 here.
17:55:32 <sharkcz> right :-) +1
17:55:45 <nirik> good to see upstream moving along... and we should tout that
17:55:53 <Kevin_Kofler> +1, new RPM is a good thing and certainly central enough to advertise.
17:57:17 <notting> dwmw2?
17:57:33 <dwmw2> I suppose so
17:57:33 <dwmw2> +1
17:57:58 <notting> #action RPM 4.8 has been accepted as a Fedora 13 feature
17:58:11 <notting> #topic Feature - Rollback with BTRFS
17:58:15 <cjb> (Hi, this one is josef/me.)
17:58:16 <notting> .fesco 290
17:58:17 <zodbot> notting: #290 (Rollback with BTRFS - https://fedoraproject.org/wiki/Features/SystemRollbackWithBtrfs) - FESCo - Trac - https://fedorahosted.org/fesco/ticket/290
17:58:21 <notting> last one!
17:58:29 * josef starts paying attention again
17:59:04 <nirik> so, should we tout a feature that requires something we aren't using by default?
17:59:04 <notting> this is a neat idea. the '0%' worries me.
17:59:26 <cjb> notting: josef e-mailed patches about 30 minutes ago :)
17:59:34 <cjb> (for the btrfs side)
17:59:35 <josef> yeah no longer 0% :)
17:59:37 <dwmw2> the concept worries me. Rolling back the _whole_ fs
17:59:41 <josef> more like 20%
17:59:49 <Kevin_Kofler> dwmw2: Yeah.
18:00:11 <notting> cjb: how does one expire snapshots so they get space back?
18:00:17 <Kevin_Kofler> Doing such whole-filesystem snapshots per default in yum (even if it's just by default for the users of an experimental filesystem) doesn't sound that great to me.
18:00:23 <josef> notting: you can just delete hte snapshot
18:00:26 <cjb> notting: I think we would have yum keep no more than (say) five.
18:00:33 <dwmw2> josef: can you?
18:00:34 <cjb> but it's policy.
18:00:36 <josef> yeah
18:00:41 <dwmw2> I didn't think that had been implemented yet :)
18:00:43 <Kevin_Kofler> I can see shipping such a yum plugin, but it should not be installed or enabled by default.
18:00:49 <cjb> dwmw2: yes, that went into Linus' tree in September.
18:00:51 <josef> yeah it went into 2.6.32
18:00:52 <dwmw2> ah, ok
18:01:02 <cjb> Kevin_Kofler: but why?
18:01:04 <josef> Kevin_Kofler: a plugin is all we're proposing
18:01:17 <cjb> Kevin_Kofler: I mean, what's bad about taking snapshots?
18:01:32 * nirik wonders if work shouldn't happen on this, and then later when we switch to btrfs for default also tout this/make this a feature.
18:01:36 <dwmw2> I think it's a cool plugin, but I'm not sure it's a feature -- not until we're using btrfs by default
18:01:40 <Kevin_Kofler> Updating the system is not really a related action to taking a whole-system snapshot.
18:02:07 <nirik> cjb: you yum update, get a bunch of emails, edit a file, then roll back... your email and files are back to the previous versions?
18:02:07 <Kevin_Kofler> It might even confuse users into thinking the snapshot is just about the RPMs.
18:02:35 <josef> nirik: thats why you subvolume everything out intelligently
18:02:41 <josef> put your /home on a different subvolume
18:02:47 <cjb> nirik: it's up to you.  since btrfs is optional (and hidden behind a boot arg), you decided in anaconda whether you wanted /home to be the same or separate to /.
18:02:48 <nirik> josef: what about /var?
18:02:50 <notting> given our current quorum, we can't approve (or disapprove) it now unless those of us here are unanimous. (i'm not saying we should stop discussion)
18:02:55 <josef> nirik: same idea
18:03:16 <nirik> so have a /var/log and a /var/spool/ and a /var/lib seperate?
18:03:35 <josef> if you so choose
18:03:42 <cjb> by the way, there was an LWN article about this; it isn't mentioned on the feature page:  http://lwn.net/Articles/362500/
18:03:44 <josef> you could rollback only one of your subvolumes
18:03:46 <josef> and not the others
18:04:04 <josef> course i guess that would mess up your rpm lib if you didnt rollback /var/lib/
18:04:10 * nirik again thinks this is cool... but shouldn't it wait until btrfs is default?
18:04:24 * sharkcz likes the idea too
18:04:43 * nirik also notes 'yum history' in the package update/downgrade space.
18:04:44 <cjb> I agree that this requires some pretty big documentation.  But no-one will be using btrfs without knowing that they're experimenting, and no-one will be forced to perform a rollback unless they choose to explicitly.
18:04:47 <josef> yeah we can wait to advertise it when its made default, the work is still going to be done now
18:05:09 <notting> well, if we're waiting to advertise, then it would be a fedora $later feature
18:05:24 <nirik> cjb: I'm worried that if we make this a f13 feature, it will appear on docs/media/etc and people will go: "cool. how do I use this" and will get confused because they didn't install with btrfs.
18:05:33 <josef> i'm doing the work now and it will be in F13
18:06:03 <notting> did we have a "Feature" for presto when it was still optional?
18:06:08 <cjb> nirik: that's reasonable.  they can, at that point, use the btrfs-convert tool to go from ext[34] to btrfs, if they want.
18:06:50 <nirik> notting: yeah, I think we did.
18:07:21 <nirik> I suppose we could mark this a "Tech Preview" feature or something to indicate it's not default/requires some setup
18:08:13 <cjb> btw, as mentioned on the feature page, our primary target is actually Fedora developers running Rawhide.
18:08:49 <cjb> (or rather, Fedora developers who would not be willing to run Rawhide under normal circumstances, but are happier to if they have a handy "go back to yesterday" button.)
18:09:32 <cjb> so I agree the advertising to users vs. developers should be somehow different.
18:09:52 <nirik> yeah, there are different sections of release notes and such for them...
18:09:58 <cjb> ah, that's good
18:10:07 <nirik> but some of the talking points and such are just bullet lists...
18:11:22 <nirik> I guess if we make sure we communicate it well I would be ok with this being a feature. (for developers, tech preview, etc)
18:12:26 <notting> so, should we take a vote?
18:13:34 <nirik> sure.
18:14:09 <sharkcz> +1
18:14:26 <nirik> +1 (with the advertising priviso)
18:14:49 * notting is +1
18:16:26 <nirik> dwmw2 / Kevin_Kofler ?
18:16:51 <dwmw2> +1
18:17:37 <Kevin_Kofler> +1, I guess it can be useful to some folks, so we can as well advertise it.
18:17:54 <notting> #agreed Rollback with BTRFS has been approved as a F13 feature
18:18:39 <notting> that's it for the agenda
18:18:43 <notting> #topic Open floor
18:18:52 <tibbs|h> Did you guys do the FPC stuff?
18:18:58 <notting> no!
18:18:59 <notting> oops.
18:19:07 <notting> forgot to enter a ticket
18:19:18 <tibbs|h> spot did create a ticket.
18:19:32 <notting> not seeing it
18:19:56 <sharkcz> .fesco 285
18:19:57 <zodbot> sharkcz: #285 (Fedora Packaging Committee items for ratification (2009-12-02)) - FESCo - Trac - https://fedorahosted.org/fesco/ticket/285
18:20:07 <notting> that could be because i'm blind
18:20:11 <notting> #topic FPC report
18:20:29 <notting> #topc RPM handling of pkgconfig requires
18:20:54 * notting is +1
18:20:54 <tibbs|h> It's all just tweaks to keep up with the current state of the various components.
18:21:10 <sharkcz> +1
18:21:25 <Kevin_Kofler> +1
18:21:25 <nirik> yeah, +1 on that.
18:21:37 <Kevin_Kofler> No need to explicitly require what RPM already handles.
18:22:10 <tibbs|h> Honestly this was probably a "just do it" kind of thing, but...
18:22:21 <notting> dwmw2: want to make it official?
18:22:37 <dwmw2> +1
18:22:59 <notting> #agreed pkgconfig guideline change approved
18:23:09 <notting> #topic Emacs Packaging
18:23:42 <dwmw2> all greek to me
18:23:46 <tibbs|h> In F12+, emacs grew some rpm macros that let us add a bit more sanity to the packaging.
18:24:12 <tibbs|h> The only changes are to use those macros and to remove unneeded stuff from the templates (like buildroot).
18:24:22 <Kevin_Kofler> OK, that sounds sane.
18:24:23 <nirik> yeah, +1 on that as well.
18:24:23 <Kevin_Kofler> +1
18:24:30 <notting> given that description, +1
18:24:30 <sharkcz> +1
18:24:33 <dwmw2> +1
18:24:57 <notting> #agreed Emacs guideline change approved
18:24:58 <tibbs|h> It cuts out about ten lines of cut-n-paste crap.
18:25:30 <notting> #topic PHP guidelines revised
18:25:31 <Kevin_Kofler> Simplifying things is always a good thing. :-)
18:27:00 <Kevin_Kofler> Small nitpick: why "%if %{?php_zend_api}0" and not the more common "%if 0%{?php_zend_api}" idiom?
18:27:00 <tibbs|h> All of this is minor.  I'm not so up on PHP, but it clarifies a couple of things related to file placement and explicitly addresses what you need to do on EPEL versus what you can do with current Fedora.
18:27:10 <Kevin_Kofler> (It doesn't make any real difference though.)
18:27:23 * notting is +1
18:27:40 <Kevin_Kofler> Here too, this just seems to document current macros.
18:27:42 <Kevin_Kofler> +1
18:27:42 <tibbs|h> We could probably go over the guidelines for consistency with idioms like that.
18:27:47 <sharkcz> +1
18:27:53 <nirik> yeah, +1
18:28:16 <Kevin_Kofler> dwmw2?
18:28:33 <dwmw2> +1
18:29:17 <notting> #agreed PHP guideline revision approved.
18:29:22 <notting> ok, now back to...
18:29:25 <notting> #topic Open floor
18:29:29 <notting> anything else?
18:29:39 <tibbs|h> Thanks.
18:29:52 <notting> no problem, my bad for missing it in the ticket list.
18:30:09 <tibbs|h> I switched over to using the more common %if 0%{foo} idiom.
18:30:32 <tibbs|h> Spot's planning to write up and announce a whole pile of backlogged guideline changes at fudcon.
18:32:19 <notting> if no one speaks up, i'll end the meeting in 1 minute
18:32:52 <Kevin_Kofler> Nothing more from me.
18:33:02 <notting> ... meeting will end in 30
18:33:36 <notting> #endmeeting