fedora-meeting
LOGS
08:29:19 <rhe> #startmeeting
08:29:19 <zodbot> Meeting started Fri Nov 27 08:29:19 2009 UTC.  The chair is rhe. Information about MeetBot at http://wiki.debian.org/MeetBot.
08:29:19 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
08:30:15 * rhe is ready
08:31:02 * lili_ is ready
08:31:15 <rhe> I use the meetbot this time so that we and James can track this.
08:32:08 <mgracik> nice
08:32:15 <mgracik> so what you guys got?
08:32:27 <rhe> #info 1. Previous meeting follow-up
08:32:47 <rhe> #link    https://fedoraproject.org/wiki/Is_anaconda_broken_proposal#Results
08:33:11 <rhe> last time, we decided v1.0: kickstart  v2.0 Grapical
08:33:18 <rhe> and James approved that.
08:34:01 <rhe> is there any comments on this topic?
08:34:30 <mgracik> i don't have anything to add to that
08:34:42 <rhe> OK, next topic
08:34:45 <rhe> #info 2. 'problem space' and 'proposed solution'
08:35:08 <rhe> I've updated the problem space part on website.
08:35:36 <rhe> #link https://fedoraproject.org/wiki/Is_anaconda_broken_proposal
08:35:54 <rhe> Can you have a look at and give some advices?
08:36:08 <rhe> I divided the install process to modules.
08:36:46 <rhe> and analyzed problems for each one
08:36:47 <lili_> I am reading it
08:37:14 <rhe> The negative thing is they are not separated by each other.
08:37:17 <rhe> OK.
08:38:24 <mgracik> rhe: looks good
08:40:11 <rhe> I mean unlike rawhide broken, when we design test case, we need to think the problems together. That's not comfortable, but that's so far I could think out.
08:41:34 <rhe> lili_, what do you think? send it to James for review?
08:41:59 <lili_> rhe,yeah, give him to see first
08:42:11 <rhe> okay:)
08:42:13 <mgracik> yeah
08:42:26 <mgracik> i don't know if you guys know, but i'm doing the install image composing scripts
08:42:53 <mgracik> so maybe then we can integrate it, so it can create new iso images before running tests :)
08:43:05 <rhe> #action rhe updated problem space.
08:43:37 <rhe> #action lili_ and mgracik agreed to send it to James for review.
08:44:11 <lili_> mgracik, the release-engineering will compose it for us,we need to make sure all tests are using the same image
08:44:24 <mgracik> oh ok
08:44:45 <mgracik> they will be using my scripts :)
08:44:59 <rhe> :)
08:45:17 <mgracik> yeah, but it's better, we don't have to worry about that
08:45:21 <lili_> then we have to make sure the packages are the same
08:46:02 <lili_> such as anaconda version, liveCD version etc....
08:46:54 <rhe> oh, you're right. should I include it in the problem space?
08:46:55 <mgracik> well i would start with the dvd isos
08:48:50 <lili_> ok
08:48:56 <rhe> ok, add items on website if needed.
08:49:07 <rhe> next 'proposed solution', any ideas?
08:49:52 <rhe> I think our solution is made from simple-> complex
08:50:19 <rhe> so first cover some easy issues like v1.0
08:50:31 <mgracik> agree
08:53:05 <rhe> #agreed fix problems from easy to complex cases.
08:54:18 <rhe> lili_  so for 1.0 we use kickstart, dvd, the other is default, right?
08:54:53 <mgracik> yeah, first i would concentrate on just being able to create a virt. machine, get the latest dvd.iso start the install, and see if it goes well
08:55:00 <mgracik> with default settings
08:55:22 <rhe> agree.
08:55:23 <mgracik> and try to extract some report from the test run
08:55:40 <mgracik> then we will create more test cases with different settings
08:56:33 <rhe> #action lili_ suggest adding package/versions check.
08:56:39 <lili_> yes, I agree, start from the most simple thing
08:57:38 <rhe> #action mgracik suggests concentrating on create virt machine, get the latest dvd.iso start the install, and see if it goes well with default settings.
08:58:07 <rhe> #agreed lili_ and rhe agree start from simple thing
08:58:53 <rhe> #info test plan/test cases.
08:59:13 <rhe> Oh, I think the above conversation also covers this topic.
08:59:25 <mgracik> yep :)
08:59:32 <rhe> Do you have some other thoughts about it?
09:00:03 <rhe> I saw the is rawhide broken, they make the test plan based on problem space.
09:00:20 <rhe> and then write the test cases
09:00:55 <rhe> How to write test case for our project?
09:01:50 <rhe> lili_, what do you think?
09:02:11 <mgracik> from bugs ?
09:02:12 <rhe> Can we use the exsiting ones?
09:02:40 <rhe> the general cases for running.
09:02:48 <mgracik> we get a bug, where there are steps to reproduce, it then gets fixed in anaconda, and we write a test case for it
09:03:15 <mgracik> rhe: what existing ones?
09:03:35 <rhe> the existing manual installation steps.
09:04:47 <mgracik> i don't know what you mean
09:04:54 <rhe> I think getting from bugs is a way. But shouldn't we have test cases before testing?
09:06:22 <rhe> the example of a test case https://fedoraproject.org/wiki/QA:Installer_image_presence_test_case
09:06:32 <mgracik> yeah, well we have one, get the dvd, and "click next next next" :)
09:07:26 <mgracik> hmmm
09:07:39 <rhe> right.
09:08:16 <mgracik> i don't know if we can break these tests into small pieces like that
09:09:47 <rhe> my concern is, first we use dvd, then we use cd, but maybe the cases are the same except this first step.
09:10:16 <lili_> we did not get problem space fixed until now
09:10:35 <lili_> we can talk about test cases after all that fixed
09:10:56 <lili_> otherwise, all talk is  meaningless
09:11:25 <lili_> how do you guys think
09:11:37 <mgracik> you're right
09:12:21 <lili_> all this shoud get the confirmation of jlaska, after that is ready, we can start to think about the test cases
09:12:31 <rhe> #action mgracik adviced writing a basic case for v1.0
09:13:37 <rhe> #action rhe have concerns for writing cases like this, which may bring same steps in the future.
09:14:21 <rhe> #action lili_ adviced  when getting the confirmation of jlaska, after that is ready, we can start to think about the test cases
09:14:29 <mgracik> how can we influence the install process?
09:14:35 <mgracik> just with kickstarts, right?
09:14:44 <rhe> #agreed we agreed.
09:15:40 <rhe> It seems so for me.
09:15:50 <lili_> agree
09:16:04 <mgracik> so our "test cases" will be just different kickstart files
09:16:07 <rhe> #info open topic
09:16:23 <mgracik> i don't thinkg we can break the test cases into small steps, like the rawhide tests
09:17:02 <mgracik> because the whole "anaconda install process" from booting to rebooting is one step, which depends on what you set during it
09:17:28 <lili_> that's also what I am thinking about
09:17:30 <mgracik> you know what i mean? i mean i don't think we can test something like "create lvm and encrypt it" and just then test the results
09:17:55 <lili_> it will be hard to identify the issues happened on anaconda
09:17:59 <mgracik> we have to create a kickstart which "creates lvm and encrypts it" and then we have to see if the WHOLE install will succeed
09:18:20 <mgracik> so for every change/problem/test case, we have to run the whole install process
09:18:26 <rhe> not hard the option of kickstart can let you get the logs from anaconda
09:19:29 <rhe> I think we can add the steps like: creates lvm and encrypts it in kickstart. what do you think?
09:19:39 <mgracik> yes, that can be added to kickstart
09:19:50 <mgracik> but what i'm saying is that we have to run the whole install, to see if it works
09:21:00 <mgracik> because creating the volumes can be ok, but THEN something breaks because of it
09:21:46 <rhe> oh, do you mean hard to identify where is the problem?
09:23:43 <mgracik> yeah
09:25:23 <rhe> Yes, that's the difference from rawhide broken. we need to run the whole process.
09:25:56 <mgracik> so we can start with one kickstart files
09:25:58 <mgracik> *file
09:26:13 <mgracik> and then change some stuff, and run the whole thing again
09:26:16 <rhe> agree
09:26:29 <mgracik> and cobbler can do the cheetah templating stuff
09:26:32 <rhe> yes, the whole process cannot be devided
09:28:33 <rhe> #action mgracik reminded that, unlike rawhide broken, a whole process need to be run for each case.
09:29:57 <rhe> Ok. Do you have any other concerns for discussing?
09:30:02 <rhe> lili_ ?
09:30:22 <lili_> I have no comments
09:30:45 <rhe> how about mgracik? If so, I will end the meeting.
09:31:08 <mgracik> not really
09:31:35 <rhe> ok. Thank you. bbl
09:31:44 <rhe> #endmeeting