fedora-meeting
LOGS
00:02:20 <Sparks> #startmeeting Docs Project Meeting - Agenda: http://fedoraproject.org/wiki/Docs_Project_meetings
00:02:20 <zodbot> Meeting started Thu Nov 19 00:02:20 2009 UTC.  The chair is Sparks. Information about MeetBot at http://wiki.debian.org/MeetBot.
00:02:20 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
00:02:29 <Sparks> #topic Roll Call
00:02:30 * Sparks 
00:02:32 * radsy is here
00:02:35 * rudi is here
00:02:38 * bcotton is here
00:02:48 * jjmcd .
00:04:41 * Sparks gives everyone a few more minutes
00:08:21 <Sparks> Okay, let's get started
00:08:41 <Sparks> #chair jjmcd
00:08:41 <zodbot> Current chairs: Sparks jjmcd
00:08:50 <Sparks> #topic Docs Project Leader Elections
00:09:18 <Sparks> When I took this job back in January(?) I wanted to make sure that we had elections for a new leader after F12 got released.
00:09:26 <Sparks> So here is my suggestion...
00:09:47 <Sparks> We take nominations starting tonight and vote next week.
00:09:51 <Sparks> Thoughts?
00:09:59 <jjmcd> wikipage
00:10:22 <Sparks> That's a good place to start
00:10:41 <rudi> sounds like a plan; and the wiki is the natural place for noms to go
00:10:55 <jjmcd> Although, we could just agree to re-elect you by acclimation
00:10:55 <Sparks> rudi: Works for me.
00:11:12 <Sparks> I won't take the job unless someone else runs
00:11:13 <Sparks> :)
00:11:25 * Sparks votes for ---> that guy
00:11:41 <jjmcd> And I won't run unless I can find a sucker ... errr ... leader for RNs
00:12:04 <Sparks> We should probably figure out if we want to do this yearly or releasely or...
00:12:32 <jjmcd> Personally, I could argue for either
00:12:47 <jjmcd> Yearly gives somebody a chance to get established
00:12:51 <Sparks> yes
00:13:04 <jjmcd> releasely gives is a quicker way to get rid of a turkey
00:14:00 <bcotton> i'd think releasely would be a bit hectic
00:14:10 <Sparks> jjmcd: I think you should be able to get rid of me... err... a turkey at any point
00:14:20 * Sparks establishes https://fedoraproject.org/wiki/Docs_Project_Leader_Elections
00:14:28 <jjmcd> So we need an impeachment process?
00:14:45 <Sparks> WE DON'T LIKE YOU ANYMORE... GET OFF THE STAGE!
00:15:14 * jjmcd prefers burning torches
00:15:22 <Sparks> Okay, I'll send out an email after the meeting
00:15:35 <Sparks> #action Sparks to send out email on nominations
00:15:52 <Sparks> Okay, anything else on this topic?
00:16:19 <Sparks> #topic Release Notes
00:16:39 <jjmcd> You saw the notes to the list
00:16:42 <Sparks> First I'd like to thank jjmcd and rudi and everyone else who helped in getting the Release Notes completed.
00:17:10 <Sparks> You guys did an awesome job!
00:17:18 <Sparks> Now if our technology could keep up...  :)
00:17:25 <Sparks> jjmcd: What are the translation issues?
00:17:27 <rudi> Ta -- there are still some bugs in the process, but we're getting better :)
00:17:27 <jjmcd> They do look nice on the new F12 background - but that's all on mo
00:17:46 <jjmcd> rudi is tracking them down, I think most are explainable
00:18:00 <jjmcd> We do need to decide when to publish
00:18:20 <jjmcd> and I like rudi's idea of moving in a direction of translators publishing, or at least deciding when
00:18:43 <jjmcd> And OBTW, as translations are committed, the built docs ARE available
00:18:53 <Sparks> jjmcd: I'd like it if the translators would join us on these meetings... especially around release time
00:19:01 <jjmcd> But without building themselves, translators have no view into the errors
00:19:20 <jjmcd> Yes, noriko at least was joining us for a while
00:19:25 <Sparks> jjmcd: So we need to do a classroom on how to use Publican?
00:19:32 <jjmcd> but they are spread out across timezones
00:19:37 <rudi> Sparks -- no, the problem is more deep-seated
00:19:42 <jjmcd> Well, it is a major PITA until the new TFX
00:19:56 <Sparks> jjmcd: True.  Maybe the lead translator for each lang could join us...  TZs make it tough
00:20:02 <rudi> yeah; Tx 0.7 is the blocker
00:20:12 <Sparks> rudi: more deep-seated?
00:20:26 <rudi> Until then, translators not only need to know how to use publican, but how to wrangle the merging and splitting as well
00:20:45 <jjmcd> And that isn't always obvious
00:20:47 <Sparks> yes
00:20:55 <rudi> and the "how to use Publican" is the least of their worries.
00:21:00 <Sparks> it isn't obvious to me!
00:21:11 <rudi> Even after all this time, *we* still bungle the merging and splitting
00:21:13 <jjmcd> When everything is hunky-dory, we could script it.  But things are rarely perfect
00:21:34 <rudi> (which is the root of most of the English strings we're still seeing cropping up in the translations)
00:21:45 <jjmcd> Yep, that was my suspicion
00:22:05 <rudi> jjmcd -- yeah, confirmed. With yours truly being the chief bungler :)
00:22:43 <jjmcd> I will remind docs and trans later where to find the nightly builds of f12zeroday-tx
00:23:11 <rudi> But there are also some genuinely inexplicable ones, where strings we can see are definitely translated somehow don't get carried across the split...
00:23:11 <Sparks> jjmcd: When will the next batch ready to commit?
00:23:39 <rudi> Sparks, jjmcd -- we need to make a decision about when and whether to refresh the POTs
00:23:49 <jjmcd> rudi: yep.  Sparks: Schedule says tomorrow, but I am poking L10N to ask if that makes sense
00:23:49 <rudi> And we probably need some input from L10N on that
00:24:11 <jjmcd> And with the latest flamebug, we may want to do that again real soon now
00:24:32 <Sparks> ya
00:24:39 <rudi> The refresh would pull in the latest fixes (from f12-temp), plus the flamebug, plus assorted small glitches that are breaking translations
00:25:14 <rudi> jjmcd -- did you want to do this before or after packaging the RN?
00:25:24 <jjmcd> I would also like to get something authoratative on processors.  We have an outstanding bug that disagrees with other experts, and I don't know who to believe
00:25:45 <jjmcd> rudi, we have a package in the DVD, and a more recent package on updates
00:26:09 <jjmcd> We will want to do another probably for the install thing first en then maybe all langs
00:26:16 <rudi> jjmcd -- Ah OK! so any update is not going to interfere with thath
00:26:23 <rudi> * that
00:26:25 <jjmcd> I don't think we want to wait that one for the translations
00:26:42 <jjmcd> yeah, Sparks has been great on getting these things to the repos
00:26:45 <rudi> OK -- so regenerate today?
00:26:56 <jjmcd> sounds good to me
00:27:25 <jjmcd> There is more manual than I would like in the packaging, but it isn't some huge deal
00:28:08 <jjmcd> The real problem is waiting hours and hours to build all the langs
00:28:16 <jjmcd> Well, mostly to merge
00:28:28 <jjmcd> BTW, I saw you committed some merged pos
00:28:44 <jjmcd> If we can keep up with that, it could be a real help
00:29:16 <rudi> NP -- I'm trying to make sure that the master branch stays current and ready to build
00:29:24 <jjmcd> good, I like that
00:29:46 <jjmcd> http://fedora.is-sixsigma.com/F12beta/ - regenerated every night, from t12zeroday even tho it says beta
00:29:58 <rudi> So -- the other question is -- do we wait till we have an answer on the arches before rebuilding?
00:30:05 <rudi> *regenerating
00:30:30 <jjmcd> I think we need to deal with the install policy immediately
00:31:15 <rudi> We have text on the policy change ready to insert?
00:31:19 <jjmcd> As much as I would like an answer on the other, I think all those guys are burning their cycles on BZ534047
00:31:24 <jjmcd> No
00:31:28 <jjmcd> Well, there is text
00:31:35 <jjmcd> and widespread agreement it is wron
00:32:09 <rudi> OK -- well, we need something definitive in the f12-temp branch ASAP
00:32:19 <rudi> radsy -- are you in a position to write it up?
00:32:24 <jjmcd> So, I will craft some weasel words that try to avoid the emotion, but we still need a definitive workaround
00:32:43 <rudi> Yeah -- whether the change is good, bad, or ugly is not relevant to the RN
00:32:58 <jjmcd> The fix posted by Seth isn't even available to most people
00:33:03 <rudi> Just its effects and what to do if you don't like it for whatever reason
00:33:20 <jjmcd> You gotta be a policykit developer to even have the tool
00:33:27 <jjmcd> It is the what to do that is the problem
00:34:03 <jjmcd> Not too hard to describe the change
00:34:44 <rudi> OK
00:34:51 <jjmcd> Does that become 5.2.1, or 4.1?
00:34:55 <rudi> So where are we going to get that from?
00:35:16 <jjmcd> Well, the bug thread hasn't slowed yet
00:35:41 <rudi> I'd say 5.2.1, with a pointer in 4.1
00:35:59 <jjmcd> Oh maybe it has.  I couldn't get a word in edgewise earlier, but now it's been an hour since someone commented
00:36:19 <jjmcd> On the bug, I'm sure the mailing list is still lively
00:36:39 <Sparks> jjmcd: Would now be a good time to ask for a definitive answer on what needs to go in the RNs?
00:36:48 <jjmcd> Or everyone got frustrated with the in-flight collisions on bugzilla
00:37:00 <jjmcd> Ask where?
00:37:13 <Sparks> jjmcd: The more I think about it the more I think that PK should just be uninstalled on systems where users shouldn't be installing software...  almost makes sense.
00:37:16 <Sparks> jjmcd: On the bug.
00:37:24 <jjmcd> Seems like everyone has a horse in this race
00:37:25 <Sparks> jjmcd: you/we still need an answer
00:37:30 <jjmcd> yep
00:37:44 * Sparks got hit twice on the same post with a collision
00:37:52 <jjmcd> And we need to test it
00:38:09 <jjmcd> Much of what has been talked about doesn't work for ordinary mortals
00:38:49 <Sparks> jjmcd: I agree
00:39:10 <jjmcd> What I think we are saying, rudi, is that we aren't ready for a full rebuild
00:39:30 <Sparks> jjmcd: Well...  work up some text saying what PK does and that a solution is in the works
00:39:31 <jjmcd> I'll post en-US as soon as we get an answer, and we can do the big thing tomorrow
00:39:38 <rudi> yeah, that's what I'm hearing.
00:39:44 <Sparks> jjmcd: If you get the solution before you crash for the night then put it in...
00:39:53 <Sparks> jjmcd: otherwise build it and let's do a push
00:40:02 <Sparks> ok
00:40:02 <jjmcd> Yeah, at least on docs.fp.o I can put a warning
00:40:10 <Sparks> WORKSFORME
00:42:26 <Sparks> Okay, anything else on the Release Notes?
00:42:42 <jjmcd> rudi,  any clue why the rev history is missing from the trans?
00:43:11 <rudi> jjmcd -- yeah; I turned them off
00:43:16 <jjmcd> Oh, OK
00:43:18 <rudi> when I was building
00:43:38 <rudi> the changes that you had to make for yelp caused them to blow up when I was building the translated versions
00:43:47 <jjmcd> I had no theory about that, as long as there's an answer and it isn't a mystery
00:43:57 <rudi> And, strapped for time, that seemed like the best solution
00:44:06 <jjmcd> oooohhhh, I thought I kept the yelp changes out of git except for the table length
00:44:10 <rudi> Yeah; no mystery
00:44:38 <rudi> Hmmm.
00:45:01 <rudi> So the "xyz changes (cont'd)" shouldn't be in there either?
00:45:09 <jjmcd> I cut the max table size down some in the hopes it might help - didn't
00:45:20 <jjmcd> Oh yeah, just the tables were shorter
00:45:24 <rudi> Oh OK
00:45:36 <jjmcd> I think I was limiting them to like 250 entries or something, shortened to 100
00:46:05 <jjmcd> didn't help,.. but I also hoped they might help you build, too
00:46:20 <rudi> Well, *something* helped me build
00:46:40 <rudi> I was finally able to build them on my machine without having to SSH into ryanlerch's :)
00:46:42 <jjmcd> Don't you love a good mystery
00:49:29 <Sparks> Okay...  Moving on...
00:49:38 <Sparks> #topic Guide Status
00:49:53 <Sparks> Anyone have any problems with their guide or want to talk about their guide?
00:50:37 <radsy> i did lots of updates to the selinux user-guide yesterday, thanks to a BZ that slipped through the cracks of my memory
00:50:46 <radsy> got it up in CVS overnight, it's fine now
00:50:55 <Sparks> radsy: Cool!
00:51:01 <Sparks> Anyone else?
00:51:10 <radsy> basically the removal of setroubleshootd as a permanent daemon
00:52:18 <Sparks> :)
00:52:28 <Sparks> #topic New Guides
00:52:33 <Sparks> Any new guides in the works?
00:53:03 <Sparks> #topic Status on CC license rollout.
00:53:11 <Sparks> For those of you that didn't know...
00:53:28 <Sparks> We have officially changed over to the CC-BY-SA license!
00:53:34 <Sparks> All of these tasks are complete!
00:53:56 <Sparks> Thanks to everyone who made this possible... it was truly a team effort.
00:54:14 <Sparks> #topic All other business
00:54:28 <Sparks> And with six minutes left...  does anyone have anything else they'd like to discuss?
00:55:10 <radsy> https://bugzilla.redhat.com/show_bug.cgi?id=534047 ? :)
00:55:11 <buggbot> Bug 534047: high, low, ---, richard, ASSIGNED, All users get to install software on a machine they do not have the root password to
00:55:41 <radsy> i'm starting to think we might want to wait for the dust to settle
00:56:04 <radsy> security response team are trying to find out if it will be reverted
00:56:21 <radsy> nobody knows it seems...
00:56:35 <Sparks> radsy: IMHO we need to get the word out that right now the vulnerability exists.
00:56:53 <radsy> your call
00:57:02 <Sparks> if admins/owners don't know that there is a change then they are assuming that they are protected.
00:57:20 <Sparks> but, of course, that is my opinion...
00:57:31 <radsy> we do have a lot of hits on the RN right now, being so close after release
00:57:54 <Sparks> Yeah
00:58:17 <radsy> i guess it can't hurt, quick enough to pull if needed
00:58:27 <Sparks> anyone have any thoughts on how Docs should handle the PK ordeal within the next 24-hours?
00:58:42 <Sparks> I'm assuming that within 72-hours we'll know more and can stand down more.
00:58:55 <Sparks> radsy: ya... we can get text up and down very quickly
00:58:56 <rudi> Well, we could add a note about the *existence* of the issue right now
00:59:08 <Sparks> rudi: Yeah, that's basically what I'm thinking right now
00:59:13 <rudi> Even if we don't have a suggested fix
00:59:35 <rudi> I kinda think that if there were a fix out there that most people could implement, we would have heard about it by now...
00:59:42 <radsy> and mention it's still in contention
00:59:50 <rudi> radsy +1
01:00:05 <Sparks> yep
01:00:33 <Sparks> Okay... it is the end of our hour.  Anything else to discuss before we close?
01:00:55 <radsy> nice timing :)
01:01:16 <Sparks> Thanks everyone for coming tonight!
01:01:19 <Sparks> #endmeeting