fedora-meeting
LOGS
15:00:06 <tk009> #startmeeting
15:00:06 <zodbot> Meeting started Tue Nov 17 15:00:06 2009 UTC.  The chair is tk009. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:06 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:00:22 <tk009> BugZappers meeting starting
15:01:05 <adamw> morning
15:01:12 <johe> hi
15:01:15 <tk009> morning =)
15:01:23 <tk009> hello johe
15:01:23 <mcepl> late afternoon :)
15:01:34 <tk009> =)
15:01:35 <adamw> i believe rjune sends his apologies
15:01:41 <tk009> yes I saw that
15:01:43 <adamw> something came up
15:01:47 <adamw> ...and also, he can't come to the meeting
15:01:55 <Tech33> here, good morning
15:01:56 <adamw> oh, i slay me.
15:01:59 <adamw> hi tech33
15:02:14 * iarlyy here too
15:02:15 <tk009> soeone needs their coffee?
15:02:56 <tk009> anyone else in attendance that has yet to speak up
15:03:25 <tk009> #topic - Semantics Change - Confirm and Implement
15:03:34 <iarlyy> Welcome Fedora 12 Constatine... = )
15:03:46 <tk009> yes welcome =)
15:04:14 <iarlyy> initial page was changed
15:04:15 <iarlyy> = )
15:04:36 <adamw> tk009: indeed, f12 is split off and rawhide is back to being rawhide, so the semantics change should go into effect
15:04:45 * SMParrish late but here
15:04:48 <tk009> SO we are offically now going to use keyword Triaged and no assigned for f13 bugs and beyond
15:04:59 <adamw> to recap again - that means basically that instead of setting bugs to ASSIGNED after we triage them, we leave them at NEW and add the Triaged keyword
15:05:00 <tk009> welcome SMParrish
15:05:06 <adamw> for new bugs in Rawhide
15:05:16 <adamw> new bugs in F12 and earlier stick with the older system
15:05:45 <adamw> we should announce this on test-announce at least, possibly also devel-list i guess
15:06:00 <adamw> anyone want to do that? should I?
15:06:18 <SMParrish> is the greasemonkey script already updated with this change?  ie one triage button for <= f12 and one for rawhide +
15:06:32 <adamw> ooh. nice point. mcepl?
15:07:25 <tk009> no takers on sending out that email?
15:07:29 <iarlyy> a question.. when this bug will be assigned ... devel team decides from now?
15:07:44 <tk009> yes iarlly
15:07:52 <adamw> yep
15:07:58 <adamw> that was the idea of the change
15:08:15 <SMParrish> tk009: I can do the email, should be an easy one
15:08:21 <adamw> great
15:08:32 <tk009> thank you SMP =)
15:08:58 <adamw> mcepl: can you update the greasemonkey script as suggested by smparrish?
15:10:44 <adamw> #action smparrish to send out email notifying test-announce and devel-list about semantics change
15:10:55 <adamw> oop, can you chair me tk009? or do that yourself?
15:11:03 <tk009> #action SMParrish will email test-announce and -devel about the 'Triaged' change.
15:11:13 <tk009> #chair adamw
15:11:13 <zodbot> Current chairs: adamw tk009
15:11:31 <adamw> who wants an action item to follow up with mcepl when he's awake? :)
15:12:20 <Tech33> I will, if I'm allowed :)
15:12:28 <tk009> yes you are =)
15:12:48 <tk009> there is no allowed here
15:13:03 <adamw> #action tech33 to follow up with mcepl about updating greasemonkey script for semantics change
15:13:28 <tk009> that it for that one?
15:13:32 <adamw> i think so
15:13:50 <tk009> #topic - Bug Lifecycle - Wiki page and image changes
15:14:00 <tk009> LINK: https://fedoraproject.org/wiki/BugZappers/BugStatusWorkFlow
15:14:41 <tk009> we need the two changes adamw mentioned two weeks ago
15:14:50 <adamw> i can change the text
15:15:20 <tk009> I guess I get the iage
15:15:24 <tk009> image*
15:15:46 <adamw> alrighty
15:15:47 <tk009> will you action both of those please adamw
15:15:54 <tk009> you type faster hehe
15:16:00 <tk009> well that and I am lazy =P
15:16:00 <adamw> #action adamw to update bug workflow wiki page for semantics change
15:16:10 <adamw> #action tk009 to update bug workflow wiki image for semantics change
15:16:37 <tk009> #topic - Housekeeping - Discuss ongoing housekeeping
15:16:48 <tk009> LINK: https://fedoraproject.org/wiki/BugZappers/HouseKeeping/Fedora12
15:16:58 <tk009> LINK: https://fedoraproject.org/wiki/BugZappers/HouseKeeping/DayBeforeRelease
15:17:39 <tk009> I am sure poelcat has the day before stuff covered
15:18:03 <tk009> it was mostly confirmation and that we have with the GA today
15:18:34 <tk009> LINK: https://fedoraproject.org/wiki/BugZappers/HouseKeeping/FirstDayDevel
15:18:42 <tk009> This is one we do
15:18:55 <tk009> and one you mentioned in the QA eeting yesterday adamw
15:19:22 <tk009> creating the blocker/tracker bugs for the next release
15:19:30 <adamw> actually the f13 ones already exist
15:19:46 <tk009> I created them last cycle
15:19:48 <adamw> they get created two releases in advance, so what we need to do now is create the NEXT next blockers :)
15:19:50 <adamw> f14
15:19:57 <tk009> and can do it again
15:20:12 <adamw> http://fedoraproject.org/wiki/BugZappers/HouseKeeping/Trackers
15:20:36 <adamw> we also should close off the f12 blocker, and move up the subsidiary tracker bugs that are blocking it to f13
15:20:45 <adamw> do you wanna take care of that tk009?
15:20:52 <tk009> I can yes
15:20:57 <adamw> thanks!
15:21:27 <adamw> #action tk009 to do tracker bug housekeeping: create f14blocker and f14tracker, close off f12blocker and move subsidiary blockers up to f13
15:21:45 <tk009> #topic - Open Floor
15:21:54 <tk009> bring what you got
15:22:25 <adamw> anyone need any help with any problems, or getting started bugzappin?
15:22:44 <iarlyy> johe, ping
15:22:48 <johe> yes
15:22:50 <johe> hi
15:23:01 <iarlyy> I guess first day here was yesterday right?
15:23:06 <johe> i think i could need a bit advice
15:23:23 <iarlyy> now is the time... feel free to ask
15:23:32 <johe> well, i tried over the weekend, but it was very lonely on irc :-)
15:23:58 <adamw> sorry :)
15:24:20 * mcepl was drawn away ... of course, Greasemonkey (and soon-to-come jetpack) script will be fixed
15:24:24 <johe> well, what to ask, first i read through the most of the stuff, but i have no good point/package to start, so any advice would be welcome
15:24:26 <poelcat> tk009: yes, I did the 'day before release' stuff
15:24:43 <poelcat> and the EOL warning will run tomorrow
15:24:47 <tk009> poelcat =) I knew it was so
15:25:20 <poelcat> tk009: your reminders help too :)
15:25:34 <tk009> johe I wanted to respond proper to your introduction email.
15:25:46 <tk009> poelcat: I nag huh =)
15:27:19 <adamw> we're getting jetpacks now?! awesome!
15:27:30 * mcepl scrolls through the backlog ... tk009 are going to make F14 blocker and F14 tracker??? Really? We know what will block F14?
15:27:35 <adamw> johe: is there a component you feel most interested / expert in?
15:27:48 <adamw> mcepl: that's the procedure, blockers and trackers get created two versions ahead of time.
15:27:56 <adamw> mcepl: f13blocker has existed since f11 came out :)
15:28:01 <mcepl> OK, I ammissing on proceure
15:28:25 * mcepl is sick and his hands are sticky ... not good for keyboard
15:28:42 <adamw> don't sneeze on the microphone :P
15:28:43 <johe> adamw, well wouldnt call me an expert on any, but i think most of the stuff could be handled
15:29:27 <johe> i work as an systemandministrator so any server related would be best i think
15:29:29 * mcepl will have questions in the end of the meeting on the design of scripts ... booking his time
15:30:24 <adamw> we don't have any servers on the 'priority components' list
15:30:35 <adamw> but you could certainly specialize in that area of triaging - it might be a nice thing to have covered
15:30:36 <tk009> johe we can talk in bugzappers channel after the meeting if you have the time.
15:31:04 <johe> tk009, half an hour or so, before my girfriend comes home :-)
15:31:10 <adamw> it looks like open apache bugs are not triaged, and there's 16 of them, which is a nice workable amount for a starting bugzapper - https://bugzilla.redhat.com/buglist.cgi?query_format=advanced&classification=Fedora&component=httpd&bug_status=NEW
15:31:22 <adamw> then you could certainly look at the other typical server components
15:31:47 <johe> adamw, okay deal :-)
15:31:52 <adamw> cool :)
15:32:22 <mcepl> I see upstart and SELinux available
15:32:31 <adamw> note about IRC: i don't always follow everything said in -bugzappers, particularly on weekends, but if you poke me by name i'll get an alert to check on what you asked, and i will do it
15:32:31 <mcepl> mkinitrd
15:32:53 <pjones> what a strange thing to say.
15:33:00 <adamw> usually within a few minutes, but could be hours if i'm out or asleep
15:33:03 <adamw> pjones: hum?
15:33:20 <pjones> just "mkinitrd", without any adorning text or obvious context.
15:33:50 <mcepl> pjones: somebody's looking for components to start bug triaging
15:33:51 <adamw> pjones: the context is "I see upstart and SELinux available"
15:34:01 <adamw> he was adding mkinitrd to that list
15:34:14 <pjones> mkinitrd isn't really worth triaging at this point, since it's deprecated.
15:34:15 <adamw> mcepl: you're behind the technological curve, though
15:34:28 <adamw> mkinitrd is the old bad thing now, dracut is the new hotness :)
15:34:57 <mcepl> adamw: well, I know I thought it is now aliased to dracut
15:35:04 <pjones> no.
15:35:15 <mcepl> adamw: dracut is not on the list
15:35:28 <adamw> mcepl: we should update it then
15:35:54 <adamw> i think we did it based off a critical path snapshot from a few months back, we should probably check it every few months against a new critical path snapshot
15:35:57 <mcepl> OK
15:36:05 <adamw> maybe stick that on the agenda for next week...
15:36:25 <tk009> it will be done
15:36:49 <tk009> Do we have anything else for today then?
15:37:01 * mcepl stands in the end of the line
15:37:23 <adamw> * mcepl will have questions in the end of the meeting on the design of scripts ... booking his time
15:37:43 <tk009> then its mcepls time now
15:37:49 <adamw> break it down!
15:38:23 <tk009> #chair mcepl
15:38:23 <zodbot> Current chairs: adamw mcepl tk009
15:38:37 <mcepl> do we really need two buttons ... couldn't the button say
15:38:37 <mcepl> if (version < 13 ) { makeAssigned } else { setTriagedKeyword }
15:38:38 <mcepl> ?
15:38:53 <adamw> sounds good to me
15:39:06 <adamw> can it also tell if the change it's about to be committed with would change the version and cope with that?
15:39:11 <mcepl> any other complaints, comments, whatever to the scripts?
15:39:24 <adamw> (e.g. if you're changing an incorrectly-filed-on-rawhide bug to f12 and setting it as 'triaged' at the same time)
15:39:40 * adamw loves to come up with the awkward corner case :)
15:39:44 <mcepl> will think about this
15:39:49 <tk009> yes we see that
15:39:53 <tk009> hehe
15:39:53 <mcepl> sure, it should be possible
15:39:58 <adamw> great
15:40:14 <adamw> then that would definitely be better - simple interface wins, and it makes the semantic change almost transparent for people who use the script buttons
15:40:16 <adamw> thanks!
15:40:39 <mcepl> some missing Buttons, something redundant, you hate blue?
15:41:06 <tk009> I was always a fan of brown? =)
15:41:45 <mcepl> tk009: that would be launchpadBugTriage.user.js script I believe ;)
15:41:48 <tk009> the scripts works like I expect, no complaints here
15:41:57 <tk009> hehe
15:42:02 <mcepl> I can make colors configurable
15:42:38 <mcepl> no questions?
15:42:40 <mcepl> three
15:42:41 <mcepl> two
15:42:41 <mcepl> one
15:42:46 <mcepl> I think Iam done
15:43:14 <tk009> okay then team, that is a wrap for today. Now go install f12 if you have not already
15:43:28 <tk009> thank you all for coming
15:43:37 <tk009> #endmeeting