fedora-meeting
LOGS
21:08:17 <biertie> #startmeeting spins-sig
21:08:17 <zodbot> Meeting started Mon Nov 16 21:08:17 2009 UTC.  The chair is biertie. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:08:17 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
21:08:37 <brunowolff> That has already been done. The package has already been blocked in rawhide.
21:09:23 <biertie> they don't want to change their licence? :(
21:10:14 <brunowolff> They can't get hold of everyone. The alternative is to redo the artwork.
21:10:15 <biertie> #topic games spin in F13
21:10:44 <biertie> ach, ok :( that's a pitty
21:10:47 <brunowolff> I'd like to see an f12 branch if the git repository soon.
21:11:17 <brunowolff> That will allow me to freeze my F12 spin page, create the F13 version and to update the F13 kickstart file.
21:12:06 <sdziallas> brunowolff: that sounds reasonable to me
21:12:15 <brunowolff> Presumably other people also will want to update their spin pages, but may not be in a hurry to do so.
21:12:34 <nirik> yeah. no hurry, but would be good to get fixed up
21:12:53 <brunowolff> The final set of kickstart files should also be in an update to the appropriate packages in F12.
21:13:50 <brunowolff> I think both the branch and the update are things that kanarip would normally take care of.
21:14:00 <biertie> I think so too
21:14:07 <brunowolff> We can probably just ask him to do it.
21:14:15 <biertie> but I think he's between his work and his house now -_-
21:14:43 <brunowolff> We aren't in so much of a hurry to get it done that doing something out of the ordinary is needed.
21:14:53 <biertie> #action kanarip fix the git repo for F12 :)
21:15:32 <brunowolff> Can you add one asking for ks package updates for the final ks versions as well?
21:16:37 <biertie> is kanarip also responsible for that?
21:17:31 <brunowolff> Normally he has updated the kickstart packages.
21:18:09 <brunowolff> Since the release isos have been built (except maybe AOS), the final ks files should be set now.
21:20:00 <biertie> #action kanarip check for the ks packages (are they in final?)
21:21:05 <biertie> anything else?
21:21:19 <brunowolff> Not specifically on the games spin.
21:21:38 <biertie> ok
21:21:39 <brunowolff> Jesse had asked a question about the AOS spin and I didn't see any response.
21:21:49 <brunowolff> On the spins sig mailing list.
21:21:54 <biertie> next thing was the AOS sping I think
21:22:03 <biertie> #topic AOS spin status
21:22:25 <brunowolff> I don't know if there is anything we can do at this point.
21:22:34 <Oxf13> yeah it's pretty dead
21:23:42 <biertie> ARCH
21:23:47 <brunowolff> What does the maintainer need to do for F13 (assuming they still want the spin)?
21:23:58 <biertie> kan anybody gives me the url of the spin_sig page?
21:24:26 <biertie> edit; found it
21:24:26 <brunowolff> https://fedoraproject.org/wiki/SIGs/Spins
21:24:31 <biertie> thx brunowolff  :)
21:24:52 <brunowolff> Here is the AOS page: https://fedoraproject.org/wiki/AOS_Spin
21:25:17 <Oxf13> the maintainer needs to fix appliance-creator
21:25:21 <biertie> uhu, found that already too ;-)
21:25:22 <Oxf13> so that it'll actually run
21:26:24 <biertie> David Huff right?
21:26:38 <biertie> is he informed about the problem?
21:26:48 <brunowolff> That's what the AOS page says.
21:27:15 <biertie> brunowolff: I think he is still the maintainer too
21:27:20 <brunowolff> The AOS spin should also get into the nightly builds so that we can tell if it breaks.
21:27:23 <biertie> if I look into the wiki history, he did all the updates
21:27:31 <nirik> it uses it's own weird compose tho.
21:27:43 <brunowolff> That may need some changes since it has a different build process.
21:27:47 <nirik> I asked him to explain it to me/write up a wiki page on it, but I haven't seen anything yet.
21:28:02 * nirik would be happy to add it to the nightlys if it can be explained how to compose it.
21:28:36 <huff> hello
21:29:03 <brunowolff> We were going over the AOS spin issue.
21:29:10 <biertie> brb
21:29:15 <huff> biertie: did not see any email about this
21:29:39 <brunowolff> Jesse asked about it on the spins sig mailing list.
21:29:50 <huff> ahh yes a while back
21:29:55 <brunowolff> I think for F13 we want it building in the nightly builds.
21:30:01 <huff> yea I did not see a response
21:30:13 <brunowolff> That will make issues apparent with enough lead time to deal with them.
21:30:22 <huff> so I am rethingking the AOS stuff for F13 and have some suggestons for spin composition as well
21:31:16 <nirik> huff: are you aware it didn't compose right for f12 final?
21:31:18 <brunowolff> I think if you work with nirik so that he has nightly builds going, that will result in us and releng having what we need.
21:31:49 <huff> nirik: i did not know there was an error my understanding was it was not built at all
21:32:21 <nirik> huff: yeah, I think it was not... Oxf13 would have more details...
21:32:56 <Oxf13> I posted to the spins list as soon as I tried to make the AOS spin and it blew up in my face
21:32:56 <brunowolff> I think an attempt was made but it didn't work.
21:33:20 <Oxf13> the deal with spins was that maintainers took care of those things and it was expected that I could come along at release time and run the tool across the config and publish the results
21:33:52 <brunowolff> I think that is the correct expectation for releng.
21:34:18 <huff> Oxf13: yea i think the AOS needs to be reworked to work better with the current spin composition process, ie be livecd like the rest of them
21:34:43 <huff> or the compose process needs to be better defineded what a spin is
21:35:01 <biertie> b
21:35:07 <huff> is it only livecd iso or not, know one really knows
21:35:16 <brunowolff> Or if you do something different we still need to be building it throughout the development, so we know it works and we
21:35:22 <brunowolff> know how to build it.
21:35:37 <huff> yea i had no clue it was not beeing built till after alpha
21:35:52 <biertie> poiop)⁻-)⁻$⁾p
21:36:32 <brunowolff> I am not sure when nirik started the nightly builds, but that was something new for F12.
21:36:55 <brunowolff> I think it was a good addition, but it didn't cover AOS becuase it was special.
21:36:55 <nirik> biertie: connection problems?
21:38:08 <nirik> anyhow, just feel free to write up or let me know what we need to add and we can get it back on track for f13.
21:38:16 <brunowolff> Can we make 'huff will work with nirik to get AOS into the nightly builds for F13'?
21:38:22 <huff> yea so i am working on a proposal for the AOS for F13 and will keep you guys in the loop
21:38:27 <brunowolff> as an action item?
21:38:55 <biertie> #ACTION huff + nirik work to get AOS into the nightly builds for F13
21:39:06 <biertie> #action huff + nirik work to get AOS into the nightly builds for F13
21:39:15 <nirik> sure. Sounds good.
21:39:22 <huff> ditto
21:39:31 <biertie> nirik: no, keyboard problems
21:40:15 <biertie> anything else?
21:40:41 <biertie> (about this topic)
21:40:48 <brunowolff> Well we could see if there was more after action review we wanted to do.
21:41:07 <brunowolff> I think the failure of AOS to get built was the main bad thing.
21:41:33 <brunowolff> I didn't get anywhere on the QA test plans for the Games Spin.
21:42:38 <brunowolff> I think the nightly builds was a good plus.
21:42:45 <biertie> ²
21:43:11 <brunowolff> It uses the tools that will be used by releng. The revisor builds kanarip does are OK, but don't test the same case.
21:43:28 <huff> what is the nightly build, kust a script that runs a bunch of livecd-creator commands?
21:43:38 <nirik> yep.
21:43:52 <brunowolff> I just see the web page, nirik did the work to make it happen.
21:44:06 <huff> link?
21:44:12 <huff> i have not seen this
21:44:21 <brunowolff> http://alt.fedoraproject.org/pub/alt/nightly-composes/
21:44:24 <huff> thanks
21:44:34 <nirik> hum. the script should be there too... and a readme... let me fix it.
21:46:01 <nirik> I think tmpwatch is messing with my data/logs, since I have it composing under /var/tmp. ;(
21:46:18 <nirik> script and readme are now there.
21:46:54 <biertie> thx nirik
21:47:01 <huff> cool ill take a look when considering AOS nextsteps
21:47:20 <brunowolff> It will be interesting to see the feedback for the pages the design team did. But we probably won't get that for a few weeks.
21:47:35 <nirik> speaking of nightlys, composes are failing currently.
21:47:40 <nirik> I haven't had time to dig too much.
21:47:53 <biertie> brunowolff: give a second, I'll show you something ;)
21:48:03 <huff> Also I have been thinking about somthing for you spin guys
21:48:17 <sdziallas> brunowolff: btw, do you know when the spins.fp.o redesign is supposed to go live?
21:48:22 <brunowolff> I had some conflicts with my update to F13 that is going on now based on yesterday's rawhide.
21:48:36 <brunowolff> There were some updates today that might fix those.
21:48:39 <huff> so for the ovirt node and other project we use a bunch of smaller kickstarts and use includes in our main ks
21:48:59 <huff> ie, common-post.ks and min-package-set.ks and a coupelothers
21:49:09 <sdziallas> huff: somehow, there's a Fedora Mini bell ringing in my mind... but go on ;)
21:49:21 <brunowolff> As long as all of them are in the git repo you should be OK.
21:49:22 <huff> sdziallas: well that was the initila goal of the aos
21:49:44 <huff> mi fedora with dhcp and yum so you can add stuff
21:49:46 <huff> min
21:50:18 <brunowolff> Let me know when i can run it on my wireless router.
21:50:23 <huff> lol
21:50:35 <sdziallas> huff: I think that would be *awesome* to get... (I've been talking with pbrobinson lately on getting different Fedora Mini incarnations, like "very mini", "moblin", "sugar",...)
21:50:53 <brunowolff> I keep waiting for a 2.6 kernel version that works with broadcom wireless chips.
21:50:56 <biertie> brunowolff: http://spins-test.fedoraproject.org/
21:51:06 <sdziallas> huff: let me know if there's anything I can help with, if it's drafting up some wiki page or whatever.
21:51:30 <huff> sdziallas: will do ive been busy in my day job however AOS needs some love
21:51:34 <brunowolff> The kernel support is there but openwrt isn't providing it yet and they move pretty slowly.
21:51:48 <huff> im trying to get to FudCon to talk about some of this stuff but not sure if it going to happen
21:52:14 <sdziallas> huff: sure! (just shout: sdz @ fp)
21:53:16 <sdziallas> huff: oh, on FUDCon... both pbrobinson and me will be there, too :) interest guaranteed
21:55:26 <sdziallas> oh, news from the moblin front: pbrobinson says he plans to be working on a specific fedora-mini kickstart (also for moblin) for F13. I guess one could put some work together there.
21:55:28 <sdziallas> anyway.
21:56:16 <biertie> sdziallas: I'll be there too ;-)
21:56:28 * nirik won't make it to fudcon... but will be around on irc if anyone needs me for anything.
21:56:40 <sdziallas> biertie: I know... that's why I was asking for a beer :p
21:56:48 <brunowolff> As a heads up for those of you that missed it, it is likely the lzma+squashsfs will be in 2.6.33.
21:57:02 <biertie> so, you think i'm not interesting? :(
21:57:32 <sdziallas> nirik: oh :/ ...well, Mel's around, so we might have some cool stuff in IRC, too :)
21:57:56 <brunowolff> That may allow for live images to hold significantly more on the same media.
21:58:21 <sdziallas> brunowolff: that'd be really great to get!
21:59:15 <brunowolff> Was there any other bad things that we need to adjust for or good things we need to expand on for F13?
22:02:41 <brunowolff> If not, then I think we covered the things I could think of for the agenda.
22:02:47 <biertie> ok
22:02:49 <biertie> thx all :)
22:02:56 <biertie> I'll close the meeting in 5
22:02:57 <biertie> 4
22:02:58 <biertie> 3
22:02:59 <biertie> 2
22:03:00 <biertie> 1
22:03:43 <biertie> #endmeeting