fedora-releng
LOGS
18:08:35 <Oxf13> #startmeeting Fedora Release Engineering
18:08:35 <zodbot_> Meeting started Mon Nov  9 18:08:35 2009 UTC.  The chair is Oxf13. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:08:35 <zodbot_> Useful Commands: #action #agreed #halp #info #idea #link #topic.
18:08:44 <Oxf13> #meetingname fedora-releng
18:08:44 <zodbot_> The meeting name has been set to 'fedora-releng'
18:09:32 <Oxf13> #topic roll call
18:09:50 <Oxf13> ping: notting jwb rdieter_work wwoods lmacken spot warren dgilmore poelcat
18:09:55 <Oxf13> spot won't likely make it, he's in AU
18:10:01 * poelcat here
18:10:03 <Oxf13> notting may be af ew minutes late, he was at lunch
18:10:05 * notting is here
18:10:29 <warren> here
18:10:44 <jwb> sort of here
18:11:33 * daMaestro lurks
18:12:57 * dgilmore 
18:13:31 <Oxf13> ok.
18:13:47 <dgilmore> Oxf13: he has a piss poor excludes.  its only 4:13am
18:13:54 <dgilmore> excude even
18:13:57 <dgilmore> excuse
18:14:00 <dgilmore> i suck
18:14:12 <Oxf13> #topic Fedora 12
18:14:18 <Oxf13> so yeah, RC4 now
18:14:23 <Oxf13> it's been a long weekend
18:14:36 <Oxf13> but so far RC4 is holding up to our testing, and no blocker issues have been found
18:14:59 <Oxf13> I've extended the go/nogo vote to happen at 5pm Pacific, 8 pm Eastern to give QA maximum testing time (they suggested the time)
18:15:11 <Oxf13> but I'm assuming go unless they find something by then
18:15:19 <notting> depending on bedtime schedules, i may or may not make that meeting.
18:15:41 <Oxf13> notting: I don't thik it'll be much of a meeting
18:15:45 * nirik would like to thank all the folks that worked hard on testing/fixing/composing this weekend.
18:15:58 <poelcat> +1
18:15:58 <Oxf13> If any blocker worthy issue is found, we're slipping
18:16:15 <dgilmore> :(
18:16:41 <dgilmore> what do we have left to do
18:16:55 <drago01> dgilmore: better release a week later than release a broken one;)
18:17:05 <Oxf13> on my plate today:
18:17:22 <Oxf13> disable mirror-manager redirects to get F12 updates(-testing) into the hands of the masses
18:17:36 <Oxf13> start staging F12 for mirrors
18:17:46 <Oxf13> finish composing live images
18:17:57 <notting> ... what's left live-wise?
18:18:07 <dgilmore> should torrent content be ready friday?
18:18:10 <Oxf13> well that depends actually
18:18:15 <warren> live? more like undead
18:18:29 <Oxf13> Desktop team would like to respin the live to drop command-not-found from running while in live mode
18:18:46 <Oxf13> keep it installed, but just disable it until you've actually done an install to your disk
18:18:56 <warren> I'm highly in favor of that.
18:19:06 <warren> Although I've been in favor of complete removal.
18:19:18 <Oxf13> I had already composed {i686,x86_64}-Live{,-KDE} but I can re-make those
18:19:30 <Oxf13> warren: lots of stuff has been fixed and more will be fixed in 0-day updates
18:19:37 <Oxf13> so once installed the experience is much better
18:19:46 <Oxf13> and it is an advertised Fedora 12 feature
18:20:33 <dgilmore> Oxf13: disabling in live mode seems like an ok idea
18:20:37 <notting> Oxf13: what's the verification timeframe for live?
18:20:57 <Oxf13> well, I don't know if anybody is/has tested the ones currently uploaded
18:21:08 <Oxf13> if we agree to respin, I could have new ones uploaded in about an hour
18:21:16 <Oxf13> but apparently we're having issues getting things downloaded from PHX
18:21:30 <Oxf13> we'd have the same cut-off for go/nogo on live images
18:21:44 <Oxf13> although if we have an issue that is just a config level change, we can re-spin the live images later
18:21:45 <dgilmore> Oxf13: sowe really dont want to respin
18:21:57 <Oxf13> dgilmore: actually I'm in favor of respinning the live images
18:22:03 <Oxf13> it's just a config level change
18:22:22 <dgilmore> Oxf13: ok, if your for it then i guess we should do it
18:22:39 * rdieter lurks
18:22:52 <Oxf13> actually it's just the gnome one I'd have to re-spin
18:22:56 <Oxf13> the KDE one is untouched
18:23:16 <notting> Oxf13: should we refactor the iswraid change into a config change instead of a livecd-creator change?
18:23:41 <Oxf13> notting: the livecd-creator change is already built/tagged/composed so... not at this time
18:25:22 <warren> eh?  it is in RC4?
18:25:22 <Oxf13> that's really all I have on my plate today.  i'm taking it kind of easy after the weekend from hell
18:25:27 <Oxf13> warren: yes.
18:25:33 <warren> oh
18:25:36 <Oxf13> er
18:25:40 <Oxf13> warren: you're talking about the wrong thing
18:25:45 <Oxf13> warren: the iommu change is in RC4
18:25:49 <warren> https://bugzilla.redhat.com/show_bug.cgi?id=533739
18:25:50 <buggbot> Bug 533739: urgent, low, ---, katzj, NEW, Partial initialization of Intel BIOS RAID arrays by the live CD could lead to data corruption
18:25:52 <Oxf13> the command-not-found change isn't.
18:26:11 <warren> Oxf13: wasn't notting asking about this?
18:26:36 <Oxf13> warren: he was asking about the iommu change yes.  That is in RC4, part of what necessitated RC4
18:26:49 <notting> yes. there was discussion that the livecd-creator change (which went into RC4) is wrong-in-theory, and should be done at the config level instead
18:26:55 <notting> Oxf13: no, intel raid, not iommu
18:27:00 <Oxf13> er blah
18:27:02 <Oxf13> yes
18:27:06 <Oxf13> intel raid fix is also in RC4
18:27:25 <Oxf13> RC4 == intel raid fix, iommu fix, anaconda external repos fix
18:27:51 <warren> reading Bug 533739 it doesn't indicate it was in RC4.
18:27:53 <buggbot> Bug https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=533739 urgent, low, ---, katzj, NEW, Partial initialization of Intel BIOS RAID arrays by the live CD could lead to data corruption
18:29:28 <warren> ooh, I see, it was patched not pushed to git
18:30:20 <Oxf13> right
18:30:26 <Oxf13> jeremy said we could actually fix this at the config level
18:30:43 <Oxf13> which would have been good info Sunday afternoon as I was scrambling to fix, a little too late on Monday morning
18:30:46 <Oxf13> not his fault
18:30:57 <Oxf13> so really this should just live as a patch in the F-12 build of livecd-tools and go no further
18:32:00 <warren> ok
18:32:07 <Oxf13> #topic Fedora 12 updates
18:32:23 <jwb> they exist
18:32:28 <jwb> more are coming
18:32:31 <Oxf13> We've had 12 updates published over the weekend, and some people have manually tested them (by pointing to mirrors directly and not MM)
18:32:36 <lmacken> there are 125 of them
18:32:49 <Oxf13> so I'm OK with disabling the MM redirect
18:32:50 <notting> jwb: how has the push process been going?
18:32:58 <Oxf13> as soon as I can get in touch with mdomsch that will happen
18:33:02 * nirik hasn't had any problems so far, but of course I have a subset of them installed here.
18:33:09 <jwb> notting, the one push i've done so far went well.  however:
18:33:18 <lmacken> push process has been flawless from my perspective.
18:33:26 <jwb> 1) no deltas because the dirs to delta against didn't exist
18:33:34 <jwb> 2) i have not verified the hashes at all
18:33:52 <jwb> there is another push running right now
18:34:52 <drago01> 125? why so many
18:35:12 <warren> drago01: better than nearly 700 3 weeks ago
18:35:21 <drago01> warren: wtf?
18:35:54 <dgilmore> drago01: we push out a very very large number of updates
18:36:02 <Oxf13> drago01: we have 8K+ source packages
18:36:11 <Oxf13> and maintainers feel the need to have latest package all the time everywhere
18:36:26 <Oxf13> so 125 updates out of 8K+ source packages is a really small slice
18:36:31 <drago01> ok 125 in updates?  or updates-testing?
18:36:36 <Oxf13> combined I think
18:36:39 <drago01> ok
18:36:48 <drago01> that does not sound that bad
18:36:50 <lmacken> 25 in testing 15 in stable
18:37:00 <lmacken> 85 pending
18:39:32 <Oxf13> so yeah, that's that.
18:39:38 <jwb> yeah
18:39:40 <Oxf13> #topic Fedora 12 Everything Tree
18:39:46 <jwb> oh
18:39:48 <Oxf13> We discussed this a but on list, and I really like this idea
18:39:58 <jwb> so once this is enabled, we'll have even more deltas for updates
18:40:00 <Oxf13> As soon as we stage F12 for mirrors, I'd like to open up the Everything tree
18:40:05 <jwb> yeah
18:40:13 <Oxf13> this will allow us to remove the redirect to rawhid eon this repo
18:40:22 <Oxf13> and allow people to get "fedora" repo contents
18:40:28 <Oxf13> and we can move rawhide on to F13
18:41:33 <notting> Oxf13: works for me. i have a rawhide-on-f13 question
18:42:02 <Oxf13> Hopefully we can get the Everything tree active in the next couple days
18:43:08 <Oxf13> #topic Fedora 13
18:43:14 <Oxf13> notting: you had a question?
18:43:33 <notting> sure. with respect to no frozen rawhide, should we turn off images for rawhide when we do the -> f13 switch?
18:43:43 <Oxf13> notting: that's a great question
18:44:55 <Oxf13> on one hand I think we should, as it gets us closer to NFR
18:45:04 <Oxf13> on the other hand, I really wonder if we made the best choice there, not making install images
18:45:29 <Oxf13> but *shrug* the time for that discussion as before, and in the future, so sure, lets turn off images
18:45:50 <Oxf13> I do have one request from anaconda storage team to get a installable tree of F13 content up somewhere, so I can still do that
18:46:05 <dgilmore> Oxf13: are we going to work on making nfr happen at fudcon?
18:46:09 <notting> Oxf13: ok. that's going to require coordination when we do the switch, as the only way to do that right now is to edit the script
18:46:15 <Oxf13> #proposal Disable image creation in F13 rawhide, as part of No Frozen Rawhide
18:46:28 <Oxf13> dgilmore: before and at fudcon yes
18:46:35 <dgilmore> Oxf13: :) awesome
18:46:42 <Oxf13> dgilmore: I'd like to have some planning sessions before fudcon so that we spend more of fudcon doing instead of planning
18:46:58 <dgilmore> Oxf13: that sounds sane
18:47:09 <notting> Oxf13: above and beyond the next 3 releng meetings?
18:47:54 <notting> (i just mean that we can co-opt them for planning if we want)
18:47:57 <Oxf13> notting: maybe.  I still can't really see over the F12 wall, so I'm not good at this right now
18:48:11 <Oxf13> yeah, we'll at least use the releng meetings, but I might call some IRC hackfest sessions
18:48:35 <dgilmore> Oxf13: so do we essentially see it as enabling F-13 in bodhi. and pushing out a F-13 tree as well as the rawhide tree?
18:48:57 <dgilmore> the f-13 tree having images etc
18:49:02 <Oxf13> dgilmore: once we've branched F-13 yes
18:49:08 <Oxf13> that branching won't happen until Alpha timeframe
18:49:20 <Oxf13> once we branch F-13 for alpha, rawhide moves on to F14
18:49:45 <poelcat> Oxf13: i'll volunteer to help set up planning sessions for FUDCon if you like
18:50:09 <Oxf13> poelcat: ok, we can talk.  I really want to get F12 out the door though and breath for a day or so
18:50:18 <dgilmore> Oxf13: ok. i guess i missed something. since i thought there would be a bodhi controlled f13 stream as soon as we switch nfr on
18:50:20 <poelcat> Oxf13: ok, let me know
18:50:27 <dgilmore> ill go back and reread the proposal
18:50:30 <Oxf13> dgilmore: no, that only happens once we branch
18:50:52 <Oxf13> does anybody disagree with enacting the no images in rawhide part of NFR for F13 rawhide?
18:51:18 <dgilmore> Oxf13: i dont, because anyone wanting an image can make there own
18:51:49 <warren> what kind of images?
18:51:54 <Oxf13> install.img
18:51:56 <dgilmore> warren: all images
18:51:59 <warren> oh
18:52:03 <Oxf13> rawhide == just a repo of packages
18:53:35 <pjones> by "no images", he means "don't run pungi on it"
18:53:48 <Oxf13> yep
18:53:57 <Oxf13> hi pjones (:
18:54:01 <pjones> hello.
18:54:04 <Oxf13> pjones: your still on board with this idea right?
18:54:24 <pjones> I don't see a big issue with it; running pungi is easy enough once you drive some policy rules about how to do it into your head.
18:54:42 <pjones> (always remove the whole pungi directory ahead of time, etc.)
18:55:03 <Oxf13> pjones: wonder if I could make that better by automatically blowing away things unless you pass --no-clean
18:55:17 <dgilmore> Oxf13: likely
18:55:47 <Oxf13> #agreed F-13 rawhide will be just a repo of packages, as per no frozen rawhide
18:57:07 <Oxf13> #topic open floor
18:57:15 <Oxf13> are there any other topics we want to discuss?
18:58:45 * dgilmore has nothing
19:01:49 <Oxf13> alright, thanks all!
19:01:51 <Oxf13> #endmeeting