fedora-meeting
LOGS
16:01:47 <adamw> #startmeeting 2009-11-02 QA meeting
16:01:47 <zodbot> Meeting started Mon Nov  2 16:01:47 2009 UTC.  The chair is adamw. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:01:47 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:01:59 <adamw> #topic taking attendance
16:02:04 <adamw> who's here?
16:02:26 * tk009 
16:02:26 * kparal first :)
16:02:28 <kparal> damn
16:02:31 <tk009> not =P
16:02:40 * jlaska lurking
16:02:46 * wwoods hereish
16:03:10 * seelchen here
16:03:14 <jlaska> I'm double booked for meetings right now, so I'll be slower than usual to respond
16:03:46 <adamw> i shall be running the meeting due to our Glorious Leader's inability to manage his schedule ;)
16:04:26 <adamw> #topic previous meeting follow-up
16:04:41 <jlaska> adamw: bitten by DST :(
16:04:45 * mchua lurking
16:04:49 <adamw> hi mel
16:05:23 <adamw> let's see - I did indeed ask Milos to follow-up on his FTBFS idea, but he obviously hasn't yet. he did ask when the next meeting was going to be, but I don't see him here.
16:05:51 <adamw> "Viking-Ice investigating creating a test case for bug#530452 ... and adding to F12 install matrix"
16:05:53 <buggbot> Bug https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=530452 high, low, ---, jmccann, CLOSED RAWHIDE, Gnome sets the keyboard layout to USA after every log in
16:06:02 <adamw> Viking-Ice: ping, any news?
16:07:00 <adamw> I guess he's not here
16:07:14 <adamw> wwoods to add roadmap/tickets for reworking shared autoqa code (watchers, test helper methods, etc) into a proper library - anything on that, will?
16:08:00 <wwoods> yeah!
16:08:08 <wwoods> I'm working in a git branch in autoqa
16:08:38 <wwoods> all of the repo info used by the watchers has been moved to a shared library and a config file
16:08:47 <wwoods> so we can update repo info without needing to replace the watcher code
16:08:56 <adamw> excellent
16:09:03 <adamw> let's save more detail for the autoqa topic
16:09:11 <wwoods> indeed
16:09:16 <adamw> so, onto the next...
16:09:20 <adamw> #topic Review beta test
16:09:21 <wwoods> but It's Coming Along Nicely.
16:09:56 <adamw> so, James put this on to get a feel for how everyone thinks f12 beta testing is coming along
16:10:05 <adamw> with a view to whether we reckon we'll be ready to go RC on schedule
16:10:32 <adamw> does anyone have any particular thoughts?
16:10:42 <wwoods> how much time is left?
16:10:56 * Viking-Ice jumps in late
16:10:58 <tk009> 2 days?
16:10:58 <adamw> i believe wednesday is basically the cutoff
16:11:09 <kparal> http://poelstra.fedorapeople.org/schedules/f-12/f-12-key-tasks.html
16:11:11 <wwoods> after friday's Epic Blocker Review I feel like we have a pretty good handle on the scope of the remaining issues
16:11:19 <kparal> 2 days
16:11:25 <adamw> at that point all the 'code bugs' should be fixed and further builds should only be addressing issues in the iso builds themselves
16:11:34 <wwoods> eep.
16:11:51 <adamw> wwoods: yeah, that was my feeling. i'm hoping to knock off several of those today...
16:12:10 * tk009 didn't look out of fear
16:12:31 <adamw> as far as the blocker bugs go, the list is at https://bugzilla.redhat.com/showdependencytree.cgi?id=473303&hide_resolved=1 for reference
16:12:47 <adamw> it still looks quite long but as I said I hope to close rather a few of those today...hopefully
16:13:01 <wwoods> AFAICT: 25 open bugs, none NEW, 12 ASSIGNED, 13 MODIFIED
16:13:18 <wwoods> in theory all MODIFIED bugs should be closeable as soon as we confirm the fix
16:14:09 <adamw> some of the ASSIGNED are somewhat misleading
16:14:29 <adamw> i haven't got an exact count but I think off the top of my head there's only 7 or 8 where we're really still waiting on developer action
16:14:53 <adamw> and some of them are pretty easy stuff, like the bug that's just davidz reminding himself to do a tag request for an updated DeviceKit-disks build
16:15:17 <wwoods> gotcha
16:15:28 <adamw> overall i'm fairly hopeful we'll actually be able to more or less knock everything off in time
16:15:53 <wwoods> later today can we run through the list and close/move bugs to MODIFIED where appropriate, to make this less scary?
16:16:15 <wwoods> I don't feel like there's any hair-on-fire-panic issues but that list is worry-making
16:16:30 <adamw> i'll be doing that myself anyway, but if you want to make it an event we could
16:16:39 <adamw> obviously will just didn't get enough blocker bug review meeting action on friday =)
16:17:01 <wwoods> nah, just wanted to make sure someone was directly responsible for managing the list
16:17:09 * wwoods hungers for it
16:17:18 <wwoods> just don't have myself CC'd on enough bugs anymore
16:17:27 <adamw> there's clear action items here, of course, btw - most of the bugs in MODIFIED need some sort of testing, so please everyone do take a minute to look through the MODIFIED items and provide any feedback you can, if you have time
16:17:53 <adamw> so that's the blocker bug perspective...anyone have perspective from any other angles? i haven't been doing / following much install testing for e.g.
16:20:34 <adamw> i guess not!
16:21:03 <drago01> fwif did two installs yesterday one from dvd one livecd both where fine
16:21:08 <adamw> well, my feeling is we may well be able to make it for wednesday but it's hard to say for sure at this point. i'm reasonably optimistic.
16:21:10 <adamw> thanks, drago.
16:21:57 <adamw> ok, onto the next one...
16:22:00 <adamw> #topic AutoQA update
16:22:08 <adamw> step forward our brave autoqa warriors!
16:22:26 <wwoods> bam!
16:22:41 <wwoods> so yeah: reworking autoqa code to provide a nice python library
16:23:38 <wwoods> #link http://git.fedorahosted.org/git/?p=autoqa.git;a=tree;f=lib/python;hb=wwoods-autotest
16:23:45 <wwoods> oh wait. #link is unnecessary. heh.
16:24:16 <wwoods> anyway, other shared (or shareable) code from the various tests is being moved in there
16:24:33 <wwoods> so e.g. the virtguest code that rats_install uses is now available for any other tests to use
16:25:00 <wwoods> there's a koji_utils module that can be used to get the NVR of previous released versions of a given package
16:25:13 <wwoods> etc.
16:25:25 <wwoods> I hope to have this merged into master by the end of the week
16:25:35 <wwoods> and the existing tests modified to use the shared code
16:25:57 <wwoods> and to start actually wiring up the post-koji-build watcher and get rpmguard running
16:26:15 <kparal> which is also my task :)
16:26:21 <wwoods> one other note
16:26:32 <wwoods> we're packaging and testing a slightly newer autotest version
16:26:52 <wwoods> so there may be some weird emails and stuff coming from that as we set up the new autotest version and work on the new hook and adapt the tests
16:27:28 <adamw> thanks for the warning
16:27:37 <adamw> anything of interest on the rpmguard front, kparal?
16:28:46 <kparal> unfortunatelly there has not been any development in rpmguard front in the past week. I have only created a few tickets with possible enhancements.
16:29:09 <kparal> the main task now will be autoqa integration. when that works, I can work more on improving the code
16:29:27 <adamw> alright, thanks
16:29:37 <adamw> so onto...
16:29:42 <adamw> #topic upcoming QA events
16:30:17 <adamw> see the list in the agenda: https://www.redhat.com/archives/fedora-test-list/2009-November/msg00043.html
16:30:32 <adamw> end of beta testing is listed as today, which is clearly a sick joke ;)
16:31:08 <adamw> but yeah, RC composing action begins wednesday. we have a blocker bug day listed for friday, which seems slightly odd to me as - by my understanding - we can't fix any more blocker bugs after wednesday.
16:31:18 <adamw> without slipping.
16:31:23 <adamw> Oxf13: any clarifications?
16:31:54 <Oxf13> adamw: we can fix bugs that show up from the RC
16:31:59 <Oxf13> up until Monday without slipping
16:32:13 <Oxf13> the following Monday is the go/nogo date, where it's either fixed or we're slipping
16:32:23 <adamw> ah, ok
16:32:35 <adamw> but we want to fix as much as possible for the RC start date anyway
16:32:49 <Oxf13> we have to have the blocker list clear before we can enter RC
16:32:55 <Oxf13> so having an RC on Wed is not a forgone conclusion
16:33:09 <adamw> alright
16:33:12 <adamw> thanks for the clarification
16:33:42 <adamw> so yeah, not much new here: now until wednesday is full-steam-ahead blocker bug bashing mode
16:34:09 <adamw> if you're not working on blocker bugs you'd better have a note from your doctor explaining that you have a serious case of 'dead' or you'll have me to answer to ;)
16:34:31 <adamw> anything you wanted to mention about the upcoming week, oxf13?
16:34:43 * jlaska no longer distracted
16:35:05 <adamw> jlaska: feel free to add anything i'm missing
16:35:25 * thomasj late lurking
16:35:40 <jlaska> Liam is planning to kick off a RC install test run on wednesday
16:35:49 <Oxf13> We have seriously tiny amount of time between the RC compose and the go/nogo vote
16:36:14 <jlaska> ideally this would be against the RC ... but Oxf13 mentioned if we haven't reached closure on the F12Blocker list, he would compose a "Test Compose" for us to track updated install results
16:36:16 <Oxf13> so we need to be hitting rawhide with a vengeance leading up to the RC, and also hitting RC with a vengeance to make sure it's up to snuff before we vote on it.
16:36:46 <adamw> right
16:36:57 <jlaska> denise: are there any bugs in progress on the anaconda side that would be good to have land in the wednesday compose
16:37:03 <jlaska> whether it's RC or 'test compose' ?
16:37:24 <jlaska> we can work that outside the meeting, but just something to coordinate for that compose milestone
16:37:36 <adamw> all the anaconda bugs are currently in MODIFIED state according to the blocker list
16:37:43 <adamw> so the onus there seems to be on us
16:37:51 <jlaska> sort of
16:37:53 <adamw> (pun not intended)
16:38:19 <jlaska> there are a few inprogress, before we do the compose, I think it would be helpful to check-in with her team
16:38:30 <jlaska> to avoid spinning another compose the next day with a new anaconda
16:38:49 <adamw> all the anaconda bugs currently marked as blocker bugs are intended to be fixed in anaconda 12.42, which was tagged today
16:39:00 <adamw> so we definitely need all of those re-tested with today's rawhide
16:39:12 <jlaska> #action jlaska to check-in with anaconda-devel team for status on any issues they are monitoring for the wednesday RC compose
16:41:38 <jlaska> that's it from me
16:41:45 <adamw> alright
16:41:52 <adamw> anything we didn't cover on the topic of upcoming events?
16:41:58 <adamw> there's no test day this week
16:43:14 <adamw> in that case, moving on to...
16:43:16 <adamw> #topic open floor
16:43:30 <adamw> anything at all anyone wants to share? come on, don't be shy!
16:43:49 <jlaska> nothing here
16:45:20 <adamw> alright, banging gavel in 3...
16:45:21 <adamw> 2...
16:45:22 <adamw> 1...
16:45:31 <adamw> thanks for coming, everyone
16:45:35 <tk009> =)
16:45:37 <adamw> #endmeeting