fedora-meeting
LOGS
17:00:33 <jds2001> #startmeeting FESCo meeting 20091023
17:00:33 <zodbot> Meeting started Fri Oct 23 17:00:33 2009 UTC.  The chair is jds2001. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:33 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
17:00:43 * jds2001 is at a Fedora Talk FAD ATM
17:00:47 <jds2001> #chair dgilmore dwmw2 notting nirik sharkcz jds2001 j-rod skvidal Kevin_Kofler
17:00:47 <zodbot> Current chairs: Kevin_Kofler dgilmore dwmw2 j-rod jds2001 nirik notting sharkcz skvidal
17:01:01 * j-rod here on time for once
17:01:05 * sharkcz is here
17:01:26 <Kevin_Kofler> Present.
17:01:43 * notting is here
17:03:00 <jds2001> alrighty, lets get started
17:03:23 <jds2001> #topic Documentation
17:03:32 <jds2001> .fesco 261
17:03:33 <zodbot> jds2001: #261 (Followup on documenting FESCo decisions on wiki) - FESCo - Trac - https://fedorahosted.org/fesco/ticket/261
17:03:46 <jds2001> this is the only item that I had for today
17:04:14 <jds2001> seems sane to me, for a decision requirng documentation, we all agree on it
17:04:31 <Kevin_Kofler> Why does this need a policy at all? It's just common sense that our stuff should be documented.
17:04:45 <jds2001> because we have utterly failed at it.
17:05:05 <jds2001> not that it needs to be a policy per se, more of a SOP
17:05:11 <jds2001> that is written down.
17:05:13 <Kevin_Kofler> As for the precise policy described, there are some things which aren't quite right, for example we aren't supposed to edit Packaging:* (and AFAIK the ACLs won't even allow it).
17:05:24 <jds2001> correct.
17:06:04 <jds2001> the proposla that I was reading is "documetnation is good, FESCo should figure out some way that works for them, here's an idea"
17:06:37 <Kevin_Kofler> On the other hand, as we're the ones having the final word on packaging guideline changes, maybe it'd also make sense to let us (FESCo) edit the relevant wiki pages?
17:07:03 <jds2001> I wouldn't really want that responsibiltiy
17:07:10 <Kevin_Kofler> The current process is that FPC passes a guideline, we approve it, then it has to go back to FPC for the wiki edit.
17:07:28 <jds2001> there's a lot of outher decisions that don't belong in Packaging: that are not documented.
17:07:59 <jds2001> well, add step 0 in there, we say "this is a good thing to do"
17:08:16 <jds2001> for example, the maven cvs branching thing.
17:08:31 * dgilmore is here
17:09:33 <jds2001> so i dont think there is any "ppolicy" decision to be made here.
17:09:49 <jds2001> but rather, here's a common sense proposal, us it!
17:09:54 <jds2001> s/us/use
17:11:28 <jds2001> so how's this: when a policy decision is made not applicable to FPC, then the meeting chair will change the keyword of the ticket from "meeting" to "writeup", and assign it to a specific person
17:11:52 <jds2001> at the next meeting, all such tickets will be poked for status.
17:12:18 <Kevin_Kofler> That makes sense.
17:12:22 <Kevin_Kofler> So +1 from me.
17:12:44 <notting> yep, sounds good. +1
17:13:02 <jds2001> +1 from me :)
17:13:04 * sharkcz agrees +1
17:13:05 <j-rod> +1
17:13:17 <jds2001> #agreed when a policy decision is made not applicable to FPC, then the meeting chair will change the keyword of the  ticket from "meeting" to "writeup", and assign it to a specific person
17:13:32 <jds2001> #topic open floor
17:13:38 <jds2001> anything else?
17:14:25 * jds2001 ends the meeting in 30
17:14:32 <notting> there's a beta. it has blocker bugs. fesco encourages people to fix them.
17:14:40 <Kevin_Kofler> I have one more thing...
17:14:58 <jds2001> #info there's a beta. it has blocker bugs. fesco encourages people to fix them.
17:15:15 <Kevin_Kofler> The Design Team apparently wants to do some artwork changes now, post beta, and with the release quite imminent.
17:15:44 <Kevin_Kofler> Should they be allowed to do this? If not, who's responsible for saying "no"? Us? Rel-eng?
17:15:48 <jds2001> yeah, stickster briefed me on that (I'm here with him)
17:15:50 <sharkcz> on web or in release?
17:15:59 <jds2001> in release
17:15:59 <notting> in release
17:15:59 <jds2001> the background
17:16:12 * dgilmore is +1 to above
17:16:20 * jds2001 doesn't see a huge problem, not like wallpaper has bugs :D
17:16:32 <Kevin_Kofler> This may require us to change the KDE themes to fit with the changed wallpapers.
17:16:45 <Kevin_Kofler> And at least the KDM theme is quite susceptible to bugs.
17:16:52 <jds2001> the new wallpapers are available...
17:16:56 <Kevin_Kofler> But then again, just swapping out the wallpapers should be fairly safe.
17:17:27 <drago01> is there a link to the new wallpapers?
17:17:36 <Kevin_Kofler> What really annoys me is the Design Team's track record of not following schedules.
17:17:43 <notting> drago01: design-team list, 'F12 Final wallpaper' thread
17:17:49 <drago01> notting: thx
17:18:20 <Kevin_Kofler> I normally favor a flexible approach when it comes to freezes, but when late delivery is systematic, at some point it really gets old.
17:20:20 <jds2001> yeah, I agree
17:20:22 * skvidal apologizes for not being around - I completely spaced on the meeting
17:21:24 <Kevin_Kofler> And things like the wallpapers need to get delivered before the last moment because at least KDM and KSplash themes (possibly also other stuff in other desktops), and Plymouth themes if they're being made (which hasn't been done for each release, probably also because of timing) are based on them.
17:21:34 <jds2001> so what's the action item here?
17:21:53 <Kevin_Kofler> Good question...
17:22:15 <Kevin_Kofler> The thing is, I don't know how to proceed, I'm just unhappy with the state of affairs, but I'm not sure what the best resolution is.
17:22:45 <Kevin_Kofler> I think we definitely need to get the message out that artwork will need to be delivered earlier for F13.
17:22:59 <Kevin_Kofler> But I don't know how to handle the current F12 situation.
17:23:04 <jds2001> well, moving the naming earlier was supposed ot help with that.
17:23:32 <Kevin_Kofler> Not if you restart from scratch twice.
17:23:33 <jds2001> but it clearly didn't
17:23:37 <jds2001> true
17:23:52 <Kevin_Kofler> They delivered something for Alpha, then something different for Beta and now they want to do a third thing for the release.
17:25:52 <jds2001> so for the current situation, what would a satisfactory resolution be?
17:26:04 <skvidal> no artwork!
17:26:09 <Kevin_Kofler> LOL
17:26:11 <skvidal> go back to the X stipple background
17:26:26 <skvidal> I want to actually get motion sickness on certain big crt monitors
17:26:32 <skvidal> :)
17:26:35 <jds2001> hehe
17:26:58 <j-rod> have they been scolded for late delivery during prior releases?
17:27:02 <notting> check with docs/marketing - when do the screenshots and tour freeze?
17:27:39 <j-rod> if so, then enough is enough already, say no, and maybe they'll figure it out for next release
17:28:09 <Kevin_Kofler> What I know is that jreznik, who's been working on the KDE artwork, has complained about this thing and suggested we use upstream KDE artwork for F13 because our Design Team can't be worked with.
17:28:33 <jds2001> that would be utter fail.
17:28:39 <j-rod> if not, and if the new art doesn't cause any earth-shattering shift reqs in theming, let it in, but warn them if they don't have their shit together sooner in the future, they're going to get rejected
17:28:40 <skvidal> should we just ask the person "in charge" of the design team to explain?
17:28:47 <skvidal> mizmo: ping
17:28:49 <jds2001> i think that would be mizmo
17:29:35 <mizmo> dude i replied to his message on design-team
17:29:50 <mizmo> i dont see how we're hard to work with
17:29:55 <mizmo> we had drafts of stuff out for the alpha
17:30:00 <skvidal> mizmo: that's not the question
17:30:04 <mizmo> we're continuously trying to improve the artwork
17:30:10 <mizmo> is that not allowed?
17:30:19 <mizmo> is it expected to stay the same from alpha on?
17:30:46 <mizmo> because not too long ago, you didnt see any new artwork until the final. then the RC. then the beta. now you're getting it in the alpha, the earliest yet
17:30:59 <mizmo> why? because we want to get feedback on it and make improvements based on the feedback
17:31:12 <mizmo> if we're not allowed to make improvements than i do not see the point in bothering to get it in so early
17:31:36 <mizmo> there is a clear progression of improvement from release to release in how early the design team releases omcment.
17:31:41 <j-rod> ultimately, the art goes in packages
17:31:43 <Kevin_Kofler> It's supposed to get in early because it's the feature freeze and artwork is a feature too.
17:31:50 <mizmo> so i am very deeply hurt for being criticized on being hard to work with
17:31:53 <Kevin_Kofler> And for at least 2 more reasons:
17:31:57 <jds2001> Kevin_Kofler: never has been before.
17:31:58 <mizmo> im sorry Kevin_Kofler but artwork isn't code. it's not a 'feature'
17:32:06 <Oxf13> Feature freeze means "testable"
17:32:11 <Kevin_Kofler> * it shows up on screenshots. Often screenshots of prereleases are used in articles, documentation etc.
17:32:12 <mizmo> and it's really highly visible
17:32:12 <Oxf13> if the art is 'testable' then it got in
17:32:20 <notting> mizmo: as a non-artist, what i see is a progression from "mosaic" (alpha) to "mosaic + fog/rain (beta)" to "all blur/rain (proposed)". so it's a progression/refining, but it now doesn't seem to resemble what we had earlier. (not claiming it is better or worse)
17:32:27 <Kevin_Kofler> * the backgrounds are required to build KDM, KSplash and Plymouth themes
17:32:32 <Oxf13> art can be "bugfixed" after feature freeze, just like any other feature
17:32:32 <Kevin_Kofler> And possibly more stuff.
17:32:44 <mizmo> notting: in any artistic process if you look at first sketch to final it's gonna look different. it has to be viewed as a progression.
17:33:07 <Kevin_Kofler> We're always struggling with KDM and KSplash and AFAIK the Plymouth folks stopped trying to match our wallpapers after Solar due to scheduling.
17:33:08 <notting> mizmo: yes. but if you don't see any of the intermediates now, you don't really see the relation at all
17:33:47 <halfline> no
17:33:56 <halfline> plymouth didn't stop because of scheduling
17:34:12 <halfline> there was a thread on the art list where mlanglie proposed we stick with one theme
17:34:15 <halfline> and refine it over time
17:34:21 <halfline> so that's what we're doing
17:34:28 <mizmo> notting: i know youre saying but im not sure how it's relevant.
17:34:57 <mizmo> halfline: per release
17:35:34 <jds2001> mizmo: i think that halfline was talking about the plymouth art
17:35:44 <jds2001> or am i totally wrong?
17:35:45 <mizmo> oh okay
17:35:48 <notting> mizmo: it's relevant *if* someone else is trying to do other design to match the wallpaper theme, in that they may be keying off some aspect of the wallpaper that is refined away. i don't know that that's the case here.
17:35:48 <halfline> yes, plymouth theme specifically
17:35:51 <mizmo> jds2001: you're right
17:35:55 <halfline> i can find the thread if people are interested
17:36:28 <mizmo> notting: the wallpapers still have a very strong 'bokeh' design element. if not all, most of the splashes already done have bokeh and would match. so only the wallpaper really needs to change for us to have a matching set.
17:36:29 <j-rod> I think updated art should more or less follow updated package rules after freeze -- needs justification and rel-eng approval to get tagged into the release
17:36:32 <jds2001> notting: im not aware of anyone doing "derivative designs"
17:37:20 <notting> mizmo: from a practical standpoint, there's the freeze dates for the docs and wiki tours that need to be considered. i'm still trying to dig up those dates.
17:37:51 <Kevin_Kofler> Well, what jreznik told me in F11 timeframe is that he talked to the guy who did the Plymouth Solar theme and that guy said he couldn't do a Leonidas theme because the wallpapers weren't ready in time (they were ready when he was on vacation and the deep freeze was right after that).
17:38:05 <Kevin_Kofler> But this is third-hand information, so take it with a grain of salt.
17:38:05 <mizmo> notting: honestly i really would not like to have to be changing art this late in the game it is true. but after it was recently pointed out to me that the wallpaper looks like a dark bathroom floor, that's all i see when i look at it and im ashamed of it
17:38:50 <notting> mizmo: aha, all hail polecat's collection of taskjuggler.
17:39:00 <notting> 33.  	Update Fedora tour page  	Wed 2009-10-28  	Wed 2009-11-04
17:39:20 <jds2001> so that's not yet started
17:39:22 <Kevin_Kofler> jds2001: KDE SIG is doing derivative designs.
17:39:23 <skvidal> mizmo: does it make any difference if some of us really like the current wallpaper in the beta?
17:39:23 <halfline> Kevin_Kofler: i'm pretty sure charlie did a leonidas theme but we never landed it
17:39:28 <Kevin_Kofler> That's what KSplash themes and KDM themes are.
17:39:39 <notting> jds2001: correct, but i think that would need to be a hard freeze point
17:39:41 <halfline> it was some theme with greek elements to it
17:39:51 * Oxf13 is one of those that really likes the beta wallpaper
17:39:52 <jds2001> Kevin_Kofler: i thought that you just took the artwork as is
17:39:54 <jds2001> Kevin_Kofler: sorry
17:40:11 <Kevin_Kofler> We take the wallpaper as is, but then we need to put matching design elements on top of it.
17:40:27 <jds2001> right, the design elemtns havent changed.
17:40:37 <Kevin_Kofler> If the wallpaper changes colors, if they put some objects right under a translucent dialog or several other possible changes, that can all make them look ugly.
17:40:38 <skvidal> Oxf13: my first thought was either tron or really cool 3d qbert :-)
17:40:40 <mizmo> skvidal: art is hard, let's go shopping
17:41:13 <mizmo> Kevin_Kofler: the wallpaper has changed colors because apparently i was able to go months before anyone pointed out that my artwork was coming out purple and not blue. i got a new laptop and its color profile was way off until i got it fixed yesterday
17:41:36 <skvidal> mizmo: I guess if you liked it before when it was released - don't let a few folks derisive comments destroy your perspective
17:42:02 * jds2001 thinks that the beta wallpaper is hot too.
17:42:16 <Kevin_Kofler> mizmo: I see, but this does mean we do have to change the KDM theme's colors to match the color changes.
17:42:17 <jds2001> a bathroom floor never entered into my mind :)
17:42:25 <mizmo> skvidal: they're right though. see the thing about artwork is it's a form of commnunication. you send a message with it. no communicatoin is perfect. but i know the message i intended with the artwork, and it's not coming across.
17:42:35 <Kevin_Kofler> Otherwise the colors will look mismatched and possibly ugly.
17:42:43 <Kevin_Kofler> So this is an example of how wallpaper changes can affect the KDE themes.
17:42:44 <skvidal> <shrug>
17:42:46 <mizmo> Kevin_Kofler: maybe you should have pointed out that it was purple to me when you first got it. (not that anyone else bothered to)
17:43:10 <Kevin_Kofler> I suppose nobody knew it was supposed to be blue. ;-)
17:43:16 <skvidal> I think this is like any other development process - it won't entirely be perfect and it can be patched in updates as you go, provided it "works" at all
17:44:07 <skvidal> mizmo: and perhaps spend less time talking to people who spend a lot of time with their faces close to the bathroom floor
17:44:11 <Kevin_Kofler> We can fix the KDM theme in updates indeed, but that won't help the live images. :-(
17:44:16 <skvidal> :)
17:44:41 <skvidal> Kevin_Kofler: but it's still functional - you make it sound like having a sub-perfect piece of artwork is a fatal flaw
17:44:52 <mizmo> skvidal: yeh but the artwork is a little different. artwork needs to be way more perfect than anything else from release
17:44:59 <skvidal> esp consider it's the kdm login screen - you see it for, hoopefully, about 30s and then it is gone
17:45:27 <mizmo> (i guess im quite biased though)
17:45:31 <skvidal> mizmo: I'd argue that the loader, grub, kernel, glibc, rpm and yum need to be more perfect but that's just my 'install things' bias
17:45:36 <notting> Kevin_Kofler: when you say 'we', are you proxying for a specific member of the kde team?
17:46:37 <Kevin_Kofler> Usually it's one of us per release. For the last couple releases, it has been jreznik, but some earlier themes have been done by me, and before that by than.
17:46:42 <notting> i.e., do we need to do a  'make sure <foo> gets pre-release artwork even before it's packaged'
17:47:03 <mizmo> skvidal: i guess, the artwork is very very very visible and very prominent, and even if you fix afterwards i dont want people thinking 'f12 the drunken night spent on the floor in a public restroom release'
17:47:21 <Kevin_Kofler> So the current contact person is jreznik.
17:47:30 <notting> mizmo: don't worry, that was the... what fudcon was that? release
17:48:08 <skvidal> mizmo: righto.
17:48:21 <notting> in any case
17:48:21 <skvidal> mizmo: If people think about f12 AT ALL - I'm happy, actually.
17:49:14 <notting> mizmo: Kevin_Kofler: as above, they start making the doc/tour screenshots next wednesday. can we ensure that the final-final artwork and related changes are all done and in packages with tag requests by next Tuesday, so they can be tagged for wednesday and the docs/mktg team can start on that task?
17:49:16 <mizmo> any way. now is a really bad time for me so im sorry if im grumpy but i've got 42 iterations of wallpaper i've spent the past 20+ hours hacking on as quickly as possible, it's a miserable process especially considering my shocking color mangaement discovery , so im a little over sensitive at the moment
17:49:26 <mizmo> notting: sure
17:50:35 <Oxf13> question, is jreznik involved in the artlist where mo is sending about these wallpapers?
17:51:04 <mizmo> yes he is, but i do not think he spoke up when we worked with poelcat to get our items on the schedule and mapped out, so i believe part of the problem here is we have no idea what his deadlines are
17:51:51 <Kevin_Kofler> notting: But what if people want to do KDM and KSplash screenshots? Then they'll need those themes updated (color scheme matching, maybe other changes), too.
17:52:15 <notting> that's why i'm asking you if that 'related changes' can be done by then
17:52:30 <Kevin_Kofler> I don't know.
17:53:00 <Kevin_Kofler> jreznik is quite busy.
17:53:19 <mizmo> we are all busy. looks like i dont get a weekend this weekend.
17:53:29 <mizmo> but in the end
17:53:38 <mizmo> it's worth it if fedora looks kick-ass
17:53:38 <Kevin_Kofler> Maybe one of us other KDE SIG folks can step in, but we don't want to end up with "too many cooks" chaos.
17:54:46 <Kevin_Kofler> Are the updated wallpapers finalized yet?
17:55:08 <mizmo> no, i am working on them right now
17:55:15 <mizmo> thus, the no weekend
17:55:46 <notting> mizmo: is the current candidate just the one with the highest number?
17:56:06 <mizmo> nope right now im developing this one http://duffy.fedorapeople.org/art/f12/oct%2020/rain31.png
17:58:41 * jds2001 has to go
17:58:49 <jds2001> someone wanna wrap this up for me?
17:59:04 * jds2001 thinks we're going in circles here at any rate and not getting much of anywhere.
17:59:32 <notting> proposal: all changes for both artwork, and kde theming thereof, need to be in packages w/tag requests by next tuesday, or we cannot change?
18:00:05 <stickster> *sigh
18:00:43 <mizmo> (sorry :'( )
18:01:09 <jds2001> sounds decent to me, if a bit heavy-handed
18:02:22 <Kevin_Kofler> I'm not sure we're not asking the impossible there. If mizmo needs the weekend to finalize the wallpaper, that just leaves 2 days for jreznik to update the KDE themes.
18:03:22 <mizmo> does the wallpaper need to be updated in kde?
18:03:24 <mizmo> does it really?
18:03:30 <Kevin_Kofler> What I see is that the wallpaper is completely different, assuming https://fedoraproject.org/wiki/F12_Artwork/Beta is what we're comparing with.
18:03:32 <notting> it would be odd if they were different
18:03:34 <mizmo> we used to do completely different designs for gdm vs wallpaper
18:03:44 <mizmo> i dont think it would be that strange
18:04:21 <mizmo> over time we've made everything off one base image but at one point every single image was different
18:04:47 <Kevin_Kofler> That rain31.png also has one issue in that it is very crowded right at the place where we'll want to put the KSplash progress bar (slightly below the center).
18:04:55 <mizmo> Kevin_Kofler: it's a draft
18:05:38 <mizmo> in the future it would be nice for us to have a set of requirements for the KDE artwork
18:05:41 <mizmo> right now we have nothing
18:05:52 <mizmo> it's not difficult though to mask the bottom of the image if thats where you need to put a progress bar.
18:06:54 <Kevin_Kofler> Hmmm, wait before doing any changes, I'll need to check how the current KSplash theme actually looks.
18:07:09 <skvidal> notting: +1
18:07:13 <skvidal> notting: to your proposal
18:07:31 <Kevin_Kofler> But chances are we'll have to completely reposition the elements anyway as the geometric structure of the wallpaper is very different from the old one.
18:07:57 <mizmo> skvidal: but i dont want to bust my ass coming up with something kick ass that has to be thrown out because kde has to match
18:08:02 <mizmo> skvidal: i think that's a silly requirement
18:08:28 <mizmo> i can get something kickass in by tuesday i am sure
18:08:39 <skvidal> mizmo: okay - that's fine - then you can issue an update like anyone else. I'm sorry.
18:08:45 <skvidal> that's how I feel about it
18:08:47 <skvidal> hence my vote
18:08:54 <mizmo> the artwork can't be updated like that
18:08:59 <mizmo> the artwork is used for everything
18:09:04 <mizmo> look at the design team schedule
18:09:05 <mizmo> release postesrs
18:09:08 <Kevin_Kofler> For reference, this was the final F11 KSplash theme: http://fedoreando.files.wordpress.com/2009/04/leonidas-ksplash.png
18:09:08 <mizmo> flyers
18:09:10 <mizmo> banners
18:09:11 <mizmo> tshirts
18:09:23 <Kevin_Kofler> The whirl below the Fedora logo was the progress indicator.
18:09:43 <Kevin_Kofler> Some KSplash themes put it further down.
18:10:00 <Kevin_Kofler> But center bottom is the general position where it'll have to be.
18:10:02 <skvidal> do any other fesco members have a position on the proposal on the table?
18:10:20 <mizmo> Kevin_Kofler: no matter what the composition of the wallpaper, it's hardly a challenge as long as im given requirements as to how large and where the progress will be positioned
18:10:41 <sharkcz> +1 to notting's proposal
18:10:46 <mizmo> i don't think kde should have to match. it's not the default spin.
18:10:51 <mizmo> the default spin will match
18:11:00 <mizmo> please :(
18:11:16 <mizmo> :'(
18:11:18 <Kevin_Kofler> The KDM theme generally also wants to put stuff in the center.
18:11:25 <mizmo> Kevin_Kofler: not a problem. seriously.
18:11:34 <Kevin_Kofler> This is the upstream Air theme on which our current design is based on: http://moinakg.files.wordpress.com/2009/09/kde-kdm1.png
18:12:23 <mizmo> can we say the new wallpaper goes in, if kde can't be updated in time, they could go with upstream theming?
18:12:25 <Kevin_Kofler> I can see if we can get screenshots of our current theme to you ASAP. These were just to give the general idea of where components are placed.
18:12:41 <Kevin_Kofler> mizmo: No.
18:12:50 <Kevin_Kofler> It's too late to change to that now.
18:12:52 <mizmo> this is not fair.
18:13:02 <Kevin_Kofler> And we'd be throwing away all the work jreznik has done on the Constantine theming so far!
18:13:08 <mizmo> i just threw away an entire fucking week
18:13:13 <mizmo> trying to fix the wallpaper
18:13:23 <mizmo> i dont have a fucking week
18:13:26 <mizmo> what a waste
18:13:44 <mizmo> im done.
18:14:13 <Kevin_Kofler> We could allow for a few more days to complete the KDE theming, I don't think Tuesday is realistic at all.
18:14:57 * skvidal wonders where the rest of fesco went
18:15:39 <skvidal> dgilmore, j-rod, jds2001, nirik, dwmw2_gone ping
18:15:47 <notting> jds2001 did say he had to leav
18:16:02 <skvidal> and I assume dwmw2_gone is gone
18:16:03 <skvidal> so
18:16:11 <skvidal> dgilmore, j-rod, nirik: ping
18:16:43 <j-rod> hrm?
18:16:53 * j-rod got distracted...
18:16:57 <sharkcz> nirik is away too
18:16:58 <skvidal> got a position on the current proposal
18:17:06 <skvidal> do we even have a quorum?
18:17:17 <dgilmore> skvidal: pong
18:18:05 <skvidal> there has been a long discussion with regard to the artwork  and what is the last time to change it
18:18:22 <skvidal> mizmo has presented a case for letting her do more work this weekend.
18:18:27 <dgilmore> skvidal: ill read abck.  i thought the meeting was done and stopped paying attention
18:18:32 <skvidal> Kevin_Kofler: has presented a case against it
18:19:01 <skvidal> notting has made a proposal
18:19:35 <skvidal> the proposal was
18:19:36 <skvidal> [13:59] <notting> proposal: all changes for both artwork, and kde theming thereof, need to be in packages w/tag requests by next tuesday, or we cannot change?
18:19:43 <Kevin_Kofler> TBH, I think that proposal isn't going to work, the timeframe is too short.
18:20:07 <Kevin_Kofler> So we'd ask mizmo to do the work over the weekend just to have it thrown out because there's no time left to complete the KDE theme.
18:20:12 <mccann> notting: that isn't going to work for the desktop spin
18:20:24 <mccann> notting: how can we do our own thing then?
18:20:43 <mizmo> could the kde spin keep the beta artwork as a unit
18:20:48 <mizmo> and the desktop spin get the updated wallpaper
18:20:55 <notting> ... that is the date that's been on the schedule for many months
18:21:00 <mizmo> then the kde spin could get a 0-day update to get the final artwork if they choose?
18:21:18 <mizmo> then they dont clash between login screen and wallpaper
18:21:23 <Kevin_Kofler> We've considered that in the #fedora-kde discussion.
18:21:28 <mizmo> and thematically the artwork still fits.
18:21:37 <mccann> notting: we're not going out the door with a wallpaper we don't want - that is just dumb
18:21:37 <notting> 0-day updates for something that's a component shown to everyone on the live spin isn't really a practical fix
18:21:55 <Kevin_Kofler> But the thing is, our stuff is going to look outdated if we stick with the same artwork as the beta whereas GNOME gets updated. :-(
18:22:13 <mizmo> notting: but that was the alternative i thought on the table if we didn't make tuesday
18:22:27 <mizmo> Kevin_Kofler: outdated? whose to say which is newer?
18:22:40 <mizmo> Kevin_Kofler: it's not like i designed the beta wallpaper in the 1980s
18:22:58 * notting makes note to request parachute pant artwork
18:23:07 <mizmo> day-glo parachute pants
18:23:11 <Southern_Gentlem> mayi make a comment
18:23:13 <mizmo> and jelly shoes!
18:23:19 <mccann> this is insane - we can't design multiple products at the same time
18:23:42 <dgilmore> im ok with notting proposal
18:24:09 <mizmo> dgilmore: are you okay with me spending a weekend doing work that might get thrown out if jreznik happens to not have time to update kdm?
18:24:13 <mizmo> or ksplash or whatever
18:24:33 <rdieter> mizmo: keeping the existing background wallpaper available is agreeable, and a reasonable backup plan
18:24:36 <mccann> kde cannot be in the critical path for getting the design we want in fedora
18:24:46 <mizmo> rdieter: for the whole distro or for KDE?
18:24:46 <Kevin_Kofler> mccann: Except it is...
18:24:54 <notting> then it needs designed earlier
18:25:05 <Southern_Gentlem> This is Fedora, Not gnome vs kde which appears to be the argument is coming down to
18:25:12 <dgilmore> mizmo: if kde misses the boat then thats there own fault.  as long as it makes it in somewhere im ok with it.
18:25:13 <rdieter> mizmo: whole distro is preferable (ie, doesn't require any modications on our part)
18:25:14 <mizmo> kde has a different audience than the gnome deskto
18:25:15 <Kevin_Kofler> notting: Right, that's the whole point.
18:25:16 <notting> there's a difference between 'polish' and 'design'
18:25:17 <mccann> notting: that's nice and all but...
18:25:22 <dgilmore> mizmo: i happen to really like the beta artwork
18:25:24 <mizmo> i would argue to serve its audience kde should have a wallpaper that appeals to that audience
18:25:40 <mizmo> dgilmore: it's not the wallpaper i as a designer want going out in the final. i would be ashamed of it.
18:25:50 <notting> i mean, if i *REALLY* want to piss everyone off
18:25:54 <dgilmore> mizmo: :( i still like it
18:26:11 <notting> i should note that the design team's own schedule says: "28.  	Final Packaging of All Release Artwork  	Tue 2009-09-29  	Tue 2009-09-29"
18:26:16 <stickster> If I can offer an opinion
18:26:28 <Kevin_Kofler> We've had only positive feedback for the Beta artwork in KDE land.
18:26:39 * jds2001 is back, sorry
18:26:39 <Kevin_Kofler> That includes the wallpaper, and the themes jreznik did on top of it.
18:26:58 * stickster is sorry to come in late, we have a FAD going on right now and so I can't watch IRC all day :-)
18:26:59 <mizmo> Kevin_Kofler: KDE land is a different land than GNOME land. and that's fine. if the wallpaper works for your userbase then stick with it.
18:27:28 <stickster> I was going to ask, has anyone brought up the schedule? I see that notting just did.
18:27:39 <mccann> kde just needs to go its own way
18:27:45 <rdieter> mizmo: +1 (we can make it work, regardless)
18:28:07 <rdieter> mccann: heavens no, that's a bit extreme
18:28:11 <Kevin_Kofler> mccann: To add to that: the KDE spin is one of the permanent, mirrored spins, we really want to present a consistent Fedora look and work hard for it, but of course that means we need to get the wallpapers in time for us to theme based on that.
18:28:13 <jds2001> +1 to KDE going with whatever they like.
18:28:23 <mizmo> thanks rdieter :)
18:28:47 <halfline> Kevin_Kofler: i'm not sure a consistent look is that important
18:29:03 <stickster> We have an opportunity every release to revisit schedule items for each team, Design being one of them
18:29:04 <halfline> Kevin_Kofler: i mean they're two very different pieces of the fedora puzzle
18:29:12 <halfline> with different objectives, target users, etc
18:29:20 <halfline> it's okay if they're different
18:29:22 <Kevin_Kofler> My proposal: the Design Team needs to get the new wallpaper in by Tuesday, any nontrivial change after that will be rejected. KDE SIG will do its best to work with that.
18:29:24 <halfline> that's sort of the point
18:29:38 <jds2001> other distros dont have a consistent look and feel in their kde vs. gnome vs. xfce vs. lxde spins i didnt think
18:29:42 <Kevin_Kofler> (But for F13, we'll need some harder freezing.)
18:30:04 <mccann> the thing is that kde should not have any power to say what goes into the default fedora
18:30:35 <mccann> if we share then great
18:30:35 <Kevin_Kofler> And why not?
18:30:39 <notting> i think having this discussion go into theoretical who decided what, and what the default look and feel is for is not going to be productive *right now*
18:30:40 <Kevin_Kofler> If you break things for us, we WILL complain.
18:30:50 <notting> we have a hard date at which marketing starts creating collateral
18:30:55 <notting> that date is next wednesday
18:30:58 <mccann> look it is hard enough to compete with ubuntu we cannot have this BS in fedora
18:31:00 <Kevin_Kofler> Shared components need to actually work everywhere.
18:31:02 <dgilmore> notting: right we are delving into non-productivity right now
18:31:07 <notting> the UI needs 'frozen' by then
18:31:12 <notting> or we need to slip the schedule.
18:31:17 <stickster> Agree
18:31:29 <dgilmore> Kevin_Kofler: we need to do something for F-13 that makes the shared components more seamless
18:31:37 <notting> given that that next wednesday date is all of one week before the RC, i don't think it's that big of a deal having a drop-dead date there
18:31:40 <mizmo> i dont think the wallpaper should be a shared component!
18:31:45 <Kevin_Kofler> As for Ubuntu, the fact that they don't accomodate much for KDE in their shared work is one of Kubuntu's major issues.
18:31:49 <dgilmore> Kevin_Kofler: but we can discuss that later/next week
18:31:52 <Kevin_Kofler> We shouldn't be even worse than them!
18:32:35 <stickster> The time for Design to find out that there are heavy dependencies on their output should come much earlier in the cycle.
18:32:46 <jds2001> define "shared work" as it relates to ubuntu, and the more broad question is why are we even talking about ubuntu to begin with?
18:32:48 <stickster> beyond the ones about which they already know.
18:33:06 <dgilmore> jds2001: no idea why
18:33:21 <dgilmore> we can learn from there mistakes but we need to make our own
18:33:29 <rdieter> stickster: maybe a bit of a miscomunication.  In my mind, our (kde's) depending on constantine-backgrounds was a given
18:33:48 <Kevin_Kofler> stickster: We've been trying to tell them that we need the wallpapers earlier so we can design KSplash and KDM themes based on that since at least F7!
18:33:58 <Kevin_Kofler> Somehow the message didn't get through. :-(
18:34:01 <mizmo> Kevin_Kofler: and we've been getting wallpapers to you earlier and earlier every release.
18:34:05 <mizmo> Kevin_Kofler: so don't give me that shit.
18:34:38 <Kevin_Kofler> You've been getting us "wallpapers", but not the wallpapers...
18:34:41 <notting> but, again... the schedule says the release artwork was 'final' 3 1/2 weeks ago. is the schedule not correct?
18:34:44 <Kevin_Kofler> That's the important distinction there.
18:35:08 <mizmo> Kevin_Kofler: you can't have your cake and fucking eat it too. You either get early, but not 100%, with a chance to comment ; or you get late but final.
18:35:10 <jds2001> alright, let's vote on notting's proposal.
18:35:17 <jds2001> UI (which i define to mean the GNOME
18:35:30 <jds2001> UI) is frozen by wednesday or we slip....
18:35:32 <Kevin_Kofler> The new wallpaper is completely different from a geometrical/organizational point of view and the color scheme also got adjusted (you explained why).
18:35:33 <mizmo> Kevin_Kofler: i wish i had clones. i wish i was a robot. but im not.
18:35:51 <mizmo> Kevin_Kofler: if i watched the first scene of the titanic and the last scene i would think it was a very different movie.
18:35:59 <mizmo> Kevin_Kofler: design is an iterative process.
18:36:12 <mizmo> Kevin_Kofler: you can eat your meat raw or you can wait until it's cooked.
18:36:13 <skvidal> mizmo, Kevin_Kofler: please stop
18:36:13 <Kevin_Kofler> We need to stop it at some point.
18:36:20 <skvidal> both o you
18:36:21 <skvidal> stop
18:36:24 <mccann> notting: fedora doesn't have anyone working on the wallpapers - mo is doing it mostly on her own time
18:36:35 <mccann> notting: so we have basically no power to dictate a schedule
18:36:37 <Kevin_Kofler> E.g. we all agree that we can't update the artwork in updates. We just don't agree on when the point to stop should be.
18:36:51 <mccann> notting: on the other hand there is a huge risk to the product and the brand if we fuck it up
18:36:59 <mccann> a pretty shitty situation overall
18:37:08 <notting> mccann: i'm not dictating, that schedule comes from the design team, which mo leads
18:37:19 <jds2001> that's easy, i just proposed something that notting proposed. Let's vote on it and end this. This is getting absolutely nowhere.
18:37:32 <jds2001> we all have other things to do and lives to live.
18:37:36 <notting> mccann: if we're treating this as an exception to that schedule, i suppose it frames the discussion differently
18:37:55 <mccann> notting: sure I'm only saying that from my point of view we didn't get it done and we need to make sure we do
18:38:00 <mizmo> it should be treated as an exception to the schedule
18:38:03 <mccann> and damn kde
18:38:04 <mizmo> and im really sorry about that
18:38:09 <mccann> we need it
18:38:27 <mizmo> think about what's been on my plate for f12
18:38:40 <mizmo> get.fpo redesign. spins redesign. fedora insight design from the ground up + html/css. and the artwork.
18:38:51 <mizmo> that is more than i have ever had due in fedora before at the same time.
18:38:56 <mccann> yup a pretty unreasonable amount of work
18:38:56 <Oxf13> mizmo: I hope nobody is actually trying to rake you over the coals for this
18:39:00 <mizmo> so rather than dump on me for not getting kde the wallpaper months ago
18:39:17 <mccann> the kde sig should have someone doing their art
18:39:21 <mccann> period
18:39:33 <mccann> we do not have enough resources to do both
18:39:43 <mizmo> how about chalk it up to be a problem of, mo had too much shit on her plate, let's not make her feel super fucking horrible awful because fedora goes out with a shit background
18:39:56 <skvidal> mizmo: except the background in the beta is not shit
18:39:57 <Kevin_Kofler> mccann: We do have somebody doing our part of the art.
18:39:57 * dgilmore votes +1 to nottings proposal
18:40:05 <mizmo> and for f13 let's try to work out deadlines such that everything isn't due at the same time
18:40:13 <Kevin_Kofler> But we need the common part to be done so we can ship a consistent Fedora look!
18:40:16 <mizmo> eg let's launch websites not to coincide with distro releases
18:40:34 <mizmo> Kevin_Kofler: the artwork was done by the same artist. they are done on the same theme. they are consistent enough.
18:40:54 <mizmo> Kevin_Kofler: it's not like one is shipping a rembrant painting and the other a wacky miyazaki
18:41:07 <mccann> Kevin_Kofler: we don't need a consistent fedora look - you are a different product
18:41:16 <Oxf13> (the continued back and forth between Kevin_Kofler and mizmo is not helping FESCo get anywhere with their meeting)
18:41:22 <mccann> if you want to look the same that is up to you
18:41:59 <mccann> Oxf13: sorry steer away
18:42:22 <Kevin_Kofler> I did make a proposal which should make mizmo happy too:
18:42:22 <Oxf13> I'm not even in FESCo, I'm just trying to figure out when I'll see tag requests.
18:42:26 <Kevin_Kofler> <Kevin_Kofler> My proposal: the Design Team needs to get the new wallpaper in by Tuesday, any nontrivial change after that will be rejected. KDE SIG will do its best to work with that.
18:42:49 <Kevin_Kofler> That's basically notting's proposal without the KDE part. Then we'll have to decide what to go with (ship beta artwork, try to update to the new one, whatever) within KDE SIG.
18:43:03 <Kevin_Kofler> We can due that in our Tuesday meeting.
18:43:11 <Kevin_Kofler> At that point we'll have all the input.
18:43:58 <Oxf13> notting: is any of the marketing collateral going to cover the KDE side of things?  If not, then it would be reasonable to let KDE have a bit more time to decide their artwork fate
18:44:06 <Oxf13> notting: and let mo land her stuff in time for the collateral
18:44:07 <mizmo> Kevin_Kofler: i like that proposal. shipit
18:44:23 <mizmo> 0xf13 im sorry about the arguing but i cant let unfair bullshit slide.
18:44:31 <mizmo> the next barb taken at me, please take it to pm
18:44:49 <notting> Oxf13:  i don't know the full extent of what they produce. lemme see if i can find someone who knows
18:44:54 * notting looks at stickster
18:44:54 <jds2001> ok, so let's go with Kevin_Kofler's proposal
18:44:55 <Kevin_Kofler> 0xf13: Sadly, so far they never really did, so I don't expect them to suddenly want to cover KDE big time right now.
18:44:56 <stickster> If Kevin and Mo have found an agreement, can we get FESCo to support that please? Barbs aren't getting us anywhere.
18:45:03 <jds2001> +1
18:45:24 <notting> +1 to the tuesday deadline
18:45:27 <sharkcz> +1
18:45:29 <skvidal> +1
18:45:29 <stickster> Oxf13: Collateral screenshots and so forth all go to the default.
18:45:37 <notting> Oxf13: KDE  *is* covered in the screenshot tour
18:45:44 <notting> see https://fedoraproject.org/wiki/Fedora_11_Screenshot_Tour
18:45:54 <jds2001> one more?
18:46:06 <j-rod> here ya go: +1
18:46:13 * dgilmore already voted +! to nottings proposal
18:46:14 <Kevin_Kofler> We can edit the KSplash and KDM screenshots if we have to.
18:46:17 <mizmo> thank you
18:46:31 <jds2001> #agreed non-trivial wallpaper changes after Tuesday will be rejected. The KDE SIG will work with that schedule
18:46:35 <Kevin_Kofler> We'll decide how to proceed on Tuesday, so the wallpaper for the desktop itself should be set by then.
18:46:37 <stickster> Oxf13: Sorry, I was referring to release docs.
18:46:42 <jds2001> Anythng else?
18:46:59 * jds2001 ends the meeting in 30
18:47:22 <jds2001> #endmeeting