fedora-meeting
LOGS
17:00:47 <jds2001> #startmeeting FESCo meeting 20091002
17:00:47 <zodbot> Meeting started Fri Oct  2 17:00:47 2009 UTC.  The chair is jds2001. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:47 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
17:00:48 <jds2001> sorry
17:00:53 * nirik is here.
17:00:56 * jds2001 was preparing :)
17:01:00 <Kevin_Kofler> Present.
17:01:01 * sharkcz is here
17:01:47 <jds2001> #chair dgilmore jwb notting nirik sharkcz jds2001 j-rod skvidal Kevin_Kofler
17:01:47 <zodbot> Current chairs: Kevin_Kofler dgilmore j-rod jds2001 jwb nirik notting sharkcz skvidal
17:01:52 <skvidal> I'm here
17:02:25 <jds2001> well, we've got 5 i guess
17:02:36 * jds2001 wishes for more, should we wait?
17:03:25 <nirik> well, 5 is more than 50% of our number.
17:03:31 <nirik> and there's 6. :)
17:03:31 * j-rod here
17:03:47 <jds2001> yeah, good enuf
17:03:58 <jds2001> so just one item today, incomplete features
17:04:12 <jds2001> #topic incomplete features
17:04:16 <jds2001> .fesco 254
17:04:17 <zodbot> jds2001: #254 (Incomplete features) - FESCo - Trac - https://fedorahosted.org/fesco/ticket/254
17:04:21 <jds2001> ajax: you around?
17:04:29 <Kevin_Kofler> We should go through one at a time.
17:04:50 <jds2001> thats what im doing
17:04:55 <Kevin_Kofler> We don't have any other items anyway.
17:04:55 * nirik nods. yes, one at a time.
17:04:55 <jds2001> note i asked for ajax
17:05:15 * jds2001 sees on this feature page (DisplayPort) that it doesn't look anywhere near complte.
17:05:18 <nirik> This feature was proposed for f11, didn't make it, was proposed for f12 now.
17:05:51 <nirik> hum, or perhaps I am confusing it with another one.
17:06:05 <jds2001> yeah, this didn't sound famailiar to me.
17:06:19 <jds2001> except for from this time.
17:06:36 * notting remembers ajax describing something about this the last time it came up a few weeks ago
17:07:30 <Kevin_Kofler> Ouch, 40% complete?
17:07:31 * nirik does a grep of irc logs.
17:07:46 <jds2001> yeah, the test matrix isn't nearly filled out either.
17:08:03 <notting> however, where the dots are in the test matrix does imply the code is there
17:08:05 <nirik> fedora-meeting.log:Aug 07 12:29:24 <Kevin_Kofler>	For DisplayPort, IIRC ajax said it's basically done, though some bugs are left.
17:08:05 <Kevin_Kofler> It looks like there's some stuff, but it's not anywhere near 100%. :-(
17:08:19 <Kevin_Kofler> Yeah, he said that.
17:08:27 <Kevin_Kofler> But the last update was the day after that.
17:08:36 <Kevin_Kofler> I have no idea what the current state is now!
17:08:39 <nirik> fedora-devel.log:Aug 25 08:46:33 <ajax>	it's almost certainly going to be part of displayport 1.2, due Any Day Now
17:08:42 <jds2001> can anyone get ahold of ajx?
17:08:45 <nirik> thats all I see on it off hand.
17:08:52 <Kevin_Kofler> Actually, the last update was 3 days before that, even.
17:08:59 <Kevin_Kofler> The status hasn't been updated since then.
17:09:03 <jds2001> s/ajx/ajax
17:09:38 <Kevin_Kofler> We really need to get the status updated, and the feature rescoped to what's actually in F12.
17:10:04 <nirik> most of the other video folks are not in a timezone to be around... airlied/etc.
17:10:40 <nirik> so, in the absense of input, we punt to f13? If we get some new updated status that it's really at 100% soon we revisit?
17:10:53 <jds2001> yeah
17:10:56 <jds2001> +1 to punting
17:11:08 <sharkcz> +1
17:11:52 <nirik> +1 to punting here, but I think if it really is done we should revist and reinstate. I guess we can burn that bridge when we come to it though
17:13:10 <Kevin_Kofler> I guess I'll go with that... +1 to punting in its current state (we can't advertise a 40% complete feature), but we should indeed revisit if the status gets updated and the feature gets rescoped to the actually completed work.
17:13:33 <notting> +1 for now.
17:14:08 <Kevin_Kofler> (Also considering that this stuff is in critical packages, so feature development as freeze overrides is not possible here.)
17:14:09 <jds2001> #agreed Display
17:14:18 <Kevin_Kofler> #undo
17:14:18 <zodbot> Removing item from minutes: <MeetBot.items.Agreed object at 0xeac15d0>
17:14:26 <Kevin_Kofler> Need a better summary here. :-)
17:14:30 <jds2001> #agreed DisplayPort feature is punted to F13, unles sthere's some other information we don't have
17:14:35 <jds2001> Kevin_Kofler: typo :)
17:14:39 <notting> nice. we really do need python objects in the meeting notes.
17:14:47 <jds2001> lol
17:14:49 <skvidal> +1
17:15:16 <jds2001> sgrubb: i saw you joined, you're next :)
17:15:29 <sgrubb> oh joy
17:15:35 <jds2001> looks like 96% done here, i dont have a rawhide system around to look at
17:15:57 <sgrubb> yes, the Contingency Plan says this is at the package level
17:16:08 <sgrubb> we can fix things not done another day
17:16:18 * nirik notes this is https://fedoraproject.org/wiki/Features/LowerProcessCapabilities
17:16:27 <jds2001> ok, so at least the minimal install is done?
17:16:28 <sgrubb> that said, I did not get good support from the two outstanding bugs
17:16:51 <sgrubb> I had patches ready for 6 weeks and the maintainers were not helpful
17:17:03 <Kevin_Kofler> Do you want me to just commit them?
17:17:18 <nirik> thats the dbus and bluetoothd ones?
17:17:22 <sgrubb> the bluez patch was accepted upstream today
17:17:31 <sgrubb> http://marc.info/?l=linux-bluetooth&m=125447683916247&w=2
17:17:38 <sgrubb> it should be safe
17:17:51 <sgrubb> although upstream insisted on pkg-confog support
17:18:00 <sgrubb> which the patch on bz does not have
17:18:11 <sgrubb> but the patch works for fedora
17:18:23 <sgrubb> I think that one is safe to do
17:18:24 <notting> then again, bluetooth is a bit out of the minimal install
17:18:31 <sgrubb> sure
17:18:49 <sgrubb> the otherone I wished we had some runtime with
17:19:01 <Kevin_Kofler> -1 to dropping the feature, looks reasonably complete, worst case (if we can't get the last 2 patches in) it can be rescoped.
17:19:06 <sgrubb> the problem I was looking at is that once I patched some daemons
17:19:15 <jds2001> i wouldnt feel comfortable dropping things in with no runtime experience
17:19:21 <jds2001> at this point
17:19:23 <sgrubb> I found they were linking against both libcap and libcap-ng
17:19:31 <sgrubb> dbus was the culprit
17:19:37 <notting> this looks like we can essentially just define 100% as 'whatever's done now',  yes?
17:20:00 <sgrubb> it could be
17:20:00 <Kevin_Kofler> Hmmm, could that be why the dbus maintainer didn't apply your patch to dbus itself?
17:20:10 <sgrubb> I just wanted to highlight lack of support from some maintainers
17:20:28 <sgrubb> look at the bz for dbus
17:20:44 <sgrubb> they asked me to see if I could fix another bug in their queue at the same time
17:20:47 <sgrubb> I did that
17:20:56 <sgrubb> and they still didn't apply the patch
17:21:02 <sgrubb> grrr
17:21:05 <Kevin_Kofler> Sigh...
17:21:14 <Kevin_Kofler> Hmmph...
17:22:00 * jds2001 notes comments 4-6 are private and he cant see them.  Any reason why?
17:22:00 <jds2001> :)
17:22:31 <Kevin_Kofler> Hmmm, some security-sensitive discussion?
17:22:38 * sgrubb looks
17:23:10 <sgrubb> not really - i think the topic deviated from the original request
17:23:23 <jds2001> oh
17:23:44 <jds2001> so long as they're irrelevant, that's fine, keep it clean :)
17:23:47 <sgrubb> I opened my two
17:23:53 * dgilmore is here
17:23:57 <sgrubb> so refresh
17:24:12 <notting> well, unlike filesystem/setup, dbus is an actual upstream project, so i can understand them being more conservative about merging changes. but comments would be nice.
17:24:48 <sgrubb> they never said anything about that
17:25:01 <jds2001> i noticed :)
17:25:03 <sgrubb> also, i would like to see it at least run before sending it upstream
17:25:06 <jds2001> or much of anything else.
17:25:11 <Kevin_Kofler> They just stop responding at some point. :-/
17:25:16 <Kevin_Kofler> *stopped
17:25:19 <sgrubb> isn't that what rawhide is for?
17:25:26 * jds2001 is fine with dropping dbus from the scope
17:25:42 <notting> ... potentially integrating not-for-upstream patches to see what happens? not really.
17:25:48 <sgrubb> try it, back it out, fix, send it
17:25:56 <notting> that's what scratch builds are for
17:26:10 * nirik nods. test instances. no need to commit and build a real version.
17:26:17 <sgrubb> my laptop is running with a patched dbus
17:26:28 <sgrubb> but I do not use the desktop on that machine
17:26:33 <sgrubb> so my usecase is limited
17:27:17 <nirik> well, could call for testers, point them at the scratch build.
17:27:35 <Kevin_Kofler> I don't see why Rawhide would not be the place to implement distro-wide features, even if upstream doesn't buy in yet.
17:27:53 <sgrubb> I don't think I can commit for dbus
17:27:53 <nirik> if the patch is intended to go upstream soon, carrying it in the rawhide package would be ok I would think after some testing.
17:28:00 <sgrubb> that was the plan   :)
17:28:07 <Kevin_Kofler> I can see the benefits of "stay close to upstream", but we shouldn't do this at the cost of distro integration.
17:28:19 * nirik just read the 'not for upstream' part of notting's comment. ;)
17:28:55 <notting> in any case, should we just define the scope to not include dbus for now, and keep the feature?
17:29:13 <nirik> thats what I would prefer. Unless we can dig up dbus maintainers to buy into it now.
17:29:19 <sharkcz> IMO we should
17:29:39 <Kevin_Kofler> IMHO we should just commit the D-Bus change (several of us are provenpackagers) and get it tagged.
17:30:06 <jds2001> .whoowns dbus
17:30:06 <zodbot> jds2001: davidz (johnp in Fedora OLPC)
17:30:09 * nirik wonder if someone can dig up walters
17:30:10 <notting> Kevin_Kofler: ????
17:30:26 <notting> the job of provenpackager is not to add features to packages that are not accepted upstream yet
17:30:26 <jds2001> Kevin_Kofler: that is *not* what provenpackager is for.
17:30:28 <nirik> Kevin_Kofler: I don't think thats a super good idea. unless we get an ack that they are ok with it.
17:30:56 <Kevin_Kofler> The provenpackager would be doing it on a FESCo mandate, not on their own initiative.
17:31:21 <jds2001> FESCo is in no posistion to micromanage maintainers
17:32:07 <Kevin_Kofler> If we want distro-wide features to succeed, we need some way to make sure they really get into all affected packages.
17:32:36 <nirik> walters: bug 518541 is the one we are talking about.
17:32:38 <buggbot> Bug https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=518541 medium, low, ---, walters, ASSIGNED, Changes for lowering capabilities project
17:33:35 <walters> ok right; i think it's relatively safe and i didn't see any obvious problems, aside from my concern about not being compilable on older OSes anymore
17:34:05 <nirik> cool. Could we land it now? or is it too late for that do you think?
17:34:06 <walters> but i didn't get time to push it through, we can do so now though if dbus is one of the blockers on the caps cahnges
17:34:09 <sgrubb> it should be fine back to rhel4.2 & fc-4
17:34:13 <jds2001> walters: is upstream going to hasve a concern about it?
17:34:15 <dgilmore> notting: right
17:34:33 <dgilmore> Kevin_Kofler: only maintainers should add non-upstream features
17:34:38 <walters> jds2001: nah
17:34:39 <dgilmore> as they will have to maintian them
17:34:49 <walters> sgrubb: oh?  will libcapng be backported?  or it already exited?
17:34:52 <walters> *existed
17:35:00 <sgrubb> it can run on rhel4
17:35:01 <dgilmore> and even then they should only do it if confident that they will get the feature upstream
17:35:14 <sgrubb> I've tested it there
17:35:26 <walters> sgrubb: well...right, what i meant is more that you can't just drop in a new dbus.tar.gz for the .spec
17:35:37 <walters> and equivalent operations
17:35:42 <jds2001> coo, if anyone's running anything older than that i guess that's their fault :D
17:35:44 <walters> sgrubb: it's nto a big deal
17:35:48 <jds2001> rhel4 is still mainstream
17:35:56 <jds2001> but anything older not so much
17:35:59 <walters> sgrubb: just something to note and live with
17:36:22 <nirik> ok, so dbus will be updated with this... walters: you going to do that? or would you like someone else to?
17:36:34 <sgrubb> libcap-ng can probably run on fc-1
17:36:35 <nirik> once thats done we can mark this 100% and go on our way.
17:36:52 <sgrubb> the dbus limitaion wrt libcap-ng is around the audit code
17:36:59 <walters> sgrubb: if you have the checkout changes made do you want to go ahead and push it?  I'll oepn an upstream bug so we can get this upstreamed
17:37:20 <sgrubb> sure
17:38:12 <Kevin_Kofler> So it looks like this is getting resolved? Great!
17:38:28 <nirik> communication is grand. ;) Shall we move on then?
17:38:37 <jds2001> yep :)
17:38:53 <nirik> thanks walters and sgrubb.
17:38:58 <jds2001> #agreed Lower Porcess Capabilities is retained, dbus changes are being committed to complet the feature.
17:39:18 <jds2001> hmm, no steved
17:39:41 <Kevin_Kofler> NFSv4Default has been discussed on the ML recently.
17:39:47 <nirik> yeah, and in devel as well.
17:39:49 * jds2001 just pinged him in #fedora-devel
17:40:21 <Oxf13> the latest build of that is v3 mounting is the default
17:40:21 <jds2001> yeah, I don't think this can in good counscionce land right now.
17:40:24 <nirik> all this is done, but it defaults to v3 out of the box.
17:40:39 <Kevin_Kofler> Basically, the plan now seems to be that NFS v4 will not be default in F12, due to interoperability concerns with old NFS servers.
17:41:13 <nirik> right, so shall we just move this to f13 and land it very early in the cycle (like now, since we've already mass branched :)
17:41:17 <Kevin_Kofler> NFSv4 only works out of the box if the server runs at least F12, otherwise you have to export / or the server will claim to support NFSv4, but then complain that there's no / directory.
17:41:29 <Kevin_Kofler> Virtual roots are only supported in F12+ NFS servers.
17:41:30 <jds2001> steved is on his way :)
17:41:48 * steved sneaks in the backdoor...
17:41:53 <jds2001> :)
17:42:41 <nirik> steved: right, so shall we just move this to f13 and land it very early in the cycle (like now, since we've already mass branched :)
17:42:48 <jds2001> OK, if I understand correctly, the plan is not for nfsv4 to be default in f12?
17:42:55 <jds2001> or what nirik said :)
17:43:05 * steved agrees with both
17:43:13 <walters> sgrubb: i filed https://bugs.freedesktop.org/show_bug.cgi?id=24280
17:43:14 <buggbot> Bug 24280: normal, medium, ---, hp@pobox.com, NEW, use libcapng
17:43:37 * steved wonder what state the  NFSv4Defaut feature should be put in?
17:44:01 * jds2001 suspects FeatureReadyForWrangler
17:44:08 <jds2001> and just change the release to F13
17:44:27 <steved> Cool...
17:44:39 <sgrubb> walters, thanks
17:44:44 <jds2001> OK, that was easy :)
17:44:51 <steved> :)
17:45:23 <steved> but there will be a F-13!!! (steved has an evil grin)
17:45:26 <jds2001> #agreed NFSvr4Default feature is deferred to F13, will land very early (like now-ish :) )
17:45:37 <jds2001> #undo
17:45:37 <zodbot> Removing item from minutes: <MeetBot.items.Agreed object at 0x2ad96035f210>
17:45:46 <jds2001> #agreed NFSv4Default feature is deferred to F13, will land very early (like now-ish :) )
17:46:15 <steved> jds2001: as soon I here go.. I make the change to NFS utils... all the kernel stuff should be there by then...
17:46:26 <Kevin_Kofler> Another victim of the mad Preview->Beta->Alpha renaming. :-(
17:46:39 <jds2001> steved: you should be good to do that now.
17:46:52 <jds2001> Kevin_Kofler: we knew there would be some confusion when changing
17:46:53 <steved> thanks! have a nice afternoon..
17:47:01 <jds2001> hopefully next cycle with be smotther.
17:47:05 <Kevin_Kofler> jds2001: Then why did you vote for it?
17:47:25 <jds2001> because change has to happen.
17:47:26 <Kevin_Kofler> I propose we revert to the F11 snapshot naming (including having 3 snapshots).
17:47:33 <jds2001> we cant just stay stagnant forever.
17:47:35 <Kevin_Kofler> Should I file an official proposal for next week's meeting?
17:47:42 <nirik> were all the people who were confused by this long time fedora contributors?
17:47:52 <jds2001> sure, but you need rel-eng buyin
17:48:15 <Kevin_Kofler> nirik: Quite likely. They're the ones used to the existing names.
17:48:17 <jds2001> this was a rel-eng proposed change, and if you're making more work for them, they need to buy in to that.
17:48:20 <Kevin_Kofler> But those are the most valuable contributors!
17:48:24 <nirik> I think it's just long term fedora memory, and will clean up as we move forward. I think the current way is a lot less confusing for new people who don't know arcane stuff
17:48:44 <jds2001> nirik: +1
17:49:01 <Kevin_Kofler> Nothing against new contributors, but in number long-term ones dominate, and in amount of packages/person, the longer you stay, the more you're likely to have.
17:49:06 <nirik> but we should try and make sure and communicate better with long term people too.
17:49:24 <dgilmore> Kevin_Kofler: put it on the agenda for next week
17:49:35 <nirik> yeah, but this way it's easier for new people... and won't the existing people learn? or haven't they already?
17:49:42 <Kevin_Kofler> And people who are new now will (hopefully) become long-term contributors themselves.
17:49:45 <nirik> moving back is likely to re-confuse some of them.
17:49:59 <jds2001> i was expecting a rough release with the renaming.  Learning curve.
17:50:24 <jds2001> but once you're acclaimated to it, it really is better.
17:50:25 <Kevin_Kofler> nirik: But then the worst thing that can happen is that they deliver too early. ;-)
17:50:30 <Kevin_Kofler> And that's not really a bad thing, is it?
17:50:33 * nirik shrugs. Feel free to propose changing it back. I think we should stick with what we have now personally.
17:51:26 <dgilmore> nirik: i agree
17:51:45 * jds2001 too, obviously
17:51:48 <nirik> perhaps you can make a compelling proposal tho... can we discuss next week?
17:51:49 <dgilmore> but if Kevin_Kofler feels he wants it changed he has a process and we can evalaute it and likely reject it
17:51:51 <Oxf13> oh, this argument again?
17:52:10 <j-rod> dead horse, boot. boot, dead horse.
17:53:20 <jds2001> anyhow, anything more for this week?
17:53:28 <jds2001> #topic open floor
17:53:28 <nirik> open floor?
17:53:35 * nirik doesn't have anything. ;)
17:54:10 * jds2001 ends the meeting in 30
17:54:44 <jds2001> #endmeeting