fedora-meeting
LOGS

00:02:29 <Sparks> #startmeeting Docs Project Meeting - Agenda: http://fedoraproject.org/wiki/Docs_Project_meetings
00:02:29 <zodbot> Meeting started Thu Sep 17 00:02:29 2009 UTC.  The chair is Sparks. Information about MeetBot at http://wiki.debian.org/MeetBot.
00:02:29 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
00:02:39 <Sparks> #topic Roll Call
00:02:42 * Sparks 
00:02:54 * stickster 
00:02:56 * jjmcd is here
00:03:03 * joat .
00:03:08 * rudi is here
00:03:48 <stickster> Sparks: Should the schedule tasks be on the agenda too?
00:04:05 * danielsmw 
00:04:13 <stickster> http://poelstra.fedorapeople.org/schedules/f-12/f-12-docs-tasks.html
00:04:22 <Sparks> stickster: Probably
00:04:30 <Sparks> We'll shoe horn it in
00:04:44 <stickster> I'd recommend that be there on a regular basis, just to avoid any sudden screechy left-hand turns
00:04:51 <Sparks> Yeah
00:04:55 <stickster> Even if the kids in the back think it's fun
00:05:08 <jjmcd> Trubble is, we're already in that state
00:05:23 <Sparks> Okay, let's get going!
00:05:25 * Tsagadai is here but late :)
00:05:32 <Sparks> #topic Last week's action items
00:05:50 <Sparks> quaid to follow up with Mizmo on the Zikula theme
00:05:55 <Sparks> quaid: You here tonight?
00:06:14 <stickster> Sparks: I can fill in here
00:06:21 <Sparks> stickster: go!
00:06:25 <stickster> mizmo worked for many hours the other night on Zikula theme
00:06:51 <stickster> But there is some very significant broken stuff in Zikula itself that made the work slow, frustrating, and ultimately unfinished
00:07:21 <stickster> mizmo has to punt for now because the web design is higher priority and there's too much Zikula architecture stuff to figure out for her to progress as fast as she's used to doing with other frameworks
00:07:47 <stickster> eof
00:08:02 * jjmcd thinks that after we come up for air we need to work on zik dox
00:08:34 <Sparks> stickster: So do we need to find someone else to work on the skins?
00:08:47 <stickster> Sparks: mchua is going to do that
00:09:06 <Sparks> Okay...  Good to know.
00:09:11 <Sparks> jjmcd: zik dox?
00:09:28 * stickster is a little disappointed at Zikula progress -- not because people didn't put forth superhuman effort, because they *did*
00:09:28 <jjmcd> My exploration of zikula was hampered by horrible dox
00:09:34 <jjmcd> lots of them, all useless
00:09:39 <stickster> More because there's so many broken pieces when you dig inside.
00:09:47 <Sparks> jjmcd: Yeah
00:09:53 <Sparks> stickster: I agree
00:10:14 <Sparks> There were a lot of people that put a lot of work into it and found it "not as advertised"
00:10:16 <stickster> It makes me want to get further information on (1) how we decided on it, and (2) re-evaluate that process so that we can learn from the experience
00:10:20 <stickster> But moreover
00:10:25 <stickster> I think having itbegins around has been helpful
00:10:33 * mchua here
00:10:35 <stickster> And I want to make sure that what we're learning is being fed back to the Zikula community for action
00:10:36 * mchua reads backlog
00:10:57 <stickster> mchua: No biggie, just letting Sparks know that you are going to be on the lookout for more theming help for Zikula
00:11:05 <jjmcd> stickster, that's why I say, once we get capacity free, we ought to help them out, too
00:11:27 <stickster> jjmcd: A significant portion of the problem may be issues we can't solve, though -- like architectural issues, according to mizmo
00:11:35 <jjmcd> since they helped us
00:11:45 <Sparks> stickster: Yeah, we've received a lot of support...  but we had to re-engineer so much...
00:11:46 <stickster> I have no idea myself, not sure I'd know from looking at it anyway :-)
00:11:47 <mchua> itbegins and mizmo have cleared their plates completely of FI items, so itbegins can help more people do FI stuff instead of doing tons of it himself
00:11:58 <jjmcd> Oh yeah, we need to give them guidance, but without simon, would you have gotten off the ground?
00:12:12 <stickster> Not sure.
00:12:24 <stickster> Anyway, don't let me derail your agenda Sparks, I think we answered the status bit
00:12:53 <mchua> All the remaining FI work is listed in https://fedorahosted.org/marketing-team/query?status=new&status=assigned&status=reopened&component=Fedora+Insight&order=priority in a manner that is pick-uppable by passers-by. We're trying to doc everything as we go along so future zikula deployments will be smoother.
00:13:05 <mchua> but yeah, there have been a lot of hacks as we approach the endgame.
00:13:20 <stickster> mchua: Not to mention the hacking we did in the startgame too :-)
00:13:24 <mchua> ...that too, yeah.
00:13:33 <Sparks> Okay...  we'll get more into Zikula in a bit..
00:13:35 <Sparks> moving on
00:13:38 <Sparks> quaid to follow up with Richard about the use of the CC logo on the wiki.
00:14:00 <Sparks> Anyone know about the outcome of this?  I feel we have revisited this more times than not.
00:14:33 <rudi> Haven't heard anything new about it; don't know if quaid has broached the subject with Richard
00:14:45 <rudi> So, AFAIK, Richard's previous advice stands
00:15:24 <Sparks> #action quaid to follow up with Richard about the use of the CC logo on the wiki.
00:15:34 <Sparks> danielsmw to package an editor for Scribite
00:15:49 <Sparks> This didn't happen.  Has anyone stepped up to do this?
00:16:13 <danielsmw> Sparks: Here's my update.
00:16:31 <danielsmw> I looked at using TinyMCE and worked at that spec file for a bit
00:16:56 <danielsmw> I later consulted with abadger1999 and figured out that TinyMCE would be basically impossible to package without 4 or 5 other packages that are questionably packagable
00:17:05 <Sparks> oh, danielsmw IS here!  Welcome!
00:17:11 <danielsmw> Yes, I'm here. :)
00:17:20 * stickster shouts Howdy to danielsmw
00:17:31 <Sparks> danielsmw: So scratch TinyMCE
00:17:34 <danielsmw> Anyway, we've picked up Xinha as our new option, as long as everyone's okay with that.
00:17:39 <danielsmw> yes, scratch TinyMCE.
00:17:50 <danielsmw> Xinha looks like it has compliant licenses
00:17:53 <danielsmw> and is packagable.
00:17:57 <Sparks> danielsmw: I'm good with whatever works!
00:18:04 <danielsmw> i'm almost done with the spec file, it's just complicated because of the lack of js guidelines.
00:18:19 <danielsmw> but abadger1999 is helping with that and hopefully i'll have it up for review before next wednesday.
00:18:22 * ianweller is here now
00:18:31 <Sparks> abadger1999++
00:18:34 <danielsmw> Indeed
00:18:37 <Sparks> danielsmw++
00:18:41 <Sparks> Excellent!
00:18:52 <Sparks> Okay... moving on...
00:18:54 <Sparks> ianweller to bring to the list the text for the CC license for the wiki so it can be approved
00:18:58 <Sparks> ianweller: Just in time!
00:19:41 <Sparks> ianweller: I think you did this already...  didn't you?
00:20:13 <onekopaka> which CC license?
00:20:24 <Sparks> CC-BY-SA
00:20:30 <onekopaka> mmkay.
00:20:49 <Sparks> ianweller was here....
00:20:57 <Sparks> We'll come back to him later...
00:21:01 <ianweller> hi
00:21:04 <onekopaka> Sparks: he disappears when he wants to.
00:21:05 <ianweller> my internet is suck tonight
00:21:06 <Sparks> ianweller: hi
00:21:09 <ianweller> aaaagain
00:21:13 <stickster> :-D
00:21:26 <ianweller> Sparks: all it needs to say is the message that "blah blah blah is licensed under blah blah blah" at the bottom of the page, just like every CC site
00:21:31 <ianweller> Sparks: unless you're looking for something different
00:22:58 <ianweller> i'm not sure if it's a good thing that my ISP's phone number is a busy signal right now ^_^
00:23:01 <ianweller> Sparks: is that good?
00:23:13 <Sparks> ianweller: Works for me...
00:23:29 <ianweller> ok
00:23:42 <Sparks> Any other old business?
00:24:01 <rudi> Publican update?
00:24:15 <Sparks> #topic Publican Update
00:24:18 <Sparks> rudi: Go for it!
00:24:48 * quaid is back
00:24:54 <rudi> radsy, ryanlerch, and I are still waiting for sponsorship so that we can get Publican dependencies into Fedora
00:25:15 <rudi> Once that's done, we can move ahead with both 1.0 and with the updated Fedora brand package.
00:25:16 <stickster> ianweller: I think as the wiki czar, you're empowered to make the change, fwiw
00:25:32 <rudi> So, any trusted packagers out there, we need you :)
00:25:43 <stickster> ianweller: As long as we've notified people the change is coming, why, etc.
00:26:11 <rudi> * perl-Locale-Maketext-Gettext-1.27-1.fc11.noarch.rpm – https://bugzilla.redhat.com/show_bug.cgi?id=521569
00:26:12 <buggbot> Bug 521569: medium, medium, ---, nobody, NEW, Review Request: perl-Locale-Maketext-Gettext - Joins the gettext and Maketext frameworks
00:26:13 <rudi> * perl-Makefile-DOM-0.004-1.fc11.noarch.rpm — https://bugzilla.redhat.com/show_bug.cgi?id=521724
00:26:14 <buggbot> Bug 521724: medium, medium, ---, nobody, NEW, Review Request: perl-Makefile-DOM - Simple DOM parser for Makefiles
00:26:15 <rudi> * perl-Makefile-Parser-0.211-1.fc11.noarch.rpm — https://bugzilla.redhat.com/show_bug.cgi?id=521723
00:26:15 <buggbot> Bug 521723: medium, medium, ---, nobody, NEW, Review Request: perl-Makefile-Parser - Simple parser for Makefiles
00:26:18 <Sparks> rudi: Okay.  Do we need anyone to give a nudge to someone?
00:26:52 <rudi> Well, unless we have any trusted packagers in the docs group, I'm open to suggestions...
00:27:13 <rudi> This is the blocker right now for Publican
00:27:39 <rudi> ianweller -- are you a trusted packager?
00:28:18 <ianweller> rudi: i guess
00:28:21 <Sparks> rudi: I don't think we have any trusted packagers in Docs.  Heck, until a few months ago we didn't have packagers in Docs.
00:28:29 <Sparks> ianweller: Are you?
00:28:36 <ianweller> they trust me enough to sponsor people
00:28:47 <rudi> Great! That's what we need :)
00:28:54 * ianweller trusts himself less than the community trusts him ;)
00:28:59 <rudi> lolz
00:29:06 <rudi> IMHO, that's always a good sign
00:30:22 <rudi> Do you think you'll have the time to look at those in the near future>?
00:30:34 <rudi> (and, of course, would you want to?)
00:31:42 <Sparks> rudi: Can you get with ianweller after the meeting, maybe?
00:31:49 <rudi> NP
00:32:13 <Sparks> rudi: So basically after that you can support the fedora brand in Publican
00:32:29 <rudi> Yep
00:32:36 <Sparks> Cool
00:32:41 <Sparks> Okay, moving on...
00:32:55 <Sparks> #topic Release notes format changes
00:33:12 <Sparks> #idea Put All Changes in a separate doc?
00:33:20 <Sparks> #idea Drop beats with few changes
00:33:21 <jjmcd> Pretty much did them all except the separate doc ... moved them to the end
00:33:28 <Sparks> #idea Rearrange/add beats
00:33:37 <jjmcd> I think we are ready to make pots.  Still a couple of beats to touch up, but we should be at the 90% point.
00:33:39 <Sparks> jjmcd: Cool...
00:33:52 <jjmcd> Many many thanks to rudi and Zach
00:33:59 <Sparks> So the RNs are on schedule?
00:34:03 <jjmcd> L10N will love the 8000+ strings, but I think we'll hide that from them.
00:34:07 <rudi> jjmcd -- so you're ready to pull the trigger now? :)
00:34:09 <jjmcd> Sparks, no, not at all
00:34:16 <jjmcd> rudi yeah
00:34:23 <Sparks> jjmcd: No?
00:34:24 <jjmcd> Most recent build at http://jjmcd.fedorapeople.org/Download/f12alpha/index.html
00:34:41 <jjmcd> Sparks, even after 900 cycles with john
00:34:45 <rudi> Great -- I'll doctor up a POT file after the meeting :)
00:34:54 <jjmcd> the wiki freeze came AFTER the pots in the schedule
00:35:09 <jjmcd> We should have had pots last week
00:35:27 <jjmcd> With luck, tomorrow.  And yeah, htanks much rudi.  I would appreciate that
00:35:52 <Sparks> Okay.  Anything I can do to help?  Do you need more resources?
00:36:14 <jjmcd> Well, we should now be in good shape
00:36:25 <Sparks> Okay
00:36:28 <Sparks> Anything else?
00:36:29 <jjmcd> THere are a couple of lame beats, but most of the changes were in virt
00:36:39 <jjmcd> Also, I got surprised with a huge FEL document
00:36:50 <jjmcd> I trimmed it way down, but it is still too large
00:37:03 <jjmcd> Chitlesh has been working his butt off
00:37:23 <jjmcd> But it is now under control
00:37:36 <Sparks> cool
00:37:40 <Sparks> anything/one else?
00:37:50 <jjmcd> thats it from me
00:37:55 <Sparks> moving on...
00:37:57 <Sparks> #topic Status on CMS (Zikula) <-- ke4qqq
00:38:05 <Sparks> #link https://fedoraproject.org/wiki/Zikula#Module_status
00:38:08 <stickster> jjmcd: rudi: Thanks for your hard work
00:38:40 <Sparks> So Zikula has stalled on the runway...  Are we now pushing this for f13 for sure?
00:39:10 <quaid> I think we were clearly not making it for F12, but shortly thereafter
00:39:19 <Sparks> Okay
00:39:21 <quaid> we'll be able to ride 80%+ on the Fedora Insight work going on
00:39:28 <stickster> Assuming that proceeds well
00:39:31 <quaid> skin, integration, etc.
00:39:34 <Sparks> WORKSFORME
00:39:51 <quaid> stickster: well, that would only adjust my 80% down the scale some amount
00:39:54 <quaid> I hope :)
00:40:04 <Sparks> I guess the question now is...  do we want to try to work on the existing docs.fp.o to clean it up for F12?
00:40:22 * mchua wonders if Docs is interested in a zikula sprint for FUDCon as well
00:40:39 <Sparks> mchua: Which FUDCon?
00:40:42 <mchua> f12
00:41:05 <jjmcd> or perhaps a docs.fp.o cleanup
00:41:08 <mchua> as a "Marketing got FI up, let's make our experience useful for Docs" thing infra-wise
00:41:40 <mchua> and a "Docs is good at writing/workflows, Marketing can learn from Docs in getting an FI zikula workflow tweaked" thing as well, perhaps
00:42:00 <Sparks> mchua: I'm good with that
00:42:46 <mchua> Ok. Who should I be coordinating with on that to see if it's a possibility then? Sparks, is that you?
00:42:56 <Sparks> mchua: Sure.
00:43:04 <mchua> cool. action item me. ;)
00:43:08 <Sparks> mchua: Are we talking about the FUDCon in Toronto?
00:43:12 <mchua> yup.
00:43:36 <jjmcd> I think it's too cold for these southern boys
00:43:52 <Sparks> #action mchua to work with Sparks on an FAD for Zikula during FUDCon Toronto
00:43:58 <Sparks> jjmcd: It is concerning
00:45:10 <Sparks> Okay...  anythign else?
00:45:24 <Sparks> #topic Status on CC license rollout.
00:45:32 <Sparks> #link https://fedoraproject.org/wiki/License_changeover_schedule
00:46:04 <Sparks> I think we are waiting for the last minute request for quaid to talk to Richard about the CC logo on the wiki
00:46:21 <Sparks> otherwise our next step is to announce internally of the change
00:46:54 <quaid> well ...
00:47:04 <quaid> spot: ping
00:47:14 <spot> quaid: yes?
00:47:29 <quaid> have you heard anything about discussions with Creative Commons
00:47:47 <quaid> about using their logo on our websites?
00:47:55 <spot> i have not... should i have?
00:48:09 <quaid> rfontana said he was going to pursue something with them perhaps.
00:48:22 <spot> send him an email and cc me
00:48:24 <quaid> ok, not sure if you were in that loop or not, I reckon not
00:48:26 <spot> and i will stay on him
00:48:37 <quaid> yeah, he said on list that he was going to look in to it, and I didn't want overly bug him :)
00:48:40 <quaid> but I'll do that now
00:48:47 <quaid> Sparks: k, we've reached
00:48:48 <spot> he tends to be busy
00:48:55 <quaid> the time when i said I'd bug him if we hadn't gotten word
00:48:57 <quaid> so I'll do that :)
00:48:57 <spot> i have regular meetings with him to make sure stuff doesn't get lost
00:49:13 <rudi> For us to be happy to use the logo, CC would have to change *their* licensing...
00:49:16 <stickster> He's a good mug and won't mind being bugged
00:49:35 <rudi> I suspect that even if they agree in principle, it would take time for them to implement that change
00:49:37 <quaid> rudi: well, or give us a specific exception that satisfied us, but ...
00:49:43 <quaid> that might have the same effect :)
00:49:58 <quaid> I think we should, as rudi is perhaps hinting
00:50:00 <Sparks> rudi: They wouldn't have to change their license.  We could only use it on the wiki.
00:50:03 <quaid> proceed as if we don't get the logos to use
00:50:19 <rudi> Sparks -- ie, change their license
00:50:39 <Sparks> rudi: Well... yes, they'd have to change for us to use it on our docs
00:50:55 <rudi> quaid -- that is indeed what I'm hinting :)
00:51:09 <Sparks> ya
00:51:26 <Sparks> Well, it really wouldn't be that big of a deal to go back and put the logo in on the wiki...
00:51:40 <rudi> Exactly
00:51:46 <Sparks> So...  all in favor of proceeding with just the text of the CC-BY-SA
00:51:49 <Sparks> +1
00:51:54 <rudi> +1
00:52:07 <quaid> +1
00:52:12 <mchua> +1
00:52:12 <stickster> +1 fwiw
00:52:30 <Tsagadai> +1
00:52:31 <jjmcd> abstain
00:52:41 <Sparks> jjmcd: Is there a problem or???
00:52:55 <jjmcd> Nope, I see no prob either way
00:53:10 <Sparks> #agreed Proceed with CC licensing using only the text
00:53:20 <Sparks> quaid: Will you still follow up on the logo issue?
00:54:34 <Sparks> #action quaid to follow up on the CC logo issues
00:54:38 <Sparks> moving on!
00:54:47 <Sparks> #topic Shared open-source style guide
00:54:56 <Sparks> #link https://www.redhat.com/archives/fedora-docs-list/2009-June/msg00163.html
00:55:03 <Sparks> Does anyone have an update on this?
00:55:27 <rudi> No progess since last week
00:55:33 <Sparks> rudi: Okay
00:55:41 <Tsagadai> not really an update as such but that may come up when I bring in a few things in a couple of weeks :)
00:55:41 <Sparks> rudi: Anything to talk about on this topic?
00:55:56 <Sparks> Tsagadai: Okay
00:56:13 <Tsagadai> there are 3 docs I have which I've scheduled to upstream as soon as I get a chance
00:56:36 <rudi> Sparks -- I'm not sure what the last you heard was; I have a greenlight from legal to take most of our internal material upstream
00:56:47 <Sparks> rudi: I didn't know!  Excellent
00:56:54 <Sparks> rudi: Just keep us updated.
00:57:17 <rudi> So it now rests on time arising in my schedule, because legal will need to greenlight the final subset I pull out to use
00:57:43 <Sparks> Okay...  cool deal
00:57:46 <Sparks> anything else?
00:57:47 <rudi> Tsagadai -- 3 docs for the upstream Style Guide?
00:58:27 * Sparks notes two minutes left
00:58:33 <Tsagadai> nope, Virt Guide, Git guide, libvirt API guide :)
00:58:43 <rudi> Ah OK -- you're ahead of us :)
00:58:56 <Sparks> okay, pressing on
00:58:58 <Sparks> #topic Guide needs?
00:59:05 <Sparks> Anyone have any guides that are in need?
00:59:18 * stickster has to bail for now
00:59:37 <Sparks> #topic New Guides
00:59:42 <Sparks> Any new guides?
01:00:15 <Sparks> #topic All other business
01:00:20 <rudi> Sparks -- I might *very maybe* have an early version of a Power Management guide
01:00:25 <Sparks> Okay, any other business anyone would like to talk about?
01:00:27 <rudi> But that's more likely to make F13
01:00:45 <Sparks> rudi: Ooooo  sounds cool
01:01:09 <Sparks> Okay, anyone else?
01:01:18 <Sparks> 5
01:01:22 <Sparks> 4
01:01:24 <Sparks> 3
01:01:26 <perspectival> I've just sent an update concerning the Deployment Guide to the fedora-docs-list
01:01:27 <Sparks> 2
01:01:37 <Sparks> perspectival: +1
01:01:39 <perspectival> I try to come in at the last minute
01:01:43 <Sparks> :)
01:01:45 <Sparks> 1
01:01:47 <Sparks> Anyone else?
01:01:55 <Sparks> Thanks everyone for coming!
01:01:58 <Sparks> #endmeeting