fedora-meeting
LOGS

18:00:19 <Oxf13> #startmeeting Fedora Release Engieering Meeting
18:00:19 <zodbot> Meeting started Mon Sep 14 18:00:19 2009 UTC.  The chair is Oxf13. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:00:19 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
18:00:30 <Oxf13> #topic roll call
18:00:54 * notting is here
18:01:08 <Oxf13> ping notting jwb rdieter lmacken spot wwoods dgilmore warren
18:01:22 <rdieter> here
18:01:39 * spot waves
18:03:25 <Oxf13> Alright, we haven't had a meeting since 8/31, so lets recap some old business.
18:03:39 <Oxf13> #topic old business - Snapshot 1 (and 2)
18:03:59 <Oxf13> Snapshot 1 went out, a reduced set of live images due to e2fsprogs resize issues
18:04:11 <Oxf13> those have been fixed, and just in time for snapshot 2
18:04:28 <Oxf13> snapshot 2 was late in getting composed due to rawhide issues, but I got them all composed on Friday
18:04:38 <Oxf13> and staged to the torrent system.  I'll be making the torrents live today
18:05:00 <Oxf13> #action Oxf13 to release snapshot2 torrents today
18:05:25 <spot> Oxf13: is the license stuff automated now?
18:05:35 <Oxf13> I couldn't find anywhere that we promised what we would release for snapshots
18:06:09 <spot> Oxf13: is that in reply to me, or in general?
18:06:46 <rdieter> I don't recall any sort of commitment either
18:07:00 <Oxf13> so I've been making the Live, Live-KDE, Live-XFCE, and Live-LXDE images
18:07:03 <Oxf13> mostly because they're all small
18:07:12 * dgilmore is here
18:07:16 <Oxf13> and I know that the xfce/lxde folks are quick to get people to poke at them.
18:07:33 * spot wonders if he's lagging... :/
18:07:35 <Oxf13> I don't think I want to amke any more than 4 live sets, and I don't really want to do any DVD sized images
18:07:41 <Oxf13> spot: no, I'll get to your question in a moment
18:07:46 <spot> Oxf13: thanks.
18:08:03 <dgilmore> Oxf13: i think live isos are perfectly ok
18:08:16 <Oxf13> dgilmore: yeah, but which ones (:
18:08:20 <Oxf13> nobody has complained yet
18:09:48 <dgilmore> Oxf13: gnome/kde/XFCE/LXDE
18:09:59 <Oxf13> as far as source is concerned.
18:10:14 <Oxf13> I have it in my notes to add the README-SOURCES file to the torrents
18:10:20 <Oxf13> but that's not "automated" in any way
18:10:37 <Oxf13> nor is keeping the tree that file references around "automated"
18:10:41 <spot> Oxf13: okay, as long as it happens.
18:10:58 <Oxf13> strategy for now is to keep all the rawhide trees for the entire cycle of a release
18:11:04 <spot> Oxf13: are your notes on the process on the wiki somewhere?
18:11:10 <spot> e.g. raptor problem
18:11:14 <Oxf13> IE don't throw out any rawhide trees made while developing F12 until after F12 is out
18:11:28 <Oxf13> spot: it's in a tomboy note and waiting for a queue slot to get it into the wiki somewhere
18:11:35 <spot> Oxf13: mmkay.
18:11:40 <Oxf13> spot: I really need a docs person to spend a day or so with me to get things into the wiki
18:13:48 <rdieter> one of those harry potter pensieve dealies would be nice, could sit next to the orbital laser controls probably
18:14:16 <Oxf13> heh
18:14:28 <Oxf13> anyway, any further thoughts on snapshots?  Got one more to make this week
18:15:21 <Oxf13> oh for those not in the "know", we need to provide a link to sources when we publish live images and snapshots
18:15:48 <notting> how do we determine the benefit we get from snapshots for the effort expended?
18:15:55 <Oxf13> to comply with this, we've been adding a README-SOURCES file that points to the rawhide tree on kojipkgs.fedoraproject.org/mash/rawhide-$DATE/source/ for which ever tree we composed against.
18:16:23 <Oxf13> and I had to re-generate all the active torrents with live images to add this file
18:18:06 <Oxf13> notting: that's a good question, probably one we should ask our QA counter parts
18:18:15 <Oxf13> the snapshots were supposed to serve a couple purposes.
18:18:27 <Oxf13> 1) something to download weekly and test with, hopefully known working
18:18:49 <Oxf13> 2) a target for developers to keep in mind "Snapshot will happen at $foo, lets make sure our stuff is done/working by then"
18:21:14 <Oxf13> I'm not sure how we're doing on #2, and QA would have to help us answer #1
18:21:28 <Oxf13> #idea <notting> how do we determine the benefit we get from snapshots for the effort expended?
18:22:13 <Oxf13> alright, moving on a bit
18:22:31 <Oxf13> #topic old business - slow newRepo tasks
18:22:48 <Oxf13> We talked about the slow tasks last meeting and had some action items to work on this.
18:23:05 <Oxf13> dgilmore was going to move builders + public access to koji1, so that kojira could have more of koji2 to use.
18:23:09 <Oxf13> dgilmore: did that happen?
18:25:18 <Oxf13> he's not listening right now
18:25:51 <Oxf13> I had an action to plot newRepo durations over time, and I did that a few times
18:26:07 <Oxf13> http://jkeating.fedorapeople.org/newrepo-average-duration.png
18:26:14 <Oxf13> that was a little over a week ago
18:26:58 <Oxf13> then we looked at the code a bit more
18:27:11 <rdieter> quite a wide variance, but that's for all newRepos I take it ? (obviously some tags will take longer than others)
18:27:20 <Oxf13> and mbonnet found where a stat was being called on every file during the first stage of the tasks
18:27:36 <Oxf13> this... is slow on our storage, and really not necessary.  So we killed the stat call
18:27:41 <Oxf13> http://jkeating.fedorapeople.org/newrepo-average-duration-14.png
18:27:55 <Oxf13> and now we're at the average times for the last 14 days, for the dist-f12-build repo
18:28:11 <rdieter> nice
18:28:16 <Oxf13> with the exception of a spike a few days ago, we've been between 10 and 15 minutes per newRepo.
18:28:31 <Oxf13> this is significantly better than we were before
18:28:48 <dgilmore> Oxf13: it did
18:29:15 <Oxf13> dgilmore: ok, thanks.
18:29:44 <Oxf13> so now, the entire newRepo task, from start to finish, is averaging about 12 minutes.  I find this acceptable and I think we can move on from this topic.
18:29:49 <Oxf13> any other thoughts?
18:30:12 <dgilmore> none
18:31:01 <Oxf13> Alright, that ends our old business.
18:31:15 <Oxf13> #topic Fedora 12 Beta
18:31:56 <Oxf13> Beta is coming up early next month
18:32:12 <Oxf13> I need to create the milestone and create a bunch of tickets for the beta cycle.
18:32:32 <Oxf13> that should happen today, I apologize for the ticket spam
18:33:33 <Oxf13> We'll also be having bug blocker days every Friday, to keep everybody in the loop with known blocker issues as we gear up for the release
18:33:36 <Oxf13> and freeze
18:33:42 <Oxf13> so I would encourage you to attend
18:35:12 <Oxf13> #topic Open Floor
18:35:21 <Oxf13> anybody got anything else to talk about?
18:35:39 <Oxf13> oh, I'll be gone at LinuxCon next week, but should have some net capability to do whatever tasks are necessary
18:35:46 <notting> Oxf13: you staying through lpc?
18:36:06 <Oxf13> notting: doubtful.  $$.  I'll probably leave either Thu or Fri
18:36:18 <Oxf13> depends on where I'm staying etc..
18:36:21 <dgilmore> ill be in RDU next week
18:36:30 <dgilmore> not sure what availability ill have
18:36:38 * notting will be at LPC
18:39:35 <Oxf13> Ok, closing the meeting in a minute if there is no other business.
18:42:01 <Oxf13> #endmeeting