fedora-meeting
LOGS

14:05:58 <Kevin_Kofler> #startmeeting KDE SIG Meeting - https://fedoraproject.org/wiki/SIGs/KDE/Meetings/2009-08-25
14:05:58 <zodbot> Meeting started Tue Aug 25 14:05:58 2009 UTC.  The chair is Kevin_Kofler. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:05:58 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
14:06:12 <Kevin_Kofler> #chair than rdieter ltinkl jreznik svahl SMParrish
14:06:12 <zodbot> Current chairs: Kevin_Kofler SMParrish jreznik ltinkl rdieter svahl than
14:06:46 <than> Kevin_Kofler,  add kde-4.3.1 to topic
14:06:53 * Kevin_Kofler is present, hoping the intermittent campus wireless won't drop out.
14:07:01 <Kevin_Kofler> Who else is present?
14:07:05 <Kevin_Kofler> than: OK, adding.
14:07:06 * SMParrish here
14:07:15 * ltinkl is here
14:07:19 * jreznik is here
14:07:23 * svahl is here
14:07:37 <than> 2.topic, phone-backend-gstreamer
14:08:06 <Kevin_Kofler> OK, added too.
14:08:14 <than> 3. topic, must-fix bugs for F12
14:08:31 <svahl> there were some topic we wanted to rediscuss this meeting, the prelinkt issue?
14:08:40 <Kevin_Kofler> than: OK, added.
14:08:47 <than> Kevin_Kofler, thanks
14:08:47 <Kevin_Kofler> svahl: Bug ID? (I'll add it to recent bugs.)
14:08:57 <Kevin_Kofler> And then we should start, we have a lot of stuff on the agenda!
14:09:06 <svahl> oh, it was the Polkit auth agent
14:09:21 <than> svahl, as i know we have disabled it now
14:09:22 <Kevin_Kofler> svahl: Those are both recent bugs.
14:09:27 <Kevin_Kofler> I'd like IDs for both.
14:09:27 <svahl> however, lets start
14:09:45 <Kevin_Kofler> If you can look those up? Or maybe SMParrish can?
14:09:48 <jreznik> svahl: more it's "can we use gnome one with kpk"
14:10:04 <Kevin_Kofler> Let's start in order, we'll get to that one when we get to the recent bugs.
14:10:13 <Kevin_Kofler> #topic revisit KDE 4.3 feature page (eg. do we really support Google calendar in Korganizer?)
14:10:21 <Kevin_Kofler> #link https://fedoraproject.org/wiki/Features/KDE43
14:11:10 <Kevin_Kofler> So AFAIK we don't support Google calendar in KOrganizer at this point.
14:11:10 <than> great, alle features are done 100% :)
14:11:20 <Kevin_Kofler> We'd have to get the extragear package for that in.
14:11:28 <Kevin_Kofler> And I'm not sure we'll want to install it by default.
14:11:36 <than> Kevin_Kofler, optional
14:11:45 <Kevin_Kofler> But we need to package it.
14:11:52 <Kevin_Kofler> Otherwise this claim in the feature page is misleading.
14:12:16 <than> is it not packaged in rawhide?
14:12:21 <Kevin_Kofler> AFAIK, no.
14:12:23 <Kevin_Kofler> It's in extragear.
14:12:32 <Kevin_Kofler> And we don't have that new extragear package yet.
14:13:02 <Kevin_Kofler> Is there anything else inaccurate on the feature page? I don't see anything.
14:13:16 <than> is the review of this package done?
14:13:27 <Kevin_Kofler> than: No.
14:13:35 <Kevin_Kofler> I think it's not even packaged yet.
14:14:02 <jreznik> I think ltinkl prepared this list in feature, could you check if it is accurate?
14:14:03 <Kevin_Kofler> rdieter pointed to a developer blog explaining the upstream situation, let me see if I find the link.
14:14:08 <svahl> and it's also only available via svn, no tarball
14:14:29 * than is checking...
14:14:32 <ltinkl> I merely copied the features from the 4.3 announcement
14:15:17 <Kevin_Kofler> In any case, the package is there: http://websvn.kde.org/trunk/extragear/pim/googledata/calendar/
14:15:26 <Kevin_Kofler> The upstream code, I mean.
14:15:32 <than> i don't see the tarball on ktown
14:16:07 <Kevin_Kofler> Yeah, they really meant "available in extragear SVN when 4.3.0 gets released". :-/
14:16:16 <Kevin_Kofler> It's kinda misleading to claim it as a KDE 4.3.0 feature.
14:16:37 <Kevin_Kofler> There are no tarballs yet.
14:17:11 <than> i think we should wait for the tarball
14:17:22 <jreznik> and first remove it from feature page
14:17:52 <than> yes, if it's in the feature page
14:17:54 <Kevin_Kofler> jreznik: I guess so.
14:18:23 <jreznik> I'll do it
14:18:52 <Kevin_Kofler> #action jreznik to remove misleading Google Calendar support reference from KDE 4.3 feature page
14:19:13 <Kevin_Kofler> #topic get.fedoraproject.org
14:19:21 <Kevin_Kofler> #link https://www.redhat.com/archives/fedora-advisory-board/2009-August/msg00133.html
14:19:28 <Kevin_Kofler> #link https://www.redhat.com/archives/fedora-advisory-board/2009-August/msg00042.html
14:19:36 <Kevin_Kofler> (the second link is the whole discussion)
14:20:12 <Kevin_Kofler> So, what's the point of bringing this one up here? It's not up to KDE SIG to decide, unfortunately.
14:20:37 <svahl> I  added this because mo requested our goals. Maybe we can skip that one
14:20:37 <Kevin_Kofler> (I'm just being a neutral chair and bringing up everything on the agenda. :-) )
14:21:12 <SMParrish> I agree, nothing we can do about it atm.  The only thing we can do is work out a proposal to present to the board before F13
14:21:37 <Kevin_Kofler> What I think we all agree is that users should be allowed to choose and that choice should be clearly visible.
14:21:50 <jreznik> svahl: yes, we should answer - let move it to mailing list
14:22:21 <svahl> ok. heads up done, next one :9
14:22:22 <svahl> :)
14:22:30 <Kevin_Kofler> Oh, and for the record: the current download page at least mentions that the "Desktop" spin is "featuring the GNOME desktop".
14:22:44 <Kevin_Kofler> mizmo: Can at least those 4 words be added to your mockups, please? :-)
14:22:58 <Kevin_Kofler> That way, people at least know what they're getting.
14:23:25 <jreznik> let's have getkde.fedoraproject.org under our management...
14:24:04 <Kevin_Kofler> Oh yes, that's also a point: a subdomain (rather than just a subdirectory) would be nice.
14:24:24 <SMParrish> I would prefer that as well.  We should get kde.fedoraproject.org as well
14:24:40 <mizmo> Kevin_Kofler: why
14:24:57 <Kevin_Kofler> Easier to give, write down, remember.
14:25:10 <jreznik> and then we can target marketing on our users, I know, it's bad when one project is figthting but this is only way - to show, what we can do
14:26:23 <SMParrish> I can write something up and get approval for the kde.f.p.o domain from the board if y'all agree
14:26:35 <Kevin_Kofler> And also for the record: I think the biggest issue with the design is the requirements as spelled out by the Board, making one spin much more prominent than another similarly popular one is simply a mistake.
14:27:09 <Kevin_Kofler> The consensus on #fedora-kde was that we really want to support user choice and we don't like this system at all.
14:28:03 <jreznik> Kevin_Kofler: they already decided, lets do it better now so we will have something in our hands, not just words... kde.fp.o and to be more independent on board... let them their download page, lets have better one!
14:28:05 <Kevin_Kofler> Correct me if you think I'm wrong, but AFAICT, pretty much everyone on #fedora-kde supports a choice-based design.
14:28:47 <Kevin_Kofler> And the current download page is a bad thing to compare the new one to because it's also not really choice-based (though it did at least have that KDE button in the sidebar).
14:28:51 <SMParrish> I certainly do.  Thats what KDE is about choice\
14:29:26 <Kevin_Kofler> Real choice-based designs are get-fedora-all or software.opensuse.org (and FYI, there's no desktop selection for the DVD because for the DVD, it's in the installer, something we also don't have and should have).
14:30:24 <jreznik> lets start first with our subdomain to have something for board for f13... and we should answer that mail - we can discuss it on ml, lets move on
14:30:46 <Kevin_Kofler> I personally think get-fedora-all was better than the current default, its only defect is that the word "GNOME" is nowhere to be found near the desktop spin, something the new mockups also have (though maybe at least that is fixable).
14:31:21 <Kevin_Kofler> So should I log something for MeetBot?
14:31:30 <Kevin_Kofler> I think we'll want to move on.
14:31:37 <SMParrish> Yes log that I'll work on the subdomain issue
14:32:17 <Kevin_Kofler> #agreed We would like a subdomain for KDE as opposed to just a subdirectory.
14:32:30 <Kevin_Kofler> #action SMParrish to talk to the Board about the subdomain issue.
14:32:45 <Kevin_Kofler> #topic KDE 4.3.1
14:32:52 <Kevin_Kofler> than: You requested this one.
14:32:58 <Kevin_Kofler> Is there an upstream schedule yet for 4.3.1?
14:33:00 <than> KDE 4.3.1 will likely be tagged around August 27th
14:33:57 <than> i will take care of the build for F12
14:34:10 <ltinkl> I'll take care of the rest, if you don't mind
14:34:11 <Kevin_Kofler> #info KDE 4.3.1 will likely be tagged around August 27th
14:34:23 <Kevin_Kofler> #action than will take care of building KDE 4.3.1 for F12.
14:34:23 <than> ltinkl, great
14:34:32 <Kevin_Kofler> #action ltinkl will take care of building KDE 4.3.1 for F10/F11 updates.
14:34:50 <svahl> including extragear? Otherwise I can do it again
14:35:00 <than> svahl, yes please
14:35:06 <Kevin_Kofler> I may help out getting builds done during the night. ;-)
14:35:20 <Kevin_Kofler> #action svahl will take care of building KDE 4.3.1 extragear packages.
14:35:52 <Kevin_Kofler> #topic phonon-backend-gstreamer
14:36:22 <Kevin_Kofler> So what do we do with this one?
14:36:36 <than> i don't see any feedback till now
14:36:45 <than> i assume it works fine in rawhide
14:37:01 <Kevin_Kofler> We have one remaining annoyance: while we now pick up the pulsesink, we get some bogus devices as top priority.
14:37:03 <than> i tested it well on my machine and it works fine for me
14:37:15 <jreznik> it works for me quite well but not 100%... but much more better than xine one
14:37:19 <Kevin_Kofler> So it shows a warning that it's falling back to PulseAudio.
14:37:56 <Kevin_Kofler> In addition, an upstream KDE developer has asked us again on #fedora-kde to reconsider (i.e. to consider reverting to xine as default).
14:38:18 <ltinkl> Kevin_Kofler: and his main reason was?
14:38:23 <than> Kevin_Kofler, why?
14:38:42 <Kevin_Kofler> It was sandsmark, who's working on Phonon and Amarok.
14:38:48 <ltinkl> afaik, gstreamer backend is the de-facto standard backend, developed together with the rest of Phonon
14:38:56 <Kevin_Kofler> He said nobody is working on the GStreamer backend at all anymore.
14:39:05 <Kevin_Kofler> Qt Software hasn't changed anything for months.
14:39:10 <ltinkl> Kevin_Kofler: not true, I've seen many commits to it recently
14:39:14 <mathstuf_> ltinkl: mostly due to licensing
14:39:17 <Kevin_Kofler> Whereas he and another person are working on -xine in KDE SVN.
14:39:30 <Kevin_Kofler> ltinkl: It's what sandsmark said.
14:39:51 <jreznik> for Fedora gstreamer is better choice as Fedora MM is based on GStreamer
14:40:01 <ltinkl> yup
14:40:10 <jreznik> so we should push on gstreamer development
14:40:11 <ltinkl> and it _is_ being actively developed
14:40:23 <ltinkl> just search the kde-commits archive
14:40:27 <Kevin_Kofler> He also claimed that Phonon-GStreamer still has a lot of unfixed bugs.
14:40:47 <ltinkl> just like the rest of KDE, valid argument :)
14:41:09 <Kevin_Kofler> And he said that he'll close all Amarok bugs from Fedora users if we're using Phonon-GStreamer.
14:41:14 <jreznik> I see one problem - PA & Xine are not best friends... there's bigger chance to have PA & Gstreamer working
14:41:29 <ltinkl> it works fine for me, with or without PA
14:41:32 <Kevin_Kofler> Amarok upstream does not support Phonon-GStreamer.
14:41:49 <ltinkl> what a bogus statement to make
14:42:09 <jreznik> Kevin_Kofler: they should support Phonon, if problems are in Phonon, report to Phonon... it's easy
14:42:12 <ltinkl> I've never seen any probs with Amarok+GStreamer backend
14:42:38 <than> sorry, his reason doesn't satisfy me
14:43:02 <Kevin_Kofler> He said there are many known bugs in Phonon-GStreamer and he worried that #amarok is going to get flooded with people complaining about those already known bugs.
14:43:25 <than> does he report the bugs to Trolltech?
14:43:33 <Kevin_Kofler> No idea.
14:43:50 <jreznik> Kevin_Kofler: there are lot of bugs in xine backend... it's same... both are actually bad :(
14:44:37 <Kevin_Kofler> IMHO if we want to default to GStreamer, we should at least fix things so you don't get a warning with the default setup (PulseAudio).
14:44:48 <Kevin_Kofler> The PulseAudio device should be the default.
14:44:58 <than> Kevin_Kofler, i don't see the warning any more
14:45:01 <than> with my last fix
14:45:04 <Kevin_Kofler> We may have to disable that KDE platform plugin for Phonon.
14:45:29 <ltinkl> no warning here either
14:45:50 <Kevin_Kofler> rdieter reported that warning.
14:45:59 <Kevin_Kofler> And maybe 1 or 2 users too, I don't remember for sure.
14:46:15 <than> Kevin_Kofler, i'm pretty sure he still have old setting
14:46:23 <than> that causes this problem
14:46:42 <Kevin_Kofler> I think that's all about phonon-backend-gstreamer, let's move on.
14:46:58 <Kevin_Kofler> #topic must-fix bugs for F12
14:47:07 <Kevin_Kofler> Looks like that can be merged with "recent bugs".
14:47:16 <Kevin_Kofler> So we have the prelink issue and the PolicyKit 1 issue.
14:47:29 <Kevin_Kofler> SMParrish: Do you have bug IDs handy? Or should I look them up?
14:47:41 <Kevin_Kofler> And are there any other blockers?
14:48:01 <SMParrish> https://bugzilla.redhat.com/show_bug.cgi?id=515539
14:48:03 <buggbot> Bug 515539: medium, low, ---, than, ASSIGNED, prelink: process for the fileprotocol / desktop protocol died unexpectedly
14:48:30 <Kevin_Kofler> #topic #515539 - prelink: process for the fileprotocol / desktop protocol died unexpectedly
14:48:35 <Kevin_Kofler> OK, let's start with this one.
14:48:56 <than> do we want to enable prelink by default?
14:49:28 <Kevin_Kofler> Some people found breakage even without prelink installed, so I'm not sure it's actually prelink at fault.
14:49:36 <Kevin_Kofler> Something is horribly broken somewhere and I have no idea what.
14:49:38 <svahl> today I've seen this for the first time on i?86
14:49:53 <Kevin_Kofler> (Installing prelink and running it fixed it for those who didn't have prelink at all.)
14:50:20 <Kevin_Kofler> I suspect there's some uninitialized stuff which depends on the addresses being used.
14:50:40 <Kevin_Kofler> So running/rerunning prelink magically changes the addresses and makes things "work".
14:51:00 <Kevin_Kofler> Running kdeinit4 through valgrind may give us some insight into what's going on.
14:51:31 <than> Kevin_Kofler, it could be a bug in kdeinit4
14:51:48 <than> but i'm not sure
14:51:52 <Kevin_Kofler> That's what I suspect.
14:52:49 <than> we will disable prelink temporary before we find a solution for this
14:53:07 <Kevin_Kofler> But does that really fix the issue for everyone?
14:53:24 <than> svahl, does it fix for you?
14:53:31 <svahl> Haven't we done this on the live images (or manually in the bug)?
14:53:36 <Kevin_Kofler> Some people reported having to install and run prelink.
14:53:50 <Kevin_Kofler> And there's also a report of prelink -ua not fixing the issue for somebody.
14:53:59 <Kevin_Kofler> So I don't think unprelinking really fixes it.
14:54:03 <Kevin_Kofler> There's a random bug there.
14:54:13 <svahl> than, prelink wasn't installed when hitting this. It was F12-Alpha-KDE-i686-rc2 after installation
14:54:28 <Kevin_Kofler> So should I reassign it to kdelibs?
14:54:34 <svahl> for me prelink -f /usr/bin/kdeinit4 fixed it
14:54:35 <Kevin_Kofler> I think prelink is just a red herring.
14:55:06 <than> ke4qqq, yes, please reassign to kdelibs
14:55:22 <Kevin_Kofler> Well, actually it's already assigned to kdelibs.
14:55:28 <Kevin_Kofler> I'll just fix the topic.
14:56:18 <Kevin_Kofler> Anything else about this bug or should we move on?
14:56:22 <Kevin_Kofler> We have one more bug to discuss.
14:57:10 <Kevin_Kofler> #topic PolicyKit 1 authentication issues with KPackageKit - https://bugzilla.redhat.com/show_bug.cgi?id=499968
14:57:12 <buggbot> Bug 499968: medium, low, ---, smparrish, ASSIGNED, port PackageKit-qt to PolicyKit 1.0
14:57:43 <jreznik> PaK-qt is not directly talking to PK
14:57:54 <jreznik> all is done in PaK
14:58:13 <jreznik> gnome auth agent can be used with KPaK
14:58:29 <Kevin_Kofler> So this now works?
14:58:30 <SMParrish> Hughsie built a new svn release of Packagekit in rawhide.  It has not hit the mirrors yet but should fix the errors kpk is having.  And what jreznik just said is all true
14:58:32 <jreznik> but latest KPaK is crashing... https://bugs.kde.org/show_bug.cgi?id=204630
14:58:33 <buggbot> Bug 204630: crash, NOR, ---, smparrish gmail com, NEW, Crash while showing message dialog
14:58:37 <Kevin_Kofler> Should I close #499968?
14:59:00 <jreznik> Kevin_Kofler: it can be closed
14:59:03 <SMParrish> Yes 499968 can be closed,
14:59:20 <ltinkl> SMParrish, jreznik: does the new PaK fix the above bug?
14:59:40 <SMParrish> It should yes.  I still have some more testing to do
14:59:51 <jreznik> what we need is polkit-qt and kde auth agent, but it's really pain... I will need some help as I become practically upstream...
15:00:16 <Kevin_Kofler> I just closed #499968.
15:01:06 <mathstuf_> jreznik: there KAuth lib from GSoC now
15:01:10 <SMParrish> I will get a new svn snapshot of kpk built this afternoon. That along with the new packagekit should solve the issues.  I'll post when its ready so we can get some testing done
15:01:11 <Kevin_Kofler> #info #499968 is fixed.
15:01:26 <Kevin_Kofler> jreznik: Does the GNOME one work for now?
15:01:36 <Kevin_Kofler> Or do we have to open a blocker bug to get things working ASAP?
15:01:39 <jreznik> Kevin_Kofler: yes, it works
15:01:49 <Kevin_Kofler> mathstuf_: That lib cannot be used to implement an auth agent.
15:01:54 <jreznik> SMParrish: thanks
15:02:00 <Kevin_Kofler> It's a platform-independent wrapper for apps.
15:02:18 <jreznik> kauth it's just library and waits for new polkit-qt
15:02:36 <mathstuf_> ah
15:02:37 <Kevin_Kofler> #action SMParrish will build a new kpackagekit snapshot which should fix some of the regressions.
15:02:43 <jreznik> ok, too late, let move back to #fedora-kde
15:03:11 <adamw> maybe we should just move our meeting to 1530 :P
15:03:19 <Kevin_Kofler> Can I close the meeting now?
15:03:25 <Kevin_Kofler> Or do we have some more stuff to discuss?
15:03:57 <Kevin_Kofler> Closing meeting in 15 seconds.
15:04:12 <Kevin_Kofler> #endmeeting