env-and-stacks
LOGS
17:00:55 <hhorak> #startmeeting Env and Stacks (2015-08-20)
17:00:55 <zodbot> Meeting started Thu Aug 20 17:00:55 2015 UTC.  The chair is hhorak. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:55 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
17:00:59 <hhorak> #meetingname env-and-stacks
17:00:59 <zodbot> The meeting name has been set to 'env-and-stacks'
17:01:02 <hhorak> #chair bkabrda hhorak juhp ncoghlan vpavlin jkaluza walters ttomecek phracek
17:01:02 <zodbot> Current chairs: bkabrda hhorak jkaluza juhp ncoghlan phracek ttomecek vpavlin walters
17:01:10 <hhorak> #topic greetings..
17:01:21 <hhorak> bconoboy: hi!
17:01:24 <bconoboy> howdy!
17:01:31 <hhorak> good evening, morning or afternoon! who else do we have here today to chat about rings?
17:01:51 * bconoboy nudges sgallagh and langdon
17:02:10 * langdon just had a distracting email.. but here
17:02:23 <sgallagh> I'm sort of here, sort of in another meeting
17:02:34 <langdon> .hello langdon
17:02:34 <zodbot> langdon: langdon 'Langdon White' <langdon@fishjump.com>
17:02:41 <sgallagh> .hello sgallagh
17:02:42 <zodbot> sgallagh: sgallagh 'Stephen Gallagher' <sgallagh@redhat.com>
17:02:47 <bconoboy> .hello blc@
17:02:47 <zodbot> bconoboy: Sorry, but you don't exist
17:02:52 * langdon really wants zodbot to use my fp.o address
17:02:52 <bconoboy> Yahr.
17:03:11 <hhorak> #topic how to invite the conversation to e&s
17:03:51 <hhorak> thanks, langdon, for the topics, these are all issues we have struggled for some time
17:04:23 <hhorak> so, who do we wan to attract and invite? other wgs on the first place..
17:04:47 <bconoboy> I'm interested in getting the Base WG involved for lower rings, but not sure if that is what you are asking
17:05:20 <hhorak> bconoboy: it is :)
17:05:31 <bconoboy> Ah, okay, so I will elaborate
17:05:47 <langdon> hhorak, i think it is a matter of outreach, basically, I believe there are a number of "stack-like" technologies being pursued in the Edition Working Groups.. i am concerned that there may be duplicated/conflicting effort.. so I went to a bunch of them and talked to them about discussing in e&s
17:05:53 <bconoboy> For context, we had a nice discussion at Flock on saturday
17:05:58 <bconoboy> About rings
17:06:08 <langdon> ok.. confused
17:06:30 <langdon> want to talk about 1) base relationship to e&s first? or 2) container-techs first?
17:06:35 <bconoboy> The general consensus in the room was that E&S should help define some of the boundaries of the rings, and possibly come up with a better name than rings since it breaks down at higher levels
17:06:56 <bconoboy> But E&S shouldn't dictate the details of each ring- those should be forwarded on to more appropriate WG's
17:07:14 <bconoboy> So it seems like Base is a good WG for ring 0/1 sort of space
17:07:30 <bconoboy> But there will be many rings, or crescents, or blobs...
17:07:34 <hhorak> #info it is a matter of outreach, there are a number of "stack-like" technologies being pursued in the Edition Working Groups; we want to avoid duplicated/conflicting effort.
17:08:09 <bconoboy> So the idea is that if we figure out the rough relationship we'd like to see, we could engage the other WGs who have expertise in that area and can sanity check/develop
17:08:12 <langdon> also, e&s should recommend available technologies for "implementing rings" which base would then include (probably) in r0 & r1.. available to all the editions and higher rings
17:08:22 <bconoboy> </context>
17:09:04 <hhorak> #info The general consensus in the room on Flock was that E&S should help define some of the boundaries of the rings, and possibly come up with a better name than rings since it breaks down at higher levels
17:09:22 <hhorak> #info But E&S shouldn't dictate the details of each ring- those should be forwarded on to more appropriate WG's
17:09:46 <bconoboy> Anyway, it seems like this activity naturally invites participation from the other WGs
17:09:58 <bconoboy> Hopefully in a positive way
17:10:10 <hhorak> #info e&s should recommend available technologies for "implementing rings" which base would then include (probably) in r0 & r1.. available to all the editions and higher rings
17:11:21 <langdon> bconoboy, i am not sure that the WGs themselves would be interested in "ring definition" (maybe individuals but not the focus of wkstn wg per se)...  but they may be interested in the "methods to deliver apps to users" which i think of as the "available stacks"
17:12:20 <bconoboy> langdon: Perhaps.  From my standpoint this is all about creating policies in which development communities can find the natural fit
17:12:51 <langdon> i guess i have been thinking that getting the "humans" involved in xdg-app, docker, rolekit, nulecule, etc to move the discussions of the capabilities to e&s then anyone with an interest in "sandboxing apps" might have a single place to discuss irrelevant of the apps in the sandboxes..
17:13:12 <bconoboy> The interaction between those policy groups is where E&S seems to fit in
17:13:22 <hhorak> langdon: we already heard ideas to have whole wkstn as rpmostree, so they might be interested in other rings as well, not only modules.. but generally your statement makes sense..
17:14:05 <langdon> hhorak, sorta my point.. e&s and base say "ostree is an avail tech" then wkstn comes along and says.. we are gonna do everything as ostrees..
17:14:44 <langdon> but i would like to see e&s and base say "xdg-app is avail tech" rather than wkstn do so.. so that, if server wanted xdg-app, they could get it (easily) too
17:15:48 <langdon> and.. i think the people involved in the techs mentioned above are more likely to be interested and steeped in the tradeoffs in those techs than a random gnome app developer or httpd developer
17:16:05 <bconoboy> Won't know till we ask
17:16:39 <hhorak> #info this is all about creating policies in which development communities can find the natural fit; various groups involved in xdg-app, docker, rolekit, nulecule, etc may move the discussions to e&s since the interaction between those policy groups is where E&S seems to fit in
17:17:51 <bconoboy> (I'm working from the assumption that each wg has a degree of leadership who sees the common problems they'd like addressed in the current fedora structure)
17:17:55 <langdon> bconoboy, i did a lot of asking, i think they agreed :) .. now i just need to ask e&s if they want to take it on :)
17:18:09 <bconoboy> langdon: sounds good :-)
17:18:45 <hhorak> langdon: I can't probably speak for whole group (anyone else from members here today?)
17:20:16 <hhorak> but it is not about e&s members & friends only, if we somehow make the other groups & developers of the cool techs to use e&s as medium to present new ideas, it would be great step forward
17:20:48 <langdon> hhorak, +1 (but i am not a member, just an agitator :) )
17:20:59 <bconoboy> likwise
17:21:00 <hhorak> langdon: you say they agreed, so the other groups already know about this evil plan to take over the world?
17:21:33 <hhorak> or should we rather communicate this as the first step..
17:21:34 <bconoboy> There were probably 25 people in the room, but there was no formal vote or tally of WG representation, just head nodding
17:21:46 <bconoboy> Communicate is definitely the first step
17:22:12 <langdon> well.. I talked to individuals, I didn't think the wkstn wg was actually interested in xdg-app (for example), per se, except as a means to deliver apps to users in a way that met their requirements..
17:22:32 <langdon> bconoboy, i had many convos about this before and during flock as well
17:22:42 <bconoboy> Coincidentally, everybody there was on board with rings, they just want to see it move forward so they can understand and participate in how it affects them
17:22:47 * bconoboy defers to langdon
17:24:24 <langdon> bconoboy, i think this convo of "shipping app tech" being the purview of e&s is related but not quite the same.. i think the rings/modularization stuff is more with regards to  guidelines as you mentioned about.. in other words the "why" vs this being the "how"
17:24:37 <bconoboy> y
17:24:37 <langdon> s/about/above
17:25:37 <hhorak> so, any volunteer to reach the WGs with some (looking for correct word... invitation?)
17:25:55 <langdon> well.. so i killed that convo.. anyone else here who is paying attention? thoughts? anyone disagree with my proposal?
17:26:34 <bconoboy> Is now the time to reach out to WGs or the time to check with the broader E&S community who isn't here today?
17:26:44 <bconoboy> (both?)
17:27:16 <langdon> well.. i can say, w/o a formal vote, that the council is in agreement with this plan...
17:27:29 <langdon> in my impression (was supposed to be in there somewhere)
17:27:31 <bconoboy> sounds like both
17:28:12 <hhorak> I don't expect other wg members will be against, at least in my PoV this has been always the secret goal :)
17:28:23 <langdon> hhorak, lol
17:28:27 <bconoboy> I suggest outreach to Base first, then
17:29:18 <langdon> hhorak, meeting tomorrow.. hint hint .. i can be on it too if you want..
17:29:45 <hhorak> langdon: what time?
17:30:06 <langdon> hhorak, 10 edt (but looking)
17:30:25 <bconoboy> 11 EDT I think
17:30:28 <langdon> 15h utc
17:30:47 <hhorak> ou, I might be in the train by that time.. but can reschedule my plans..
17:30:52 <bconoboy> (From https://apps.fedoraproject.org//calendar/ical/base/)
17:30:53 <hhorak> (or try to)
17:31:28 <hhorak> I'll at least try to contact the WG prior the meeting with rough ideas..
17:31:30 <langdon> hhorak, or next week then.. and bring it up with e&s on thurs next week first
17:32:10 <hhorak> langdon: next Friday is even worse, we have the team building where you hopefully will be as well :)
17:32:16 <bconoboy> tomorrow++
17:32:38 <hhorak> I'll try to be there tomorrow..
17:33:46 * langdon is anti-team-building .. will be sulking instead ;)
17:33:56 <bconoboy> I'll be there
17:34:45 <hhorak> langdon, did we cover all the points you proposed? we touched all at least but I'm not sure whether that was enough..
17:34:48 <langdon> bconoboy, team building? or base-wg? cause i think you should come to the team building thing.. it will amuse me..
17:35:23 <langdon> can you or one of us recap? to make sure we are all on the same page? like i think we did, but i want to be sure you heard what i heard ;)
17:35:25 <bconoboy> langdon: team building not on my calendar, but i'm game ;-)
17:35:41 <bconoboy> I *think* the plan is:
17:35:47 * langdon wonders if we can build a team of anti-team-builders :)
17:35:56 <bconoboy> Somebody mails e&s list saying "Hey, let's lead ring development and reach out to WGs"
17:36:28 <bconoboy> Somebody mails base members and says "Hey, we think you should define ring0/1 maybe 2, but we don't know what that means"
17:36:50 <bconoboy> The base email might, instead of being an email, be an intro during tomorrow's base wg meeting
17:37:00 <bconoboy> Makes it a little less formal
17:37:28 <bconoboy> That way, everybody who was unprepared for this topic this week (everybody) will have it in mind for next week
17:37:44 <bconoboy> Then we can actually get going
17:38:08 <langdon> hhorak, is that what you heard?
17:38:17 * langdon assumed bconoboy was complete
17:38:21 <bconoboy> y
17:38:35 <hhorak> bconoboy: +1 nice recap, thx
17:38:56 <hhorak> so no mail to base before meeting and we can use moment of surprise?
17:39:29 <bconoboy> Well, base uses devel@fp.o so that's a big distribution ;-)
17:40:09 <bconoboy> Either way seems reasonable to me, as long as it's phrased as a tentative idea and an invitation to join in, it's good
17:41:34 <langdon> ok.. so e&s agenda for next week: 1) ratify container-techs live in e&s belief 2) identify author of email to other wgs inviting the techs in to e&s ?
17:42:16 <hhorak> langdon: works for me :)
17:42:23 <langdon> and for base tomorrow: nice agenda item to talk about owning r0/1 with guidelines from e&s? will hhorak send that? me? bconoboy? someone who isn't here that we can trick in to the action item?
17:42:57 <bconoboy> volunteers?
17:43:23 <bconoboy> I'm just gate crashing here so I'm probably not the right person
17:43:48 <langdon> well.. i can write it or help write it.. but i think it should come from e&s official.. hence hhorak..
17:44:01 <bconoboy> I second langdon's nomination of hhorak ;-)
17:44:02 <hhorak> langdon: you mean sending agenda item for tomorrow, right?
17:44:22 <langdon> hhorak, correct.. and if you want, i can help author it
17:45:52 <hhorak> langdon: I think I'll keep it short, but if you have something on you mind already, don't be afraid to share :)
17:46:09 <langdon> hhorak, not really..
17:46:41 <hhorak> #action hhorak to send agenda item for tomorrow's base meeting about owning r0/1 with guidelines from e&s
17:47:15 <hhorak> all right, so we're set on this point.. I'm not sure whether it is reasonable to start with deeper ring discussion, but maybe just touch the topic about where to keep track of rings...
17:47:23 <langdon> hhorak, and, you are doing the agenda stuff for e&s next week, right? (but I will be there and bconoboy probably will too)
17:48:44 <hhorak> langdon: yes, I'll do the agenda, but not sure whether be able to attend..
17:49:20 <langdon> hhorak, i think we can fight our way out of the other meeting... this is important..
17:49:36 <langdon> hhorak, ohhh
17:49:37 <hhorak> ok.. :)
17:49:38 <langdon> yuck
17:49:48 <langdon> its at a bad time..
17:50:41 <langdon> lets take it offline and see what we can do.. worst case, we can shift it a week.. or just bring it up on the ML?
17:50:48 <bconoboy> not sure I can make the alternate week, but this time is always good
17:51:39 <hhorak> langdon: ML works for me..
17:52:01 <langdon> hhorak, esp. as we don't, really, expect any pushback
17:52:14 <hhorak> exactly
17:52:26 <bconoboy> If anything people will reply "of course you are, get to it already" :-)
17:52:40 <bconoboy> (this happened at flock;-)
17:53:29 <hhorak> anyway, any idea where to keep track of everything what is happening around fedora.next?
17:53:38 <langdon> hhorak, trying to build that now
17:54:26 <hhorak> langdon: build? /me really wondering what that might be...
17:54:42 <langdon> hhorak, ha.. not in the cool sense.. just "building up the content" :)
17:55:00 <bconoboy> langdon: I can help
17:55:34 <hhorak> langdon: great, do you have plan where to put it? ML has tendency to be hard to find in the future..
17:55:50 <hhorak> wiki?
17:55:52 <bconoboy> I'll work with Langdon on this question, let's revisit next time
17:56:02 <bconoboy> wiki has my tentative vote
17:56:49 <langdon> hhorak, +1 on "not-ML" for a "project page"... wiki might be the right answer.. but may not have all the features.. or seomthing.. i am not sure yet
17:57:14 <hhorak> we don't have much more options in fedora I guess.. but it should be fine at least for beginning..
17:57:30 <hhorak> the time is almost up, any last words?
17:57:34 <langdon> hhorak, yeah.. but.. let's table that for this meeting..
17:58:03 <hhorak> langdon: +1
17:59:11 <hhorak> #info we can think about which tool to track the rings and fedora stuff later, but short-term, wiki should be fine enough
17:59:54 <hhorak> Thanks a lot guys, have a nice rest of the day!
18:00:30 <hhorak> #endmeeting