f23_alpha_gono-go_meeting
LOGS
17:00:27 <jkurik> #startmeeting F23 Alpha Go/No-Go meeting
17:00:27 <zodbot> Meeting started Fri Aug  7 17:00:27 2015 UTC.  The chair is jkurik. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:27 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
17:00:28 <jkurik> #meetingname F23 Alpha Go/No-Go meeting
17:00:28 <zodbot> The meeting name has been set to 'f23_alpha_go/no-go_meeting'
17:00:39 <nirik> morning everyone.
17:00:41 <jkurik> #topic Roll Call
17:01:36 <sgallagh> .hello sgallagh
17:01:37 <zodbot> sgallagh: sgallagh 'Stephen Gallagher' <sgallagh@redhat.com>
17:01:49 <jkurik> Hi Go/No-Go team
17:01:52 <mattdm> .hello mtatdm
17:01:53 <zodbot> mattdm: Sorry, but you don't exist
17:01:54 <mattdm> lol
17:01:57 <mattdm> .hello mattdm
17:01:59 <zodbot> mattdm: mattdm 'Matthew Miller' <mattdm@mattdm.org>
17:02:08 * pwhalen is here
17:02:57 <roshi> .hello roshi
17:02:58 <zodbot> roshi: roshi 'Mike Ruckman' <mruckman@redhat.com>
17:03:08 <jkurik> #chair sgallagh nirik mattdm roshi
17:03:08 <zodbot> Current chairs: jkurik mattdm nirik roshi sgallagh
17:03:09 <nirik> I also talked with stickster eariler and have his proxy to say stupid things. ;)
17:03:16 <mattdm> nirik: ooh, do it!
17:03:34 <roshi> and he has to put them on his twitter feed, right?
17:03:41 <roshi> do we get a vote? :p
17:03:56 <jkurik> nirik: so your vote has a double power now
17:03:58 <nirik> I think he's off to a justin beiber concert today.
17:04:03 * nirik runs
17:04:05 <roshi> haha
17:04:22 * roshi makes a note to ask him about the concert at flock
17:04:26 <jkurik> #topic Purpose of this meeting
17:04:28 <jkurik> #info Purpose of this meeting is to see whether or not F23 Alpha is ready for shipment, according to the release criteria.
17:04:29 <jkurik> #info This is determined in a few ways:
17:04:31 <jkurik> #info No remaining blocker bugs
17:04:32 <jkurik> #info Release candidate compose is available
17:04:34 <jkurik> #info Test matrices for Alpha are fully completed
17:04:35 <jkurik> #link https://qa.fedoraproject.org/blockerbugs/milestone/23/alpha/buglist
17:04:36 <jkurik> #link https://fedoraproject.org/wiki/Test_Results:Fedora_23_Alpha_RC2_Installation
17:04:38 <jkurik> #link https://fedoraproject.org/wiki/Test_Results:Fedora_23_Alpha_RC2_Base
17:04:40 <jkurik> #link https://fedoraproject.org/wiki/Test_Results:Fedora_23_Alpha_RC2_Desktop
17:04:41 <jkurik> #link https://fedoraproject.org/wiki/Test_Results:Fedora_23_Alpha_RC2_Server
17:04:43 <jkurik> #link http://meetbot.fedoraproject.org/fedora-meeting-2/2015-08-06/f23_alpha_gono-go_meeting.2015-08-06-17.00.html/
17:04:46 <jkurik> #topic Current status
17:04:55 <jkurik> #info This is the second round of Go/No-Go meeting for Fedora 23 Alpha
17:05:05 <jkurik> #info The Go/No-Go decision has been postponned for today due to bug 1250874
17:05:46 <jkurik> So we are here to discuss mostly the impact of 1250874 on the Alpha release
17:06:05 <roshi> from my testing, things look good with the grub2 workaround
17:06:09 <jkurik> However I see there is one new proposed blocker 1251247
17:06:23 <roshi> and there's confirmation from dustymabe, mattdm and nirik (iirc)
17:06:25 <nirik> there's currently 3 proposed blockers it looks like
17:06:37 <nirik> yes, the new cloud-base image looks good to me.
17:06:45 <roshi> mini blocker  review time?
17:06:59 <nirik> yep I suppose so
17:07:15 <jkurik> #topic Mini blocker review
17:07:25 <jkurik> roshi: may I ask you please ?
17:07:31 <roshi> sure thing
17:07:46 <roshi> I guess I forgot to secretarialize from yesterday
17:08:01 <roshi> so the Cloud bug and the FreeIPA ones we don't have to go over
17:08:06 <roshi> since we did those yesterday
17:08:32 <roshi> #topic (1251247) Review Request: f23-kde-theme - Fedora Twenty Three KDE Theme
17:08:35 <roshi> #link https://bugzilla.redhat.com/show_bug.cgi?id=1251247
17:08:38 <roshi> #info Proposed Blocker, Package Review, ASSIGNED
17:08:48 <nirik> so, this is the fun one.
17:08:58 * nirik doesn't guess we have adamw or dgilmore or many others around yet?
17:09:31 <dgilmore> hola
17:09:31 <sgallagh> I will reiterate my stance that treating wallpaper as an Alpha blocker is nonsense
17:09:41 <nirik> my proposal: drop this critera from alpha.
17:09:58 <dgilmore> +1
17:10:05 <roshi> the criteria has a purpose, and I think it's a decent one
17:10:06 <jkurik> nirik: +1
17:10:10 <sgallagh> nirik: I made the same proposal to the QA list, FWIW
17:10:12 <sgallagh> +1
17:10:13 <mattdm> roshi +1
17:10:31 <roshi> and I'm not a huge fan of the idea of "we might have to block on this so lets drop the criterion"
17:10:40 <roshi> otherwise, why have criteria in the first place?
17:10:49 <roshi> not saying this is something critical we're handwaving
17:10:52 <roshi> just in principle
17:11:04 <sgallagh> roshi: The criteria has a purpose, but not enough alone to justify blocking a release IMHO
17:11:04 <dgilmore> roshi: indeed
17:11:15 <sgallagh> And that should be the definition of a blocker criterion
17:11:32 <dgilmore> but things change and it seems a silly to have that criterea
17:11:45 <roshi> criterion don't just end up on the list due to a whim of QA - there was a discussion and reasoning behind this being one
17:12:02 <roshi> and we should revisit that if need be (thanks for starting the discussion on the list nirik)
17:12:05 <mattdm> So, alternate way to fulful that purpose -- jkurik, can you make sure that "Update wallpaper for alpha right when the new release branches" is on Some Schedule Which The Right People Will Be Aware Of for the future?
17:12:08 <nirik> this fails the "if this was the last thing blocking release" test.
17:12:18 <roshi> but now we're just asking "does this bug violate the criterion as written, today"
17:12:30 <nirik> mattdm: IMHO, we should be landing the f24 walpaper in rawhide before it branches.
17:12:38 <roshi> +1 nirik
17:12:54 <mattdm> nirik: sure or that, if it's okay for the alpha and rawhide to have same wallpaper
17:13:07 <roshi> like I said last meeting, and adam comments on in the bug - this really shouldn't be an issue, it's an easy task
17:13:08 <nirik> perfectly fine IMHO
17:13:14 <roshi> it just must have gotten overlooked
17:13:19 <nirik> roshi: sure, but here we are.
17:13:32 <jkurik> mattdm: yes I can do it
17:13:37 <roshi> mattdm: when F2N branches, change the rawhide backgrounds - then it's differnt and handled
17:13:38 <mattdm> jkurik++
17:13:38 <zodbot> mattdm: Karma for jkurik changed to 4:  https://badges.fedoraproject.org/tags/cookie/any
17:14:05 <mattdm> roshi sure, that'll work; either way.
17:14:17 <jkurik> #action jkurik make sure that "Update wallpaper for alpha right when the new release branches" is on Some Schedule Which The Right People Will Be Aware Of for the future
17:14:18 <nirik> anyhow, I don't think we can say -1 blocker based on the current critera, we need to change the critera, or just slip 2 weeks.
17:14:26 <roshi> so, today, as written, does this bug violate the criteria?
17:14:32 <nirik> yes, it does.
17:15:20 <sgallagh> nirik: Or make a judgement call and let the test@ list discussion decide the future
17:15:29 <nirik> we are geting bogged down in process, it's silly.
17:15:33 <roshi> I'd like to ignore this criteria and just get the release out - but I don't feel comfortable signing off for all QA on that
17:15:36 <sgallagh> (For example, a judgement call like "make this a Beta blocker for now")
17:15:45 <roshi> but that's just me
17:15:55 <nirik> roshi: understandable..
17:16:03 <sgallagh> roshi: Who can you find that will be comfortable with that? ;-)
17:16:07 <nirik> tflink / adamw / kparal ^ any of you around?
17:16:07 <roshi> haha
17:17:38 <mattdm> So... is "make exception for blocker for this release, fix the process that led us to getting here at the last momemnt, leave as blocker" an option in any way?
17:17:49 <nirik> I don't think so.
17:18:14 <nirik> because QA will say "no go" as their are open blockers per their process.
17:18:22 <roshi> right
17:18:26 <nirik> so this needs to be not a blocker or fixed.
17:18:32 <mattdm> quick, remove as blocker, put back as blocker on monday :)
17:18:36 <nirik> IMHO, we should make it not a blocker.
17:19:07 <roshi> I'm not a huge fan of this particular instance of our process - but I don't want to start a trend of changing/ignoring criterion during clutch times like this
17:19:10 <roshi> if that makes sense
17:19:15 <roshi> lol
17:19:28 <nirik> sure, no one likes it, but we have done it before in the past too...
17:19:35 <mattdm> I'm not proposing ignoring it -- we should definitely address the problem
17:19:53 <roshi> well, let's move to votes
17:20:13 <roshi> if it gets voted down, then it's done and the conversation about the criterion can go on in the list
17:20:23 <sgallagh> Jury's prerogative? I vote -1 blocker on the grounds that the law is unjust ;-)
17:20:37 <danofsatx> seconded
17:20:45 <tflink> we've handwaved more severe blockers in the past
17:21:11 * roshi would propose adding a caveat to all criterion that some are identified as mini-blockers or something ("this isn't enough to block release on" {but then again, why have it at all if it doesn't block?})
17:21:14 <nirik> I guess I don't see a way to handwave it tho...
17:21:16 <tflink> but yeah, I'd rather see us handwave the wallpaper blocker away than anything else - the debate over the actual criterion should take the normal route
17:21:19 <potty> 0
17:21:25 * nirik ponders
17:22:00 <danofsatx> if anything, this should be a final, not alpha.
17:22:13 <nirik> there is a final critera on it.
17:22:22 <sgallagh> danofsatx: There's a separate final criterion
17:22:26 <roshi> proposed #agreed - 1251247 - RejectedBlocker - While this bug does violate the criteria as written, it's not deemed severe enough to block release and discussion is ongoing regarding the validity of this as an Alpha criterion.
17:22:43 <roshi> proposed #agreed - 1251247 - RejectedBlocker - While this bug does violate the criterion as written, it's not deemed severe enough to block release and discussion is ongoing regarding the validity of this as an Alpha criterion.
17:22:44 <nirik> sure. +1
17:22:55 <jkurik> ack
17:22:56 <tflink> ack
17:22:57 <roshi> s/criteria/criterion/
17:23:03 <sgallagh> ack
17:23:06 <roshi> #agreed - 1251247 - RejectedBlocker - While this bug does violate the criterion as written, it's not deemed severe enough to block release and discussion is ongoing regarding the validity of this as an Alpha criterion.
17:23:21 <nirik> thanks roshi
17:23:43 <roshi> np
17:23:44 <jkurik> uff, I was afraid we will block the Alpha due to this ... :)
17:24:14 * nirik was too, would have made for an angry flock, so happily thats avoided. ;)
17:24:16 <sgallagh> jkurik: Me too. I was all ready to start laying about with an empty whiskey bottle.
17:24:25 <tflink> we need to figure out some better process stuff, though
17:24:37 <tflink> the fact that we got to this point means something failed
17:24:42 <nirik> I think we could frontload more stuff into rawhide than we do.
17:24:48 <nirik> this being a great example
17:24:59 <sgallagh> tflink: The design folks got surprised right at the end with the deadline, not sure how that happened.
17:24:59 <roshi> for sure
17:25:08 <sgallagh> I'll talk with mizmo about solving it for the future
17:25:24 <roshi> it's good we identified a process problem, and working on a solution
17:25:56 <tflink> sounds like a failure in planning or communication to me. not trying to blame anyone, just wondering how to fix it
17:26:09 <mattdm> hmmm https://fedorapeople.org/groups/schedule/f-23/f-23-all-tasks.html has the alpha wallpaper _way in the future_
17:26:36 <roshi> now we've got one accepted blocker to look at:
17:26:36 <roshi> #topic (1251242) Tracker: Fedora 23 desktops using Fedora 22 desktop backgrounds
17:26:39 <roshi> #link https://bugzilla.redhat.com/show_bug.cgi?id=1251242
17:26:42 <roshi> #info Accepted Blocker, distribution, NEW
17:26:55 <nirik> ditto the last
17:26:58 <mattdm> "Finalize Alpha Wallpaper" is august 19th, a week and a day after alpha release. :-/
17:27:05 <nirik> mattdm: :(
17:27:06 <roshi> oof
17:27:10 <roshi> that might explain it
17:27:33 <jkurik> mattdm: The schedule has many strange things; it needs a rework
17:27:38 <roshi> I'll note the same reasoning from the last bug on this one
17:27:41 <roshi> and we can move on
17:27:54 <jkurik> I already started with some, but will need more time to check all of it
17:27:56 <roshi> anybody find anything else broken in the past 24 hours that needs discussion?
17:27:59 <sgallagh> Oddly, that schedule has the Final wallpaper and Alpha wallpaper dates on the same day
17:28:11 <sgallagh> roshi: Besides the process?
17:28:44 <nirik> roshi: https://bugzilla.redhat.com/show_bug.cgi?id=1250724 is still listed as proposed?
17:28:48 <nirik> otherwise, nope.
17:29:21 <roshi> nirik: I've updated those bugs since the meeting started
17:29:27 <roshi> takes a bit for the list to be updated
17:29:34 <adamw> sigh, thought this was in a half hour.
17:29:35 <nirik> ah, ok, blockerbugs hasn't synced. no worries.
17:29:35 <mattdm> #action jkurik to fix the schedule :)
17:29:45 <roshi> the dogtag one was rejected yesterday
17:30:58 <nirik> adamw: now you can blame everyone else for alpha. ;)
17:31:03 <sgallagh> Well, I'd still kind of like to see that tomcatjss package pushed stable in time for Alpha
17:31:09 <adamw> nirik: already planning to!
17:31:10 <sgallagh> It's got the necessary karma
17:31:29 <adamw> we can vote it as FE if you like, then. +1, whatever.
17:31:53 <nirik> we should be able to get it in for alpha.
17:32:03 <nirik> we need to cut the release and then we can do stable pushes again.
17:32:07 <sgallagh> nirik: Thanks.
17:32:21 <adamw> oh, 0-day? sure.
17:32:29 <sgallagh> adamw: I don't think it needs the FE, if there's an unfreeze in time for 0-day
17:33:35 <roshi> 0-day makes sense to me
17:33:50 <nirik> we shouldn't push it before that, would mean we would/should respin media with it...
17:34:18 <adamw> right.
17:34:53 <roshi> jkurik: I think it's back to you now
17:35:11 <jkurik> roshi: ok, thanks
17:35:20 <jkurik> #topic Test Matrices coverage
17:35:30 <jkurik> #link https://fedoraproject.org/wiki/Test_Results:Fedora_23_Alpha_RC2_Summary
17:36:05 <jkurik> Shall we go through the it ?
17:36:34 * nirik should put his xfce testing on there somewhere
17:37:16 <adamw> see also https://www.happyassassin.net/testcase_stats/23/
17:37:29 <adamw> RC1 and RC2 were very similar, so i'd say we can take RC1 tests as valid for RC2 in most cases.
17:37:37 <roshi> I feel like coverage is decent - only missing a few tests for alpha
17:37:40 <sgallagh> Just to note: Server didn't see any changes between RC1 and RC2, so I only did spot checks on RC2.
17:37:47 <roshi> but nothign sticks out as particularly explody
17:37:53 <sgallagh> Minus an SELinux patch
17:38:23 <adamw> we're missing fileconflicts, i can run that.
17:38:49 <adamw> 'generic netinst' is expected to be missing for tcs/rcs as that image doesn't exist, so that's fine.
17:39:13 <adamw> there's good old 'install to SAS', which i'm now leaving on there as a brown M&Ms thing.
17:39:49 <adamw> we're missing release blocking desktop tests for ARM, pwhalen are you there?
17:40:17 <pwhalen> There is an issue with KDE on at least some arm hw platforms, we're still investigating it, but we dont think that its a blocker
17:40:19 <adamw> or anyone else with hardware that can actually run 23 with graphics?
17:40:33 <adamw> pwhalen: what's the issue? the requirements for alpha are only 'can run a browser and a terminal'.
17:40:38 * nirik has a BBB he keeps meaning to bring back up
17:41:05 <pwhalen> black screen with a 'x' cursor after install, no sddm
17:41:29 <adamw> oh, still that? fun. it sounds...bad.
17:41:42 <jkurik> Bug 1250409
17:41:51 <nirik> .bug 1250409
17:41:54 <zodbot> nirik: Bug 1250409 Graphical initial setup fails to start on KDE - https://bugzilla.redhat.com/1250409
17:42:06 <pwhalen> adamw, we're not sure. there is an underlying kernel issue there too, which could affect it. we have someone looking at that now
17:42:47 <nirik> so thats only initial-setup, if you make a user in anaconda you are ok?
17:43:07 <adamw> nirik: i don't think we're talking about that bug here.
17:43:09 <pwhalen> this is after initial0setup
17:43:28 <pwhalen> initial setup is fine, does either tui or gui depending on who wins
17:43:33 <nirik> ok.
17:43:49 <dgilmore> I think as long as it runs and you can create a user and set root password etc it is okay
17:44:06 <sgallagh> pwhalen: Is there a BZ for this?
17:44:33 <pwhalen> https://bugzilla.redhat.com/show_bug.cgi?id=1251254
17:45:19 <nirik> sig=11. whee
17:45:48 <adamw> pwhalen: has anyone actually successfully run the image and seen a desktop?
17:45:55 <adamw> because if not, that sounds pretty blocker to me.
17:46:24 * nirik sighs.
17:46:24 <pwhalen> i am not aware of anyone being able to, nor of anyone else trying
17:46:28 <dgilmore> adamw: going to test now
17:46:42 * nirik goes to grab the BBB
17:46:44 <sgallagh> /me looks for that whiskey bottle
17:47:11 <adamw> pwhalen: awesome.
17:47:14 <pwhalen> nirik, bbb has an mmc issue. we're also working on that
17:47:19 <pbrobinson> sgallagh: please don't hit me with it, I don't like to waste good alcohol
17:48:02 <pbrobinson> adamw: I've had gnome and xfce on a couple of devices, haven't had time to test KDE myself
17:48:15 <adamw> pbrobinson: can you boot the 23 alpha KDE image on one of them?
17:48:20 <sgallagh> pbrobinson: I specified "empty" the first time I mentioned it.
17:48:38 <pbrobinson> adamw: not quickly
17:48:51 * adamw tried to do this yesterday and found none of his three ARM devices is actually viable for testing.
17:49:12 <pwhalen> adamw, we'll fix that next week
17:49:33 <pwhalen> we've also got some hw to give to a few lucky kde devs.
17:49:39 <pbrobinson> adamw: what 3 arm devices do you have?
17:49:56 * roshi has a BBB here
17:50:04 <roshi> should I find the cables and stuff?
17:50:33 <pbrobinson> roshi: not for BBB, it's got issues that I'm trying to fix ATM
17:50:39 <roshi> kk
17:50:45 <pwhalen> roshi, for beta that will help. there is an issue with external mmc on bbb, would need to dd to the internal mmc
17:50:49 <roshi> aside from an rpi - that's all I have
17:51:46 <pbrobinson> and KDE won't fit on internal mmc
17:52:04 * nirik gets back with his BBB and reads backscroll. dho.
17:52:12 <roshi> heh
17:52:24 <nirik> I can try a pxe install to a highbank device if it would help?
17:52:24 <adamw> pbrobinson: a cubox, a trimslice, and a BBB
17:52:48 <nirik> but I guess not, since you want to test the kde image.
17:53:04 <pbrobinson> adamw: first two might be OK, I don't know the current reqs for KDE in terms of GPU though
17:53:42 <pwhalen> pbrobinson, i think he needs a fw upgrade on the TS
17:53:55 <pwhalen> bringing my cable for that
17:54:13 <adamw> pbrobinson: there's no indication in the wiki that there's any official support for the cubox. my trimslice just sits at a black screen eternally when i try and boot it, apparently it can't output firmware or boot progress screens over HDMI or some crap so it's basically impossible to tell what's going on with it.
17:54:49 <pbrobinson> adamw: oh :(
17:55:15 <pbrobinson> adamw: cuboxi should be there in F-23, we might even soon have full accel graphics for it
17:55:35 <adamw> ok, great - so how do i set up the image for the cubox?
17:56:04 * dgilmore is putting KDE image on sdcard
17:56:15 <dgilmore> thought I had KDE on one but it was Xfce
17:58:57 <adamw> fileconflicts passes, btw.
17:59:33 <sgallagh> ... and there was much rejoicing
18:01:07 <nirik> so now we are just waiting for kde on arm?
18:01:29 <jkurik> nirik: that is my understaning too
18:02:12 <roshi> same here
18:02:42 <jkurik> The next topic is to make Go/No-Decision, so we need to wait to be sure whether we have a blocker or not
18:03:33 <nirik> so, would it be usefull to do a highbank pxe install? if that worked I should be able to run a browser there, but not sure if thats valid for the critera
18:05:02 <pwhalen> nirik, i didnt think it would. the browser could be installed elsewhere I would think. the optional desktops work
18:05:23 <nirik> ok.
18:06:23 <adamw> nirik: i'd take it as a data point.
18:06:34 <adamw> nirik: assuming you'd be testing KDE.
18:06:49 <nirik> well, I'd have to run it in vnc....
18:06:56 <nirik> but I could try that if it's of use
18:06:56 <dgilmore> lets see if X and sddm starts
18:07:24 <adamw> btw, did anyone have an answer for how i test on a cubox? because i'm totally happy to do it if someone tells me the steps to prepare the media.
18:08:20 <pwhalen> adamw, i dont have one yet, sorry. been looking to order
18:09:46 <nirik> pbrobinson: ^
18:10:46 <pbrobinson> adamw: fedora-arm-installer --target=mx6cuboxi --media=DEVICE --image=IMAGE
18:11:47 <pbrobinson> nirik adamw: I can run a browser and a terminal on ARM, I just don't use KDE, not sure if we can sign it off on XFCE or gnome?
18:12:14 <adamw> pbrobinson: not really. we agreed that the blocking desktop for ARM was KDE.
18:12:33 <adamw> this was at flock last year or the year before, i think you were there.
18:13:28 <pbrobinson> adamw: ah, OK, I thought we decided it was XFCE but I don't remember, XFCE is much more widely used and performant IMO
18:14:37 <adamw> pbrobinson: https://meetbot.fedoraproject.org/fedora-meeting/2013-08-12/fedora-qa.2013-08-12-14.31.html/
18:14:41 <adamw> was the follow-up QA meeting
18:15:47 <adamw> https://meetbot.fedoraproject.org/teams/fedora-qa/fedora-qa.2013-08-12-14.31.log.html/
18:16:09 <adamw> <adamw> proposed #agreed release blocking image set for ARM will consist of minimal and KDE images for F20
18:16:14 <adamw> <dgilmore> +1
18:16:18 <adamw> <pbrobinson> +1
18:17:29 <pbrobinson> adamw: 2013 seems a long time ago :)
18:19:13 * nirik is doing a f23alpharc2 pxe install on a highbank soc
18:19:35 <nirik> and... bzzzzzzzzzzzt. no go
18:20:11 <nirik> http://paste.fedoraproject.org/252801/89716001/
18:20:13 <sgallagh> nirik: The install failed or the boot failed?
18:20:25 <adamw> pbrobinson: welp, no-one ever proposed changing it...
18:20:29 <nirik> boot worked, loaded kickstart and boom
18:21:31 <pwhalen> adamw, KDE has become more resource intensive. perhaps we should consider it
18:21:46 <nirik> pwhalen: with the move to 5 you mean?
18:22:19 <pbrobinson> nirik: yes
18:22:34 <pwhalen> nirik, that is the underlying kernel bug. doesnt always happen, i just provisioned a system with 23alpharc2 to look at it. pbrobinson has also been working with upstream to isolate it
18:22:37 <pbrobinson> nirik: I'm not even sure if it's like gnome now and needs 3D
18:22:37 <adamw> hum, apparently cubox doesn't boot from usb or something. /me writes again to a microSD.
18:22:39 <pwhalen> nirik, right
18:22:54 <nirik> ok, fair.
18:23:02 * nirik can try again for grins
18:23:10 <adamw> so, wait, there's a known kernel bug which causes ARM systems to just crash at random?
18:23:23 <pbrobinson> nirik: is it this bug? https://bugzilla.redhat.com/show_bug.cgi?id=1250613
18:23:34 <pbrobinson> adamw: some systems, and it's been quite random
18:23:36 <adamw> would we be considering releasing if there was a known kernel bug which caused x86_64 systems to just crash at random?
18:23:51 <roshi> probably not
18:23:56 <pwhalen> in most cases, the system remains usable.
18:23:59 <nirik> pbrobinson: looks similar at least
18:24:13 <sgallagh> adamw: We have done so on many occasions...
18:24:16 <pwhalen> installs complete, but it can take longer
18:24:20 <adamw> sgallagh: I mean, *all* x86_64 systems.
18:24:22 <sgallagh> (Usually related to uncommon hardware)
18:24:25 <dgilmore> kde5 requires working 3d acceleration same as gnome
18:24:36 <dgilmore> we do not quite have that
18:24:39 <pbrobinson> adamw: this isn't all systems
18:24:45 <sgallagh> Which means that the KDE criterion for ARM is basically impossible to meet
18:24:55 <adamw> pbrobinson: which ones aren't affected?
18:24:58 <pbrobinson> adamw: and we don't block x86 on specific HW bug
18:25:01 <nirik> :( and of course we are just finding that out now. ;(
18:25:08 <adamw> sgallagh: well, it should presumably run with emulation.
18:25:20 <adamw> but yes, if what people want is for KDE to not be the blocking desktop for ARM, the ideal time to decide this is not the go/no-go meeting.
18:25:23 <nirik> and in fact, it worked fine on another boot (so far) it's installing away
18:25:27 <pbrobinson> adamw: BBB on mmc, Mirabox, a number of allwinner systems
18:25:29 <nirik> adamw: quite
18:25:59 <kinokoio> there are as much KDE users as there are GNOME users
18:26:12 <adamw> kinokoio: we're talking specifically about ARM, here
18:26:13 <pwhalen> not on arm. in fact i am not sure anyone uses kde.
18:26:54 <sgallagh> OK, rdieter tells me in #fedora-kde that there's no real emulation mode
18:27:04 <sgallagh> "llvmpipe theoretically works for some apps, but not everything"
18:27:39 <pbrobinson> sgallagh: OK, so it does need 3D which means it's not really a viable desktop for ARM at the moment
18:27:54 <sgallagh> That's what I'm hearing from rdieter.
18:28:04 * nirik face palms.
18:28:07 <adamw> doesn't necessarily explain why even SDDM doesn't start, but what the hell.
18:28:14 <pbrobinson> it might be on tegra RSN but not for alpha
18:28:42 <nirik> ok, so, slip? switch blocking to Xfce? demote arm to secondary again? drink?
18:28:46 <pbrobinson> adamw: if it's expecting specific GPU features and not getting them it would
18:28:52 <roshi> tbh, I always wondered why a lighter weight DE wasn't the default for arm
18:28:57 <sgallagh> nirik: Definitely drink
18:29:03 * pbrobinson already is
18:29:10 <sgallagh> roshi: Purely so we didn't add a *third* blocking desktop
18:29:18 <roshi> ah
18:29:21 <pwhalen> nirik, id like to see a light weight desktop for arm. i think the rational was not to add another for PA
18:29:23 <pwhalen> right
18:29:26 <roshi> what about the "A DE has to work"
18:29:31 <adamw> well, slipping makes fairly little sense if the reason for slipping is that KDE doesn't work and there's no realistic prospect of making KDE work.
18:29:36 <roshi> then we can fix the least broken one when the time comes :p
18:29:37 * roshi ducks
18:29:50 <sgallagh> (02:29:01 PM) rdieter: sgallagh: *if* we choose to block, we'll block for quite awhile... I think it's fixable (building some/all of the stack to support egl instead)
18:29:51 <sgallagh> (02:29:33 PM) rdieter: So... my opinion: probably not worth blocking
18:29:51 <pwhalen> adamw, or anyone who uses it, save me checking that it works.
18:29:51 <pbrobinson> adamw: agreed
18:30:25 <nirik> ok, so do we know if any other desktops work/pass this?
18:30:29 <pbrobinson> OK so do we sign off XFCE and move on?
18:30:36 <pwhalen> mate, xfce and lxde all work
18:30:39 <adamw> pbrobinson: on a practical level, fine.
18:31:00 <adamw> on an organizational level, i'm gonna say personally, this crapola seriously decreases my confidence in ARM as a primary arch from a release standpoint
18:31:35 <adamw> why is this happening *now*? i mean, everyone knows how the release process works, right? if any more crap like this comes up i'd be inclined to talk about ways we can decrease ARM's prominence when it comes to releases
18:31:41 <roshi> at the very least, we need more people with h/w to test it
18:32:10 <adamw> there are other meanings to primary arch vs. secondary arch, but if we don't even notice until go/no-go that the supposed release blocking desktop can't possibly work, then things clearly aren't going right
18:32:15 <pwhalen> i could definitely use some help testing.
18:32:24 <pbrobinson> adamw: I've been under so much load I've probably not done the breadth of testing, it ends up being scale
18:32:49 <adamw> testing is part of it, but knowing that you don't want KDE to be the release blocking desktop isn't testing.
18:32:54 <pbrobinson> adamw: and I don't follow all the changes to all the desktops, it's simply not possible to keep up with everything
18:32:55 <nirik> proposal: change arm releasing blocking desktop tests to Xfce for now, -1 blocker the ssdm bug on the basis of it no longer being release blocking, move on for now
18:33:10 <roshi> I can live with that
18:33:15 <sgallagh> as can I
18:33:17 <nirik> lets have a nice discussion of that on list? I don't think we can solve this today here.
18:33:23 <roshi> but +1 to adamw's thoughts
18:33:31 <adamw> yeah, I just wanted to flag up that this is not business as usual.
18:33:49 <roshi> this should have been known long before now and migrated to another DE if that's what the arm folks want
18:34:11 <sgallagh> Didn't F22 ship with Plasma 5?
18:34:11 <pbrobinson> adamw roshi: agreed, I dropped the ball on that one, sorry
18:34:14 <nirik> I think we have been leaning on pwhalen too much to do all arm things qa wise. if arm is really primary we should have many more people testing
18:34:20 <sgallagh> How did *that* work?
18:34:42 <sgallagh> Eh, irrelevant
18:34:48 <pbrobinson> nirik: I agree
18:34:49 <dgilmore> I think we have the same issues in cloud land as well
18:34:53 <roshi> there are only so many cycles in a day pbrobinson
18:34:59 <pwhalen> sgallagh, it worked.. very slowly. but it did work, not sure the change
18:35:06 <roshi> we're getting that fixed in cloud, at least
18:35:10 <nirik> dgilmore: yeah, althought there we didn't have images even to test for a while
18:35:13 * roshi is pushing hard on the test front
18:35:38 <adamw> nirik: the thing is, when i want to do x86_64 testing i do a 'dd' and stick the stick in a machine and boot it up
18:35:52 <dgilmore> nirik: right, but they could work on fixing that
18:35:55 <adamw> when i want to do ARM testing i...go read the wiki for some exotic instructions which always seem to be out of date then find none of it seems to work
18:35:58 <roshi> true, cloud and arm are more setup for sure
18:36:06 <dgilmore> anyway we will not solve the world's problems here
18:36:11 <adamw> not blaming anyone, but it just seems like it's always difficult to actually get the point where you *do some testing*
18:36:11 <nirik> adamw: yeah, thats definitely an issue too.
18:36:37 <adamw> seems like every time i say 'oh hey i'll go do some ARM testing' i wind up surrounded by wiki pages, cables, google search results and whiskey bottles, and with no actual testing happening.
18:36:43 <sgallagh> /me wonders if we could leverage Beaker here somehow
18:36:49 <pwhalen> adamw, that shouldnt be the case. ping me
18:37:02 <pbrobinson> adamw: I don't think that's particularly fair, fedora-arm-installer has been the mechanism for a few releases now
18:37:02 <roshi> or simplify testing in virt
18:37:09 <mattdm> pwhalen wants some of adamw's whiskey :)
18:37:19 * pbrobinson needs a lot
18:37:30 <pwhalen> if the wikis out of date, we can fix it. i try to stay on it
18:37:40 <adamw> pwhalen: well, it doesn't list cubox at all, for instance
18:37:51 <jkurik> ok, so how to deal with it atm ? Wave the bug for now and change the KDE on ARM criterion to something lighter ?
18:38:02 <pwhalen> adamw, largely because i dont have it myself.
18:38:06 <adamw> jkurik: i think we mostly all agreed to switch it to be Xfce for now.
18:38:09 <roshi> that seems to be the call right now jkurik
18:38:20 <pbrobinson> adamw: cuboxi support landed in u-boot only a few weeks ago
18:38:40 <nirik> anyone object to the proposal? votes?
18:38:46 <nirik> proposal: change arm releasing blocking desktop tests to Xfce for now, -1 blocker the ssdm bug on the basis of it no longer being release blocking, move on for now
18:38:53 <sgallagh> nirik: +1
18:38:53 <pwhalen> +1
18:38:57 <jkurik> +1
18:38:59 <roshi> +1
18:39:29 <adamw> +1
18:39:55 <jkurik> #agreed change arm releasing blocking desktop tests to Xfce for now, -1 blocker the ssdm bug on the basis of it no longer being release blocking, move on for now
18:40:05 <mattdm> (Just to be clear, Xfce wasn't previously release-blocking anywhere, right? So that's its own potential excitement.)
18:40:10 <adamw> mattdm: right.
18:40:14 <sgallagh> yes
18:40:17 <adamw> but hey, nirik's the maintainer, you're good for it, right?
18:40:35 <nirik> sure. I have tons of time to work on it. ;)
18:40:36 <pwhalen> nirik, i will bribe you appropriately.
18:40:40 * nirik kids
18:40:54 <jkurik> moving on ...
18:40:56 <nirik> anyhow if the arm folks want a different one or none, thats up to them to change.
18:40:59 <jkurik> #topic Go/No-Go decision
18:41:00 <sgallagh> /me is definitely bringing whiskey to Flock
18:41:03 <nirik> but soon.
18:41:30 <sgallagh> So, now that we have lowered the bar to the point where we can step over it... Go?
18:41:33 <pwhalen> nirik, thank you, we will discuss it
18:41:34 <Southern_Gentlem> sgallagh, might be cheaper to buy it there
18:41:53 <nirik> sgallagh: indeed. go before we trip over the bar.
18:41:55 <jkurik> so we waived the KDE on ARM; we waived the wallpapers; anything else what might blocks ?
18:41:56 <sgallagh> Southern_Gentlem: Well, that's kind of what I meant. Acquire it and bring it to the hotel/venue
18:41:59 <pbrobinson> sgallagh: I'll have a litre of scotch
18:42:16 <sgallagh> pbrobinson: I call that an "appetizer" after this week...
18:42:21 <adamw> jkurik: hell, let's just buy  some sharks, slap on a 'Fedora 23 Alpha' label and set them free on a beach somewhere
18:42:32 <pbrobinson> sgallagh: pussy ;-)
18:42:55 <pbrobinson> sgallagh: but this week has been hell!
18:43:14 <adamw> Phoronix can run the photos with the headline 'Fedora 23 Alpha released, several dead'
18:43:29 <roshi> heh
18:43:35 <sgallagh> adamw: "Survivors envy the dead"
18:43:43 * dgilmore hides behind adamw
18:43:45 <roshi> where does one go to purchase live sharks?
18:43:55 <roshi> that'd be a TIL I'd be proud of
18:43:55 <adamw> Sharks R Us
18:43:57 <roshi> ;p
18:44:05 <sgallagh> roshi: https://duckduckgo.com/?q=buy+live+sharks
18:44:09 <jkurik> roshi: you need to hunt some
18:44:12 <sgallagh> Err, http://www.sharksupply.com/
18:44:16 <pbrobinson> adamw: s/Phoronix/Moronix
18:44:21 <sgallagh> This was the first hit. Holy crap
18:44:24 <tflink> roshi: it's really hard, you may need to settle for agitated sea bass
18:44:25 <adamw> sgallagh: ah, once again life beats satire.
18:44:50 <sgallagh> tflink: Are they ill-tempered?
18:44:58 <tflink> did i get my quote wrong?
18:45:21 <tflink> sgallagh:  both agitated and ill-tempered
18:46:03 <sgallagh> OK, back to the topic at hand
18:46:15 <jkurik> proposal #agreed  Fedora 23 Alpha RC2 status is GO by Release Engineering, QA and Development
18:46:22 <roshi> ack
18:46:24 <jkurik> ack
18:46:31 <sgallagh> ack
18:46:48 <nirik> ack
18:46:51 * adamw determinedly doesn't notice the major firefox security vulnerability we're shipping.
18:46:59 <adamw> QA acks per the tattered remains of our policy.
18:47:41 <roshi> pretty much
18:47:41 <mattdm> adamw++
18:47:41 <zodbot> mattdm: Karma for adamwill changed to 8:  https://badges.fedoraproject.org/tags/cookie/any
18:47:59 <jkurik> #agreed  Fedora 23 Alpha RC2 status is GO by Release Engineering, QA and Development
18:48:12 <roshi> alright, see you all down at the pub
18:48:15 <jkurik> #action jkurik to announce the GO decision
18:48:19 <dgilmore> Releng says go
18:48:46 <dgilmore> jkurik: you are supposed to get votes from all three teams
18:48:51 <jkurik> dgilmore: sorry
18:48:53 <adamw> hey look a t that, retroactive agreement
18:49:02 <adamw> dgilmore: nirik did say ack. :)
18:49:18 <dgilmore> adamw: he reperesnts engineering here I think
18:49:25 <dgilmore> anyway :P
18:49:27 <dgilmore> whatever
18:49:32 * nirik shrugs. sure, ask everyone, whatever works.
18:49:37 * nirik is down on process right now.
18:50:08 <jkurik> #topic Open floor
18:50:15 <jkurik> anything else ?
18:50:32 <dgilmore> not here
18:51:12 <potty> Good meeting
18:51:12 <sgallagh> FWIW, I was covering for dev, so we had acks from all three groups
18:51:32 <potty> I do not know some things you mention here but it is interesting to learn
18:51:48 <adamw> potty: never take a tour of the sausage factory.
18:51:58 <sgallagh> Purely hypothetically, if I was to arrive at flock with a trunk full of whiskey.. what brand would it be?
18:52:04 <jkurik> sgallagh:  nirik has the power vote from sticker
18:52:13 <roshi> sgallagh: any
18:52:15 <potty> Lol
18:52:16 <adamw> sgallagh: the smooth stuff - the kind where you get your sight back after five days, guaranteed
18:52:42 * tflink is bringing his bottle of fedora qa brand whisky - "freeze exception"
18:52:43 <roshi> ^^ that
18:53:07 <nirik> https://www.thewhiskyexchange.com/P-3525.aspx
18:53:09 <sgallagh> /me will shop around for "process exception", then
18:53:27 <roshi> in the long run it just proved cheaper for QA to distill their own than buy it...even wholesale
18:54:13 <adamw> the project you know as 'taskotron' is in fact just an elaborate cover for our distillery.
18:54:19 <sgallagh> OK, I think everyone is either drunk or punch-drunk at this point. Let's close up shop?
18:54:25 <tflink> adamw: hush, nobody's supposed to know that
18:54:50 <jkurik> ok, sounds like we can end this meeting
18:55:00 <jkurik> last call ....
18:55:17 <mattdm> :)
18:56:04 <jkurik> #endmeeting