env-and-stacks
LOGS
17:00:56 <hhorak> #startmeeting Env and Stacks (2015-05-28)
17:00:56 <zodbot> Meeting started Thu May 28 17:00:56 2015 UTC.  The chair is hhorak. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:56 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
17:01:02 <hhorak> #meetingname env-and-stacks
17:01:02 <zodbot> The meeting name has been set to 'env-and-stacks'
17:01:06 <hhorak> #chair bkabrda hhorak juhp ncoghlan vpavlin sicampbell walters ttomecek phracek
17:01:06 <zodbot> Current chairs: bkabrda hhorak juhp ncoghlan phracek sicampbell ttomecek vpavlin walters
17:01:15 <hhorak> Hey, do we have anybody here today?
17:01:28 <hhorak> #topic greetings..
17:02:47 <vpavlin> Hello
17:03:00 * vpavlin is not really here..
17:03:05 <vpavlin> ;)
17:04:55 <hhorak> vpavlin: the only one and even not here, are we in the correct room?
17:05:21 <hhorak> langdon hides as well I guess :)
17:05:52 <langdon> hhorak, i KNEW i saw a notify.. i couldn't find it.. i still think gnome needs "notification history"
17:06:24 * langdon mutters.. but this wasn't even the right one.. someone pinged me somewhere about packaging web libraries
17:07:06 <vpavlin> langdon: Don't reply to that ping!
17:07:15 <langdon> vpavlin, lol
17:08:15 <hhorak> langdon: I also fight with irc client every day.. going from ethernet to wifi and back is really not working in pidgin..
17:08:23 <hhorak> #topic how to gather feedback from users? who are our users?
17:08:43 <hhorak> langdon: I actually hope you can help us with this ^^ a bit..
17:08:53 <vpavlin> Feedback on what?
17:09:39 <hhorak> #link https://lists.fedoraproject.org/pipermail/env-and-stacks/2015-May/000783.html
17:09:46 <hhorak> vpavlin: ^ read the link there..
17:10:14 <hhorak> (well, it's quite long, but shortly every WG should get feedback from users about...)
17:10:15 * langdon also watching google i/o keynote(s) .. so slow response (potentially)
17:10:36 <hhorak> langdon: ok, np
17:11:51 <hhorak> about the feedback...
17:11:51 <hhorak> 1. Ask the WGs to identify segments of their user population which  may benefit from a modularized approach to OS composition. Please use  the list below to get started. Ask the WGs to reach out to their population segments to get  feedback. Perhaps sending an email to the appropriate mailing list and  holding 2-3 "town hall" meetings (by segment) to gather feedback Provide both the raw feedback and prioritized set of requirements,
17:11:53 * langdon also just rebooted... so waiting for things to start.. following link
17:12:15 <hhorak> 1. Ask the WGs to identify segments of their user population which  may benefit from a modularized approach to OS composition. Please use  the list below to get started.
17:12:15 <hhorak> 2. Ask the WGs to reach out to their population segments to get  feedback. Perhaps sending an email to the appropriate mailing list and  holding 2-3 "town hall" meetings (by segment) to gather feedback
17:12:16 <hhorak> 3. Provide both the raw feedback and prioritized set of requirements, by user segment, to the Objective Team
17:12:24 <hhorak> (hit the enter too quickly)
17:12:26 <langdon> that was a quick read :)
17:13:02 <langdon> so.. hhorak how can i help? recommend survey monkey? ;)
17:14:40 * vpavlin finally read langdon's proposal..
17:15:22 <langdon> vpavlin, dont worry... if you read the comments.. i also get to do a rewrite :)
17:15:47 <langdon> hhorak, vpavlin and, might be relevant... http://1angdon.com/2015/05/28/fedora-moularization-prototypes/
17:16:17 <vpavlin> So do we want feedback from users first or do we want what WGs are able to get from their user base(s)?
17:16:29 <langdon> more posts coming... btw
17:16:58 <langdon> vpavlin, i think poling the wg leadership for the editions might be interesting for e&s... at least..
17:17:32 <vpavlin> I mean..do we want to approach users directly, or rather do that through other WGs?
17:17:53 * vpavlin thinks it could be better through WGs
17:18:47 <langdon> vpavlin, i guess that is what i was trying to say.. "who are e&s users?" ...  i would argue "base" & editions .. not "humans" :)
17:20:41 <hhorak> langdon: sounds fine to me, but what about python developers for example ... isn't that another group of direct users?
17:20:58 <vpavlin> langdon: Yeah...question of who is the user of e&s is a good one;)
17:21:00 <hhorak> or are they more workstation's users already?
17:21:00 <langdon> hhorak, i don't know? maybe? you guys are in charge :)
17:22:04 <hhorak> looking at the ML statistics.. well, we don't have any users :)
17:22:39 <langdon> hhorak, well.. you have a "user" in a python developer, who, as far as reqs are concerned, might be the same as a "python deployer" .. so wkstn and server would stake a claim on those users.. and e&s needs to find and deliver the common ground..
17:26:07 <hhorak> also packagers -- just looking at the taskslist, there are few of them connected to fedora packagers work..
17:26:17 * hhorak thinks it might be easier to find out who is not user of e&s
17:27:53 <langdon> so.. when i wrote the proposal.. i was expecting the editions to be doing the bulk of user info gathering.. and orgs like e&s and base to be the ones doing the prototyping and implementing
17:29:44 <hhorak> langdon: makes a bit more sense.. but still it seems to me asking people what they think about "docker images related things", "non-rpm content" ... is something no other edition will do..
17:30:37 <langdon> hhorak, perhaps..
17:31:08 <langdon> hhorak, what if you created a list of qs you wanted all editions to ask.. then ask them to include your qs in their "surveys" (or whatever)
17:32:34 <hhorak> langdon: yeah, and create one common survey if the question is relevant for more of them..
17:33:32 <langdon> hhorak, ohh.. i guess i was thinking it was "all one list".. that you would ask of all the editions' users
17:35:21 <hhorak> langdon: oh, I see.
17:36:44 <hhorak> #action hhorak to initiate a list of questions our WG want all editions to ask.. and will share a link to some collaborative tool..
17:38:04 <hhorak> #topic Council Engineering update
17:38:11 <hhorak> #link https://lists.fedoraproject.org/pipermail/env-and-stacks/2015-May/000786.html
17:40:10 <hhorak> well, this means to me we should prioritize few items from the whole task list and set a goal for F23/F24 based on it..
17:41:01 <hhorak> since bkabrda is not here, I'd mention the devpi pilot to be available :)
17:42:56 <hhorak> the playground repo is also quite close to be finished.. and dockah dockah dockah can't be missing there, right?
17:43:54 <hhorak> any ideas about what should be prioritize more?
17:45:41 <langdon> i think playground... docker has one .. sorta.. but playground is "unique" to fedora
17:48:07 <hhorak> langdon: I try to think of what you meant by that but fail :)
17:49:24 <langdon> hhorak, "docker hub" is a way to get any sort of docker container.. there isn't really anything like that for rpm..
17:49:45 <langdon> so.. although i wouldn't recommend docker hub as a way to get things for prod.. it does work..
17:51:06 <vpavlin> langdon: I'd say copr is our Docker Hub, no?
17:51:15 <hhorak> langdon: ah, so it was like we have tooling for docker -- the hub.. right?
17:52:18 <vpavlin> hhorak: I think langdon tries to compare docker image == rpm, dokcer hub == ????
17:53:56 <bowlofeggs> langdon: fwiw, http://pulpproject.org can be used to host Yum repos, docker repos ("docker hubs"), python repos, and more
17:54:08 <langdon> so .. copr is "sorta" like docker hub.. but there is no "get rpm i dont care about which repo it is in"
17:54:12 <langdon> which playground solves
17:54:17 <langdon> and docker hub solves
17:54:37 <langdon> bowlofeggs, yeah.. i think that is how we want to implement a bunch of this stuff..
17:55:29 <vpavlin> langdon: That isn't absolutely true - in Docker Hub you need to know repository/image -> rpm has a very different workflow than Docker but you also need repository/package (if we skip the dnf copr enable... part)
17:55:57 <bowlofeggs> langdon: cool, well if you need anything let me know (i work on pulp ☺)
17:56:10 <bowlofeggs> </self_promoting>
17:56:18 <vpavlin> \m/
17:56:26 <langdon> vpavlin, good point.. maybe we need to modify the dnf plugin to work that way... copr-repo/rpm -> adds the repo -> installs
17:56:30 <langdon> bowlofeggs, :)
17:56:39 <vpavlin> langdon: Maybe;)
17:57:48 <vpavlin> So if you really want "Docker Hub" for rpms, we need to make search better - https://copr.fedoraproject.org/coprs/fulltext/?fulltext=apache
17:57:55 <vpavlin> Doesn't seem very useful:-)
17:58:38 <langdon> so.. the q remains.. focus on playground? or docker for fedora?
17:58:58 <vpavlin> But then it should be simple to just call dnf awesome-copr-auto-enable-install-plugin rhscl/httpd24
17:59:29 <langdon> vpavlin, ack
18:00:43 <vpavlin> anyway, I was not following the previous discussion, so I am not sure what's the original question
18:00:59 <hhorak> it means copr should define which package to install if user asks just for the copr.. since otherwise the user would have to do something like dnf copr-install rhscl/httpd24:httpd24
18:01:11 <vpavlin> #info Think about if it would be possible to auto-enable & install copr repos: dnf awesome-copr-auto-enable-install-plugin rhscl/httpd24
18:01:30 <hhorak> vpavlin: basically what we want to focus on for F23/24 and try harder to deliver
18:01:30 <vpavlin> hhorak: Ah, truth
18:02:22 <hhorak> #idea copr to have option to specify the main package from the copr repo, so it may be installed as soon as user says `dnf copr-install rhscl/httpd24`
18:02:24 <vpavlin> That's the difference:) I sort of assumed automatic resolution of the main package for copr
18:02:37 <hhorak> vpavlin: how would you do it?
18:03:12 <vpavlin> hhorak: I wouldn't ... it was just an assumption in my head ... or simplification
18:03:54 <hhorak> vpavlin: well, if there is a package that is called the same as copr project, then it is probably the main package..
18:03:55 <vpavlin> hhorak: But if the copr maintainer could specify the main package explicitely when creating copr, that might work, I'D say:)
18:04:15 <hhorak> vpavlin: I like that idea..
18:05:26 <hhorak> thinking more about parallel with docker hub -- when there is just one copr with name httpd24, then it may be enough to say `dnf playground install httpd24`
18:05:50 <vpavlin> hhorak: What does playground mean in this context?
18:06:18 <hhorak> the set of copr projects.... the playground repo..
18:06:51 <vpavlin> So..copr is httpd24...and that's also a playground?
18:06:52 <vpavlin> COnfusing..
18:07:25 <hhorak> vpavlin: kind of, copr project may be tagged and be part of playground repository
18:08:06 <hhorak> #idea to prioritize few items from the whole WG's task list and set a concrete goals for F23/F24 based on it..
18:08:07 <langdon> arguably... if we did the playground plugin for dnf.. its source could change over time
18:08:09 <vpavlin> Ok, so httpd24 is a copr that's part of playground httpd24 which consists of a single copr repository?
18:08:50 <hhorak> vpavlin: playground consists of many *nice* copr packages..
18:10:27 <hhorak> langdon: yes, although I don't have idea why the source would change, but that's definitely possible..
18:11:56 <vpavlin> Ok, I think I'll go home
18:12:02 <langdon> hhorak, aka.. (and, i am not 100% up on the plan for playground).. for now, "playground" is launched tomorrow by way of a dnf plugin called "playground" .. which in fact just recognizes a very small list of copr repos.. over time, the list of copr repos grow.. eventually.. the "formal playground repo" comes online...
18:12:07 * vpavlin is still in the office (20:12)
18:12:21 <langdon> but.. it is all transparent to the user.. except "size of offering"
18:14:33 * hhorak thinks we can close anyway...
18:15:38 <hhorak> #idea for now, "playground" is launched tomorrow by way of a dnf plugin called "playground" .. which in fact just recognizes a very small list of copr repos.. over time, the list of copr repos grow.. eventually.. the "formal playground repo" comes online...
18:16:42 <hhorak> vpavlin: langdon: thanks guys for sharing the ideas!
18:16:54 <vpavlin> hhorak: Bye!
18:16:54 <langdon> hhorak, cool.. thanks for hosting
18:16:59 <langdon> vpavlin, bye!
18:17:13 <vpavlin> langdon: Good night:-P
18:17:24 * langdon might go take a nap ;)
18:17:42 <vpavlin> langdon: at 2pm? Crazy Americans..
18:17:51 <langdon> vpavlin, "banker" :)
18:17:58 <langdon> just ate lunch... food coma
18:18:05 <vpavlin> aah..makes sense;)
18:18:19 <vpavlin> Then enjoy
18:18:24 <vpavlin> And really - bye!
18:18:37 <hhorak> #action everybody to think about which of the tasks we make goals from for F23/F24
18:18:38 <hhorak> #action everybody to think about and write up questions that we want to ask users of editions
18:18:46 <hhorak> (a small home work ^ ) :)
18:19:12 <hhorak> langdon: vpavlin: good night both! :)
18:19:16 <hhorak> #endmeeting