env-and-stacks
LOGS
18:04:57 <hhorak> #startmeeting Env and Stacks (2015-03-05)
18:04:57 <zodbot> Meeting started Thu Mar  5 18:04:57 2015 UTC.  The chair is hhorak. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:04:57 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
18:05:04 <hhorak> #meetingname env-and-stacks
18:05:04 <zodbot> The meeting name has been set to 'env-and-stacks'
18:05:08 <hhorak> #chair bkabrda hhorak juhp ncoghlan vpavlin sicampbell walters ttomecek phracek
18:05:08 <zodbot> Current chairs: bkabrda hhorak juhp ncoghlan phracek sicampbell ttomecek vpavlin walters
18:05:19 <vpavlin> hhorak: yeah, we hoped we will sneak out before you appear;)
18:05:49 <hhorak> vpavlin: and I'd risk my driving license for nothing :)
18:06:07 * vpavlin nods =-O
18:06:21 <hhorak> #topic Dockerfiles recommended tips, dockerlint and WebUI
18:06:21 <walters> heh
18:06:51 <vpavlin> phracek: once more - thanks for kicking this off:)
18:07:11 <phracek> I hope that we are going to do it.
18:07:30 <hhorak> phracek: of course we are :)
18:07:31 <phracek> We need to focus developer or beginners to use Fedora as docker main system:)
18:09:21 <hhorak> about the dockerfile guidelines/best practices ... before I forget, langdon point us to https://github.com/redhataccess/dockerfile_lint and that it would be good idea to keep this tool together with guidelines...
18:09:36 <hhorak> or in other words implement the guidelines in the dockerfile_lint
18:09:41 <hhorak> which makes sense to me
18:10:36 <phracek> Yes sure. We need to create "fantastic" tool for checking docker files.
18:11:16 <vpavlin> hhorak: any idea if there already has been an attempt to run it in Fedora infra?
18:11:56 * hhorak doesn't know
18:12:12 <hhorak> even openshift would be fine for beginning
18:12:25 <vpavlin> hhorak: what do you mean?
18:12:29 <walters> running it on https://github.com/fedora-cloud/Fedora-Dockerfiles ?  Or running it as a web service?
18:12:41 <vpavlin> walters: as a service
18:12:48 <phracek> walters: I would prefer as a service
18:12:58 <walters> makes sense
18:13:03 <vpavlin> but I have not idea about the first either:)
18:13:28 <phracek> I would like to create a wiki page with stuff about docker files etc.
18:13:43 <phracek> And there could be a link to a service.
18:13:44 <hhorak> vpavlin: I meant run it dirty and quickly at dockerfilelint-user.rhcloud.com
18:14:03 <hhorak> just for the beginning, before it is ready in fedora infra
18:14:17 <vpavlin> I have seen that just once and it is some time since then..but it also had a web UI so it could be easily integrated to that "docker.fedoraproject.org" website...
18:14:21 <hhorak> it's simple nodejs app, so it could work fine
18:14:34 <vpavlin> hhorak: sure
18:15:13 <hhorak> #info dockerfile_lint and dockerfile packaging guidelines make sense to be kept together
18:15:13 <hhorak> #link https://github.com/redhataccess/dockerfile_lint
18:16:07 <phracek> I have a question.
18:16:08 <hhorak> #idea run dockerfile_lint somewhere publically (fedora infra or rhcloud until it is ready in fedora infra)
18:16:32 <phracek> How to keep them together?
18:16:57 <phracek> All information in one webside?
18:17:50 <phracek> Like I mentioned in mailling list?
18:18:13 <langdon> i want to say that the existing running linter as a service is running on openshift enterprise now
18:18:32 <vpavlin> langdon: So do you think we should just use that one?
18:18:55 <langdon> vpavlin, no.. just that standing it up should be pretty easy
18:19:03 <hhorak> phracek: I had some vague idea about having both in one git... every guideline or best practice would have some ID and those IDs would be then used in the tool.. so every user could easily find why dockerfile_lint reports such an error and a link to the guideline would be provided..
18:19:06 <langdon> vpavlin, the existing one is inside rht-portal
18:19:08 <vpavlin> langdon: I thought so...
18:20:03 * phracek is thinking
18:20:53 <vpavlin> hhorak: I am a bit confused - are we talking about guildlines in a form of text or the linter rulse?
18:20:55 <vpavlin> rules?
18:21:11 <phracek> hhorak: I see. the tool will refer to the errors or guidelines. Realy good approach.
18:21:13 <hhorak> vpavlin: we need both, right?
18:21:28 <vpavlin> hhorak: I think so..
18:22:26 <hhorak> vpavlin: well, that's a good question actually.. what if the guidelines with all comments/description/reasoning would be in the tool...
18:23:00 <hhorak> the configuration is yaml, so it could be done imho
18:23:06 <phracek> I think that some of the guidelines can be in the tool.
18:23:17 <vpavlin> hhorak: As long as we cen "extract" them in a form of website or whatever so that you can easily search through it..I am fine with that
18:23:24 <phracek> But huge description can be in GIT, though.
18:24:15 <phracek> It depends whether user who will use that tool will have access to Internet.
18:24:29 <phracek> If yes, then there could be a direct link to GitHub.
18:24:40 <hhorak> phracek: it reminds me preupgrade assistant a bit :) we also have checking, error reporting and quite a lot of other text there.. and it seems to work fine.. :)
18:25:13 <phracek> Problems and GitHub should be well designed otherwise we could be on wrong way.
18:25:34 <hhorak> phracek: or if everything is in yaml, it could be always extracted to be accessible offline as well.
18:26:07 <vpavlin> phracek: The dockerfile_lint tool is a web service...you have to have access to internet to use it...(until somebody package in a docker image...)
18:26:13 <phracek> Langdon is here and therefore I am not worried.
18:26:41 <phracek> vpavlin: +1. I have been lost;)
18:27:22 <phracek> I would like to discuss If a web service is going to be in docker.fedoraproject.org?
18:27:31 <phracek> How does it look like this page?
18:28:05 <phracek> Basic description of docker, How to install on fedora, Basic commands?
18:28:10 <phracek> If so then ok.
18:29:14 <phracek> Does it make sense to port dockerfile_lint also as CLI interface?
18:29:20 <vpavlin> Content wise..I'd like to have really simple "how to install docker" and "how to run your first container" sections...then probably links hub and then the dockerfile_lint tool
18:29:45 * langdon on another call too .. so laggy
18:30:03 * phracek have to leave after 15 minutes. I have to care about kids.
18:30:14 <hhorak> phracek: I'd try to rephrase langdon's idea, or at least how I interpreted him for my satisfaction :) upstream dockerfile_lint would include more modules -- some general one, something for fedora, then some specialities for RH...
18:30:31 <hhorak> so there may be more instances running in the end, but with one common upstream...
18:30:52 <langdon> hhorak, yes
18:30:55 * vpavlin nods
18:30:57 <phracek> Well, It seems that I have to read it carefully, firstly
18:31:03 <langdon> hhorak, and.. not all instances would support all rules
18:31:09 <phracek> langdon: thanks
18:31:31 <langdon> but.. that isn't to say there isn't "docs" as well.. howto-use-docker-on-fedora, why-to-container, etc...
18:32:06 <vpavlin> langdon: Just that quite a lot of this is already part of Project Atomic
18:32:09 <hhorak> so one instance could also be part of docker.fedoraproject.org... next to other stuff...
18:32:39 <hhorak> vpavlin: that's probably why many people suggested to move the dockerfile_lint under project atomic as well :)
18:32:56 <hhorak> which seems reasonably imho
18:33:07 <vpavlin> Yes..that's why I'd like to see this site as a links hub
18:33:34 <langdon> so.. i want to move the docker-lint project under projectatomic.. but i need to get the owner(s) to agree
18:33:58 <langdon> i have an email in to them.. but .. today is a bad day to talk to anyone at rht
18:34:23 <jsmith> langdon: Because of the new fiscal year?  Or some other reason?
18:34:32 <phracek> langdon: I know release RHEL-7.1 and RHEL atomic.
18:34:43 <phracek> right?
18:34:49 <phracek> More celebrations?
18:34:52 <langdon> so... i think the "content" (rules and docs) would all live under the project-atomic/linter thingie.. and then docker.f.o or whatever would run an instance
18:35:06 <walters> is docker.fp.org a proposed thing somewhere?  i may have missed it
18:35:11 <langdon> nothing i can officially talk about until the Press release ships :)
18:35:18 * phracek nods
18:35:40 <vpavlin> langdon: you mean this press release;) http://www.redhat.com/en/about/press-releases/red-hat-launches-red-hat-enterprise-linux-7-atomic-host-advances-linux-containers-enterprise
18:35:50 <langdon> vpavlin, lol.. thats the one
18:35:59 <phracek> walters: Currently no. We are just thinking where to place these information.
18:36:08 <langdon> so.. my suspicion is.. we wont make progress on moving things til next week
18:36:43 <vpavlin> walters: nope...it's just an idea at the moment..but as docker has a lot of traction, I don't think it's a blocker
18:36:43 <hhorak> never mind, we may start touching the tool at least :)
18:37:16 <phracek> hhorak: phracek nods
18:37:56 <phracek> Yeah we need to know an interface also for web.
18:38:21 <hhorak> phracek: which interface you mean now?
18:38:41 <hhorak> 469380
18:38:54 <hhorak> ^ sorry, yubikey again :)
18:39:16 * langdon thinks its a good thing there is a "something you know" part ;)
18:39:21 <phracek> It seems that I have lost. How to contact docker_lint? Am I right. Friday is comming:)
18:40:17 <vpavlin> phracek: It's basically a website afaik..
18:41:02 <phracek> vpavlin: Is it the same issue as I have mentioned on mailing list? like create a dockerfile from Web?
18:41:14 <phracek> For that case you need to contact docker-lint.
18:41:45 <phracek> As a web-service, right?
18:42:09 <phracek> If not then today or next week I will need to explain that.
18:42:18 <hhorak> phracek: docker-lint is more for checking the given dockerfile is sane
18:42:39 <hhorak> if that was what you asked about..
18:42:56 <vpavlin> it parses a given Dockerfile an spits out a report based on rules whether or not the Dockerfile is fine
18:43:43 <langdon> phracek, and, arguably.. the how-to-get-started-with-docker might live somewhere else.. i thought we were mostly discussing i-know-docker-but-i-dont-know-if-i-am-doing-it-right
18:43:44 <hhorak> phracek: the tool you talk is about creating the dockerfile using web, right? so such a dockerfile should already by perfect :)
18:44:06 <phracek> I see. and docker_lint is going to be install on docker.f.org. THX
18:44:09 <phracek> to both
18:44:10 <langdon> hhorak, phracek "generating dockerfiles" is hopefully going on dev-assistant roadmap
18:44:38 <phracek> what about something like dockergui.com?
18:44:59 <phracek> There is a page who to generate a docker file from web.
18:45:01 * langdon put it on the roadmap but doesn't know if it will stick :)
18:45:02 <vpavlin> phracek: You have the answer one line above:-)
18:45:41 <phracek> ok.
18:46:00 <langdon> phracek, can you please elaborate on what you mean by "create from web"? do you mean something like yocto? or do you mean "examine this website and gen a dockerfile"? or something else entirely?
18:46:06 <hhorak> langdon: you mean turning whole devassistant into web app? bkabrda is lucky he's not here today :)
18:46:19 <langdon> hhorak, see clarification q :)
18:46:47 <vpavlin> hhorak: no..the tool to generate Dockefiles could be part of DevAss
18:47:04 <vpavlin> We don't need another completely separated tool..we need to integrate:)
18:47:38 <phracek> langdon: I have seen the video from vpavlin where was dome how to generate a Dockerfile from web.
18:47:41 <vpavlin> hhorak: and the idea of moving from desktop ui to web ui with DevAssistant is mine;) (I think it should be a Cockpit module..)
18:47:50 <phracek> But DevAssistant is more suitable.
18:48:10 <phracek> I don't think that DevAssistant is going to be on web.
18:48:10 <langdon> vpavlin, so this is your fault? what demo did you do to gen a dockerfile?
18:48:17 <langdon> :)
18:48:40 <hhorak> vpavlin: nice
18:48:57 <vpavlin> langdon: I'll forward it to you...it's based on dockergui.com (which seems to be pretty much dead) - you met that guy Ben Grissinger last time I was in Westford
18:49:14 <vpavlin> langdon: And sure..all great ideas should be my fault:-P
18:49:20 <langdon> ohh.. re-reading the email thread.. so .. you mean construct a dockefile on the web.. so kinda like yocto..
18:49:24 <langdon> ok.. yeah... i get it
18:49:30 <langdon> the linter does that already
18:49:49 <vpavlin> langdon: really?
18:49:51 <langdon> so.. while it is just supposed to "lint" it also lets you "fix the results"
18:49:55 <langdon> vpavlin, yep
18:50:04 <phracek> sorry guys I really have to leave. Kids are calling.
18:50:12 * vpavlin needs to check it tomorrow..
18:50:16 <phracek> Thanks for great discussion. See you.
18:50:25 <langdon> vpavlin, it is not as pretty as the one from ben.. but it does do the basics
18:50:32 <langdon> phracek, bye!
18:50:36 <hhorak> phracek: thanks, bye
18:50:38 <langdon> phracek, say hi to the kids!
18:52:20 <vpavlin> So...we should assign some work to phracek now..right?
18:52:47 <hhorak> vpavlin: what an evil! ... (but sounds fine to me)
18:54:20 <hhorak> so, a lot of ideas mentioned today, where do we start? :) I'd say looking at the dockerfile_lint to see if it is capable to accommodate all the guidelines or we need to have them beside..
18:55:03 <hhorak> and get more of the rules...
18:55:53 <vpavlin> yup...and checking it's abilities in terms of Dockerfile creation so that we can file some feature requests:)
18:56:54 <hhorak> vpavlin: not sure I'm following now, we said it may fix something, but for creating devassistant will be there...
18:57:14 <vpavlin> langdon said it already does some of it..
18:57:24 <vpavlin> so we should review:)
18:58:11 <hhorak> #action all to look at dockerfile_lint to see if it is capable to accommodate all the guidelines or we need to have them beside; get more of the rules; and checking it's abilities in terms of Dockerfile creation so that we can file some feature requests
18:58:21 <hhorak> vpavlin: all right
18:58:21 <langdon> hhorak, well.. i think DA will do something much more interesting.. the linter just lets you write a dockerfile on the web with a bit of feedback on best practices
18:58:36 <hhorak> langdon: I see
18:58:58 <hhorak> #info DA will do something much more interesting stuff in terms of creating dockerfiles.. the linter just lets you write a dockerfile on the web with a bit of feedback on best practices
18:59:21 * vpavlin likes langdon's confidence..
18:59:46 <vpavlin> ok, I think we should call it a day in 3, 2, 1...
18:59:46 <langdon> vpavlin, what i lack in competence, i make up for in  ... or something like thta
18:59:55 <hhorak> langdon: you said you'd try to convince dockerfile_lint author to move to atomic?
19:00:20 <langdon> hhorak, correct.. well.. via someone else :) .. but yes.. email is sent.. awaiting response
19:01:01 <hhorak> #action langdon to try handle dockerfile_lint moving to project atomic.. somehow...
19:01:08 <hhorak> so are we done then?
19:01:30 <jreznik> you should be :)
19:01:31 * langdon points out that my AIs are very similar to my personality... :)
19:01:51 <vpavlin> Artificial Inteligence?
19:01:56 <jzb> langdon: how so?
19:01:57 <vpavlin> :-P
19:02:15 <jreznik> the readiness meeting follows here...
19:02:15 <langdon> nice!
19:02:25 <langdon> jzb, wishy-washy
19:02:28 <hhorak> #endmeeting