env-and-stacks
LOGS
18:02:53 <hhorak> #startmeeting Env and Stacks (2015-02-19)
18:02:53 <zodbot> Meeting started Thu Feb 19 18:02:53 2015 UTC.  The chair is hhorak. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:02:53 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
18:03:04 <hhorak> #meetingname env-and-stacks
18:03:04 <zodbot> The meeting name has been set to 'env-and-stacks'
18:03:27 <hhorak> Hey, do we have anybody here?
18:03:39 <hhorak> #chair bkabrda hhorak juhp ncoghlan vpavlin sicampbell walters ttomecek phracek
18:03:39 <zodbot> Current chairs: bkabrda hhorak juhp ncoghlan phracek sicampbell ttomecek vpavlin walters
18:03:56 * walters is present; the new time is better for me as well
18:05:56 <hhorak> walters: Hi, yeah, it seems there will be two separate set of people in odd and even weeks.
18:07:03 <hhorak> I'm thinking about moving our meeting to this room every week, since fpc likes to talk longer than 1hour..
18:07:39 <phracek> Yeah, why not. Hopefully the our meeting is going to be shorter and shorter:)
18:08:46 <hhorak> we still have mailing list, that can be used much more
18:09:10 <hhorak> #topic Follow-ups -- any changes from last week?
18:10:08 <hhorak> we talked about the governance charter the last time, do we have anything to change there?
18:10:22 <phracek> from my point of view no. I think that we discussed about goverment and DevPy.
18:11:18 <hhorak> from my PoV just the "Changes the rules" section and state that another re-evaluation will be done after Fedora 22?
18:11:27 <walters> I still can't say I have enough experience/knowledge with alternative approaches to say whether the charter could be improved, but what is there now seems OK
18:14:02 <walters> lw
18:14:18 <hhorak> fine, so I'll just change the very bottom chapter "Changing These Rules"  with somethign like s/21/22/ if nobody protests on ML
18:14:32 <hhorak> anything else?
18:15:06 <hhorak> (not expecting much from devpi since bkabrda and ncoghlan are not here)
18:15:21 <hhorak> #topic Dockerfiles recommended tips
18:15:38 <hhorak> this is actually one topic from the task list
18:15:45 <hhorak> #link https://fedoraproject.org/wiki/Env_and_Stacks/Tasklist
18:15:55 <hhorak> #link https://fedoraproject.org/wiki/User:Hhorak/Draft/task-dockerfile-rules
18:16:17 <hhorak> it still has no 'owner' or anybody who would push on that..
18:16:46 <hhorak> also there may be some changes (some guidelines already existing somewhere?) since we spoke about it the last time
18:17:09 <phracek> I think that vpavlin how has enough experiences could be a owner
18:17:39 <hhorak> phracek: that's nice from you :)
18:17:39 <phracek> But If vpavlin helps me than I can be the owner.
18:18:02 <phracek> hhorak: What is the deadline?
18:18:13 <phracek> Till release date F22?
18:18:54 <hhorak> phracek: I don't think there is really a deadline, but it would be nice to have at least some basic rules before we start to build some layered docker images
18:18:59 <walters> i wonder if marek would be interested in helping migrate some of the content to fedora?
18:19:30 <phracek> But because of I would like to finally work with docker files then I could be the owner.
18:19:54 <phracek> It will make a press to me to learn and work with docker files.
18:20:20 <phracek> Where should be placed this documentation.
18:20:52 <hhorak> walters: marek is someone from RH?
18:21:12 <walters> the author of http://file.rdu.redhat.com/~mgoldman/jboss-docker-docs/best-practice.html so yes =)
18:21:33 <phracek> I spoke with Vasek last time about docker he shown me a wiki page where manipulation was pretty described.
18:22:02 <phracek> Wow. Can we contact him?
18:22:18 <hhorak> phracek: do you mean https://fedoraproject.org/wiki/Docker?
18:22:48 <phracek> hhorak: yes
18:23:06 <hhorak> walters: thanks, I have a feeling we spoke about it once already, so let's talk to him and we'll see.
18:23:27 <hhorak> phracek: can I make an action item for you to get in touch with marek?
18:23:40 <phracek> hhorak: Yes, definitelly.
18:24:10 <hhorak> #action phracek to get in touch with marek, author of JBoss Docker images best practices
18:24:23 <hhorak> awesome, so we can move further
18:24:39 <hhorak> #topic Some info about beaker @ fedoraproject and potential Env&Stack use cases
18:25:16 <hhorak> this was just that I wanted to share few things about beaker project in fedora
18:25:24 <walters> we're missing nick, but he said a QA person would possibly be here?
18:25:28 <hhorak> #link http://beaker.fedoraproject.org/
18:26:45 <hhorak> walters: yeah, that was exactly tflink who I got some summary from
18:27:03 <phracek> This beaker is similar like we are using for RHEL?
18:27:18 <hhorak> phracek: yes, same technology, same use cases
18:27:44 <hhorak> #info The initial use case was to run installer tests in http://beaker.fedoraproject.org/
18:27:54 <hhorak> #link https://bitbucket.org/fedoraqa/fedora-beaker-tests
18:27:54 <phracek> wow, awesome
18:28:31 <hhorak> so, currently it has no fas authentication, but there are plans to have this, so every contributor can log in
18:29:16 <hhorak> there are also some other blockers with LC hostname in log URLs ... whatever it means :)
18:30:18 <hhorak> but generally this system should be used for tasks that shouldn't be run within taskotron itself, so taskotron would probably launch jobs in beaker
18:31:12 <hhorak> as soon as it is ready, some of the RH internal tests can be opened, I've talked to some QE people, that this option is possible
18:31:36 <hhorak> which I find great and very logical -- to catch some issues sooner in the process
18:32:37 <hhorak> but still there will be limited resources, so it won't serve as a cheap server rent service, it will be probably dedicated for tests only
18:33:22 <hhorak> and of course there are limited resources in fedora qe, who lead the effort
18:34:40 <walters> something that's kind of related to this is that docker is a nice way to run tests that require uid 0
18:34:47 <walters> which is not supported by mock
18:34:57 <walters> beaker could enable that too, but it's more heavyweight
18:35:51 <phracek> I think that CI test could be used by beaker and packages testing could be used by mock
18:36:02 <hhorak> walters: yeah, but there are still tasks that require real system, some integration testing, starting services in 'proper' systemd...
18:37:03 <hhorak> the systemd service testing issue is actually even worse in mock, systemd simply doesn't work in chroot
18:38:12 <hhorak> so I still see classic visualization beneficial... but you're right, for many tests docker or mock is fine enough
18:40:40 <hhorak> well, I've nothing else here and I also have no other topic for today
18:40:48 <hhorak> #topic Open Floor
18:40:56 <hhorak> does anybody else have something?
18:43:09 <hhorak> it doesn't seem so.. so I'll close in a minute..
18:43:23 <walters> just a quick note, https://fedoraproject.org/wiki/Changes/RpmOstree was approved
18:43:31 <walters> i'm going to be working on pushing that forward as well as Docker stuff
18:46:24 <walters> that's all i had though
18:47:09 <hhorak> #info RpmOstree change was approved, hooray!
18:47:09 <hhorak> #link https://fedoraproject.org/wiki/Changes/RpmOstree
18:47:21 <hhorak> walters: thanks and congrats :)
18:48:11 <hhorak> so, thank you all (both) for today, take care!
18:48:17 <hhorak> #endmeeting