f21_beta_gono-go_meeting
LOGS
17:00:19 <jreznik> #startmeeting F21 Beta Go/No-Go meeting
17:00:19 <zodbot> Meeting started Thu Oct 23 17:00:19 2014 UTC.  The chair is jreznik. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:19 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
17:00:20 <jreznik> #meetingname F21 Beta Go/No-Go meeting
17:00:20 <zodbot> The meeting name has been set to 'f21_beta_go/no-go_meeting'
17:00:41 <jreznik> Hi all!
17:00:41 <nirik> morning
17:00:43 <jreznik> #topic Roll Call
17:00:57 <jreznik> who's around today?
17:00:59 <sgallagh> .hello sgallagh
17:01:02 <zodbot> sgallagh: sgallagh 'Stephen Gallagher' <sgallagh@redhat.com>
17:01:08 <nirik> .hello kevin
17:01:08 <roshi> .hello roshi
17:01:09 <zodbot> nirik: kevin 'Kevin Fenzi' <kevin@scrye.com>
17:01:12 <zodbot> roshi: roshi 'Mike Ruckman' <mruckman@redhat.com>
17:01:13 <danofsatx> .hello dmossor
17:01:16 <zodbot> danofsatx: dmossor 'Dan Mossor' <danofsatx@gmail.com>
17:01:54 <jreznik> #chair nirik sgallagh roshi adamw
17:01:54 <zodbot> Current chairs: adamw jreznik nirik roshi sgallagh
17:02:38 <jreznik> let's wait a minute and we can start to finish earlier - a lot of stuff to be done, readiness meeting in two hours then...
17:03:00 * danofsatx goes to nuke his lunch
17:03:14 <sgallagh> Nuke it from orbit. It's the only way to be sure.
17:03:28 * adamw is filing the compose request atm
17:04:01 <sgallagh> Do we have a rel-eng representative?
17:04:25 <jreznik> dgilmore, are you around? good point sgallagh
17:05:05 <jreznik> #topic Purpose of this meeting
17:05:25 <jreznik> #info Purpose of this meeting is to see whether or not F21 Beta is ready for shipment, according to the release criteria.
17:05:26 <jreznik> #info This is determined in a few ways:
17:05:28 <jreznik> #info No remaining blocker bugs
17:05:29 <jreznik> #info Release candidate compose is available
17:05:31 <jreznik> #info Test matrices for Beta are fully completed
17:05:59 <jreznik> #topic Current status
17:06:47 <jreznik> #info no RC available for Fedora 21 Beta, RC1 request filed at the moment
17:06:54 <adamw> so we have a problem with ARM
17:07:08 <adamw> beta TC4 ARM images had the generic-release issue and no-one's fixed that that I can see
17:07:20 <adamw> we can either pull in generic-release 21.7 to RC1, or do a quick fix to the kickstarts
17:07:27 <jwb> i think we're also waiting for the workstation tree being dropped per fesco
17:07:38 <adamw> i think changing fedora-arm-base.ks the same way someone changed fedora-live-base.ks would do the job
17:07:42 * nirik saw a commit to do that earlier.
17:07:53 <roshi> and we have no cloud images for TC4
17:07:55 <adamw> nirik: to do which?
17:08:13 <pwhalen> adamw, wouldnt the overall fix, also fix the issue for arm?
17:08:34 <jwb> nirik, ah, indeed
17:08:37 <nirik> adamw: drop workstation tree
17:08:52 <jwb> ok, should be gone in the next compose
17:09:05 <nirik> https://lists.fedoraproject.org/pipermail/rel-eng/2014-October/018625.html
17:09:33 <adamw> pwhalen: i would expect that generic-release 21.7 would avoid the problem, yeah, but we haven't really done a test compose with it included
17:09:42 <adamw> pwhalen: so far the fix for other images was a change to fedora-live-base.ks
17:09:49 <jreznik> #info workstation tree dropped
17:09:51 <adamw> but arm images don't use that kickstart, they start from fedora-arm-base.ks
17:11:12 <sgallagh> I think it would be wiser to pull in generic-release
17:11:17 <adamw> just adding @fedora-release-nonproduct to fedora-arm-base.ks should 'fix' it (or at least behave the same as the lives, we haven't done a full test compose to ensure everything works the way we expect yet)
17:11:18 <jreznik> if we really want to do anything with rc1 this week, less intrusive way is preferred I'd say
17:11:47 <sgallagh> adamw: fedora-arm-base should support products though
17:11:56 <sgallagh> it would be a bad idea to make that non-productized
17:12:00 <pwhalen> adamw, i see. I pinged Peter but he isnt around right now. I can ask if can make that change before the compose, or dgilmore.
17:12:04 <adamw> sgallagh: well, it's the same thing we did in fedora-live-base.ks
17:12:15 <adamw> sgallagh: fedora-workstation-packages drops it again and pulls in the product group instead
17:12:25 <kalev> fedora-live-base.ks is a bit different since it only affects Workstation; other products aren't live-based
17:12:28 <adamw> i can change it if we decide it's the right thing to do, i have commit rights
17:12:39 <pwhalen> cool, ok
17:12:47 <jreznik> sgallagh: is arm planned to be productized - or what products are currently supported on ARM?
17:13:19 <adamw> kalev: afaics only fedora-arm-kde, fedora-arm-lxde, fedora-arm-mate, fedora-arm-minimal, fedora-arm-soas, fedora-arm-workstation and fedora-arm-xfce include fedora-arm-base.ks
17:13:26 <adamw> kalev: unless something else is pulling it in some other way
17:13:46 <kalev> ah, no arm-server or arm-cloud?
17:14:17 <adamw> i don't think we build such things ATM, and if we did, i don't think they'd use fedora-arm-base.ks
17:14:19 <kalev> scary to do these kinds of changes the very last minute, if we botch them we'll definitely miss this week's release
17:14:41 <adamw> well, we have to do something or the ARM images will be generic-ized, which we don't want
17:14:52 <adamw> i guess i'll just throw the change at fedora-arm-base.ks and we can cross our fingers
17:14:57 <Corey84> id be willing to throw another vm up to test arm if need be
17:15:02 <sgallagh> Sorry, urgent phone call. Be back soon
17:15:03 <jreznik> kalev: I'm becoming more inclined to let everything settle down a bit... reading all this last minutes stuff
17:15:38 <Corey84> it has become a case of what is solid and ready hasnt it ?
17:15:54 <adamw> i sent the change, it's done. let's see what happens. :P
17:16:25 <jreznik> :)))
17:16:50 <jreznik> ok, so if there anything now we have to do for RC try?
17:17:03 <pwhalen> adamw, thanks
17:17:04 <kalev> how is arm composed, does it use pungi and friends?
17:17:29 <adamw> jreznik: no, i just need to finish the compose request
17:17:53 <kalev> is it the same system (pungi / anaconda) as is used for DVD and netinstall generation?
17:18:01 <jreznik> adamw: ok
17:18:25 <jreznik> so today we're definitely no-go, let's plan the next steps
17:18:41 <jreznik> I expect everyone agrees with todays no-go
17:18:56 <roshi> yeah
17:19:00 <danofsatx> for the record, on what criteria?
17:19:10 <nirik> we have no rc
17:19:11 <kalev> yes, no-go today, based on no RC being available
17:19:12 <jreznik> danofsatx: no release candidate available
17:19:21 <danofsatx> rgr
17:19:40 <sgallagh> I'm back. Reading scrollback now
17:20:08 <jreznik> #agreed Fedora 21 is No-Go due to no release candidate available as of 2014-10-23
17:20:28 <jreznik> #topic Beta release plan
17:20:48 <jreznik> we have the option to repeat Go/No-Go meeting tomorrow
17:21:13 <jreznik> a) we need RC, b) we need QA coverage and c) bits has to be available for releng tomorrow
17:21:58 <jreznik> looking on the whole effort put into it today, I think we want to try it but waiting for opinions
17:22:15 <pwhalen> kalev, appliance-tools is used for arm images
17:22:37 <sgallagh> I think this is primarily up to QA: are you folks willing and able to validate the RC compose?
17:22:58 <pwhalen> going to be hard for arm validation, looking at 8 hours for the compose to land..
17:23:00 <jreznik> sgallagh: yeah, definitely
17:23:28 <kalev> pwhalen: which arm image do you guys consider release blocking?
17:23:35 <pwhalen> minimal and kde
17:23:59 <adamw> do we want to pull the SDDM CVE fix into RC1?
17:24:15 <adamw> https://bugzilla.redhat.com/show_bug.cgi?id=1149610
17:24:21 <jreznik> what's the severity?
17:24:25 <adamw> local privesc
17:24:36 <adamw> impact=important
17:24:47 <adamw> requires a spin-kickstarts change, unfortunately
17:26:02 <jreznik> what's the minimal impact in criteria?
17:26:19 <adamw> jreznik: it's an FE not blocker
17:26:29 <adamw> just wondering if it's important enough that we should pull it
17:26:34 <nirik> I'd be inclined to say no if we are planning a marathon test session... the less changes the better
17:26:35 <jreznik> aha, sorry, I saw it but...
17:26:54 <adamw> guess people can get the fix with an immediate update
17:27:03 <adamw> there's no impact on live since it has no account security
17:27:09 <jreznik> adamw: well we said from some rh clasification it's blocker, I'm just not sure from which level :)
17:27:30 <adamw> final IIRC
17:27:48 <adamw> https://fedoraproject.org/wiki/Fedora_21_Final_Release_Criteria#Security_bugs
17:27:50 <adamw> so it's a final blocker
17:27:55 <jreznik> ok
17:28:13 <adamw> OK, RC1 request filed
17:28:24 <jreznik> without sddm, right?
17:28:40 <kalev> https://fedorahosted.org/rel-eng/ticket/6010#comment:11
17:29:11 <jreznik> ok
17:29:39 <jreznik> and so there's still the question opened - Go/No-Go 2nd try tomorrow the same time?
17:30:38 <sgallagh> jreznik: +1
17:30:45 <danofsatx> +1
17:30:49 <kalev> maybe we should ask releng folks first what time we'd need to know the Go / No-Go tomorrow so that they wouldnt' have to work over the weekend
17:30:54 <jreznik> adamw, roshi - it's really up to you what QA can make
17:31:02 <adamw> we can try.
17:31:08 <adamw> the test load is rather heavier in 21 than previously.
17:31:26 <adamw> and of course, other teams are supposed to be pitching in
17:31:38 <adamw> server folks should be testing server (sgallagh does, thanks sgallagh), workstation folks testing workstation, etc etc
17:31:44 <jreznik> kalev: it's still in the middle of day in the us
17:31:49 <adamw> hey, we now have a thing which makes it pretty easy to see the test load:
17:31:53 <adamw> https://fedoraproject.org/wiki/Test_Results:Fedora_21_Beta_TC4_Summary?rd=Test_Results:Current_Summary
17:32:00 <pwhalen> love the summary
17:32:17 <adamw> everything listed as Alpha or Beta there (except Security Lab, forget Security Lab) needs running
17:33:00 <adamw> btw, for people who hate editing wiki text to enter results, i wrote a stupid thing that lets you submit results from a console app: https://www.happyassassin.net/wikitcms/
17:33:04 <roshi> I can try for an all nighter once the compose lands
17:33:07 <jreznik> kparal asked in the office for help, so maybe in the morning, if RC would be usable, we can ping all guys who volunteered to help
17:34:38 <jreznik> dgilmore: what's the latest time we have to say go on Friday?
17:36:09 <jreznik> but seems like we have agreement to try it, let's make the timing with Dennis later - I'll send announcement to the list after readiness meeting
17:36:22 <jreznik> for now I'd say the same time as today, may change
17:37:07 <kalev> sure
17:38:15 <sgallagh> ok
17:38:41 <jreznik> #info we will try Go/No-Go #2 tomorrow 2014-10-24, the same time (17:00 UTC) but may change, same channel - jreznik to ask dgilmore and announce it later today
17:38:57 <jreznik> #topic Open floor
17:39:17 <jreznik> btw. thanks for help everyone!
17:40:46 <jreznik> anything else today?
17:41:17 * roshi has nothing
17:42:33 <jreznik> ok, so thanks again, I'll end the meeting soon
17:43:08 <jreznik> just a reminder - readiness meeting later today19:00 utc
17:43:15 <jreznik> #endmeeting