f21_alpha_gono-go_meeting_-_2
LOGS
17:03:46 <jreznik> #startmeeting F21 Alpha Go/No-Go meeting - 2
17:03:46 <zodbot> Meeting started Thu Sep 11 17:03:46 2014 UTC.  The chair is jreznik. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:03:46 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
17:04:04 <jreznik> #meetingname F21 Alpha Go/No-Go meeting - 2
17:04:04 <zodbot> The meeting name has been set to 'f21_alpha_go/no-go_meeting_-_2'
17:04:13 <jreznik> #topic Roll Call
17:04:29 <jreznik> it's going to be a quick one but to make process happy and sync a bit where we are now
17:04:54 <jreznik> #chair sgallagh mattdm adamw dgilmore
17:04:54 <zodbot> Current chairs: adamw dgilmore jreznik mattdm sgallagh
17:05:01 * jsmith is here late
17:06:57 <mattdm> i'm here, by the way :)
17:07:03 <jreznik> let's wait a second
17:07:06 <sgallagh> .hellomynameis sgallagh
17:07:07 <zodbot> sgallagh: sgallagh 'Stephen Gallagher' <sgallagh@redhat.com>
17:07:08 <jreznik> yeah, I see you mattdm :)
17:07:31 * amita is here
17:07:38 <mdolezel> is here
17:07:54 <drago01> .
17:08:03 <jreznik> btw. we can discuss what to do with go/no-go when there's clear no-go - sgallagh proposed it on the devel list and I was thinking about the same
17:08:22 <jreznik> on the other hand, it could be useful even with clear no-go to sync
17:08:35 * adamw hereish
17:08:40 * jsmith likes the idea of syncing up, even with a clear No-Go
17:08:43 <drago01> can we do a shorter slip this time?
17:08:44 <adamw> yeah, we can use it as a sync meeting
17:08:57 * drago01 didn't really get an answer on the list
17:08:58 <sgallagh> jreznik: So agenda: 1) rel-eng update, 2) go/no-go vote, 3) plan for obvious no-go?
17:09:13 <jreznik> sgallagh: yep, give me a sec
17:09:16 <sgallagh> drago01: Let's visit that after the rel-eng update
17:09:21 <drago01> sgallagh: ok
17:09:41 <sgallagh> (I.e. if they say "it's going to take a week", your question is moot :) )
17:09:49 <jreznik> #topic Purpose of this meeting
17:09:50 <jreznik> #info Purpose of this meeting is to see whether or not F21 Alpha is ready for shipment, according to the release criteria.
17:09:52 <jreznik> #info This is determined in a few ways:
17:09:54 <jreznik> #info No remaining blocker bugs
17:09:55 <jreznik> #info Release candidate compose is available
17:09:57 <jreznik> #info Test matrices for Alpha are fully completed
17:09:58 <jreznik> #link http://qa.fedoraproject.org/blockerbugs/milestone/21/alpha/buglist
17:10:00 <jreznik> #link https://fedoraproject.org/wiki/Test_Results:Fedora_21_Alpha_TC6_Install
17:10:01 <jreznik> #link https://fedoraproject.org/wiki/Test_Results:Fedora_21_Alpha_TC6_Base
17:10:03 <jreznik> #link https://fedoraproject.org/wiki/Test_Results:Fedora_21_Alpha_TC6_Desktop
17:10:04 <jreznik> to make process happy :)
17:10:13 <jreznik> #topic Current status
17:10:36 <jreznik> so as you all know, we don't have release candidate and it's prereq for the go decision
17:10:53 <jreznik> there are still a few unresolved blocker bugs - see http://qa.fedoraproject.org/blockerbugs/milestone/21/alpha/buglist
17:12:12 <jreznik> dgilmore: do you want to update us on the status of netinst or should I just copy what you sent on qa channel?
17:13:12 <jreznik> .bug 1134524
17:13:15 <zodbot> jreznik: Bug 1134524 Product-ized network install images do not offer filtered group lists - https://bugzilla.redhat.com/1134524
17:13:56 <sgallagh> Most of the remaining blockers are prepped and just awaiting a new TC7
17:14:17 <adamw> netinst needs a new anaconda build
17:14:18 <dgilmore> jreznik: sure I can
17:14:25 <adamw> i am currently trying to get the necessary patch through review
17:14:47 <jreznik> #info netinst needs a new anaconda build, adamw working to get the necessary patch through review
17:14:53 <dgilmore> we have a fedora-repos update that has a new fedora-repos-anaconda subpackage its been added to anaconda-tools group in comps
17:15:04 <adamw> i was just eyeballing fedora-repos to give it karma, yeah
17:15:13 <dgilmore> im working to sort out some issues with Mirrormanager
17:15:24 <dgilmore> once mm is sorted it should all just work
17:15:27 <jreznik> #info we have a fedora-repos update that has a new fedora-repos-anaconda subpackage its been added to anaconda-tools group in comps
17:15:35 <dgilmore> but we cant test and know for sure until mm is sorted
17:15:41 * sgallagh will look at the fedora-repos update as well
17:16:03 <jreznik> #info dgilmore is working to sort out some issues with Mirrormanager
17:16:23 <adamw> dgilmore: did you update comps to pull fedora-repos-anaconda into the appropriate group?
17:16:24 <dgilmore> the issues are that its not detecting the repos in teh productised tree
17:16:36 <dgilmore> adamw: yes anaconda-tools
17:16:39 <adamw> cool
17:16:54 <adamw> once we get a new anaconda and tc7 we can at least confirm that anaconda is requesting the URL we want it to from MM
17:16:54 <dgilmore> which is things anaconda wants in place but not to have deps on
17:17:01 <jreznik> ok, so we just have to make sure all required bits are in TC7 and then test it with MM update, cool, thanks dgilmore/adamw
17:17:03 <dgilmore> adamw: right
17:17:05 <adamw> from that point on we at least don't need new composes; all the changes will be to MM
17:17:23 <dgilmore> indeed
17:17:24 <roshi> which will be a good thing
17:17:47 <jreznik> give me a sec, I have to move to the adapter, battery is crying
17:17:52 * dgilmore needs to run for a bit
17:18:05 <mattdm> dgilmore: did you get some help with mm?
17:18:42 <dgilmore> mattdm: ive been in communication with Matt Domsch and Patrick has said he will help
17:18:52 <jreznik> great
17:19:36 <drago01> dgilmore: timeframe?
17:19:45 <jreznik> for the other bug - tc7 could fix it, right?I mean 1139015
17:20:36 <sgallagh> .bz 1139015
17:20:44 <sgallagh> .bug 1139015
17:20:49 <zodbot> sgallagh: Bug 1139015 F21 Workstation Alpha TC6 network install fails with crash, hang, reboot or "pane is dead" - caused by anaconda segfault - https://bugzilla.redhat.com/1139015
17:21:04 <sgallagh> Did we ever figure out what caused the truncation?
17:21:22 <sgallagh> But yeah, hopefully it was just a fluke and will work itself out next time.
17:21:27 <sgallagh> (Hooray for heisenbugs)
17:21:29 <adamw> my suggestion for this one is 're-fire with crossed fingers', yeah
17:21:39 <adamw> here's a way to make it sound more professional:
17:22:04 <adamw> maybe the extra size from dep bloat in tc6 caused it somehow and with that fixed it won't happen? :)
17:22:32 <sgallagh> Has Workstation changed their deps for TC7?
17:22:33 <jreznik> scientific explanation, let's hope it will be gone with tc7
17:22:45 <sgallagh> Or are you confusing that with the Server dep bloat related to python-qrcode
17:24:42 <adamw> sgallagh: i thought those deps wound up in workstation too
17:24:47 <adamw> at least the images were the same size
17:25:02 <adamw> don't dissect the handwave, damnit!
17:25:09 <sgallagh> It's possible, but I wouldn't expect it offhand.
17:25:15 <sgallagh> It was mainly the FreeIPA server pulling it in.
17:25:21 * sgallagh checks if anything else depends on it
17:26:23 <adamw> damnit, can't a man wave his hands around here without someone *fact checking*
17:27:05 <sgallagh> adamw: This isn't Fox News :-P
17:27:24 <jreznik> it's usually adamw who's checking everything when others waves hands!
17:27:54 <jreznik> but can we do anything else for this one except trying to get working tc7?
17:28:20 <adamw> we could f igure out what actually caused the problem, but man, that sounds like work.
17:28:37 <sgallagh> adamw: You're right. freeipa-client pulls it in too
17:28:51 <adamw> WOOHOO SCORE ONE FOR "THE SARAH PALIN OF FEDORA"
17:29:06 <jreznik> lo
17:29:07 <jreznik> l
17:29:19 <mattdm> :)
17:29:46 <sgallagh> moving on...
17:29:59 <jreznik> ok
17:30:19 <jreznik> .bug 1135746
17:30:22 <zodbot> jreznik: Bug 1135746 Fedora 21 Server TC5 software selection spoke is blank - https://bugzilla.redhat.com/1135746
17:30:38 <jreznik> sgallagh: I see your last comment
17:30:55 <sgallagh> This is fixed. I've run test-composes of Server to verify.
17:31:03 <sgallagh> Just waiting on the official TC7 to close it
17:31:24 <jreznik> #info fixed, waiting for official TC7 to close it
17:31:32 <jreznik> thanks!
17:31:56 <jreznik> and the last not on_qa/verified
17:31:59 <jreznik> .bug 1088933
17:32:02 <zodbot> jreznik: Bug 1088933 update grubby to support device tree options for arm - https://bugzilla.redhat.com/1088933
17:32:34 <jreznik> as dgilmore is out
17:32:38 <jreznik> [18:48] <dgilmore> jreznik: and the arm grubby thing I need a day to sit down and get it right
17:32:54 <jreznik> peter comments it, it could be beta blocker with workaround
17:33:12 <adamw> sgallagh: why can't we close 1135746 based on tc6?
17:33:18 <jreznik> [18:49] <jreznik> dgilmore: for arm grubby, peter thinks we can move it to beta and document workaround, do you agree? would it help you to get one thing from you now?
17:33:20 <jreznik> [18:50] <dgilmore> jreznik: sure, the workaround is to tweak extlinux.conf manually
17:33:21 <jreznik> [18:50] <dgilmore> if you do a anaconda install fdtdir entry is missing completely
17:33:23 <jreznik> [18:50] <dgilmore> which works on highbank as it breaks with the fdtdir line
17:34:04 <sgallagh> adamw: Because TC6 had a different issue, IIRC
17:34:16 * sgallagh checks
17:34:23 <adamw> sgallagh: i don't think so...i did installs from it
17:34:29 * adamw already checking
17:34:35 <sgallagh> adamw: You're right. I misremembered.
17:34:44 <adamw> it has the netinst issues, of course, but the DVD shouldn't be affected
17:34:45 <sgallagh> adamw: Kill it. Fire optional (but preferred)
17:35:00 <adamw> fire is never optional.
17:36:26 <jreznik> so, any wrap up for that one? and thoughts on arm grubby blocker?
17:37:41 <sgallagh> jreznik: "sgallagh and adamw assert that this was fixed as of TC6"
17:38:15 <jreznik> you can info it, you're chair
17:38:39 <sgallagh> #info sgallagh and adamw assert that 1135746 was fixed as of TC6
17:38:48 <jreznik> thanks!
17:39:32 <jreznik> and now the grubby one - do we want to wait for dgilmore with a lot more important issues to fix for neinstall or based on the answer in bug and what dgilmore said (see above) -> beta?
17:39:58 <sgallagh> jreznik: topic and link?
17:40:09 <jreznik> .bug 1088933
17:40:12 <zodbot> jreznik: Bug 1088933 update grubby to support device tree options for arm - https://bugzilla.redhat.com/1088933
17:40:34 <jreznik> see 19:32+ here
17:40:37 <adamw> it sounds like it's a bit ugly, if the arm folks say we can waive it then fine, maybe keep it FE in case they find some time to fix it
17:41:09 <jreznik> definitely +1 for FE
17:41:10 <pwhalen> I'm okay moving it to a beta blocker, easily documented for alpha
17:41:22 <jreznik> thanks for voice pwhalen
17:42:11 <sgallagh> OK, so AlphaFE, BetaBlocker?
17:42:17 <jreznik> formal vote to move 1088933 to beta blockers, set accepted FE?
17:42:24 <sgallagh> +1
17:42:26 * nirik is here late.
17:42:40 <roshi> +1
17:42:46 <pwhalen> +1
17:42:48 <danofsatx> +1
17:42:48 <sgallagh> nirik: It's okay, we assigned you to fix all the blockers
17:43:05 <nirik> excellent.
17:43:15 <adamw> +1
17:43:48 <jreznik> and we can count peter and dgilmore
17:44:04 * jreznik does not know how to correctly write agreement using QA style...
17:44:56 <sgallagh> Proposed: #agreed Bug 1088933 is RejectedBlocker for Alpha, Approved Blocker for beta and FE for Alpha.
17:45:24 <jreznik> patch, I'd add ARM team is ok and we need documentation for common bugs
17:46:20 <sgallagh> Proposed: #agreed Bug 1088933 is RejectedBlocker for Alpha, Approved Blocker for beta and FE for Alpha. ARM Team agrees to deferral of blocker to Beta. Common Bugs page will need content added for this issue in Alpha.
17:46:31 <sgallagh> ack/nack/patch?
17:46:36 <jreznik> ack
17:46:40 <danofsatx> ack
17:46:43 <adamw> ack
17:47:16 <sgallagh> #agreed Bug 1088933 is RejectedBlocker for Alpha, Approved Blocker for beta and FE for Alpha. ARM Team agrees to deferral of blocker to Beta. Common Bugs page will need content added for this issue in Alpha.
17:47:24 <jreznik> thanks sgallagh
17:47:50 <jreznik> is there any other bug you'd like to talk about?
17:48:34 <jreznik> adamw, sgallagh: ^^^
17:49:15 <sgallagh> I think the remainder are either just waiting for TC7 or else related to the mirror/netinst work
17:49:43 <jreznik> ok, seems like
17:49:59 <adamw> there's a proposed FE with sufficient karma to go through if people wanted to vote on it
17:49:59 <adamw> https://bugzilla.redhat.com/show_bug.cgi?id=1137023
17:50:28 * jreznik is looking
17:51:09 * danofsatx is Waiting for bugzilla.redhat.com
17:51:19 <danofsatx> at least, according to Chrome I am.
17:52:02 <sgallagh> +1 (This bug would be very annoying to people trying to do a headless install)
17:52:21 <jreznik> seems like it helps with vnc installation and it's tigervnc related, should not break anything really needed, +1 FE
17:53:16 <jreznik> other votes?
17:53:22 <roshi> +1
17:53:42 <adamw> i'm not clear on what teh visual impact of the bug is, but at least +1 FE, maybe even +1 blocker
17:53:46 <adamw> (VNC blocks Alpha)
17:54:02 * jreznik was thinking if vnc blocks alpha or not
17:54:40 <adamw> "When using a dedicated installer image, the installer must be able to complete an installation using the text, graphical and VNC installation interfaces.
17:54:40 <adamw> "
17:55:06 <jreznik> adamw: "I cannot click any of the UI or get the installer screen to repaint."
17:55:17 <sgallagh> Yeah, that sounds pretty blocker-ish.
17:55:27 * sgallagh tries to remember how to start an install that way to test
17:55:46 <jreznik> so it's not visual impact but actually it seems to be unusable at all
17:57:50 <adamw> oh, hum
17:57:55 <adamw> tigervnc is the client, right?
17:58:04 <jreznik> aha
17:58:12 <jreznik> so it can work with other clients?
17:58:27 <sgallagh> I'm not sure
17:58:34 <jreznik> but this sounds more like it's server
17:58:35 <sgallagh> I think anaconda uses tigervnc libraries to send it
17:58:51 <roshi> iirc tigervnc is what anaconda uses
17:59:03 <roshi> it's been a while since I did vnc installation though
17:59:09 <adamw> i don't think so
17:59:14 <sgallagh> Requires: tigervnc-server-minimal
17:59:17 <adamw> ps aux | grep vnc shows Xvnc
17:59:17 <jreznik> it was missing patch hunk in xserver
17:59:19 <adamw> hm
17:59:27 <adamw> i just tested TC6 using vinagre as viewer and it works
17:59:29 <sgallagh> (repoquery --requires anaconda-gui)
17:59:30 <roshi> I think any vnc client should work with it
17:59:41 <jreznik> and also one tigervnc fix, so seems like two fixes
17:59:43 <jreznik> ?
18:00:11 <sgallagh> Given that the fix is known and karma passes, shall we just grant it blocker and be done with it?
18:00:14 <jreznik> no, it's xserver patch in tigervnc but it acts as server
18:00:17 <sgallagh> There's no cost to us
18:00:18 <jreznik> https://github.com/TigerVNC/tigervnc/pull/29
18:00:19 <adamw> oh, yeah, Xvnc comes from tigervnc-server-minimal
18:00:35 <adamw> so, odd that i don't see the bug in tc6, but i don't mind granting at least FE
18:00:41 * sgallagh has to run to another meeting
18:01:13 <jreznik> so let's do FE now and some QA looking for more work can retest and raise it as blocker
18:01:45 <adamw> sure
18:03:26 <jreznik> proposed #agreed - 1137023 - AcceptedFreezeException - this can make VNC installation impossible, it could be blocker too based on VNC installation Alpha criteria, QA to retest and raise bug priority in case it's true
18:04:32 <jreznik> any acks/patch/nack? /me would have to end the meeting in a few minutes
18:05:19 <jreznik> adamw, roshi, others
18:06:10 <roshi> ack
18:06:27 <jreznik> jsmith, nirik? ^^^
18:06:34 <roshi> danofsatx: ^^
18:06:51 <jsmith> ACK
18:07:47 <adamw> ack
18:08:00 <jreznik> #agreed - 1137023 - AcceptedFreezeException - this can make VNC installation impossible, it could be blocker too based on VNC installation Alpha criteria, QA to retest and raise bug priority in case it's true
18:08:10 <jreznik> #topic Go/No-Go decision
18:08:34 <jreznik> so we're clear here, again to make process happy
18:08:51 <jreznik> we don't have release candidate, there are still unresolved blocker bugs
18:09:03 <jreznik> #info we don't have release candidate, there are still unresolved blocker bugs
18:09:53 <jreznik> proposed #agreed Fedora 21 Alpha is No-Go due to no Release Candidate available and open blocker bugs
18:10:13 <roshi> ack
18:11:40 * jreznik expects dgilmore as releng would ack for sure, sgallagh or nirik here?
18:12:05 <nirik> ack
18:12:17 <jreznik> #agreed Fedora 21 Alpha is No-Go due to no Release Candidate available and open blocker bugs
18:12:54 <jreznik> there were two options asked - not to release netinst for alpha or do more than one week slip
18:13:27 <jreznik> but after this meeting, I think we look on the right way to resolve netinst issues and other blockers
18:13:52 <jreznik> so I expect I can do standard one week delay announcement + update schedules
18:14:12 <nirik> yeah.
18:14:15 <roshi> makes sense to me
18:14:51 <adamw> so looking at the matrices, our coverage for tc6 isn't terrible
18:15:04 <adamw> i'm moderately optimistic we could possibly actually be done next week if the netinst stuff works out
18:15:21 <roshi> yeah
18:15:38 * roshi is working on the i386 stack of tests as we speak
18:16:21 <adamw> so i'd go with standard one week slip, it feels about right
18:16:40 <adamw> if we hit sharks in the netinst waters we can consider waiving the requirements for it to work without manual repo configuration, or not shipping them
18:16:56 <jreznik> #action jreznik to announce one week slip and update schedules
18:17:28 <jreznik> #info it we hit issues with netinst, we can consider waiving the requirements for it to work without manual repo configuration, or not shipping them
18:17:40 <jreznik> sounds like the way we should proceed
18:17:47 <jreznik> anything else?
18:17:51 <jreznik> #topic Open floor
18:17:53 <adamw> goddamnit, a man can't wave his arms or get sharks in the minutes
18:17:58 <adamw> it's like this is some kind of professional operation
18:18:14 <jreznik> :D
18:18:39 <jreznik> if there's nothing else, I'll just push the button - dinner waits for me :)
18:18:47 <roshi> if you cross the streams you get arm waving sharks - which no one wants
18:19:00 * roshi has nothing
18:19:16 <jreznik> btw. I'll be on PTO tomorrow - going to Prague for the CERN exhibition at Czech Academy of Science
18:19:19 <jzb> roshi: I, for one, welcome our arm-waving-shark overlords.
18:19:20 <adamw> roshi: i thought that was discovery channel's next big hit.
18:19:28 <adamw> jreznik: have fun!
18:20:02 <jreznik> you can make particle collisions by kicking some probably kinect based device :)
18:20:08 <roshi> nah, that was the arm waving sharknado lazer circus adamw
18:20:36 <jreznik> ok, thanks for coming and especially all that big thanks for sorting out netinst issues!
18:20:48 <jreznik> #endmeeting