env-and-stacks
LOGS
15:03:40 <mmaslano> #startmeeting Env and Stacks (2014-05-20)
15:03:40 <zodbot> Meeting started Tue May 20 15:03:40 2014 UTC.  The chair is mmaslano. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:03:40 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:03:45 <mmaslano> #meetingname env-and-stacks
15:03:45 <zodbot> The meeting name has been set to 'env-and-stacks'
15:03:49 <mmaslano> #chair abadger1999 pkovar tjanez samkottler bkabrda drieden hhorak juhp mmaslano
15:03:49 <zodbot> Current chairs: abadger1999 bkabrda drieden hhorak juhp mmaslano pkovar samkottler tjanez
15:04:06 <mmaslano> I see three people, me, hhorak, tjanez
15:04:16 <mmaslano> anybody else?
15:04:45 * tflink is here but doesn't count for voting :)
15:05:21 <mmaslano> tflink: doesn't matter I wanted to ask more about Taskotron
15:05:34 <mmaslano> tflink: I wanted to stop by Kamil Paral, but I didn't catch him today
15:05:42 <mmaslano> #topic init process
15:06:02 <mmaslano> #topic Taskotron
15:06:51 <mmaslano> I'm sure we spoke about how is Taskotron doing, but I can't remember when
15:07:28 <tjanez> mmaslano, maybe you meant the ML status update from last week?
15:07:38 <mmaslano> ah that was it
15:07:43 <mmaslano> so I need to catch Kamil anyway :)
15:08:18 <mmaslano> #proposal put possible tests for Playground on wiki page
15:08:23 <tflink> we had our first release on Friday but there's still plenty of work to do
15:08:32 <mmaslano> I guess we can create list of what we want to test without knowing details
15:08:42 <mmaslano> tflink: great, so I can look at it
15:09:22 <tflink> what details are you looking for?
15:10:04 <tflink> mmaslano: it's still early alpha software but it does work - we're switching to a time-based release schedule instead of feature based
15:10:11 <mmaslano> how to write tests, if you have any :)
15:10:53 <tflink> https://docs.qadevel.cloud.fedoraproject.org/libtaskotron/latest/writingtasks.html
15:12:15 <tjanez> #info preliminary documentation for writing Taskotron tasks:  https://docs.qadevel.cloud.fedoraproject.org/libtaskotron/latest/writingtasks.html
15:12:23 <tjanez> tflink, I hope you don't mind
15:12:25 <mmaslano> that's a good start
15:12:50 <tflink> tjanez: not at all
15:13:33 <tflink> for now, we're just planning to support tasks written in python until the system matures a bit
15:13:48 <tjanez> tflink, do you have any description of the background infrastructure, e.g. worker nodes, results db, task dispatcher, ...
15:14:16 <hhorak> tflink: but python also can execute some other binaries, right?
15:14:18 <tflink> tjanez: not much at the moment, I'm planning to start writing about that this week
15:14:35 <tflink> hhorak: yeah, no restrictions on doing stuff like subprocess
15:14:38 <mmaslano> I don't prefer python, but I guess it's sufficient, support of other languages will just take your time
15:15:18 <tjanez> tflink, cool, I'm interested to know more about that. Will ping you next week.
15:15:24 <hhorak> Just a general thought, I think all tests should be able to be run locally if possible, so people can reproduce the scanning before pushing changes to koji and debug tests... tflink - do you think that is a sane requirement?
15:15:38 <tflink> I want to support other languages eventually but we need to make sure that we stay sane and don't have a lot of experience with other languages
15:16:32 <tflink> the interactions are designed to work mostly on stdout, though. Valid TAP13 emission (with a few requirements on included data for reporting) is the hard requirement
15:16:51 <mmaslano> tflink: from Perl person point of view, it doesn't matter. Later we will be just modifying existing tests, so it shouldn't be hard to do even for non python people
15:17:15 <tflink> taskotron was designed to run locally so that people can write tasks without needing to set up a bunch of services
15:17:29 <tflink> hhorak: does ^^ answer your question?
15:17:39 <hhorak> tflink: great, that is fantastic
15:17:52 <tflink> if you find that not to be true, I want to know so we can fix it
15:18:12 <hhorak> tflink: great, I will give it a try
15:18:13 <mmaslano> sounds good, we need to test it
15:18:15 <tflink> that was one of my pet peeves about autoqa - that the whole system was required to write tests
15:19:40 * hhorak has the same experience with many similar systems
15:21:14 <hhorak> tflink: Has anybody already taken a look at "copr vs. taskotron" thing?
15:21:28 <tflink> hhorak: not sure what you're referring to
15:22:17 <hhorak> tflink: sorry, badly written. I'm just wondering if somebody looked if taskotron could be used for builds in copr somehow.
15:22:42 <tflink> hhorak: depending on what exactly you're looking to do, I don't see why that couldn't work
15:23:29 <tflink> we're not set up for that yet but I'm not aware of any incompatibilities outside of potential complications with deps between copr repos
15:23:55 <tjanez> tflink, in which environment are the tests executed: a LXC, a chroot, a virtual machine instance?
15:24:01 <tflink> taskotron schedules execution based on fedmsgs and IIRC, copr emits fedmsgs
15:24:07 <tflink> tjanez: for now, virtual machines
15:24:45 <hhorak> tflink: no specific issue on my mind right now, just thinking how much the taskotron infrastructure is tight to koji or if it is flexible enough to work fine with copr builds as well.. but if not tested yet, we should look at it soon..
15:25:39 <tjanez> tflink, Ok, that should be secure enough for even some "wilder" contributed taskotron tasks
15:25:40 <tflink> hhorak: ah, I didn't think about that part. no, we don't have any functionality to query or  download builds from copr
15:26:32 <tflink> tjanez: at the moment, they're persistent VMs, so potentially destructive tasks aren't an option
15:26:47 <tflink> per-task vms is on the roadmap, though
15:27:08 <tjanez> tflink, aha, I see. I thought it was already per-task new VM
15:27:09 * tflink makes note to file tickets on copr integration, hadn't thought of that
15:27:41 <hhorak> tflink: I'm thinking if it would be better to have two separate instances or one common system. The sooner seems like less deployment work, but not sure if it is possible..
15:27:42 <tflink> tjanez: nope, not yet. I have an idea to let us have per-task vms without much effort but I need to investigate before promising anything
15:28:15 <tflink> hhorak: you mean one instance for working with copr and another instance for working with koji?
15:28:15 <hhorak> ^ I meant the later is less deployment work, but it is obvious I guess..
15:28:18 <tjanez> tflink, no pressure. I'll be interested in reading the architecture of the system when you write it up
15:29:14 <hhorak> tflink: yeah, that one I thought as one alternative, the worse one (more work).. sorry for making mess :)
15:30:13 <tflink> hhorak: I don't think there would be much advantage to separate systems. interfacing with copr shouldn't be a big problem, though.
15:31:09 <hhorak> tflink: great, that would be awesome
15:37:55 <mmaslano> I'm more than satisfied with your answers :)
15:38:16 <mmaslano> so, action item - homework test taskotron?
15:39:22 <tflink> if anyone has questions, please let us know. kparal is a good person to ask if I'm not around and we're both in #fedora-qa
15:41:05 <mmaslano> sounds great
15:41:27 <mmaslano> guys, I would suggest testing Taskotron and do a list of test needed for Playground
15:41:50 <hhorak> tflink: as for the particular tests -- do you happen to know if anybody is already looking at including rpmgrill or not yet?
15:41:56 <tjanez> tflink, to "test" taskotron locally, one only need to clone and install libtaskotron, right?
15:42:06 <tflink> if there are features that you need and we don't have, please let us know or file tickets. same thing if there are oddities in interactions that seem wrong
15:42:19 <tflink> tjanez: or install libtaskotron from our copr repo
15:42:32 <tflink> hhorak: not that I'm aware of, no
15:42:38 <tjanez> tflink, aha, even easier :)
15:42:50 <hhorak> tflink: ok
15:43:42 <tflink> hhorak: are there docs for rpmgrill? I remember hearing about it but the details are escaping me at the moment
15:44:11 <tflink> nvm, found the repo
15:45:56 <mmaslano> hhorak: you don't want to learn Perl, I can see that :)
15:46:27 <mmaslano> I don't think there is documentation, there are implemented many checks
15:47:01 <mmaslano> if we could run that, it would safe us lot of tests
15:47:01 * hhorak no aware of any other doc than source either
15:47:27 <mmaslano> it's readable, I was looking at it once
15:48:17 <hhorak> mmaslano: but you are perl guru, which I am not. It it looks similar to php, so I should be able to hack it :)
15:48:25 <mmaslano> :)
15:48:53 <mmaslano> I would start with looking if it's usable in Fedora and by taskotron somehow
15:49:08 <mmaslano> hhorak: do you want to find out or should I take it?
15:51:29 <hhorak> mmaslano: I already took a look and currently talking to one student who prepared a patch to have rpmgrill usable for one build (originally it was strictly tight to koji build results)
15:51:40 <hhorak> mmaslano: so I can continue with that
15:51:46 <mmaslano> ok great
15:52:02 <mmaslano> #action hhorak will look at usability of rpmgrill
15:56:52 <mmaslano> I think we can close it
15:56:57 <mmaslano> thanks for information!
15:57:00 <mmaslano> #endmeeting