f20_beta_gono-go_meeting
MINUTES

#fedora-meeting-2: F20 Beta Go/No-Go meeting

Meeting started by jreznik at 17:00:58 UTC (full logs).

Meeting summary

  1. Roll Call (jreznik, 17:01:11)
  2. Purpose of this meeting (jreznik, 17:07:15)
    1. Purpose of this meeting is to see whether or not F20 Beta is ready for shipment, according to the release criteria. (jreznik, 17:07:42)
    2. This is determined in a few ways: (jreznik, 17:07:44)
    3. No remaining blocker bugs (jreznik, 17:07:46)
    4. Test matrices for Beta are fully completed (jreznik, 17:07:48)
    5. http://qa.fedoraproject.org/blockerbugs/milestone/20/beta/buglist (jreznik, 17:07:49)
    6. https://fedoraproject.org/wiki/Test_Results:Fedora_20_Beta_RC5_Install (jreznik, 17:07:51)
    7. https://fedoraproject.org/wiki/Test_Results:Fedora_20_Beta_RC5_Base (jreznik, 17:07:52)
    8. https://fedoraproject.org/wiki/Test_Results:Fedora_20_Beta_RC5_Desktop (jreznik, 17:07:54)

  3. Current status (jreznik, 17:08:03)
    1. the current blocker status is: (tflink, 17:14:17)
    2. 6 Proposed Blockers (tflink, 17:14:23)
    3. 4 Accepted Blockers (tflink, 17:14:24)

  4. (1008732) LUKSError: luks device not configured (tflink, 17:14:42)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1008732 (tflink, 17:14:42)
    2. Proposed Blocker, anaconda, NEW (tflink, 17:14:42)
    3. https://fedoraproject.org/wiki/Fedora_20_Beta_Release_Criteria#Custom_partitioning (kparal, 17:22:28)
    4. AGREED: 1008732 - RejectedBlocker (beta) AcceptedBlocker (final) - Violates the following F20 final release criterion: "The installer must be able to create and install to any workable partition layout using any file system and/or container format combination offered in a default installer configuration." (tflink, 17:27:42)

  5. (978298) AttributeError: 'DeviceFormat' object has no attribute 'peStart' (tflink, 17:27:52)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=978298 (tflink, 17:27:55)
    2. Proposed Blocker, anaconda, ASSIGNED (tflink, 17:27:57)
    3. AGREED: 978298 - RejectedBlocker - This use case was deemed too much of a corner case to justify blocking the release of Fedora 20 beta. (tflink, 17:34:32)

  6. (1027682) DeviceError: ('Cannot destroy non-leaf device', 'fedora_dhcp-29-193-root') (tflink, 17:35:10)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1027682 (tflink, 17:35:13)
    2. Proposed Blocker, anaconda, NEW (tflink, 17:35:16)
    3. AGREED: 1027682 - RejectedBlocker - Resize issues are generally considered for blocking final release, not beta. As such, this bug is rejected as a release blocking issue for F20 beta but please re-propose as a Final Blocker and mark for inclusion in CommonBugs. (tflink, 17:50:33)

  7. (1027846) PartitionException: Partition is not part of the disk it is being removed from (tflink, 17:50:54)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1027846 (tflink, 17:50:57)
    2. Proposed Blocker, anaconda, NEW (tflink, 17:50:59)
    3. https://bugzilla.redhat.com/show_bug.cgi?id=865653 seems to be very similar/the same? (nirik, 17:52:53)
    4. AGREED: 1027846 - RejectedBlocker - Going through the partitioning spoke multiple times was deemed not worthy of blocking beta and thus, this bug is rejected as a blocker for Fedora 20 beta. Please re-propose as a blocker for F20 final and mark for inclusion in CommonBugs. (tflink, 17:57:59)

  8. (1027947) ValueError: new size same as old size (tflink, 17:58:07)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1027947 (tflink, 17:58:07)
    2. Proposed Blocker, anaconda, NEW (tflink, 17:58:07)
    3. AGREED: 1027947 - RejectedBlocker - While unfortunate, this is a resize issue at heart and that is not covered by the F20 beta release criteria and thus, is rejected as a release blocking issue for fedora 20 beta. Please re-propose as a F20 final blocker and mark for inclusion in CommonBugs (tflink, 18:14:00)

  9. (1027965) CreateException: Can't have a partition outside the disk! (tflink, 18:14:11)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1027965 (tflink, 18:14:14)
    2. Proposed Blocker, anaconda, NEW (tflink, 18:14:16)
    3. AGREED: 1027965 - RejectedBlocker - While unfortunate, this is a resize issue which is not covered by the F20 beta release criteria. Thus, it is rejected as a release blocking issue for fedora 20 beta. Please re-propose as a F20 final blocker and mark for inclusion in CommonBugs (tflink, 18:20:03)

  10. (1008633) ValueError: invalid target size request (tflink, 18:20:44)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1008633 (tflink, 18:20:44)
    2. Accepted Blocker, anaconda, ASSIGNED (tflink, 18:20:44)
    3. AGREED: 1008633 - RejectedBlocker - While unfortunate, resize issues are not covered in the F20 beta release criteria. Thus, this bug is rejected as a release blocking issue for F20 beta. Please re-propose as a F20 final blocker and mark for inclusion in CommonBugs (tflink, 18:27:46)

  11. Current status (jreznik, 18:31:04)
    1. After the blocker review, there are no known accepted and not fixed blocker bugs (jreznik, 18:31:47)

  12. Test matrices coverage (jreznik, 18:32:37)
    1. QA is ok with RC5 test matrices coverage (jreznik, 18:42:25)

  13. Go/No-Go decision (jreznik, 18:47:04)
    1. AGREED: Fedora QA and Fedora Development are Go (jreznik, 18:55:01)
    2. ACTION: jreznik to announce the Go decision (jreznik, 18:55:22)

  14. Open floor (jreznik, 18:55:45)


Meeting ended at 19:13:52 UTC (full logs).

Action items

  1. jreznik to announce the Go decision


Action items, by person

  1. jreznik
    1. jreznik to announce the Go decision


People present (lines said)

  1. jreznik (107)
  2. tflink (92)
  3. kparal (92)
  4. adamw (60)
  5. nirik (51)
  6. roshi (17)
  7. dlehman (13)
  8. zodbot (6)
  9. pwhalen (3)
  10. croberts (3)
  11. nangthang (2)
  12. jwb (2)
  13. mkrizek (1)
  14. satellit (1)


Generated by MeetBot 0.1.4.