fpc
LOGS
17:00:20 <geppetto> #startmeeting fpc
17:00:20 <zodbot> Meeting started Thu Jan 21 17:00:20 2016 UTC.  The chair is geppetto. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:20 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
17:00:20 <zodbot> The meeting name has been set to 'fpc'
17:00:20 <geppetto> #meetingname fpc
17:00:20 <zodbot> The meeting name has been set to 'fpc'
17:00:21 <geppetto> #topic Roll Call
17:00:28 <mbooth> Good evenin'
17:00:31 <geppetto> #chair mbooth
17:00:31 <zodbot> Current chairs: geppetto mbooth
17:00:36 <orionp> hello
17:00:37 <tibbs|w> Hey, folks.
17:00:57 <geppetto> #chair orionp
17:00:57 <zodbot> Current chairs: geppetto mbooth orionp
17:00:59 <geppetto> #chair tibbs
17:00:59 <zodbot> Current chairs: geppetto mbooth orionp tibbs
17:01:21 <geppetto> #chair Rathann
17:01:21 <zodbot> Current chairs: Rathann geppetto mbooth orionp tibbs
17:01:23 <Rathann> hi
17:01:24 <tibbs|w> A user got themselves ransomwared so I'm a bit distracted dealing with that.
17:01:34 * geppetto nods
17:01:39 * SmootherFrOgZ is here
17:01:41 <geppetto> backups ftw?
17:01:44 <geppetto> #chair SmootherFrOgZ
17:01:44 <zodbot> Current chairs: Rathann SmootherFrOgZ geppetto mbooth orionp tibbs
17:01:51 <tibbs|w> Yeah, but tape is sloooow.
17:01:57 <geppetto> :)
17:02:10 <tibbs|w> And she waited too long to tell us so it's rolled off of the online backups.
17:02:20 <geppetto> ahh
17:02:36 <geppetto> #chair tomspur
17:02:36 <zodbot> Current chairs: Rathann SmootherFrOgZ geppetto mbooth orionp tibbs tomspur
17:04:03 <geppetto> #chair racor
17:04:03 <zodbot> Current chairs: Rathann SmootherFrOgZ geppetto mbooth orionp racor tibbs tomspur
17:04:15 <geppetto> Ok, almost everyone … should be good to go
17:04:23 <geppetto> #topic Schedule
17:04:31 <geppetto> https://lists.fedoraproject.org/archives/list/packaging%40lists.fedoraproject.org/message/P5JLYLVRLKJWRB5OZXZCEQSYDKOE7ZIV/
17:04:40 <geppetto> #topic #590 systemd links update
17:04:44 <geppetto> .fpc 590
17:04:45 <zodbot> geppetto: #590 (systemd links update) – fpc - https://fedorahosted.org/fpc/ticket/590
17:07:20 <tibbs|w> Haven't had a chance to read my email this morning, and that's pretty new.
17:07:34 <geppetto> I'm not sure what the change is at line 17 … maybe whitespace? … this looks fine/simple though, to me.
17:08:14 <tibbs|w> So basically this is a minor cleanup, changing some links, removing the "Fedora 18+ bit", and one substantive change.
17:08:19 <orionp> Looks good to me
17:08:23 <SmootherFrOgZ> yup
17:08:25 <tibbs|w> The addition of the service name to %systemd_postun.
17:08:31 <tibbs|w> Why is that required now?
17:08:34 * geppetto nods … the main bit really is removing all references to sysv init scripts.
17:08:53 <geppetto> Which seems fine given 24 goals etc.
17:08:56 <tibbs|w> It's not mentioned in the comment.
17:09:00 <zbyszek> tibbs|w: for consistency with the rest of the example
17:09:13 <tibbs|w> OK, but is it required or not?
17:09:37 <zbyszek> Yes, a name of the unit is required.
17:10:17 <zbyszek> It's not like it's hard to figure out, but still, consistent is usually better.
17:10:18 <racor> zbyszek: And it wasn't required before?
17:10:25 <tibbs|w> Hmm, then how did that slip through for so long?
17:10:54 <tibbs|w> Not that I disagree with the change, mind you.  I'm just curious how this got messed up in the first place.
17:11:14 <zbyszek> I think it's obvious from context that you need a name... so anyone using this would add the name, even though the example doesn't have one.
17:12:13 <tibbs|w> That's obvious to you is not always obvious to everyone else.
17:12:22 <tibbs|w> But anyway, +1 to this.
17:12:28 <zbyszek> Oh, wait I see one more issue
17:12:42 <zbyszek> s/following %post/following %postun/
17:13:20 <zbyszek> I updated the draft...
17:13:27 <tibbs|w> Still +1.
17:13:27 <racor> zbyszek: You didn't answer my question. Is this a syntactical change or not?
17:14:09 <zbyszek> racor: The script does nothing without the unit name.
17:14:09 <geppetto> zbyszek: Does it not need the %post bit there as well?
17:14:51 <tibbs|w> racor: It appears to be nothing more than cleaning up obsolete links and fixing one example.
17:14:54 <tomspur> Looking at the definition of %systemd_postun, the argument seems to be ignored...
17:15:03 <racor> zbyszek: Did it something before?
17:15:07 <zbyszek> %post and %preun are unchanged. Only %postun is different for restartable services.
17:15:23 <zbyszek> racor: Yes, it did something before, and still does in Fedora < rawhide.
17:15:43 <racor> I am worried about backward compatibility
17:15:46 <geppetto> ok, +1 with the post/postun change as well.
17:16:09 <tibbs|w> I think we're just asking questions unrelated to the draft because this is still a bit magic.
17:17:02 <geppetto> Well to be fair zbyszek says the line 23 change was always needed, and tomspur says it does nothing.
17:17:13 <orionp> Looks like tomspur is right %systemd_postun doesn't take an argument
17:17:15 <zbyszek> Shit, tomspur is right.
17:17:23 <orionp> systemctl daemon-reload >/dev/null 2>&1 || :
17:17:33 <orionp> so nothing unit specific
17:17:43 <zbyszek> I thought it was different before, but it isn't.
17:18:03 <tomspur> I can understand to have the service name there anyway. So I'd be fine with both.
17:18:11 <geppetto> yeh
17:18:27 <geppetto> Also if everyone adds it correctly it makes it much easier to use if required at some point.
17:18:34 <geppetto> So doesn't seem like a big deal.
17:18:36 <tomspur> +1 also
17:18:42 <mbooth> +1 from me, either way
17:18:57 <SmootherFrOgZ> +1 here too
17:19:52 <geppetto> ok, +5 … racor Rathann orionp, want to vote for the record?
17:19:58 <orionp> +1
17:20:00 <racor> +1
17:20:27 <Rathann> +1
17:20:31 <geppetto> #action systemd minor policy update and github URL change (+1:8, 0:0, -1:0)
17:20:32 <tibbs|w> On the same subject, is something happening with triggers?
17:20:52 <tibbs|w> I see mention of adding transfiletriggers but I'm not sure if that changes anything.
17:21:03 <geppetto> it's still stuck on 1284645 atm. AIUI
17:21:26 <zbyszek> tibbs|w: triggers are mostly implemented, and seem to work, but not as pretty as I originally hoped
17:21:30 <geppetto> Also the ML comment about upgrades vs. installs/etc.
17:21:44 <tibbs|w> The ticket says "Triggers are spread between two file after addition of transfiletriggers." so I'm wondering if we need to do anything to accommodate that.
17:21:48 <geppetto> zbyszek: You've worked around the rpm bug?
17:22:11 <zbyszek> Yes, but saving state on disk between the scriptlets.
17:22:17 <zbyszek> ... by saving ...
17:22:21 <geppetto> ouch
17:22:57 <zbyszek> It's still a speed improvements (and less logs) than what was before.
17:23:02 * geppetto nods
17:23:20 <tibbs|w> Does that imply that there's a release where the scriptlets aren't needed?
17:23:39 <tibbs|w> By that I mean the %post, %postun, etc. bits.
17:23:50 <zbyszek> No, the scriptlets are still needed to do presets.
17:24:09 <tibbs|w> Well that's unfortunate.
17:24:32 <zbyszek> And to disable the services after uninstallation. And only the package know if the service can be safely restarted.
17:24:47 <zbyszek> It's just that we stop doing daemon-reload all the time.
17:26:01 <tibbs|w> Ah, well.  One thing at a time, I guess.  I still wish we could get rid of them at least for some daemons.
17:26:13 <tibbs|w> Anyway, I guess we should move on.
17:26:18 <geppetto> #topic #591 Description of filtering macros in Perl is outdated
17:26:23 <geppetto> .fpc 591
17:26:24 <zodbot> geppetto: #591 (Description of filtering macros in Packaging:AutoProvidesAndRequiresFiltering#Perl is outdated) – fpc - https://fedorahosted.org/fpc/ticket/591
17:26:46 <tibbs|w> I don't think anyone has touched this in ages.
17:27:00 <geppetto> This part of policy?
17:27:05 <geppetto> Yeh, I'd guess not
17:27:49 <tibbs|w> Again, haven't read my mail this morning, so I hadn't seen ppisar's message.
17:28:18 <tibbs|w> I kind of agree that we should consider dropping the exact definition of the perl_default_filter macro.
17:28:54 * tomspur nods
17:28:55 <tibbs|w> A description of it would work better, I think.  I don't like too much magic, but I don't think it's too difficult for someone to run rpm --showrc and look if they want to see the exact code.
17:29:39 <tibbs|w> Should also remove the "rpm in Fedora 20" note.
17:30:21 <Rathann> agreed
17:30:35 <tibbs|w> I updated the draft.
17:30:57 <tibbs|w> Except, does the private libraries section describe the pre-f20 way of doing it?  Or the post-f20 way?
17:31:16 <tibbs|w> Because perhaps a bunch of that section can go away.
17:32:24 <geppetto> That looks like new information, from what I know
17:32:37 <geppetto> So … post-f20
17:32:46 * geppetto is prepared to be wrong though
17:33:11 <tibbs|w> I have forgotten what I knew about this.
17:33:40 <geppetto> Here's the diff with tibbs change: https://fedoraproject.org/w/index.php?title=User%3AZbyszek%2FFilteringDraft&diff=432755&oldid=432675
17:33:52 <geppetto> I'm +1
17:34:10 <tibbs|w> Usually easier to just use https://fedoraproject.org/w/index.php?title=User%3AZbyszek%2FFilteringDraft&diff=current&oldid=432675
17:34:26 <geppetto> Fair enough
17:34:46 <Rathann> geppetto: you removed the trailing '2' from Win32 in the first section
17:34:57 <orionp> I'd get rid of the perl_default_filter definition
17:35:10 <Rathann> me too
17:35:26 <Rathann> we can link to the source file in Fedora git
17:35:31 <tibbs|w> I'm editing it now.
17:35:33 <geppetto> I wondered about that, but wasn't sure if that made a bunch of the text less than helpful
17:35:42 <geppetto> Rathann: I'm pretty sure I didn't do anything :)
17:35:59 <Rathann> geppetto: sorry, I meant tibbs|w
17:36:08 <tibbs|w> I didn't do that either.
17:36:20 <tibbs|w> But the section is going away.  Typing as fast as I can....
17:36:33 <Rathann> it says last revision was edited by Tibbs on the wiki
17:36:49 <tibbs|w> Yeah, but I didn't remove that.  I didn't even touch that section.
17:37:05 <Rathann> ok
17:37:09 <Rathann> sorry
17:37:29 <tibbs|w> OK, saved.
17:38:00 <tibbs|w> BTW, here's a fun question: If the default filter is fixing dependencies erroneously generated by the automatic dep generator, why don't we just fix the dep generator?
17:38:10 <geppetto> hahah
17:38:12 <tibbs|w> I mean, we have control over it.
17:38:33 <tibbs|w> Surely it can just ignore files in /usr/share/doc.
17:38:50 <geppetto> Yeh, I know there was discussion at one point of ignoring everything not in the main /lib paths.
17:38:51 <tibbs|w> And VMS, Win32, etc. modules.  And UNIVERSAL.
17:39:28 <geppetto> I'm not sure what happened
17:39:29 <tibbs|w> Well, this is the perl dependency generator, so it does more than look in libdir.
17:39:41 <tibbs|w> Also, why do we filter perl(DB.* again?
17:40:06 <tibbs|w> Oh, just perl(DB).  I guess that's some virtual thing.
17:40:23 <tibbs|w> Been a long time since I knew the internals of this.
17:40:46 <tibbs|w> Anyway, that's orthogonal.  I'll look into it since I'm deep in RPM magic anyway.
17:40:56 <geppetto> I userd to do a lot with perl … 10-15 years ago.
17:41:00 <geppetto> :-o
17:41:22 <geppetto> Anyway … your latest draft seems fine to me
17:41:30 <tibbs|w> I coded Perl yesterday..... And python, and zsh, and C, and probably a couple of others.  And my brain still hurts.
17:41:32 <tibbs|w> +1
17:41:35 <geppetto> zbyszek: You looked at it, happy?
17:41:43 <zbyszek> give me a sec
17:41:58 <geppetto> no problem
17:42:40 <Rathann> there seems to be a stray <pre> in the Private Libraries section
17:42:59 <zbyszek> look good
17:43:02 <Rathann> $ rpm -qp foo-1.0-1.x86_64.rpm</code>
17:43:02 <Rathann> <pre>libprivate.so()(64bit)
17:43:02 <Rathann> foo = 1.0-1.fc19
17:43:13 <Rathann> oh, and </code>
17:44:18 <tibbs|w> That must have been in there forever.
17:44:23 <geppetto> Yeh
17:44:29 <tomspur> Hmm, I don't see the appending thing from the ppisar. Am I looking at the wrong draft?
17:45:21 <tibbs|w> Rathann: Those should be fixed.
17:46:02 <orionp> tomspur: I think he just commented in the ticket
17:47:25 <tomspur> orionp: Thanks.
17:48:23 <orionp> While it's certainly needed when creating macros like perl_default_filter, I'm not sure how much it's needed elsewhere
17:48:49 <tibbs|w> I'm still +1 on these changes, but if we want to hold off until we can integrate ppisar's recommendations than I'm OK with that.
17:48:54 <geppetto> tibbs: +1 on your latest, with the /pre fix.
17:49:18 <tibbs|w> I think we should get this in now (since it's far less wrong) and tweak later.
17:49:26 <orionp> agreed
17:49:29 <tibbs|w> But I'll understand if people feel otherwise.
17:49:46 <geppetto> Well this version is an improvement over the previous one, so approving it and doing more changes if needed seems the way to go.
17:50:11 <Rathann> +1
17:50:21 <tomspur> This version looks fine for everything but perl. I don't know enough about the perl packaging foo to say if this is fine for perl too
17:51:46 <orionp> Isn't the perl stuff all we're changing here?
17:52:40 <geppetto> It's in the perl section, but most of the advise is generic
17:54:03 <geppetto> orionp: mbooth: tomspur: racor: SmootherFrOgZ: vote?
17:54:09 <orionp> +
17:54:10 <orionp> +1
17:54:23 <racor> I am hesitant on the perl section, because it's almost orthognal to current to current perl practices
17:54:43 <geppetto> What are current perl practises?
17:54:56 <tibbs|w> Someone should document those.
17:55:01 <racor> current perl practice is want ppisar says
17:55:04 <tibbs|w> This is supposed to be that documentation.
17:55:11 <SmootherFrOgZ> +1 from me
17:55:29 <racor> use %perl_default* first, then append
17:55:42 <tibbs|w> Well that's what we said earlier.  He's probably right, but this document is less wrong than it was, so we can commit this now and then apply ppisar's changes on top.
17:55:54 <tibbs|w> But if you want to edit the draft to reflect that now, please go ahead.
17:56:23 <orionp> Ah, so yeah, perl_default_filter doesn't append
17:56:31 <racor> tibb|w: we are talking about changing 100 of package, here!
17:57:06 <zbyszek> racor: I don't think there is need to change any packages.
17:57:12 <orionp> Which it probably should do, but won't for years
17:57:47 <orionp> So ppisar is correct
17:57:58 <Rathann> hm wait the latest version of the draft specifies perl_default filter AFTER custom filter, so it's wrong
17:58:44 <zbyszek> Rathann: it's not wrong
17:59:07 <tibbs|w> How are we talking about changing packages?
17:59:30 * Rathann is checking current perl_default_filter definition
17:59:46 * racor scratches head ... I have packages which append without explicitly using _perl_default_filter ?
18:00:07 <orionp> The version or perl_default_filter in EL7 does not append
18:00:18 <tibbs|w> I then suggest we just table this.  racor obviously understands this, so perhaps he's willing to give us a draft.
18:00:44 <orionp> rawhide does append
18:00:53 <racor> tibbs|w: ATM, I am completely confused ;)
18:01:18 <geppetto> Well we are already at +5 anyway
18:01:40 <geppetto> Actually +6, I missed a vote
18:01:40 <orionp> well, I'm may change my vote...
18:01:48 * tomspur is +0 and waits for a draft of racor until next week :)
18:02:32 * geppetto shrugs … we can wait until next week though, I doubt it's urgent to fix this.
18:02:48 <tibbs|w> True, it's been wrong for a long time now.
18:02:55 <racor> tomspur: Not sure, I'll be able to come with a draft, but I'll definitely experiment
18:02:56 <Rathann> right, rawhide filter appends
18:03:14 <orionp> so does F22
18:03:20 <orionp> so it's okay for Fedora, but not EPEL
18:03:34 <Rathann> so it actually does what ppisar wanted
18:03:42 <tibbs|w> Well, <=epel6 is a whole different thing.
18:03:53 <tibbs|w> EPEL7, I don't know.
18:04:01 <orionp> it doesn't append in EPEL7
18:04:08 <Rathann> meh
18:04:10 <tibbs|w> We can override system-provided macros if we need to do so.
18:04:32 <tibbs|w> Well, technically we can do so.  I don't know if we should, but I would lean towards "hell yes".
18:04:41 <tomspur> :)
18:05:17 <tibbs|w> The EL6 epel macros package overrides one of the broken EL6 fontpackages macros.
18:07:22 <mbooth> So, leaving this until next time?
18:07:32 <geppetto> Yeh, we can move on
18:07:32 <racor> I am not sure, but isn't perl_default_filter automatically included by all perl packages in Fedora? The would at least explain my remark from above.
18:08:13 <geppetto> #info Had enough to pass, and seems better than what we have but tabling until we have a final change for perl.
18:08:20 <geppetto> #topic #592 Blanked bootstrapping exception for mlton
18:08:26 <geppetto> .fpc 592
18:08:28 <zodbot> geppetto: #592 (Blanket bootstrapping exception for mlton) – fpc - https://fedorahosted.org/fpc/ticket/592
18:08:35 <geppetto> This seems like a simple one :)
18:08:59 <orionp> racor - it's in perl-macros
18:09:18 <racor> orionp: thx.
18:10:53 <racor> geppetto: It's news to me, bootstrapping a package or package set would require FPC permission.
18:11:21 <mbooth> .fpc 585
18:11:23 <zodbot> mbooth: #585 (Blanket reauth. of bootstrapping exceptions (Free Pascal Compiler, atm.)) – fpc - https://fedorahosted.org/fpc/ticket/585
18:11:26 <mbooth> Duplicate?
18:11:36 <mbooth> We talked about this a fortnight ago
18:11:47 <geppetto> racor: We give exceptions for shipping the binaries in the bootstrap rpm
18:12:10 <orionp> Different packages - but yeah we talked about not needing "reauth"
18:12:11 <tibbs|w> +1
18:12:16 <geppetto> mbooth: This is ML … isn't that different from pascal?
18:12:38 <Rathann> +1 to #592 as long as the binaries are not included in any released update
18:12:44 <tomspur> +1
18:13:13 <SmootherFrOgZ> +1
18:13:32 <racor> geppetto: even this is news to me. these binaries should never make into the releases, so ...
18:13:33 <racor> +1
18:13:53 <mbooth> geppetto: Did we not generalise to any package that needs to be periodically rebootstrapped?
18:14:00 <mbooth> I don't remember exact wording
18:15:00 <geppetto> mbooth: I believe we said that they needed to get an exception the first time, but after that they could rebootstrap when they wanted.
18:15:33 <Rathann> racor: https://fedoraproject.org/wiki/Packaging:Guidelines#Exceptions
18:15:36 <mbooth> Ah, I see, then +1, obviously -- and I should file fpc tickets for my packages that need bootstapping
18:15:49 <Rathann> it's also mentioned in the Bootstrapping section of the main Guidelines
18:16:46 <orionp> +1
18:16:54 <geppetto> #action Blanket bootstrap exception for mlton (+1:8, 0:0, -1:0)
18:17:10 <geppetto> #topic Open Floor
18:17:23 <geppetto> Ok, is there anything else to bring up?
18:18:21 <mbooth> Not from me, but I need to leave anyway -- I am also absent next week, so see you in a fortnight
18:19:00 <geppetto> I won't be here in a fortnight, due to devconf.cz
18:19:16 <geppetto> Anyone else at that?
18:19:28 <Rathann> sorry, not this year
18:20:36 <tibbs|w> I'm not sure I'll be able to run next week's meeting.
18:20:43 <tibbs|w> I can try, though.
18:20:59 <geppetto> I'll be here next week
18:21:08 <geppetto> it's the week after that I won't be
18:22:35 <geppetto> ok, I'll close in a minute or two … see everyone but mbooth next week :)
18:22:49 <Rathann> thanks
18:22:50 <Rathann> see you
18:22:56 <orionp> later
18:22:56 <tomspur> See you next week
18:23:16 <tibbs|w> Thanks.  Way too much going on today.  Still the first week of the semester.
18:23:35 <geppetto> Don't you know that September never ends ;)
18:24:11 <geppetto> #endmeeting