fpc
LOGS
17:00:27 <geppetto> #startmeeting fpc
17:00:27 <geppetto> #meetingname fpc
17:00:27 <geppetto> #topic Roll Call
17:00:28 <zodbot> Meeting started Thu Dec 17 17:00:27 2015 UTC.  The chair is geppetto. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:28 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
17:00:28 <zodbot> The meeting name has been set to 'fpc'
17:00:28 <zodbot> The meeting name has been set to 'fpc'
17:01:04 <gbcox> Good Morning
17:01:10 <geppetto> heey
17:01:25 <geppetto> geppetto limburgher mbooth orionp racor Rathann SmootherFr0gZ tibbs|w tomspur: FPC ping
17:01:47 <tomspur> Hi.
17:01:53 <geppetto> #chair tomspur
17:01:53 <zodbot> Current chairs: geppetto tomspur
17:01:54 <tibbs> Howdy
17:01:58 <geppetto> #chair tibbs
17:01:58 <zodbot> Current chairs: geppetto tibbs tomspur
17:02:09 <mbooth> Hi
17:02:14 <geppetto> #chair mbooth
17:02:14 <zodbot> Current chairs: geppetto mbooth tibbs tomspur
17:02:25 <mbooth> Last meeting of the year for me :-)
17:02:41 <geppetto> yeh, for everyone I think
17:03:05 <geppetto> At least this is the last Thursday I work in 2015
17:03:09 <orionp> hello
17:03:14 <geppetto> #chair orionp
17:03:14 <zodbot> Current chairs: geppetto mbooth orionp tibbs tomspur
17:03:44 <geppetto> If everyone really wanted to do one just before new years, I could probably make it
17:03:59 <geppetto> #topic Schedule
17:04:02 <geppetto> https://lists.fedoraproject.org/archives/list/packaging%40lists.fedoraproject.org/message/FLS2WNHGB7N5KGFPDJWMLPJZWJF3BD4P/
17:04:11 <tibbs> Hell, I'm always online in some capacity.
17:04:32 <geppetto> #chair racor
17:04:32 <zodbot> Current chairs: geppetto mbooth orionp racor tibbs tomspur
17:04:36 <geppetto> #topic #547 SourceURL addition/clarification - Submodules
17:04:43 <geppetto> .fpc 547
17:04:44 <zodbot> geppetto: #547 (SourceURL addition/clarification - Git Hosting Services) – fpc - https://fedorahosted.org/fpc/ticket/547
17:04:47 <geppetto> https://fedorahosted.org/fpc/ticket/547
17:05:21 <geppetto> Note that you should ignore everything before comment 10
17:05:32 <geppetto> Someone just reopened the ticket instead of starting a new one
17:06:05 <gbcox> Yeah... it wasn't me... LOL
17:06:09 <orionp> do we still want testing from gitlab/bitbucket ?
17:06:30 <orionp> or is git git?
17:06:39 <gbcox> When I wrote the doc, I wanted to make sure everything worked with all vendors
17:06:49 <gbcox> I didn't test that
17:07:02 <geppetto> Is it possible to quickly test them now?
17:07:07 <gbcox> It "should" work, but haven't personally verified
17:07:23 <tomspur> If we quickly find a project with submodules over there...
17:07:35 <geppetto> Is it just simpler instructions, or does --recursive do extra things?
17:07:51 <gbcox> I think it is just simpler instructions
17:08:16 * geppetto nods
17:08:23 <gbcox> on second thought... it's a git command, if it doesn't work then correct course would be to open a bug with bitbucket or gitlab
17:08:23 <geppetto> I'm +1
17:08:43 <orionp> Yeah, this just seems like git cli stuff
17:08:47 <orionp> +1
17:09:03 <orionp> even EL6 git should support it
17:09:18 <gbcox> yup
17:10:48 <tomspur> Is there a difference between --recursive and --recurse-submodules ?
17:11:01 <tomspur> Seems the same, just want to double check
17:12:03 <orionp> looks like an alias
17:12:21 <orionp> according to man git-clone
17:12:47 <orionp> not present in git 1.7.1 (el6) , but it's a better name
17:13:20 <geppetto> so --recurse-submodules is in el6 git?
17:13:37 <orionp> no, it isn't
17:13:44 <geppetto> ahh
17:14:17 <tomspur> If a repo doesn't contain a submodule "--recursive" just does nothing.
17:14:20 <orionp> But I think we can assume most people aren't building packages on el6
17:14:23 <tomspur> I'm also +1
17:14:33 <tibbs> If it works, I'm fine with it.  I don't really see the point, but if it's been tested and working then fine.
17:14:51 * geppetto nods
17:14:57 <tibbs> This is just for generating tarballs and doesn't get into the spec do I don't particularly think EL6 compat matters.
17:14:58 <geppetto> So we're at +3 now
17:15:25 <Rathann> hi
17:15:31 <Rathann> sorry for being late
17:15:35 <tibbs> At least I would assume that someone doing packaging would have access to something from this decade.
17:16:02 <geppetto> #chair Rathann
17:16:02 <zodbot> Current chairs: Rathann geppetto mbooth orionp racor tibbs tomspur
17:16:34 <geppetto> Rathann: Only looking at comment 10 onwards of 547
17:17:32 <mbooth> I'm +1 too
17:18:05 <racor> I've never used git submodules, but what you say seems sound to me: +1
17:18:45 <geppetto> Ok, we're at +5 now … want to vote for the record Rathann and tibbs ?
17:18:47 <Rathann> +1
17:19:30 <tibbs> Oh, sorry, I forgot to type the +1.
17:19:54 <geppetto> :)
17:20:31 <geppetto> #action SourceURL addition/clarification - Submodules (+1:7, 0:0, -1:0)
17:21:07 <geppetto> #topic #583 Node.js Guideline Addition
17:21:15 <geppetto> .fpc 583
17:21:16 <zodbot> geppetto: #583 (Node.js Guideline Addition) – fpc - https://fedorahosted.org/fpc/ticket/583
17:21:19 <geppetto> https://fedorahosted.org/fpc/ticket/583
17:21:42 <geppetto> I know nothing about JS or nodejs … but this seemed pretty trivial to me
17:21:48 <tibbs> Seems reasonable to me.
17:21:56 <orionp> +1
17:21:58 <tibbs> I mean if you can't load the thing....
17:22:16 <tibbs> But then you could do the same for pretty much any interpreted language.
17:22:30 <tibbs> Which isn't actually a bad idea, I guess, but not really in scope.
17:22:33 <tibbs> +1
17:23:54 <tomspur> +1 in general, just thinking where to put it. %check is already mentioned in another context there: https://fedoraproject.org/wiki/Packaging:Node.js#.25check
17:24:40 <tomspur> So possibly below %install
17:25:14 <Rathann> yes, +1
17:25:49 <Rathann> this does mean that all Requires: are also BuildRequires:
17:26:07 <Rathann> not sure if that's the intended effect
17:26:41 <Rathann> so I'd say s/MUST/SHOULD/
17:26:42 <geppetto> Yeh, I guess
17:27:09 <tibbs> Rathann: That's already the case with nodejs anyway, as I understand things.
17:27:13 <Rathann> ok
17:27:17 <Rathann> +1 anyway
17:27:41 <geppetto> +1
17:27:56 <geppetto> Ok, that's +5
17:28:03 <racor> +1
17:28:12 <tomspur> Having fewer BuildRequires is not advantage enough to get fewer testing...
17:28:20 <geppetto> Vote for the record, mbooth ?
17:28:42 <geppetto> It might be nice if we had a CheckRequires too
17:28:45 <tibbs> tomspur: I agree.
17:28:45 <mbooth> Oops, sorry, got distracted
17:28:52 <geppetto> But meh
17:29:02 <tibbs> The only real issue there would be cyclical build dependencies.
17:29:56 <mbooth> Eh, +1, for the record
17:30:42 <geppetto> #action Node.js Guideline Addition, to do loads in %check (+1:7, 0:0, -1:0)
17:31:35 <geppetto> #topic Open Floor
17:31:45 <geppetto> Ok, it doesn't look like much has happened on the older tickets
17:32:11 <geppetto> FWIW 566 (filetriggers) also stuck behind a couple of bugs
17:33:52 <geppetto> Anything anyone else wants to bring up?
17:34:17 <Rathann> nothing from me this week
17:34:24 <tomspur> There is a badge for being member of FESCo, how about asking for a FPC one?
17:34:50 <Rathann> I guess we're cancelling the next two meetings as they fall on Christmas Eve and New Year's Eve
17:35:03 <geppetto> Yeh
17:35:24 <geppetto> Unless there'4 four of you that really want to be here on New Yers eve, at which point I could make that
17:35:49 <orionp> If epel wanted to allow EPEL only packages installed into different prefixes, would that have to go through the FPC
17:36:52 <geppetto> maybe
17:39:21 <orionp> hmm
17:39:24 <orionp> :)
17:40:14 <geppetto> #endmeeting