serversig
LOGS
16:00:12 <sgallagh> #startmeeting Server SIG Weekly Meeting (2015-12-01)
16:00:12 <zodbot> Meeting started Tue Dec  1 16:00:12 2015 UTC.  The chair is sgallagh. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:12 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:00:12 <zodbot> The meeting name has been set to 'server_sig_weekly_meeting_(2015-12-01)'
16:00:12 <sgallagh> #meetingname ServerSIG
16:00:12 <sgallagh> #chair sgallagh mizmo nirik stefw adamw simo danofsatx mhayden jds2001
16:00:13 <sgallagh> #topic roll call
16:00:13 <zodbot> The meeting name has been set to 'serversig'
16:00:13 <zodbot> Current chairs: adamw danofsatx jds2001 mhayden mizmo nirik sgallagh simo stefw
16:00:26 <nirik> morning
16:00:29 <sgallagh> .hello sgallagh
16:00:30 <zodbot> sgallagh: sgallagh 'Stephen Gallagher' <sgallagh@redhat.com>
16:01:31 <mhayden> .hello mhayden
16:01:31 <zodbot> mhayden: mhayden 'Major Hayden' <major@mhtx.net>
16:03:51 * nirik guesses everyone else is in a turkey coma.
16:05:11 <sgallagh> Tryptophan poisoning was the cited excuse in the rolekit meeting this morning
16:05:30 <sgallagh> I'll wait a few more minutes to see if people filter in
16:06:21 <mhayden> hah
16:07:11 * jsmith is tied up in other meetings :-(
16:08:38 <adamw> ahoy
16:08:42 * adamw was making pancakes
16:08:48 <adamw> top tip: marmalade and nutella
16:09:04 <adamw> .hello adamwill
16:09:05 <zodbot> adamw: adamwill 'Adam Williamson' <awilliam@redhat.com>
16:09:14 <sgallagh> adamw: Sounds delightful, but we have nut allergies in my household :(
16:10:09 <adamw> sgallagh: damnit, nutella is worth the odd restricted airway.
16:11:26 <sgallagh> OK, it's been ten minutes and while we don't really have quorum, I don't think we're debating anything problematic.
16:11:37 <sgallagh> #info No quorum, but proceeding anyway
16:11:41 <sgallagh> #topic Agenda
16:11:45 <danofsatx> I just got here, sorry
16:11:45 <sgallagh> #info Agenda Topic: Server/Cloud Interaction
16:11:45 <sgallagh> #info Agenda Topic: Trimming the DVD
16:11:53 <sgallagh> #info Quorum achieved.
16:12:07 <danofsatx> \o/
16:12:11 <adamw> ooh, achievement!
16:12:54 <mhayden> i like achieving things
16:13:14 <sgallagh> mhayden: What does it feel like? I've long since forgotten
16:13:23 <sgallagh> Joking aside: any other agenda items?
16:13:27 <adamw> it's kind of like drinking
16:13:48 <danofsatx> but not nearly as entertaining
16:14:26 <sgallagh> OK, moving on
16:14:30 <sgallagh> #topic Server/Cloud Interaction
16:14:46 <sgallagh> mhayden: jds2001 couldn't make it today, so I guess you're on the hook for status here.
16:14:53 <mhayden> so jds2001 and i are setting up some time to plan this thing out
16:14:58 <sgallagh> /me pries the bus off of mhayden
16:15:10 <mhayden> i've had some initial discussions with dusty mabe on this topic and he's all ears
16:15:38 <mhayden> and i think part of the confusion in the user community is around cattle vs. pets in virtualized envieonments
16:15:46 <mhayden> for example, some folks prefer Fedora Server in their VM's
16:15:46 <sgallagh> ok
16:15:53 <mhayden> while others prefer Fedora Cloud
16:16:09 <mhayden> and some people are staunchly fighting for one or the other while other folks don't really care strongly
16:16:51 <mhayden> but, seeing that a cloud instance at AWS/RAX/elsewhere is essentially a server, the interaction between both groups should be good
16:17:23 <mhayden> so jds2001 and i will sync up on those touch points and find a way to collaborate and keep the users informed on which workloads might work better on Fedora Server/Cloud
16:17:36 <sgallagh> Right, so we should be advertising the differences based on use-case rather than ideology, I think
16:17:43 <sgallagh> Right, exactly
16:17:48 <mhayden> full disclosure, i work for rackspace
16:18:05 <mhayden> and our customers typically want a server-ish experience, especially those with dedicated envs
16:18:14 <sgallagh> /me grabs his torch and pitchfork :-P
16:18:16 <nirik> so the idea would be to show when you should use each, rather than trying to converge them into one thing?
16:18:25 * danofsatx grabs the rope
16:18:30 <mhayden> nirik: i think so -- there are good use cases for each
16:18:55 <mhayden> and the cloud folks are doing some interesting work with atomic/containers/docker/rocket/container_tech_of_the_week
16:18:57 <nirik> yeah. They are pretty similar, but yeah, may not be able to converge them without sacrifices.
16:20:17 <sgallagh> So the subtext here is that we should consider whether we're going to produce a full Server image for the various services or if we're going to explore moving the adopt-your-cattle script into cloud-init
16:20:55 <mhayden> hah, possibly
16:21:58 <sgallagh> #info General agreement that Cloud and Server should remain individual offerings
16:22:20 <sgallagh> #info Marketing focus should be on workloads/use-cases
16:22:46 <mhayden> more to come from jds2001 and i
16:23:40 <sgallagh> #action mhayden and jds2001 to continue investigation here
16:23:45 <sgallagh> Thanks for the update
16:23:54 <sgallagh> #topic Trimming the DVD
16:24:18 <sgallagh> While many of us in the US are busy "trimming the tree", we in the Server SIG should consider...
16:24:36 <adamw> nice segue.
16:24:40 <sgallagh> Thanks
16:24:43 <nirik> ha
16:25:05 <sgallagh> Last week we addressed the default installation
16:25:08 <nirik> related, there's a bunch of old junk in comps... when/if I get time I am planning on cleaning it out.
16:25:33 <sgallagh> This week, I think we should address which pieces of the optional bits on the DVD we don't really care about.
16:25:55 <danofsatx> how long did you work on that one, sgallagh?
16:26:12 <sgallagh> There's a lot of content there that's present because of the old Fedora tradition of "if there's room and someone might need it, stick it on the DVD"
16:26:47 <sgallagh> But in reality, the set on the DVD *never* perfectly matches anyone's preferred set of packages.
16:26:54 <nirik> right
16:27:05 <sgallagh> So real-world deployments always have to use either the mirror network or a local mirror to supplement it anway
16:27:34 <mhayden> should the DVD keep getting produced? (just tossing that out there as food for thought)
16:27:40 <sgallagh> So my thought is that we should trim a lot of the excess off of the DVD and get it down basically to just the default install plus optional hardware enablement and role support files.
16:28:48 <sgallagh> mhayden: That's a fair question. I personally still see some value in having something that can be burned to physical media, but I'm open to arguments that it's a waste.
16:28:51 <adamw> i think we already went down the 'should we get rid of the DVD' path, didn't we?
16:28:53 <danofsatx> mhayden: yes, it should.
16:29:16 <sgallagh> In my experience, having the DVD makes it easier to do testing at least, since I don't have to set up a local mirror to produce new VMs
16:29:16 <nirik> I think there's some cases where it's useful, but I wish we had a way to tell for how many people... ;(
16:29:25 <mhayden> i can see it being valuable for systems that are not on a great internet connection
16:29:48 <danofsatx> or on any internet connection (see the many military installations in town for reference)
16:29:48 <sgallagh> mhayden: I'm trying to minimize that argument.
16:30:11 <sgallagh> Mostly because it still needs to be on a decent intranet connection at least to do anything truly useful
16:30:21 <mhayden> my use for the DVD in the past has been to explode it into a directory structure for PXE installs
16:30:32 <sgallagh> danofsatx: I think those are the cases where a local mirror should be assumed
16:30:52 <sgallagh> mhayden: Incidentally, would you mind writing up a HOWTO blog or something on that
16:31:00 <sgallagh> That would be great documentation to have.
16:31:01 <danofsatx> agreed, but not always. I had to build my own in order to get one.
16:31:24 <nirik> sgallagh: I think it's still in the install guide? or did it get dropped?
16:31:29 <sgallagh> danofsatx: I didn't mean assumed to already be present. Just assumed that such a thing was necessary in that environment
16:31:42 <sgallagh> nirik: Oh, is it? I guess I missed that section.
16:32:02 <nirik> https://docs.fedoraproject.org/en-US/Fedora/23/html-single/Installation_Guide/index.html#pxe-overview
16:32:19 <sgallagh> You're right. Mea culpa.
16:32:26 <sgallagh> I should really read our docs one of these days.
16:33:27 <sgallagh> OK, so https://git.fedorahosted.org/cgit/spin-kickstarts.git/tree/fedora-install-server.ks includes the set of package groups we put on the DVD.
16:34:00 <sgallagh> Actually, starts at https://git.fedorahosted.org/cgit/spin-kickstarts.git/tree/fedora-install-server.ks#n87
16:35:32 <sgallagh> My proposal is to basically drop everything from line 87 down except for @sql-server, @freeipa-server, @smb-server and @virtualization-headless
16:36:12 <sgallagh> Oh, and @web-server
16:37:04 <sgallagh> Thoughts? Arguments? Rotten tomatoes?
16:37:10 <adamw> we'll want to keep ansible-node.
16:37:57 <sgallagh> adamw: That's going to become a dep of the fedora-release-server package
16:38:04 * nirik is ok with that... we will want to make sure to get feedback from people in the alpha/beta cycles about it.
16:38:04 <sgallagh> Or, no it's not
16:38:05 <sgallagh> Sorry
16:38:29 <sgallagh> adamw: Yeah, I'll make sure that's present explicitly.
16:39:27 <sgallagh> nirik: Do you know at what point we'll start getting test composes, BTW?
16:39:51 <nirik> well, we have rawhide now... if dracut would stop breaking everything
16:40:00 <adamw> sgallagh: we usually start at branch point.
16:40:19 <sgallagh> nirik: Right, but we're not producing nightly artifacts except the boot.iso, right?
16:40:23 <adamw> which is feb 2nd.
16:40:25 <nirik> but there's still plans to get daily full composes, just not sure how far along that is.
16:40:34 <sgallagh> ok
16:40:39 <nirik> boot iso and live and appliances.
16:40:52 <nirik> but hopefully we can add trees and dvd images and everything else.
16:41:17 <sgallagh> danofsatx, mhayden: any opinion on this plan?
16:41:48 <sgallagh> If we're generally in favor of this, I'll get the spin-kickstart changes in today.
16:42:06 * adamw is fine with it.
16:42:14 * nirik is ok with it
16:42:14 <mhayden> i'm okay with it
16:42:20 <mhayden> i'm curious to see how much the disk usage changes
16:43:38 <sgallagh> mhayden: Yeah, I'm not really sure. I suspect that the lion's share of the usage is still held by FreeIPA and its dependencies.
16:43:46 <sgallagh> (Particularly Dogtag)
16:43:50 <mhayden> oh yeah
16:43:55 <mhayden> there be dragons ;)
16:44:09 <sgallagh> Dogtag at least is working on eliminating the full java requirement and getting back to java-headless
16:44:12 <sgallagh> Which should help some
16:44:25 <mhayden> i unfortunately need to scoot
16:44:30 <mhayden> but i'm okay with the change proposed
16:44:51 <sgallagh> OK, then I'll go ahead and have at it, I think
16:45:43 <sgallagh> Of course, the flip side of the FreeIPA issue is that we *may* in Fedora 24 be converting over to using FreeIPA as a container instead of RPMs. So we might be able to get that off the disk too.
16:45:47 <sgallagh> More on that at a future meeting.
16:47:16 <sgallagh> #action sgallagh to remove most of the package groups from the Server DVD except for the web-server, FreeIPA, Samba, Virtualization, Ansible bits and hardware enablement.
16:47:53 <sgallagh> I'm also hopeful that FreeIPA will finish shedding its Python 2 deps this cycle, but that might stick around until F25.
16:48:33 <sgallagh> #topic Open Floor
16:48:42 <sgallagh> Any other topics for the remaining 12 minutes?
16:48:43 <danofsatx> +1 for plan
16:48:50 * danofsatx late to the party again
16:48:57 * nirik has no items
16:50:21 <sgallagh> OK, thanks for coming, folks.
16:50:32 <sgallagh> I appreciate your Service.
16:51:02 <sgallagh> #endmeeting