fpc
LOGS
16:00:19 <geppetto> #startmeeting fpc
16:00:19 <zodbot> Meeting started Thu Oct 29 16:00:19 2015 UTC.  The chair is geppetto. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:19 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:00:19 <geppetto> #meetingname fpc
16:00:19 <geppetto> #topic Roll Call
16:00:19 <zodbot> The meeting name has been set to 'fpc'
16:00:27 <geppetto> geppetto limburgher mbooth orionp racor Rathann SmootherFr0gZ tibbs|w tomspur: FPC ping
16:00:32 <orionp> hello
16:00:34 <tomspur> hi
16:00:37 <mbooth> Hey
16:00:39 <geppetto> #chair orionp
16:00:39 <zodbot> Current chairs: geppetto orionp
16:00:41 <geppetto> #chair tomspur
16:00:41 <zodbot> Current chairs: geppetto orionp tomspur
16:00:43 <geppetto> #chair mbooth
16:00:43 <zodbot> Current chairs: geppetto mbooth orionp tomspur
16:00:52 <geppetto> #chair tibbs
16:00:52 <zodbot> Current chairs: geppetto mbooth orionp tibbs tomspur
16:00:58 <tibbs|w> Howdy.
16:05:17 <tibbs|w> We do have five.
16:05:30 <geppetto> yeh
16:05:38 <geppetto> usually wait until 5 past though
16:05:47 <geppetto> racor and Rathann often get here
16:05:55 <geppetto> We can start though
16:06:06 <tomspur> We might have a daylight saving issue again... ;)
16:06:10 <tibbs|w> Of course.
16:06:28 <geppetto> Yeh, most of .eu off by one hour for a couple of weeks
16:06:32 <geppetto> stupid timezones
16:06:40 <geppetto> #topic Schedule
16:06:42 <geppetto> https://lists.fedoraproject.org/pipermail/packaging/2015-October/011073.html
16:06:46 <tibbs|w> My general attitude is to make it easy for Europe since it's our government which made this stupidity.
16:06:55 <geppetto> #topic #577 	Update references to SysV Init scripts
16:06:55 <geppetto> .fpc 577
16:06:55 <geppetto> https://fedorahosted.org/fpc/ticket/577
16:06:56 <zodbot> geppetto: #577 (Update references to SysV Init scripts) – fpc - https://fedorahosted.org/fpc/ticket/577
16:06:56 <tibbs|w> Where "our" is the US.
16:07:12 <geppetto> Well it's only this week and next IIRC
16:07:27 * mbooth doesn't mind -- my calendar is smart enough to compensate ;-)
16:07:37 <tibbs|w> So, I'm good with this.  Probably the easiest thing for 577 is to let me loose to clean that stuff up.
16:07:41 <geppetto> But we could try moving it if everyone wants to?
16:07:57 <geppetto> Yeh, I'm +1
16:07:59 * tomspur is using fedocal and apparently it worked this week :)
16:08:25 <tibbs|w> Oh, did EU change their times already?  I just can't keep track,
16:08:36 <geppetto> .eu changed back one hour
16:08:47 <geppetto> but the schedule is based on 12:00 EST
16:08:49 <sgallagh> tibbs|w: Have at it. I was just trying to reduce your workload a bit, but I'm perfectly happy having you take over :)
16:08:53 * racor is here, sorry, for being late - DST changed ;)
16:09:00 <geppetto> #chair racor
16:09:00 <zodbot> Current chairs: geppetto mbooth orionp racor tibbs tomspur
16:09:09 <geppetto> racor: Yeh, we guessed … see above :)
16:09:23 <geppetto> Ahh, you can't … lots of messages about how timezones are stupid :)
16:09:27 <tibbs|w> Hmm, I have this appointment in my calendar in UTC.
16:09:31 <racor> yep, EU changed time ;)
16:09:51 <tibbs|w> Online I generally just live in UTC.
16:11:07 <tibbs|w> So, my plan for 577 is outlined in the ticket: just add language that initscripts are forbidden, remove all references to them from the guidelines and copy the relevant stuff over to EPEL.
16:11:39 <mbooth> I'm happy with that
16:11:42 <geppetto> yeh, we used to … but we've historically followed .us time … so that made it a pain, and IIRC tomspur found a way to set the time in New York time … so that solved it
16:11:44 <geppetto> Anyway …
16:11:59 <geppetto> Anyone else want to vote on tibbs cleaning up 577?
16:12:06 <tibbs|w> sgallagh basically indicated the stuff which needs to change, though I found a couple of other links and stuff.
16:12:07 <orionp> +1
16:12:09 <tibbs|w> +1
16:12:37 <tomspur> +1
16:12:41 <tibbs|w> This is basically reflecting reality in any case since FESCo has completely banned the things.
16:13:00 * geppetto nods
16:13:33 <tibbs|w> Which which I'm completely in agreement, not that it makes much difference.
16:14:02 <mbooth> +1, embrace the future
16:14:16 <tibbs|w> The future's so bright....
16:14:37 <sgallagh> It's full of stars!
16:14:59 <tibbs|w> Mixing references, there.
16:15:17 <sgallagh> You talkin' to me?
16:15:23 <tibbs|w> Yep.
16:15:32 <sgallagh> (That was another mixed reference)
16:15:35 <tibbs|w> Anyway, that's +5, so I'll add it to my list.
16:16:14 <tibbs|w> I really need to clean up my list.  If only I could stop vacationing.
16:16:33 <racor> +1, was reading the ticket.
16:16:37 <geppetto> #action tibbs Cleanup policy wrt sysV init scripts. (+1:5, 0:0, -1:0)
16:16:40 <geppetto> #undo
16:16:40 <zodbot> Removing item from minutes: ACTION by geppetto at 16:16:37 : tibbs Cleanup policy wrt sysV init scripts. (+1:5, 0:0, -1:0)
16:16:43 <geppetto> #action tibbs Cleanup policy wrt sysV init scripts. (+1:6, 0:0, -1:0)
16:17:35 <geppetto> tibbs: You know if anything was voted on in yesterdays fesco meeting, for 575?
16:18:19 <tibbs|w> I've zero idea, but sgallagh might.
16:18:55 <tibbs|w> I do think I should close the ticket once I actually finish writing it up.  I thought I had, but I seem to have stopped in the middle.
16:18:59 <sgallagh> tibbs|w, gepetto: No voting happened on that score.
16:19:12 <tibbs|w> If FESCo wishes to make more changes, I'm sure they'll push them down to us.
16:19:27 <tibbs|w> There are a couple of dangling links and such I need to clean up.
16:19:45 * geppetto nods
16:19:50 <sgallagh> tibbs|w: There's more investigation ongoing; probably no output from that for two weeks
16:19:58 <geppetto> #topic #575     Bundling Guidelines Overhaul
16:19:58 <geppetto> .fpc 575
16:19:58 <geppetto> https://fedorahosted.org/fpc/ticket/575
16:20:00 <zodbot> geppetto: #575 (Bundling Guidelines Overhaul) – fpc - https://fedorahosted.org/fpc/ticket/575
16:20:07 <sgallagh> (Since a bunch of people will be at the systemd conference next week)
16:20:13 <geppetto> #action Close this ticket, if something else gets voted on we can open new ones.
16:20:43 <orionp> +1
16:20:47 <geppetto> Anything to look at for 567?
16:21:14 <tibbs|w> geppetto: Do leave 575 in writeup until I finish and make the rollup anouncement.
16:21:28 <geppetto> #undo
16:21:28 <zodbot> Removing item from minutes: ACTION by geppetto at 16:20:13 : Close this ticket, if something else gets voted on we can open new ones.
16:21:48 <geppetto> #action Move this ticket to writeup, and then close, if something else gets voted on we can open new ones.
16:21:53 <geppetto> There ya go :)
16:22:12 <tibbs|w> For 567, we're getting close I think.  orionp and tomspur did a bunch of stuff while I was away and that branched is merged in now.
16:22:12 <geppetto> #topic #567     Packaging Python 3 applications and modules for EPEL 7+
16:22:13 <geppetto> .fpc 567
16:22:13 <geppetto> https://fedorahosted.org/fpc/ticket/567
16:22:14 <zodbot> geppetto: #567 (Packaging Python 3 applications and modules for EPEL 7+) – fpc - https://fedorahosted.org/fpc/ticket/567
16:22:40 <geppetto> Anything we need to talk about or vote on?
16:22:51 <tibbs|w> But this isn't blocking anything so we're trying to be very careful instead of just hacking something.
16:23:16 <tibbs|w> Nothing to vote upon at this time as far as I can tell.  Just that things are progressing.
16:23:52 <tibbs|w> I also rewrote spectool so that it actually works when you use any remotely complex macro in Source: or Patch:.
16:24:10 <geppetto> yeh, have you tried to ship that anywhere atm?
16:24:20 <tibbs|w> Spectool?  Not yet.
16:24:32 <tibbs|w> Haven't had the cycles and I'm still cleaning it up.
16:25:12 <tibbs|w> Plus as usual I wrote it in python3 and now I have to see if I'll have to make it work in EL5 or something.
16:25:21 <geppetto> :)
16:25:49 <tibbs|w> I don't have a lot of confidence that upstream would take it regardless of what I do.
16:26:08 <tibbs|w> But it's worth a try anyway.
16:27:28 <tibbs|w> Anyway, that's it for 567 unless tomspur or orionp have anything to add.
16:27:47 <orionp> nope, been too busy
16:27:58 <tomspur> Same here.
16:28:58 <tibbs|w> I hope to be able to do some proper testing and package conversion soon, as well as illustrate what the guidelines would look like were this in production.
16:29:25 <geppetto> ok
16:29:35 <geppetto> That's probably it then …
16:29:42 <geppetto> #topic Open Floor
16:29:50 <geppetto> Anything anyone else wants to talk about?
16:30:19 * tomspur tries to remember the discussion on the devel list about BR: python3-devel
16:30:39 <tibbs|w> That's a simple one.  The change he asked for isn't valid currently.
16:30:53 <tibbs|w> You need python-* devel for the macros which are currently in our guidelines.
16:31:02 <tomspur> I think it was prefered to just have a BR on some pythonX, but I think that always having a BR on the -devel is a feature and not a bug
16:31:43 <tomspur> If you build something, you should BR the -devel package consistently, no matter if it is python or perl or whatever
16:31:46 <tibbs|w> Currently it doesn't matter, but I want to get the macros out of the python package so that at least won't be the reason you have to require python*-devel.
16:32:04 <tibbs|w> I don't have an opinion one way or the other after that.
16:33:12 <tibbs|w> I don't see why our guidelines would require dependencies which aren't strictly necessary to build the package, but I agree that it's just simpler to tell people to use devel.
16:33:36 <tomspur> Seems like noarch packages can BR python and others python-devel. Having one if less in the guidelines makes it much clearer
16:33:41 <tibbs|w> Still, it's obvious when you would need to do so; if your package is noarch, you wouldn't need devel.
16:34:12 <tibbs|w> It's just one sentence anyway, and if you get it wrong your package doesn't build so it's not like we'd have to enforce it somehow.
16:34:14 <mbooth> Well, the guidelines as written right now are correct, right? You need pythonX-devel in order for macros to work
16:34:22 <tibbs|w> mbooth: Yes, that is the current state.
16:34:49 <mbooth> So no need to change anything then... Sounds just like a misconception from a concerned party
16:35:19 <tibbs|w> Indeed.  Though I think it's a reasonable goal.
16:35:29 <tibbs|w> But there's nothing for us to do currently.
16:35:50 <tibbs|w> Anyway, there was a bit of talk about file triggers this morning.
16:36:20 <tibbs|w> geppetto: Did you still have that list of packages which currently implement them?
16:36:47 <tibbs|w> I don't even remember how to check currently.
16:37:43 <geppetto> Yeh, I have a complete checkout of fedora package git
16:37:47 <geppetto> and grep over it
16:37:58 <tomspur> How bit is that?
16:38:01 <tomspur> big*
16:38:04 <geppetto> I'm not sure the talk this morning was really file trigger related
16:38:07 <tibbs|w> You can just download the checckout seed, though.
16:38:11 <geppetto> as much as dnf being different related
16:38:14 <tibbs|w> geppetto: And it sort of was, sort of wasn't.
16:38:27 <tibbs|w> Debugging these things is less fun.
16:38:51 <geppetto> I'm not sure, it depends if dnf has different behaviour for %pre
16:38:54 <tibbs|w> The triggers aren't installed as files, right?  Do you can't do a repoquery to find them.
16:39:24 <geppetto> No, you have to use rpm -q --scripts, and/or grep on the specfiles
16:39:36 <tibbs|w> The issue this morning was about something that used to run in %post, but now I believe is a file trigger that runs after installation.
16:39:37 <geppetto> --scriptlets, even
16:39:46 <tibbs|w> Damn, that's kind of annoying.
16:40:14 <tibbs|w> rpm must at least store these somewhere, but you'd still have to have the relevant packages installed.
16:40:27 <tibbs|w> I think we'd need to try and keep a list somewhere, at least for the major ones.
16:40:53 <geppetto> One thing I did think about was putting in policy to have them all be a single line that ran something in /var/lib/rpm-filetriggers or something … it seemed like a good idea, to me … but I'm not sure how much hate I'd get for suggesting it :)
16:41:14 <tibbs|w> Zero hate from me, assuming that's actually possible.
16:41:21 <tibbs|w> Are you still tasked with working on this?
16:41:27 <geppetto> Yeh
16:41:52 <geppetto> other stuff and holidays getting in the way
16:42:05 <geppetto> But anytime now(tm) :)
16:42:07 <tibbs|w> Welcome to the club.
16:42:29 <tibbs|w> But I'd think we could at least get ldconfig done before F24 branches.
16:42:50 <geppetto> 5.8G for a full distgit
16:43:09 <geppetto> that doesn't include "source" though, so just specfiles and patches
16:43:27 <tibbs|w> A shallow checkout should be much smaller.
16:43:34 <tomspur> Quite a bit to "git pull"...
16:43:42 <tibbs|w> You don't need to pull it.
16:43:47 <tibbs|w> Just download the checkout seed.
16:43:57 <geppetto> Yeh, but getting and upgrade is much faster now
16:44:02 <geppetto> http://paste.fedoraproject.org/284890/44613700/
16:44:04 <tibbs|w> I'm going to propose to releng that in addition to generating that seed, they pull out the specs.
16:44:11 <geppetto> That's the current filetrigger usage
16:44:21 <tibbs|w> fpaste is slow today....
16:44:53 <geppetto> "fgrep filetrig */*.spec" … which will get everythign AFAIK
16:44:53 <tomspur> A checkout to directly grep on fedorapeople would also be a nice feature
16:45:11 <tibbs|w> That's a nice idea, actually.
16:45:17 * geppetto nods
16:45:35 <tibbs|w> I'm not sure if I can do that directly on pkgs.
16:45:35 <tomspur> iiuc they are in different datacenters, so it's not so easy possible
16:45:39 <tomspur> But maybe that changed
16:46:00 <geppetto> Could use the script I wrote to get mine, should be network happy ;)
16:47:24 <tibbs|w> Nope, can't do that on pkgs; it has the repos but they're not checked out.
16:48:32 <tibbs|w> Ah, but there is a complete checkout there as well.
16:48:43 <tibbs|w> Anyway, I'll ask the folks if it's feasible.
16:49:14 <tibbs|w> Looks like I have about two hours to work on FPC stuff just after the meeting, so I'm going to get to it.
16:49:42 * geppetto nods, cool.
16:49:49 <geppetto> Ok, I'll close in a minute or so then
16:50:03 <geppetto> Oh, one note before we go
16:50:09 <geppetto> I won't be here next Thursday.
16:50:14 * geppetto almost forgot :-o
16:50:32 <geppetto> So we can cancel the meeting, or tibbs could run it?
16:51:02 <geppetto> It should be fine to cnacel it if everyone would prefer, as we don't really have a backlog anymore.
16:51:16 <geppetto> Anyway, something to think about.
16:51:17 <mbooth> geppetto: Either is fine by me. Have a good time not being here :-)
16:51:27 <geppetto> :)
16:51:39 <tibbs|w> I'm actually leaving town next Thursday as well.
16:51:54 <tibbs|w> Though I _might_ be able to be around at meeting time.
16:52:10 <racor> FWIW: I'll probably also not be available next Thursday.
16:52:14 <mbooth> Heh
16:52:21 <mbooth> Probably won't get quorum anyway
16:52:42 <tibbs|w> Could possibly run it, assuming we actually have anything to cover.  If it's just a couple of non-urgent tickets then I guess we'll cancel then.
16:52:58 <tibbs|w> BTW, do we need to do anything about DST?
16:53:20 <tibbs|w> I guess not since everyone will be synchronized this weekend.
16:53:27 <mbooth> tibbs|w: I'd say not
16:53:33 <geppetto> I think it's next, but yeh … I think it'll just work
16:54:00 <tibbs|w> I would still like to see if there's any time which would allow us to get the folks who are rarely here.
16:54:08 * geppetto nods
16:54:24 <tibbs|w> We're basically running a committee with seven people but requiring a quorum of five.
16:55:35 * geppetto nods
16:55:47 <tibbs|w> I don't know if they can't attend due to the meeting time, or if there's something else going on.
16:57:31 <geppetto> Yeh, I think some of them just have a bunch of work
16:57:36 <tibbs|w> I know limb has a work situation, though he's still active elsewhere in Fedora.  I know Xavier/laxathom/SmootherFrOgZ is still around as well but he's in CET.
16:57:41 <geppetto> So would be better to just get new people
16:57:48 <tibbs|w> We get everyone else occasionally.
16:57:59 <geppetto> I don't remember seeing Xavier for a long time
16:58:06 <tibbs|w> He was at flock.
16:58:17 <geppetto> Yeh, I meant at the meetings
16:58:26 <tibbs|w> Yeah, it's been a while.
16:58:35 <tibbs|w> Obviously Rathann is bouncing.
16:58:51 <Rathann> hi
16:58:54 <tibbs|w> Can someone ping them politely and see if there's any way we can accommodate them?
16:58:56 <geppetto> Hey, DST ftw :)
16:59:07 <Rathann> darn, I guess my calendar forgot about DST
16:59:39 <tibbs|w> Well, unless you put the meeting in for the New York timezone you wouldn't have noticed.
16:59:56 <SmootherFrOgZ> hey, sorry in the middle of something right now :/. please don't hesitate to ping me like tibbs|w just did
17:00:25 <tibbs|w> SmootherFrOgZ: We're just wondering if there's a better meeting time for you.
17:00:31 <tibbs|w> I guess we can go to whenisgood.com again.
17:00:40 <tibbs|w> Sorry, whenisgood.net
17:00:51 * tomspur uses the ical of https://apps.fedoraproject.org/calendar/packaging/
17:01:00 * Rathann edits the entry and sets TZ to UTC
17:01:12 <SmootherFrOgZ> yeah. this time usually fit but we had some urgent task this last month :(
17:01:12 <tibbs|w> Rathann: Except it's not UTC.
17:01:23 <tibbs|w> SmootherFrOgZ: Cool.
17:01:24 <SmootherFrOgZ> @ work
17:01:35 <tibbs|w> And I don't think we can do anything about limb's situation.
17:02:55 <tibbs|w> So I guess there's not much to do.
17:04:22 <tibbs|w> Let's see if I can get that ical thing into google.
17:05:05 <tibbs|w> Cool, that worked.
17:05:20 <tibbs|w> Anyway, I'm going to get started on guidelines and then python macros.
17:05:29 <tibbs|w> Hope everyone has a fun Halloween if you're into that.
17:05:38 <tibbs|w> (Christmas without the drama for me.)
17:06:44 <geppetto> :)
17:06:54 <geppetto> Yeh, give candy out … see happy children :)
17:07:10 <geppetto> Ok, see you all in a couple of weeks
17:07:16 <geppetto> #endmeeting