fpc
LOGS
16:01:28 <geppetto> #startmeeting fpc
16:01:28 <zodbot> Meeting started Thu Oct 15 16:01:28 2015 UTC.  The chair is geppetto. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:01:28 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:01:28 <geppetto> #meetingname fpc
16:01:28 <geppetto> #topic Roll Call
16:01:28 <zodbot> The meeting name has been set to 'fpc'
16:01:42 <tomspur> Hi
16:01:46 <geppetto> #chair tomspur
16:01:46 <zodbot> Current chairs: geppetto tomspur
16:02:15 <geppetto> Hmm, no tibbs this week
16:02:19 <orionp> hello
16:02:23 <geppetto> #chair orionp
16:02:23 <zodbot> Current chairs: geppetto orionp tomspur
16:02:35 * tomspur will be missing next week
16:02:41 <mbooth> Hi
16:02:50 <geppetto> limburgher racor Rathann SmootherFr0gZ: FPC ping
16:02:53 <geppetto> #chair mbooth
16:02:53 <zodbot> Current chairs: geppetto mbooth orionp tomspur
16:02:56 <mbooth> I might need to duck out early though
16:03:19 * geppetto nods
16:03:25 <Rathann> hi
16:03:29 <geppetto> #chair Rathann
16:03:29 <zodbot> Current chairs: Rathann geppetto mbooth orionp tomspur
16:04:29 <geppetto> #topic Schedule
16:04:31 <geppetto> https://lists.fedoraproject.org/pipermail/packaging/2015-October/011063.html
16:04:40 <geppetto> #topic #563 	PYTHON_PATH in MPI modules
16:04:41 <geppetto> .fpc 563
16:04:41 <geppetto> https://fedorahosted.org/fpc/ticket/563
16:04:42 <zodbot> geppetto: #563 (PYTHON_PATH in MPI modules) – fpc - https://fedorahosted.org/fpc/ticket/563
16:05:04 <geppetto> tomspur: This is you?
16:05:20 <geppetto> Ahh, I see the proposed changes now:
16:05:25 <geppetto> https://fedoraproject.org/w/index.php?title=User%3AZbyszek%2FMPIPackagingDraft&diff=424068&oldid=424066
16:06:10 <tomspur> It would be nice to have MPI_PYTHON_SITEARCH point to the unversioned python_sitearch. Rest seems fine
16:07:06 <Rathann> I think there's a typo in the last part:
16:07:07 <geppetto> Yeh, they just removed the old env. variable?
16:07:31 <Rathann> Automatic setting of the module loading path in python interpreters is _down_ using a .pth file [...]
16:07:42 <Rathann> shouldn't it be "is _done_" ?
16:07:48 <geppetto> Get down now, we all get down.
16:07:52 * geppetto dances
16:07:55 <tomspur> :)
16:08:57 <Rathann> maybe we should drop MPI_PYTHON_SITEARCH altogether?
16:09:02 <tomspur> Rathann: I think "is done" or maybe "is down to"? I like the former too
16:09:19 <Rathann> is done
16:09:24 <geppetto> yeh, I assume it's a typo
16:09:48 <geppetto> Rathann: They've done that, right? Having it stay and be backwards compat. doesn't seem like a bad idea to me though
16:09:49 <tomspur> I see MPI_PYTHON_SITEARCH as the macro of the /usr/bin/python version
16:09:57 <geppetto> oh
16:10:16 <orionp> But I don't think anything should be using MPI_PYTHON_SITEARCH
16:10:19 <tomspur> For now it is python2_sitearch, so python_sitearch makes more sense to me
16:10:40 <Rathann> another typo which was also in the previous version
16:10:52 <Rathann> The module file MUST prepend the MPI bindir %{_bindir}/%{name}-%{_arch}%{?_opt_cc_suffix} into the users PATH, [...]
16:11:03 <Rathann> MPI bindir is %{_libdir}/%{name}%{?_opt_cc_suffix}/bin
16:11:30 <Rathann> not %{_bindir}/%{name}...
16:11:38 * geppetto sees it now … I'm not sure what we gain by explicitly having it be python_sitearch … if the later ever changes I'm not sure we want that env. variable to change anyway
16:13:47 <tomspur> And at the directory for LD_LIBRARY_PATH should add a 'lib' at the end?
16:14:10 <orionp> I think it's time to drop the whole _cc_name_suffix - neither openmpi or mpich is using it
16:14:14 <Rathann> $MPI_BIN to PATH and $MPI_LIB to LD_LIBRARY_PATH
16:14:23 <tomspur> +1
16:14:46 <Rathann> it's better to explicitly say $MPI_BIN and $MPI_LIB instead of duplicating the values from the table
16:15:38 <Rathann> isn't _cc_name_suffix useful for RHEL where there may be two compilers in the repos?
16:16:09 <Rathann> I also don't think it's useful for Fedora itself
16:16:18 <orionp> It's actually something I requested years ago to be able to build the rpm with intel compilers
16:16:23 <geppetto> Does anyone want to try to alter these now, or do we want to just throw it back to the reporter and wait a week or 7 ;)
16:16:41 <Rathann> orionp: and have you actually used it?
16:17:04 <orionp> yes, although I'm using a different scheme now
16:17:10 <Rathann> geppetto: one minute, let me update the text
16:18:24 * Rathann wonders why he has an MPI packaging draft from 2014 under his userpage
16:19:06 <geppetto> best not to ask questions you don't want to know the answer to :)
16:25:00 <Rathann> ok, this should be Zbyszek's proposal with the fixes mentioned above
16:25:01 <Rathann> https://fedoraproject.org/w/index.php?title=User%3ARathann%2FPackaging%3AMPI%3ADraft&diff=424467&oldid=424465
16:25:09 <Rathann> except the _cc_name_suffix removal
16:25:26 <Rathann> do we want to do it now, too?
16:25:44 <Rathann> if orionp says it's no longer necessary, then I'm +1
16:25:56 <tomspur> It doesn't hurt, so I'd leave it. (Don't know where it is in use)
16:26:04 <tomspur> Sure, if it is not necessary...
16:26:08 <orionp> Yeah, let's do it - it's not in use
16:26:19 <orionp> and supposedly it's a MUST
16:27:16 <orionp> well, actuallly...
16:28:21 <orionp> It is still in place in openmpi , but %{name} becomdes openmpi%{?_cc_name_suffix}.  It doesn't need to be added to %{name}.
16:28:28 <geppetto> I'm good either way but is it fine for orion to just remove it :)
16:29:20 <tomspur> It seems it was in use with gcc34: https://fedoraproject.org/wiki/PackagingDrafts/MPI
16:30:36 <Rathann> do I drop the whole section about supporting compilation of MPI implementations with other compilers?
16:32:54 <orionp> I think it's time, yes
16:33:04 <orionp> If RHEL wants to support it, they can
16:35:42 <Rathann> https://fedoraproject.org/w/index.php?title=User%3ARathann%2FPackaging%3AMPI%3ADraft&diff=424468&oldid=424465
16:35:46 <Rathann> new diff
16:35:55 <Rathann> with _cc_name stuff removed
16:36:08 <Rathann> also dropped some extra slashes at the end of paths
16:37:16 <geppetto> Uh, lots of deletes … are we sure zbyszek is happy with this?
16:37:30 <geppetto> It looks ok to me though, assuming the changes are wanted by everyone
16:38:40 <orionp> Rathann: we want to drop the CFLAGS setting in the rpm macro
16:38:41 <Rathann> hm I believe the deletion of the example spec file is unintentional
16:39:19 <tomspur> I would not remove the MUST of the serial mode
16:39:58 <Rathann> *sigh*
16:41:08 <mbooth> Apologies, I have to leave -- but tbh I don't know enough about MPI to be helpful anyway
16:42:23 <geppetto> Ok
16:42:27 <tomspur> racor seems to be here, so we'd still be 5?
16:42:35 <geppetto> Yeh
16:42:54 <Rathann> https://fedoraproject.org/w/index.php?title=User%3ARathann%2FPackaging%3AMPI%3ADraft&diff=424469&oldid=424465
16:42:57 <geppetto> racor: You are here, right?
16:43:04 * racor is here
16:43:04 <Rathann> this is the intended change, I believe
16:43:32 <geppetto> #chair racor
16:43:32 <zodbot> Current chairs: Rathann geppetto mbooth orionp racor tomspur
16:43:39 <racor> but I am in a similar position as mbooth .... I know too little about mpi
16:44:01 <Rathann> I maintain a couple of MPI-using packages
16:44:07 <geppetto> Yeh, me too … I'm mostly trusting orionp and Rathann
16:45:03 <orionp> may be time to drop MPICH2 references
16:45:05 <tomspur> I'm on the user side of MPI
16:45:18 <Rathann> ah right
16:45:23 <Rathann> we have just mpich
16:45:48 <orionp> and lam
16:46:03 <Rathann> lam is only in EPEL5
16:46:08 <Rathann> not in Fedora
16:46:25 <Rathann> also mvapich is (EP)EL-only
16:48:32 <Rathann> I'll update the introduction
16:48:52 <orionp> lots of mpich2 references
16:49:03 <orionp> great, thanks
16:54:29 <Rathann> LAM is officially retired upstream, even
16:54:42 <orionp> yeah, openmpi replaced it years ago
16:55:06 <Rathann> ok, new draft: https://fedoraproject.org/w/index.php?title=User%3ARathann%2FPackaging%3AMPI%3ADraft&diff=424471&oldid=424465
16:56:56 <Rathann> hm I should remove all references to lam as well
16:57:07 <Rathann> not just from introduction
16:57:11 <Rathann> but that's minor
16:57:26 <orionp> looks like there is duplicate CFLAGS paragraph now
16:58:30 <tomspur> LD_LIBRARY_PATH should be prepended and not set, right?
17:00:37 <geppetto> Do we really want to get rid of "The MPI compiler RPMs <b>MUST</b> be possible to build with other compilers …"
17:01:12 <orionp> tomspur: yes
17:02:00 * geppetto shrug … everything else looks ok, as far as I know
17:02:17 <tomspur> currently LD_LIB_PATH is set according to the text
17:02:46 <Rathann> fixing the duplicate CFLAGS paragraph
17:05:33 <Rathann> actually the current MPI implementation prepend MPI_LIB to LD_LIBRARY_PATH
17:05:40 <Rathann> so I'll update that as well
17:08:43 <Rathann> hopefully final draft: https://fedoraproject.org/w/index.php?title=User%3ARathann%2FPackaging%3AMPI%3ADraft&diff=424472&oldid=424465
17:09:34 <geppetto> Same question as above … why did you decide to remove the bit about building with other compilers?
17:10:03 <geppetto> Apart from that I'm +1
17:10:12 <Rathann> if we remove the _cc_name_suffix, that part doesn't make sense anymore
17:10:25 <geppetto> Ahh
17:10:36 <geppetto> Ok, makes sense … +1 to it then
17:10:47 <Rathann> +1 from me
17:10:50 <orionp> mpich doesn't do it, Fedora doesn't use it, ...
17:10:52 <tomspur> +1
17:11:00 <tomspur> seems fine
17:11:22 <geppetto> racor: vote?
17:11:28 <orionp> +1 thanks
17:11:43 <racor> +1
17:12:31 <geppetto> #action Re-work MPI policy, PYTHON_PATH, remove _cc_name_suffix, remove old packages (+1:5, 0:0, -1:0)
17:12:53 <geppetto> #topic #576 	Add extra pari-sage package
17:12:53 <geppetto> .fpc 576
17:12:54 <geppetto> https://fedorahosted.org/fpc/ticket/576
17:12:55 <zodbot> geppetto: #576 (Add extra pari-sage package) – fpc - https://fedorahosted.org/fpc/ticket/576
17:13:30 <geppetto> So this came up … wasn't sure what to do with it … under the new policy they can just bundle everything
17:14:21 <geppetto> But they want to create a new package for the snapshot of pari they want to use
17:14:53 <geppetto> Not sure if we should say yes, or just tell them to bundle it all
17:14:58 * geppetto shrugs
17:16:14 <Rathann> actually I'd say they should bundle pari
17:16:30 <Rathann> at least they seem to have been working actively with both upstreams on unbundling
17:16:35 * geppetto nods
17:16:53 <orionp> yeah, bundling it seems to be the current way to go
17:17:03 <Rathann> if it has different SONAME and no chance of conflicting with current pari package then it's fine
17:17:08 <Rathann> which it does
17:17:27 <racor> Rathann: *-devel would conflict
17:17:31 <Rathann> right
17:18:03 <Rathann> so don't ship -devel if it's only for sagemath
17:18:14 * geppetto nods
17:18:35 <racor> Rathann: that's one possibility. Another one would be alternatives
17:18:50 <Rathann> environment modules are better
17:18:57 <Rathann> this is not system-wide
17:19:02 <geppetto> #action Under the new bundling guidelines it'll just be much easier to bundle the devel. version of pari, just don't ship the -devel files.
17:19:21 <geppetto> $topic Open Floor
17:19:24 <geppetto> #topic Open Floor
17:19:34 <geppetto> Anything anyone wants to bring up?
17:19:37 <Rathann> s/devel. version of pari/pari snapshot/
17:19:56 <geppetto> yeh
17:20:10 <Rathann> anyone want to sign up for the Unbundling SIG? ;)
17:20:35 <geppetto> I'm thinking no
17:21:56 <tomspur> I'd have a question about the general provides: https://bugzilla.redhat.com/show_bug.cgi?id=1271776
17:22:01 <Rathann> I believe everyone on FPC should chime in on https://fedorahosted.org/fesco/ticket/1491
17:22:08 <tomspur> Should there be a fc24 at the end or now?
17:22:10 <tomspur> now*?
17:22:22 <racor> no, I think users need to experience the harm of bundling, otherwise they will not understand its harmfulness.
17:22:52 <racor> folks. my time is up, I need to go.
17:23:56 <Rathann> tomspur: that should work, I wonder what's going on there
17:24:13 <geppetto> Rathann: I'm not sure what you'd want us to chime in with?
17:25:53 <Rathann> geppetto: there are 5 points mentioned in the ticket
17:28:23 <geppetto> I guess someone from FPC could answer how we would have in the past … as a reference point
17:28:42 <geppetto> not sure it's good for all of us to do that though, could easily be interpreted badly
17:28:55 <geppetto> Rathann: You want to answer for us?
17:29:06 <Rathann> sure, I can do that
17:29:22 <geppetto> ok, cool
17:30:09 <geppetto> Ok … going to close unless anyone has anything else?
17:32:24 <geppetto> #endmeeting