cloud_wg
LOGS
17:02:30 <dustymabe> #startmeeting
17:02:30 <zodbot> Meeting started Wed Oct  7 17:02:30 2015 UTC.  The chair is dustymabe. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:02:30 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
17:02:35 <dustymabe> #rollcall
17:02:42 <dustymabe> #topic rollcall
17:02:43 <roshi> .hello roshi
17:02:44 <zodbot> roshi: roshi 'Mike Ruckman' <mruckman@redhat.com>
17:02:44 <maxamillion> .hello maxamillion
17:02:47 <zodbot> maxamillion: maxamillion 'Adam Miller' <maxamillion@gmail.com>
17:02:53 <adimania> .hello adimania
17:02:54 <rtnpro> .hello rtnpro
17:02:54 <zodbot> adimania: adimania 'Aditya Patawari' <adimania@gmail.com>
17:02:56 <roshi> dustymabe: don't forget the meeting name
17:02:57 <dustymabe> .hellomynameis dustymabe
17:02:57 <zodbot> rtnpro: rtnpro 'Ratnadeep Debnath' <rtnpro@gmail.com>
17:02:57 <jbrooks> .hello jasonbrooks
17:03:00 <zodbot> dustymabe: dustymabe 'Dusty Mabe' <dustymabe@redhat.com>
17:03:03 <zodbot> jbrooks: jasonbrooks 'Jason Brooks' <JBROOKS@REDHAT.COM>
17:03:09 <dustymabe> roshi: what is that directive?
17:03:20 <roshi> #meetingname Cloud WG
17:03:20 <zodbot> The meeting name has been set to 'cloud_wg'
17:03:21 <smdeep> .hellomynameis smdeep
17:03:23 <zodbot> smdeep: smdeep 'Sudeep Mukherjee' <smdeep@gmail.com>
17:03:41 <dustymabe> #chair maxamillion roshi adimania rtnpro jbrooks
17:03:41 <zodbot> Current chairs: adimania dustymabe jbrooks maxamillion roshi rtnpro
17:03:45 <dustymabe> did I forget anyone?
17:03:50 <roshi> also, during #startmeeting add the name there too
17:03:58 <roshi> so, #startmeeting cloud wg
17:04:01 <roshi> or something like that
17:04:03 <dustymabe> ahh ok
17:04:08 <dustymabe> :)
17:04:13 <roshi> makes logs easier to find if someone else uses this channel for a meeting today
17:04:22 <roshi> :D
17:05:08 <dustymabe> finding notes from last meeting
17:05:32 <dustymabe> what date was that
17:06:07 <dustymabe> we had one on the 23rd didnt we?
17:06:24 <roshi> canceled last meeting
17:06:27 <roshi> yeah, sounds right
17:06:41 <dustymabe> weird.. no logs of meetings on 09/23
17:06:50 <dustymabe> https://meetbot.fedoraproject.org/sresults/?group_id=fedora-meeting-1&type=team
17:07:55 <dustymabe> we can go with the meeting notes from 09/16?
17:08:17 <roshi> https://meetbot-raw.fedoraproject.org/fedora-meeting-1/2015-09-23/cloud_wg.2015-09-23-17.00.txt
17:08:20 <kushal> .hellomynameis kushal
17:08:21 <zodbot> kushal: kushal 'Kushal Das' <kushaldas@gmail.com>
17:08:32 <roshi> dustymabe: those are the logs from the last meeting
17:08:36 <kushal> though trying to eat the dinner
17:08:57 <dustymabe> roshi: yep I just found them myself
17:09:06 <dustymabe> not sure why they don't show up in mote thought?
17:09:08 <dustymabe> though?
17:09:10 <dustymabe> oh well
17:09:18 * roshi always uses meetbot raw - can't figure out the new UI think for meetbot
17:09:21 <dustymabe> #topic last meeting items
17:09:35 <dustymabe> - adimania to look into this ticket in the next couple weeks
17:09:42 <dustymabe> - maxamillion to talk to mhayden about comparing network stacks
17:09:47 <dustymabe> - dustymabe to update ticket #94
17:10:02 <dustymabe> I updated the ticket #94
17:10:11 <dustymabe> https://fedorahosted.org/cloud/ticket/94
17:10:25 <maxamillion> I spoke with mhayden and he updated the wiki page (trying to remember which one ... just a sec)
17:10:42 <maxamillion> https://fedoraproject.org/wiki/Cloud/Network-Requirements
17:11:13 <maxamillion> he also said he's open to feedback or requests if there's anything he hasn't covered or isn't clear
17:11:19 <adimania> I will check out mhayden's notes and will work up on it, if required.
17:11:25 <maxamillion> +1
17:11:29 <dustymabe> #link https://fedoraproject.org/wiki/Cloud/Network-Requirements
17:11:40 <dustymabe> #info maxamillion spoke with mhayden and he updated the wiki page
17:11:51 <dustymabe> adimania: thanks!
17:12:15 <dustymabe> adimania: for your action item which one was "this ticket"
17:12:26 <adimania> dustymabe, no problem. :)
17:12:40 <adimania> I can only recall two tickets
17:12:51 <adimania> one was the one on which mhayden worked.
17:12:59 <adimania> Other one was dockerfiles :)
17:13:09 <dustymabe> ok.. cool
17:13:15 <adimania> no idea which one is "this ticket". :(
17:13:18 <dustymabe> ok.. moving on to next topic?
17:13:48 <dustymabe> #topic Migrate all Dockerfiles / Images to systemd where possible
17:13:57 <dustymabe> #link https://fedorahosted.org/cloud/ticket/121
17:14:20 <number80> o/
17:14:52 <maxamillion> oh ok, so running systemd inside the container
17:15:39 <dustymabe> yeah and managing the other processes with that
17:15:48 <jbrooks> The ticket mentions one using supervisord, is there an example of one using systemd?
17:16:03 <jbrooks> I didn't realize the systemd issues had been resolved
17:16:23 <dustymabe> this one maybe: https://github.com/fedora-cloud/Fedora-Dockerfiles/blob/master/systemd/apache/Dockerfile
17:16:34 <dustymabe> all of the ones under the systemd folder
17:16:40 <jbrooks> ah, ok
17:17:29 <dustymabe> so I don't think anyone is volunteering for this right now
17:17:34 <dustymabe> we'll take these as we have time
17:17:51 <dustymabe> #topic Migrate all Dockerfiles / Images to systemd where possible
17:17:59 <dustymabe> #link https://fedorahosted.org/cloud/ticket/121
17:18:11 <dustymabe> sigh
17:18:12 <roshi> I'm reading Docker: Up and Running, and once I get more familier with stuff I'll start actually helping with the dockerfiles
17:18:25 <dustymabe> #topic  fedora-dockerfiles: Clean up READMEs.
17:18:29 <roshi> just as an #info
17:18:34 <dustymabe> #link https://fedorahosted.org/cloud/ticket/122
17:18:51 <adimania> I will pick that up after 123, if no one else does.
17:18:59 <dustymabe> adimania: thanks
17:19:10 <dustymabe> f23 you mean?
17:19:15 <dustymabe> oh no
17:19:18 <dustymabe> after ticket 123
17:19:20 <dustymabe> got ya
17:19:27 <adimania> ticket 123
17:19:55 <dustymabe> do we have anyone here looking to get involved in this space?
17:20:01 <dustymabe> if so 122 would be an easy thing to do
17:20:19 * dustymabe will move to next topic shortly
17:20:36 <roshi> I'm looking to get more involved, but don't have cycles now
17:20:58 <dustymabe> roshi: :) you are super busy already
17:21:07 <dustymabe> didn't know if we had any lurkers out there
17:21:24 <dustymabe> #topic Document process for using Fedora-Dockerfile branches
17:21:30 <dustymabe> #link https://fedorahosted.org/cloud/ticket/123
17:21:39 <adimania> I have done some docs already.
17:22:09 <adimania> there are some suggestions about more changes by bkabrda
17:22:37 <adimania> 1. creating a different doc contributing.md. This looks good to me.
17:22:57 <dustymabe> adimania: thanks!
17:23:16 <adimania> 2. Remove the section "The version of Docker that it was created and tested on.". I am not happy with this suggestion.
17:23:21 <dustymabe> if you want to update the ticket with that information for those following it
17:23:41 <adimania> already done. The ticket is updated.
17:23:46 <dustymabe> cool. thanks!
17:24:01 <dustymabe> moving to next topic
17:24:07 <dustymabe> #topic CI for Fedora-Dockerfiles
17:24:15 <dustymabe> #link https://fedorahosted.org/cloud/ticket/124
17:25:00 <adimania> I can pick this up between 123 and 122, if no one else seems interested.
17:25:15 <adimania> However, if this is to use taskotron, I will need help.
17:26:07 <dustymabe> adimania: sounds awesome. I am interested in taskotron myself so we might be able to get roshi/tflink to show it to us when we are ready
17:26:37 <adimania> oh good. I am in.
17:26:42 <roshi> yeah, work is ongoing there
17:26:51 <roshi> right now, we have too few devs and too many other things to do
17:27:05 <roshi> if someone had some spare cycles to contribute to taskotron dev, that'd be great
17:27:13 <dustymabe> roshi: ok.. yeah I think we are a little ways out from being ready ourselves.. hopefully it grows by the time we are
17:27:22 <roshi> I know maxamillion was able to get some stuff working
17:27:30 <maxamillion> who ever is going to work on this, I'd like to coordinate with to sort out how it might tie into the Layered Image Builds https://fedoraproject.org/wiki/Changes/Layered_Docker_Image_Build_Service
17:28:03 <roshi> right now, work on disposable clients is getting closer and closer to merging back into dev - which means a release with it comes shortly after that
17:28:52 <roshi> I have an interest in this space
17:29:04 <roshi> and as taskotron progresses, I'll start to work on it
17:29:07 <dustymabe> cool
17:29:30 <maxamillion> +1
17:29:35 <dustymabe> next topic
17:29:45 <dustymabe> #topic Fedora-Dockerfiles examples for Kubernetes
17:29:53 <dustymabe> #link https://fedorahosted.org/cloud/ticket/125
17:30:45 * adimania wants to do all the dockerfiles tasks but there are too many of them. :(
17:31:27 <dustymabe> adimania: wish there was more than one of you :)
17:31:41 <dustymabe> I vote we create adimania2
17:31:52 <dustymabe> and he can be devoted to it :)
17:32:20 <dustymabe> ok will push off kubernetes stuff for now.
17:32:30 <adimania> :)
17:32:42 <dustymabe> #topic open floor
17:32:51 <kushal> I have update
17:33:05 <kushal> https://apps.fedoraproject.org/autocloud/jobs/ is finally on production
17:33:18 <number80> kushal++
17:33:21 <kushal> we are still seeing different hickups
17:33:31 <kushal> fixing them one by one.
17:33:53 <kushal> Will do another round of update from tunir and autocloud tonight
17:34:07 <dustymabe> kushal: thanks.. I think eventually a periodic notification to the list might be useful
17:34:20 <rtnpro> kushal++
17:34:29 <dustymabe> like once a week that lets us know if the latest images are building/passing tests or not
17:34:52 <dustymabe> or maybe notification to the irc channel would be better?
17:34:59 <kushal> dustymabe, it will file bugs for broken images :)
17:35:06 <dustymabe> in BZ?
17:35:25 <kushal> dustymabe, that we will talk and decide :)
17:35:34 <dustymabe> ehh.. I'm not the biggest fan of an automated tool filing bug reports
17:35:42 <dustymabe> but let's discuss it
17:35:44 <dustymabe> :)
17:36:11 <kushal> dustymabe, Yup.
17:36:23 <dustymabe> ok.. I have something
17:36:36 <dustymabe> so our fedora cloud images have python3
17:36:39 <dustymabe> no python
17:36:45 <kushal> yes
17:36:54 <dustymabe> this doesn't play nice with ansible
17:36:55 <kushal> dustymabe, we had to move our tests into Python3 for the same
17:37:04 <dustymabe> what do we do about that?
17:37:21 <kushal> dustymabe, ouch
17:37:22 <roshi> is that intentional?
17:37:35 <kushal> roshi, Python3?
17:37:35 <dustymabe> you mean the move to python3?
17:39:21 <roshi> yeah
17:39:25 <dustymabe> the move to python3 was intentional
17:39:42 <roshi> I don't recall making that decision - last I heard people wanted to get *rid* of python
17:39:43 <dustymabe> for fedora as a whole.. but we don't always see all the problems
17:39:56 <kushal> roshi, it was a f22change, pushed back to f23
17:40:17 <dustymabe> ok.. I'm going to open a ticket about this
17:40:28 <dustymabe> some of the higher powers that exist will probably have comments
17:40:42 <roshi> yeah, I didn't think we were ready for it yet
17:40:44 <kushal> dustymabe, Okay.
17:40:45 <dustymabe> #action dustymabe to create ticket to figure out python3/ansible requirements for cloud
17:40:57 <dustymabe> ok cool
17:41:00 <jbrooks> dustymabe, could you include a test case for what's broken
17:41:33 <dustymabe> jbrooks: /bin/sh: /usr/bin/python: No such file or directory
17:41:39 <dustymabe> it's all broken :)
17:41:43 <maxamillion> roshi: wait, getting rid of python for what?
17:41:54 <maxamillion> dustymabe: /usr/bin/python3 ?
17:41:58 <roshi> out of the cloud images entirely
17:42:01 <jbrooks> dustymabe, that's when you try to do something to a f23 cloud instance from a separate machine w/ ansible?
17:42:13 <roshi> that was the last I heard, anyhow
17:42:16 <dustymabe> maxamillion: yeah we might be able to use that but ansible doesn't know to look there
17:42:28 <roshi> flamingo was an effort at that - since cloud-init needs python
17:42:29 <dustymabe> jbrooks: correct
17:42:31 <maxamillion> dustymabe: oh, no .. ansible doesn't do py3 yet
17:42:37 * gholms appears
17:42:44 <dustymabe> gholms: \o
17:42:45 <kushal> =[00000000000000000000000000000000p[=-['.lllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllll,,9iuuuuuuuuuuuuuuuuuuuuuuuuuuuuuo0p[-9o0]]]]];'[
17:42:47 <maxamillion> dustymabe: sorry, I totally missed that
17:42:51 <maxamillion> kushal: wut?
17:43:03 <kushal> daughter attack on keyboard
17:43:07 <dustymabe> nice
17:43:08 <gholms> kushal: Warning: infant detected on keyboard
17:43:16 <adimania> i guessed so.
17:43:27 <dustymabe> ok I will open ticket
17:43:33 <dustymabe> any more items for open floor?
17:44:09 <maxamillion> dustymabe: hit me up when you do the ansible stuff, I have some background in ansible lan705404d
17:44:20 <maxamillion> dustymabe: if you would like help that is
17:44:39 <dustymabe> maxamillion: sure..
17:44:43 * maxamillion bumped his yubikey :/
17:44:54 <dustymabe> maxamillion: I have all of your secrets
17:44:54 <kushal> `:)
17:45:05 * dustymabe sets the fuse
17:45:07 <maxamillion> dustymabe: I'm not sure what all work will be needed but if there's anything I can help with let me know
17:45:12 <dustymabe> 3
17:45:18 <dustymabe> ...
17:45:21 <kushal> dustymabe, we will ask toshio
17:45:22 <dustymabe> maxamillion: I will
17:45:42 <dustymabe> 2...
17:45:50 <dustymabe> 1...
17:45:53 <dustymabe> #endmeeting