fedoraqa-devel
LOGS
14:01:52 <tflink_> #startmeeting fedoraqa-devel
14:01:52 <zodbot> Meeting started Mon Aug 24 14:01:52 2015 UTC.  The chair is tflink_. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:52 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
14:01:52 <tflink_> #meetingname fedoraqa-devel
14:01:52 <tflink_> #topic roll call
14:01:52 <zodbot> The meeting name has been set to 'fedoraqa-devel'
14:02:37 <tflink_> #chair tflink kparal
14:02:37 <zodbot> Current chairs: kparal tflink tflink_
14:02:53 * lbrabec is here
14:02:55 * kparal is here
14:03:10 * garretraziel is here
14:03:12 <bexelbie> .hello bex
14:03:14 <zodbot> bexelbie: bex 'Brian (bex) Exelbierd' <bex@pobox.com>
14:03:30 <bexelbie> sorry, wrong meeting
14:03:47 <kparal> Josef replied a while ago that he wouldn't be able to be here
14:03:54 <tflink> bexelbie: no worries
14:04:05 <tflink> and Martin is on PTO until tomorrow IIRC
14:04:29 <tflink> so I think we have everyone who's expected
14:04:41 <kparal> yes
14:04:55 <tflink> #topic status updates
14:05:21 <tflink> #info got taskotron mostly working with bodhi2 - tflink/kparal
14:05:21 <tflink> #info disposable clients are working well enough to use for dev work
14:05:21 <tflink> #info Added test coverage for weak dependencies to depcheck, all tests pass - handsome_pirate
14:05:21 <tflink> #info switch from TAP to YAML for inter-directive communication and results representation in libtaskotron. Early WIP of the result-yaml format: https://bitbucket.org/fedoraqa/resultyaml - tflink, jskladan
14:05:21 <tflink> #info OpenQA - added updates.img via local media test - jsedlak
14:05:34 <tflink> any questions/comments about the above?
14:05:40 <tflink> or additional things to add?
14:06:02 <kparal> nope
14:06:12 <kparal> well
14:06:14 <garretraziel> no
14:06:28 <kparal> what is the ETA for the TAP replacement?
14:06:42 <kparal> i.e. how fast should I rush to review that?
14:06:54 * handsome_pirate waves
14:06:59 <kparal> very soon/in a few months?
14:07:11 <tflink> haven't really talked about it yet but I'd like to have it by the time we have dist-git tasks in place
14:07:28 <tflink> kparal: I wish I could say very soon but I think that's a bit on the optimistic side
14:07:35 <kparal> ok
14:07:39 <tflink> switching over would make packaging somewhat easier
14:07:54 <tflink> and less confusing when folks start writing tasks
14:09:03 <tflink> kparal: if you could look at it to see if we came up with something horrible or if we're missing an important use case, that would be great but a detailed review can wait, I think
14:09:22 <tflink> it's mostly a collection of use cases right now
14:09:50 <tflink> there's some small inconsistencies between them but that'll be worked out with time
14:10:01 <kparal> ok, thanks for info
14:10:09 <tflink> if there's no other questions/comments, moving on
14:10:19 <tflink> #topic Bodhi2 and Fedmsg emission
14:10:39 <tflink> in case anyone missed it, bodhi was upgraded to bodhi2 last week
14:10:53 * kparal didn't miss that
14:11:05 <tflink> kparal and I spent most of last week trying to prepare for the upgrade and cleaning up after it
14:11:18 <tflink> fun times ...
14:11:53 <tflink> anyhow, most of our stuff is working now with the notable exception of bodhi comments
14:11:58 <kparal> bodhi2 comments still don't work, but I'll poke infra today to move it forward
14:12:48 <tflink> we're trying not to put too much effort into supporting bodhi2 comments, though since we want our commenting code to DIAF
14:13:45 <tflink> as i understand it, mkrizek will be working on the fedmsg emission stuff again when he gets back tomorrow
14:14:35 <tflink> once we have fedmsg emission working from resultsdb and appropriate filters in place for fmn, we can get rid of comments
14:15:20 <tflink> one other important note - fakefedorainfra no longer represents a mock bodhi interface and we're not planning to take the time to update it. the project will likely be killed off soon
14:15:43 <tflink> any comments/questions on this or anything I missed?
14:16:36 * tflink takes that as a no, moves on to next topic
14:16:45 <tflink> #topic Remaining Disposable Client Work
14:16:57 * kparal likes DIAF acronym
14:17:48 <tflink> We had a successful-enough demo of the disposable client bits at Flock - folks seem to be interested and looking forward to the dist-git tasks
14:18:02 <tflink> but there's still work left before the disposable clients are ready for production
14:18:31 <tflink> mostly around image production, image handling, system maintenance and polish
14:19:43 <tflink> I'd like to get this done soon. other than the fedmsg/bodhi_comment stuff, this is the higest priority for taskotron work
14:20:13 <tflink> does everyone involved in dev understand what the disposable client feature is and why we're doing it?
14:20:56 * kparal feels he should say yes
14:21:05 <garretraziel> yup, I think so
14:21:19 * lbrabec nods
14:21:26 * handsome_pirate does
14:21:31 <tflink> good - I was hoping so but it doesn't hurt to ask
14:22:09 <tflink> i think the rest of it will be handled when we start going over tasking
14:22:29 <tflink> unless there are comments/questions about the disposable client demo or the remaining work
14:23:04 * tflink assumes not, moves on to tasking
14:23:14 <tflink> #topic Tasking
14:23:27 <tflink> who all is looking for taskotron work to do?
14:23:45 <garretraziel> I think that jskladan did
14:23:50 * handsome_pirate waves
14:23:52 <lbrabec> me too
14:23:54 <tflink> yeah, he mentioned that
14:24:09 <tflink> lbrabec: how do you feel about https://phab.qadevel.cloud.fedoraproject.org/T575
14:24:42 <tflink> kparal: we started talking about this on Friday but do you think you'll have time for https://phab.qadevel.cloud.fedoraproject.org/T568 ?
14:24:47 <kparal> what about creating json metadata for those images?
14:25:03 <kparal> I can do that easily in taskotron-vmbuilder
14:25:27 <tflink> what would the metadata be used for?
14:25:35 <kparal> instead of filename parsing
14:26:34 <kparal> just an idea
14:26:59 * handsome_pirate likes this idea
14:27:00 <tflink> when we (jskladan at least, don't recall off hand who else was there) were talking about this at Flock, the idea was that filename parsing isn't perfect but it's easy and pretty straight forward
14:27:09 <handsome_pirate> Could store it in db
14:27:24 <handsome_pirate> wow, have signal in tunnel
14:27:26 <kparal> well, fine by me
14:27:39 <tflink> is there an advantage that I'm not thinking of
14:27:40 <tflink> ?
14:27:53 <kparal> I'm talking about T575, just to be sure
14:27:59 <tflink> oh
14:28:10 <tflink> yeah, same thing
14:28:48 <tflink> I just really like the simplicity of filename parsing
14:28:53 <kparal> ok
14:29:15 <tflink> this is going to be complex enough as it is :-/
14:30:05 <kparal> let's talk about T568 after the meeting, I'm still not clear about the use cases
14:30:14 <tflink> but if there is an advantage in using json metadata instead, I'm not totally against the idea
14:30:29 <tflink> it'd be better defined and less reliant on convention
14:31:29 <tflink> but we might have to add testcloud support for the json files. or at least make sure it doesn't puke when the json files are in it's backingstore/ dir
14:32:12 <tflink> thoughts?
14:32:21 <kparal> too many
14:32:23 <kparal> :P
14:32:59 <kparal> let's go with filename parsing for T575 for the time being
14:33:34 <tflink> my thought process was that if we run into problems, we can look into something more sophisticated
14:34:12 <tflink> lbrabec: are you OK with T575?
14:34:24 <lbrabec> tflink, yep
14:34:43 <tflink> cool, did I miss anyone?
14:34:54 <tflink> other than josef - will sync up with him after the meeting
14:35:29 <tflink> wow, this is going much faster than I thought it would :)
14:35:35 <tflink> but those are famous last words
14:36:13 <handsome_pirate> tflink:   Ahoy
14:36:26 <handsome_pirate> tflink:  Want me to do something?
14:36:53 <tflink> handsome_pirate: https://phab.qadevel.cloud.fedoraproject.org/T576 is a quick task that comes to mind
14:37:40 * handsome_pirate looks
14:38:34 <handsome_pirate> grabs
14:39:18 <tflink> any other comments/questions?
14:39:35 <tflink> ok, moving on to
14:39:43 <tflink> #topic Upgrading to Fedora 22
14:40:04 <tflink> we never really circled back to the conversation around whether to migrate to el7 or not
14:40:32 <tflink> and since f21 is going EOL soon, we need to upgrade our deployments to f22 before long
14:40:56 * tflink was thinking of doing it between beta and final
14:41:23 <kparal> there's still one month after F23 is out
14:41:35 <kparal> too short?
14:41:41 <tflink> shouldn't be
14:41:53 * nirik notes you should likely check dnf vs yum compat for anything you are doing on them...
14:42:09 <tflink> but our dev/stg systems are relying on HW that's going EOL at the end of october
14:42:23 <tflink> seems silly to reinstall the clients on dev/stg and not upgrade them at the same time
14:42:40 <tflink> nirik: have you heard anything about the dnf module in ansible not working?
14:42:52 <tflink> it's been working for me so far but I've not used it much
14:43:13 <nirik> it should work fine for the most part... was more meaning things in mock, etc...
14:43:20 <tflink> ah
14:43:50 <tflink> which reminds me of more fun
14:44:07 <tflink> nirik: thoughts on what to do about roles we depend on that are written for yum?
14:44:36 <nirik> we need to modify them to handle either... shouldn't be too bad I wouldn't think.
14:44:49 * tflink isn't sure doing 'when: is_fedora' and duplicating all the yum directives is the best idea every
14:44:51 <nirik> actually most of them would likely just keep working if you also installed yum-depreciated
14:45:10 <nirik> some folks handled this by making the module itself a variable...
14:45:16 <nirik> package_manager: dnf
14:45:38 <nirik> {{ package_manager }}: state=installed name=whatever
14:45:50 <tflink> didn't realize that would work
14:46:07 <tflink> my first thought was to use old-style syntax if it's still supported
14:46:10 <nirik> yeah, it supposedly does... we can figure something out tho.
14:46:34 <tflink> all the more reason to start working on the upgrade sooner than later :-/
14:47:18 <tflink> any other thoughts/comments on the upcoming upgrade?
14:47:33 <nirik> yeah. I think I already fixed up base... not sure how much else is affected you use
14:47:55 <tflink> I'm not sure either, haven't tried looking much
14:48:37 * tflink will need to remember to work with the docs folks - they wanted to have their buildbot on el7
14:49:05 <tflink> #action tflink to sync up with docs team to make sure that we keep the buildbot roles compatible with el7
14:49:35 <tflink> any other thoughts/comments?
14:49:51 <Corey84> will pass on  docs is  mtg in  -meeting btw
14:50:45 * kparal shakes his head
14:50:48 <tflink> Corey84: yeah, I don't think it's of immediate concern, though. IIRC, there are bigger fish to fry before we start worrying about compatibility
14:51:45 <tflink> ok, moving on to
14:51:51 <tflink> #topic Open Floor
14:53:15 <tflink> anything else that folks want to bring up?
14:54:11 * tflink looks through his notes from flock again to see if he missed anything
14:54:23 <tflink> oh, i did forget one thing
14:54:29 <tflink> #topic new taskotron logo
14:54:38 <tflink> will try to do this quickly
14:55:10 <tflink> we have a new logo for taskotron - https://mashaleonova.wordpress.com/2015/08/18/a-logo-for-taskotron/
14:55:21 <tflink> one question is when to start using it
14:55:37 <lbrabec> relevant link https://phab.qadevel.cloud.fedoraproject.org/T584
14:55:53 * tflink would like to hold off for a bit until we at least have disposable clients in place, maybe dist-git tasks
14:56:00 <kparal> lbrabec: you can use #link
14:56:03 <tflink> my thought process goes something like this:
14:56:15 <tflink> 1) test/task automation doesn't really have a great reputation in Fedora
14:56:38 <tflink> 2) we haven't done much with Taskotron in production which AutoQA wasn't capable of (from a packagers perspective)
14:57:09 <tflink> 3) waiting until we have more bits that AutoQA could never do would add a visual change to emphasize that "hey, this isn't AutoQA. it's different and does much more"
14:57:27 <lbrabec> that sounds reasonable
14:57:47 * kparal agrees with all of that, but he wouldn't wait more than a month
14:58:01 <tflink> it would also give us a bit more time to do some frontend redesign/rework so that it doesn't look like we just slapped it on something
14:58:14 <kparal> it would be impolite to the logo author, in my eyes
14:58:27 <tflink> kparal: even if we tell her what we're thinking?
14:58:49 <lbrabec> also, with jsedlak we did quick draft https://db.tt/iXYwltw6
14:58:58 * kparal shrugs. sure
14:59:03 * tflink wouldn't think that saying "we want to use the logo you designed to emphasize a big change that's coming but isn't done yet"
14:59:06 <tflink> would be that bad
14:59:31 <tflink> ugh, bootstrap :-P
14:59:41 * tflink lost that battle a long time ago, though
14:59:43 <kparal> I'm not that optimistic that all of that will be in place in a short timeframe. I think we're again talking about 3-6 months
15:00:25 <tflink> kparal: I'm just worried that we'd be wasting a chance to have the visual emphasis that new things are in place
15:01:40 <kparal> I don't have strong feelings. just expressed my thoughts. if we wait and tell it to Masha and she's not disappointed about that, no big deal
15:01:59 <garretraziel> I can send Masha (author of our logo) draft of our webpage and tell her that we will use it in a few months
15:02:24 <tflink> yeah, I think that not telling her anything would be disrespectful
15:02:49 * garretraziel agrees
15:03:07 <tflink> garretraziel: I'd like to explain some of the reasons behind why we're not planning to use it immediately as well
15:03:39 <kparal> just a note, QA meeting has just started
15:03:51 <garretraziel> tflink: sounds reasonable
15:04:09 <tflink> but we're over time now
15:04:22 <tflink> and can finish this up outside of the meeting - sound reasonable?
15:04:33 <tflink> #topic Open Floor
15:04:36 <tflink> any other topics?
15:04:47 <tflink> otherwise, we're over time and the QA meeting has started
15:05:38 <tflink> thanks for coming, everyone
15:05:45 * tflink will send out minutes shortly
15:06:09 <tflink> feedback on how well the new method for status updates works would be appreciated
15:06:12 <tflink> #endmeeting