fedora-meeting-1
LOGS
14:59:44 <sgallagh> #startmeeting Server SIG Weekly Meeting (2015-07-14)
14:59:44 <zodbot> Meeting started Tue Jul 14 14:59:44 2015 UTC.  The chair is sgallagh. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:59:44 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
14:59:44 <sgallagh> #chair sgallagh mizmo nirik stefw adamw simo tuanta mitr danofsatx
14:59:44 <sgallagh> #topic roll call
14:59:44 <zodbot> Current chairs: adamw danofsatx mitr mizmo nirik sgallagh simo stefw tuanta
14:59:48 <adamw> hi
14:59:49 <nirik> morning
14:59:55 <mizmo> yo
14:59:55 <sgallagh> Hello
15:00:03 <danofsatx> hola, peeps
15:01:05 <sgallagh> I'll leave a couple minutes for folks to filter in
15:03:29 <sgallagh> ok, I guess we're it today.
15:03:44 <sgallagh> #topic Agenda
15:04:01 <sgallagh> I had one additional small item that I forgot to put in the email
15:04:04 <sgallagh> #topic Agenda Item
15:04:08 <sgallagh> #undo
15:04:08 <zodbot> Removing item from minutes: <MeetBot.items.Topic object at 0x2fe7a1d0>
15:04:19 <sgallagh> #info Agenda Item: Getty IP Address
15:04:29 <sgallagh> #info Agenda Item: Fedora 23 Progress
15:04:39 <sgallagh> #info Agenda Item: Atomic Server
15:04:42 <sgallagh> Other items?
15:05:22 <danofsatx> not sure - I need to look at the minutes for the meetings I missed
15:05:36 <sgallagh> OK, if you think of anything, we'll get it in Open Floor
15:06:32 <mitr> Hello
15:06:46 <crose> Hello
15:07:25 <sgallagh> OK, let's proceed.
15:07:31 <sgallagh> #topic Getty IP Address
15:07:53 <sgallagh> So, stefw wrote some patches to support printing the IP on getty
15:08:12 <sgallagh> I sent out a proposal for how to phrase this on the terminal.
15:08:39 <sgallagh> Just to put it to rest:
15:09:14 <sgallagh> Proposal: Use the approach described in https://lists.fedoraproject.org/pipermail/server/2015-July/001936.html with the \S amendment
15:09:41 * nirik nods. seems fine to me.
15:09:51 <adamw> nice.
15:10:01 <mitr> nice++
15:11:00 <sgallagh> #link https://lists.fedoraproject.org/pipermail/server/2015-July/001936.html
15:11:23 <sgallagh> #idea Use the approach described in https://lists.fedoraproject.org/pipermail/server/2015-July/001936.html with the \S amendment
15:13:20 <sgallagh> Votes?
15:14:16 <adamw> oh, i didn't realize we were voting on ideas here
15:14:37 <adamw> sure, whatever, +1.
15:14:47 <sgallagh> Well, I raised it as a Proposal: above
15:14:54 <sgallagh> Then I figured I'd add it to the notes
15:15:04 <mitr> +1
15:15:10 <danofsatx> +1
15:15:15 <nirik> +1 sure
15:15:17 <adamw> oh right, missed that.
15:15:36 * nirik steps away for a min
15:16:20 <sgallagh> OK, with my own +1, I think that's accepted.
15:16:26 <sgallagh> #agreed Use the approach described in https://lists.fedoraproject.org/pipermail/server/2015-July/001936.html with the \S amendment
15:16:31 <sgallagh> #topic Fedora 23 Progress
15:16:37 <sgallagh> ... or lack thereof
15:17:08 <sgallagh> So, we're at branch, with Alpha Freeze only two weeks away.
15:17:19 <sgallagh> Things are not going particularly well this cycle (by my estimation)
15:17:38 <adamw> yeah, from here it's been a bit of a mess too.
15:18:06 <danofsatx> I've been out of the loop....too darned busy with RL
15:18:28 <sgallagh> I myself am behind on the role containerization work, mostly due to a number of unexpected fires
15:19:04 <sgallagh> I'm going to see what I can manage by the 28th, but I have a few days of PTO coming up as well
15:19:23 <jsmith> sgallagh: Unfortunately, sometimes PTO days are the ones with the fewest distractions :-(
15:19:28 <sgallagh> The Cockpit domain controller setup had to be deferred due to GSoC chaos.
15:19:42 <sgallagh> jsmith: I'm taking my children to a theme park. No hacking allowed.
15:20:02 <jsmith> sgallagh: Yeah, laptops and roller coasters don't mix well...
15:20:17 <adamw> sgallagh: so just to be clear, https://fedoraproject.org/wiki/Changes/Cockpit_Domain_Controller_GUI is not happening for 23, right?
15:20:23 <sgallagh> adamw: Correct.
15:20:38 <sgallagh> Until we can find some resources to pick it up, it's on hold.
15:21:13 <sgallagh> I think those are the only things we planned on delivering this cycle
15:21:31 <sgallagh> So unless I miss my guess, there's not going to be a lot of marketable change in this release.
15:21:44 <sgallagh> Maybe the FreeIPA 4.2 release will help with that, though
15:22:08 <sgallagh> Anyone else working on anything exciting for this cycle?
15:23:01 <danofsatx> not in regards to Server ;)
15:23:15 * nirik is still working on passphrase policy, but thats not really exciting. ;)
15:23:26 <sgallagh> nirik: But extremely noteworthy
15:24:07 <sgallagh> So, the biggest problem I think we're facing is a lack of resources (primarily available cycles).
15:24:35 <sgallagh> I'd really appreciate it if everyone on the WG (and in the SIG) would make an effort to publicize our work and goals a bit more.
15:24:49 <sgallagh> I'd like for us to be semi-actively recruiting folks.
15:26:16 <sgallagh> I'd also like if you could help with the occasional blog post or lightning talk out in the wild.
15:26:21 <adamw> i didn't get anywhere with openQA stuff, unfortunately, as i wound up spending the whole week working out why all our existing openQA tests didn't work and getting those problems fixed.
15:26:36 <sgallagh> (If I have to hear "Why would I use Fedora Server instead of CentOS?" *one more time*...)
15:26:38 <adamw> i was looking at the possibility of doing some test days for server stuff this cycle, though; anyone interested in that?
15:26:56 <sgallagh> adamw: What in particular?
15:27:05 * nirik might be able to help with test days.
15:27:31 <adamw> er, what have we got? :) how are Containerized Server Roles coming?
15:27:47 <sgallagh> "(11:18:28 AM) sgallagh: I myself am behind on the role containerization work, mostly due to a number of unexpected fires"
15:27:52 <adamw> if we don't have any new stuff we could at least try and run one as an opportunity to get a wider audience looking at existing bits
15:27:58 <adamw> ah fun, /me will learn to read one of these days
15:28:19 <danofsatx> adamw: reading is for loosers.
15:28:33 <adamw> right now it seems like validation testing is basically done by two or three of us, who might miss stuff a wider audience would see...
15:28:36 <sgallagh> adamw: I would like to run a Domain Controller/DB server test day though
15:28:37 <adamw> danofsatx: so's spelling
15:28:45 <adamw> sgallagh: right, something like that
15:28:50 <sgallagh> If nothing else, it might catch issues introduced by switching rolekit and firewalld over to python 3
15:28:55 <adamw> let's get a ticket filed this week
15:29:24 <sgallagh> /me nods
15:29:37 <sgallagh> #action sgallagh to file a ticket for a Server Role Test Day
15:29:51 <danofsatx> did we ever test DB role?
15:30:17 <sgallagh> danofsatx: No Test Day, but I ran it through a lot of release validation
15:30:22 <danofsatx> like, test-day type
15:30:43 <danofsatx> roger
15:31:34 <sgallagh> OK, so the short version is that we should probably let Marketing know that Fedora Server will likely have few visible changes in F23 and they should focus on the other editions this time around
15:31:45 <danofsatx> agreed
15:31:55 <danofsatx> refocus efforts for F24
15:32:13 <sgallagh> By "refocus" I hope we mean "go on a recruiting spree"
15:32:19 <danofsatx> that too ;)
15:32:35 <danofsatx> hopefully, I'll have new employment that will allow me to devote more resources to open source
15:33:27 <sgallagh> #info Fedora Server 23 will have few user-visible changes. Encourage marketing to focus efforts on the other Editions.
15:33:50 <sgallagh> OK, last agenda item:
15:33:59 <sgallagh> #topic Atomic Server
15:34:39 <sgallagh> As many of you have probably seen, the Workstation team is looking into eventually providing an Atomic Workstation system
15:35:15 <sgallagh> The basic idea around it is that the core platform will be a read-only, atomically-updated system and that all of the user and system applications will be containerized.
15:35:30 <sgallagh> Is this something we would also like to be exploring in the Fedora Server?
15:36:21 <adamw> it seems like a direction lots of people are thinking/moving in, but it feels slightly odd to do it at the flavor level, to me...
15:37:21 <sgallagh> adamw: Well, the plan is to not abandon RPMs as a deployment mechanism in the near future
15:37:45 <sgallagh> (And with rpm-ostree to use those RPMs to create the read-only platforms)
15:37:49 <nirik> adamw: yeah, seems also to me more like a format
15:38:01 <sgallagh> So I think technologically it makes sense, even if it's a little awkward conceptually
15:39:38 <sgallagh> OK, I'm not hearing an overwhelming response either way. Is this something we just don't care about for the immediate future?
15:39:40 <mitr> An atomic OS (meaning single-package, take-it-or-leavit deal, as opposed to “unwritable /bin /lib /usr” we’ve always had) makes sense to me; moving libraries into applicatinos not really.
15:40:43 * adamw tends to be bad at thinking about things that don't exist, so isn't very keen to give thoughts
15:40:54 * danofsatx has to bow out. Duty calls.
15:41:07 <sgallagh> adamw: Lies: you talk about "quality" all the time :-P
15:41:11 <adamw> :P
15:41:14 <nirik> mitr: yeah. +1
15:41:27 <adamw> sgallagh: quality is like luck, it exists in 'bad' and 'good' varieties ;P
15:41:31 <mitr> It would be nice to explore this, sure; can anyone spare the time?
15:42:22 <mitr> (betting that the atomic OS is a prerequisite to applications actually relying on an OS, and thus not needing libraries so much)\
15:43:02 <adamw> would we be using the same core as Workstation or not?
15:43:20 <mitr> adamw: Great question.
15:43:39 <sgallagh> I suppose that's going to depend on how the layering works
15:43:52 <sgallagh> I expect that we won't want the full GNOME Shell environment
15:44:09 <sgallagh> Which I would think would be part of the atomic image. The applications, probably not.
15:44:13 <mitr> I’d expect there to be push to keep GUI out of the OS, but having the same set of API/ABI libraries in both would make sense to me.
15:44:24 <sgallagh> mitr++
15:44:48 <mitr> sgallagh: (This means also having libjpeg and libgtk3 in the OS rather than Workstation pushing copies of these into apps)
15:45:11 <sgallagh> mitr: I don't think it necessary mandates that
15:45:26 <sgallagh> But that's certainly important to figure out
15:46:06 <mitr> sgallagh: We could perhaps split into base->{server,workstation} but that’s making the job of attracting developers harder
15:46:28 <mitr> Anyway… spare cycles?
15:46:37 <sgallagh> I absolutely don't have any :(
15:46:52 <sgallagh> I started with zero and it's gone downhill from there.
15:47:24 <mitr> My time allocation is completely unknown at this moment
15:49:11 <adamw> i don't think i'd be the right person for this anyway.
15:49:36 <sgallagh> #info Help wanted to investigate an Atomic Server platform.
15:49:50 * nirik is also very busy.
15:51:03 <sgallagh> OK, let's move on
15:51:06 <sgallagh> #topic Open Floor
15:52:22 * nirik has nothing
15:53:24 <sgallagh> OK, setting the fuse
15:57:32 <sgallagh> #endmeeting