fpc
LOGS
16:02:06 <geppetto> #startmeeting fpc
16:02:06 <zodbot> Meeting started Thu Jun  4 16:02:06 2015 UTC.  The chair is geppetto. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:02:06 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:02:06 <geppetto> #meetingname fpc
16:02:06 <geppetto> #topic Roll Call
16:02:06 <zodbot> The meeting name has been set to 'fpc'
16:02:10 <tibbs|w> Howdy.
16:02:39 <geppetto> Hey
16:02:43 <geppetto> #chair mbooth
16:02:43 <zodbot> Current chairs: geppetto mbooth
16:02:45 <geppetto> #chair tibbs
16:02:45 <zodbot> Current chairs: geppetto mbooth tibbs
16:03:12 <tomspur> Hi
16:03:21 <geppetto> #chair tomspur
16:03:22 <zodbot> Current chairs: geppetto mbooth tibbs tomspur
16:03:39 <sYnfo> Hi!
16:04:40 <tibbs|w> (crickets)
16:04:45 <geppetto> ha
16:05:21 <tibbs|w> I forget who said they couldn't make it.
16:05:31 <geppetto> Rathan, I think
16:05:40 <tibbs|w> And racor.
16:06:17 <geppetto> interesting
16:08:43 <tibbs|w> So, without quorum, maybe I can talk about 539.
16:09:21 <geppetto> sure
16:09:50 <geppetto> #topic #539 	Procedure for approving package review process exceptions
16:09:50 <geppetto> .fpc 539
16:09:50 <geppetto> https://fedorahosted.org/fpc/ticket/539
16:09:51 <zodbot> geppetto: #539 (Procedure for approving package review process exceptions) – fpc - https://fedorahosted.org/fpc/ticket/539
16:09:57 <tibbs|w> Basically, I proposed to FESCo that there be some procedure for allowing exemptions to the package review process.
16:10:05 <tibbs|w> FPC delegated that to us.
16:10:16 <tomspur> So things like mass renaming without reviews?
16:10:38 <tibbs|w> Yes, or splitting texlive or maybe mingw or even SCL packages.
16:10:55 <tibbs|w> The driving force for me was texlive.
16:11:44 <tibbs|w> But there are several things that have kind of hinged on how painful the review process is.  That's one of the things that killed the SCL discussion.
16:12:12 <tibbs|w> Another possibility is unison, where they want to create compat packages with each new version.
16:12:24 * SmootherFrOgZ here
16:12:33 <tibbs|w> Anyway, for now all I think we really need to do is have a procedure in place.
16:12:48 <tibbs|w> Once we've seen some, we can work out the rest and actually make guidelines.
16:12:49 <geppetto> #chair SmootherFrOgZ
16:12:49 <zodbot> Current chairs: SmootherFrOgZ geppetto mbooth tibbs tomspur
16:13:04 <tibbs|w> I see this as being a very rare thing anyway, and shouldn't really take much of our time.
16:14:11 <tibbs|w> But anyway, all I have left to do is re-edit the committee page in the wiki and document the procedure.  And announce it in the regular announcement.
16:14:20 <tibbs|w> And probably update the package review process page.
16:14:30 <tibbs|w> And... that's that, I guess.
16:14:49 <mbooth> tibbs|w: Sounds like you're on top of it :-)
16:15:21 <tibbs|w> I think it's something we've needed for a long time.
16:16:06 <tibbs|w> I might poke at the SCL ticket again.  They gave up in disgust because FPC demanded that this stuff be in separate packages, and they didn't want to have to deal with the review process for entire stacks.
16:16:22 <tibbs|w> But I really don't want to think about SCL stuff again.
16:17:01 <tibbs|w> Anyway, we have five now.  Hooray.
16:17:15 <geppetto> yeh
16:17:24 <geppetto> I don't think that was the only problem with SCLs
16:17:36 <tibbs|w> I think we got it to a place where we could deal.
16:17:45 * tomspur would need to leave in 40-45 mins today... :/
16:17:58 <tibbs|w> But our mandate that this crap not contaminate regular packages was too much for the folks who wanted them.
16:18:48 <geppetto> #topic Schedule
16:18:52 <geppetto> https://lists.fedoraproject.org/pipermail/packaging/2015-June/010674.html
16:19:10 <geppetto> #topic #534 	Add provides for python2-foo to python-foo packages
16:19:11 <geppetto> .fpc 534
16:19:11 <geppetto> https://fedorahosted.org/fpc/ticket/534
16:19:12 <zodbot> geppetto: #534 (Add provides for python2-foo to python-foo packages) – fpc - https://fedorahosted.org/fpc/ticket/534
16:19:45 <tibbs|w> +1 to the idea.  But it needs to be part of the macros, I think.
16:20:21 <tibbs|w> So many python-related things happening at once.
16:21:14 <tomspur> %python_provide python2-foo emits python-foo with the lua macro over there
16:21:49 <tomspur> %python_provide python3-foo can be used and added everywhere, but will do nothing for now (and we are free to change it when py2->py3 switches)
16:25:17 <geppetto> it seems fine to me
16:25:21 <tomspur> Here is the diff, when we want to forbit the plain usage of %files, when we have several python?-foo packages in one spec:
16:25:22 <tomspur> https://fedoraproject.org/w/index.php?title=User%3ATomspur%2FPackaging%3APython&diff=cur&oldid=413644
16:26:37 * geppetto nods
16:26:51 <tibbs|w> Not entirely sure that setuptools is a good package to use as an example.  It might be a bit confusing to some people.
16:27:06 <tibbs|w> But I like the idea.
16:27:53 <tibbs|w> BTW, can we just nuke the "Test your work" and "For packagers of the python interpreter" admons?
16:28:21 <tibbs|w> And the PyGTK2 and Numpy section?
16:28:39 <tibbs|w> I was going to make that a separate proposal but don't want to interfere with the rest of the work.
16:29:34 <SmootherFrOgZ> tibbs|w: +1
16:29:54 <tibbs|w> I mean, our guidelines don't really need to tell people to test their packages.
16:30:12 <tomspur> I'm unsure about the "For packagers of the python interpreter", but +1 to the rest
16:30:28 <SmootherFrOgZ> well, they should know that. it's quite obvious
16:30:48 <tibbs|w> The elite group of people who package the interpreter don't really need mention in the guidelines.
16:31:08 <tibbs|w> Anyway, don't mean to derail.
16:31:22 <tomspur> Yeah...
16:31:40 <tibbs|w> When is the "python3 as default" thing actually landing now?
16:32:05 <tomspur> rkuska wanted to do everything in smaller tickets it seems
16:32:18 <tomspur> Unfortunately, he doesn't respond do pings and cannot join today
16:32:18 <tibbs|w> Well, however it happens....
16:32:28 <tibbs|w> If we do the macros right it won't really matter.
16:32:45 <mstuchli> tomspur: I just pinged him off IRC, he should join in a little bit
16:32:56 <tomspur> mstuchli: thanks
16:33:19 <tibbs|w> Could you talk a bit more about the lua macro?
16:34:17 <tomspur> With the lua macro, one can do differentiate between python2 and python3
16:34:25 <tibbs|w> Or, I guess, why lua?  I don't have a problem with it, but for most people it pushes things beyond their understanding.
16:34:28 <geppetto> from what I can see it just handles the python-foo vs. python2-foo, so you always get both
16:34:43 <tomspur> tibbs|w: lua is directly included/suppored in rpm
16:34:49 <tibbs|w> Does the print output actually make things error?
16:34:58 <tibbs|w> Yeah, I know about the embedded lua interpreter.
16:35:18 <tibbs|w> I've done things with it, but I'm not entirely sure why it's required in this instance.
16:35:34 <tomspur> geppetto: Yes, and it is easy to switch when it will be python3 (or pypy)
16:36:12 <tibbs|w> I think we need a plan for dealing with these python tickets in some kind of order.
16:36:21 <tomspur> I couldn't find another easy way to see if the string starts with "python2". If there is another/better way, that's fine too
16:36:44 <tibbs|w> Like I said, lua is fine with me.  I think it's preferable to shelling out.
16:36:55 <geppetto> it seemeed fine to me … it's possible you could do it in "normal" macro lang. … but it might well look uglier
16:36:58 <tibbs|w> Assuming it does what you like.  The environment is kind of sparse.
16:37:21 <geppetto> Anyway, I think I'm +1
16:37:26 <tibbs|w> In any case, he who is actually doing the work gets to decide as far as I'm concerned.
16:39:11 <tomspur> rkuska: What do you think about the lua macro?
16:39:21 <tomspur> Does this help you with the route to py3?
16:39:44 <rkuska> I am kinda late to the conversation so I don't know what you talked about, about lua macro I am perfectly fine with it.
16:40:12 <tibbs|w> geppetto: Were you +1'ing the guideline or the general idea?
16:40:13 <rkuska> Altough I dont think it is really needed atm, it can wait for f24.
16:41:41 <rkuska> I've proposed #534 originaly, but after some chat with bkabrda and toshio comments I would like to move this to f24 as I think I will not have a time for this to implement and rebuild all the packages affected.
16:42:47 <geppetto> tibbs: the guidline
16:43:05 <tibbs|w> I would be +1, but again, I think using setuptools is a bit confusing.
16:43:19 <tomspur> Doing it now would give anyone more time to implement it and it doesn't interfere with just adding Provides: python-foo manually
16:43:37 <tomspur> In both cases one must edit the spec file and add one line
16:44:24 <tibbs|w> Can we just use an abstract python-foo thing instead, so nobody mixes up the python-setuptools package with the fact that their package will need to depend on python-setuptools?
16:44:42 <tibbs|w> I mean, I know it's minor.
16:44:48 <tibbs|w> And I guess I'll +1 it either way.
16:44:48 * tomspur can do so
16:44:59 <rkuska> I am +1 for python-foo (if my plus matter) :-)
16:45:03 <tibbs|w> Unless there's something special about setuptools here that I'm missing.
16:45:23 <rkuska> tibbs|w: I don't understand either why there is python-setuptools as an example
16:45:38 <tibbs|w> Maybe it was just the first package to be converted or something.
16:46:28 <tomspur> I'll edit it to use %{pypi_name} as that is used in some spec files
16:48:55 <rkuska> https://fedoraproject.org/wiki/User:Rkuska/f24packaging this is what I would like to have specfiles for python in f24 look like
16:49:39 <tibbs|w> That's still too much stuff.
16:49:48 <tibbs|w> Not that it isn't better, mind you.
16:50:37 <geppetto> Yeh, there's still a lot of %if py2 checks :(
16:50:45 <tibbs|w> I would macroize as much of the buildrequires bits as possible given the settings of with_python*
16:50:55 <tibbs|w> And default with_python* to something reasonable.
16:51:09 <tibbs|w> And why the conditional definition of py2dir?
16:51:42 <tibbs|w> Surely if we're defining all these new macros we can define that one as well.
16:51:43 <mstuchli> The build/install parts will hopefully be macroized as well
16:52:07 <tibbs|w> Yes, pretty much all of %install can be macroized.
16:52:17 <tibbs|w> Of course, if the macros don't work, anyone can do it by hand, no big deal.
16:52:23 <tibbs|w> And we should of course document that somewhere.
16:52:48 <tibbs|w> But I think the majority of modules could just be handled by a few macros.
16:52:58 <tomspur> diff with pypi_name: https://fedoraproject.org/w/index.php?title=User%3ATomspur%2FPackaging%3APython&diff=cur&oldid=413644
16:52:59 <rkuska> There was a ticket about easier packaging.
16:53:10 <tibbs|w> Yeah, there are a bunch of tickets.
16:53:33 <tibbs|w> The problem is that they all deal with the same guidelines, and we don't know if we should deal with them in any order.
16:53:55 <tibbs|w> Currently we are at +2 on 534.
16:54:09 <tomspur> +1 :)
16:54:21 <geppetto> mbooth: vote?
16:54:29 <tibbs|w> I think for the sake of the regular packagers we should do as much of the python overhaul in one announcement.
16:54:29 <geppetto> SmootherFrOgZ: vote?
16:54:36 <mbooth> +1
16:54:44 <SmootherFrOgZ> sure, +1
16:54:50 <tibbs|w> Not that we can't do an incremental thing to make sure we are happy with individual ideas about cleaning things up.
16:55:24 <tibbs|w> I think for macros, the only thing you really can't do is include things like "%check" and "%install" in the macros themselves.
16:55:27 <geppetto> #action Add provides for python2-foo to python-foo packages (+1:5, 0:0, -1:0)
16:55:30 <tibbs|w> We have in the past rejected that.
16:56:05 <geppetto> #topic #531 	Establish guidelines for use of weak dependencies in package specifications for F23.
16:56:05 <geppetto> .fpc 531
16:56:05 <geppetto> https://fedorahosted.org/fpc/ticket/531
16:56:07 <zodbot> geppetto: #531 (Establish guidelines for use of weak dependencies in package specifications for F23.) – fpc - https://fedorahosted.org/fpc/ticket/531
16:56:21 <geppetto> See if we can agree on anything here before tomspur has to go.
16:56:30 <tibbs|w> So I basically have the same opinions as last week.
16:56:56 <tibbs|w> But the whole thing about documenting this as an interim thing until we have the real thing bothers me.
16:57:18 <tibbs|w> If we're getting the real thing (enhanced dependencies or whatever) soon then why are we doing this now?
16:57:34 <tibbs|w> Sorry, "rich dependencies".
16:58:14 <geppetto> rich. deps. solve a bunch of things better, esp. 2.4 … but they want it now for 2.2 … so they can remove requires and use recommends instead
16:58:54 <geppetto> I thought they'd removed the 2.4 part about package preferences from the draft, but it seems not
16:59:20 <geppetto> I'm happy to vote on it without 2.4 in, if you want.
16:59:41 <tibbs|w> I actually like the package preference concept, but the guidelines are fine without it.
17:00:15 <tomspur> rich deps means the hints?
17:00:23 <tibbs|w> No, it's something else.
17:00:24 * geppetto nods … the concept is good … I'm just not sure if they'll eventually be done the way this policy recommends
17:00:44 <geppetto> tomspur: No richs deps. allows you to have if statements in requires
17:00:58 <geppetto> tomspur: So you can say "Requires XYZ if FOO is installed"
17:01:50 <tibbs|w> Anyone happen to know the timeline for rich deps?
17:02:04 <geppetto> F23, I think
17:02:13 <tibbs|w> Uh, so why are we doing this now?
17:02:21 <tibbs|w> F22 is already in the bag.
17:02:32 <geppetto> because people want to convert a whole bunch of requires to recommends in F23
17:02:54 <tibbs|w> But in F23 they could just use rich deps....
17:03:28 <geppetto> maybe, assuming it arrives on time … and has some policy
17:03:52 <geppetto> But I think people want to change F22 packages with weak deps.
17:05:04 <geppetto> Does anyone want to vote on this now? With or without 2.4?
17:05:10 <tibbs|w> +1 either way.
17:05:17 <tomspur> +1 also
17:05:18 <tibbs|w> Obviously without the first section.
17:05:20 <SmootherFrOgZ> yeah +1
17:05:37 <geppetto> Yeh, +1 without the first section.
17:05:42 <geppetto> mbooth: vote?
17:05:44 <tibbs|w> Also, the compatibility section at the end...
17:06:00 <tibbs|w> It conflicts with what geppetto just said about people wanting to change F22.
17:06:19 <geppetto> yeh
17:06:45 <tibbs|w> So I'm still kind of confused.  That implies that this is just for current rawhide and will go away in four months are so.
17:06:52 <mbooth> I'm +1
17:06:54 <tibbs|w> Assuming rich deps make it in by F23.
17:07:10 <geppetto> #action Establish guidelines for use of weak dependencies in package specifications, no first and last section (+1:5, 0:0, -1:0)
17:07:28 <geppetto> tomspur: You stay for another ticket?
17:08:02 <tomspur> A quick one would be fine
17:08:03 <geppetto> #topic #538 	Bundling exception for htmlunit-core-js
17:08:04 <geppetto> .fpc 538
17:08:04 <geppetto> https://fedorahosted.org/fpc/ticket/538
17:08:05 <zodbot> geppetto: #538 (Bundling exception for htmlunit-core-js) – fpc - https://fedorahosted.org/fpc/ticket/538
17:09:18 <tibbs|w> The diff is big; seems to be a plain fork to me.
17:09:37 <geppetto> The diff is big, but I doubt it's really a fork :(
17:10:20 <tibbs|w> Hmmm.
17:10:33 <tibbs|w> How many files are we talking about here?
17:10:43 <tibbs|w> For some reason I thought it was only a couple.
17:11:15 <tibbs|w> Oh, rhino is huge and they're not just taking a bit of it.
17:11:22 <tibbs|w> Would have been nice to tell us that in the ticket.
17:11:32 <geppetto> http://htmlunit.sourceforge.net/gettingLatestCode.html
17:11:39 <geppetto> Says "forked rhino"
17:11:49 <tomspur> The diff doesn't look too big
17:12:05 <geppetto> https://github.com/HtmlUnit/htmlunit-core-js
17:12:08 <tomspur> Why isn't the feature implementation pushed back...?
17:12:08 <mbooth> Like 2 and a half dozen changed files
17:12:14 <tibbs|w> It looks big if we're talking about one or two files.
17:13:03 <geppetto> It isn't one or two files:
17:13:09 <geppetto> https://github.com/HtmlUnit/htmlunit-core-js/tree/master/src/net/sourceforge/htmlunit
17:13:30 * tomspur would expect a bigger diff given that this is java
17:13:33 <geppetto> And this seems old and non-maintained
17:14:55 <geppetto> Looking at the upstream rhino … it appears that significant parts of it aren't changing there either
17:15:09 <tibbs|w> Not a fan given the information we have available.
17:15:15 <geppetto> yeh
17:15:51 <tibbs|w> This is one of those things where if we had more information available we might make a more favorable decision.
17:16:16 <geppetto> Yeh, I think they'd be much better off filling out the normal bundling questions
17:16:21 <tibbs|w> Like the opinions of the upstreams involved, info about what has been sent upstream, etc.
17:16:47 <tibbs|w> I suggest we just say no unless more information is provided.
17:17:04 * geppetto nods
17:17:11 <tibbs|w> Another needinfo ticket.  Joy.
17:17:36 <geppetto> That leaves 533 for new tickets we haven't looked at
17:17:42 <geppetto> But I doubt it'll be quick
17:17:48 <geppetto> #topic Open Floor
17:18:08 <tibbs|w> I don't understand why 533 is so long.
17:18:25 <tibbs|w> We have a distinction between applications and modules in various places.
17:19:03 <geppetto> rkuska:
17:19:05 <tibbs|w> Just change the current guidelines (the "py3 is mandatory if supported" bit)
17:19:16 <tomspur> +1 for distinguishing between them, but I'd need to leave now
17:19:44 <tibbs|w> Say modules have to be packaged; applications don't have to be but should be if it makes sense.  Just make sure that the names differ.
17:20:00 <tomspur> I can vote later on in the ticket for the guidelines diff...
17:20:23 <tibbs|w> I don't see a need to do much more; there's always going to be a question about what's an application and what's a module, but packagers have been getting it right for a decade now.
17:20:50 * geppetto nods
17:20:56 <rkuska> the aim of my proposal is to let application packagers use unversioned python macros
17:21:31 <geppetto> tibbs: doesn't this overlap with one of your python proposals?
17:21:59 <tibbs|w> Well, it overlaps with the "py3 packaging is mandatory if supported" thing.
17:22:06 <tibbs|w> Which is already in the current guideline.
17:22:42 <geppetto> ahh
17:23:02 <tibbs|w> But that works for both modules and applications.
17:23:20 <tibbs|w> In Fedora we have multiple python runtimes, one for each supported major release. At this point that's one for python2.x and one for python3.x. If a piece of software supports python3, it must be packaged for python3. If it supports python2 as well, it may be packaged for python2. If it supports only python2 then it must not be packaged for python3
17:23:35 <tibbs|w> That's the current guidleine, minus the period which my paste left off for some reason.
17:24:16 <tibbs|w> Personally I think that's enough, actually.
17:25:00 <tibbs|w> I know there's desire to allow some things to just use the unversioned macros, but at this point I don't see why.
17:25:18 <rkuska> Well, you could use one specfile across different fedora versions
17:25:20 <tibbs|w> Just do py3 as soon as the app supports it and don't care when the unversioned stuff switches.
17:25:21 <rkuska> And also in epel
17:25:35 <tibbs|w> I disagree with that in general.
17:26:07 <tibbs|w> epel is just not going to work anyway given all of the changes we're making.
17:26:52 <tibbs|w> And old Fedora, I don't get.  They all have python3 currently.
17:27:33 <geppetto> part of me wants there to be a simple solution for simple python apps.
17:27:37 <tibbs|w> RIght now old Fedora is F21.
17:27:46 <rkuska> yes, but applications shipped on live dvd should be built with default python which for fedora < 23 is python2
17:27:50 <tibbs|w> I think the simple solution is package for py3 and be done with it.
17:28:08 <tibbs|w> No change you make in F22 is going to change what's on the live DVD now.
17:28:16 <geppetto> But I'm not sure adding stuff to do that is the win, plus a huge number of python apps. are also modules anyway
17:28:51 <tibbs|w> When you package an app/module combo, you just don't ship the executables in the py2 package.
17:29:41 <tibbs|w> Or, sure, you package them under a different name.  Our guidelines already cover this.
17:30:20 <rkuska> Is it possible atleast add a section about python applications? Because of naming, as applications dont need python- prefix and also should be built only with one interpreter
17:31:09 <geppetto> don't we already have something saying that?
17:31:44 <tibbs|w> https://fedoraproject.org/wiki/Packaging:Python#Executables_in_.2Fusr.2Fbin
17:32:00 <tibbs|w> Naming of these is handled generally and doesn't need to be in the python-specific guidelines.
17:33:06 <rkuska> ok
17:33:31 <tibbs|w> It's basically a packager choice thing anyway.
17:34:58 * geppetto nods
17:36:06 <geppetto> Ok, so anything else we want to discuss?
17:36:32 <tibbs|w> Nothing from me.
17:36:54 <geppetto> Ok, I'll close the meeting in a couple of minutes then
17:37:04 <geppetto> Thanks for coming, and see you next week.
17:37:19 <rkuska> Bye
17:37:56 <tibbs|w> Thanks again.
17:38:35 <geppetto> #endmeeting