fpc
LOGS
16:01:41 <geppetto> #startmeeting fpc
16:01:41 <zodbot> Meeting started Thu May 14 16:01:41 2015 UTC.  The chair is geppetto. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:01:41 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:01:41 <geppetto> #meetingname fpc
16:01:41 <zodbot> The meeting name has been set to 'fpc'
16:01:41 <geppetto> #topic Roll Call
16:01:44 <limburgher> Nope.  Maybe I should start running xchat through Tor. ;)P
16:01:49 * limburgher here
16:01:56 <orionp> morning
16:02:09 <geppetto> #chair limburgher
16:02:09 <zodbot> Current chairs: geppetto limburgher
16:02:12 <geppetto> #chair tibbs
16:02:12 <zodbot> Current chairs: geppetto limburgher tibbs
16:02:15 <geppetto> #chair orionp
16:02:15 <zodbot> Current chairs: geppetto limburgher orionp tibbs
16:02:38 <mbooth> Hello
16:02:47 <geppetto> #chair mbooth
16:02:48 <zodbot> Current chairs: geppetto limburgher mbooth orionp tibbs
16:02:56 <geppetto> hey everyone :)
16:03:50 <tibbs|w> Howdy.
16:03:51 * limburgher waves
16:04:20 <tibbs|w> We were down to 10 tickets....
16:04:32 <limburgher> Le sigh
16:04:37 <tibbs|w> Actually I could do an announcement and get rid of a couple.
16:04:48 <tibbs|w> Will do that after the meeting.
16:04:54 <geppetto> #chair tomspur
16:04:54 <zodbot> Current chairs: geppetto limburgher mbooth orionp tibbs tomspur
16:05:08 <tibbs|w> racor won't be here today.
16:05:10 * tomspur is finally here... Seems irc with ipv6 is not working over here...
16:05:11 <geppetto> tomspur: I assume you are here ?:-o
16:05:24 <geppetto> so … situation normal with ipv6 then ;)
16:06:19 <geppetto> Ok, well we can start
16:06:24 <geppetto> #topic Schedule
16:06:28 <geppetto> https://lists.fedoraproject.org/pipermail/packaging/2015-May/010648.html
16:06:44 <geppetto> Anyone here for anything specific?
16:06:58 <geppetto> #topic #530 	request copylib exception for dcraw.c
16:06:59 <geppetto> .fpc 530
16:06:59 <geppetto> https://fedorahosted.org/fpc/ticket/530
16:07:00 <zodbot> geppetto: #530 (request copylib exception for dcraw.c) – fpc - https://fedorahosted.org/fpc/ticket/530
16:07:21 <tibbs|w> My opinions are all in the ticket.
16:08:09 <geppetto> "it is, apparently, managed with RCS upstream"
16:08:11 <limburgher> It was suggested in the recent CVE BZ for LibRaw that I include bundles(dcraw)n.
16:08:24 <geppetto> I saw your comment about globals yesterday or tuesday
16:09:30 <tibbs|w> We should certainly document the bundling in all instances where it exists.
16:09:33 <geppetto> my opinion is roughly the same as yours and the nicest way to express it is probably "upstream too stupid/apathetic to release library/API"
16:09:40 <tibbs|w> But I'm not up for a blanket exception.
16:10:24 <tibbs|w> It's just an old-school programmer with some old-school code.  Which is fine, but don't bundle it.
16:10:31 <limburgher> geppetto: +1
16:10:41 <mbooth> The more software I look at, the more I consider becoming a garderner...
16:10:50 <tibbs|w> He wants it called as a separate executable.  That's fine.  Things that want to use it should obey his  wishes.
16:10:56 <geppetto> mbooth: +1
16:10:59 <orionp> duct tape and bailing wire
16:13:15 <tibbs|w> So, I doubt we'd get +5 on a blanket exception here.
16:13:16 <orionp> So, do we have a proposal here?  I'm not clear on that
16:13:38 <tibbs|w> The proposal was for a blanket copylib exception for dcraw.
16:13:40 <geppetto> Yeh, I think we are all in favour of everything that includes this to have to use a bundled()
16:13:54 <geppetto> But also to has as few things as possible bundle it
16:14:28 <tibbs|w> As I wrote in the ticket, I would vote for an exception for libraw, assuming it's just not considered to be forking the dcraw code wholesale.
16:15:00 <Rathann> hi guys
16:15:04 <Rathann> sorry but I can't stay
16:15:06 <geppetto> #chair Rathann
16:15:06 <zodbot> Current chairs: Rathann geppetto limburgher mbooth orionp tibbs tomspur
16:15:10 <Rathann> have a bit of emergency at home
16:15:13 <geppetto> ok, no problem
16:15:30 <Rathann> if there are not enough votes, I'll vote in the tickets later
16:15:31 <geppetto> Yeh, I'd consider libraw a fork
16:15:32 <Rathann> bye
16:15:33 <limburgher> I haven't looked at the code yet, been AFK for a few weeks and getting caught up.  Just updated to current where possible and backported the patch for f20.
16:17:35 <tomspur> Seems like it is a lot of work to port to libraw?
16:18:08 <tibbs|w> Yeah, it is.
16:18:21 <tibbs|w> Anyway, what else can we do here?
16:18:22 <geppetto> yeh, probably … but I don't see any other good options
16:20:40 <tibbs|w> We're not going to get to +5 for a blanket exception.
16:20:59 <tibbs|w> We could, I suppose, vote on an exception for libraw.
16:21:22 <tibbs|w> Otherwise I think we ask the various packages which bundle dcraw to document that.
16:21:37 <geppetto> Not sure it's worth it … given how forky it seems
16:21:43 <tibbs|w> I agree.
16:21:50 <geppetto> #action Everything using it should add a bundled(dcraw), until it's a true fork.
16:22:25 <geppetto> #action It's way too big and messy to be classified as a copylib though, any potential users should probably look at moving to libraw
16:22:39 <geppetto> #topic #528 	Allow Mono 4.0 to be bootstrapped with monolite
16:22:40 <geppetto> .fpc 528
16:22:40 <geppetto> https://fedorahosted.org/fpc/ticket/528
16:22:42 <zodbot> geppetto: #528 (Allow Mono 4.0 to be bootstrapped with monolite) – fpc - https://fedorahosted.org/fpc/ticket/528
16:22:53 <geppetto> this seemed kind of trivial to me
16:23:08 <geppetto> I'm somewhat surprised we needed to get invovled to rebootstrap something
16:23:31 <mbooth> +1 -- seems sensible enough
16:23:38 <limburgher> Yeah.  E_JUSTDOIT
16:23:38 <geppetto> +1
16:23:53 <limburgher> +1
16:23:53 <tomspur> +1
16:24:26 <orionp> +1 - the guidelines say to contact the FPC
16:24:45 <tomspur> I think it is good to be aware of any bootstrapping
16:24:57 <tibbs|w> +1
16:24:59 <geppetto> Fair enough
16:25:01 <geppetto> #action Reboostrap mono with monolite binaries (+1:7, 0:0, -1:0)
16:25:12 <geppetto> #topic #527 	AppData for Application Addons
16:25:13 <geppetto> .fpc 527
16:25:13 <geppetto> https://fedorahosted.org/fpc/ticket/527
16:25:13 * tibbs|w presses easy button.
16:25:14 <zodbot> geppetto: #527 (AppData for Application Addons) – fpc - https://fedorahosted.org/fpc/ticket/527
16:25:23 <tibbs|w> I haven't had time to look at this.
16:25:57 <geppetto> https://fedoraproject.org/w/index.php?title=User%3AVondruch%2FDraftAppDataGuidelines&diff=412575&oldid=412571
16:26:02 <geppetto> Is the new policy/diff
16:26:25 <tibbs|w> Does anyone else find the whole MUST and SHOULD thing annoying?
16:27:08 <tibbs|w> I know it comes from RFCs but I've always had a preference for just writing English without yelling where possible.
16:27:27 <limburgher> A little but I think it helps call attention to it for those with a tendency to skim.
16:27:31 <tibbs|w> There are minor grammatical errors which I could fix up later if approved.
16:27:46 <geppetto> it's probably better to yell a little bit in packaging instructions/policy
16:28:04 <geppetto> I can't see anything that makes me not want to +1 … so +1
16:28:25 <mbooth> This change basically documents what I have already been doing... so +1
16:28:58 <mbooth> Except I haven't been validating my metadata files... oops
16:29:01 <tibbs|w> Note also that "appdata-validate --relax" seems to have changed to "appstream-util validate-relax".
16:29:02 <tomspur> I think validating belongs to %install
16:29:17 <geppetto> tibbs: yeh, vond mentioned that in the ticket
16:29:25 <limburgher> +1
16:29:41 <tibbs|w> That is a "just do it" in any case.
16:30:28 <tibbs|w> Is there a better location for the AppData spec page besides hugsie's personal page on freedesktop?
16:30:46 <tibbs|w> The appstream spec page has an "official" location.
16:30:59 <orionp> +1
16:31:02 <tibbs|w> Anyway, I'm just asking random questions.
16:31:06 <tibbs|w> +1 in any case.
16:31:23 <tomspur> Only AppData must be validated but not AppStreams?
16:31:43 <tibbs|w> Also the last section needs a rename, which I will take care of.
16:32:00 <tibbs|w> tomspur: My best guess is that appstream-util does both.
16:32:14 * tomspur would guess so too
16:32:34 <tibbs|w> Third section of the diff says that appdata must be validated with appstream-util, so....
16:33:17 <tomspur> +1 on the guideline, the validation of appstream data can be added/asked for in the ticket
16:34:04 <tomspur> e.g. in the examples of usages for a *..metainfo.xml would be fine
16:34:33 * tomspur needs to go also soonish because of the holiday over here...
16:34:49 <geppetto> no problem … this is the lastof the new tickets
16:34:58 <geppetto> And I don't think we really have anythng to do on the old tickets
16:34:59 <tibbs|w> Which holiday is it, BTW?
16:35:07 <tibbs|w> I did make a little progress in some of them.
16:35:15 <geppetto> oh, cool
16:35:26 <tibbs|w> Did 527 pass?
16:35:38 <geppetto> it's really close atm.
16:35:45 <geppetto> but a couple of people haven't voted
16:35:48 <mbooth> 6 +1s, no?
16:35:59 <tomspur> Ascension Thursday and Fathers Day
16:36:16 <geppetto> I get +5
16:36:27 <tibbs|w> Yeah, I see +5 as well.
16:37:15 <tibbs|w> No, +6; didn't catch mbooth's at teh end of the line.
16:37:29 <geppetto> Ohh, is that everyone now?
16:37:37 <tomspur> Seems so :)
16:37:46 <geppetto> #action AppData for application Addons (+1:6, 0:0, -1:0)
16:37:51 <geppetto> thought we had 7 at one point
16:38:00 <tibbs|w> Rathann came and went.
16:38:10 * geppetto nods
16:39:04 * geppetto shrugs
16:39:12 <geppetto> #topic Open Floor
16:39:29 <geppetto> tibbs: So any of 281/508/513 you want to talk about?
16:39:42 <tibbs|w> .fpc 126
16:39:44 <zodbot> tibbs|w: #126 (bundling exception for scintilla) – fpc - https://fedorahosted.org/fpc/ticket/126
16:39:49 <geppetto> ha
16:39:58 <tibbs|w> Oh, wait, we talked about this last week, didn't we?
16:40:05 <geppetto> yeh
16:40:09 * tomspur needs to go... sorry. See you next week
16:40:16 <geppetto> tomspur: see ya
16:40:17 <tibbs|w> There's really nothing else we can do to that one, I think.
16:40:30 <mbooth> This one also makes me want to become a gardener...
16:40:37 * orionp wonders what broke mock...
16:40:48 <tibbs|w> I mean, if there was a real scintilla package that someone was willing to maintain, perhaps two or three of the bundlings might be able to be cleaned up.
16:41:00 <tibbs|w> Certainly scite, because it doesn't modify the bundled copy.
16:41:05 <tibbs|w> And probably qscintilla.
16:41:17 <tibbs|w> But the rest, we may just have to live with.
16:41:32 <tibbs|w> Unless someone wants to grab the power and say we can start forcing change.
16:41:45 <mbooth> tibbs|w: How much work is it would a real scintilla package be? I mean, how often do new versions appear?
16:41:56 <tibbs|w> Every few months, I think.
16:42:02 <tibbs|w> It does have an active upstream.
16:42:18 <mbooth> I could maybe take it on, if it was low maintainence
16:42:29 <tibbs|w> I would suggest that it be a joint project between the qscintilla and scite maintainers.
16:42:35 <tibbs|w> If I could just hand out effort like that.
16:42:59 <tibbs|w> rdieter said he's been meaning to do it if he could find the time.
16:43:08 <tibbs|w> So there would probably be some help there.
16:43:31 <tibbs|w> But I haven't even looked at it, and that's the first step.  I guess a static library would be preferable to the current state.
16:43:43 <mbooth> Indeed
16:43:54 <tibbs|w> Anyway....
16:43:57 <tibbs|w> .fpc 529
16:43:58 <zodbot> tibbs|w: #529 (Bootstrap recipes for stages 1-3 in fedora git) – fpc - https://fedorahosted.org/fpc/ticket/529
16:44:05 <tibbs|w> Does anyone understand this at all?
16:44:17 <tibbs|w> I mean, I understand what they're trying to do, but not at all how they plan to do it.
16:44:42 <mbooth> Is this even in our remit?
16:44:50 <mbooth> They just want a git repo?
16:44:55 <tibbs|w> It depends on how they plan to do it, I think.
16:45:37 <geppetto> I don't think they want a git repo. … I think they want to do something to a bunch of git repos. for packages
16:45:44 <tibbs|w> If they're talking about basically importing some new packages, not our business unless they want to skip the review process and FESCo decided they want us involved in that.  (WHich is a discussion for a bit later.)
16:46:11 <tibbs|w> If they're indeed going to go in and make changes to existing packages to add some macros or ifdefs or something then, yeah, that's our business.
16:46:28 <tibbs|w> But so far we just have a "you have to pass it to see it" kind of thing.
16:46:53 <geppetto> I _think_ they want to store a few extra files in Fedora git for some core packages, which will do something during RCM (or mass rebuilds? or somewhere else?)
16:47:11 <tibbs|w> It could be that they're asking if we would be amenable to accepting such a thing before they go working on it, but I doubt it.
16:47:21 <geppetto> ¯\_(ツ)_/¯
16:47:38 <tibbs|w> If they just want to check other files into current packages.... they should feel free.
16:47:46 <tibbs|w> If they want to modify the spec files, please tell us how.
16:48:15 <mbooth> So we should ask all this in the ticket then
16:48:28 <tibbs|w> If they want to import specs under different names, that does currently violate the guidelines but I would be happy to give them an exception.
16:48:36 <tibbs|w> I've kind of been asking but haven't gotten many answers.
16:48:53 <tibbs|w> I will convert the questions we've come up with here into more direct questions for them.
16:49:06 <tibbs|w> There may be a bit of a language barrier here as well; I'm not sured.
16:49:12 <geppetto> I guess also point them to this discussion when asking the next question … so it's obvious we don't know what they want or why
16:49:12 <mbooth> "Moreover, I need approval/blessing for pushing the recipes to the fedora git as some owners/maintainers could take it as touching their sources without permission." -- just ask the maintainers?
16:49:53 <tibbs|w> Yeah, or just use provenpackager.  I mean, if this is just some random extra files, jeez.
16:50:11 <geppetto> If they want to push some files into some core packages … I guess I'd +1 that … but they'd be much better off asking people so those maintainers know wtf those files are there for and don't just delete them
16:50:52 <tibbs|w> I don't even think we need to +1 that; it doesn't violate any existing guidelines to do that.
16:51:00 * geppetto nods
16:52:01 <tibbs|w> So, basically, if they're modifying existing specs, they should tell us how.  If they're going to be uploading other things which are essentially specs, we should discuss it but I doubt we'd have any issue approving it.  And if they're not doing either, then they should just go ahead.
16:53:31 <tibbs|w> Where is my python proposal?
16:53:39 <tibbs|w> Ah...
16:53:42 <tibbs|w> .fpc 526
16:53:44 <zodbot> tibbs|w: #526 (Mandatory python3 packaging when upstream supports python3) – fpc - https://fedorahosted.org/fpc/ticket/526
16:54:18 <tibbs|w> I thought that was on the agenda anyway.
16:54:30 <tibbs|w> Anyway, does anyone have any input?
16:54:49 <tibbs|w> Basically, if your python module supports python3, build it for python3.
16:54:57 <geppetto> I looked at it … I thought it was part of the py3 as default feature
16:55:00 <limburgher> I think it's probably a good idea, especially for new packages, for future-proofing.
16:55:03 <geppetto> so was a bit confused
16:55:27 <tibbs|w> If it was part of the py3 as default thing, I didn't see it get proposed to us.
16:55:33 <tibbs|w> The guidelines would have to change at some point.
16:55:47 <tibbs|w> Or have I still been misssing that requirement in the guidelines all along?
16:56:33 <geppetto> I mean … I just expected that when py3 was default then everything using python would be required/heavily-encouraged to move
16:57:07 <tibbs|w> Well, that's happening for F23, which has been a real thing for a while now, and yet.. no guideline change proposal.
16:57:12 <tibbs|w> Well, until I made one.
16:57:35 <orionp> I'm +
16:57:38 <orionp> +1
16:57:56 <tibbs|w> +1 obviously.
16:58:09 <geppetto> sure +1
16:58:51 <limburgher> +1
16:58:57 <geppetto> #topic #526 Mandatory python3 packaging when upstream supports python3
16:59:38 <mbooth> +1
16:59:54 <geppetto> #action Mandatory python3 packaging when upstream supports python3 (+1:5, 0:0, -1:0)
16:59:59 <tibbs|w> Well that was easy.
17:00:03 <geppetto> :)
17:00:10 <geppetto> #topic Open Floor
17:00:14 <tibbs|w> Also note the bit at the end.
17:00:16 <tibbs|w> https://github.com/fedora-python/packaging-guidelines/
17:00:44 <tibbs|w> I guess github is as good a place as any, except it seems counterproductive to go back and forth between formats.
17:01:32 <tibbs|w> Also I did make some progress on 497.
17:01:39 <tibbs|w> The "clean up buildrequires" thing.
17:02:06 <tibbs|w> I floated it again on packaging and it seems like the feedback is positive, but the details are painfully difficult to pin down.
17:02:24 <tibbs|w> And I'm sort of running out of steam to push it forward.
17:02:55 <geppetto> It seems fine to me
17:03:21 <geppetto> At least if we want to move away from the current system … this seems like a great starting point
17:03:27 <tibbs|w> Indeed.
17:03:39 <tibbs|w> Really I just want to let releng decide what's in the buildroot and keep us out of it.
17:03:48 <geppetto> You want to vote on it?
17:04:01 <tibbs|w> Is the wording good enough now?
17:04:18 <geppetto> As I said, it seems fine to me
17:04:19 <tibbs|w> https://fedoraproject.org/wiki/User:Tibbs/BuildReqDraft
17:04:30 <geppetto> #topic #497 Clean up BuildRequires section; don't try to define the minimal build env
17:04:36 <geppetto> https://fedoraproject.org/wiki/User:Tibbs/BuildReqDraft
17:04:53 <geppetto> .fpc 497
17:04:54 <tibbs|w> Wait, I swear I changed it since that URL was posted.
17:04:55 <zodbot> geppetto: #497 (Clean up BuildRequires section; don't try to define the minimal build env) – fpc - https://fedorahosted.org/fpc/ticket/497
17:05:13 <tibbs|w> What the hell?
17:05:30 <tibbs|w> The wiki hates me, and I hate it.
17:05:44 <tibbs|w> Anyway, it's just the paragraph in comment 16, not what's currently on the wiki.  Sorry.
17:06:14 <geppetto> Ok, +1 to comment 16
17:06:20 <tibbs|w> +1 obviously.
17:06:30 <orionp> I like it +1
17:07:44 <mbooth> +1
17:07:51 * mbooth likes conciseness
17:08:14 <geppetto> limburgher: vote?
17:08:34 <limburgher> I think I'm +1.
17:08:40 <geppetto> #action Clean up BuildRequires section; don't try to define the minimal build env (+1:5, 0:0, -1:0)
17:08:49 <geppetto> #topic Open Floor
17:09:01 <geppetto> Ok … I think we are probably good now
17:09:07 <tibbs|w> Yeah, I'm out.
17:09:14 <tibbs|w> Oh, shit.
17:09:25 <geppetto> ?
17:09:28 <tibbs|w> There was one thing I wanted to make us aware of.
17:09:43 <tibbs|w> Have to dig it up.
17:10:02 <tibbs|w> .fesco 1435
17:10:04 <zodbot> tibbs|w: #1435 (Approving exceptions to the package review process) – FESCo - https://fedorahosted.org/fesco/ticket/1435
17:10:27 <tibbs|w> I filed that with fesco, but the details may come back to us.
17:11:02 * limburgher sighs
17:11:05 <tibbs|w> Basically, if someone wants to do a mass import or work around the arduous package review process (like, dunno, a texlive split or importing an scl stack if that was a thing).
17:11:31 <tibbs|w> Should be rare, but it is packaging and we might end up being asked to approve them.
17:11:47 * geppetto nods
17:12:04 <tibbs|w> Anyway, nothing really to discuss; I just wanted to make sure folks were aware of it.
17:12:35 <tibbs|w> I will write the process if it comes down to that, no big deal.
17:12:49 <mbooth> Thanks tibbs|w, CC'd myself
17:12:59 <tibbs|w> limburgher: Why the sigh, BTW?
17:13:26 <limburgher> tibbs|w: Thinking about texlive, that's all.
17:13:30 <geppetto> yeh, me too … we can all now crash into each other on the Cc bandwagon ;)
17:13:31 <tibbs|w> Ah, yeah.
17:14:25 <geppetto> Ok, well I'll close the meeting in a minute unless any brings up anything else
17:14:26 <tibbs|w> I think if we had this we wouldn't have had the current texlive situation.
17:14:36 <tibbs|w> And maybe the scl thing wouldn't have hit a brick wall.
17:14:41 <geppetto> Have a nice lunch, and I'll see you next week.
17:14:46 <tibbs|w> Thanks, folks.
17:14:50 * limburgher waves
17:15:32 <geppetto> #endmeeting