fpc
LOGS
17:01:00 <geppetto> #startmeeting fpc
17:01:01 <zodbot> Meeting started Thu Feb 26 17:01:00 2015 UTC.  The chair is geppetto. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:01:01 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
17:01:01 <geppetto> #meetingname fpc
17:01:01 <zodbot> The meeting name has been set to 'fpc'
17:01:01 <geppetto> #topic Roll Call
17:02:01 <geppetto> limburgher mbooth orionp racor Rathann SmootherFr0gZ spot tibbs|w tomspur: FPC ping
17:02:11 <mbooth> Hi geppetto
17:02:16 <orionp> hello
17:02:16 <geppetto> #chair mbooth
17:02:16 <zodbot> Current chairs: geppetto mbooth
17:02:22 <geppetto> #chair orionp
17:02:22 <zodbot> Current chairs: geppetto mbooth orionp
17:02:26 <geppetto> #chair tibbs
17:02:26 <zodbot> Current chairs: geppetto mbooth orionp tibbs
17:02:30 <geppetto> hey :)
17:02:33 <tibbs> Hey, folks.
17:02:38 * tomspur is here
17:02:40 * limburgher is nearly here
17:02:42 <geppetto> #chair tomspur
17:02:42 <zodbot> Current chairs: geppetto mbooth orionp tibbs tomspur
17:02:45 <geppetto> #chair limburgher
17:02:45 <zodbot> Current chairs: geppetto limburgher mbooth orionp tibbs tomspur
17:03:04 <tibbs> I'm feeling like absolute crap today and have been since last Friday, so I'm around but pretty much useless.
17:03:13 * Rathann here
17:03:18 <limburgher> tibbs: :(
17:03:24 <geppetto> #chair Rathann
17:03:24 <zodbot> Current chairs: Rathann geppetto limburgher mbooth orionp tibbs tomspur
17:03:59 <geppetto> :( … a lot of that this year
17:04:00 * racor is here
17:04:03 <geppetto> #chair racor
17:04:03 <zodbot> Current chairs: Rathann geppetto limburgher mbooth orionp racor tibbs tomspur
17:04:17 <geppetto> #topic Schedule
17:04:19 <Rathann> nice, 8/9 members present :)
17:04:23 <geppetto> https://lists.fedoraproject.org/pipermail/packaging/2015-February/010483.html
17:05:08 <geppetto> #topic #501 	Fix bootstrap guidelines
17:05:12 <geppetto> https://fedorahosted.org/fpc/ticket/501
17:05:20 <tibbs> I haven't done any writeups or anything this whole week; please just skip 497 when it comes around.
17:05:29 <geppetto> tibbs: no problem
17:06:43 <geppetto> So any of the really old members remember why the wording is what it is here?
17:07:03 <mbooth> geppetto: This is bootstrapping guideline we added recently
17:07:19 <mbooth> Looks like just logic error in the example?
17:07:32 <Rathann> apparently yes
17:07:34 <geppetto> maybe, I'm not sure … it does seem opposite of what I'd expect
17:08:32 <Rathann> looks like a proper fix to me, I wonder why we missed it before
17:08:56 <limburgher> Rathann:  This is what happens when you let humans get involved. . .
17:09:04 <geppetto> Proposal: Reverse conditionals in bootstrap examples, to make it less confusing
17:09:05 <Rathann> :D
17:09:11 <Rathann> geppetto: +1
17:09:13 <geppetto> +1
17:09:13 <orionp> looks good to me +1
17:09:15 <mbooth> +1
17:09:17 <limburgher> +1
17:09:27 <racor> +1, but ...
17:09:28 <tomspur> +1 also for the provides
17:09:47 <racor> there is another issue lurking.
17:10:08 <geppetto> tibbs: yeh, meant both examples
17:10:12 <geppetto> racor: what's that?
17:10:51 <racor> which values can %bootstrap take. bootstrap=0, bootstrap=1 and bootstrap= undefined?
17:11:28 <Rathann> all 3 should be considered valid
17:11:29 <geppetto> yeh, pretty normal. undefined == 0, convention
17:11:30 <racor> the perl_bootstrap macros can take "undefined" and "defined"
17:12:11 <racor> In perl, we use %if !%{defined perl_bootstrap}
17:12:14 <tomspur> If bootstrap is not undefined -> 0{?bootstrap} evaluates to 0
17:12:33 <tomspur> If bootstrap is not defined -> 0{?bootstrap} evaluates to 0
17:12:39 * geppetto nods
17:13:07 <geppetto> tibbs: You want to vote?
17:13:49 <geppetto> #action Proposal: Reverse conditionals in bootstrap examples, to make it less confusing (+1:7, 0:0, -1:0)
17:13:58 <geppetto> #topic #435     %py3dir not removed by rpmbuild --clean
17:14:03 <geppetto> https://fedorahosted.org/fpc/ticket/435
17:14:17 <geppetto> https://fedoraproject.org/wiki/PackagingDrafts:Python
17:14:24 <geppetto> diff: https://fedoraproject.org/w/index.php?title=PackagingDrafts%3APython&diff=403829&oldid=403815
17:14:27 <racor> correct, but then we have inconsistent semantics, differing between %perl_bootstrap and the %bootstrap
17:14:32 <geppetto> Rathann: you want to say anything?
17:14:38 <Rathann> basically it's s/%{py3dir}/python3/g
17:14:56 <Rathann> and moving main source on level below builddir
17:15:39 <Rathann> you can also take a look at python-fastcache as an example (uses differently named dirs, but the spirit is the same)
17:15:50 <geppetto> Ok, looks fine to me
17:15:51 <geppetto> +1
17:16:07 <Rathann> +1
17:16:26 <limburgher> +1
17:18:07 <tibbs> Kind of wish we had macros for those find calls.
17:18:37 <Rathann> tibbs: which ones?
17:18:39 <tibbs> But, meh, python packaging is already pretty nasty and this makes sense.
17:18:53 <Rathann> I guess I could take a shot at macroizing some parts
17:18:57 <tibbs> The ones fixing up the #! lines.
17:19:00 <Rathann> ah
17:19:27 <tibbs> Anyway, +1.
17:19:54 <orionp> +1 - really like having everything under the builddir
17:19:54 <racor> 0
17:20:23 <tomspur> Rathann: Should we allow building in one directory, when the package builds in different build subdirectories?
17:20:49 <Rathann> tomspur: if it supports out-of-dir builds, sure
17:20:59 <Rathann> as long as they're under the builddir
17:21:10 <Rathann> %{py3dir} was a mistake IMHO
17:22:10 <geppetto> mbooth: vote?
17:22:17 <mbooth> +1
17:22:17 <tomspur> Could that be maybe mentioned in the description directly above the spec example
17:22:30 <geppetto> #action Policy change to remove py3dir from python policy (+1:6, 0:1, -1:0)
17:22:32 <tomspur> e.g. after "we copy the source tree to python3 so that" ...
17:23:28 <geppetto> Rathann: what do you think?
17:24:00 <Rathann> sure, one minute, I'll add some wording there
17:24:07 <geppetto> ok, no problem
17:28:57 <Rathann> ok, refresh
17:29:38 <tomspur> +1
17:30:08 <tomspur> Rathann: thanks
17:31:07 <geppetto> +1
17:31:12 <Rathann> and reworded a bit again
17:31:30 <Rathann> I think it conveys what tomspur wanted a bit better
17:31:36 <geppetto> yeh
17:32:27 <Rathann> tomspur: still ok with current wording?
17:32:59 <tomspur> Rathann: yes +1 :)
17:33:37 <Rathann> even though I'd think that's an obvious thing, practice shows it's often necessary to spell things out, so thanks for bringing it up
17:33:57 <Rathann> cool
17:34:01 <geppetto> Anyone else want to vote on the note?
17:34:13 * tomspur could imagine to receive reviews, that you must to it in two folders, no matter what...
17:34:23 <geppetto> It's probably trivial enough to not bother, but while we're here :)
17:34:26 <limburgher> +1
17:34:47 <tibbs> +1 on the note.
17:35:19 * Rathann obviously +1 as well ;)
17:35:56 <orionp> +1
17:39:12 <geppetto> #action Extra note about copies (+1:6, 0:0, -1:0)
17:39:21 <geppetto> #topic #338     %doc and %_pkgdocdir duplicate files and cause conflicts
17:39:26 <geppetto> https://fedorahosted.org/fpc/ticket/338
17:39:40 <geppetto> Draft: ​https://fedoraproject.org/wiki/User:Tibbs/DocdirDraft#Documentation
17:39:47 <geppetto> diff: ​https://fedoraproject.org/w/index.php?title=User%3ATibbs%2FDocdirDraft&diff=cur&oldid=404105
17:40:10 <geppetto> tibbs: want to say anythign?
17:41:00 <tibbs> Don't think I have much to add.
17:41:11 <tomspur> tibbs: you mean with "in the proper documentation directory" %_pkgdocdir ?
17:42:46 <tibbs> Well, I was replacing "as %doc" which is kind of contradictory.
17:43:06 * tomspur would understand "in %_pkgdocdir" or something like that, but is a bit confused now
17:43:59 <tibbs> I didn't imagine that could be confusing, but I could change it.
17:44:28 <tibbs> The second paragraph tells you explicitly how to put the files in the proper place.
17:44:37 <tibbs> The first paragraph is introductory text.
17:44:56 <orionp> read fine to me
17:45:02 <geppetto> yeh, I think I understand it
17:45:10 <tibbs> It reads rather cleanly to me, but I'm not opposed to changing it.
17:46:00 <geppetto> tomspur: You want to suggest an edit?
17:46:29 <racor> I am having some problems with this proposal. I think it's too strict.
17:47:19 <tomspur> Maybe just scratching "proper"? Otherwise it sounds very formal
17:47:39 <tibbs> Well, it's what we decided upon two weeks ago, unless I misinterpreted.
17:47:46 <geppetto> racor: You want people to be able to use relative and direct?
17:47:55 <racor> e.g. why the sentence "Files located in <code>%_pkgdocdir</code> must not ..." . IMO, packages should be allowed to degrade gracefully
17:48:02 <geppetto> Yeh, I think so … although racor could have -1'd then too
17:49:04 <tibbs> I guess if racor can provide an alternate draft I'd be happy to have a look.  I don't understand what "degrade gracefully" means in this context.
17:49:32 <tibbs> If there's a way to mix %doc and direct installation of files into _pkgdocdir without duplicates, maybe someone could state it.
17:49:46 <tibbs> I guess you have to use %exclude.  Which seems 100% pointless.
17:50:12 <racor> e.g. a package might be picking up some docs from %_pkgdocdir to display them. It they are missing it can display a box telling the files are missing.
17:50:30 <racor> remember all %doc files are optional!
17:50:44 <tibbs> racor: The fun thing is that the rule there is one you wrote.
17:50:47 <limburgher> But then it affects runtime and shouldn't be in %doc to begin with.
17:50:50 <tibbs> That's not new at all to this proposal.
17:51:10 <racor> tibbs: What did I wrote? I don't recall.
17:52:07 <orionp> I suppose the new wording is stricter "with unchanged functionality"
17:53:11 <orionp> Is this (help/doc viewer) situation worth calling out?
17:53:46 <tibbs> When these guidelines were originally drafted, racor was the one who wanted the part about documentation not altering program functionality.
17:54:42 <tibbs> Which why if I was feeling better I'd be laughing now.  But in any case, if I changed the original intent of the rules, I didn't intend to.  There was just a bit of bad grammar in there that I thought I'd clean up.
17:54:56 <geppetto> I'm not even sure I'd agree that not displaying docs. changes program functionality anyway
17:55:20 <geppetto> I'm +1 on tibbs writeup
17:55:27 <tomspur> +1 from me also
17:55:52 <orionp> I think it's fine, but I won't be surprised if the issue come up in a review :)
17:55:59 <racor> tibbs: I seriously do not remember what you are referring to - Pointers please!
17:56:14 <racor> 1-
17:56:16 <racor> -1
17:56:22 <tomspur> I think it should be obvious, that you cannot display the docs, if you choose to not install them. As long as the program doesn't crash and displays nothing, it's ok
17:56:31 <tibbs> Man, it was years ago.  I can try to dig up all of the meeting logs, but I remember clearly you being quite adamant.
17:57:04 <geppetto> tomspur: yeh
17:57:14 <orionp> In general the statement is good - docs should not affect how a program operates
17:57:15 <geppetto> mbooth: orionp: Rathann: limburgher: vote?
17:57:18 <tibbs> In any case, what you're objecting to isn't even part of this proposal.  If you want something else changed, please submit a new draft.
17:57:26 <orionp> I'm +1
17:57:28 <Rathann> +1
17:57:31 <mbooth> +1
17:57:33 <tibbs> +1 I guess because I wrote it.
17:57:45 <geppetto> tibbs: :)
17:58:15 <geppetto> #action %doc and %_pkgdocdir duplicate files and cause conflicts (+1:6, 0:0, -1:1)
17:58:28 <geppetto> #topic #325     Temporary bundling exception of yajl library
17:58:33 <geppetto> https://fedorahosted.org/fpc/ticket/325
17:58:44 <limburgher> +1
17:58:57 <limburgher> to docs. . .
18:00:32 <racor> tibbs: "years ago" ... things are changing, rpm is change and %doc has changed.
18:01:52 <orionp> yay, unresponsive upstreams...
18:02:10 <geppetto> yeh, and I'm not sure if it's needed anymore
18:02:41 <orionp> not sure if what is needed anymore?
18:02:41 <geppetto> Does anyone know vondruch's IRC nick?
18:03:05 <tibbs> vondruch.
18:03:09 <geppetto> orionp: The last comment implies that Chef has moved on to use a different library, with a difference set of bundling problems
18:03:26 <geppetto> tibbs: yeh, thought so … he's not around then.
18:03:44 <tibbs> Yeah, quit about 4 hours ago.
18:04:05 * geppetto nods
18:04:24 <orionp> Has OBS changed?
18:04:35 <geppetto> no idea
18:04:37 <tibbs> This ticket is another thing that I don't really git.
18:04:39 <tibbs> get.
18:04:51 <Rathann> at least it looks like they moved to bundling 2.0, which is in Fedora already, or am I reading this incorrectly?
18:05:01 <Rathann> yajl-2.0 I mean
18:05:15 <orionp> Rathann - it seems there still is a local change
18:05:37 <Rathann> but that can be - presumably - unbundled and system package can be used
18:05:54 <Rathann> without introducing 1.x compat package
18:07:25 <tomspur> If there is a patch to use the system yajl, why not using that in the Fedora package?
18:08:28 <tomspur> Rathann: I read the gh issue as if there is a patch to use the system yajl-2.0: https://github.com/brianmario/yajl-ruby/pull/113
18:10:05 <Rathann> yes, there is
18:10:16 <Rathann> but upstream has not taken it yet :(
18:10:35 <geppetto> for over 2 years
18:11:34 <orionp> I'm not sure the change has ever been submitted to yaji
18:11:46 <geppetto> anyone want to just throw your hands up in the air and approve it anyway?
18:12:06 <mbooth> geppetto: kinda
18:12:20 <geppetto> :)
18:12:21 <Rathann> well if the patch works, I'm -1, let Fedora carry the patch until upstream accepts it
18:12:28 * tomspur would prefer to carry the patch, and continue to convince upstream to take it
18:12:38 <geppetto> Yeh, I was just wondering how bad it would be for us to carry the patch
18:12:54 <limburgher> I'm with Rathann and tomspur.
18:12:55 <geppetto> and why someone hadn't done that already
18:12:55 <tomspur> Not worse to not ship it ;)
18:13:52 <orionp> I think there are two patches that would need to be carried - the yajl-ruby patch to yajl, and the patch for yajl-ruby to use sytem yajl
18:14:46 <geppetto> #action Can you carry the patches within Fedora, to use the system library from ruby and alter jajl? If not we need a clearer timeline on when upstream is going to do something.
18:15:15 <geppetto> #topic Open Floor
18:15:42 <geppetto> Ok, I'm going to leave the last couple for a future week … unless anyone thinks one of them is pressing.
18:15:47 <geppetto> Or you have something else to bring up?
18:16:26 <Rathann> nothing from me
18:16:48 <geppetto> Ok, I'll close at 20 past if nobody objects :)
18:16:57 <tomspur> To understand it correctly: Is tibbs doing all the wiki edits/merging or can I help with one or two? :)
18:17:20 <geppetto> tomspur: I'm almost 100% sure tibbs won't mind you helping :)
18:18:01 <Rathann> tomspur: all FPC members should have edit rights in Packaging:
18:18:31 <tibbs> Yeah, I usually do them but the last seven days have been crap.
18:18:35 <tomspur> Rathann: yeah, still wanted to ask for the usual process, before starting merging
18:19:14 <tibbs> You're welcome to look at the writeup tickets, write them up, add a sentence or two for the announcement text and move them to the announce state.
18:19:33 <tomspur> tibbs: ok, will do so :)
18:19:46 <tibbs> I took some good drugs today so I should be able to get something done.
18:20:24 * Rathann wishes tibbs a speedy recovery
18:20:40 <geppetto> #endmeeting