fedora-meeting-1
LOGS
16:01:22 <sgallagh> #startmeeting Server SIG Weekly Meeting (2015-02-24)
16:01:22 <zodbot> Meeting started Tue Feb 24 16:01:22 2015 UTC.  The chair is sgallagh. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:01:22 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:01:22 <sgallagh> #chair sgallagh mizmo nirik stefw adamw simo tuanta mitr danofsatx
16:01:22 <sgallagh> #topic roll call
16:01:22 <zodbot> Current chairs: adamw danofsatx mitr mizmo nirik sgallagh simo stefw tuanta
16:01:27 <mitr> Hello
16:01:30 <sgallagh> .hello sgallagh
16:01:31 <zodbot> sgallagh: sgallagh 'Stephen Gallagher' <sgallagh@redhat.com>
16:01:39 <tuanta> .hello tuanta
16:01:40 <zodbot> tuanta: tuanta 'Truong Anh Tuan' <tuanta@iwayvietnam.com>
16:01:42 <danofsatx> .hello
16:01:43 <zodbot> danofsatx: (hello <an alias, 1 argument>) -- Alias for "hellomynameis $1".
16:01:55 * nirik is sort of here, but also busy on other stuff.
16:01:58 <danofsatx> .hello danofsatx
16:01:58 <zodbot> danofsatx: Sorry, but you don't exist
16:02:14 <danofsatx> darnit, I'm here zodbot, get over it
16:02:21 <sgallagh> danofsatx: It expects your FAS ID
16:02:30 <danofsatx> I know, not enough coffee yet this morning
16:02:41 <simo> .herllo simo
16:02:48 <simo> .hello simo
16:02:49 <zodbot> simo: simo 'Simo Sorce' <ssorce@redhat.com>
16:02:50 <simo> sigh
16:02:58 <sgallagh> nirik: Can we add a .caffeinate command to Zodbot? :)
16:03:34 <tuanta> :)
16:04:48 * stefw says hi
16:05:00 <sgallagh> #topic Agenda
16:05:16 <sgallagh> #info Agenda Item: Fedora Server 22 Alpha Checkpoint
16:05:41 <sgallagh> #info Agenda Item: Fedora 22 QA Needs
16:06:26 <sgallagh> Other agenda topics?
16:06:46 <simo> sgallagh: should we discuss DC role issues ?
16:06:58 <sgallagh> Yeah, that'll be part of the checkpoint discussion
16:07:04 <sgallagh> #topic Fedora Server 22 Alpha Checkpoint
16:07:14 <simo> ok
16:07:20 <simo> I have a hard stop in 20 min.
16:07:23 <sgallagh> So, as simo points out, we have a significant problem with the Domain Controller Role
16:07:24 <simo> can we discuss it early ?
16:07:32 <sgallagh> simo: I want a short meeting anyway, but yes :)
16:08:06 <sgallagh> simo: Can you summarize the problem? IIUC it's a matter of an incompatible pki-core package?
16:10:09 <simo> no
16:10:16 <simo> it is a dependency issue apparently
16:10:30 <simo> so F22 moves from tomcat 7 to tomcat 8 if I understand that correctly
16:10:38 <simo> and a class referenced by pki-core disappeared
16:10:49 <simo> not clear if it is just gone or replaced by something else
16:11:00 <simo> so -ki-core is broken and installation with CA fails
16:11:17 <sgallagh> #info The offending bug is https://bugzilla.redhat.com/show_bug.cgi?id=1195811
16:11:40 <sgallagh> I have proposed it as a blocker for Fedora 22 Alpha, since it violates the criterion of core functionality being available.
16:12:02 <simo> yup
16:12:29 <sgallagh> simo: OK if I #action you and me to shepherd this?
16:12:35 <sgallagh> s/me/I/
16:12:49 <sgallagh> Actually, no. "me" was correct there.
16:12:56 <simo> yes
16:13:26 <sgallagh> #action simo and sgallagh to address Dogtag/FreeIPA dependency issue.
16:13:49 <sgallagh> I don't know that there's much else to be discussed here; it's pretty clearly a blocker and needs to be fixed before we can ship.
16:14:10 <sgallagh> So, on other F22 Alpha topics:
16:14:38 <sgallagh> #info The first pass at a Database Server Role has landed in rolekit and will be included in F22 Alpha TC5 later today.
16:15:05 <simo> sgallagh: note that it may be hard to fix pki to work with tomcat 8
16:15:18 <simo> sgallagh: do we have any leverage to ask to include compat-tomcat-7 in f22 ?
16:15:36 <sgallagh> #info simo notes that making pki work with tomcat 8 may be difficult.
16:15:40 <mitr> simo: hard as in some finite amount of doable work, or as in not happening ever?
16:16:22 <sgallagh> simo: We need to find out from Ade if it's going to be less work to support tomcat 8 or build a new compat package.
16:16:34 <sgallagh> I'd prefer to avoid the latter, as it's a significant maintenance burden.
16:16:39 <simo> mitr: hard, and I am thinking also about migration
16:16:44 <simo> F21 upgrade to F22
16:17:49 <sgallagh> When exactly did the tomcat 7->8 transition land?
16:19:10 <sgallagh> February 15th it looks like
16:19:38 <mitr> suggests 2014-09-21
16:19:54 <sgallagh> mitr: What?
16:20:02 <mitr> http://pkgs.fedoraproject.org/cgit/tomcat.git/commit/?id=53dd1361b3ab4535e39dae014a53eb7b56627f24
16:20:31 <sgallagh> mitr: It didn't get built in Koji until Feb. 15
16:20:49 <mitr> ah
16:21:28 <sgallagh> I'm prepared to ask them to revert to the Fedora 21 version, given that they don't have a FESCo-approved system-wide change and it's REALLY late.
16:22:32 <sgallagh> I think that this clearly deserves a cycle in Rawhide to work out the issues.
16:22:35 * mizmo here now, was in an unexpected phone call
16:22:43 <sgallagh> mizmo: Welcome :)
16:23:22 <danofsatx> sgallagh: I whole-hearedly concur.
16:24:01 <simo> sgallagh: that's an option too I guess
16:24:19 <sgallagh> Proposal: The Fedora Server SIG and WG will file a FESCo ticket asking them to vote on reverting Tomcat to version 7 for Fedora 23 so it can spend a stabilization cycle in Rawhide.
16:24:27 <simo> sgallagh: we should coordinate offline later to avoid having 2 teams rushing
16:24:35 <danofsatx> +1
16:24:37 <simo> either we revert or we rush the dogtag team
16:24:50 <simo> sgallagh: fedora 22 not 23
16:24:59 <sgallagh> I'm of the opinion that rushing will cause more problems than it solves.
16:25:03 <simo> and +1 with that correction
16:25:04 <sgallagh> Yes, thanks. Typo.
16:25:09 <simo> sgallagh: I agree
16:25:18 <sgallagh> +1 to my own proposal, for the record.
16:25:42 <tuanta> +1
16:26:30 <sgallagh> mitr, mizmo, stefw, adamw?
16:26:46 <nirik> well, not sure it needs fesco... can't we just ask first?
16:26:59 <nirik> or do we know they don't want to?
16:27:06 <mizmo> im fine with it +1
16:27:10 <mitr> sgallagh: Has at least one Java person actually looked at this?  Seems like a fair overreaction
16:27:50 <sgallagh> mitr: This was brought to simo and me by the dogtag team.
16:27:59 <sgallagh> So... yes.
16:28:05 <stefw> in that case i'm fine with it +1
16:28:13 <simo> I have to run
16:28:25 <simo> sgallagh, and all: thanks
16:28:26 <mitr> none of the tomcat maintainers seem to be Cc:ed on the bug
16:28:28 <sgallagh> simo: Thanks
16:28:54 <sgallagh> mitr: Yeah, the current treatment of that bug is that the dogtag folks need to react to it.
16:29:04 <simo> mitr: we should get them involved indeed
16:29:08 <mitr> I guess +0, a FESCo ticket won’t exactly hurt but having the tomcat maintainers hear about this first from a FESCo ticket would be annoying.
16:29:14 <simo> mitr: but before today we did not think of a revert
16:29:17 <sgallagh> mitr: OK, fair point.
16:29:17 * mitr goes ahead and adds them all to Cc
16:29:23 <sgallagh> mitr: Thanks.
16:29:25 <mitr> (We are at +6 already?)
16:30:10 <sgallagh> OK, I'll treat that as agreed, but as a secondary plan (after talking with tomcat folks)
16:30:19 * nirik nods
16:30:50 <sgallagh> #agreed If the Tomcat and Dogtag teams cannot settle this between themselves quickly, the Fedora Server SIG and WG will file a FESCo ticket asking them to vote on reverting Tomcat to version 7 for Fedora 23 so it can spend a stabilization cycle in Rawhide.
16:31:07 <sgallagh> (I'm assuming that is an acceptable revision, unless otherwise corrected)
16:31:43 <sgallagh> Moving on.
16:31:49 <tuanta> sgallagh, you meant "Fedora 22"?
16:31:53 <sgallagh> #undo
16:31:53 <zodbot> Removing item from minutes: AGREED by sgallagh at 16:30:50 : If the Tomcat and Dogtag teams cannot settle this between themselves quickly, the Fedora Server SIG and WG will file a FESCo ticket asking them to vote on reverting Tomcat to version 7 for Fedora 23 so it can spend a stabilization cycle in Rawhide.
16:31:58 <sgallagh> #agreed If the Tomcat and Dogtag teams cannot settle this between themselves quickly, the Fedora Server SIG and WG will file a FESCo ticket asking them to vote on reverting Tomcat to version 7 for Fedora 22 so it can spend a stabilization cycle in Rawhide.
16:32:03 <sgallagh> tuanta: Thanks :)
16:32:10 <tuanta> :)
16:32:22 <sgallagh> stefw: What's the status of Cockpit at the Fedora 22 Alpha Freeze?
16:33:14 <stefw> this is our milestone: https://trello.com/c/duRQw1rU/113-milestone-fedora-22
16:33:58 <stefw> there's a lot of work that's gone in under the covers and that remains to finish up. making cockpit modular, having a stable protocol so that versions can interact between
16:34:05 <stefw> fedora versions, and different operating systems
16:34:23 <stefw> Rolekit support was dropped and will be done async, and likely land in Fedora 23
16:34:46 <stefw> In general each item here has someone working on finishing it up, and we should be good for the Fedora 22 release
16:36:14 <stefw> that's it i think, any questions?
16:37:30 <stefw> oh, and the goal is to have our CI system start running against Fedora 22 this week
16:37:49 <stefw> and that's likely when we'll discover loads of Fedora 22 bugs throughout the whole stack :)
16:39:37 <sgallagh> Sorry folks, my network dropped.
16:39:38 <sgallagh> What was the last message seen from me?
16:39:54 <stefw> "<sgallagh> stefw: What's the status of Cockpit at the Fedora 22 Alpha Freeze?"
16:39:56 <danofsatx> <sgallagh> stefw: What's the status of Cockpit at the Fedora 22 Alpha Freeze?
16:40:02 <sgallagh> OK
16:41:51 <sgallagh> /me reviews the zodbot log
16:42:00 <sgallagh> stefw: Thanks for the update.
16:42:04 <stefw> sure
16:42:13 <sgallagh> adamw: Are you around?
16:42:25 <sgallagh> If not, we'll skip the QA topic
16:43:08 <sgallagh> OK, I'm assuming he's not.
16:43:12 <sgallagh> #topic Open Floor
16:43:15 <sgallagh> Anything for Open Floor?
16:43:19 <danofsatx> Draft DB Role Requirements doc: https://fedoraproject.org/wiki/User:Dmossor/DBRoleReqs
16:44:02 <danofsatx> Did we miss anything?
16:44:06 <sgallagh> #link https://fedoraproject.org/wiki/User:Dmossor/DBRoleReqs
16:44:13 <sgallagh> danofsatx: Could you send an email about that to the list?
16:44:26 <danofsatx> Roger, will do - just finished it before the meeting.
16:44:39 <sgallagh> danofsatx: "The FreeIPA configuration web UI must be available and allow at least basic configuration of the DB"
16:44:45 <sgallagh> I suspect that's a mistake :)
16:45:04 <danofsatx> whoops, junland put that one in there - I missed it. We did a copy-n-paste of the FreeIPA doc
16:45:06 <sgallagh> We probably want to talk with the Workstation folks and see if we can get pgadmin3 added as something they're interested in making sure works from the client side
16:45:32 <nirik> or at least easily discoverable
16:45:56 <sgallagh> Yes. I don't believe it has AppStream metadata yet
16:46:04 <sgallagh> We should probably own that part of it, at least.
16:46:28 <danofsatx> is pgadmin an application, or a web interface?
16:46:56 <sgallagh> Application
16:47:21 <danofsatx> rgr...I hadn't looked at it yet.
16:47:28 <sgallagh> The only web-based config tool I'm aware of for PGSQL is the Ruby one
16:47:37 <sgallagh> Which was generally frowned upon.
16:49:22 <danofsatx> Yeah I was just reading that thread yesterday.
16:49:51 <sgallagh> danofsatx: Want to get your hands dirty with some XML?
16:50:17 <danofsatx> I can't dedicate the time, but I'll take a look
16:50:36 <sgallagh> We need to have someone create the metadata for pgadmin3 so that it will show up in GNOME Software and other similar tools
16:50:47 <sgallagh> Right now you have to do 'dnf install pgadmin3'
16:51:16 <danofsatx> hmmm......sounds interesting. Can you point me in the right direction for reference, or will it be an exercise on my part?
16:51:45 <sgallagh> danofsatx: I can get you a few links.
16:51:54 <danofsatx> rgr, thanks
16:52:16 <sgallagh> #info We need to generate AppStream metadata for pgadmin3 to support the DB Role
16:52:27 <sgallagh> OK, anything else, or shall we call it a meeting?
16:53:08 <danofsatx> I second the call
16:53:10 <sgallagh> /me sets the fuse.
16:53:15 <sgallagh> 3...
16:53:28 <sgallagh> 2...
16:54:00 <sgallagh> 1...
16:54:13 <sgallagh> #endmeeting