fedora-meeting-1
LOGS
16:01:45 <sgallagh> #startmeeting Server SIG Weekly Meeting (2014-01-27)
16:01:45 <zodbot> Meeting started Tue Jan 27 16:01:45 2015 UTC.  The chair is sgallagh. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:01:45 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:01:48 <sgallagh> #chair sgallagh mizmo nirik stefw adamw simo tuanta mitr danofsatx
16:01:48 <zodbot> Current chairs: adamw danofsatx mitr mizmo nirik sgallagh simo stefw tuanta
16:01:51 <sgallagh> #topic roll call
16:02:17 * nirik is sort of here, but also rebuilding a server.
16:02:56 <sgallagh> I am sitting in the middle of a blizzard, so apologies in advance if I go unresponsive.
16:03:09 * simo waves from snowy NY
16:06:45 * jsmith lurks
16:07:18 <sgallagh> /me waits a little longer for other attendees
16:07:34 <corey84--> .fas corey84
16:07:36 <zodbot> corey84--: corey84 'Corey84' <sheldon.corey@gmail.com>
16:07:36 <corey84--> sorry late
16:08:00 <corey84--> noted, stay warm /safe sgallagh
16:09:12 <sgallagh> We don't really have a quorum, but I suppose we should proceed.
16:09:33 <sgallagh> I have a short status update and then hopefully dgilmore will turn up so we can discuss ARM
16:09:35 <simo> .hello simo
16:09:37 <zodbot> simo: simo 'Simo Sorce' <ssorce@redhat.com>
16:09:41 <sgallagh> #topic Fedora 22 progress
16:10:40 <sgallagh> I've been focusing on three major areas for Fedora 22: Branding/installer defaults, the database server role and Cockpit support of the Domain Controller Role.
16:11:33 <sgallagh> #info The anaconda team has added new hooks in Fedora 22, so we can simplify the branding needs as well as altering the defaults for things like partitioning. This is going to make it easier to generate the product-specific install media.
16:11:35 <Corey84> Cockpit is a bit foreign to me still but willing to help test out stuff on it
16:12:02 <Corey84> defaults like what exactly  tables ?
16:12:18 <sgallagh> I also hosted a meeting on Friday where rel-eng, QA and anaconda folks put together a plan on what the network install media situation would be in Fedora 22. See the devel@ list for a full summary.
16:12:49 <sgallagh> Corey84: In the case of Fedora 22, using XFS for the default filesystem, rather than EXT4 (which we planned for F21 but were unable to do)
16:13:15 <sgallagh> (Default for Fedora Server; other editions can address this as they see fit)
16:13:28 <Corey84> i do that on 21 anyway that would be swell
16:14:44 <sgallagh> #info I've got a proof-of-concept of the Database Server Role in progress on my github clone of the rolekit repo. It's about 50% complete at this point.
16:15:13 <sgallagh> I'd like to have a second person involved in that effort at some point before I push for upstream inclusion.
16:15:45 <Corey84> sgallagh,  ill grab it later and look
16:16:45 <sgallagh> #info I've worked with the Cockpit upstream designer and we have a visual design ready for the Domain Controller support. However, I have nonexistent JavaScript skills and am looking for a volunteer to help with implementation.
16:17:37 * nirik knows not js. ;)
16:17:45 <nirik> I can help look at the db role if I can find some time tho
16:17:52 <Corey84> ^ same
16:18:13 <Corey84> no js onboard here
16:18:45 <sgallagh> I was hoping to get some help from the main Cockpit upstream, but they have a lot on their plates with Atomic work right now.
16:19:19 <sgallagh> I'd prefer not to see this miss F22, so...
16:19:27 <Corey84> i'm game for testing but suck at js from the coding side
16:19:57 <sgallagh> #info Anyone with some JavaScript skills and an interest in Fedora Server is invited to help with adding the Domain Controller Role to Cockpit.
16:21:00 <sgallagh> I don't realistically expect to be able to finish the other two tasks with enough time to spare to learn JS for this.
16:21:42 <sgallagh> dgilmore: Are you around yet? I'm done with my status update if you're ready to talk ARM
16:22:37 * jsmith knows a little bit of javascript, but is more inclined to help with the Database Server role...
16:22:50 <danofsatx> I'm here, sorry....working on a CPU misconfiguration and missed the call
16:23:03 <sgallagh> FYI, https://github.com/sgallagher/rolekit/tree/database is the github repo with my WIP
16:23:51 <sgallagh> /me notices it was slightly out of date and updates it
16:24:33 * Corey84 is having bad lag outs intermittently  fyi
16:24:58 <sgallagh> danofsatx: Right in time to volunteer for the Cockpit work :-D
16:25:12 <danofsatx> I'm no coder, remember? ;)
16:26:25 <sgallagh> That's ok, it's JavaScript!
16:26:30 <sgallagh> (Sorry, couldn't resist)
16:26:46 <sgallagh> OK, dgilmore does not appear to be around.
16:26:52 <sgallagh> #topic Open Floor
16:26:55 * danofsatx thinks of ways to slowly torture sgallagh to the point of tears
16:27:15 <sgallagh> danofsatx: No, you're confusing JavaScript with Ruby.
16:27:35 <danofsatx> It's all the same in my book. code is code ;)
16:27:52 <sgallagh> Anyone have anything for Open Floor?
16:28:27 <danofsatx> I'd just like to point out that Intel's LGA2011 port is physically incompatible with LGA2011v3.
16:30:13 <sgallagh> /me sets the fuse for the meeting.
16:30:16 <sgallagh> 3...
16:30:29 <Corey84> I will be doing more srever/cloud VM work starting this weekend feel free to ping me for test work if need a tester (vms will be 32    host is 21 64 server tho)
16:31:08 <danofsatx> do we want to consider dropping 32 bit arch for F22, F23, or beyond?
16:31:09 <Corey84> 2...
16:31:12 <sgallagh> #action Corey84 volunteers for testing Server features.
16:31:23 <Corey84> and cloud 32bit
16:31:31 <sgallagh> danofsatx: We might consider dropping 32-bit install media
16:31:44 <sgallagh> But we will still need 32-bit compat libs
16:31:49 <danofsatx> roger
16:31:52 <simo> sgallagh: do you know what dgilmore wnated to talk about exactly ?
16:32:05 <Corey84> sgallagh, agree but still a decent amount of older servers still need it
16:32:09 <simo> I mean is there any action item we will have to address for ARM ?
16:32:31 <sgallagh> simo: I do not.
16:32:36 <simo> or was just a way to keep everyone informed about some work being done by the fedora-arm people ?
16:32:37 <simo> ok
16:34:24 <sgallagh> 1...
16:35:04 <Corey84> kaboom ?
16:35:14 <danofsatx> I thought it was kablooey
16:35:14 <sgallagh> #endmeeting