fedora-meeting-1
LOGS
16:00:27 <sgallagh> #startmeeting Server SIG Weekly Meeting (2014-01-06)
16:00:27 <zodbot> Meeting started Tue Jan  6 16:00:27 2015 UTC.  The chair is sgallagh. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:27 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:00:27 <sgallagh> #chair sgallagh mizmo nirik stefw adamw simo tuanta mitr danofsatx
16:00:27 <sgallagh> #topic roll call
16:00:27 <zodbot> Current chairs: adamw danofsatx mitr mizmo nirik sgallagh simo stefw tuanta
16:00:46 <stefw> .hello stefw
16:00:47 <zodbot> stefw: stefw 'Stef Walter' <stefw@redhat.com>
16:00:48 <sgallagh> Happy New Year!
16:00:51 <sgallagh> .hello sgallagh
16:00:52 <zodbot> sgallagh: sgallagh 'Stephen Gallagher' <sgallagh@redhat.com>
16:00:54 * nirik is sort of here, but also sort of killing off f19. ;)
16:01:07 <sgallagh> nirik: Nuke the site from orbit.
16:01:16 <mitr> Hello
16:01:21 <pwhalen> .hello pwhalen
16:01:21 <simo> .hello simo
16:01:21 <zodbot> pwhalen: pwhalen 'Paul Whalen' <pwhalen@redhat.com>
16:01:24 <zodbot> simo: simo 'Simo Sorce' <ssorce@redhat.com>
16:01:28 <tuanta> .hello tuanta
16:01:31 <simo> fyi I am double booked so I will react SLOWLY
16:01:32 <zodbot> tuanta: tuanta 'Truong Anh Tuan' <tuanta@iwayvietnam.com>
16:02:53 <sgallagh> #chair danofsatx|w
16:02:53 <zodbot> Current chairs: adamw danofsatx danofsatx|w mitr mizmo nirik sgallagh simo stefw tuanta
16:03:16 <sgallagh> OK, we have quorum, so we may as well get started.
16:03:21 <sgallagh> #topic Agenda
16:03:21 <sgallagh> #info Agenda Item: ARM Support
16:03:21 <sgallagh> #info Agenda Item: Database Server Role Design
16:03:40 <sgallagh> I have those two items on the agenda at the moment. Anyone else?
16:05:10 <sgallagh> OK, that sounds like "no"
16:05:18 <sgallagh> #topic ARM Support
16:05:43 <sgallagh> OK, so in Fedora 21, we didn't do as good a job with ARM support as we might have.
16:06:15 <sgallagh> I invited pwhalen to join us today so we could discuss how to better work with the ARM folks in F22 and also start setting up some goals for aarch64 support.
16:06:40 <pwhalen> ive been following along with testing as much as possible, doing more basic testing. itd be great to have some assistance from people doing more of the in depth testing
16:07:12 <pwhalen> arm can be tested in qemu. or hw access could be arranged for some
16:07:13 <sgallagh> pwhalen: The testing piece is one part of it; we (the Server SIG) need access to more hardware or really good documentation on cross-virtualization
16:07:50 <pwhalen> ok, has anyone tried arm in qemu?
16:08:36 <pwhalen> currently the biggest hurdle is the need to extract files from the disk image to boot, but its a couple of commands i think have been documented on our wiki
16:08:47 <sgallagh> pwhalen: link?
16:09:15 <pwhalen> https://fedoraproject.org/wiki/Architectures/ARM/F21/Installation#For_Versatile_Express_Emulation_with_QEMU
16:09:19 <sgallagh> pwhalen: That will be helpful, but I think we also need to talk about ARM deliverables.
16:09:25 <sgallagh> #link https://fedoraproject.org/wiki/Architectures/ARM/F21/Installation#For_Versatile_Express_Emulation_with_QEMU
16:10:09 <pwhalen> we can look at hw as well
16:10:20 <sgallagh> In particular, I've been fielding a lot of questions (on Q&A sites and e-zine articles) about people install it
16:10:57 <sgallagh> I think we need to make a stronger effort with the Websites folks to make sure that installation documentation is locatable from the download pages.
16:11:11 <sgallagh> (And of course, the documentation needs to be kept up and accurate)
16:11:15 <pwhalen> id agree there
16:11:56 <sgallagh> #info Need to coordinate with Websites and Docs folks to have installation resources easily discoverable, ideally from the download page
16:12:28 <sgallagh> pwhalen: I think we also need to put together a more formal "supported" hardware list.
16:12:41 <pwhalen> installations for arm require tftp server, pxe for hw
16:12:45 <sgallagh> Right now, our definition is vague: "We support ARM platforms that can install using Anaconda"
16:13:26 <sgallagh> Which also explicitly excludes pure-image deployments from official status
16:13:34 <pwhalen> i can give you a list of hw ive personally tested, but there might be others that work as well.
16:13:41 <sgallagh> (That does not and should not mean that the ARM SIG doesn't produce them, just that they're non-blocking)
16:14:19 <sgallagh> pwhalen: Well, what I'd like is for us to get a list of popular hardware that works.
16:14:35 <sgallagh> If the cross-section between "working hardware" and "popular hardware" is small... we have a problem.
16:14:57 * nirik thinks there will be more server interest when aarch64 stuff starts really rolling out.
16:15:08 <pwhalen> its about the same. most people do use images based on the tftp server needed for an install
16:15:30 <sgallagh> pwhalen: Sorry, I can't parse that. Would you mind rephrasing?
16:15:47 <sgallagh> nirik: Yeah, I'm sure there will be. However, right now the ARM SIG is in kind of a weird place.
16:16:04 <sgallagh> It's a primary arch of the Fedora Project, but none of our primary deliverables have a strong focus on it.
16:16:09 <pwhalen> working hardware and popular hw is about the same. most users will use disk images as its more difficult to setup the environment
16:16:25 <pwhalen> ie working for anaconda installs
16:16:58 <sgallagh> ok, so we need to ask ourselves whether it's worth producing those install media at all, vs. declaring some prebuilt images to be blocking
16:17:43 * mizmo here, sorry for lateness
16:17:48 <sgallagh> (replace "producing" with "presenting that as the preferred approach", since I'm sure we need to produce it to make the images)
16:17:58 <sgallagh> mizmo: Welcome back and Happy New Year :)
16:18:11 <mizmo> happy new year :)
16:18:27 <sgallagh> mizmo: See #info above regarding Websites and Docs folks (relevant to your interests)
16:18:49 <mizmo> is there a way to see it in meeting? meetbot.fpo?
16:18:50 <pwhalen> for server installations, pxe installs is preferred.
16:19:14 <mizmo> oh ho! there is!
16:19:29 <sgallagh> pwhalen: OK, that's good at least.
16:19:42 <mizmo> okay cool, i wanted to bring up how we're doing on the web front on this list this week
16:19:56 <sgallagh> So perhaps something we might want to consider is having the ARM team work with us on an "ARM Deployment Role" that sets up the hard parts of the environment for them.
16:20:28 <sgallagh> mizmo: That sounds useful. Want to do it on the list or as an agenda item in the meeting (or both?)
16:20:50 <pwhalen> or better documentation on the setup required. either i am very willing to assist
16:21:02 <mizmo> sgallagh, if we have time at the end happy to talk about it here today
16:21:47 <sgallagh> pwhalen: I think the better documentation is at least a pre-requisite. Otherwise, we won't have a design to follow in creating the role.
16:22:23 <sgallagh> #info Better documentation on PXE deployment of ARM is important. May lead to the creation of an ARM Deployment Role to simplify the process.
16:23:00 <pwhalen> most of the qa tests are step by step, do this, do that. some of the server documentation should be extended to included all that is needed
16:23:29 <sgallagh> In general, I think we need to start putting together a Server-specific manual
16:24:34 <sgallagh> pwhalen: What other things can we improve on the ARM front?
16:25:00 <sgallagh> (I'd like to move on to other topics soon, so we don't spend the entire meeting on ARM)
16:26:02 <pwhalen> everything *should* work on arm, as it does on x86. id like to work with someone to either help them setup some hw or qemu instance or have the documentation for server testing be extended to be a little easier to test
16:26:28 <sgallagh> pwhalen: I'm sure adamw and his gang would appreciate that.
16:27:09 <pwhalen> ah, i thought the tests were written by you guys
16:27:29 <sgallagh> pwhalen: Well, we all help. I meant they'd appreciate the improvements
16:27:34 <pwhalen> but, be great to have some server members, look at arm too
16:28:48 <sgallagh> pwhalen: Yeah, I think the first step would be to have a few of us tinker with getting ARM VMs up and running to test on
16:28:57 <pwhalen> happy to help there
16:29:06 <sgallagh> I've been rebuilding my VM env today, so I may as well work on that while I'm doing so
16:29:28 <pwhalen> documentation should be copy and pastable, if not please let me know
16:29:36 <pwhalen> or fix it :)
16:30:03 <sgallagh> Will do
16:30:15 <sgallagh> #action sgallagh to try setting up an ARM qemu VM
16:30:43 <sgallagh> OK, the next topic I had was on the Database Server, but I think unless there's strong resistance, I'd prefer to cede the floor to mizmo's update.
16:31:17 <sgallagh> (and continue the DB discussion on the list)
16:32:27 <sgallagh> *crickets*
16:32:35 <sgallagh> OK
16:32:35 <mizmo> \o/
16:32:37 * mizmo wins
16:32:42 <sgallagh> #topic Website Team Update
16:32:48 <sgallagh> mizmo: Enlighten us!
16:32:56 <mizmo> okay well
16:33:12 <mizmo> i dont have an update so much as i just wanted ot have a little discussion about the website now that's it's all done and live and been out there for a bit
16:33:16 <mizmo> this is what we have: https://getfedora.org/en/server/
16:33:23 <mizmo> DL page is here: https://getfedora.org/en/server/download/
16:33:34 <mizmo> the original design included plans for a tour that we shelved for F21 given lack of time
16:33:53 <sgallagh> #link https://getfedora.org/en/server/
16:33:58 <sgallagh> #link https://getfedora.org/en/server/download/
16:34:00 <mizmo> I really think a tour and some more interactive stuff (like a short screencast of how easy it is to use rolekit to deploy stuff) would be cool to have on the roadmap
16:34:27 <mizmo> but i was also wondering if folks felt the website was a good representation, if you've heard any chatter about it or complaints
16:35:26 <mizmo> ...
16:35:32 <mizmo> :)
16:35:41 <sgallagh> mizmo: The number-one complaint I've heard was as I mentioned above: people didn't know how to install it on ARM
16:35:52 <nirik> I've not heard so much about the server pages...
16:35:54 <mizmo> are we going to officially support arm in f22?
16:36:14 <sgallagh> mizmo: We technically support it officially in F21
16:36:26 <sgallagh> We (I) just botched the messaging.
16:36:30 <sgallagh> And coordination
16:36:33 <mizmo> ahh okay
16:36:42 <mizmo> do you want the arm link up asap then?
16:36:51 <mizmo> i'd stick it in the other downloads column here: https://getfedora.org/en/server/download/
16:36:53 <nirik> there is also the 'server' netinstall being the 'generic' netinstall... not sure how that fits in.
16:37:26 <mizmo> hm
16:37:29 <sgallagh> Yeah, right now we don't have any real official messaging about that.
16:37:43 <mizmo> well let's finish about the arm link, you want the link should be up right away?
16:37:47 <sgallagh> mizmo: I'm not sure we want that link up until we have official guidelines as well.
16:37:48 <mizmo> or would you rather wait until f22?
16:37:49 <mizmo> okay
16:37:53 <sgallagh> Because as pwhalen noted, it's hard to set up.
16:37:54 <mizmo> well keep me posted on that then
16:37:58 <sgallagh> Will do.
16:38:13 <pwhalen> tftp server presents a hurdle for people, not too hard, but a hurdle
16:38:17 <mizmo> are arm users... similar to the 32/64 users? or are they a special class?
16:38:24 <sgallagh> mizmo: Very special :)
16:38:26 <mizmo> in terms of our personas
16:38:32 <sgallagh> oh, in that case.
16:38:33 <mizmo> are they kind of like a distant cousin?
16:38:44 <sgallagh> They're probably mostly MacGuyver's
16:38:52 <sgallagh> (using low-cost hardware to maximize efficiency)
16:38:59 <mizmo> ahhh okay got it
16:39:08 <mizmo> okay so the whole thing about the server serving as the generic netinstall -
16:39:17 <mizmo> so a few thoughts there -
16:39:21 <mizmo> #1 I wonder how widespread this is?
16:39:25 <sgallagh> That was sort of a technical issue rather than an intentional design
16:39:34 <sgallagh> Sorry, define "this" in that sentence?
16:39:42 <mizmo> #2 I think it's not a server issue so much as an issue with other products not providing netinstall if it's needed by their base?
16:39:54 <mizmo> sgallagh, "this" = folks complaining it's a pain to get a netinstall image
16:40:04 <sgallagh> mizmo: Well, it's also a common way for people to "roll their own"
16:40:27 <sgallagh> Or basically operate like they did pre-products
16:40:30 <mizmo> i wonder if we shouldn't have a 'fourth product' on the site for macguyver on the weekend
16:40:35 <mizmo> but i wonder how large that population is
16:40:59 <sgallagh> mizmo: It's pretty common. Usually not so much "complaining" as "confusion"/
16:41:00 <mizmo> i mean the point of the products was to better meet folks needs, if theres unmet needs did we screw up?
16:41:08 <sgallagh> People want to continue doing what they used to
16:41:15 <mizmo> ah yeh, kind of the adjustment period
16:41:22 <nirik> well, server, workstation, cloud, ... other ... ;)
16:41:32 <mizmo> yo dawg, you got in a plane in ny and just got out in tokyo, it's 2 pm not 2 am
16:41:34 <mitr> mizmo: By defining explicit personas we have necessarily excluded some users
16:41:49 <sgallagh> mizmo: And also yeah: there's a constituency that wants to be able to mass-deploy Workstations and they have to use the Server netinst for that
16:41:55 <nirik> some of the netinstall users are also people who used to use the old 'generic' dvd
16:41:58 <sgallagh> Because the Live images don't support kickstarts
16:42:02 <mizmo> sgallagh, so that i would argue is a deficiency of workstation
16:42:13 <mizmo> large scale deployment of workstations i would assume should be a use case??
16:42:20 <nirik> so, I think netinstall iso is more popular... because it's old dvd people, people who want to do mass installs, and other groups
16:42:21 <sgallagh> Sure, but as we're the de-facto solution, we should discuss how to better communicate that
16:43:06 <mizmo> well here's my thing tho - in a way, i feel like going to server to get the netiso is kind of a bit of a crude 'hack' and i'm reluctant to promote that
16:43:15 <sgallagh> mizmo: Well, it's intended to fix that in F22, last I checked.
16:43:27 <sgallagh> The problem was that we had technical issues creating product-specific netinstall disks
16:43:35 <mizmo> hm
16:43:38 <sgallagh> The short-term solution was "just use the Server one"
16:44:01 <sgallagh> But I *think* the F22 plan is going to be to create a generic one for all instead of having branded netinstalls
16:44:05 <mizmo> so maybe we put a notice on the dl pages for workstation and cloud?
16:44:09 <mizmo> in the 'other downloads' section?
16:44:34 <sgallagh> Yeah, that's likely where it will live
16:45:13 <mizmo> but in F22 we clean it up bc those flavors will have the proper netisoage?
16:45:32 <sgallagh> I think I may not have explained well.
16:45:54 <sgallagh> The original plan was that each product would have its own netinstall ISO that would have its own branding and default to its correct package set.
16:46:23 <sgallagh> It turned out that there were too many technical hurdles to accomplishing this, so we scrapped all but the Server one and just recommended using that one to install from (since it could install any of them)
16:46:32 <mizmo> right, but they will be available for f22?
16:46:44 <sgallagh> In F22, I think we're going to drop the idea of having individually-branded ones at all and just produce a single one with only "Fedora" branding.
16:46:53 <mizmo> oh, boy
16:47:16 <sgallagh> It will still default to the Server packages, but it won't otherwise be unique.
16:47:20 <mizmo> so if you want to mass deploy workstation you gotta individually pick out the same package set?
16:47:29 <sgallagh> Then both Server and WS can use it as the netinstall.
16:47:38 <sgallagh> mizmo: No, environment group
16:47:44 <mizmo> ohh okay
16:47:48 <sgallagh> @^"Fedora Workstation"
16:47:50 <mizmo> is there a way to have anaconda prebake in which one?
16:48:00 <mizmo> or, i guess people using netiso would be smart enough to figure it out
16:48:00 <mizmo> okay
16:48:03 <sgallagh> No, that's the same problem that caused the current situation
16:48:04 <mizmo> so here's my take then
16:48:15 <sgallagh> And most people using the netiso would be using a kickstart, so they wouldn't care
16:48:18 * mizmo sorry if this is too much mo shooting from the hip monologuing
16:48:26 <mizmo> so if it's the same image, that's cool
16:48:34 <sgallagh> Right
16:48:38 <mizmo> i think on the getfedora.org page, though, we treat them liket hey are separate
16:48:56 <mizmo> in that, each flavor has a download page that has a netiso listed in the otehr downloads section but we don't let on they're the same damn thing
16:49:00 <mizmo> bc i think it doesn't really matter
16:49:06 <mizmo> and it'll just confuse people
16:49:08 <nirik> seems fine
16:49:54 <mizmo> okay so for F21 we stay the course re: netiso, for F22 we have a link on each of the flavor download pages to a common netiso image, which users will have to pick the correct flavor env group in anaconda or just ks
16:50:37 <sgallagh> That sounds right to me.
16:50:54 <sgallagh> #info or F21 we stay the course re: netiso, for F22 we have a link on each of the flavor download pages to a common netiso image, which users will have to pick the correct flavor env group in anaconda or just ks
16:50:59 <sgallagh> #undo
16:50:59 <zodbot> Removing item from minutes: INFO by sgallagh at 16:50:54 : or F21 we stay the course re: netiso, for F22 we have a link on each of the flavor download pages to a common netiso image, which users will have to pick the correct flavor env group in anaconda or just ks
16:51:05 <sgallagh> #info For F21 we stay the course re: netiso, for F22 we have a link on each of the flavor download pages to a common netiso image, which users will have to pick the correct flavor env group in anaconda or just ks
16:51:36 <mizmo> oh yeh and for arm too we should do one?
16:51:48 <sgallagh> mizmo: one what?
16:51:57 <mizmo> #info sgallagh will keep mizmo in the loop re: if/when we add a DL link for arm image on getfedora.org/server
16:52:02 <mizmo> (fair?)
16:52:09 <sgallagh> yes, absolutely
16:53:28 <sgallagh> mizmo: OK, anything further around website stuff?
16:55:15 <sgallagh> /me interprets that as a "no"
16:55:25 <sgallagh> #topic Open Floor
16:55:37 <sgallagh> Anything for the last five minutes?
16:56:01 * nirik has nothing
16:56:20 <sgallagh> Thanks for coming, folks
16:56:35 * simo waves a happy new year to everyone
16:57:00 <mizmo> i dont think so, but anyone plz feel free to ping me anytime
16:57:06 <sgallagh> mizmo: ping!
16:57:08 <mizmo> feedback of any form is fine as long as it doesn't involve epithetes
16:57:19 <mizmo> (Also sorry for disappearing for a second the hallway police wanted me to clean up my cube :) )
16:57:25 <sgallagh> #info Happy New Year, everyone!
16:57:39 <sgallagh> mizmo: Hello Kitties get loose?
16:57:54 <mizmo> something like that :)
16:58:13 <sgallagh> #endmeeting