fpc
LOGS
17:01:37 <geppetto> #startmeeting fpc
17:01:37 <zodbot> Meeting started Thu Dec 11 17:01:37 2014 UTC.  The chair is geppetto. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:01:37 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
17:01:37 <geppetto> #meetingname fpc
17:01:37 <zodbot> The meeting name has been set to 'fpc'
17:01:37 <geppetto> #topic Roll Call
17:02:04 <geppetto> geppetto limburgher mbooth orionp racor Rathann SmootherFr0gZ spot tibbs|w tomspur: FPC ping
17:02:14 <tibbs|w> Howdy.
17:02:16 <orionp> morning
17:02:20 <geppetto> #chair tibbs|w
17:02:20 <zodbot> Current chairs: geppetto tibbs|w
17:02:22 <mbooth> geppetto: Here, but may have to leave early today
17:02:26 <geppetto> #chair orionp
17:02:26 <zodbot> Current chairs: geppetto orionp tibbs|w
17:02:28 <geppetto> #chair mbooth
17:02:28 <zodbot> Current chairs: geppetto mbooth orionp tibbs|w
17:02:35 * tomspur is here
17:02:39 <geppetto> #chair tomspur
17:02:39 <zodbot> Current chairs: geppetto mbooth orionp tibbs|w tomspur
17:04:41 * spot is mostly around today
17:04:43 <geppetto> racor: You around?
17:04:49 <geppetto> Hey spot!
17:04:52 <geppetto> #chair spot
17:04:52 <zodbot> Current chairs: geppetto mbooth orionp spot tibbs|w tomspur
17:05:55 * racor is here
17:06:04 <geppetto> #chair racor
17:06:04 <zodbot> Current chairs: geppetto mbooth orionp racor spot tibbs|w tomspur
17:06:19 <geppetto> #topic #476 	Requesting copylib exemption for libgnome-volume-control
17:06:57 * zbyszek can hopefully answer any questions
17:07:04 <tibbs|w> All that makes me think is that someone in the Gnome camp is nuts.
17:07:22 <spot> zbyszek: is there a reason why that's not a separate lib?
17:07:54 <geppetto> wow … it is not small
17:07:58 <zbyszek> According to the messages on the mailing list, they didn't want to provide a stable api.
17:08:14 <zbyszek> The idea was to update each user seperately after some changes.
17:08:34 <geppetto> instead of bundling you can provide a static library only
17:08:36 <zbyszek> As long as it was gnome-only, I think this wasn't a problem. But now it's in cinammon and budgie.
17:08:40 <spot> isn't it problematic to have multiple, potentially incompatible versions of this embedded in other apps?
17:08:43 <geppetto> it's still horrible … but better than bundling
17:10:19 <zbyszek> spot: This would be rather unusual, it seems to be only used by DE managers.
17:10:27 <spot> zbyszek: okay
17:11:08 <spot> i think my opinion on this is to ask the libgnome-volume-control to rework into a shared lib, given the multiple consumers, and revisit this if they are still unwilling.
17:12:28 <zbyszek> Yeah, it should be split out. What about a temporary exception for budgie (and others), until this is resolved?
17:12:39 <zbyszek> I'm afraid it'd take at least until the next gnome release.
17:13:05 <geppetto> doing it as a static library shouldn't be time consuming
17:13:26 <geppetto> it's not much more work than just bundling it … esp. as it doesn't seem to be changing much now
17:14:48 <racor> folks, i think this meeting isn't going to work for me, today.
17:15:03 <geppetto> racor: ok
17:15:03 <tomspur> Where the last commits really from sept 2013?
17:15:32 <racor> I am experiencing severe issues in accessing any fedora sites, they all appear to be almost non-responsive
17:16:59 <geppetto> tomspur: I assume so
17:17:04 <geppetto> zbyszek: ^?
17:17:27 <zbyszek> Commits, yeah, from 2013.
17:17:38 * geppetto nods
17:17:45 <zbyszek> They all use the same commit.
17:18:25 <geppetto> it makes it mostly trivial to make it a static lib. as they don't really need to worry about it changing API and breaking the builds, given it's not changing.
17:18:59 <zbyszek> geppetto: OK
17:20:11 <geppetto> #action General agreement that it should be made at least a static lib. … hopefully a shared lib. eventually.
17:20:19 <tibbs|w> +1
17:20:27 <spot> +1
17:20:28 <orionp> +1
17:21:00 <tomspur> +1
17:21:13 <racor> 0, i am still waiting for control-center's download to finish ;)
17:21:49 <mbooth> +1
17:22:06 <geppetto> It's cool, no real need to vote … just adding #action so I remember for updating the tickets :)
17:22:26 <geppetto> #topic Write up tickets
17:22:34 <geppetto> https://fedorahosted.org/fpc/report/14
17:23:10 <geppetto> So, AFAICS that's all we have for new/updated tickets … so it might be worth trying to all do a writeup for an old ticket during the meeting time?
17:23:45 <tibbs|w> Yes, we really need to get on that.
17:24:08 <tibbs|w> Also, I added a new state; after being written up, you can add a comment with the announcement text
17:24:26 <tibbs|w> and set the state to 'announce' so that someone can grab all of those, concatenate and dump them to devel-announce.
17:24:59 <tibbs|w> I assume that's how we want to do it, instead of spamming the list with a pile of individual change notices.
17:25:08 <geppetto> cool, looking at 302 it appears to have been written up a long time ago … just never announced
17:25:35 <geppetto> How do I change it from writeup to announce?
17:25:44 <geppetto> nevermind … I see the option now
17:25:47 * geppetto is blind
17:26:09 * spot needs to run, but if I find any spare cycles, i'll try to take a writeup or two.
17:26:27 <orionp> I'll try to do 465
17:26:37 <tibbs|w> https://fedorahosted.org/fpc/report/15 has all of the announce tickets.
17:26:57 <orionp> It's complete - so just move the page into the Packaging space?
17:27:23 <orionp> https://fedoraproject.org/wiki/PackagingDrafts/libreOfficeExtentions I mean
17:27:27 <tibbs|w> Yes.
17:27:42 <tibbs|w> Just edit the official guidelines, then make a quick announcement note and change the state of the ticket.
17:27:57 <tibbs|w> You should have editing privs in the Packaging namespace, I think.
17:29:55 <orionp> that worked - now - how can I redirect Packaging:OpenOffice.orgExtensions to Packaging/libreOfficeExtentions , and do we use : or / ?
17:31:04 <tomspur> https://fedorahosted.org/fpc/ticket/316 is also in the guidelines already, so I change it to announce right?
17:31:22 * tomspur is confused, why toshio changed it to writeup and not directly to announce
17:31:50 <geppetto> tomspur: tibbs|w created the announce state in the last couple of weeks
17:31:59 <geppetto> Before that there was just writeup
17:32:07 <tomspur> ah ok
17:32:27 <geppetto> I'm looking at https://fedorahosted.org/fpc/ticket/388
17:32:44 <geppetto> Does anyone know where that text should be going? :-o
17:32:54 <tibbs|w> Yeah, I just did this after last week's meeting when I wrote up that dist tag stuff.
17:33:34 <tibbs|w> Which, by the way, took changes all over the place.  If anyone wants to read over http://fedoraproject.org/wiki/Packaging:DistTag and https://fedoraproject.org/wiki/Packaging:NamingGuidelines and make sure I didn't do anything idiotic, feel free.
17:34:29 <tibbs|w> https://fedoraproject.org/w/index.php?title=Packaging%3ADistTag&diff=397407&oldid=174910 and https://fedoraproject.org/w/index.php?title=Packaging%3ANamingGuidelines&diff=397408&oldid=379705 are the changes I made.
17:35:02 <tibbs|w> There was stuff in those guidelines which was ancient (referencing pre-FC1 stuff, RHEL2, and CVS) which I fixed or removed.
17:35:05 <tibbs|w> Sorry to derail.
17:35:06 <geppetto> isn't it _dist?
17:35:20 <tibbs|w> Not that I've used.
17:35:53 <geppetto> no, you're right
17:35:59 <tibbs|w> The name of the tag is %{dist}, but when you actually use it you have to say %{?dist}.
17:35:59 <geppetto> just being confused
17:36:04 <geppetto> yeh
17:36:59 <tibbs|w> I went over all of the other guidelines templates I could fine and made sure they all had the tag.  They did.
17:37:26 <tibbs|w> But I might have missed something.  If anyone sees any Release: anywhere in the guidelines that doesn't have %dist, just feel free to add it.
17:37:42 <geppetto> cool, the diffs look good to me
17:38:33 <tibbs|w> Anyway, do we have anything to vote on this week or is it just going through writeups?
17:38:46 <tibbs|w> There was the new python stuff, wasn't there?
17:39:02 <geppetto> AFAICS no tickets were updated
17:39:30 <tibbs|w> I swear someone filed a ticket about the python3 by default stuff.
17:39:39 <geppetto> nevermind … I see 475 now
17:39:58 <geppetto> #topic #475 	Suggested Changes for Python Guidelines for F22
17:39:58 <tibbs|w> Oh, crap, the active ticket report has two pages....
17:42:44 <tibbs|w> So, I'm generally on board with this.
17:42:45 <tibbs|w> However....
17:43:02 <tibbs|w> Do we try to conditionalize these for >= F22?
17:43:21 <tibbs|w> Or just say that this is now the policy for all Fedora?  Because conditionalizing gets nasty.
17:43:40 <geppetto> the naming stuff can be everywhere
17:43:51 <tibbs|w> Indeed.
17:43:58 <geppetto> not sure about the first part about /bin
17:44:07 <tomspur> I'd say for all Fedora, if a binary is supported for both pythons, one should start picking python3
17:44:22 <geppetto> For the versioning stuff … what does everyone think of having the name end with -py3 ?
17:44:33 <tibbs|w> tomspur: I kind of agree.
17:44:43 <geppetto> tomspur: Do you really want that for updates in F21 though?
17:44:47 <tibbs|w> This would only matter for new packages and maintainers who really care anyway.
17:45:22 <tibbs|w> I don't see people doing mass updates just to comply.  But new packages should probably get it right everywhere and not try to conditionalize for older fedora.
17:45:27 <geppetto> So for the versioning example: foo-v1.2-py3
17:45:28 <tibbs|w> EPEL is another story, of course.
17:45:32 <tomspur> geppetto: If there is a binary, one is using, it doesn't matter which python it is using. The only "bad thing" that can happen is, that you have both python runtimes installed
17:45:49 <tomspur> Or is there another reason not to ship such an update?
17:46:14 <geppetto> tomspur: yeh, that's what I meant … you upgrade and it pulls in python3 == unhappy people
17:46:19 <tibbs|w> tomspur: Just needless churn, I guess.  But that's always up to the maintainer anyway.
17:46:26 <geppetto> I'm not that bothered though
17:46:53 <tibbs|w> As long as someone doesn't get jumpy and start mass-filing bugs to get F20-F21 packages changed, it shouldn't be an issue.
17:47:03 <tibbs|w> We don't retroactively apply most guidelines anyway.
17:47:06 * geppetto nods
17:49:13 <geppetto> Do we want to just suggest they can do a bunch of changes and use py3 … but to ask them to make a policy diff. before we'll officially vote on it?
17:49:45 <geppetto> Or do we want to vote on this ticket as is?
17:50:13 <tomspur> Is having the symlinks with a "-X" a must or a should ?
17:51:04 <mbooth> I have to go guys, sorry
17:51:37 <geppetto> tomspur: I think it's a must, but it doesn't specify explicitly
17:52:01 <tomspur> I think that is a must if "assuming there are *both* python2 and python3 version"
17:52:02 <geppetto> Hence the "yes, but please go write a real policy diff" suggestion :)
17:52:17 <tibbs|w> Let's make our suggestions and ask for a full draft diff.
17:52:42 <tibbs|w> I do prefer "py3" as opposed to just "3".
17:52:58 <geppetto> I agree with both of those things :)
17:53:08 <tibbs|w> And at the end, not in the middle.
17:53:19 <geppetto> ok, that's fine by me
17:54:09 * tomspur prefers ipython3 over ipython-py3
17:54:35 <tibbs|w> Is that version 3 of ipython?
17:54:41 <tibbs|w> Because that's what it looks like to me.
17:54:55 <tomspur> Ah, it is only for compat packages anyway
17:55:41 <tibbs|w> Right, for name of the executable, chances are upstream already made a choice anyway.
17:56:30 <tibbs|w> Anyway, there is a whole section about that (3rd bullet point) which I think we need to decide.
17:57:20 <geppetto> I agree the prefix there seems weird
17:57:24 <tibbs|w> Yes.
17:57:29 <tibbs|w> I prefer "follow upstream".
17:57:40 <geppetto> I guess
17:57:41 <tibbs|w> And if upstream didn't chose, append -py3.
17:57:52 <tibbs|w> But that's just my personal preference.
17:58:33 <tibbs|w> No matter what we do, we're going to have some inconsistency.  I'd rather that we not have inconsistency with upstream-chosen executable names if at all possible.
17:58:48 <geppetto> it'll be a non-consistent mess, in some ways, but it might well be a giant disaster trying to patch upstreams to one form.
17:59:21 <geppetto> for the exec name I assume just adding -3 should be fine in most cases
17:59:47 <geppetto> but I'm fine with -py3 to make it consistent with the package name
18:00:23 <geppetto> Any other comments?
18:01:44 <geppetto> #action Mostly approving but follow comments from IRC discussion and write a real policy change we can vote on.
18:01:58 <geppetto> #topic #474 	Allocating a soft static uid and gid 389 for dirsrv
18:02:22 <tibbs|w> As with pretty much all static allocation requests, I don't understand the reasoning.
18:02:40 <geppetto> Yeh, I'm not sure what they mean by "volumes" here
18:02:57 <geppetto> I guess NFS or something?
18:03:00 <tibbs|w> The bug does have more good info.
18:03:06 <tibbs|w> https://bugzilla.redhat.com/show_bug.cgi?id=1143066
18:03:41 <tibbs|w> Now, what is ipa-server-install, and why doesn't that user/group get created at package install time?
18:03:43 <geppetto> oh, god … this is volumes for a container
18:05:01 <geppetto> I'm reluctant to give anything that wants to run in a container a soft static uid/gid
18:06:33 <geppetto> I'll comment asking a bunch of stuff.
18:06:48 <tibbs|w> I'm kind of lost as to what questions to even ask.
18:07:00 <tomspur> The guidelines mention " Explain how the uids and gids are being shared between computers. If applicable, also explain why the program can't be adapted to use symbolic names (username and groupname) instead."
18:07:02 <tibbs|w> They must have a reason for not doing the normal thing and creating the uid at package install time.
18:07:18 <tibbs|w> And the container stuff, I don't understand it either.
18:07:41 <tibbs|w> It seems that just creating the uid/gid in the normal fashion would do the right thing.
18:07:49 <tibbs|w> But I'm sure I'm missing something.
18:07:50 <orionp> I suspect so as well
18:08:24 <orionp> As a 389ds user, I'd appreciate the user being created at package install time
18:08:54 <orionp> but I suspect that a fixed uid is not strictly needed
18:09:00 <geppetto> #action james Need more data, we esp. don't want to set a precedent that anything that can be in a container needs a soft static uid/gid.
18:09:22 <geppetto> #topic Open Floor
18:09:30 <geppetto> Ok, anyone want to bring anything up?
18:10:05 <geppetto> I should be around next week … but I doubt I'll be after that until next year
18:10:33 <racor> geppetto: The same applies to me.
18:11:05 <tomspur> I'll be arount next time on 8th January...
18:11:53 <geppetto> tomspur: yeh, I should have specified not the first :)
18:13:53 <tibbs|w> I'll be "around" pretty much the whole time, though I imagine pretty busy on the 25th.
18:14:12 <tibbs|w> Do we want to try and meet next week if we can get quorum?
18:14:13 <geppetto> ha :)
18:14:26 <geppetto> I'll be around … but I won't be shocked if there aren't 5 of us
18:14:44 <tibbs|w> Honestly the only thing I do on the 25th is cook.
18:15:04 <tibbs|w> Fried turkey and prime rib, baby.
18:15:11 <geppetto> :)
18:15:38 <tibbs|w> I have to cook on the 24th, too.  Two Christmas dinners.
18:16:29 <geppetto> I might have a similar problem … but for eating two of them ;)
18:16:44 <tibbs|w> Time to loosen that belt.
18:16:57 <geppetto> elastic pants ftw.
18:17:20 <racor> I traditionally cook on 25th (dinner for 8).
18:17:32 <tibbs|w> I wish I could get 8.
18:17:32 <geppetto> 8 is a lot
18:17:43 <tibbs|w> I did 24 once.  Never again.
18:18:35 <racor> yeh, my wife, parents-in-law, brother/sister-in-law, their daughter and my sister-in-law's father ;)
18:18:56 <racor> ;)
18:20:14 <tibbs|w> Well, off to do some actual work.  I'll try to get to a writeup or two later.
18:21:41 <orionp> wtf weren't SCLs given a prefix in their name?
18:22:35 <geppetto> orionp: yeh, but an scl never got approved to be in Fedora anyway, so it never mattered
18:22:51 <geppetto> orionp: You see one?
18:23:07 <orionp> It's just a huge mess for Fedora EPEL
18:23:26 <orionp> conflicting with RedHat's SCLs
18:24:20 * tomspur needs to go now
18:24:35 <tomspur> See you next year then ;)
18:24:42 <orionp> later, thanks all - sorry I was distracted through most of it...
18:26:30 <racor> reminds me about my networking issues: This release seems to have had massive mirror-sync and fedora*.org access issues
18:26:35 <geppetto> ok, see ya
18:26:38 <geppetto> #endmeeting