fpc
LOGS
17:02:20 <geppetto> #startmeeting fpc
17:02:20 <zodbot> Meeting started Thu Dec  4 17:02:20 2014 UTC.  The chair is geppetto. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:02:20 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
17:02:20 <geppetto> #meetingname fpc
17:02:20 <zodbot> The meeting name has been set to 'fpc'
17:02:20 <geppetto> #topic Roll Call
17:02:34 <geppetto> limburgher mbooth orionp racor Rathann SmootherFr0gZ spot tibbs|w tomspur: FPC ping
17:02:43 <tomspur> pong
17:02:43 * limburgher here
17:02:49 <geppetto> #chair tomspur
17:02:49 <zodbot> Current chairs: geppetto tomspur
17:02:49 <mbooth> Good evening
17:02:51 <geppetto> #chair limburgher
17:02:51 <zodbot> Current chairs: geppetto limburgher tomspur
17:03:11 * williamjmorenor listening, first time in FPC meeting
17:03:59 <Rathann> hi
17:04:19 <mbooth> Hi
17:04:25 <geppetto> #chair Rathann
17:04:25 <zodbot> Current chairs: Rathann geppetto limburgher tomspur
17:04:27 <geppetto> #chair mbooth
17:04:27 <zodbot> Current chairs: Rathann geppetto limburgher mbooth tomspur
17:04:41 <geppetto> and then there were 5 :-o
17:05:03 <tibbs|w> Hey, folks.
17:05:17 <geppetto> #chair tibbs|w
17:05:17 <zodbot> Current chairs: Rathann geppetto limburgher mbooth tibbs|w tomspur
17:05:23 <tibbs|w> I'm in the middle of moving about 30 computers so I will be in and out.
17:05:28 <geppetto> ok
17:06:03 <geppetto> #topic #472 	Minor modification bootstrap-related guidelines
17:06:17 <geppetto> https://fedorahosted.org/fpc/ticket/472
17:06:43 <mbooth> I filed this because I didn't want to just wade in and edit the guidelines :-)
17:08:00 <mbooth> It basically removes the incomplete information about bootstrapping that was there before we added the new bootstrapping section last time
17:08:18 <tibbs|w> Seems OK, to me, but why did you remove the Spec Legibility anchor at the end?
17:08:24 * geppetto nods … seems fine to me
17:08:50 <mbooth> tibbs|w: Done in error, I will leave that in
17:08:58 <tibbs|w> Cool, just making sure.
17:09:01 <geppetto> cool, +1 then
17:09:02 <tibbs|w> +1
17:09:04 <tomspur> +1
17:09:07 <limburgher> +1
17:09:15 <Rathann> +1
17:09:16 <mbooth> +1
17:10:15 <mbooth> Okay I will make that change :-)
17:10:20 <geppetto> #action mbooth Minor modification bootstrap-related guidelines (+1:6, 0:0, -1:0)
17:10:39 <geppetto> #topic #473 	explicit conflicts exception for fedora-productimg-*
17:10:39 <geppetto> packages (or other solution?)
17:10:53 <geppetto> #topic #473 	explicit conflicts exception for fedora-productimg-* packages (or other solution?)
17:11:10 <geppetto> https://fedorahosted.org/fpc/ticket/473
17:12:51 <mbooth> This seems reasonable, I would ask for comments in the spec files that explain that it implicitly conflicts with other packages that provide this file
17:13:14 <geppetto> no
17:13:22 <geppetto> The big problem here is that yum/dnf can't see file conflicts, with repo. metadata only rpm can (after all packages have been downloaded).
17:13:27 <Rathann> why not use alternatives?
17:13:44 * Rathann looks up what Lorax is
17:13:52 <mbooth> geppetto: Oh I see, I didn't realise that
17:14:00 <geppetto> alternatives seems like a fine solution to me … as does having a virtual provide, and a conflict on that within each package.
17:14:17 <tibbs|w> Or just use different filenames, have lorax look for more than file, and have it complain or just pick one if there are several.
17:14:43 <geppetto> I kind of hope they'd have already done that, if they easily could do so
17:14:44 <tibbs|w> I don't understand why this has to go all the way to conflicts when there's a perfectly obvious solution.
17:14:59 <geppetto> maybe I'm just being an optimist again
17:17:16 <geppetto> anyone else think of any other alternative workarounds?
17:18:29 <tomspur> Is there a possibility for "!=" in a conflicts?
17:19:01 <Rathann> tomspur: I don't think so
17:19:04 * tomspur played around with Provides: product = $foo and Conflicts: product != $foo, which didn't work :/
17:19:27 <geppetto> tomspur: yeh
17:19:30 <tomspur> well... Conflicts: product > $foo and Conflicts: product > $foo worked :/
17:19:34 <geppetto> That's what I'm suggesting atm.
17:19:51 <geppetto> tomspur: That didn't work?
17:19:58 <Rathann> error: line 9: Dependency tokens must begin with alpha-numeric, '_' or '/': Conflicts: blah != 1.0
17:20:00 <geppetto> tomspur: What did you test it on? How didn't it work?
17:20:23 <tomspur> geppetto: > and < works, but doen't look right, isn't it?
17:20:33 <racor> tomspur, Rathann: There wasn't one until very recently, but there were != related changes in recent past.
17:21:02 <geppetto> Rathann: that is very weird
17:21:12 <tomspur> geppetto: this works http://paste.fedoraproject.org/156676/77136031
17:21:17 <geppetto> Rathann: and rpmbuild works if you don't have the != ?
17:21:38 <Rathann> yes
17:21:43 <geppetto> Rathann: is that the rawhide rpmbuild?
17:21:53 <Rathann> no, F20
17:22:05 <geppetto> tomspur: uh … well, that's better than nothing
17:22:31 <racor> cf.: https://bugzilla.redhat.com/show_bug.cgi?id=1138926
17:22:59 <Rathann> geppetto: f20's rpmbuild won't even let me do rpmbuild -bs with !=
17:24:18 <tomspur> Rathann, geppetto: Same here on f21
17:25:12 <geppetto> I submitted a comment
17:25:23 <geppetto> can everyone check that I didn't miss something?
17:26:03 <Rathann> looks good to me
17:26:40 <geppetto> racor: weird … because the code does exist internally in yum (and I'd assume rpm) … just can't build with != … :-o
17:26:41 <mbooth> Makes sense
17:26:45 <Rathann> though I shudder at the Conflicts < > hackery
17:26:50 <geppetto> yeh
17:27:04 * tomspur too
17:27:39 <tomspur> With the lack of !=, I tried to be creative ;)
17:28:03 <geppetto> yeh
17:29:08 <geppetto> #topic Open Floor
17:29:17 <geppetto> Well, it looks like a fast meeting so far
17:29:29 <geppetto> Neither of the tickets on the backlog have had any updates
17:29:38 <Rathann> any old stuff to revisit?
17:29:39 <geppetto> Anyone want to bring anything up?
17:30:00 <geppetto> Rathann: Just had a look at 466 and 468, no updates
17:31:16 <Rathann> well, I don't have anything specific to bring up today
17:31:35 <Rathann> oh, I did update the FPC wiki with current member list
17:31:39 <Rathann> and IRC nicks
17:31:50 <Rathann> just FYI
17:31:58 <geppetto> cool
17:32:55 <geppetto> #topic #469 	Unified bootstrapping
17:33:03 <geppetto> https://fedorahosted.org/fpc/ticket/469
17:33:15 <geppetto> Looks like there was a quick update to this, just after we passed it
17:33:23 <tibbs|w> Oh, nice.
17:33:59 <tibbs|w> I wonder if we shouldn't consider just making dist mandatory everywhere.
17:34:08 <tibbs|w> Not having it just causes problems.
17:34:27 <geppetto> yeh, it was before my time … anyone know why we let people not have it?
17:34:50 <mbooth> I have noticed packages without it, but I have never understood why either
17:35:06 <tibbs|w> There were a couple of recalcitrant maintainers.
17:35:38 <geppetto> tibbs|w: Do you remember what their reasons were … or was it just "I don't want to"?
17:35:42 <tibbs|w> The latter.
17:35:46 <geppetto> nice
17:35:55 <tibbs|w> Let me check real quick.
17:36:51 <tibbs|w> So rawhide has 57 packages with no dist tag.
17:37:12 <tibbs|w> ls */^*fc*
17:37:26 <geppetto> fancy :)
17:37:45 <tibbs|w> People still don't use zsh?
17:38:08 <tibbs|w> http://fpaste.org/156678/14177146/
17:38:17 <geppetto> I think bash does the expands now too
17:38:45 <tibbs|w> Nothing in there that couldn't be fixed or perhaps doesn't have a good reason.
17:39:32 <tibbs|w> And we wouldn't retroactively apply it anyway.
17:40:17 <tibbs|w> Personally I'd be for making dist a must, but in the meantime I'm +1 on the unified bootstrapping tweak.
17:40:21 <racor> geppetto: Commonly people not wanting to use %dist, believe in "cross-distro/release" re-usability of rpms.
17:40:24 <geppetto> Hmm … the fedora-release packages are interesting
17:41:08 <geppetto> sgallagh: ping
17:41:19 <sgallagh> geppetto: pong
17:41:35 <geppetto> sgallagh: ^ … do you know why the release packages don't use dist?
17:41:55 <geppetto> and the repos ones, I guess
17:41:58 <tibbs|w> There's no reason for them to do so, since their version is tied to the distro version.
17:42:15 <tibbs|w> It seems a reasonable exception, and I wouldn't write it into the guidelines anyway.
17:42:17 <sgallagh> geppetto: I have no idea. Those are pretty much dgilmore exclusives
17:42:35 <tibbs|w> Oh, I remember now.
17:42:47 <tibbs|w> There was a time when we didn't use different signing keys for different fedora versions.
17:42:56 <racor> Guess, once rpm's payload format changes or the architecture CFLAGS change, they will learn they are in error.
17:43:05 <tibbs|w> So it was possible to have one package that worked for multiple distro version.
17:43:21 <geppetto> yeh … but did we allow you to do a single build?
17:43:22 <tibbs|w> This was for things like huge data files that were noarch and not compiled in any way.
17:43:28 <geppetto> ahh
17:43:33 <tibbs|w> We did, but it was hacky and way before koji.
17:43:47 <tibbs|w> Currently it is entirely pointless.
17:43:58 <geppetto> ok, so I'm happy to +1 requiring dist for all new builds
17:44:10 <tibbs|w> That explains why torcs-data doesn't use dist, BTW.
17:44:16 <tomspur> +1 here also
17:44:17 <geppetto> with the possible exception of fedora-release* and fedora-repos*
17:44:51 <tibbs|w> I don't think we would hardcode an exception for those in the guidelines, just comment it in those specs.
17:44:59 <racor> geppetto: They will also break once rpm changes its internals - We've had this once in Fedora's history ;)
17:45:00 <tibbs|w> It's not like existing packages would have to change anyway.
17:45:02 * geppetto nods … that seems fine
17:45:08 <tibbs|w> racor: At least once.
17:45:42 <tibbs|w> Anyway, if we're voting, +1.  If we need a draft, I will cook one up for next week.
17:45:52 <geppetto> racor limburgher mbooth Rathann: You want to vote?
17:46:09 <geppetto> I'm fine with you just adding it somewhere … it's only gotta be a couple of words, right?
17:46:28 <limburgher> Sorry, afk, reading. . .
17:46:35 <racor> tibbs|w: I recall rpm having changed it's checksums from md5 to sha254. As consequence of this sharing fedora rpms with older CentOSs is impossible.
17:46:44 <racor> +1 to enforcing %dist
17:46:49 <limburgher> +1
17:47:03 <mbooth> +1
17:47:07 <geppetto> yeh, rhel5 rpm needs md5 options to build rpms
17:47:22 <geppetto> tibbs|w: Ok, looks like you win
17:47:53 <tibbs|w> racor: that was indeed the case.
17:47:58 <geppetto> #action tibbs|w Make dist mandatory for all packages. (+1:5, 0:0, -1:0)
17:48:12 <tibbs|w> Sorry, folks, I have to run.  Will write that up in a bit.
17:48:14 <Rathann> +1 from me as well
17:48:29 <geppetto> #undo
17:48:29 <zodbot> Removing item from minutes: ACTION by geppetto at 17:47:58 : tibbs|w Make dist mandatory for all packages. (+1:5, 0:0, -1:0)
17:48:31 <geppetto> #action tibbs|w Make dist mandatory for all packages. (+1:6, 0:0, -1:0)
17:48:38 <geppetto> Ok
17:48:49 <geppetto> #topic Open Floor
17:49:07 <geppetto> If nobody says antyhing I'll close in a minute
17:49:15 <limburgher> Nothing here.
17:50:31 <geppetto> #endmeeting